精华内容
下载资源
问答
  • 不同网段同一个vlan
    千次阅读
    2020-12-24 12:26:35

    展开全部

    可以。

    如果你的S55是EI的可以在62616964757a686964616fe58685e5aeb931333365646332三层交换机上做dhcp server 。全局地址池模式。

    如下:

    dhcp server ip-pool 1

    network 192.168.1.0 mask 255.255.255.0

    gateway-list 192.168.1.1

    dns-list 219.148.204.66 219.149.6.99

    domain-name office

    把要分配地址的全创建上就可以。能够根据vlan自动分配的。

    如果你的S55是SI,是不支持server的。你的路由也应该是H3C的吧,在路由上启server,S55启中继。

    路由上正常创建地址池。

    主要是S55的配置。

    如下:

    dhcp-server 0 ip 192.168.100.1 这个地址是路由接S55的接口地址。

    dhcp relay information enable

    interface Vlan-interface10

    ip address 192.168.10.1 255.255.255.0

    dhcp-server 0

    interface Vlan-interface20

    ip address 192.168.20.1 255.255.255.0

    dhcp-server 0

    interface Vlan-interface30

    ip address 192.168.30.1 255.255.255.0

    dhcp-server 0

    更多相关内容
  • 不同VLAN不同网段互相访问,主机能够互相ping通-华为s5700 3700 用华为ensp模拟器模拟
  • 不同网段的设备之间如何互访?有朋友提到关于交换机如何实现不同网段的互访?这交换机完全可以实现,在实际项目中,交换机实现不同网段的互访用的也比较多,那么今天我们一起来看下。
  • 交换机和路由器实现不同网段划分、不同vlan之间的通信、指定组合vlan进行网络通信。 推荐一个画图非常好用的在线免费工具:https://www.processon.com/i/5f58a647e658155997003a46 、网络需求举例 1、假设有A、B、...

    交换机和路由器实现不同网段划分、不同vlan之间的通信、指定组合vlan进行网络通信。

    推荐一个画图非常好用的在线免费工具:https://www.processon.com/i/5f58a647e658155997003a46

    一、网络需求举例

    1、假设有A、B、C三台PC,要分别在不同的网段,要实现A与B通信、A与C通信、B与C不能通信;

    在这里插入图片描述

    –交换机:

    Switch>enable
    Switch#configure terminal
    Switch(config)#hostname sw1
    sw1(config)#vlan 10
    sw1(config-vlan)#vlan 20
    sw1(config-vlan)#exit
    sw1(config)#interface range fastEthernet 0/1,f0/4
    sw1(config-if-range)#switchport mode access
    sw1(config-if-range)#switchport access vlan 10
    sw1(config-if-range)#exit
    sw1(config)#interface range fastEthernet 0/2,f0/3
    sw1(config-if-range)#switchport mode access
    sw1(config-if-range)#switchport access vlan 20
    sw1(config-if-range)#end
    

    华为交换机示例:

    要配置 VLAN,首先要先创建 VLAN,然后才把交换机的端口划分到特定的端口上:

    (1) 步骤 1:在划分 VLAN 前,配置 R1 和 R2 路由器的 g0/0 接口,从 R1 ping 192.168.12.2。

    默认时,交换机的全部接口都在 VLAN1 上,R1 和 R2 应该能够通信;

    (2) 步骤 2:在 S1 上创建 VLAN

    S1# vlan database

    //进入到 VLAN 配置模式

    S1(vlan)# vlan 2 name VLAN2

    VLAN 2 added:

    Name: VLAN2

    //以上创建 vlan,2 就是 vlan 的编号,VLAN 号的范围为 1~1001,VLAN2 是该 VLAN 的名字:

    S1(vlan)# vlan 3 name VLAN3

    VLAN 3 added:

    Name: VLAN3

    S1(vlan)# exit

    APPLY completed.

    Exiting…

    //退出VLAN模式,创建的VLAN立即生效:

    【 提示】交换机中的 VLAN 信息存放在单独的文件中 flash:vlan.dat,因此如果要完全清除

    交换机的配置,除了使用“ erase starting-config”命令外,还要使用“delete

    flash:vlan.dat

    delete

    flash:vlan.dat”命令把 VLAN 数据删除。

    【提示】新的 IOS 版本中,可以在全局配置模式中创建 VLAN,如下:

    S1(config)# vlan 2

    S1(config-vlan)# name VLAN2

    S1(config-vlan)# exit

    S1(config)# vlan 3

    S1(config-vlan)# name VLAN3

    (3) 步骤 3:把端口划分在 VLAN 中

    S1(config)# interface f0/1

    S1(config-if)# switch mode access

    //以上把交换机端口的模式改为 access 模式,说明该端口是用于连接计算机的,而不是用

    于 trunk

    S1(config-if)# switch access vlan 2

    //然后把该端口 f0/1 划分到 VLAN 2 中

    S1(config)# interface f0/2

    S1(config-if)# switch mode access

    S1(config-if)# switch access vlan 3

    【提示】默认时,所有交换机接口都在 VLAN 1 上,VLAN 1 是不能删除的。如果有多个接口

    需要划分到同一 VLAN 下,也可以采用如下方式以节约时间,注意破折号前后的空格:

    S1(config)# interface range f0/2 -3

    S1(config-if)# switch mode access

    S1(config-if)#switch access vlan 2

    【提示】

    switch access vlan 2

    【提示】如果要删除VLAN,使用 “ no vlan 2”命令即可。删除某一VLAN后,要记得把该VLAN

    上的端口重新划分到别的VLAN上,否则将导致端口的“消失”。

    调试

    (1) 查看 VLAN

    使用“ show vlan”或者“ show vlan brief”命令可以查看 VLAN 的信息,以及每个

    VLAN 上有什么端口。要注意这里只能看到的是本交换机上哪个端口在 VLAN 上,而不能看到

    其他交换机的端口在什么 VLAN 上。如下:

    SW1# show vlan

    VLAN Name Status Ports


    1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4

    Fa0/5, Fa0/6, Fa0/7, Fa0/8

    Fa0/9, Fa0/10, Fa0/11, Fa0/12

    Fa0/13, Fa0/14, Fa0/16, Fa0/17

    Fa0/18, Fa0/19, Fa0/20, Fa0/21

    Fa0/22, Fa0/23, Fa0/24, Gi0/1

    Gi0/2

    2 VLAN2 active

    3 VLAN3 active

    2 VLAN2 active

    3 VLAN3 active

    1002 fddi-default act/unsup

    1003 token-ring-default act/unsup

    1004 fddinet-default act/unsup

    //在交换上,VLAN1是默认VLAN,不能删除,也不能改名。此外还有1002、1003等VLAN的存

    在。

    (2) VLAN 间的通信

    由于 f0/1 和 f0/2 属于不同的 VLAN,从 R1 ping 192.168.12.2 不能成功了。


    2、实际组网例子实现
    在这里插入图片描述

    设置交换机端口trunk和access的区别:端口接收数据时不同、端口发送数据时不同。

    1、端口接收数据时不同:

    trunk:如果接收的数据包本身不包含VLAN信息的话,那么该数据包将会加上该缺省VLAN的信息;如果接收的数据包本身已经包含了VLAN信息,那么将不再添加。

    access:无论接收的数据包是否已经含有VLAN信息,全部都要加上该缺省VLAN信息。

    2、端口发送数据时不同:

    trunk:如果发送的数据包所含的VLAN与端口缺省的VLAN相同,那么就会把VLAN信息从该数据包中去掉;如果两者不相同,该数据包将带着原有VLAN信息一起发送出去。

    access:无论端口缺省VLAN是否等于输出的数据包中的VLAN,都会将VLAN信息从该数据包中去掉。

    coding:

    # 1、进入交换机1,创建 vlan2、vlan3、vlan100
    vlan 2
    q
    vlan 3
    q
    vlan 100
    q
    
    # 2、进入端口,配置端口模式,加入vlan
    interface g0/0/1
    port link-type hybrid
    port hybrid pvid vlan 2
    
    interface g0/0/2
    port link-type hybrid
    port hybrid pvid vlan 3
    
    # 3、进入交换机2,创建vlan100
    vlan 100
    q
    
    interface g0/0/2
    port link-type hybrid
    port hybrid pvid vlan 50
    
    vlan 5
    q
    vlan 10
    q
    
    # 4、给交换机1打标签
    interface g0/0/3
    port link-type hybrid
    port hybrid tagged vlan 2 3 100
    q
    
    interface g0/0/1
    port hybrid untagged vlan 2 100
    q
    
    interface g0/0/2
    port hybrid untagged vlan 3 100
    q
    
    save
    
    # 5、给交换机2打标签
    interface g0/0/1
    port link-type hybrid
    port hybrid tagged vlan 2 3 100
    q
    
    interface g0/0/2
    port hybrid untagged vlan 2 3 100
    q
    
    save
    
    # 6、保存后,分别断电后重启
    display vlan
    


    vlan的3种划分方法:

    端口类型

    在学习划分vlan前,必须要了解华为交换机的端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面的vlan划分会用到。

    1、Access类型端口

    执行命令port default vlan vlan-id,将端口加入到指定的VLAN中。

    Access类型端口只能属于1个VLAN,一般用于连接计算机端口;

    2、Trunk类型端口

    Trunk类型端口可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    3、Hybrid类型端口

    – 选择执行其中一个步骤配置Hybrid端口加入VLAN的方式:Hybrid类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文。

    我们前面曾说到,关于vlan的划分方法有很多,项目应用中较多的方法就是基于 端口划分vlan 、 基于mac地址划分vlan 、 基于ip地址划分vlan ,要真正对vlan了解,必须熟悉这三种划分方法,以便于根据实际项目进行应用。

    一、基于端口的vlan划分方法

    这里面为了方便大家理解,直接用实例讲解更清楚。

    1、组网需求

    如图1所示,某企业的交换机连接有很多用户,且相同业务用户通过不同的设备接入企业网络。为了通信的安全性,也为了避免广播报文泛滥,企业希望业务相同用户之间可以互相访问,业务不同用户不能直接访问。

    可以在交换机上配置基于端口划分VLAN,把业务相同的用户连接的端口划分到同一VLAN。

    也就是不同VLAN的用户不能直接进行二层通信,同一VLAN内的用户可以直接互相通信。
    在这里插入图片描述
    2、配置步骤

    步骤1 在SwitchA创建VLAN2和VLAN3,并将连接用户的端口分别加入VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [ Quidway] system-view //进入配置视图

    [Quidway] sysname SwitchA //给交换机命名

    [SwitchA] vlan batch 2 3 //同时创建vlan2与vlan3

    [SwitchA] interface ethernet 0/0/1 //进入端口0/0/1

    [SwitchA-Ethernet0/0/1] port link-type access //设置端口模式为access

    [SwitchA-Ethernet0/0/1] port default vlan 2 //将端口加入vlan2中

    [SwitchA-Ethernet0/0/1] quit //退出

    [SwitchA] interface ethernet 0/0/2 //进入端口0/0/2

    [SwitchA-Ethernet0/0/2] port link-type access //端口模式为access

    [SwitchA-Ethernet0/0/2] port default vlan 3 //将端口加入vlan3中

    [SwitchA-Ethernet0/0/2] quit //退出

    步骤2 配置SwitchA上与SwitchB连接的端口类型及通过的VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interface ethernet 0/0/3 // 进入端口0/0/3

    [SwitchA-Ethernet0/0/3] port link-type trunk //设置端口模式为trunk

    [SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3 // trunk口允许通过vlan2与vlan3的数据包

    步骤3 验证配置结果将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。

    User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。

    二、基于MAC地址vlan划分方法

    1、组网需求

    某个公司的网络中,网络管理者将同一部门的员工划分到同一VLAN。为了提高部门内的信息安全,要求只有本部门员工的PC才可以访问公司网络。

    如图2所示,PC1、PC2、PC3为本部门员工的PC,要求这几台PC可以通过SwitchA、Switch访问公司网络,如换成其他PC则不能访问。可以配置基于MAC地址划分VLAN,将本部门员工PC的MAC地址与VLAN绑定,从而实现该需求。

    在这里插入图片描述
    2、操作步骤

    和上面一样,可以验证下,经过上面的理解,是否能认识下面的配置代码。

    步骤1 配置Switch

    #创建VLAN

    [Quidway] system-view

    [Quidway] vlan batch 10 100

    #配置接口的PVID和加入VLAN

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] port hybrid pvid vlan 100 //将接口以加入到vlan100

    [Quidway-Ethernet0/0/1] port hybrid untagged vlan 10 //untagged是指当数据离开端口时脱掉标签,指定端口允许VLAN 10的数据帧通过,且发送时不带VLAN标签

    [Quidway-Ethernet0/0/1] quit #退出

    [Quidway] interface ethernet 0/0/2 #进入端口0/0/2

    [Quidway-Ethernet0/0/2] port hybrid tagged vlan 10 //tagged是指当数据离开端口时带着标签,指定允许VLAN 10的数据帧通过,且发送时必须带有VLAN标签

    [Quidway-Ethernet0/0/2] quit

    #PC的MAC地址与VLAN10关联

    [Quidway] vlan 10

    [Quidway-Vlan10] mac-vlan mac-address 22-22-22

    //关联pc1的mac地址

    [Quidway-Vlan10] mac-vlan mac-address 33-33-33

    //关联pc2的mac地址

    [Quidway-Vlan10] mac-vlan mac-address 44-44-44

    //关联pc3的mac地址

    [Quidway-Vlan10] quit

    #使能接口的基于MAC地址划分VLAN功能

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] mac-vlan enable

    //起动端口的mac-vlan功能

    [Quidway-Ethernet0/0/1] quit

    三、基于IP子网的vlan划分

    1、组网需求

    某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的IP地址网段各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

    如图3所示,Switch接收到用户报文有数据、IPTV、语音等多种业务,用户设备的IP地址网段各不相同。现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLANID分流到不同的远端服务器上以实现业务互通。

    这类在实际应用中是比较多的。

    在这里插入图片描述
    2、配置思路

    采用如下的思路配置基于IP子网划分VLAN:

    a、创建VLAN,确定每种业务所属的VLAN。

    b、关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。

    c、配置端口加入VLAN,实现基于IP子网的VLAN通过当前端口。

    d、配置VLAN划分方式的优先级,确保优先选择基于IP子网划分VLAN。

    e、使能基于IP子网划分VLAN。

    3、操作步骤

    步骤1 创建VLAN

    #在Switch上创建VLAN100、VLAN200和VLAN300。

    [Quidway] system-view

    [Quidway] vlan batch 100 200 300

    步骤2 配置接口

    #在Switch上配置接口Eth0/0/1为Hybrid类型,并加入VLAN100、VLAN200和VLAN300。

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] port link-type hybrid //设置端口为hybrid模式

    [Quidway-Ethernet0/0/1] port hybrid untagged vlan100 200 300 //指定端口允许VLAN 100、vlan200、vlan300的数据帧通过,且发送时不带VLAN标签

    [Quidway-Ethernet0/0/1] quit

    #在Switch上配置接口Eth0/0/2加入VLAN100。

    [Quidway] interface ethernet 0/0/2

    [Quidway-Ethernet0/0/2] port link-type trunk

    [Quidway-Ethernet0/0/2] port trunk allow-pass vlan 100 //接口0/0/2加入vlan100

    [Quidway-Ethernet0/0/2] quit

    #在Switch上配置接口Eth0/0/3加入VLAN200。

    [Quidway] interface ethernet 0/0/3

    [Quidway-Ethernet0/0/3] port link-type trunk

    [Quidway-Ethernet0/0/3] port trunk allow-pass vlan 200 //接口0/0/3加入vlan200

    [Quidway-Ethernet0/0/3] quit

    #在Switch上配置接口Eth0/0/4加入VLAN300。

    [Quidway] interface ethernet 0/0/4

    [Quidway-Ethernet0/0/4] port link-type trunk

    [Quidway-Ethernet0/0/4] port trunk allow-pass vlan 300 //接口0/0/4加入vlan300

    [Quidway-Ethernet0/0/4] quit

    #在Switch上配置接口Eth0/0/1使能基于IP子网划分VLAN功能。

    [Quidway] interface ethernet 0/0/1

    [Quidway-Ethernet0/0/1] ip-subnet-vlan enable

    [Quidway-Ethernet0/0/1] quit

    步骤3 配置基于IP子网划分VLAN

    #在Switch上配置VLAN100与IP地址192.168.1.2/24关联,优先级为2。

    [Quidway] vlan 100

    [Quidway-vlan100] ip-subnet-vlan 100 ip 192.168.1.2 24 priority 2

    [Quidway-vlan100] quit

    #在Switch上配置VLAN200与IP地址192.168.2.2/24关联,优先级为3。

    [Quidway] vlan 200

    [Quidw ay-vlan200] ip-subnet-vlan 200 ip 192.168.2.2 24 priority 3

    [Quidway-vlan200] quit

    #在Switch上配置VLAN300与IP地址192.168.3.2/24关联,优先级为4。

    [Quidway] vlan 300

    [Quidway-vlan300] ip-subnet-vlan 300 ip 192.168.3.2 24 priority 4

    [Quidway-vlan300] quit

    步骤4 验证配置结果

    在Switch上执行以下命令,显示信息如下:

    [Quidway] display ip-subnet-vlan vlan all


    Vlan Index IpAddress SubnetMask Priority


    100 1 192.168.1.2 255.255.255.0 2

    200 1 192.168.2.2 255.255.255.0 3

    300 1 192.168.3.2 255.255.255.0 4


    ip-subnet-vlan count: 3 total count: 3

    即为组网配置成功。


    展开全文
  • 最近上网看帖子,发现这个VLAN网段之间很纠结。我想阐明一下;相同VLAN相同网段,相同VLAN不同网段不同VLAN相同网段不同VLAN不同网段,有这四种情况!首先大家要明白host发包的机制:Host们在将包发送到不同的...

    最近上网看帖子,发现这个

    VLAN

    、网段之间很纠结。

    我想阐明一下;

    相同

    VLAN

    相同网段

    相同

    VLAN

    不同网段

    不同

    VLAN

    相同网段

    不同

    VLAN

    不同网段

    ,有这四种情况!

    首先大家要明白

    host

    发包的机制:

    Host

    们在将包发送到不同的网段的主机时的机制是这样的:

    host

    会将目的地址与子网掩码

    进行与运算(

    1^1=1

    剩下的都是

    0

    )

    ,得到的结果是

    host

    发现目的地址与自己不再同一网段,

    所以

    host

    要查看它有没有默认网关的

    MAC

    地址,没有的话就需要用配置好的网关的

    IP

    址来进行

    ARP

    请求了,得到

    MAC

    地址后,

    host

    就将数据包发送到网关别的什么都不管了。

    交换机的转发机制:

    如果它从某个端口收到数据包,它会向相同的

    VLAN

    端口去转发,或者向允许这个

    VLAN

    通过的

    TRUNK

    端口去转发。

    情况

    1.

    相同

    VLAN

    ,相同网段

    这个二层就能通信的,

    三层不能通信,

    所以同一交换机下或跨交换机能通信,

    但不能跨路由

    器通信,为什么呢?

    因为首先网段相同,所以

    host

    会进行

    ARP

    查询寻找目的地址的

    MAC

    地址,这个时候

    SW

    会先看看都有哪些端口和

    host

    是同一个

    VLAN

    的,然后转发泛洪,

    host

    会得到目的地址的

    MAC

    地址的。所以可以进行通信。但是三层不能通信,因为路由器不允许它的任意两个接

    口配置到同一个网段中。

    情况

    2.

    相同

    VLAN

    ,不同网段

    这个二层不能通信,

    三层可以通信的,

    所以同一交换机下或跨交换机不能通信,

    但能跨路由

    器通信,为什么呢?

    我们再来重复上面的步骤,首先网段是不同的,所以

    host

    会将数据包发送给网关,然后静

    候佳音,

    而网关发现这个网段需要路由就开始查找路由表,

    网关肯定找不到这个网段也就无

    法路由,

    丢包。

    网关为什么不能找到这个网段呢,

    因为一个路由器上的端口如果不配置子接

    口或者从地址的话是不能配置两个网段的。

    但是如果是两个交换机分别接到路由器的两个接

    口上就可以了,因为是通过三层路由转发,而二层的

    VLAN

    允许同

    VLAN

    端口间的

    ARP

    请求,所以这个要看网络拓扑。

    情况

    3.

    不同

    VLAN

    ,相同网段

    这个二层三层都不可能实现通信,

    所以同一交换机下或跨交换机不能通信,

    也不能跨路由器

    通信,为什么呢?

    首先,不同

    VLAN

    就意味着不能通过二层通信,而同网段就意味着路由器的两个接口要配

    置为同一个网段,但是这个根本就不符合路由器的配置规范。

    情况

    4.

    不同

    VLAN

    ,不同网段

    这个二层不能通信,

    但是三层可以通信,

    所以同一交换机下或跨交换机不能通信,

    但能跨路

    由器通信,为什么呢?

    不同的

    VLAN

    意味着不能通过二层通信,而不同网段却可以通过路由器路由转发。

    2015.4.25

    日——

    sniffer

    展开全文
  • 同一个vlan同一个网段的ip地址能够直接互通,那么同一个vlan不同网段能不能互通呢?现在小编分享篇文章,可以解决大家在网络中遇到的一些奇怪的问题,同时加深对网络的理解。 同vlan不同网段能否互通今天小编...

    原标题:同一个vlan不同的网段能不能互通?

    同一个vlan同一个网段的ip地址能够直接互通,那么同一个vlan不同的网段能不能互通呢?现在小编分享一篇文章,可以解决大家在网络中遇到的一些奇怪的问题,同时加深对网络的理解。

    一、同vlan不同网段能否互通

    今天小编用几个实例来细说下同vlan不同网段互通的问题。

    实例一:

    现在有两台电脑,他们同处于一个vlan,

    l pcA IP地址:10.1.1.1/8

    l pcB ip地址:11.1.1.1/8

    1. 无网关,A ping B

    报出的Destination host unreachable

    显然,A机器发现对方与自己不是同一网段,试图寻找网关,但网关不存在,所以报主机不可达,B上的Sniffer未抓到任何包,观察网卡也是只发不收,显然数据没有出去。

    2. 网关设成对方IP,A ping B

    能正常PING通,为什么能通?

    从A计算机Sniffer上抓到的包可以看出,A在PING对方过程中,A首先进行了ARP广播,它广播询问11.1.1.1的MAC是什么。

    显然这个ARP广播是可以被B收到的(因为他们同处一个vlan),而11.1.1.1正好就是B的IP地址,理所当然B要回应这个ARP请求。下图是A上的抓包情况,A首先进行了ARP广播,然后收到了B的应答。

    这样A就有了B的MAC,而B在接到A的ARP广播时候就学到A的MAC,所以双方可以PING通。

    3. 网关设成自己,A ping B

    一样是可以ping的通的,A上抓包如下:

    抓到的结果与第2种情况一样,A依然是先广播询问11.1.1.1的MAC,这个ARP广播被B接到后,B有义务应答,于是双方知道对方MAC,所以能PING通。

    与第2种情况不同的是,这里可以明确知道ARP中的11.1.1.1指的是PING中所指定的IP地址而不是网关(此时A网关是10.1.1.1了),那么第2种情况中的11.1.1.1也指的是PING中所指定的IP ?我们再来看下面。

    二、ping三个不存的ip地址,深入了解网络通信原理

    网关设成自己,PING 3个不存在的IP:

    l 一个是和自己在同一网段的;

    l 一个是和网关在同一网段的;

    l 一个是和谁都不在同一网段的;

    1. PING和自己同一网段的IP,PING返回超时,在B上抓包结果如下:

    可以看出,A发出了询问10.1.1.2的ARP广播而不是询问网关(10.1.1.1)的广播,由于这个IP不存在,所以没有机器做出回应。

    2. PING和网关同一网段的IP。

    超时,B上接到的是A发出的关于11.1.1.2的ARP广播,由于不存在11.1.1.2这个地址,所以没有机器回应。

    3. PING和谁都不在一个网段的IP

    超时,B上接到是A发出的关于100.1.1.1的ARP广播,由于不存在100.1.1.1这个地址,所以没有机器回应。

    从上面的3个实验来看,当网关设置成自己的时候,不管PING的地址是什么,计算机发出的ARP广播都是直接询问PING中所指定IP对应的MAC,没有询问网关的MAC,这符合卷一上的描述,其实计算机在广播询问PING命令指定的IP之前还是会先问网关的MAC的,只是这里由于网关是自己所以这一步就被跳过了。

    那到底是不是这样的呢?我们再验证下。

    三、A计算机网关设置中B的ip,B的网关设置中不存在的ip地址

    A计算机网关设成B的IP地址,但B的网关设置成一个不存在的IP(且与A/B都不在同一网络),PING三种情况。

    1. PING与网关同一网段IP,在A上抓包,可以看到A首先发出了关于网关11.1.1.1的ARP广播请求(对应B接到这个广播请求),B对这个11.1.1.1进行了ARP应答.但这个IP是不存在的所以PING结果超时。

    2. PING与谁都不在同一网段,超时,结果类似5.2结果,A发出了关于网关11.1.1.1的请求,B做了应答.但PING是超时的.

    3. PING计算机B的地址,结果超时,为什么这个也不通呢?按说按照上面的测试,AB计算机都能获得对方MAC,以太网下,有MAC应该就有通信的可能,可这个时候却不通,查看Sniffer抓到的包可以发现:

    A发出了关于11.1.1.1的ARP广播请求,B对11.1.1.1做出应答,但是下面接到了多个B发来的关于100.1.1.1的ARP广播请求,且100.1.1.1的请求没有得到B的应答,看来B是一直在试图查询B的网关(100.1.1.1)所对应的MAC,在网关的MAC没有获得应答之前,B不会对PING产生回应。

    从上面的所有实验看出,计算机在与非本网段的地址通信时,计算机首先查找网关的MAC,如果网关MAC得不到回应,是不会对PING作出响应的;因此,实例一中1和2的情况是属于特殊情况,正好利用了网关与主机IP相同,骗过了计算机.如果AB的网关都设置的与AB ip毫不相干的话,相互肯定不通。返回搜狐,查看更多

    责任编辑:

    展开全文
  • 华为设备配置通过VLANIF实现同VLAN不同网段通信
  • 交换机的三层接口可配置多IP地址,即一个主IP地址,其余均为从IP地址,至多配置255从IP地址。 网络拓扑 基本配置 LSW1 [LSW1]interface Vlanif 1 [LSW1-Vlanif1]ip address 10.0.0.254 24 [LSW1-Vlanif1...
  • 同一个vlan同一个网段的ip地址能够直接互通,那么同一个vlan不同网段能不能互通呢?本期我们推荐篇文章,可以解决大家在网络中遇到的一些奇怪的问题,也是加深对网络的理解。 同VLAN不同网段能否Ping通 ...
  • 在同一网段划分不同VLAN

    千次阅读 2020-03-17 23:56:58
    1.在不同网段划分vlan,与在同一网段划分vlan的区别? 划分VLAN其IP地址可能是在一个网段内,其主要作用是为了防止网络风暴 2.设置vlan与设置不同网段有什么区别? 通过交换机划分2个VLAN 与 在IP上设置2个不同的...
  • 同网段不同vlan相同网关组网

    千次阅读 2021-03-31 10:36:06
    同网段不同vlan用相同网关组网 、网络拓扑图 二、网络设备配置 1.LSW1配置文件 sysname Huawei vlan batch 100 200 300 cluster enable ntdp enable ndp enable drop illegal-mac alarm diffserv domain ...
  • 1、利用路由器子接口实现不同vlan网段的通信 2、利用三层交换机vlanif接口实现不同网段之间的通信 三、配置信息 拓扑(1) 【S1】 (1)创建vlan (2)0/0/1、0/0/2、0/0/4端口配置为access类型并在端口加入相应...
  • VLAN Mapping实现同一网段不同VLAN的主机通信
  • PC-10和PC-30是不同网段下,同一VLAN里的两台PC,现在想将其ping通 1. 两PC都不设置网关 PC-10-1 ip:192.168.10.11 子网:255.255.255.0 网关:.0.0.0.0 PC-30-1 ip:192.168.30.13 子网:255.255.255.0 网关...
  • PC1访问PC2,判断目标是否同网段;PC1发出针对PC2的ARP请求,因为vlan的隔离效果,这ARP请求是无法到达PC2的,最多只能到达交换机的vlanif 10;交换机的vlanif 10开启了代理arp,所谓的代理arp,就是可以代替其他...
  • 同VLAN不同网段能否ping通

    千次阅读 2021-01-25 21:13:33
    同一个vlan同一个网段的ip地址能够直接互通,那么同一个vlan不同网段能不能互通呢?本期我们推荐篇文章,可以解决大家在网络中遇到的一些奇怪的问题,也是加深对网络的理解。 同VLAN不同网段能否Ping通 前面我们...
  • 我们可以看到,采用这种方法实现不同网段不同vlan之间的互访需要为每一个vlan创建条物理链路,每个vlan会占用一个路由器接口,当交换机上的vlan数量增加时,就会产生路由器接口不足的情况,而且,有的vlan之间通信...
  • 主要介绍了跨网段监控软件、如何跨网段监控、交换机多vlan上网管理控制软件的选择,需要的朋友可以参考下
  • DHCP中继配置,给不同网段个vlan分配IP** 交换机做 System-view Sysname SW 交换机改名字 [SW] Vlan batch 10 20 创建vlan 10与20 Int g0/0/01 port link-type access 该端口改为access类型 Port default vlan 10...
  • 网段是三层62616964757a686964616fe4b893e5b19e31333431366263概念,是对IP地址的划分,不同网段之间必须通过三层设备访问,因为在寻址过程中,第步就是判断是否位于同一网段,如果是则直接交付,否则发送给默认...
  • 实现不同网段vlan互访

    千次阅读 2020-09-23 12:41:59
    标题实现不同网段vlan互访## 实验拓扑: 【实验过程】 .二层设备依据拓扑创建vlan,实现vlan互访。 1.sw1创建vlan100、vlan200 2.将接口加入相应的vlan。 验证: 二、实现跨交换机相同vlan互访。 1.sw1、...
  • 我会通过系列场景,给大家分析一下网络通信的原理,但是三种方式内容太多,所以今天就先给大家讲讲纯二层网络下,如何实现同网段不同vlan通信,后续再给大家分享另外两种方式。 拓扑如图,pc1属于vlan10,pc2...
  • 1、纯二层网络,如何实现同网段不同vlan通信? 2、通过代理ARP,如何实现同网段不同vlan通信? 3、Vxlan架构,如何实现同网段不同vlan通信? 关于纯二层网络下和代理ARP如何实现同网段不同vlan通信,之前给大家...
  • 同网段交换机,不同vlan间通信

    千次阅读 2020-02-28 17:44:10
    默认情况下,接口的类型都是Access、Trunk类型,并且PVID都是1,默认允许vlan 1的帧进行通过的,所以,主机A到达SW1G0/0/1的时候,是会打上pvid为1的帧,然后从G0/0/2发送出去的时候是不带tag的,到达SW2的G0/0/2...
  • 1.1 交换机接入三台PC, 分别属于vlan100 vlan2 vlan31.2 对应IP: 1.1.1.1、1.1.1.2、1.1.1.3 掩码:255.255.255.0 属于同网段不同VLAN二、配置要求2.1 PC1(vlan100) 可以与 PC2(vlan2) PC3(vlan3) 之间通讯2.2 ...
  • 同网段VLAN隔离

    2022-03-17 15:08:00
    小型企业实现不同部门同网段IP之间的隔离,相同部门同网段之间互通
  • 交换机互联不同vlan不同网段通信问题总结.pdf
  • ensp模拟交换机不同VLAN不同网段之间互通
  • 同一网段不同VLAN的结果(实验)

    千次阅读 2019-10-20 17:35:56
    首先我们先来做一个简单的拓扑图: 现在我们暂时先不划分VLAN,先将pc配上ip查看是否互联互通 我们查看到,未划分VLAN之前,3台主机之间时互通的,现在我们来划分到不同VLAN当中 我们需要打开交换机,创建vlan...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 31,361
精华内容 12,544
关键字:

不同网段同一个vlan

友情链接: qsqlmysql.zip