精华内容
下载资源
问答
  • 不同网段访问,比如要实现1网段和2网段之间能互通,有台服务器IP是192.168.1.2,不能给2网段(192.168.2.3)ping通 可以给这个192.168.1.2服务器,附加一个2网段的ip地址,然后2网段的就能ping通它了 比如我这里:...

    不同网段的访问,比如要实现1网段和2网段之间能互通,有台服务器IP是192.168.1.250,不能给2网段(比如192.168.2.11)ping通

    可以给这个192.168.1.250服务器,附加一个2网段的ip地址,然后2网段的就能ping通它了

    比如我这里:ip地址是192.168.1.250的设备ping不通192.168.11.119,所以给它附加一个11网段的设备ip地址,比如192.168.11.12就可以ping通了。

    通过执行ifconfig eth0:11 192.168.11.12来添加附加的ip地址,设备名称是eth0:11,然后再执行ifconfig就可以看到这个设备。

    [root@vclustersSW-ls2k-left ~]# ifconfig
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.1.250 netmask 255.255.255.0 broadcast 192.168.1.255
    ether 0a:d7:df:bf:4d:76 txqueuelen 1000 (Ethernet)
    RX packets 12537 bytes 1416668 (1.3 MiB)
    RX errors 0 dropped 131 overruns 0 frame 0
    TX packets 125 bytes 12382 (12.0 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    device interrupt 20

    eth0:11: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.11.12 netmask 255.255.255.0 broadcast 192.168.11.255
    ether 0a:d7:df:bf:4d:76 txqueuelen 1000 (Ethernet)
    device interrupt 20

    展开全文
  • Linux下如何实现不同网段之间的访问

    万次阅读 2014-10-08 16:58:37
    本实例要说明的是:实现10.0.0.0/24网段与192.168.2.0/24网段相互访问. 步骤1:查看本机IP地址 [root@localhostroot]# ifconfig eth0 Linkencap:Ethernet HWaddr 00:0C:29:A7:6E:77 inet addr:10.0.0.120Bcast:...

    本实例要说明的是:实现10.0.0.0/24网段与192.168.2.0/24网段相互访问.

    步骤1:查看本机IP地址

    [root@localhostroot]# ifconfig

    eth0 Linkencap:Ethernet HWaddr 00:0C:29:A7:6E:77

    inet addr:10.0.0.120Bcast:10.0.0.255 Mask:255.255.255.0

    UP BROADCASTRUNNING MULTICAST MTU:1500 Metric:1

    RX packets:2418errors:0 dropped:0 overruns:0 frame.:0

    TX packets:1293errors:0 dropped:0 overruns:0 carrier:0

    collisions:0txqueuelen:100

    RX bytes:1000347(976.9 Kb) TX bytes:192592 (188.0 Kb)

    Interrupt:10Base address:0x2024

    步骤2:添加路由规则

    [root@localhostroot]# route add -net 192.168.2.0/24 eth0

    步骤3:查看路由规则

    [root@localhostroot]# route

    Kernel IProuting table

    DestinationGateway Genmask Flags Metric Ref Use Iface

    10.0.0.0 * 255.255.255.0 U 0 0 0 eth0

    192.168.2.0 *255.255.255.0 U 0 0 0 eth0

    169.254.0.0 *255.255.0.0 U 0 0 0 eth0

    注:route规则中,必须同时存在两个网段,否则,一个网段的IP地址将无法访问到另一网段的IP地址。

    步骤4:检测本地机(IP:10.0.0.120)与远程机(IP:192.168.2.80)是否可互访.

    [root@localhostroot]# ping 192.168.2.80

    PING 192.168.2.80 (192.168.2.80) 56(84) bytes of data.

    64 bytes from192.168.2.80: icmp_seq=1 ttl=127 time=5.51 ms

    64 bytes from192.168.2.80: icmp_seq=2 ttl=127 time=3.17 ms

    步骤5:删除路由规则

    [root@localhostroot]# route del-net 192.168.2.0/24 eth0

    展开全文
  • 现在有一个需求,A子网和B子网处于不同网段,当网络中存在多个路由器时,要求不同路由器下属的子网可以互相通讯,同时又可以通过宽带路由器上网,这如何实现?在查阅了大量资料和参考了网上现有的解决方案下,得出...

    现在有一个需求,A子网和B子网处于不同网段,当网络中存在多个路由器时,要求不同路由器下属的子网可以互相通讯,同时又可以通过宽带路由器上网,这如何实现?在查阅了大量资料和参考了网上现有的解决方案下,得出如下解决方法,更加详细的说明,请设置静态路由不同网段互相访问参考。

    先介绍几个基本知识。

    1. 网关,简单来说就是网络中数据的关口,网关的IP地址就是具有路由功能设备的IP地址,而此类设备可以是路由器、启动路由协议的服务器或者代理服务器等。

    2. 路由就是把信息从源传输到目的地的行为,在大多数宽带路由器中,未配置静态路由的情况下,内部就存在一条默认路由,这条路由将LAN口下所有目的地不在自己局域网之内的信息包转发到WAN口指定的网关去。每个信息包在经过路由器时,路由器会检查目的IP,将它和路由表中的子网掩码做与计算,并与路由条目中的IP进行对比,相同,就按照这条路由规则转发,不相同就在检查对比下一条,如果所有的都不相同,则转发到默认路由去。

    3. 默认路由,路由器在转发时,它将所有非本网段的目的IP包都发到WAN口的网关去,由WAN口网关所指定的设备决定信息包是发到它自己连的内网还是发到外网去。

    4. 路由器隔绝广播,划分了广播域,也就是说,路由器不会转发广播数据,不同路由器之间通讯,是通过ARP协议来获得下一跳路由器的MAC地址,ARP是基于广播的,路由器只能发现一跳范围内的其他路由器设备。

    5. IPv4地址是有4段8位二进制数组成,一部分是网络位,一部分是主机位,网络位对于的子网掩码部分全为1,而主机位全为0.

     

    情景一:

    企业通过一台路由器R1上网,局域网LAN1,。因为业务需要,扩充了一台路由器R2,加入一个新的局域网段LAN2。

    要使能PC1和PC2相互通讯,需要做如下图中所说的设置。

     image

     

    一条静态路由一般由三部分组成,目的IP地址、子网掩码和下一跳地址,按照上图的分析,新建一条静态路由所包含的信息,应该有如下内容,发往目的地址192.168.1.0网段的IP包(子网掩码为255.255.255.0)的下一跳地址为192.168.0.100.具体配置位置,如果是在路由器中,以TP-Link的为例子,在路由器配置界面,有静态路由表配置:

    image

    在设置静态路由时,网关IP必须是与本路由器LAN口IP属于同一个网段。 

    如果目的IP地址是一台主机的IP地址,则子网掩码必须为255.255.255.255

     

    如果是在服务器上,可以通过命令行来配置静态路由,包括添加、删除和修改。

    image

     

    情景二:

    小区共享性宽带接入,A用户用一台宽带路由器构建了一个局域网,B用户也用一台宽带路由器构建局域网,A、B用户各自局域网之间的主机不能相互通讯。网络拓扑如下:

     image

    要想实现PC2和PC1之间的互相访问,和情景一类似,需要在内网网关中添加两条静态路由。一般的小区网关肯定是不会随便让用户配置路由的,而且这样配置后,其他网段的电脑也可以访问PC1和PC2,这样带来了安全隐患。我们可以这样设置,不在内网网关上面添加静态路由,在R1和R2上各添加一条路由,指向对象来实现R1和R3下主机的相互访问。

     

    情景三:

    既有串联也有并联,网络中有多级路由设备的环境,这种情况可以说是情景一和情景二的整合。

    类似的网络拓扑如下:

     image

    要实现PC1、PC2和PC3之间的互访,需要配置如下的静态路由:

    R1:目的地址为192.168.1.0,掩码255.255.255.0,下一跳为192.168.0.100

         目的地址为172.16.0.0,掩码255.255.0.0,下一跳为10.1.1.3

    R3:目的地址为192.168.0.0,掩码255.255.255.0,下一跳为10.1.1.2

           目的地址为192.168.1.0,掩码255.255.255.0,下一跳为10.1.1.2.

    对于路由器R3来看,它只能看到R1,而看不到R2.对于R3来说,上面两条路由,可以汇总会一条,就是

    目的地址为192.168.0.0,掩码为255.255.0.0,下一跳为10.1.1.2.这个网段包含了192.168.0.0~192.168.255.0所有的子网,这条静态路由会使所有目的IP在这个范围内的信息包,都转发给10.1.1.2路由器R1,这种,将多条子路由条目汇总成一条都包含在内的总路由条目,叫做路由汇总。

    在大型路由器上,路由表往往很长很大,采用路由汇总可以减少路由表的长度,提高路由器效率。

    路由汇总也不总是有效的,因为子网的划分是人为的,路由汇总中的其他网段可能存在其他局域网下。

    上述例子中的路由汇总,不那么精确,对于192.168.0.0和192.168.1.0,网络位相同的位数有前23位,要可以通过掩码来区分这两个网段的话,需要将掩码设置为255.255.254.0,这条改进的汇总路由表应该写成这样:

    目的地址为192.168.0.0,子网掩码为255.255.254.0,下一跳为10.1.1.2.这条汇总路由,只会包含192.168.0.0和192.168.0.1两个子网,这是一条精确路由。

    总结:在进行路由汇总时,应该经历使用精确的汇总条目,本能汇总的条目就汇总,不能精确汇总的条目就不汇总的原则,这样有助于网络以后的扩展和维护。

    作者:浩天之家

    出处: http://www.cnblogs.com/cherishui/

    本文版权归作者和博客园共有,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利.

    展开全文
  • 当所有的Router都连接在一起的时候,其中同一网段内是可以实现互相访问的,但是我们如何才能够让不同网段之间的路由也可以互相访问呢?那就是静态路由配置,可能有的朋友会问怎么不用动态路由协议呢?下面我们一起来...
  • 我们可以看到,当所有的Router都连接在一起的时候,其中同一网段内是可以实现互相访问的,但是我们如何才能够让不同网段之间的路由也可以互相访问呢?那就是静态路由配置,可能有的朋友会问怎么不用动态路由协议呢?...

    大家看到大家看到上面这个简单的拓扑了吗?我们这次的实验目的就是让这三台路由之间都可以实现通信,也就是互相之间可以ping通。

    我们可以看到,当所有的Router都连接在一起的时候,其中同一网段内是可以实现互相访问的,但是我们如何才能够让不同网段之间的路由也可以互相访问呢?那就是静态路由配置,可能有的朋友会问怎么不用动态路由协议呢?是的,当设备过多时我们当然会考虑优先使用动态路由协议来配置了,因为那样会更加方便,但咱们现在不是做实验么,以掌握技巧为主。好了,废话不多说,在下面我会写出各个路由的详细配置与说明,供大家参考学习。

    实验步骤:

    1、在SW1中新建VLAN,并将VPCS1-3加入各个VLAN:

    sw1>enable

    sw1#vlan da

    sw1(vlan)#vlan 2

    sw1(vlan)#vlan 3

    sw1(vlan)#vlan 4

    sw1(vlan)#apply

    sw1(vlan)#exit

    Sw2>enable

    Sw2#vlan da

    Sw2(vlan)#vlan 2

    Sw2(vlan)#vlan 3

    Sw2(vlan)#vlan 4

    Sw2(vlan)#apply

    Sw2(vlan)#exit

    Sw3>enable

    Sw3#vlan da

    Sw3(vlan)#vlan 3

    Sw2(vlan)#vlan 5

    Sw2(vlan)#apply

    Sw2(vlan)#exit

    -------------------------------------------------

    2、 将VPCS加入VLAN:

    Sw1>enable

    Sw1#config terminal

    Sw1(config)#interface f0/2

    Sw1(config-if)#switchport access vlan 2

    Sw1(config-if)#no shutdown (打开端口)

    Sw1(config-if)#exit

    Sw1(config)#exit

    Sw1#show interface status (查看端口状态)

    Sw1#show running-config (查看运行状态)

    分别将Sw1-3的VPCS加入到VLAN并打开端口。

    --------------------------------------------------

    3、 给SW1、SW2和SW3配置中继链路:

    Sw1>enable

    Sw1#config terminal

    Sw1(config)#interface f0/1

    Sw1(config-if)#switchport mode trunk

    Sw1(config-if)#no shutdown

    Sw1(config-if)#exit

    Sw3>enable

    Sw3#config terminal

    Sw3(config)#interface f0/1

    Sw3(config-if)#switchport mode trunk

    Sw3(config-if)#no shutdown

    Sw3(config-if)#exit

    Sw2>enable

    Sw2#config terminal

    Sw2(config)#interface f0/0

    Sw2(config-if)#switchport mode trunk

    Sw2(config-if)#no shutdown

    Sw2(config-if)#exit

    Sw2>enable

    Sw2#config terminal

    Sw2(config)#interface f0/1

    Sw2(config-if)#switchport mode trunk

    Sw2(config-if)#no shutdown

    Sw2(config-if)#exit

    4、配置R1、R2和R3的IP地址及路由:

    R1(config)#interf e0/0

    R1(config-if)#duplex full (将e0/0端口设为全双工模式或将与其相连的交换机端口设为半双工模式)

    R1(config-if)#no shutdown (将e0/0端口启用)

    R1(config)#interf e0/0.1

    R1(config-subif)#encapsolution dot1q 2 (和VLAN2连接的端口e0/0.1启用dot1q协议)

    R1(config-subif)#ip addr 192.168.1.1 255.255.255.0

    R1(config-subif)# no shutdown

    R1(config)#interf e0/0.2

    R1(config-subif)#encapsolution dot1q 3 (和VLAN3连接的端口e0/0.2启用dot1q协议)

    R1(config-subif)#ip addr 192.168.2.1 255.255.255.0

    R1(config-subif)# no shutdown

    R1(config)#interf e0/0.3

    R1(config-subif)#encapsolution dot1q 4 (和VLAN4连接的端口e0/0.3启用dot1q协议)

    R1(config-subif)#ip addr 192.168.3.1 255.255.255.0

    R1(config-subif)# no shutdown

    R1(config)#interf e0/1

    R1(config-if)#duplex full

    R1(config-if)#ip addr 192.168.7.1 255.255.255.0 (给端口e0/1设置IP地址)

    R1(config-if)#no shutdown

    R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.7.2 (开启默认路由,192.168.7.2为下一跳地址)

    R1(config)#exit

    R1#show ip interface (查看端口状态)

    R1#show ip route (查看路由表)

    R2(config)#inter e0/0

    完成最后的配置时,我们的三个路由器以及路由器下面的交换机之间就可以相互访问了,当ping 的时候就会看到5个感叹号就表明连通了,谢谢阅读,希望能帮到大家,请继续关注脚本之家,我们会努力分享更多优秀的文章。

    展开全文
  • 我们今天在这里讲解一种企业路由器应用——IPSEC VPN配置实现访问不同网络下的局域网网站。 需要材料 企业路由器(此处以TP-LINK企业路由为例) 网络规划 青岛总公司局域网网段为“192.168.1.0/24”; 上海分...
  • 不同vlan、不同网段互访

    千次阅读 2019-07-12 23:43:16
    那么,通过不同VLAN隔离的两个网段如何通讯呢? 实现不同VLAN之间的访问,有两种方式: 一种是通过三层交换机,通过默认网关的方式实现不同VLAN之间的访问;一种是通过路由器,利用路由器的子...
  • Linux下如何实现不同网段之间的访问   本实例要说明的是:实现10.0.0.0/24网段与192.168.2.0/24网段相互访问. 步骤1:查看本机IP地址 [root@localhost root]# ifconfig eth0 Link encap:Ethernet ...
  • 服务器 (eth1 linux机器 eth0) <-------------> 客户端 物理连接如上。linux机器作为代理服务器,有两个网卡。...网上都是不同网段的配置,没有找到同网段的配置 2. linux实现透明代理,iptables规则应该如何设置
  • 转载地址:http://soft.chinabyte.com/122/11072122.shtml Linux下如何实现不同网段之间的访问 本实例要说明的是:实现10.0.0.0/24网段与192...
  • 3)楼层间拉两根线连接在两端交换机上,然后配单独的网段。楼层间地址不变, 但是需要三层交换机,搜索交换机型号好像不是三层。 目前了解这些,具体操作不清晰。如何配地址,在交换机还是路由上。
  • 前置机电脑,终端网卡1,终端网卡2,ip分别在...如何添加静态路由实现前置机同时访问终端网卡1和2,中间经过路由器。 如果在网卡1和网卡2上同时配上前置机的目的地址,则前置机只能ping通网卡1,不能ping通网卡2 求解!
  • 有一台linux(ubuntu)主机,双网卡。eth1和eth2分别接到两个不同网段1和网段2”。 另一台Web服务,位于网段2。 我需要实现的是,用网段1中其它主机的浏览器向Linux发请求,请求会被转发...请问这个需求如何实现
  • 三层交换机和路由器具备网络层的功能,能够根据数据的IP包头信息,进行选路和转发,从而实现不同网段之间的访问。 直连路由是指:为三层设备的接口配置IP地址,并且激活该端口,三层设备会自动产生该接口IP所...
  • 这就造成了一个问题,如何实现在自控网络上位机访问摄像头并嵌入使用?这里其实很简单,因为这两个网络本质上属于同一个物理链路。 所以,可以直接在上位机软件所在电脑上直接设置两个ip,分属于自控网络和视频网络...
  • 本文主要介绍在公司(固定网段如何用路由器上网同时还可以实现别的机器通过远程桌面连接访问本机,也可以通过输入ip获取本机的共享文件 首先路由器有一个WAN口和几个LAN口,这个一定要区分开,WAN口插公司分配的...
  • 网段的不同也可能导致网关也不同,不同网段是不能互相直接访问的。代理服务器IP可以在互联上搜索,并且能够实现上网,因此对于代理服务器实现搜索及配置上网迫在眉睫,想要实现网络访问某些网站,利用代理服务器是最...
  • 在要求不太高的情况,我们可以用其它设备作为网关来...但要注意的是:使用两块网卡来连接两个网段的方法在这里是不行的,那样这台机器虽然可以被任何网段访问到,但以它为网关来访问其它不同网段的机器是无法做到的。
  • 注:原有的4个ADSL均配置不同网段且启用着DHCP功能 需求摘要: 1.实现各部门均能访问打印机、文件共享服务器(机器均为单网卡) 2.实现各部门间互传数据,网速能达能1M左右 3.保证台式机(有线连网)及笔记本...
  • 如何实现把 linux 当路由器来使用,实现不同网段之间的通信访问,这是所要实现的 路由配置  环境准备: 4 台虚拟机,两台中间两台作为路由器来使用(每天主机两块网卡),其他两台作为终端主机,目的是让不同网段...
  • eNSP 华为模拟器 配置DHCP服务器实验 一、实验概述 二、路由器的配置 三、三层交换机的配置 四、实验...何通过路由器实现不同网段之间的访问。并且开启路由器的DHCP功能, 自动给PC端分发IP地址。 (2)运 用所学的知识
  • 前置机电脑,终端网卡1,终端网卡2,ip分别在...如何添加静态路由实现前置机同时访问终端网卡1和2,中间经过路由器。 如果在网卡1和网卡2上同时配上前置机的目的地址,则前置机只能ping通网卡1,不能ping通网卡2 求解!
  • 我们可以看到,当所有的Router都连接在一起的时候,其中同一网段内是可以实现互相访问的,但是我们如何才能够让不同网段之间的路由也可以互相访问呢?那就是静态路由配置,可能有的朋友会问怎么不用动态路由协议呢...
  • 我们可以看到,当所有的Router都连接在一起的时候,其中同一网段内是可以实现互相访问的,但是我们如何才能够让不同网段之间的路由也可以互相访问呢?那就是静态路由配置,可能有的朋友会问怎么不用动态路由协议呢?...
  • 还有一种办法就是用路由器,能够实现不同网段之间的文件共享。如果我们口袋里银子不够呢?呵呵,你就会说:这是小段存心刁难咱! 今天我们来看看如何实现上述效果。硬件路由器,而不是我们常见的家用路由器,一般...
  • 第二层以太网交换机连接多个以太网LAN网段。由于交换机的每个端口可以连接至不同网段,所以这种拓扑结构能够形成规模更大的以太网。交换机存储介质访问控制器...本文将讨论如何利用低成本的可编程逻辑架构实现以太
  • 基于上篇文章,遇到不同网段互相访问的一些问题的总结我理解了要想在真实网络环境中,实现跨局域网的ndn通信(非同一内网下;例如联通和移动下的网络设备进行ndn通信),必须考虑NAT技术。那么现有的如QQ这样的通信...

空空如也

空空如也

1 2 3
收藏数 41
精华内容 16
关键字:

不同网段如何实现访问