精华内容
下载资源
问答
  • 在同一网段和不同网段通信的区别

    千次阅读 2010-08-25 00:13:00
    在同一网段和不同网段通信的区别

    文章出处:http://ifiloveican.blog.sohu.com/83043622.html

     

    下面的表是在同一网段内,主机A和主机B通信,主机A数据的封装,可以和第二个表对比一下,基本上是一样的,只是第二个的目的IP用的是公网地址,因为私有地址是上不了公网的

     

     

    目的

     

    应用层

     

     

    Data、数据流

    传输层、端口

    1336

    139

    Segment、数据分段

    网络层、IP地址

    192.168.1.1

    192.168.1.2

    Packet、数据包

    数据链路层、MAC地址

    1111.1111.1111

    2222.2222.2222

    Frame、数据帧

    物理层

     

     

    Bit、数据位

     

    数据提交到交换机后,交换机对主机A所发出的数据不做任何改动,直接转发给B(前提是交换机的MAC地址表中有B的MAC地址),这是位于同一网段的通信过程。下面是位于不同网段的通信过程

     

    下面的表是源主机的数据封装过程,没什么好说的,

     

     

    目的

     

    应用层

     

     

    Data、数据流

    传输层、端口

    1700

    21

    Segment、数据分段

    网络层、IP地址

    192.168.1.2

    218.69.192.87

    Packet、数据包

    数据链路层、MAC地址

    1111.1111.1111

    2222.2222.2222

    Frame、数据帧

    物理层

     

     

    Bit、数据位

     

    数据从A出来,进入交换机,交换机依然不做任何改动,发给路由器A,下面的表是路由的封装过程,可以看到源IP的地址已经改变,这是为了要在公网上传输,而交换机的源MAC地址和目的MAC地址都已经改变。源MAC地址是了路由A的S0端口的,而目的MAC地址路由B的S0几口的地址,这样就可以看出来了,原来在公网上,每经过一个路由MAC地址就会相应改变,而IP地址是不变的

     

     

    目的

     

    应用层

     

     

    Data、数据流

    传输层、端口

    1700

    21

    Segment、数据分段

    网络层、IP地址

    218.68.45.1

    218.69.192.87

    Packet、数据包

    数据链路层、MAC地址

    3333.3333.3333.3333

    4444.4444.4444.4444

    Frame、数据帧

    物理层

     

     

    Bit、数据位

    展开全文
  • 通过VLANIF实现同VLAN不同网段通信

    千次阅读 2019-01-01 20:59:06
    如图1所示,某企业网络中,同一VLAN的主机...图1 配置通过VLANIF实现同VLAN不同网段通信组网图 配置思路 针对上述需求,如果在Router的VLANIF接口上只配置一个IP地址,则只有一个网段的主机能够通过Router访问Inter...

    如图1所示,某企业网络中,同一VLAN的主机分别属于两个网段10.1.1.1/24和10.1.2.1/24,要求这两个网段的主机都可以通过Router访问Internet,且这两个网段中的主机能够互通。

    图1 配置通过VLANIF实现同VLAN不同网段通信组网图

    配置思路

    针对上述需求,如果在Router的VLANIF接口上只配置一个IP地址,则只有一个网段的主机能够通过Router访问Internet。为了使局域网内所有主机都能够通过Router访问Internet,需要配置VLANIF接口的从IP地址。为了使两个网段中的主机能够互通,两个网段中的主机需要将此主从IP地址分别设置为网关。

    可采用如下思路配置通过VLANIF实现同VLAN不同网段用户的通信:

    1.配置VLAN并将各接口加入VLAN。

    2.配置VLANIF接口及其IP地址,使两网段的主机间能够互通。

    3.配置上行路由,使主机可通过Router访问Internet。

    操作步骤

    在Router上配置VLAN并将各接口加入VLAN

    创建VLAN10和VLAN20。

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 10 20

    配置接口Eth2/0/1和Eth2/0/2加入VLAN 10,Eth2/0/3加入VLAN 20。

    [Router] interface ethernet 2/0/1
    [Router-Ethernet2/0/1] port link-type access
    [Router-Ethernet2/0/1] port default vlan 10
    [Router-Ethernet2/0/1] quit
    [Router] interface ethernet 2/0/2
    [Router-Ethernet2/0/2] port link-type access
    [Router-Ethernet2/0/2] port default vlan 10
    [Router-Ethernet2/0/2] quit
    [Router] interface ethernet 2/0/3
    [Router-Ethernet2/0/3] port link-type trunk
    [Router-Ethernet2/0/3] port trunk allow-pass vlan 20
    [Router-Ethernet2/0/3] quit
    在Router上配置VLANIF接口

    创建并配置VLANIF10的主IP地址为10.1.1.1/24、从IP地址为10.1.2.1/24,创建并配置VLANIF20的IP地址为10.10.10.1/24。

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 10.1.1.1 24
    [Router-Vlanif10] ip address 10.1.2.1 24 sub
    [Router-Vlanif10] quit
    [Router] interface vlanif 20
    [Router-Vlanif20] ip address 10.10.10.1 24
    [Router-Vlanif20] quit
    配置上行路由

    配置OSPF基本功能,发布用户网段以及Router与Router_1之间的互联网段。

    [Router] ospf
    [Router-ospf-1] area 0
    [Router-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [Router-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [Router-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.255
    [Router-ospf-1-area-0.0.0.0] quit
    [Router-ospf-1] quit
    说明:
    Router_1上需要进行如下配置:
    将连接Router的接口以Tagged方式加入VLAN20,并指定VLANIF20的IP地址与10.10.10.1在同一网段。
    配置OSPF基本功能,并发布Router与Router_1之间的互联网段。
    具体配置请参见使用设备的产品文档,本文不再赘述。

    验证配置结果
    配置Host1的IP地址为10.1.1.2,缺省网关为VLANIF10接口的主IP地址10.1.1.1/24;配置Host2的IP地址为10.1.2.2,缺省网关为VLANIF10接口的从IP地址10.1.2.1/24。

    配置完成后,Host1和Host2能够互相Ping通,且都可以Ping通Router连接Router的接口的IP地址10.10.10.2/24,也就都可以访问Internet。

    配置文件

    Router的配置文件

    #
    sysname Router
    #
    vlan batch 10 20
    #
    interface Vlanif10
    ip address 10.1.1.1 255.255.255.0
    ip address 10.1.2.1 255.255.255.0 sub
    #
    interface Vlanif20
    ip address 10.10.10.1 255.255.255.0
    #
    interface Ethernet2/0/1
    port link-type access
    port default vlan 10
    #
    interface Ethernet2/0/2
    port link-type access
    port default vlan 10

    interface Ethernet2/0/3
    port link-type trunk
    port trunk allow-pass vlan 20
    #
    ospf 1
    area 0.0.0.0
    network 10.1.1.0 0.0.0.255
    network 10.1.2.0 0.0.0.255
    network 10.10.10.0 0.0.0.255
    #
    return

    要使设备能够分辨不同VLAN的报文,需要在报文中添加标识VLAN信息的字段。IEEE 802.1Q协议规定,在以太网数据帧的目的MAC地址和源MAC地址字段之后、协议类型字段之前加入4个字节的VLAN标签(又称VLAN Tag,简称Tag),用以标识VLAN信息。

    在一个VLAN交换网络中,以太网帧主要有以下两种形式:

    有标记帧(Tagged帧):加入了4字节VLAN标签的帧。
    无标记帧(Untagged帧):原始的、未加入4字节VLAN标签的帧。
    tagged方式即指设备在接收或发送以太网帧时,在以太网帧头部添加Tag字段。

    转载于:https://blog.51cto.com/13505091/2337606

    展开全文
  • 组网需求 如图1所示,某企业网络中,同一VLAN的主机分别属于两个网段10.1.1.1/24和10.1.2.1/24,要求这两个网段的主机都可以通过Router访问Internet,且这两个网段中的...配置通过VLANIF实现同VLAN不同网段通信

    转自:http://support.huawei.com/ecommunity/bbs/10266280.html

    组网需求

    图1所示,某企业网络中,同一VLAN的主机分别属于两个网段10.1.1.1/24和10.1.2.1/24,要求这两个网段的主机都可以通过Router访问Internet,且这两个网段中的主机能够互通。

    图1 配置通过VLANIF实现同VLAN不同网段通信组网图


    配置思路

    针对上述需求,如果在Router的VLANIF接口上只配置一个IP地址,则只有一个网段的主机能够通过Router访问Internet。为了使局域网内所有主机都能够通过Router访问Internet,需要配置VLANIF接口的从IP地址。为了使两个网段中的主机能够互通,两个网段中的主机需要将此主从IP地址分别设置为网关。

    可采用如下思路配置通过VLANIF实现同VLAN不同网段用户的通信:

    1.配置VLAN并将各接口加入VLAN。

    2.配置VLANIF接口及其IP地址,使两网段的主机间能够互通。

    3.配置上行路由,使主机可通过Router访问Internet。

    操作步骤

    1. 在Router上配置VLAN并将各接口加入VLAN

      # 创建VLAN10和VLAN20。

      <Huawei> system-view
      [Huawei] sysname Router
      [Router] vlan batch 10 20
      

      # 配置接口Eth2/0/1Eth2/0/2加入VLAN 10,Eth2/0/3加入VLAN 20。

      [Router] interface ethernet 2/0/1
      [Router-Ethernet2/0/1] port link-type access
      [Router-Ethernet2/0/1] port default vlan 10
      [Router-Ethernet2/0/1] quit
      [Router] interface ethernet 2/0/2
      [Router-Ethernet2/0/2] port link-type access
      [Router-Ethernet2/0/2] port default vlan 10
      [Router-Ethernet2/0/2] quit
      [Router] interface ethernet 2/0/3
      [Router-Ethernet2/0/3] port link-type trunk
      [Router-Ethernet2/0/3] port trunk allow-pass vlan 20
      [Router-Ethernet2/0/3] quit
      
    2. 在Router上配置VLANIF接口

      # 创建并配置VLANIF10的主IP地址为10.1.1.1/24、从IP地址为10.1.2.1/24,创建并配置VLANIF20的IP地址为10.10.10.1/24。

      [Router] interface vlanif 10
      [Router-Vlanif10] ip address 10.1.1.1 24
      [Router-Vlanif10] ip address 10.1.2.1 24 sub
      [Router-Vlanif10] quit
      [Router] interface vlanif 20
      [Router-Vlanif20] ip address 10.10.10.1 24
      [Router-Vlanif20] quit
      
    3. 配置上行路由

      # 配置OSPF基本功能,发布用户网段以及Router与Router_1之间的互联网段。

      [Router] ospf
      [Router-ospf-1] area 0
      [Router-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
      [Router-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [Router-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.255
      [Router-ospf-1-area-0.0.0.0] quit
      [Router-ospf-1] quit
      
      说明:
      Router_1上需要进行如下配置:
      • 将连接Router的接口以Tagged方式加入VLAN20,并指定VLANIF20的IP地址与10.10.10.1在同一网段。
      • 配置OSPF基本功能,并发布Router与Router_1之间的互联网段。

      具体配置请参见使用设备的产品文档,本文不再赘述。

    4. 验证配置结果

      配置Host1的IP地址为10.1.1.2,缺省网关为VLANIF10接口的主IP地址10.1.1.1/24;配置Host2的IP地址为10.1.2.2,缺省网关为VLANIF10接口的从IP地址10.1.2.1/24。

      配置完成后,Host1和Host2能够互相Ping通,且都可以Ping通Router连接Router的接口的IP地址10.10.10.2/24,也就都可以访问Internet。

    配置文件

    Router的配置文件

    #
    sysname Router
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     ip address 10.1.2.1 255.255.255.0 sub
    #
    interface Vlanif20
     ip address 10.10.10.1 255.255.255.0
    #
    interface Ethernet2/0/1
     port link-type access
     port default vlan 10
    #
    interface Ethernet2/0/2
     port link-type access
     port default vlan 10
    # 
    interface Ethernet2/0/3
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.10.10.0 0.0.0.255
    #
    return
    


    要使设备能够分辨不同VLAN的报文,需要在报文中添加标识VLAN信息的字段。IEEE 802.1Q协议规定,在以太网数据帧的目的MAC地址和源MAC地址字段之后、协议类型字段之前加入4个字节的VLAN标签(又称VLAN Tag,简称Tag),用以标识VLAN信息。

    在一个VLAN交换网络中,以太网帧主要有以下两种形式:

    • 有标记帧(Tagged帧):加入了4字节VLAN标签的帧。
    • 无标记帧(Untagged帧):原始的、未加入4字节VLAN标签的帧。

     tagged方式即指设备在接收或发送以太网帧时,在以太网帧头部添加Tag字段。


    展开全文
  • 单臂路由及Trunk实现交换机内不同网段通信 仿真环境:Cisco Packet Tracker 拓扑图如图 实验目的:实现全网互通 1、查看VLAN表: do sh vlan b   2、创建两个VLAN,分别取名10、20 vlan 10 / vlan 20   3、对...

    单臂路由及Trunk实现交换机内不同网段通信

    仿真环境:Cisco Packet Tracker

    拓扑图如图
    实验目的:实现全网互通
    在这里插入图片描述
    1、查看VLAN表: do sh vlan b
      在这里插入图片描述
    2、创建两个VLAN,分别取名10、20 vlan 10 / vlan 20
      在这里插入图片描述
    3、对交换机1:将f0/4端口接入到vlan10,f0/5端口接入到vlan20 。交换机2同理
      在这里插入图片描述
      在这里插入图片描述
      同样的方法设置另一个交换机
      在这里插入图片描述
    4、设置trunk
      第一个交换机设置端口f0/1为trunk 在这里插入图片描述
      第二个交换机设置端口f0/1为trunk 在这里插入图片描述
    5、对路由器进行配置
      在这里插入图片描述
    6、此时,即便是与不同网关的PC通信,也可以
      在这里插入图片描述

    展开全文
  • 1.交换机xiang相互通信是要有前提了,必须是处于同一广播域的主机才能通信不同网段的主机都不再同一广播域,发送的数据包都不能广播得不到目标主机的MAC就不能通信了~
  • 虚拟机配置路由实战环境说明配置过程测试 环境说明 虚拟机 说明 ...路由器 172.16.17.170 + 192.168.43.104 ... 主要是配置“路由器”,使它在不同网段间能转发包 (添加网卡就不再赘述,直接描述路由器配置过程
  • 交换机能不能实现不同网段通信

    千次阅读 2019-10-07 20:34:05
    交换机(网桥)是数据链路层上的设备,用于将同一个子网的多个节点连接在一起,没有进/出口之分。...与路由器不同,它内部没有网络适配器,即没有IP和MAC地址,只有端口。也就是说,它对接收到的数据包,只...
  • ip addr show eth1 ip link set up eth1
  • 只能在三层交换机上的一个接口上实现两个不同网段的网关能通信。 命令以及结果验证 lsw2配置: interface Vlanif10 ip address 10.1.1.254 255.255.255.0 ip address 10.1.2.254 255.255.255.0 sub interface Vlan...
  • 当一个局域网中必须存在两个以上网段时,分属于不同网段内的主机彼此互不可见。为了解决这个问题,就必须在不同网段之间设置路由器。如果花费上万元资金购买一台路由器,仅仅用于连接局域网中的两个网段,实在不...
  • ARP 地址解析协议,即ARP(Address Resolution Protocol),是根据IP地址获取物理地址的一个TCP/IP协议。...如图,在相同网段的时候,PC5会广播ARP请求,然后根据交换机的工作原理,如果划分了VLAN就在相同的VL.
  • 1.1 组网一:新华三单臂路由组网实验 1.1.1 实验拓扑图 看完记得点赞加关注!...(3)分析PC1pingPC4的三层通信过程和二层通信过程。 (4)掌握层次化配置与排错在局域网项目中的运用。 (5)掌握三层逻辑拓扑与...
  • 计算机网络——不同网段下的主机通信

    万次阅读 多人点赞 2020-06-20 08:20:22
    搞懂不同网段间的主机通信
  • 文章出处:同网段不同网段设备通信原理详解 在当今的以太网络通信中,在IP数据包中有两个必不可少的地址,那就是IP地址和网卡地址(即MAC地址),在数据包中,无论是IP地址还是MAC地址,都有源地址和目标...
  • 首先先看一下拓扑图,此时不考虑AR-1和PC3,只关注PC1和PC 2 LSW-1 研究同网段通信,且将地址设置为如下配置地址 同网段通信过程 此时PC1 PING PC2 PC1首先查看自己的ARP表,检查是否有主机2的IPMAC的映射,PC开始...
  • 网段不同网段设备通信原理详解

    万次阅读 多人点赞 2015-12-15 11:50:43
    在当今的以太网络通信中,在IP数据包中有两个必不可少的地址,那就是IP地址和网卡地址(即MAC地址),在数据包中,无论是IP地址还是MAC地址,都有源地址和目标地址,因为通信是双方的,所以就必须同时拥有双方的地址...
  • 网段不同网段主机间通信原理

    千次阅读 2018-04-06 08:38:26
    在当今的以太网络通信中,在IP数据包...在同一IP网络中通信,将会发生以下事件:1、同网段主机间通信 主机A与主机B通信,这时主机A肯定首先要封装这些需要发给主机B的数据包,那么对于主机A来说,自己的IP地址和MAC...
  • 在当今的以太网络通信中,在IP数据包中有两个必不可少的地址,那就是IP地址和网卡地址(即MAC地址),在数据包中,无论是IP地址还是MAC地址,都有源地址和目标地址,因为通信是双方的,所以就必须同时拥有双方的地址...
  • 不同网段之间的通信

    千次阅读 2018-10-21 00:01:37
    本篇博客采用构造路由器来实现不同地址段 ip 地址之间的通信。 路由器就是作为不同网络之间互相连接的枢纽而存在。 说明:本实验设置虚拟机desktop为路由器,虚拟机server为客户端(1.1.1.129) 步骤一:设置路由...
  • 不同vlan,不同网段通信 - 副本

    千次阅读 2020-04-15 20:49:09
    �㣻 vlan ���� 1������vlan��ȫ��ģʽconf t��vlan * exit 2����vlan����˿ڣ�conf t�� ����˿� interface fastetherent 0/1 �������˿ڷ���˿ڣ� �� interface ...
  • 在当今的以太网络通信中,在IP数据包中有两个必不可少的地址,那就是IP地址和网卡地址(即MAC地址),在数据包中,无论是IP地址还是MAC地址,都有源地址和目标地址,因为通信是双方的,所以就必须同时拥有双方的地址...
  • 基于MAC网卡物理地址的通信类,可实现不同网段之间通信 本类为C++源码需要 winpcap 支持 winpcap 官方地址 http://www.winpcap.org/ winpcap 3.0通过测试。
  • 不同网段的终端相互通信

    千次阅读 2015-06-08 08:58:59
     在没有路由器的情况下,两个网络之间是不能进行TCP/IP通信的,即使是两个网络连接在同一台交换机(或集线器)上,TCP/IP协议也会根据子网掩码(255.255.255.0)判定两个网络中的主机处在不同的网络里。而要实现这两个...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 66,111
精华内容 26,444
关键字:

不同网段通信