精华内容
下载资源
问答
  • 宽带运营商检测
    千次阅读
    2019-06-28 17:12:01

    现有条件:cisco2811路由器一台(插板卡,一共四个FE口)
    一根电信线路:48.210.41.170/30 (假设)
    一根联通线路:25.220.87.160/30 (假设)
    假设公司有192.168.8.0/24 192.168.9.0/24 192.168.10.0/24 192.168.11.0/24
    四个内网网段。

    想要实现目的:
    ①.192.168.8.0/24;192.168.9.0/24上外网默认走电信;
    ②.192.168.10.0/24;192.168.11.0/24上外网默认走联通
    ③.当电信线路断掉时,原本走电信的192.168.8.0/24和192.168.9.0/24能自动切换到联通线路。
    ④.当联通线路断掉时,原本走联通的192.168.10.0/24和192.168.11.0/24能自动切换到电信线路。
    以上目的便可实现负载均衡,同时当线路故障时可自动切换到另一条完好的线路,达到冗余备份的目的。
    注意:当电信联通线路同时断掉时,就没辙了,不过这种几率很小,这里不做考虑。

    本次过程用真机在真实环境中搭建,并完全实现上述功能,就不浪费时间在模拟器实验了,直接手写配置好了。

    拓扑:L3----R1-----因特网
    假设四个网段均在L3上
    R1的f0/0/0口作为连接网段与L3连接。
    连接网段10.100.100.2/30
    关键配置都在R1上,L3就写条默认路由指向R1

    路由器hostname:R1
    R1:
    interface f0/0
    description
    ip address 48.210.41.170 255.255.255.252
    no shut

    interface f0/1
    description
    ip address 25.220.87.160 255.255.255.252
    no shut

    interface f0/0/0
    description
    ip address 10.100.100.2
    ip policy route-map INTERNET
    no shut

    ip nat inside source route-map NAT_CT_2_CT interface FastEthernet0/0 overload
    ip nat inside source route-map NAT_CT_2_CU interface FastEthernet0/1overload
    ip nat inside source route-map NAT_CU_2_CT interface FastEthernet0/0overload
    ip nat inside source route-map NAT_CU_2_CU interface FastEthernet0/1overload
    //这里如果只写两条包含所有网段的列表分别应用在两个接口下的话,会一直走电信线路(亲测)所以用route-map调用列表分别做NAT。

    ip route 192.168.8.0 255.255.255.0 10.100.100.1 //l路由回指
    ip route 192.168.9.0 255.255.255.0 10.100.100.1 //l路由回指
    ip route 192.168.10.0 255.255.255.0 10.100.100.1 //l路由回指
    ip route 192.168.11.0 255.255.255.0 10.100.100.1 //l路由回指
    注意:可以不用写默认路由
    ip next-hop > 普通明细路由 > ip default next-hop > 默认路由

    ip access-list extended TO_CT
    permit ip 192.168.8.0 0.0.0.255 any
    permit ip 192.168.9.0 0.0.0.255 any
    ip access-list extended TO_CU
    permit ip 192.168.10.0 0.0.0.255 any
    permit ip 192.168.11.0 0.0.0.255 any
    //电信联通分开

    ip sla 1
    icmp-echo 48.210.41.169 source-interface FastEthernet0/0
    frequency 10
    ip sla schedule 1 life forever start-time now
    ip sla 2
    icmp-echo 25.220.87.159 source-interface FastEthernet0/1
    frequency 10
    ip sla schedule 2 life forever start-time now

    track 1 ip sla 1

    track 2 ip sla 2
    //sla与tracek关联,检测电信和联通线路是否故障,形成故障切换条件。

    route-map INTERNET permit 10
    match ip address TO_CT
    set ip next-hop verify-availability 48.210.41.169 10 track 1
    set ip next-hop verify-availability 25.220.87.159 20 track 2
    set ip next-hop 48.210.41.169 25.220.87.159
    !
    route-map INTERNET permit 12
    match ip address TO_CU
    set ip next-hop verify-availability 25.220.87.159 10 track 2
    set ip next-hop verify-availability 48.210.41.169 20 track 1
    set ip next-hop 25.220.87.159 48.210.41.169
    //判断下一跳是否可达,与track关联,ip next-hop后面加电信和联通的网关

    route-map NAT_CT_2_CT permit 10
    match ip address TO_CT
    match interface FastEthernet0/0
    !
    route-map NAT_CU_2_CU permit 10
    match ip address TO_CU
    match interface FastEthernet0/1
    !
    route-map NAT_CT_2_CU permit 10
    match ip address TO_CT
    match interface FastEthernet0/1
    !
    route-map NAT_CU_2_CT permit 10
    match ip address TO_CU
    match interface FastEthernet0/0
    //NAT中的route-map,需要注意的是一定要match对应的接口。

    结果:将电信线路断掉,192.168.8.0/192.168.9.0会自动切换到联通线路,然后将电信线路插回去,192.168.8.0/192.168.9.0会自动切换走电信线路,联通同理,完美!
    这样不管哪条线路出现什么问题,都能自动完成切换。
    PS:在L3上,一条默认路由 ip route 0.0.0.0 0.0.0.0 10.100.100.2即可。

    更多相关内容
  • 什么是http劫持:http劫持就是第三方(宽带运营商)在你和网站建立交互过程中劫持了你的请求,并返回错误页面的行为,宽带运营商作为基础电信网络服务提供者, 掌握着用户通往互联网大门的钥匙,用户的所有网络请求...

    什么是http劫持:http劫持就是第三方(宽带运营商)在你和网站建立交互过程中劫持了你的请求,并返回错误页面的行为,宽带运营商作为基础电信网络服务提供者, 掌握着用户通往互联网大门的钥匙,用户的所有网络请求都会通过宽带运营商的节点(路由),宽带运营商可以轻易劫持用户数据并做出更改。
    IIS7网站监控可以及时防控网站风险,快速准确监控网站是否遭到各种劫持攻击,网站在全国是否能正常打开(查看域名是否被墙),精准的DNS污染检测,具备网站打开速度检测功能,第一时间知道网站是否被黑、被入侵、被改标题、被挂黑链。精益求精的产品,缺陷为零数据提供!
    它可以做到以下功能:
    1、检测网站是否被黑
    2、检测网站是否被劫持
    3、检测域名是否被墙
    4、检测DNS是否被污染
    5、网站真实的完全打开时间(独家)
    6、拥有独立监控后台,24小时定时监控域名
    官方图:
    在这里插入图片描述
    在这里插入图片描述
    官方地址:IIS7网站监控
    现在我们就来细数宽带运营商常见的集中http劫持行为

    一、改变访问内容

    宽带运营商获得用户访问请求后,利用自身技术优势,将正常返回的页面进行劫持并做302跳转,跳转到更改后的页面。通常这种行为的目的是跳转到带有后缀推广链接的地址(网址后面加上小尾巴),现在更有直接跳到其他网站的事情发生,甚至是直接跳转到广告页面,本站之前介绍过的《最近好多网赚博客都被http劫持了》这篇文章中出现的现象就是属于这种情况。

    二、在返回的页面中加入广告

    在返回页面中加入框架代码来实现强行加入广告,这种劫持方式是最常见的方式,普通用户无法分辨广告是否为网站本身所有,还是劫持所致,所以发现难,申述难,解决难,下图右下角的广告就是运营商劫持篡改的。

    http劫持

    三、篡改网页中原有广告

    这种行为更隐蔽,会将网页中原本就存在的广告更改为运营商推送的广告,你要是不看源代码,根本就不知道被劫持了。

    如何防止运营商http劫持呢?

    网站本身可以采用https加密传送,可以有效的减少被劫持的可能性。

    普通用户可以在浏览器中添加广告拦截插件,当然这种方法只能屏蔽被劫持的广告,网站页面被恶意跳转是不管用的。

    最彻底的解决方法有三种

    一、不上网

    二、移居海外,用国外的运营商来上网

    三、宽带运营商良心发现,不再劫持

    展开全文
  • 摘要 从P2P流量现状及运营商互联网络组织和运营模式入手。分析了P2P应用给运营商带来问题的原因,阐明了对于P2P应用的看法,并给出了P2P流量控制策略。随着计算机网络的广泛应用和多媒体资源的丰富,P2P技术主要...

    摘要 从P2P流量现状及运营商互联网络组织和运营模式入手。分析了P2P应用给运营商带来问题的原因,阐明了对于P2P应用的看法,并给出了P2P流量控制策略。

    随着计算机网络的广泛应用和多媒体资源的丰富,P2P技术主要应用于文件(主要是大型的多媒体文件)共享方面。近年来,P2P应用成为互联网行业的热门话题,信息产业部多次召开专题会议对P2P问题进行研究,互联网协会也成立宽带P2P应用推进联盟。典型的P2P应用如BT、Skype、eDonkey等被广大互联网用户熟知并应用,但是在运营商和企业那里却并不那么受欢迎,因为P2P应用给运营商的互联网经营及企业的正常互联网应用带来了诸多问题。

    在P2P大量应用之前,运营商搭建互联网业务承载网络,互联网上的信息服务主要采用服务器/客户机模式,瓶颈主要在服务器端,服务器的处理能力和带宽限制是影响用户服务的主要矛盾。在P2P应用大规模部署之后,客户机/服务器的区别变得模糊,对于参与P2P应用的用户而言,其本身作为客户机的同时,也在作为服务器为其他客户机提供服务,使得原来服务器/客户机的瓶颈得以突破,随着互联网用户接入带宽的增加,P2P模式的应用也使每个用户的接入带宽得到充分发挥。

    据统计,互联网流量中60%~80%的成份为P2P应用,P2P流量影响了用户对网页访问、电子邮件、ERP应用等的正常使用。运营商遇到的问题是,无论如何进行扩容,总是不能满足用户对带宽增长的需求,用户使用网络丢包和时延增加,对网络质量的满意度下降。在企业端也遇到同样的问题,正常的办公受到影响,许多企业纷纷采取技术和管理手段限制P2P类应用的大量使用。

    1、P2P流量产生问题的原因

    从信息共享的角度看,P2P技术的应用扩大了互联网信息共享能力,使互联网的信息承载量增加。从对用户带来价值的角度讲,P2P技术的应用给使用该技术的用户带来价值,但由于网络技术及网络建设的滞后,损害了其他用户的利益。在当前的运营模式下,互联网网络运营商基本不参与到P2P应用价值链之中,因此运营商没有从P2P技术应用中获得好处。

    P2P流量对运营商互联网的冲击将是一个相对长期的过程,下面从几个方面谈P2P流量带来问题的原因。

    1.1 粗放的计费模式为P2P应用创造大行其道的市场

    从世界范围看,互联网接入多采用包月和计时长的收费方式,使得用户在使用互联网时,不会因为使用互联网信息量多而额外支付费用,P2P应用使互联网接入用户的上行带宽资源得到充分发挥,由于克服了传统服务器/客户机模式下的服务器带宽瓶颈,用户下行带宽也得到充分发挥。用户利用P2P程序占用互联网带宽的能力增强,且并不因此而多支付费用,从而扩大了用户通过P2P程序对互联网带宽的索取。

    1.2 结构化的运营商网络结构不适应P2P应用的大规模使用

    运营商在设计互联网网络时,都考虑了流量汇聚和用户收敛。由于现有用户中包月用户数量增多,产生了大量一直在线的用户,这些在线用户通过使用P2P软件可以与互联网其他用户共享资源,使得原来按照流量汇聚和用户收敛方式设计的网络出现阻塞,网络在接入和城域网上出现信息超载现象。

    虽然近年来运营商的骨干网络开始向扁平化发展,但长久以来形成的结构化网络设计,网络分级分层较多,在短时间内还不能根本改变,如图1所示。

    20080227024324217.jpg

    图1 运营商长久以来形成的结构化骨干网络

    这样,如果在一个运营商的两个用户之间进行通信,往往要跨过“城域网1—省内骨干网1—省级骨干网—省内骨干网2—城域网2”。对于传统的电话网来说,由于受到行政区域划分、社会组织的影响,结构化的组网方式可以节约资源。但随着互联网上的P2P应用分布不再受传统的行政区域划分等因素的制约,信息源和用户的分布更加分散,严格的结构化网络造成了资源的浪费。

    目前,我国大运营商的互联网主要通过设在北京、上海和广州的三个互联点进行互联,使得很多两个运营商用户之间的本地流量都要通过这三个互联点进行转接,造成了运营商骨干网资源的大量占用。

    近年来,运营商之间的网络互联质量一直是影响互联网服务质量的一大问题,P2P类应用的大量涌现无疑加剧了在现有网络结构下运营商网内和网间的服务质量的恶化。

    1.3 用户接入网络速率的提高超过运营商网络速率的提高

    用户计算机以太网接口速率基本实现了10/100 Mbit/s到桌面甚至更高,用户Wi-Fi接口的速率也超过50 Mbit/s。

    基于电话铜线xDSL技术、基于电视电缆的HFC技术、基于电力线的PLC技术、基于光纤的PON技术对用户接入带宽都有大大的提升,就基于电话铜线的宽带技术发展看:下行为56 kbit/s→512 kbit/s→1.5 Mbit/s→24 Mbit/s→55 Mbit/s;上行为33.6 kbit/s→128 kbit/s→512 kbit/s→1 Mbit/s→19.2 Mbit/s,并且速率有进一步提高的趋势。

    局域网中GE接口、10 GE接口已经在广泛使用,但是运营商网络设备接口与用户终端设备一样,受到器件能力的制约,目前接口速率可达40 Gbit/s。用户端设备、用户接入网络速率的提升速度高于运营商互联网承载网络的带宽增加速度。

    1.4 P2P类应用拓展了用户端资源的共享能力

    在P2P类应用出现之前,用户主要从互联网上获取信息,信息的传递是非对称的,下行的带宽要大于用户上行的带宽。在P2P类应用出现之后,用户向互联网发送的信息量增大,上行的带宽利用率大大增加。普通用户通过互联网主要进行人与人的通信以及人与机器的通信。P2P类应用增加了普通用户机的通信能力,用户端计算机等设备可以在非人工参与的情况下进行通信,拓展了用户端计算机计算、存储、信息共享的能力。

    1.5 网络服务质量的保证措施不健全

    当今互联网主要提供“尽力而为”的业务,网络设备对业务服务质量的保障能力很弱,在网络拥塞时,网络浏览、电子邮件等各种应用都受到影响,不因为某个应用对某个用户较重要而得到特殊的保护,这样在网络能力有限时,所有用户的服务都不能得到保障。

    2、P2P的意义和价值

    P2P类应用尤其是P2P下载类应用对运营商和企业带来网络服务质量下降、扩容成本和维护成本增加的问题,但却受到大量使用者的欢迎。用户通过互联网P2P应用获取信息的效率和获取的信息量大幅提高,随着P2P应用技术的发展,通过P2P手段所进行的网络应用越来越多,从信息下载、通信、流媒体播放到协同办公等。

    2.1 P2P应用提高了互联网上信息的传递效率

    在P2P大量应用之前,客户机/服务器模式是互联网上的主要应用组网方式,客户机/服务器在互联网上信息的传送能力主要受到服务器个数、服务器网络带宽、服务器连接用户数的限制,而采用P2P模式在互联网上信息的传送,突破了应用对服务器的性能、服务器连接用户数及连接带宽的极高要求,信息传送的效率随着P2P模式应用参与方的增加而提高。

    结合目前的互联网用户访问速度以及通常的服务器性能,就用户信息下载这个应用进行分析,我们可以得出P2P应用可以提高互联网信息传递效率的结论。

    假定一:信息下载的速度受服务器带宽的限制就信息下载这一个简单的应用来说,在P2P技术应用前,主要采用客户机/服务器方式进行,一个信息在互联网上单位时间所占带宽主要为提供该信息的服务器的数量(Ns)及服务器为传送该信息所提供的平均带宽(Bs),则可简单由Ns×Bs来表示。这里假定Bs为1 000 Mbit/s,则采用服务器/客户机模式,一个应用占用互联网带宽为Ns×1 000 Mbit/s。

    假定二:信息下载的速度只受到服务器用户数的限制

    在服务器/客户机模式下,信息下载在互联网上单位时间所占带宽为Ns×N1×Bc,Ns是提供该信息的服务器个数,N1为每个服务器支持同时连接的用户数,Bc为每个用户的连接平均带宽;这里考虑用户为ADSL用户,服务器连接数通常低于1 000,可以假定Bc=512 kbit/s,N1=1 000;则采用服务器/客户机模式,一个应用占用互联网带宽通常为Ns×1000×512 kbit/s=Ns×512 Mbit/s。

    在上述的两个假定之下,一个应用采用服务器/客户机模式的互联网占用带宽通常不超过Ns×min{1 000 Mbit/s,N1×Bc}≤Ns×1000 Mbit/s。

    采用P2P技术应用,在互联网上单位时间所用带宽主要为参与传送该信息的客户数量(Nc)及每个客户为传送该信息所提供的平均带宽(Bc),则可简单由Nc×Bc来表示。这里考虑到互联网宽带用户,则Bc可假设为100 kbit/s(宽带客户提供某信息上行互联网的接入带宽通常高于128 kbit/s,这里假定信息上行带宽为100 kbit/s)。这样,在P2P模式下,信息下载在互联网上单位时间所占带宽为:Nc×Bc=Nc×100 kbit/s。

    比较服务器/客户机模式和P2P模式,得出当Nc>10 000Ns时,P2P模式单位时间所占用互联网的带宽更大,利用互联网采用P2P模式进行信息下载的效率更高。

    也就是说,在用户数量达到一定程度时,P2P类应用对互联网带宽的消耗将更大。另外P2P类应用在用户数增多时,表现出对网络结构更强的适应性,而服务器/客户机模式在用户增多时,由于服务器的数目、能力的限制,导致在服务器端造成拥塞,同时层次化的网络结构使网络不同层次互联环节容易出现带宽瓶颈,从而客观限制互联网带宽的消耗。在服务器/客户机模式下,获取信息用户数的增多,并不会使互联网的带宽消耗增多。

    对于信息下载来讲,P2P技术与服务器/客户机技术相比更能充分挖掘互联网的信息传递潜力。然而,网络上除了P2P类应用之外,还有各种各样的其他应用。在网络没有任何变化的基础上,运营商还无力做到各种需求兼顾,对各种应用进行区分服务或按需服务,P2P类应用效率的发挥无疑会影响互联网上的其他应用。

    总的来讲,P2P类应用使得互联网潜能有了更大的发挥,使带宽资源和客户端计算机资源得到更好应用。用户采用P2P技术分享(获取并提供)信息,可以把用户的接入带宽及计算机能力极大地发挥出来。

    造成网页浏览、邮件收发类应用质量下降是因为用户的互联网接入能力得到了发挥,而运营商骨干网络资源不足,并且在技术上还没有采用好的措施对网页浏览、邮件收发等应用进行保障的原因。

    P2P应用扩大了互联网的信息承载传送能力,给最终用户的信息获取和共享带来益处。对于互联网运营商来说,P2P应用在互联网之上架设了虚拟网络,互联网只是为P2P应用提供了通道,没有因为P2P应用通过互联网运行而获得额外的收益,无论P2P应用怎样发展,运营商只是收取了用户的互联网接入费用,却增加了带宽的过多消耗,出现带宽扩容成本增幅远远大于收入增幅的问题。导致运营商对P2P谈虎色变,但P2P技术对运营商来说也不是一无是处。

    2.2 P2P技术对信息化作出重大贡献

    站在信息化的角度,P2P技术的应用在互联网上得以大量应用,并获得用户的好评,扩大了互联网承载信息的能力,使互联网的应用更加广泛。P2P技术有效利用了互联网用户端设备的计算能力、存储空间、网络带宽等能力,减轻了服务器/客户机模式对服务器相应能力的要求,使得某些应用更容易得到推广。P2P技术提供了更多优质高效的应用,如流媒体传送、文件共享、即时通信,使人们与网络的联系更加紧密,更多利用网络传递信息。P2P技术通过对客户端网络带宽能力的挖掘,客观上扩大了整个互联网络的利用率。

    2.3 对P2P应用应采用技术和管理的手段

    在现有网络条件下,由于互联网的服务区分能力相对较弱,难以保证对关键业务进行重点保护,一些P2P应用对资源过度使用妨碍了其他业务的正常运行。因此,需要对P2P应用进行区分,采用一定的手段进行管理。个人电脑上的P2P应用耗费计算机内存、硬盘、网络带宽资源,可能给用户的其他正常工作带来影响。企业如果不对P2P应用进行管理,一些正常的ERP应用、视频通信、邮件等系统将很难正常运行。运营商互联网上运行的业务种类多,带宽资源紧张,也有对P2P类应用进行管理的需求。

    2.4 扬长避短,发挥P2P的优势

    互联网带宽紧张的成因看似是大量P2P技术应用的结果,而更深层次的原因是用户对带宽的需求、对高服务质量的需求不能得到保证的结果。P2P的某些应用如流媒体应用、基于P2P的内容分发服务等可以优化网络资源的分发及分布,运营商可以利用这些P2P技术,优化网络结构,挖掘网络潜力,提升网络服务质量。

    3、运营商的对策

    P2P流量在互联网上的泛滥,不仅影响了其他应用在网上的使用,而且使运营商扩容应接不暇,带宽增加和收入增加不成比例。各个运营商普遍采取的措施是通过P2P流量控制设备对互联网P2P流量进行鉴别,并采取措施进行封堵。

    目前,P2P流量鉴别技术主要有两种:一是深度数据包检测技术(DPI),即通过对数据包应用层协议检测来发现P2P应用;二是基于流量特征的检测技术,即利用P2P应用在传输层所表现的流量特征,通过流量特征检测技术来识别P2P应用。这两种P2P流量鉴别技术各有优缺点,基于这两种技术的流量控制设备在业界已经有大量应用。通过对P2P流量进行控制,为互联网其他应用提供了较好的质量保证,一定程度减轻了由于服务质量下降给运营商带来的网络扩容压力。

    业界对P2P技术及P2P流量对互联网所带来影响的关注程度越来越高,运营商简单的P2P流量控制措施对互联网整体网络服务质量的改善起到积极作用,但由于侵害P2P使用者的利益而遭到广大P2P拥趸的强烈反对,P2P流量所带来的问题不可能在短期内得以彻底解决,然而要保障互联网业务的正常运行,就必须关注互联网P2P流量,运营商对策建议分为近期目标和远期目标来实施。

    3.1 近期目标

    P2P流量在互联网中所占比例的增加使运营商单纯通过网络扩容所起到的效果越来越不明显,相反却产生投资增加和收入增加的严重倒挂现象。对P2P流量控制,毫无疑问可以减少网络拥塞,给其他应用空出带宽,也可通过P2P技术对互联网流量进行疏导和优化,可以有如下策略。

    3.1.1 对P2P流量进行分区分时控制

    由于P2P应用是架设在现有网络之上的网状网络,现有的结构化网络不适应P2P应用的传送,但为P2P流量的控制带来方便。为了减少P2P流量,可对P2P流量进行分区控制,控制点主要有4个:运营商之间的互联点、运营商骨干网与省网之间的互联点、运营商的城域网出口、运营商的IDC出口。控制点所加载的位置影响P2P应用所受限制的范围。控制点加载在运营商之间的互联点上主要影响运营商的跨网P2P应用,依此类推,影响到省际的P2P应用,影响跨城域的互联网应用,限制IDC的P2P应用。

    互联网流量在一天24 h的分布特征不同,从互联网用户上网行为分析看,10:00和15:00是白天的高峰,20:00、21:00达到一天的上网高峰,在1:00-7:00上网人数最少,这种互联网用户的行为导致早上的互联网流量较少,而白天忙时和晚上忙时的互联网流量很大。对于P2P流量我们可以进行分时控制,空闲时间在网上传送P2P的流量控制可适当放松,而在忙时对P2P的流量控制适当加强。通过分时控制,既保障了互联网的服务质量又使得P2P应用在一定限度内得以使用,使网络能力得以充分发挥。

    3.1.2 利用P2P技术对互联网流量进行疏导

    在P2P技术被广泛关注之前,VoD点播、大型内容网站的内容传送是运营商关注的一个问题,通过组建内容分发网(CDN),站点镜像等措施一定程度上缓解了这些应用对互联网带来的压力。随着P2P技术在互联网的大量应用,基于P2P技术的流媒体技术、基于P2P的CDN技术逐渐成熟,运营商可把P2P技术运用在流媒体传送和互联网内容分发,组建基于P2P技术的内容分发网络,以节省骨干网带宽,同时使互联网基础设施的投资成本及运营成本也得到节省。

    3.2 远期目标

    P2P应用的增长将是一个长期的趋势,单纯对P2P流量的限制不能根本上解决运营商目前面临的问题。从长远来看,还需要在如下几个方面作出努力。

    3.2.1 运营商进行业务模式的创新

    目前互联网接入简单的收费模式使得运营商被排斥在P2P应用价值链之外,P2P应用给运营商带来的只是服务质量的降低和网络扩容的压力,运营商介入P2P应用价值链可从两方面入手。一方面是运营商积极引入P2P类应用,参与到P2P应用价值链中来,譬如,向用户提供P2P类的视频应用,采用P2P技术组建CDN减轻骨干网的流量等。

    当前的业务模式中已经很少采用按照流量进行计费的方式,再加上互联网接入领域激烈的竞争,很难再回到按照流量计费的时代。业界也提出按照应用进行分类计费,按照用户可以接入的应用种类,把各种应用如网站浏览、邮件收发、BT下载等进行分类,根据对用户提供的应用进行计费,但这种业务模式的应用需要专门的认证计费设备,并需要一定的时间进行推广。

    提供内容服务,提供差异化服务,对用户上网行为数据进行挖掘分析,这些都是创建新的业务模式的基础。通过这些措施可以改变目前的互联网接入收费主要是向互联网接入用户进行的前项收费简单模式,增加用户的粘性,并为运营商带来更多收入。

    3.2.2 改进互联网组网结构

    互联网使人与人之间的联系和协作更加紧密,打破了地域和种族的界限,打破了现实世界的社会组织方式,本身是对结构化的组织结构的挑战,同样对结构化的网络也带来影响。在P2P应用在互联网上越来越流行时,多级结构化的组网理念受到冲击。

    P2P应用要求网络尽量扁平化,由于信息源在网络末梢的分布更加丰富,网络越扁平,网络的效率和传送速度将越快。增加互联点,建立多级互联,也是提高运营商与运营商之间的互联效率,提高运营商间互联服务质量的有效措施。

    当然,网络扁平化对网络的管理也带来一定的难度,网络故障排除以及网络优化的复杂度增大。

    3.2.3 更新网络设备

    对用户提供差异化服务,对用户行为进行挖掘分析向当前的网络设备提出了更高的要求,提供差异化服务要求对不同的用户、同一用户的不同应用进行区分,并按需提供不同服务级别的保障。只有更新现有网络设备才能达到这些要求,同时网络扁平化及网络规模的扩大对网络设备的性能也提出了新的更高要求。

    4、总结

    互联网技术一直都是按照发展、遇到问题、找到解决问题的方法、再发展的模式进行的。在今天我们欣喜地看到,依托互联网我们可以做更多的事,互联网成为我们不可或缺的信息工具。

    目前,简单的互联网运营模式、互联网基础设施和组网结构是导致运营商互联网运营困境的根本原因,而P2P技术及P2P应用使得互联网网络能力及网上资源得以充分利用,在整个互联网发展中起到积极的作用。运营商在面对P2P技术及应用时应着眼长远目标,使得互联网运营在健康的轨道上前行。

    展开全文
  • 运营商是指那些提供宽带服务的ISP,包括三大运营商中国电信、中国移动、中国联通,还有一些小运营商,比如长城宽带、歌华有线宽带运营商提供最最基础的网络服务,掌握着通往用户物理大门的钥匙,目前运营商劫持也...

    运营商劫持在如今很普遍,相信很多人还不清楚,什么是运营商劫持?遇到DNS运营商劫持怎么办?本次在这里就为大家科普下。
    什么是运营商劫持?
    运营商是指那些提供宽带服务的ISP,包括三大运营商中国电信、中国移动、中国联通,还有一些小运营商,比如长城宽带、歌华有线宽带。运营商提供最最基础的网络服务,掌握着通往用户物理大门的钥匙,目前运营商劫持也很普遍,百度一下,可以发现有大量反馈反馈这个问题,各种广告弹窗,甚至还可能会窃取用户因素,令人憎恨。
    网络运营商为了卖广告或者其他经济利益,有时候会直接劫持用户的访问,目前,运营商比较常见的作恶方式有两种,分别是DNS劫持、HTTP劫持。
    遇到DNS运营商劫持怎么办?
    1、修改DNS地址
    运营商劫持弹广告,一般是DNS劫持,我们可以通过修改电脑或者手机网络的DNS地址,一定程度上解决弹窗广告的问题。比如,可以将运营商默认的DNS更改为阿里公共DNS、114.114.114.114之类的公共安全DNS,
    2、投诉解决
    宽带被运营商劫持,弹广告,目前最有效的办法就是投诉,电信宽带用户拨打:10000、联通宽带用户打:10010、移动宽带打:10086,然后转人工服务,反馈劫持弹广告问题,一般客服的回复多为将问题又推给用户,这时候直截了当警告,再弹窗就投诉到工信部,一般反馈后,这个问题客服会反馈给运营部,弹窗问题可能随后就解决了。
    对于这个投诉,如果打一次不解决,可以天天打运营商服务商服务热线投诉。他们最怕这个,投诉多了月底要扣奖金的,一般机房可能会为你单独处理,不在你的IP上不跳广告。
    据说,运营商劫持很多是运营商的网管和CDN服务商私下偷偷干的,这行属于暴利,劫持一天轻松赚6位数。相当于所有被劫持用户电脑每天为这些非法分子赚广告费,遇到了大家果断投诉吧。
    IIS7网站监控可以做到提前预防各类网站劫持、并且是免费在线查询、适用于各大站长、政府网站、学校、公司、医院等网站。他可以做到24小时定时监控、同时它可以让你知道网站是否被黑、被入侵、被改标题、被挂黑链、被劫持、被墙及DNS是否被污染等等功能、更是拥有独家检测网站真实的完全打开时间、让你作为站长能清楚的知道自己网站的健康情况!
    官方图在这里插入图片描述
    在这里插入图片描述官方地址:IIS7网站监控
    3、偏方解决方法
    这里首先提供给大家一个解决运营商弹广告偏方,这个是网上网友分享的,目前来看,确实起到了作用了。
    只要在百度搜索“被运营商劫持了怎么办”,然后就好了,亲测两次有效!笔者用的是山东联通宽带,搜索了之后,确实没有了弹窗广告。这点来看,运营商还是很狡猾的,当发现用户知道被劫持后,明显收敛了。
    当然,这个目前是偏方,目前测试了联通宽带有效,至于移动、电信宽带就不清楚了,遇到的朋友,不妨试试。
    以上就是我介绍的什么是运营商劫持 遇到DNS运营商劫持怎么办,希望对你有帮助。
    一、什么是运营商劫持
    什么是运营商:
    运营商是指那些提供宽带服务的ISP,包括三大运营商中国电信、中国移动、中国联通,还有一些小运营商,比如长城宽带、歌华有线宽带。运营商提供最最基础的网络服务,掌握着通往用户物理大门的钥匙,目前运营商劫持很普遍。
    举个劫持的栗子:
    劫持方式:
    运营商比较常见的作恶方式有三种,分别是DNS劫持、HTTP劫持、HTTPS劫持:
    DNS劫持:这种劫持会把你重新定位到其它网站,我们所熟悉的钓鱼网站就是这个原理。但是因为它的违法性,现在被严厉的监管起来,已经很少见。
    HTTP劫持:虽然DNS劫持已经被监管了起来,但是还有HTTP劫持啊!你DNS解析的域名的IP地址不变,当运营商发现你的是HTTP请求时,就会在里面插入一些奇奇怪怪的广告(比如一些banner、浮标、更有甚把你你的商品位给劫持了 WTF…)并且这种现象十分常见,不信你可以试着随便打开一个网页,仔细看看你就会发现一些小尾巴,这就是被HTTP劫持了。
    HTTPS劫持:安全的超文本传输协议,数据加密这也能劫持?答案是肯定的!该劫持方式有两种:
    伪造证书,通过病毒或者其他方式将伪造证书的根证书安装在用户系统中(较少)
    代理也有客户的证书与私钥,或者客户端与代理认证的时候不校验合法性,即可通过代理来与我们服务端进行数据交互(较多)
    备注:使用本篇的代码一定会让你查到HTTPS劫持的(前提是使用了https)
    二、防运营商劫持
    准确的来说是防script、iframe注入型劫持,95%以上是这种劫持方式,因为DNS劫持被严管了。
    运营商是如何劫持的,网上有很多资料,这里不多逼逼
    下面是防劫持代码:

    防劫持代码测试
    防劫持代码测试
    <div class="bro">
    
    
      <div class="xiongdei">
    
    
        <script src="https://mt.cnzz.com/js/hdpi_canvas.js"></script>
    
    
      </div>
    
    
    </div>
    

    复制代码

    加入运营商劫持代码后,不在白名单和安全标签(shendun-eddy)内的script或者iframe都会被remove掉。
    提示:network内能看到加载了其他非白名单内的script代码,但它们都没有执行
    以 yun.dui88.com/qiho-h5/jqg… 为例,代码如下:

    ;(function(){

    console.log(‘哎哟,我来劫持你了…’);

    })()

    复制代码

    核心功能
    MutationObserver()创建并返回一个新的 MutationObserver 它会在指定的DOM发生变化时被调用。
    具体参数和用法传送门:developer.mozilla.org/zh-CN/docs/…
    兼容性
    所有浏览器的兼容性是92.79%,手机端的兼容性更高,代码中加了保护所以放心使用吧!
    三、总结
    目前运营商劫持率大约是3% ~ 25%,它们无处不在。
    为了还用户一个干净安全的浏览环境,我们需要做好预防措施
    全站https,能防一部分
    加入防运营商劫持代码,能防大部分注入型劫持
    记录Log,记录证据,向工信部投诉

    展开全文
  • 运营商行业是数据泄漏的重灾区之一。例如2015年10月,英国大的宽带服务提供商TalkTalk,遭受了三次黑客攻击,约400多万用户的隐私数据被泄露,这可能是英国史上大规模的数据泄漏事件之一。而在美国,美国移动电话...
  • 如何应对运营商插入的广告: 1.运营商告知缴费信息不在下列讨论范围。 2.理性投诉,不要辱骂客服人员,你说问题,让他给你记录反馈即可。 简要流程为:(工信部投诉之前务必先拨打运营商客服热线受理) 具体流程为: ...
  • 为您提供360宽带测速器下载,360宽带测速器是一款由360安全管家中提取的360宽带测速器独立版,使用这款360宽带测速器可以让你在任意Windows...测试宽带接入速度采用P2P+HTTP的测试方法,评估电脑到本地运营商的最大接入
  • 正则表达式判断所填入号码的运营商js代码修改版:http://www.jb51.net/article/31563.htm在做WEB项目时,有时候需要根据用户的输入手机号码判断该号的运营商是移动、联通、电信或其他,再根据不同的运营商做出相应的...
  • 运营商是指那些提供宽带服务的ISP,包括三大运营商中国电信、中国移动、中国联通,还有一些小运营商,比如长城宽带、歌华有线宽带运营商提供最最基础的网络服务,掌握着通往用户物理大门的钥匙,目前运营商劫持也...
  • 引言:家里接入300M的宽带,但是自我感觉网速不佳,遂结合所学知识,对此问题进行分析、研究和调察,最后有所感悟,如遇到类似情况,可以阅读此文解决。本文可能不定期更新,最后会显得些许冗杂,还请各位耐心阅读。...
  • 运营商网络IP地址分配原则

    万次阅读 2019-09-25 15:52:26
    相关文章:你的宽带运营商偷偷分配了内网IP怎么办?! 不过也可能有人不知道自己到底是不是被分配到了内网IP,我还给大家准备了一个查询 方法: 1、进入IP138网站查询你的IP地址(进入后自动检测,无需操作)...
  • 放眼我们的生活和工作,现在已经完全依赖于网络了。互联网的爆炸式发展,让我们的上网方式也由最早的 56K Modem 拨号上网到 ISDN、ADSL,直到现在逐渐普及的...不过,有些黑心运营商的虚假宣传,坑坏了不少用户,我...
  • 在《同运营商多条外线如何做负载均衡?》一文中,我们介绍了多条外线(同一个运营商)时如何进行负载均衡。在实际使用中,很多用户的外线是不同运营商的(比如一条电信和一条移动)。对于大部分用户来说,采用《同...
  • 运营商5G商业模式研究

    千次阅读 2021-09-01 00:28:29
    ‍‍ 1、 5G产业发展分析 1.1 全球5G发展现状 2021年5月,全球133个国家/地区的443家运营商正在投资5G建设,其中42.4%的运营商在现网上推出符合3GPP标准的5G移动或FWA(Fixed Wireless Access)服务,128家设备商...
  • 电信家用宽带作为商用的问题

    千次阅读 2020-03-29 01:01:43
    现在正在做的一个项目,使用了两条电信家用宽带用于商用,单条线路300M,在使用过程中才发现家用宽带是不能用于商用的。 在使用的最开始投入使用的时候,就出现问题,当时是我同事在现场测试,macbook在连接wifi的...
  • 要使两条线路实现负载均衡的功能,不能简单的做静态路由来实现,因为运营商的线路断了,在自己的交换端口上是无法感知到DOWN的(运营商使用了光收接入)。于是我询问了相关技术人员得知是可以使用BFD技术来感知链路...
  • 运营商流量劫持

    千次阅读 2016-08-05 10:16:32
    最近了解了一下运营商流量劫持,文章很多,但感觉很零碎,在这里把众多文章内容串一下,清晰一下思路。下面多是引用,引文在附录里,就不一一标识了。对于传统的流量劫持请见引文1,这里不作介绍。 运营商流量...
  • 运营商屏蔽80端口,移动封80端口,80端口穿透,免费80端口穿透
  • 但是,与动态路由协议不同,静态路由自身没有检测机制,当网络发生故障时,静态路由无法感知,需要由管理员介入,这样无法保证及时进行链路切换,可能造成业务较长时间中断。 部署BFD for静态路由的方案可以适应链路...
  • 连接数测试工具 用户测试ISP给你多少连接数
  • 移动、联通和电信三大运营商支持的手机网络模式分别为: 1、中国移动 移动4G:移动TD-LTE; 移动3G:TD-SCDMA; 移动2G:GSM。 2、中国联通 联通4G:联通TD-LTE,联通FDD-LTE; 联通3G:WCDMA; 联通2G:GSM...
  • 上来先说一句,其实我对运营商DNS劫持了解不深,这个标题起的有点俏,还请见谅。 什么是DNS劫持 查百度百科《DNS劫持》我们可以知道:“DNS劫持又称域名劫持,是指在劫持的网络范围内拦截域名解析的请求,分析...
  • 中国互联网经过这么多年的沉浮,地下黑色产业链已经有了很大的变化。随着免费杀毒软件的流行,中国互联网发生了...买卖流量对黑产来说有一个好处,就是风险低,而且收益高,甚至连运营商都忍不住加入这场饕餮盛宴,通过
  • 4、具有故障检测的功能, 极大的方便了运营商的维护和用户的使用。5、具有计时功能,能查询用户的详细上网纪录。6、界面友好,使用方便。7、对个人用户免费。8、解决了共享时客户端不能访问一些网站的问题。9、在线...
  • 揭秘三大运营商在5G专网的布局!

    千次阅读 2020-08-17 18:24:25
    我国主要为依靠运营商,利用边缘计算、网络切片技术建立虚拟专网,目前运营商正积极与各行各业合作建设虚拟5G专网,三大运营商中国移动、中国联通、中国电信皆推出自身专网解决方案及发展路径。 01、中国移动为5G...
  • DNS劫持,又叫DNS重定向攻击,就是将用户导向到非预期网站的行为...IIS7网站监控可以及时防控网站风险,快速准确监控网站是否遭到各种劫持攻击,网站在全国是否能正常打开(查看域名是否被墙),精准的DNS污染检测,具
  • AI能力在运营商应用中的畅想一、机房智能运维二、基站智能运维三、无人营业厅四、宽带故障用户咨询五、自有APP精准推荐 一、机房智能运维 智能机器人在机房巡检过程中将采集图像、视频、声音等信息,通过人工智能...
  • 运营商进行网络劫持的前生今世+劫持的危害 2016-02-06 00:00:52 +08:00  raysonx 西元 2016 年 2 月 5 日晚 (注:本人只是一名技术人员,凭专业知识和经验写成本文,并非运营商员工,如有错误还请各位看官指出...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,960
精华内容 1,984
热门标签
关键字:

宽带运营商检测