精华内容
下载资源
问答
  • VC++简易计算器,能实现简单的计算,满足日常基本要求。
  • 支持多项式运算 支持对数运算 支持指数运算 支持三角函数运算 支持2进制,8进制,10进制和16进制之间的相互转换.
  • 这是个用栈编写的计算器,支持带任意括号的混合四则运算,以及指数对数,三角函数等运算
  • 网页计算器 基本的四则运算 三角函数 对数 指数等
  • 指数/对数/WIN10计算器

    2020-07-25 20:01:35
    由x产品的灵敏度计算公式,引出对数函数和指数函数的回顾学习,并讲解了如何在PC计算器软件中执行指数和对数运算..

    概述

    刚进入一个新领域,在计算灵敏度(sen=log10Vm)时,或者已知Sen求取Vm的值时,要用到幂运算和对数运算,你学过高数吗,突然感觉脑子让狗吃干净了…

    指数/对数

    该章节先从最直观的对数函数、指数函数图像开始重启一波学习。基本初等函数,幂函数(y=xa)、指数函数(y=ax)、对数函数(y=logax)、三角函数、反三角函数、常数函数。直观了解后,在深入幂运算和对数运算法则…

    函数图像

    • 一般地,形如y=ax(a>0且a≠1)的函数叫做指数函数(exponential function) ,指数函数图像大约如下:
    • 一般地,函数y=logax(a>0,且a≠1)叫做对数函数,也就是说以幂(真数)为自变量,指数为因变量,底数为常量的函数,叫对数函数。
    指数函数图像 对数函数图像
    在这里插入图片描述 在这里插入图片描述

    a不能是负数?

    Here我们不研究函数图像的单调性,只探讨下函数的定义域。在对数函数定义中,函数的定义域是(0,+∞),即x>0。它实际上就是指数函数的反函数,可表示为x=ay。因此指数函数里对于a的规定,同样适用于对数函数。指数函数和对数函数都规定了a的取值范围是 a>0且不=1,但是对幂运算来说没有这种规定。
    如果ax =N(a>0,且a≠1),则:
    在对数运算中,数x叫做以a为底N的对数,记作x=logaN,读作以a为底N的对数,其中a叫做对数的底数,N叫做真数
    在幂运算中,指数是幂运算aⁿ(a≠0)=N中的一个参数,a为底数,n为指数,幂运算表示指数n个底数a相乘,幂(power)N是指乘方运算的结果。
    底数,既是指数函数中的a,也是对数函数中的a,先辈们人为的规定了它不能是负数。
    对数的底不能为负的原因并不是不存在负数的底数,而是人为的规定,人们为了简化对数的求解与研究,人为规定了对数的底必须是正数,即大于零的数,这样由于正数的任何次方的数都大于零,所以真数(和对数相匹配的一个概念)自然而然的肯定要大于零。指数函数的底我们也强行规定为正,因为底为负的指数函数,它的图像是不连续的,我们很难研究它的特性,而对数又是指数函数的反函数,所以可以很容易理解为什么人们也把对数的底规定为正数。

    幂函数

    在数学中指数是幂运算aⁿ(a≠0)中的一个参数,a为底数,n为指数,幂运算表示指数n个底数a相乘。指数函数和幂函数都是在做幂运算,下边对其区别做简单整理:

    • 指数函数 y=ax
      以指数为自变量 ,a>0,a≠1
    • 幂函数y=xm
      以底数为自变量,m≠1 可正可负

    一般地,y=xm(m为有理数)的函数,即以底数为自变量,幂为因变量,指数为常数的函数称为幂函数。例如函数y=x0、y=x1、y=x2、y=x-1、y=x-1/2、y=x3/4等都是幂函数。幂函数的定义域值域以及就特性都是相对复杂,此处不再深究。一些常见幂函数的曲线如下图:
    在这里插入图片描述
    幂运算的词条真的是写太烂,说它词不对题也不过。我们通过幂函数的词条来理解些基本的幂运算表示含义:
    在这里插入图片描述

    基本运算

    幂运算和对数运算的常见公式有,不讨论其推导过程。

    幂运算常见公式 对数运算常见公式
    在这里插入图片描述 在这里插入图片描述

    计算举例
    10-0.25 = 10-1/4 = 1/(101/4) = 1 / 104\sqrt[4]{10} = 1/1.7782794 = 0.56234
    在PC中使用计算器验证上述过程(具体方案参考下边的相关章节),直接在calc中进行指数计算(输入10-0.25 ),或计算104\sqrt[4]{10} 然后取倒数,计算结果一致。

    WIN10计算器-科学模式

    打开计算器

    使用WIN+R打开“运行”对话框,输入calc执行确认后,选择计算器模式为科学型,如下图:

    Win10企业版 WIN10教育版
    在这里插入图片描述 在这里插入图片描述

    操作界面说明

    • MS / MR / MC / M+ / M-
      该系列按钮的具体使用过程可参考百度经验
      MS:memory save,将显示框的数值存于存储器中,以后续实用。
      MR:memory read,将存于存储器中的数显示在计算器的显示框上。
      MC:memory clear,清除存储器中的数值。
      M+:将显示框的数与存储器中的数相加并进行存储。
      M-:将显示框的数与存储器中的数相减并进行存储。

    • CE / C / Del(叉号)
      在这里插入图片描述
      有的系统中计算器显示上的C/CE键共用一个位置,有的系统中它们各自占用一个位置,这破玩意我总是感觉它特别的难用,以前我都是怼着一个一个点击,直到存储器显示位置变成0为止。
      在这里插入图片描述
      在Win10教育版计算器中,初始时位置显示为C,输入一位数字(如数字1)后变为CE,然后再输入+号和一个数字(如数字2),点击CE后,新输入的数字被删除,且CE又变成了C键显示,但显示区依然显示"1+",也就是说+号并未被删除,此时可以直接再输入别的加数进行后续计算。当点击了一次等号即完成了一次计算后,点击CE键,则内存显示处将被清零。
      CE:clear error ,纠错的意思;C键代表全清除,是归零复位的意思。
      当输入的数字很长时,可以按叉号键,逐位删除。

    • DEG / RAD / GRAD
      点击DEG位置,会在上述三种模式上循环切换,它们指的是计算器可以采用的角度的3种单位。D(DEG)、 R(RAD)、 G(GRAD) 分别表示:角度制,弧度制,百分度制。

    • HYP
      点击此位置后,三角函数的显示变成了下边的样子。它代表的是,设置sin、cos、tan的双曲线函数,主要应用在计算机当中计算器软件的科学型,完成一次计算后自动关闭双曲线函数功能。暂时用不到,不去深究啦。
      在这里插入图片描述

    • F-E
      点击F-E位置后,变化如下。打开或关闭科学计数法。大于10^32的数总是以指数形式表示。F-E只能用于十进制数字系统。
      在这里插入图片描述

    • 2nd按键(见第二张计算器图)
      这里的2nd是Second Function (第二功能)的意思,其实在实体计算器上,该按键是常见的。如有些计算器的x^2和√x是一个键,如不先按下2ndF这个键,则这个键的功能是计算平方,若先按下2ndF,则再按这个键则计算根号。

    第一功能 第二功能 第二功能
    在这里插入图片描述 在这里插入图片描述 在这里插入图片描述
    点击2nd按键进行功能切换 在Win10企业版中,
    点击向上的箭头切换第二功能

    有点跑远了,其他的PC计算器按键含义,请去参考这篇文章,有更详细的说明。

    指数运算

    在计算器中输入105 步骤如下:

    step1 step2 step3 step4
    10 在这里插入图片描述 5 =

    在计算器中输入100.25 步骤如下:

    step1 step2 step3 step4
    10 在这里插入图片描述 0.25 =

    在计算器中输入10-0.25 步骤如下:

    step1 step2 step3 step4 step5
    10 在这里插入图片描述 0.25 在这里插入图片描述 =

    PS-注意这里的符号必须要后输入,否则负号将被识别到底数上。

    在计算器中进行开n次方运算164\sqrt[4]{16}

    step1 step2 step3 step4 out
    2nd
    切换
    16 在这里插入图片描述 4 在这里插入图片描述

    对数运算

    计算常用对数 log10100

    step1 step2 step3 /
    10 在这里插入图片描述 =

    计算普通对数呢 logab
    以前,PC计算器并不能直接输入执行上述计算过程,而是必须要使用对数预算换底公式,化为常用对数或自然对数。比如想算:log2(16),计算思路:用lg16/lg2或ln16/ln2就能算出最终结果。
    在这里插入图片描述
    计算普通对数呢 logab
    现在win10的附件计算器中是具有直接计算任意对数功能的,(Win10教育版)计算器-科学模式-2nd-logyx功能键。测例log2(16)同上,输入顺序与结果如下:

    step1 step2 step3 out_show
    16 在这里插入图片描述 2 在这里插入图片描述
    展开全文
  • 科学计算器,可以实现键盘输入和按钮点击功能,还有可以实现三角对数和指数的运算
  • 总共有19 钟运算功能加,减,乘,除,平方,开方,N次方,开N次方,正弦函数,余弦函数,正切函数,反正弦,反余弦,反正切,对数运算,阶乘(N<=34),排列,组合,累加! 功能键有,复位键,回删键,确定键,第...
  • 基本四则运算 小数点后至少包含2位 实现任意数平方,开方,三次方。开三次方 实现0到1之间随机数,小数点后至少3位 计算响应时间小于1秒 扩展功能 实现自然对数,和以10为底的对数 三角函数,反三角函数 用科学技术...
  • c++写的计算器运算代码,包含基本运算、三角函数运算、对数运算
  • 计算器代码采用栈的思想能进行四则混合运算,同时还包含了指数运算,经过很多次实验是成功的,而且显示很正确,易一直到单片机做的计算器上去
  • 这是一个简单科学计算器,有对数、平方、开方、三角函数、支持连式混合运算
  • 如何实现对数ln运算

    万次阅读 2015-12-11 21:29:07
    好朋友Z说他们期末得设计一个计算器对数ln的运算挺麻烦的。 我想,这不是就是泰勒展开的事吗? 泰勒展开1.0 立刻想到了这个嘛: 然而,跑一下程序的结果是这样的: 1.1 循环的次数多——Peano余项为o...

    好朋友Z说他们期末得设计一个计算器,对数ln的运算挺麻烦的。

    我想,这不是就是泰勒展开的事吗?

    泰勒展开1.0

    立刻想到了这个嘛:


    然而,跑一下程序的结果是这样的:


    1.1 循环的次数多——Peano余项为o(x^n),收敛的速度慢;x越接近2,收敛就越慢。

    1.2 当x>1时,增量不收敛,然后答案跑不出来了= =

    因为设置的跳出循环的条件为:

           

    while(fabs(delta/i)>Epsilon)

            所以这样展开将进入死循环

    面对这1.1和1.2两个缺陷,我不由得觉得自己最开始想得太天真。

    泰勒展开2.0

    教材上的一道例题——提高ln2的求解精度,同时解释了1.0泰勒展开的缺陷:


    (《数学分析(上) 第二版》陈纪修 等著 P208 )

    因为Peano余项的Taylor展开是以x逼近x0为前提的,所以当x远离0的时候,Maclaurin公式的精度将会很低

    受此启发,当采用换元法之后:


    这样进行Talyor展开:


    2.1 因为对数函数的定义域大于0,可知——不管α取定义域内何值,t始终在0~1之间,比泰勒展开1.0更逼近x0=0

    2.2 始终是收敛级数

    2.3 收敛速度快——Peano余项为o(t^(2n+2)),更容易增长到更高阶

    高兴地跑了跑程序:

    (图中的“第一种”是泰勒展开2.0,“第二种”是泰勒展开1.0


    上述的几大特点都体现出来了——循环次数少、精度更高、适用范围更广,然而——

    2.4 可知当α逼近+∞时,t逼近1,与x0=0距离太远,精度降低(图中对于10000连0.1精度都没达到)


    泰勒展开3.0

    目前的问题,集中在大数的求对数上了。

    最开始想类比换元法,设计一个定义域控制更加严格的t的换元法,无果。

    后来觉得——大数应该拆成小数!

    举个例子: ln(123456)=ln(1.23456*10^5)=ln(1.23456)+5ln10


    对于α小于10,用泰勒展开2.0,当α>10就视为大数,拆为k倍ln10和lnN (0<N<10)之和,lnN精度用泰勒展开2.0保证在10e-6,而ln10的值事先存储:

    #define ln10 2.30258509299404568401
    

    然后跑一跑程序:

    (“第一种”为泰勒展开3.0,“第二种”为泰勒展开2.0,,“第三种”为泰勒展开1.0



    泰勒展开3.0的优点是:

    3.1 大数运算精确

    3.2 循环次数少,收敛速度快 (0-20次,图中后两次有误,无碍)

    3.3 不远离x0=0,精度高


    缺点有:

    3.4 对于ln0.1这样的小数运算精度反倒不如泰勒展开1.0

    3.5 由于有两个lnN,不能明确确定精度范围

    优化思路大抵如上,但剩下的这些缺点如何解决?实际上ln的运算是如何实现的呢?我们可以越挖越深......感谢Z提供了一个如此有思考价值的问题~吐舌头


    附C语言代码如下:

    #include "stdafx.h"
    #include <math.h>
    #define Epsilon 10e-6
    #define ln10 2.30258509299404568401
    
    long double ln(long double c)
    {long double s2=0.0,delta;int i=1;
    if(c==1) 	{printf("循环次数为%d\n",i-1);return 0;}
    c=(c-1.0)/(c+1.0);//Marclurin公式变换技巧
    	delta=c;i=0;
    	do{ s2+=delta/(2*i+1);
    		delta*=c*c;i++;
    }while(fabs((2*delta)/(2*i+1))>Epsilon);
    	printf("循环次数为%d\n",i-1);
    return 2*s2;
    }
    
    int main()
    { long double c,s1=0.0,s2=0.0,input,delta,standard;int i=1,j=1,d;
    	while(1)
    	{
    	printf("精度为10e-6\n");
    	printf("ln");
    	scanf("%lf",&c);
    	
    	if(c==1) {printf("%.10lf\n",s2);return 0;}
    	else { printf("第一种展开方式——————\n");//泰勒展开3.0
    		input=c;
    		for(d=0;input>=10;d++)input/=10;
    			printf("结果为:%.10f\n",d*ln10+ln(input));
    		
    	    printf("第二种展开方式——————\n");//泰勒展开2.0
    	    printf("结果为%.10f\n",ln(c));
    	
    		if(c>2.0) //泰勒展开1.0
    		{printf("第三种展开方式——————\n当x>1时增量不收敛,第三种展开方式进入死循环\n");
    		goto start;
    		}
    		input=c-1.0;//方便使用Maclaurin公式
    		delta=input;i=1;
    		do{ 
    		if(i%2) s1+=delta/i;
    		else s1-=delta/i;
    		delta*=input;i++;
    		}while(fabs(delta/i)>Epsilon);	//当x>1时增量不收敛,进入死循环
    		printf("第三种展开方式——————\n");
    		printf("循环次数为%d\n",i);
    		printf("结果为%.10f\n",s1);
       
     start: printf("Windows计算器结果为:");
    		    scanf("%lf",&standard);
    		    putchar('\n');
    			s1=s2=0.0;i=j=1; 
        }
    	}
    return 0;
    }
    




    展开全文
  • 易语言的算术运算命令包括:相乘,相除,整除,求余数,相加,相减,负,取符合,取绝对值,取整,绝对取整,四舍五入,求次方,求平方根,求正弦,求余弦,求正切,求反正切,求自然对数,求反对数,是否运算正确,...

    易语言的算术运算命令包括:相乘,相除,整除,求余数,相加,相减,负,取符合,取绝对值,取整,绝对取整,四舍五入,求次方,求平方根,求正弦,求余弦,求正切,求反正切,求自然对数,求反对数,是否运算正确,置随机数种子,取随机数命令,本课分别了重点讲解和示范,特别是取整和绝对取整的区别等等....

    511遇见(www.511yj.com)

    511遇见(www.511yj.com)

    511遇见易语言教程

    易语言源码:

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 _按钮_运算_被单击
    
    
    .判断开始 (组合框1.现行选中项 = 0)
        编辑框3.内容 = 到文本 (到数值 (编辑框1.内容) × 到数值 (编辑框2.内容))
    .判断 (组合框1.现行选中项 = 1)
        编辑框3.内容 = 到文本 (到数值 (编辑框1.内容) ÷ 到数值 (编辑框2.内容))
    .判断 (组合框1.现行选中项 = 2)
        编辑框3.内容 = 到文本 (到数值 (编辑框1.内容) \ 到数值 (编辑框2.内容))  ' 整除
    .判断 (组合框1.现行选中项 = 3)
        编辑框3.内容 = 到文本 (到数值 (编辑框1.内容) % 到数值 (编辑框2.内容))  ' 求余数
    .判断 (组合框1.现行选中项 = 4)
        编辑框3.内容 = 到文本 (到数值 (编辑框1.内容) + 到数值 (编辑框2.内容))
    .判断 (组合框1.现行选中项 = 5)
        编辑框3.内容 = 到文本 (到数值 (编辑框1.内容) - 到数值 (编辑框2.内容))
    .默认
    
    .判断结束
    
    
    .子程序 __启动窗口_创建完毕
    
    组合框1.现行选中项 = 0
    
    .子程序 _按钮1_被单击
    .局部变量 a, 双精度小数型
    .局部变量 b, 双精度小数型
    .局部变量 c, 双精度小数型
    
    
    ' 调试输出 (1 % 2)
    ' 取整
    
    ' 调试输出 (取整 (1.23))
    ' 调试输出 (取整 (0.23))
    ' 调试输出 (取整 (-1.23))
    ' a = “-1.01”
    
    ' 调试输出 (取整 (到数值 (a)))
    ' 调试输出 (取整 (-7.8))
    ' 调试输出 (绝对取整 (13.69))
    
    ' 调试输出 (取符号 (-99999))
    ' 调试输出 (取绝对值 (3))
    
    
    .' 如果 (是否运算正确 (求平方根 (4)) = 真)
        ' 信息框 (“运算正确”, 0, , )
    .否则
        ' 信息框 (“运算错误”, 0, , )
    .如果结束
    
    ' a = 3.1415
    ' b = 1.2
    ' c = a × b
    
    ' 信息框 (是否运算正确 (c), 0, , )
    置随机数种子 ()
    画板1.清除 (, , , )
    画板1.写出 (取随机数 (10, 100))
    
    

    源码:易语言教程算术运算

             511遇见易语言教程

     

     

     

     

     

     

     

     

    展开全文
  • 例题一 牛顿迭代 或 二分查找 判断是否是有效完全平方数 ...x的平方根 牛顿迭代+二分查找+袖珍计算器法 官方解答 内置的ln函数就是log不带底 二分越界避免 (left+right)/2换成left+(right-left)/2 ...

    例题一

    牛顿迭代 或 二分查找 判断是否是有效完全平方数

    在这里插入图片描述在这里插入图片描述
    注意看java和python的区别(除法取整+循环结构书写)
    注意各种语言代码的细微差异

    例题二

    x的平方根 牛顿迭代+二分查找+袖珍计算器法
    官方解答

    内置的ln函数就是log不带底
    二分越界避免 (left+right)/2换成left+(right-left)/2

    展开全文
  • 科学计算器

    2018-12-26 19:53:46
    使用C语言写的科学计算器,可以实现四则运算、三角函数运算、指对数运算;优先级正确;能智能屏蔽空格,能识别输入错误和运算错误,能实现继续运算、清空运算结果和有效退出的功能
  • 对数运算(log,ln),幂运算(x^y)等科学计算。 (3) 使用按钮BACKSPACE,CE,C清除当前的输入。 (4) 使用智能键M-、M+、。键入数字后,按M+将数字读入内存,按下M-则把该数字从内存中删除。 (5) 计算时可使用...
  • 让表达式计算器支持函数运算 1.FunctionTable的实现 对于一个好的科学计算器,内置函数是必需的。计算器必须能计算平方根、对数、三角函数等等。因此,我们要让解析器识别这些函数,并调用适当的数学库函数。 ...
  • Android计算器

    2013-10-14 13:05:13
    Android计算器,实现了三角函数、对数运算等函数,还支持二进制、十进制、十六进制之间的转换。
  • JAVA简单计算器

    2014-03-18 23:04:48
    此代码是用Java写的简单计算器,实现简单的四则运算和对数运算,bug也有挺多,继续努力!
  • C语言计算器

    千次阅读 2018-06-14 07:44:49
    功能:使用C语言写的科学计算器,可以实现四则运算、三角函数运算、指对数运算;优先级正确; 能智能屏蔽空格,能识别输入错误和运算错误, 能实现继续运算、清空运算结果和有效退出的功能 ********************/...
  • Java计算器

    2016-05-15 20:31:01
    用Java写的计算器,用户界面做的还不错,实现了加减乘除、对数、幂运算,功能强大,你值得拥有。
  • 一个计算器,有多种功能,如取对数、求平方根。最重要的是利用堆栈算法实现运算符优先级。
  • 简单计算器

    2016-07-20 16:21:30
    闲暇时刻帮别人写的简单计算器,可以四则运算,三角函数,对数,等等,希望大家帮忙指教。
  • 计算器模拟

    2015-06-13 09:48:23
    计算器可以完全实现双精度浮点型的加减乘除的基本运算,并且以双精度浮点型的结果输出,此计算器还可以实现三角函数的运算,还可以进行对数和指数的运算,并且额外添加了阶乘,取余,取相反数,取百分比等简单功能...
  • 科学 计算器.cpp

    2021-03-25 21:44:28
    模拟Windows中的计算器程序,实现基本数学运算、数学函数、进制转换等功能:加、减、乘、除、阶乘、正弦、余弦、开平方、指数、对数运算,十进制数、二进制数、八进制数、十六进制之间的相互转换。要求以菜单形式选择...
  • 基于MFC的简单计算器程序代码。实现最基本的加减乘除四项基本运算、平方、对数运算以及一些简单的混合运算(逆波兰算法)。
  • VC++计算器

    2015-11-10 21:07:38
    实现计算器的功能。用户根据程序提示,输入数字或字符,选择要进行的运算,可以进行正弦、余弦、正切、开方、对数、加、减、乘、除、华氏温度与摄氏度之间的换算以及平方根的运算
  • 多功能计算器

    2012-12-23 10:25:53
    实现了计算器的基本功能,指数对数运算,括号识别等

空空如也

空空如也

1 2 3 4 5 ... 13
收藏数 243
精华内容 97
关键字:

对数运算计算器