精华内容
下载资源
问答
  • 1.公网ip私网ip 外网IP是全世界唯一的IP地址,仅分配给一个网络设备。公网IP地址全世界仅分配给一个网络设备(比如你在家拨号,分配给你一个IP地址吧,那个地址是唯一的,你用你机器做个网站,别人访问你的IP地址...

    1.公网ip和私网ip

    外网IP是全世界唯一的IP地址,仅分配给一个网络设备。公网IP地址全世界仅分配给一个网络设备(比如你在家拨号,分配给你一个IP地址吧,那个地址是唯一的,你用你机器做个网站,别人访问你的IP地址就可以连接到你的机器);而内网IP是由路由器分配给每一部内部使用的IP地址,而内网的所有用户都是通过同一个外网IP地址进行上网的。

    内网IP局域网,网线都是连接在同一个 交换机上面的,也就是说它们的IP地址是由交换机或者路由器进行分配的。而且每一个IP也是有所不同的,并且这些连接在同一个路由器上的电脑都可以通过internet连接共享的,也就是说网吧里面的电脑是可以访问网吧内另外一部电脑的。

    区别是内网的IP地址每个人的都不一样,Internet上的用户也无法直接访问到内网用户。简单来说呢,外网IP就是标示了您在整个互联网上的地址,就相当于小区的地址,而内网IP呢,就是标识着您在局域网里面的地址,也就是小区内的几栋几楼几号房子。你家比如有2台电脑,通过一个路由器接好,为了区分每台电脑每台电脑分配一个内部的IP地址,比如192.168.0.2 这个地址是内部的,也叫私网地址,这两台电脑都是通过一个外网IP地址上网的,但他们每个人还有个内网的地址,内网的地址外网不能直接访问。

    2.静态ip和动态ip

    一、静态IP与动态IP区别:

    1、动态IP需要在连接网络时自动获取IP地址以供用户正常上网,而静态IP是ISP在装机时分配给用户的IP地址,可以直接连接上网,不需要获取IP地址。

    静态IP是可以直接上网的IP段,该IP在ISP装机时会划分一个IP地址给你,让计算机在连接网络时不再自动获取网络地址,避免了网络连接上的困扰。

    2、动态IP和静态IP对网速的影响,ISP对每个用户所提供的网速,并不是从IP地址限定的,而是从用户连接到ISP的物理线路上进行限定的。

    3、ISP分配的静态IP地址ISP赠送IP地址的情况是不可能存在的。准确的应该说是ISP将IP地址租借给用户使用。因为在目前IPv4地址已经分配完毕,严重稀缺的情况下。ISP是不可能随便将一个IP地址赠送给用户的。

    二、静态IP与动态IP使用:

    1、动态IP上网,又叫做DHCP上网。自动获取IP上网。动态IP这种上网方式,在未使用路由器的情况下,只需要把这根宽带网线连接到电脑上,电脑上的IP地址设置为自动获得,电脑就可以实现上网了。

    2、静态IP上网,又叫做固定IP地址上网。这种上网方式,宽带运营商会提供一根一个IP地址、子网掩码、网关和DNS服务器地址给用户。在未使用路由器的情况下,只需要把这根入户网线连接到电脑上,并且手动设置电脑上的IP地址,这样电脑才能上网。

    3.路由器和交换机

    1. 交换机

    在计算机网络系统中,交换机是针对共享工作模式的弱点而推出的。交换机拥有一条高带宽的背部总线和内部交换矩阵。交换机的所有的端口都挂接在这条背 部总线上,当控制电路收到数据包以后,处理端口会查找内存中的地址对照表以确定目的MAC(网卡的硬件地址)的NIC(网卡)挂接在哪个端口上,通过内部 交换矩阵迅速将数据包传送到目的端口。目的MAC若不存在,交换机才广播到所有的端口,接收端口回应后交换机会“学习”新的地址,并把它添加入内部地址表 中。
    交换机工作于OSI参考模型的第二层,即数据链路层。交换机内部的CPU会在每个端口成功连接时,通过ARP协议学习它的MAC地址,保存成一张 ARP表。在今后的通讯中,发往该MAC地址的数据包将仅送往其对应的端口,而不是所有的端口。因此,交换机可用于划分数据链路层广播,即冲突域;但它不 能划分网络层广播,即广播域。
    交换机被广泛应用于二层网络交换,俗称“二层交换机”。
    交换机的种类有:二层交换机、三层交换机、四层交换机、七层交换机分别工作在OSI七层模型中的第二层、第三层、第四层盒第七层,并因此而得名。

    2. 路由器

    路由器(Router)是一种计算机网络设备,提供了路由与转送两种重要机制,可以决定数据包从来源端到目的端所经过 的路由路径(host到host之间的传输路径),这个过程称为路由;将路由器输入端的数据包移送至适当的路由器输出端(在路由器内部进行),这称为转 送。路由工作在OSI模型的第三层——即网络层,例如网际协议。
    路由器的一个作用是连通不同的网络,另一个作用是选择信息传送的线路。
    路由器与交换器的差别,路由器是属于OSI第三层的产品,交换器是OSI第二层的产品(这里特指二层交换机)。

    3.网关

    网关(Gateway),网关顾名思义就是连接两个网络的设备,区别于路由器(由于历史的原因,许多有关TCP/IP 的文献曾经把网络层使用的路由器(Router)称为网关,在今天很多局域网采用都是路由来接入网络,因此现在通常指的网关就是路由器的IP),经常在家 庭中或者小型企业网络中使用,用于连接局域网和Internet。 网关也经常指把一种协议转成另一种协议的设备,比如语音网关。
    在传统TCP/IP术语中,网络设备只分成两种,一种为网关(gateway),另一种为主机(host)。网关能在网络间转递数据包,但主机不能 转送数据包。在主机(又称终端系统,end system)中,数据包需经过TCP/IP四层协议处理,但是在网关(又称中介系 统,intermediate system)只需要到达网际层(Internet layer),决定路径之后就可以转送。在当时,网关 (gateway)与路由器(router)还没有区别。

    在现代网络术语中,网关(gateway)与路由器(router)的定义不同。网关(gateway)能在不同协议间移动数据,而路由器(router)是在不同网络间移动数据,相当于传统所说的IP网关(IP gateway)。

    网关是连接两个网络的设备,对于语音网关来说,他可以连接PSTN网络和以太网,这就相当于VOIP,把不同电话中的模拟信号通过网关而转换成数字信号,而且加入协议再去传输。在到了接收端的时候再通过网关还原成模拟的电话信号,最后才能在电话机上听到。
    对于以太网中的网关只能转发三层以上数据包,这一点和路由是一样的。而不同的是网关中并没有路由表,他只能按照预先设定的不同网段来进行转发。网关最重要的一点就是端口映射,子网内用户在外网看来只是外网的IP地址对应着不同的端口,这样看来就会保护子网内的用户。

    展开全文
  • 一、IP地址 使用 IP 地址,是设备能够相互查找并在 Internet 上建立端到端通信的主要方式。网络中的每个终端设备都必须配置 ...输出将显示从 DHCP 服务器接收的 IPv4 地址、子网掩码和网关信息。 本文只用于学习与记录

    一、IP地址

    使用 IP 地址,是设备能够相互查找并在 Internet 上建立端到端通信的主要方式。网络中的每个终端设备都必须配置 IP 地址。

    对于 IPv4 地址,子网掩码也是必要设置。IPv4 子网掩码是将地址的网络部分与主机部分区分开来的 32 位值。子网掩码,与 IPv4 地址相结合,可用于确定设备属于哪个特定子网。

    那么什么是子网掩码传送门

    二、配置终端IP地址

    终端手动配置

    要在 Windows 主机上手动配置 IPv4 地址,请打开控制面板 > 网络共享中心 > 更改适配器设置,然后选择适配器。接下来右键单击并选择“属性”以显示“本地连接属性”,突出显示 Internet 协议版本 4 (TCP/IPv4),并单击“属性”以打开“Internet 协议版本 4 (TCP/IPv4) 属性”窗口,不过手动配置可能因复制另一设备的 IPv4 地址而增加配置错误的风险。

    注意:DNS 服务器地址是域名系统 (DNS) 服务器的 IPv4 地址,用于将 IP 地址转换为域名

    自动配置

    PC 通常默认使用 DHCP 进行 IPv4 地址自动配置( IPv4 地址、子网掩码、默认网关和 DNS 服务器)。

    要在 Windows PC 上配置 DHCP,只需选择 “自动获取 IP 地址”和“自动获取 DNS 服务器地址”。您的 PC 将会找到 DHCP 服务器,并为其分配在网络上通信所需的地址设置。

    三、交换机虚拟接口配置

    要远程访问交换机,SVI(vlan 1) 上必须配置 IP 地址和子网掩码。要在交换机上配置SVI(vlan 1),请使用 interface vlan 1 全局配置命令。Vlan 1 并不是一个实际物理接口,而是一个虚拟接口。接下来,使用 ip address 命令分配 IPv4 地址 ip-address subnet-mask 接口配置命令。最后,使用 no shutdown 接口配置命令启用虚拟接口(默认为shutdown)。

    switch>enable											// 进入特权模式
    switch#configure terminal								// 进入全局模式
    switch(config)#interface vlan 1							// 进入vlan
    switch(config-if)#ip address 10.10.10.100 255.255.255.0	// 设置ip地址与子网掩码
    switch(config-if)#no shutdown							// 开启虚拟接口
    

    四、交换机的网关配置

    如果想通过多个网络连接到交换机并进行管理,则需要配置SVI(vlan 1)IPv4 地址、子网掩码和默认网关地址。具体的IPv4 地址、子网掩码在上面已经配置好了,而默认网关需要在 SVI(vlan 1) 里面使用 ip default-gateway 全局配置命令。配置的网关地址是交换机与路由器接口处的 IP 地址。

    switch>enable											// 进入特权模式
    switch#configure terminal								// 进入全局模式
    switch(config)#interface vlan 1							// 进入vlan
    switch(config-if)#ip address 10.10.10.100 255.255.255.0	// 设置ip地址与子网掩码
    switch(config-if)#ip default-gateway 211.25.32.1 		// 设置默认网关
    switch(config-if)#no shutdown							// 开启虚拟接口
    

    五、其他

    在命令提示符下使用 ipconfig 命令,可以显示 Windows PC 上的 IP 配置设置。输出将显示从 DHCP 服务器接收的 IPv4 地址、子网掩码和网关信息

    本文只用于学习与记录

    展开全文
  • 1、首先给PC1主机配置ip地址和网关(gateway) --不配网关可能ping不同,并且网关要和下一跳地址相同,否则也无法ping通 2、配置交换机S1 进入S1命令行界面 Switch>enable --进入特权模式 ...

    一、实验目的:配置一台交换机,并配置默认网关,使不同网段的主机能够远程telnet登录连接到交换机

    二、实验拓扑图如下:

     

    二、实验步骤:

    1、首先给PC1主机配置ip地址和网关(gateway) --不配网关可能ping不同,并且网关要和下一跳地址相同,否则也无法ping

     

    2、配置交换机S1

    进入S1命令行界面

    Switch>enable  --进入特权模式

    Switch#configure terminal  --进入全局配置模式

    Switch(config)#hostname S1  --修改交换机主机名为S1(方便识别)

    S1(config)#enable password 111  --设置明文管理密码为111

    S1(config)#enable secret 222  --设置加密密码为222(设置了加密密码后,明文将不会起作用)

    S1(config)#line vty 0 5  -- 设置虚拟终端个数(一般为5个,最多为16个)

    S1(config-line)#password 333  --设置远程登录密码为333

    S1(config-line)#login  --配置远程登录密码后必须要有login,如果没有的话则远程登录密码无效

    S1(config-line)#exit  --返回上一级(全局配置模式)

    S1(config)#interface vlan 1  --进入vlan 1 端口

    S1(config-if)#ip address 192.168.1.1 255.255.255.0  --给vlan1配置ip地址,使PC1S1可以Ping互通

    S1(config-if)#no shutdown  --激活vlan 1 端口

    S1(config-if)#exit  -- --返回上一级(全局配置模式)

    S1(config)#ip default-gateway 192.168.1.254  --给交换机S1设置默认网关,从而达到跨网段telnet

    S1(config-if)#end  --返回特权模式

    S1#copy running-config startup-config  --将配置保存(从内存RAM保存到硬盘NVRAM) 

     

    3、配置路由器R1

    进入到路由器R1命令行界面

    Continue with configuration dialog? [yes/no]: n  --是否继续配置对话框?(yes/no)

    Router>enable  --进入到特权模式

    Router#configure terminal   --进入到全局配置模式

    Router(config)#hostname R1   --修改路由器主机名为R1

    R1(config)#interface f0/0   --进入到f0/0端口

    R1(config-if)#ip address 192.168.2.254 255.255.255.0   --给f0/0配置ip地址

    R1(config-if)#no shutdown   --激活f0/0端口

    R1(config-if)#interface f0/1   --进入f0/1端口

    R1(config-if)#ip address 192.168.1.254 255.255.255.0   --给f0/1配置ip地址

    R1(config-if)#no shutdown   --激活f0/1端口

    R1(config-if)#end   ----返回特权模式

    R1#copy running-config startup-config    --将配置保存(从内存RAM保存到硬盘NVRAM

    3、进入到PC1主机命令行界面

    PC1主机上测试是否Ping的通S1

    # ping 192.168.1.1

    (2)tenlet远程登录

    # tenlet 192.168.1.1

    Passwor 333

    成功登录

    转载于:https://www.cnblogs.com/evolve/p/9149943.html

    展开全文
  • 中继器 集线器 网桥 交换机 路由器 网关 分类: 数据存储 2009-12-05 16:14 333人阅读 评论(0) 收藏 举报 Source: http://blog.donews.com/littlechen/archive/2005/10/10/582975.aspx 不同...
     
    

    中继器 集线器 网桥 交换机 路由器 网关

    分类: 数据存储 333人阅读 评论(0) 收藏 举报

    Source: http://blog.donews.com/littlechen/archive/2005/10/10/582975.aspx


    不同层次的网络连接设备

    1、物理层 :中继器(Repeater)和集线器(Hub)。用于连接物理特性相同的网段,这些网段,只是位置不同而已。Hub 的端口没有物理和逻辑地址。

    2、逻辑链路层 :网桥(Bridge)和交换机(Switch)。用于连接同一逻辑网络中、物理层规范不同的网段,这些网段的拓扑结构和其上的数据帧格式,都可以不同。Bridge和Switch的端口具有物理地址,但没有逻辑地址。

    3、网络层 :路由器(Router)。用于连接不同的逻辑网络。Router的每一个端口都有唯一的物理地址和逻辑地址。

    4、应用层 :网关(Gateway)。用于互连网络上,使用不同协议的应用程序之间的数据通信,目前尚无硬件产品。


    前两者属于OSI和TCP/IP模型的最低层,即物理层,起到数字信号放大和中转的作用。

    中继器(REPEATER),用来延长网络距离的互连设备。(局域网络互连长度是有限制,不是无限,例如在10M以太网中,任何两个数据终端设备允许的传输通路最多为5个中继器、4个中继器组成)。REPEATER可以增强线路上衰减的信号,它两端即可以连接相同的传输媒体,也可以连接不同的媒体,如一头是同轴电缆另一头是双绞线。

    集线器(HUB)实际上就是一个多端口的中继器,它有一个端口与主干网相连,并有多个端口连接一组工作站。它应用于使用星型拓扑结构的网络中,连接多个计算机或网络设备。集线器又分成:1 能动式,2 被动式,3 混合式。1 动能式:对所连接的网络介质上的信号有再生和放大的作用,可使所连接的介质长度达到最大有效长度,需要有电源才能工作,目前多数HUB为此类型。2 被动式只充当连接器,其不需要电源就可以工作,市场上已经不多见。3 混合式:可以连接多种类型线缆,如同轴和双绞线。

    集线器就是一种共享设备,HUB本身不能识别目的地址,当同一局域网内的A主机给B主机传输数据时,数据包在以HUB为架构的网络上是以广播方式传输的,由每一台终端通过验证数据包头的地址信息来确定是否接收。也就是说,在这种工作方式下,同一时刻网络上只能传输一组数据帧的通讯,如果发生碰撞还得重试。这种方式就是共享网络带宽。


    网桥和交换机属于OSI和TCP/IP的第二层,即数据链路层。数据链路层的作用包括数据链路的建立、维护和拆除、帧包装、帧传输、帧同步、帧差错控制以及流量控制等。

    网桥(BRIDGE)工作在数据链路层,将两个局域网(LAN)连起来,根据MAC地址(物理地址)来转发帧,可以看作一个“低层的路由器”(路由器工作在网络层,根据网络地址如IP地址进行转发)。它可以有效地联接两个LAN,使本地通信限制在本网段内,并转发相应的信号至另一网段,网桥通常用于联接数量不多的、同一类型的网段。

    网桥通常有透明网桥和源路由选择网桥两大类。
    1、透明网桥
    简单的讲,使用这种网桥,不需要改动硬件和软件,无需设置地址开关,无需装入路由表或参数。只须插入电缆就可以,现有LAN的运行完全不受网桥的任何影响。
    2、源路由选择网桥
    源路由选择的核心思想是假定每个帧的发送者都知道接收者是否在同一局域网(LAN)上。当发送一帧到另外的网段时,源机器将目的地址的高位设置成1作为标记。另外,它还在帧头加进此帧应走的实际路径。

    交换机(SWITCH)是按照通信两端传输信息的需要,用人工或设备自动完成的方法,把要传输的信息送到符合要求的相应路由上的技术统称。广义的交换机就是一种在通信系统中完成信息交换功能的设备。

    在计算机网络系统中,交换概念的提出是对于共享工作模式的改进。

    交换机拥有一条很高带宽的背部总线和内部交换矩阵。交换机的所有的端口都挂接在这条背部总线上,控制电路收到数据包以后,处理端口会查找内存中的地址对照表以确定目的MAC(网卡的硬件地址)的NIC(网卡)挂接在哪个端口上,通过内部交换矩阵迅速将数据包传送到目的端口,目的MAC若不存在才广播到所有的端口,接收端口回应后交换机会“学习”新的地址,并把它添加入内部地址表中。

    使用交换机也可以把网络“分段”,通过对照地址表,交换机只允许必要的网络流量通过交换机。通过交换机的过滤和转发,可以有效的隔离广播风暴,减少误包和错包的出现,避免共享冲突。

    总之,交换机是一种基于MAC地址识别,能完成封装转发数据包功能的网络设备。交换机可以“学习”MAC地址,并把其存放在内部地址表中,通过在数据帧的始发者和目标接收者之间建立临时的交换路径,使数据帧直接由源地址到达目的地址。

    其实SWITCH的前身就是网桥。交换机是使用硬件来完成以往网桥使用软件来完成过滤、学习和转发过程的任务。SWITCH速度比HUB快,这是由于HUB 不知道目标地址在何处,发送数据到所有的端口。而SWITCH中有一张路由表,如果知道目标地址在何处,就把数据发送到指定地点,如果它不知道就发送到所有的端口。这样过滤可以帮助降低整个网络的数据传输量,提高效率。但是交换机的功能还不止如此,它可以把网络拆解成网络分支、分割网络数据流,隔离分支中发生的故障,这样就可以减少每个网络分支的数据信息流量而使每个网络更有效,提高整个网络效率。目前有使用SWITCH代替HUB的趋势。


    路由器(ROUTER)位于网络层,用于连接多个逻辑上分开的网络,几个使用不同协议和体系结构的网络。当一个子网传输到另外一个子网时,可以用路由器完成。它具有判断网络地址和选择路径的功能,过滤和分隔网络信息流。一方面能够跨越不同的物理网络类型(DDN、FDDI、以太网等等),另一方面在逻辑上将整个互连网络分割成逻辑上独立的网络单位,使网络具有一定的逻辑结构。

    对于不同规模的网络,路由器作用的侧重点有所不同:

    1、在主干网上,路由器的主要作用是路由选择。主干网上的路由器,必须知道到达所有下层网络的路径。这需要维护庞大的路由表,并对连接状态的变化作 出尽可能迅速的反应。路由器的故障将会导致严重的信息传输问题。

    2、在地区网中,路由器的主要作用是网络连接和路由选择,即连接下层各个基层网络单位——园区网,同时,负责下层网络之间的数据转发。

    3、在园区网内部,路由器的主要作用是分隔子网。早期的互连网基层单位是局域网(LAN),其中所有主机处于同一个逻辑网络中。随着网络规模的不断扩大,局域网演变成以高速主干和路由器连接的多个子网所组成的园区网。在其中,各个子网在逻辑上独立,而路由器就是唯一能够分隔它们的设备,它负责子网间的报文转发和广播隔离,在边界上的路由器则负责与上层网络的连接。

    展开全文
  • 路由器:连接不同IP 子网的设备,负责寻径转发,工作在OSI 的网络层。 网桥: 连接不同子网,使其透明通信,工作在数据链路层,解析数据帧。缺点是无法避免“广播风暴”。 网关(gateway):工作在应用层,不同...
  • 由于本人一直以来对集线器,路由器,交换机网关这几个东西的作用有点模糊,本周读了一部分《CCNA1网络基础》,加上在网上搜搜学学,整理了一下。  集线器——局域网集线器有许多插座(通常是RJ-4S 插座),用于...
  • 中继器 集线器 网桥 交换机 路由器 网关
  • 然而,在这种情况下,中继器也只是单纯负责信号在01比特流之间的替换,并不负责判断数据是否有错误,同时,他只负责将电信号转换为光信号,因此不能在传输速度不同的媒介之间转发。 2.网桥 网桥是在OSI模型的第2层...
  • 由于传输线路噪声的影响,承载信息的数字信号或模拟信号只能传输有限的距离,中继器的功能是对接收信号进行再生发送,从而增加信号传输的距离。它连接同一个网络的两个或多个网段。如以太...
  • 集线器 路由器 交换机 网关 网桥的区别功能原理
  • 不同层次的网络连接设备1、物理层:中继器(Repeater)集线器(Hub)。用于连接物理特性相同的网段,这些网段,只是位置不同而已。Hub 的端口没有物理逻辑地址。2、逻辑链路层:网桥(Bridge)和交换机(Swi
  • DDN——防火墙——路由器——交换机——内部网(包括服务器) HUB中继工作在1层。 二层交换机工作在2层。 路由器防火墙在3层。 现在有结合路由功能的交换机,用于局域网内路由连接。 有工作在高层的防火墙,比如...
  • 交换机IP地址和网关的配置

    千次阅读 2017-11-14 15:18:00
    实验网络拓扑图 实验步骤: ...2、交换机配置模式 3、验证通信 实验总结 勤加练习交换机的命令 本文转自 无心低语 51CTO博客,原文链接:http://blog.51cto.com/fengzhankui/153878...
  • cisco配置交换机管理地址默认网关

    万次阅读 2017-10-30 00:00:31
    配置交换机远程管理地址默认网关拓扑图如下:1、配置PC02、配置SW1交换机Switch(config)#no ip domain-lookup #关闭域名解析Switch(config-line)#exec-timeout 0 0 #与交换机保持连接的时延,这里的设置是与路由器...
  • 实验七:配置交换机管理地址默认网关 @toc 1.实验目标 1.理解交换机默认VLAN的作用; 2.理解交换机默认网关的作用; 3.实现交换机远程管理; 2.实验步骤 1.根据拓扑所示,配置相应的IP...
  • 交换机,在京东上千兆交换机大概三四百块,百兆交换机只需要几十块,...交换机根据工作位置的不同,可以分为广域网交换机和局域网交换机。广域的交换机就是一种在通信系统中完成信息交换功能的设备,它应用在数据链路
  • 交换机拥有一条高带宽的背部总线内部交换矩阵。交换机的所有的端口都挂接在这条背部总线上,当控制电路收到数据包以后,处理端口会查找内存中的地址对照表以确定目的MAC的NIC(网卡)挂接在哪个端口上,通过内部...
  • 2.1 什么是网关网关英文名称为Gateway,又称网间连接器、协议转换器。 网关在网络层以上实现网络互连,是最复杂的网络互连设备,仅用于两个...同时,网关也可以提供过滤安全功能。大多数网关运行在OSI 7层...
  • 网络工具集线器、交换机、路由器和网关 1、中继器和集线器(Hub) 中继器和集线器将从连接点之一(端口)接收的电信号重新传给所有端口,以保持信号的完整性。 中继器是在不产生数据丢失情况下扩展...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,001
精华内容 800
关键字:

交换机和网关