精华内容
下载资源
问答
  • 交换机和路由器的静态路由
    2022-07-28 16:43:09

    目录

    一、静态路由介绍

    1.1静态路由和默认路由特点

    1.2静态路由配置

    1.2.1静态路由

    1.2.2默认路由

    1.3静态路由和默认路由配置实例


    一、静态路由介绍

    1.1静态路由和默认路由特点

    由管理员收到配置,不灵活、单向的

    特殊的静态路由:默认路由,当在路由器中,找不到目标网络的条目时,再去查看默认路由

    默认路由使用场景:一般用于末节(末梢)网络,网络的最末端(一个路由器的一端,之连接了一个网络。比如:R1的左侧)静态路由是直接指定目标为任何地方

    1.2静态路由配置

    1.2.1静态路由

    Ip route 目标网络(目标的网段“目标的网络地址”) 目标子网掩码 下一跳地址(下一个路由器接口的IP地址)或者是发往下一个路由器的本地接口。

    例如:ip route 192.168.100.0 255.255.255.0 f0/1

         去往网段192.168.100.0/24 转发端口是f0/1

          ip route 192.168.100.0 255.255.255.0 192.168.100.8

         去往网段192.168.100.0/24 下一跳路由ip是192.168.100.8

    网络地址:通过目标的子网掩码和IP地址做与运算(1与任何数得任何数,0与任何数得0)

    1.2.2默认路由

    Ip route 0.0.0.0.0 0.0.0.0.0 转发端口

    Ip route 0.0.0.0.0 0.0.0.0.0 f0/1

    去往任意网段 转发端口是f0/1

    Ip route 0.0.0.0.0 0.0.0.0.0 下一跳路由ip

    Ip route 0.0.0.0.0 0.0.0.0.0 192.168.100.8

    去往任意网段,下一跳路由ip是192.168.100.8

    查看路由条目:show ip route

    1.3静态路由和默认路由配置实例

    思路:

    设置路由各个接口IP和子网掩码,并开启接口,配置各个主机IP地址子网掩码

    PC0-PC1:R0-R2-R1

    在R0上配置静态路由

    Ip route 192.168.20.0 255.255.255.0 g0/1

    在R2上配置静态路由

    Ip route 192.168.20.0 255.255.255.0 g0/1

    在R1上配置静态路由

    Ip route 192.168.10.0 255.255.255.0 g0/2

    在R1上还可以直接配置默认路由,因为R1只连接了一个设备,处于网络最末端

    Ip route 0.0.0.0 0.0.0.0 g0/2

    查看实验效果

    更多相关内容
  • 什么是交换机 实现一个网络内多台主机之间的通讯 #如何利用交换机实现通讯 在数据前面设置目标地址和源地址,目标地址和源地址用mac地址进行标识 mac称为物理地址,每块网卡上都有的一个标识身份信息的 mac地址...

    网络设备说明介绍

    什么是交换机

    实现一个网络内多台主机之间的通讯

    如何利用交换机实现通讯
        1.在数据前面设置目标地址和源地址,目标地址和源地址用mac地址进行标识
           mac称为物理地址,每块网卡上都有的一个标识身份信息的
           mac地址全球唯一,不能进行修改,mac地址用16进制标识
           MAC地址: 类似家庭住址 最终通信都是通过MAC地址进行通信
           IP地址: 类似身份证号 逻辑地址
        2.在网络通讯初期,会利用广播方式进行发送数据包,在通讯的过程,数据包的发送一定是有去有回的。
           

    在一个交换网路中,如果产生了大量广播数据包时会产生广播风暴,影响主机性能,这样的问题称为广播风暴问题

    解决广播风暴问题思路:
              减少广播产生数量,将一个大的交换网络切割为几个小的交换网络(局域网,广播域)

    交换机的种类
              傻瓜交换机(TP-link/Dlink/水星…) 家用
              程控交换机(存储程序控制交换机,配置管理,思科、华为、华三、锐捷)

    ARP缓存表:
              路由器
              交换机
              计算机 arp -a 查看所有
              服务器

    公司无法上网排查思路:
    问题1: 计算机IP地址如何获取的 DHCP自动获取 手动配置的
              手动设置会引发IP地址冲突 导致无法上网
    问题2: 如果自动获取 ping 网关是否正常
              如果到网关正常 说明内网没问题 从路由器到运营商有问题的
    问题3: ping外网IP地址 IP地址通 但是域名不通 DNS服务器问题 更改DNS测试
    问题4: 如果到路由器延迟高 内网问题
              网线问题
              交换机问题 老了 硬件 环路
              IP地址冲突 导致大量的数据包在交换机转发
                        手工导致
                        有其他路由器IP和主路由器IP地址冲突

    企业常见网络出现问题故障:
    1.DNS服务器问题
    2.有的员工浏览器无法正常打开页面 (笔记本问题 一定要进行ping测试 或者登陆QQ测试)
    3.运营问题 设备故障
    4.IP地址冲突 多个路由器 路由器IP地址需要修改成不同的

    二层: 主要做数据包转发 交换机工作在二层
    三层: 可以做路由路径选择 路由器工作在三层

    思科交换机硬件设备
    *思科交换机硬件设备

    什么是路由器

    实现不同局域网之间主机通讯,可以隔离广播风暴(路由不同的接口连接不同广播域)

              路由类似于现实生活中从A地去往B地可能需要先步行,在坐车,在做飞机才能到达B地,这样的整个过程在网络中对应数据的传递过程就称为路由。因此一个数据信息跨越不同的网段传递到目的地址,就可以把传递数据的过程称为路由,也可以看做每条传递数据的路径。

    1)需要有身份标识信息:ip地址
    逻辑地址(可以改变的地址/???) 利用10进制方式进行显示
    IP地址由两部分组成: 交换网络标识信息+主机地址标识信息===网段地址+主机地址
    网络标识(网段): 192.168.100 192.168.100.1-192.168.100.254
                              192.168.110 192.168.110.1-192.168.110.254
                              192.168.120 192.168.120.1-192.168.120.254
                              只有在相同网段内的主机之间可以进行互通
                              不同的网段不能进行通信

      虚拟机: 10.0.0.200    10.0.0.网段
      vmnet8: 10.0.0.1
      以上网段 前三位 相同的称为网段

    内网卡—交换机 192.168.11.0/24(192.168.11.1~192.168.11.254)
    外网卡—运营商 122.71.227.79(铁通)
    查公网ip的方法:
    windows,打开浏览器,访问百度,搜IP即可
    网址: ip138.com
    linux:curl ifconfig.me

    高级路由器还有上网行为管理器和防火墙功能
    论坛:鸿鹄论坛(网络工程师)

    2) 路由实现数据传输通讯时,会根据路由表信息进行数据包路由
          实现不同网段之间通讯需要经过一条必经之路,这条路称为网关

    3)   查看路由条目信息方法

    [root@b13k ~]#route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         10.0.0.2        0.0.0.0         UG    100    0        0 eth0
    10.0.0.0        0.0.0.0         255.255.255.0   U     100    0        0 eth0
    
    [root@b13k ~]#netstat -rn
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
    0.0.0.0         10.0.0.2        0.0.0.0         UG        0 0          0 eth0
    10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
    

    第一列:所能去往网段的信息
    第二列:0.0.0.0 通过局域网即可到达
                  10.0.0.254 想去往其他网段的必经节点,称为网关
    第三列:子网掩码(告诉网段内可以容纳多少主机)
    最后一列:到达指定目标,通过哪一个接口出去
     
     

    案例:

    请添加图片描述

    在这里插入图片描述

    路由器配置:

    Router> # 用户模式 命令提示符 命令较少 常用ping命令
    查看当前的模式可以使用执行哪些命令使用? 回车查看

    Router>
    Router>ping 192.168.0.100
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.0.100, timeout is 2 seconds:
    .....				 # 显示. 表示网络不通 显示!!!!表示可以通信
    Success rate is 0 percent (0/5)
    
    Router>enable	# 输入enable进入特权模式
    Router#		    # 特权模式
    
    Router#show running-config 	      # 查看路由器配置
    
    Router#configure te
    Router#configure terminal 		  # 进入配置模式 可以使用tab键 可以使用简写方式
    

    简写方式-----------------

    Router(config)#exit			      # 退出到上一个模式
    Router#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#
    

    --------------------------

    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#					 # 配置模式
    Router(config)#
    

     
     

    配置网关:

    在路由器的接口上配置网关:
    192.168.0网段网关 192.168.0.1 g0/0
    192.168.4网段网关 192.168.4.1 g0/1
     
    在路由器配置模式中进入g0/0配置网关
     

    Router(config)#interface g0/0			# 在配置模式进入g0/0接口
    Router(config-if)#
    
    Router(config-if)#ip address 192.168.0.1 255.255.255.0   # 配置IP
    

     
    默认的接口为关闭状态 开启接口

    Router(config-if)#no shutdown 
    

     
    进入g0/1配置192.168.4.254网关
    通过返回到配置模式然后进入接口
    也可以在当前G0/0接口进入到G0/1

    Router(config-if)#int g0/1
    Router(config-if)#ip address 192.168.4.254 255.255.255.0
    Router(config-if)#no shut
    

     

    静态路由配置过程: 三台路由器

    R1路由配置:

    Router(config)#int g0/0
    Router(config-if)#no ip add 192.168.0.1 255.255.255.0		# 删除原IP
    Router(config-if)#ip add 192.168.1.254 255.255.255.0         # 配置为192.168.1.254
    

     
    进入g0/1接口

    Router(config-if)#int g0/1
    Router(config-if)#no ip add 192.168.4.254 255.255.255.0
    Router(config-if)#ip add 10.0.0.1 255.255.255.0
    

     
    R2路由器配置:

    Router>enable
    Router#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#int g0/0
    Router(config-if)#ip add 10.0.0.2 255.255.255.0
    Router(config-if)#no shut
    

     
    进入G0/1配置IP

    Router(config-if)#int g0/1
    Router(config-if)#ip addr 172.16.1.1 255.255.255.0
    Router(config-if)#no shut
    

     
    R3路由器配置

    Router>enable
    Router#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#int g0/0
    Router(config-if)#ip add 172.16.1.2 255.255.255.0
    Router(config-if)#no shut
    
    Router(config-if)#int g0/1
    Router(config-if)#ip add 116.63.0.254 255.255.255.0
    Router(config-if)#no shut
    

     
    查看R1路由表信息

    Router>show ip route
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       10.0.0.0/24 is directly connected, GigabitEthernet0/1
    L       10.0.0.1/32 is directly connected, GigabitEthernet0/1
         192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.1.254/32 is directly connected, GigabitEthernet0/0
    
    #C: 直连网段
    #L:在接口上直接配置的IP地址
    

     
    R1路由器配置静态路由

    Router>enab
    Router>enable 
    Router#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#
    Router(config)#ip route 116.63.0.0 255.255.255.0 10.0.0.2
    

     
    R1路由器路由表

    Router#show ip route
    
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       10.0.0.0/24 is directly connected, GigabitEthernet0/1
    L       10.0.0.1/32 is directly connected, GigabitEthernet0/1
         116.0.0.0/24 is subnetted, 1 subnets
    S       116.63.0.0/24 [1/0] via 10.0.0.2
         192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
    C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
    L       192.168.1.254/32 is directly connected, GigabitEthernet0/0
    

     
    R2路由器配置:

    Router#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#ip route 116.63.0.0 255.255.255.0 172.16.1.2
    
    Router#show ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       10.0.0.0/24 is directly connected, GigabitEthernet0/0
    L       10.0.0.2/32 is directly connected, GigabitEthernet0/0
         116.0.0.0/24 is subnetted, 1 subnets
    S       116.63.0.0/24 [1/0] via 172.16.1.2
         172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    C       172.16.1.0/24 is directly connected, GigabitEthernet0/1
    L       172.16.1.1/32 is directly connected, GigabitEthernet0/1
    

     

    R2路由器配置回包静态路由

    Router#
    Router#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#
    Router(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1
    Router(config)#exit
    

     
    R2路由表最终信息

    Router#show ip route
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       10.0.0.0/24 is directly connected, GigabitEthernet0/0
    L       10.0.0.2/32 is directly connected, GigabitEthernet0/0
         116.0.0.0/24 is subnetted, 1 subnets
    S       116.63.0.0/24 [1/0] via 172.16.1.2
         172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    C       172.16.1.0/24 is directly connected, GigabitEthernet0/1
    L       172.16.1.1/32 is directly connected, GigabitEthernet0/1
    S    192.168.1.0/24 [1/0] via 10.0.0.1
    

     
    R3路由配置回192.168.1.0段的静态

    Router>enab
    Router#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#ip route 192.168.1.0 255.255.255.0 172.16.1.1
    

     

    R3路由器路由表

    Router#show ip route
         116.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       116.63.0.0/24 is directly connected, GigabitEthernet0/1
    L       116.63.0.254/32 is directly connected, GigabitEthernet0/1
         172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    C       172.16.1.0/24 is directly connected, GigabitEthernet0/0
    L       172.16.1.2/32 is directly connected, GigabitEthernet0/0
    S    192.168.1.0/24 [1/0] via 172.16.1.1
    
    展开全文
  • Cisco Packet Tracer 配置交换机路由器静态路由

    万次阅读 多人点赞 2019-07-11 18:45:35
    第二步:规划每个网段的子网掩码ip地址 第三步:配置主机的ip地址,子网掩码,网关 第四步:配置路由器的ip地址 配置路由器0左边的以太网接口 配置路由器0右边的接口 测试一下主机ping网关,能ping同说明...

    第一步:搭建线路并连接

    在这里插入图片描述
    在这里插入图片描述

    第二步:规划每个网段的子网掩码和ip地址

    在这里插入图片描述

    第三步:配置主机的ip地址,子网掩码,网关

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    第四步:配置路由器的ip地址

    配置路由器0左边的以太网接口
    在这里插入图片描述
    配置路由器0右边的接口
    在这里插入图片描述
    测试一下主机ping网关,能ping通说明路由器0配置正确
    在这里插入图片描述
    配置路由器1左边的接口
    在这里插入图片描述
    配置路由器1右边的接口
    在这里插入图片描述
    配置路由器2左边的接口
    在这里插入图片描述
    配置路由器2右边的接口
    在这里插入图片描述
    配置路由器3左边的接口
    在这里插入图片描述
    配置路由器3右边的接口(注意这个接口和路由器0左边的接口一样都是以太网接口)
    在这里插入图片描述

    全部的ip地址都配置成功后,所有连线的一端都有一个绿色的三角号,如果配置错误就是红色的三角号
    在这里插入图片描述

    第五步:配置每个路由器的路由表

    只配置好路由器两个主机之间是ping不同的,因为在不同的网段之间通信,要告诉路由表下一跳给谁,所以要配置每个路由器的路由表信息。
    查看路由器的路由表
    在这里插入图片描述
    设置路由器0的路由表
    在这里插入图片描述
    设置路由器1的路由表
    在这里插入图片描述
    在这里插入图片描述
    设置路由器2的路由表
    在这里插入图片描述
    在这里插入图片描述
    设置路由器3的路由表
    在这里插入图片描述

    测试 主机0ping主机1能ping通
    在这里插入图片描述
    大功告成,以上就是在Cisco Packet Tracer中配置交换机和路由器静态路由的详细步骤。

    思考:为什么主机0ping主机1能ping通,主机0ping路由器0ping不通
    在这里插入图片描述
    因为只是设置了途径的每个路由器从一个主机到另一个主机下一跳到哪个路由器,并没有设置路由器之间怎么传输。

    查看到目标ip地址经过了那些路由器
    在这里插入图片描述
    静态路由的缺点:
    1、需要管理员高速路由器所有没有直连的网络下一跳给谁。
    2、静态路由只适用于规模小的网络,不能够自动调整路由。

    展开全文
  • 1、开启交换机路由功能: Switch(config)#ip routing 2、配置三层交换机端口的路由功能(config全局配置模式下) Switch(config)#interface fastEthernet 0/1 # 简写: int fa 0/1 Switch(config-if)#no switchport ...

    一、本次实验核心命令

    说明:命令适当简写机器也认,如interface fastEthernet 0/1可以简写成int fa 0/1

    1、开启交换机路由功能:

    Switch(config)#ip routing
    

    2、配置三层交换机端口的路由功能(config全局配置模式下)

    Switch(config)#interface fastEthernet 0/1  # 可简写为:int fa 0/1 
    Switch(config-if)#no switchport 
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    

    no switchport: 顾名思义,就是关闭二层交换的功能,即开启三层的路由功能。

    3、RIP、OSPF

    Switch(config)#router rip
    Switch(config-router)#network 192.168.1.0 
    Switch(config-router)#network 192.168.3.0  
    # 宣告连接在两边的网络号
    
    Switch(config-router)#router ospf 1 
    Switch(config-router)#network 192.168.1.0 255.255.255.0 area 0 
    Switch(config-router)#network 192.168.3.0 255.255.255.0 area 0  
    # 宣告连接在两边的网络号和area
    

    二、实验步骤

    0.路由基础模型

    实现拓扑图如下:

    配置PC的ip和网关:

    PC0 ip:192.168.1.2 网关:192.168.1.1
    PC1 ip:192.168.2.2 网关:192.168.2.1
    

    clipboard.png

    clipboard.png

    进入三层交换机CLI界面

    配置如下:

    Switch>en
    Switch#conf t
    Switch(config)#ip routing
    Switch(config)#int fa 0/1
    Switch(config-if)#no switchport
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)#exit
    Switch(config)#int fa 0/2
    Switch(config-if)#no switch
    Switch(config-if)#ip address 192.168.2.1 255.255.255.0
    

    验证

    PC0的Command Prompt命令提示符中输入

    ping 192.168.2.2
    

    注意:第一次可能没法完全ping通,再ping一次即可。

    1.多路由器(三层交换机)基础配置

    将之前用路由器做的实验全部改成用三层交换机3560做一遍。

    建立拓扑图如下。同种设备之前用双绞线,不同种设备用普通的直通线。

    (按照我的风格,端口左1右2,终端连接在交换机1号端口,三层连二层24号端口)

    clipboard.png

    1.开启三层交换机的路由模式,并给每个端口配置IP

    进入 CLI 命令行窗口,或者用配置线连接交换机的Console口(带外管理)。

    Multilayer Switch0:

    #---一号端口---#
    Switch>en
    Switch#conf t
    Switch(config)#ip routing
    Switch(config)#int fa 0/1
    Switch(config-if)#no switchport
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    #---二号端口---#
    Switch(config-if)#exit
    Switch(config)#int fa 0/2
    Switch(config-if)#no switchport
    Switch(config-if)#ip address 192.168.3.1 255.255.255.0
    

    Multilayer Switch1:

    #---一号端口---#
    Switch>en
    Switch#conf t
    Switch(config)#ip routing
    Switch(config)#int fa 0/1
    Switch(config-if)#no switchport
    Switch(config-if)#ip address 192.168.3.2 255.255.255.0
    #---二号端口---#
    Switch(config-if)#exit
    Switch(config)#int fa 0/2
    Switch(config-if)#no switchport
    Switch(config-if)#ip addr 192.168.4.1 255.255.255.0
    

    Multilayer Switch2:

    #---一号端口---#
    Switch>en
    Switch#conf t
    Switch(config)#ip routing
    Switch(config)#int fa 0/1
    Switch(config-if)#no switchport
    Switch(config-if)#ip addr 192.168.4.2 255.255.255.0
    #---二号端口---#
    Switch(config-if)#exit
    Switch(config)#int fa 0/2
    Switch(config-if)#no switchport
    Switch(config-if)#ip addr 192.168.2.1 255.255.255.0
    

    配置PC的ip和网关(同上):

    PC0 ip:192.168.1.2 网关:192.168.1.1
    PC1 ip:192.168.2.2 网关:192.168.2.1
    

    此时,ping网关已经可以ping通了,但是PC0 ping PC1 不通,接着配置静态路由。

    clipboard.png

    2.静态路由

    可以当成路由器配置。

    Multilayer Switch0:

    Switch(config)#ip route 192.168.2.0 255.255.255.0 192.168.3.2
    

    Multilayer Switch1:

    Switch(config)#ip route 192.168.2.0 255.255.255.0 192.168.4.2 
    Switch(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
    

    Multilayer Switch2:

    Switch(config)#ip route 192.168.1.0 255.255.255.0 192.168.4.1
    

    验证路由

    PC0的Command Prompt命令提示符中输入

    ping 192.168.2.2
    

    clipboard.png

    注意:第一次可能没法完全ping通,再ping一次即可。

    3.RIP路由

    删除上面三个交换机配置的静态路由

    clipboard.png

    或者用命令删除:(三个交换机均删除)

    ##交换机0
    Switch(config)#no ip route 192.168.2.0 255.255.255.0 192.168.3.2
    ##交换机1
    Switch(config)#no ip route 192.168.2.0 255.255.255.0 192.168.4.2
    Switch(config)#no ip route 192.168.1.0 255.255.255.0 192.168.3.1
    ##交换机2
    Switch(config)#no ip route 192.168.1.0 255.255.255.0 192.168.4.1
    

    配置RIP(宣告这路由器和哪些网段相连即可)

    ##交换机0
    Switch(config)#router rip
    Switch(config-router)#network 192.168.1.0
    Switch(config-router)#network 192.168.3.0
    ##交换机1
    Switch(config)#router rip
    Switch(config-router)#network 192.168.3.0
    Switch(config-router)#network 192.168.4.0
    ##交换机2
    Switch(config)#router rip
    Switch(config-router)#network 192.168.2.0
    Switch(config-router)#network 192.168.4.0
    

    验证路由

    PC0的Command Prompt命令提示符中输入

    ping 192.168.2.2
    

    clipboard.png

    4.OSPF路由

    删除RIP

    ##交换机0
    Switch(config)#router rip
    Switch(config-router)#no network 192.168.1.0
    Switch(config-router)#no network 192.168.3.0
    ##交换机1
    Switch(config)#router rip
    Switch(config-router)#no network 192.168.3.0
    Switch(config-router)#no network 192.168.4.0
    ##交换机2
    Switch(config)#router rip
    Switch(config-router)#no network 192.168.2.0
    Switch(config-router)#no network 192.168.4.0
    

    配置OSPF

    ##交换机0
    Switch(config-router)#router ospf 1
    Switch(config-router)#network 192.168.1.0 255.255.255.0 area 0
    Switch(config-router)#network 192.168.3.0 255.255.255.0 area 0
    ##交换机1
    Switch(config-router)#router ospf 1
    Switch(config-router)#network 192.168.3.0 255.255.255.0 area 0
    Switch(config-router)#network 192.168.4.0 255.255.255.0 area 0
    ##交换机2
    Switch(config-router)#router ospf 1
    Switch(config-router)#network 192.168.4.0 255.255.255.0 area 0
    Switch(config-router)#network 192.168.2.0 255.255.255.0 area 0
    

    注:255.255.255.0 反码 0.0.0.0.255,这里命令不写反码,机器也会自动转化。

    验证路由

    PC0的Command Prompt命令提示符中输入

    ping 192.168.2.2
    

    clipboard.png

    5.单臂路由

    新建拓扑图如下

    clipboard.png

    配置终端电脑IP和网关。同上。配置好的示意图如下:

    clipboard.png

    clipboard.png

    不支持子接口,所以直接通过Vlan来配置。

    三层交换机CLI

    Switch#conf t
    Switch(config)#vlan 2
    Switch(config-vlan)#exit
    Switch(config)#vlan 3
    Switch(config-vlan)#exit
    Switch(config)#int vlan 2
    Switch(config-if)#ip addr 192.168.1.1 255.255.255.0
    Switch(config-vlan)#int vlan 3
    Switch(config-if)#ip addr 192.168.2.1 255.255.255.0
    Switch(config-if)#exit
    Switch(config)#int fa0/1
    Switch(config-if)#switch mode access
    Switch(config-if)#switch mode trunk
    Switch(config-if)#ip routing
    

    在二层交换机CLI:配置Vlan分隔两个网段

    Switch>en
    Switch#conf t
    Switch(config)#vlan 2
    Switch(config-vlan)#exit
    Switch(config)#vlan 3
    Switch(config-vlan)#exit
    Switch(config-if)#int fa 0/2
    Switch(config-if)#switch access vlan 2
    Switch(config-if)#int fa 0/3
    Switch(config-if)#switch access vlan 3
    Switch(config-if)#exit
    Switch(config)#int fa 0/1
    Switch(config-if)#switch mode trunk
    

    成功:

    clipboard.png

    展开全文
  • 一 实验目的 1.识别静态路由的应用场景 2.掌握静态路由的配置 二 实验原理: 静态路由是指由用户或网络管理员手工配置的路由信息。当网络的拓扑结构或链路...静态路由由管理员亲自手动配置,静态路由路由器的路由选择
  • 1、静态路由2、默认路由ip route 目标网络(目标的网段“目标的网络地址") 目标的子网掩码 下一跳地址(下一个路由器的接口的IP地址)或者发往下一个路由器的本地接口(即这个接口的自己的,这个接口指向下一个路由)...
  • 路由器静态路由实验拓扑
  • 下面将三层交换机路由器组合在一起,做静态路由和OSPF路由重发布配置。两侧采用单臂路由形式(右侧三层交换机也形如单臂) 拓扑如下图:注意要使用Vlan1来连接路由器的接口。 具体配置如下: 二层交换机...
  • 1.配置两台主机各自的ip地址,掩码网关地址 2.进入三层交换机进行配置 ①创建vlan35,进入g0/0/6端口设置access模式并把端口加入vlan35 ②设置vlanif 35的ip地址为PC1的网关地址 ③进入g0/0/1...
  • 8三层交换机路由器静态路由的建立(1).doc
  • 交换机间的静态路由配置

    千次阅读 2021-01-19 12:16:06
    创建3个vlan,然后分配这三个vlan端口,最后配置三个端口ip (结果同一台交换机下的两台PC可ping通,跨交换机则不行) 加上这两条命令即可(sa与sb都需配置)
  • 12 路由器静态路由配置

    千次阅读 2022-05-09 21:28:38
    路由器静态路由配置
  • 三个三层交换机互访实例,使用静态路由实现,博文含拓扑图,命令,以及参考文献,感兴趣的同学可以试试,不懂的欢迎提问,欢迎纠错!
  • 采用的是明文密码方式,不是很安全,—般用于内网管理,...理,也常用于远程管理Linux操作系统法1:法2:因为在解封装时要去掉mac帧,再次封装时又添加mac帧,所以跨网段传输的源mac目的mac一直在发生变化。.........
  • 使用静态路由和多层交换网络技术完成如下要求的网络配置,通过网络配置,使所有计算机都能连通,要求: 1、使两台核心交换机之间形成一根聚合了两条物理链路的TRUNK聚合虚拟链路; 2、交换机S2可以管理除交换机S1...
  • 思科交换机和路由器的配置

    万次阅读 多人点赞 2020-01-09 16:54:22
    思科交换机和路由器的配置交换机的配置交换机端口的隔离 上一篇:思科的安装与汉化 接下来将用实例带小伙伴们一起来了解思科交换机和路由器的配置 交换机的配置 交换机端口的隔离 实例:将交换机的1—5号端口划分在...
  • 思科静态路由器配置,有截图有步骤有代码有讲解,非常适合小白初学者,以及忘记思科基本代码的大佬复习。Cisco static router configuration, with screenshots, steps, code and instructions, is very suitable ...
  • 静态路由是指由网络管理员手工配置路由信息。当网络的拓扑结构或链路状态发生...另一方面,当网络的拓扑结构链路状态发生变化时,路由器中的静态路由信息需要大范围地调整,这一工作的难度复杂程度非常高。 ...
  • 6、找某一路由器关机后开机,再次配置IP地址,RIP设置,注意要在宣告之前关闭路由聚合,之后再来。这里前面路由器的g0/0预设为191是错误的,因为191是广播地址,我们应当要设置为190.因为去20.0的网段下面的线路比...
  • 静态路由&默认路由
  • 中兴路由器静态路由的配置

    千次阅读 2019-11-25 11:33:47
    2、熟练掌握静态路由的配置过程。 二、实验内容 1、绘制拓扑图,根据拓扑图进行试验: 2、配置路由器,并最终验证网络的连通性。 三、实验过程 1、实验任务说明 1、配置静态路由,使两个不同网段的PC可以互通...
  • 思科路由器静态路由的配置

    千次阅读 2019-11-03 00:46:08
    目的二:掌握静态路由的默认路由配置 目的三:掌握路由诊断方法,会使用pingtrace等命令进行路由测试 实验设备与条件 (1)2811路由器两台,2960交换机两台,计算机若干,同异步串口连接线,网线。 (2)Cisco ...
  • 方法一:设置vlanif 静态路由 方法二:在交换机和路由器上运行ospf 拓扑图如下: 方法一配置命令: sw1 interface GigabitEthernet0/0/1 port link-type access port default vlan 10 # interface ...
  • Cisco路由器配置静态路由

    千次阅读 2021-09-30 15:54:34
    文章目录1、拓扑图2、R1配置3、R2配置4、R3配置 1、拓扑图 2、R1配置 进入特权模式:Router>en 进入全局模式:Router#conf t 修改设备名称:Router(config)#hostname R1 进入接口:R1(config)#int g0...配置静态
  • 路由器静态路由

    千次阅读 2021-11-16 13:38:38
    路由器1.1 路由表的主要作用1.2 路由的形成1.3 路由协议1.4路由概述1.5 路由表1.6 静态路由1.7选择最优路由时的标准1.8 默认路由 前言 路由器工作在osi参考模型的网络层,它的重要作用是为数据包选择最佳路径,最终...
  • 交换机路由器的配置

    万次阅读 多人点赞 2019-05-30 11:02:14
    交换机路由器的配置 一、交换机的基本配置 配置enable口令、密码主机名 Switch> (用户执行模式提示符) Switch>enable (进入特权模式) Switch# ...
  • 思科交换机和路由器

    2022-05-22 01:16:33
    no switchport这条命令的意思是:可以把二层接口改为三层接口,也就是说相当于一个路由器上的接口。no switch 实际上是no switchport的简写,而switchport就是交换口,也就是二层接口,这样no命令就意味着关闭二层...
  • 华为交换机路由器配置静态路由实现不同网段通信...vlanif20 192.168.20.254/24,vlanif100 192.168.100.1/24,PC1:192.168.10.1能ping通PC2:192.168.20.1,也能ping通PC3:192.168.30.1,交换机和路由器使用静态路由
  • policy-name } undo preference 缺省情况下,62616964757a686964616fe59b9ee7ad9431333365646261EBGP外部路由、IBGP内部路由和BGP本地路由的优先级值都是255。 参数说明 external EBGP外部路由的协议优先级。外部...
  • 2---AR-1配置静态默认路由,下一跳地址指向AR-2; [AR-1]ip route-static 0.0.0.0 0 12.1.1.2 AR-2配置静态默认路由,下一跳地址指向AR-3; [AR-2]ip route-static 0.0.0.0 0 23.1.1.3 AR-3配置静态默认路由,下一跳...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 24,141
精华内容 9,656
热门标签
关键字:

交换机和路由器的静态路由