精华内容
下载资源
问答
  • 交换机均衡负载
    千次阅读
    2021-03-17 10:35:02

     

    AP 可以根据报文的源 MAC 地址、目的 MAC 地址、源 MAC 地址+目的 MAC 地址、源 IP 地址,目的 IP 地址以及源 IP 地址+目的 IP 地址等特征值把流量平均地分配到 AP 的成员链路中。从而实现负载均衡,避免单根链路流量饱和。

     

           重要提示:

    默认设备支持的流量均衡方式为 src-dst-mac ,在不同的场景模型中,用户流量的特征不同,可能负载的效果并不是所期望的,这时候需要人工调整负载均衡的方式算法。

    命令如下:

          Ruijie(config)#aggregateport load-balance   src-dst-ip  ------>常用推荐的负载均衡方式

     

    常见可配置的负载均衡方式及说明如下:

    Ruijie(config)# aggregateport load-balance {dst-mac |src-mac | src-dst-mac | dst-ip | src-ip | src-dst-ip }

    dst-mac:根据输入报文的目的 MAC 地址进行流量分配。

    src-mac:根据输入报文的源 MAC 地址进行流量分配。

    src-dst-ip:根据源 IP 与目的 IP 进行流量分配。

    dst-ip:根据输入报文的目的 IP 地址进行流量分配。

    src-ip:根据输入报文的源 IP 地址进行流量分配。

    src-dst-mac:根据源 MAC 与目的 MAC 进行流量分配。

    更多相关内容
  • 一台三层交换机做双链路负载均衡.pdf
  • 这是在说什么呢,也就是说如果给每一个vlan单独做一个instance那么就是一颗另类的PVST,区别在于instance可以根据情况承载多个vlan 可能看实验会清楚一点: 通过手工改变pc网关的地址可以实现负载均衡 如果其中一个...

    华为的MSTP在我看来与思科的PVST是极其相似的,PVST为思科私有的,是按vlan给局域网中的每一个vlan生成一颗树便于流量管理,有不清楚的可以看我前面的博客。
    而华为用的MSTP则相对比较灵活,需要先创建一个承载区域,然后在区域中创建instance,最后把一个或多个vlan放入instance中。
    这是在说什么呢,也就是说如果给每一个vlan单独做一个instance那么就是一颗另类的PVST,区别在于instance可以根据情况承载多个vlan
    可能看实验会清楚一点:
    在这里插入图片描述
    在这里插入图片描述
    通过手工改变pc网关的地址可以实现负载均衡
    如果其中一个网关坏了,还可以通过这种方式切换网关通信
    在这里插入图片描述
    在这里插入图片描述
    配置脚本:

    二层交换机
    undo t m
    sys
    vlan 10
    vlan 20
    q
    stp enable
    stp mode mstp
    stp region-configuration
    region-name MSTP
    revision-level 1
    instance 1 vlan 10
    instance 2 vlan 20
    active region-configuration
    q
    int e0/0/1
    port link-type access
    port default vlan 10
    int e0/0/2
    port link-type access
    port default vlan 20
    q
    int e0/0/3
    port link-type trunk
    port trunk allow-pass vlan all
    int e0/0/4
    port link-type trunk
    port trunk allow-pass vlan all
    
    三层交换机1
    undo t m
    sys
    vlan 10
    vlan 20
    int vlan 10
    ip add 192.168.10.254 24
    int vlan 20
    ip add 192.168.20.254 24
    q
    stp enable
    stp mode mstp
    stp region-configuration
    region-name MSTP
    revision-level 1
    instance 1 vlan 10
    instance 2 vlan 20
    active region-configuration
    q
    stp instance 1 root primary
    stp instance 2 root secondary
    int g0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    int g0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    q
    
    三层交换机2
    undo t m
    sys
    vlan 10
    vlan 20
    int vlan 10
    ip add 192.168.10.253 24
    int vlan 20
    ip add 192.168.20.253 24
    q
    stp enable
    stp mode mstp
    stp region-configuration
    region-name MSTP
    revision-level 1
    instance 1 vlan 10
    instance 2 vlan 20
    active region-configuration
    q
    stp instance 1 root secondary
    stp instance 2 root primary
    int g0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    int g0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    q
    
    展开全文
  • 交换机环境配置负载均衡

    千次阅读 2018-01-30 13:10:30
    **实验步骤: 1. 如拓扑为pc机配置ip...2. 配置网关与交换机: Sw21: [Sw21]vlan batch 10 20 30 40 [Sw21]interface gigabitethernet 0/0/1 [Sw21-GigabitEthernet0/0/1]undo shutdown [Sw21-GigabitEthernet...

    多交换机环境配置负载均衡

    **实验步骤:

    1. 如拓扑为pc机配置ip地址

    2. 配置网关与交换机:

    Sw21:
         [Sw21]vlan batch 10 20 30 40
         [Sw21]interface gigabitethernet 0/0/1
         [Sw21-GigabitEthernet0/0/1]undo shutdown
         [Sw21-GigabitEthernet0/0/1]port link-type access
         [Sw21-GigabitEthernet0/0/1]port def vlan 10

    Sw1的0/0/2 0/0/3 0/0/4端口都如此分别加入vlan 20 vlan 30 vlan 40
    交换机之间配置trunk链路:
    [Sw21-GigabitEthernet0/0/5]port link-type trunk
    [Sw21-GigabitEthernet0/0/5]port trunk allow-pass vlan all
    Sw21的0/0/5 0/0/6 sw18 Gw19 Gw20 的0/0/1 0/0/2 端口全部配置trunk链路

    3. 配置优先级**:

    Gw19:
    Vlan 10 : [Gw19]in vlan 10
    [Gw19-Vlanif10]vrrp vrid 10 virtual-ip 192.168.10.250
    [Gw19-Vlanif10]vrrp vrid 10 priority 150(配置优先级)
    Vlan20: [Gw19]in vlan 20
    [Gw19-Vlanif20]vrrp vrid 20 virtual-ip 192.168.20.250(虚拟ip)
    [Gw19-Vlanif20]vrrp vrid 20 priority 150
    Vlan30: [Gw19]in vlan 30
    [Gw19-Vlanif30]vrrp vrid 30 virtual-ip 192.168.30.250
    Vlan40: [Gw19]in vlan 40
    [Gw19-Vlanif40]vrrp vrid 40 virtual-ip 192.168.40.250
    vlan 30与vlan 40 为默认优先级100
    Gw20:
    vlan10: [Gw20]in vlan 10
    [Gw20-Vlanif10]vrrp vrid 30 virtual-ip 192.168.10.250
    Vlan20: [Gw19]in vlan 20
    [Gw20-Vlanif20]vrrp vrid 40 virtual-ip 192.168.20.250
    Vlan30: [Gw20]in vlan 30
    [Gw20-Vlanif30]vrrp vrid 10 virtual-ip 192.168.30.250
    [Gw20-Vlanif30]vrrp vrid 10 priority 150(配置优先级)
    Vlan40: [Gw20]in vlan 40
    [Gw20-Vlanif40]vrrp vrid 20 virtual-ip 192.168.40.250
    [Gw20-Vlanif40]vrrp vrid 20 priority 150

    4. Pc机网关

       Pc1;192.168.10.250 255.255.255.0
       Pc2:  192.168.20.250 255.255.255.0   
       Pc3:  192.168.30.250 255.255.255.0
       Pc4:  192.168.40..250 255.255.255.0
       在GW19和GW20中配置SVI ip地址,分别是;
             Vlan x 192.168.x.254/24和192.168.x.25324

    5. Sw18和路由之间配置192.168.50.0/24网关

    6. 验证,测试,保存

    线路1或2故障时,vlan10 vlan20 会使用备份电路,整个网络还是通的,平时则会使用GW19,解决单点链路故障,实现了负载均衡
    如果线路3或4故障时,可以在端口下设置命令:
    [Gw19-Vlanif20]Vrrp vrid x track interface gi 0/0/2(监控上一端口状态)
    [Gw19-Vlanif20]vrrp vrid 10 track int gi 0/0/2 reduced
    50(当0/0/2端口down时,其相应的优先级会减少
    这就是VRRP的负载均衡以及链路跟踪希望对大家有点帮助,如果有什么不对的地方请大家一定要提出来,一起探讨!!!

    转载于:https://blog.51cto.com/13558034/2066772

    展开全文
  • 针对软件定义网络(SDN)多域部署中存在的子域控制器负载均衡问题,提出了一种面向SDN负载均衡交换机自适应迁移策略。首先,通过检测各子域控制器的负载,在网络中基于自适应遗传算法选择迁入和迁出域,可以实现...
  • 一台三层交换机做双链路负载均衡(20210906111855).pdf
  • H3C 交换机策略路由流量负载均衡

    千次阅读 2019-08-06 19:27:23
    外网出口交换机上有2条运营商线路,出外网的流量到达交换机后需要流量在2条线路上负载均衡,由于考虑到还会有其他运营商线路接入,且要求运营商流量来回路径一致,所以单纯通过静态路由迭代无法实现,此处可以使用...
    1.  

      组网环境

    1.  

      实现说明

    外网出口交换机上有2条运营商线路,出外网的流量到达交换机后需要流量在2条线路上负载均衡,由于考虑到还会有其他运营商线路接入,且要求运营商流量来回路径一致,所以单纯通过静态路由迭代无法实现,此处可以使用pbr+静态路由迭代的配置方式实现上述需求。

    1.  

      配置说明

    vlan 100

    description 流量路径-1

    #

    vlan 101

    description 流量路径-2

    #

    interface Vlan-interface100

    description 流量路径-1

     ip address 1.1.1.1 255.255.255.0

    #

    interface Vlan-interface101

    description 流量路径-2

     ip address 2.2.2.1 255.255.255.0

    #

    interface GigabitEthernet1/0/1

     port link-mode bridge

     port link-type trunk

     port trunk permit vlan 100

    #

    interface GigabitEthernet1/0/2

     port link-mode bridge

     port link-type trunk

     port trunk permit vlan 101

    #

    nqa entry admin 1

     type icmp-echo

      destination ip 1.1.1.2

      frequency 100

      next-hop ip 1.1.1.2

      reaction 1 checked-element probe-fail threshold-type consecutive 5 action-type trigger-only

    #

    nqa entry admin 2

     type icmp-echo

      destination ip 2.2.2.2

      frequency 100

      next-hop ip 2.2.2.2

      reaction 1 checked-element probe-fail threshold-type consecutive 5 action-type trigger-only

    #

    nqa schedule admin 1 start-time now lifetime forever

    nqa schedule admin 2 start-time now lifetime forever

    #

    track 1 nqa entry admin 1 reaction 1

    track 2 nqa entry admin 2 reaction 1

    #

    acl advanced 3000

     rule 0 permit ip source 10.0.0.0 0.0.0.8 

    #

    policy-based-route aaa permit node 1

     if-match acl 3000

     apply next-hop 111.111.111.111

    #

     ip route-static 111.111.111.111 32 1.1.1.1 track 1

     ip route-static 111.111.111.111 32 2.2.2.1 track 2

    #

     

    展开全文
  • VRRP \VLAN 负载均衡
  • VRRP负载均衡模式原理 原理:在一个典型的VRRP网络,同一时刻,永远只有一个设备担任Master角色,其余设备则是backup角色。从数据转发的角度来看,其实无论有多少设备,只有一个设备进行数据流量转发,这样的话,...
  • SDN多控制器网络中基于交换机迁移的动态负载均衡策略.pdf
  • 简单的基于交换机迁移的SDN控制器负载均衡实验 本人首次接触SDN,了解了下SDN的定义后,针对这个实验,首先通过查询文献,大概了解这个实验的环境搭建方案。 对于SDN控制器使用较多的有:OpenDaylight、Floodlight和...
  • 思科Cisco 交换机 VTP负载均衡的配置

    千次阅读 2015-07-07 19:09:05
    思科Cisco 交换机 VTP负载均衡的配置 3560三层交换机配置: int ran fa0/23 - fa0/24 sw trunk encapsolution dot1q sw mode trunk exit vlan 10 vlan 20 vlan 30 int vlan 10 ip address 172.16....
  • 交换机实现网络负载均衡的设计与实现毕业论文.docx
  • pvst实现流量负载均衡 如图所示:分别配置四台pc机ip地址和两台交换机的子网划分 switch0: switch2 switch1 配置switch0为vlan10的根,vlan20的备份 配置switch1为vlan20根,vlan10备份。 可以抓包看VLAN10...
  • 一台三层交换机做双链路负载均衡(20210906110707).pdf
  • 针对SDN中静态网络结构不能适应动态流量变化所引起的控制器负载均衡问题,...实验结果表明,与现有的负载均衡策略相比,其改善了迁入控制器和交换机的选取过程,优化了网络性能,控制器的负载均衡度提升了约31.4%。
  • F5 BIGIP应用交换机负载均衡,想学习F5负责均衡的朋友们注意咯
  • ROS通过H3C s1526交换机进行Vlan配置进行多线ADSL拨号接入,并且进行多线的负载均衡 ROS通过H3C s1526交换机进行Vlan配置进行多线ADSL拨号接入,并且进行多线的负载均衡
  • 交换机链路聚合负载均衡算法原理

    千次阅读 2017-11-09 16:50:00
    在2011年初我学习交换机链路聚合技术的时候,心中一直有一个疑问: 交换机收到一个报文,到达聚合口的时候,是怎么选择成员口出去的呢? 是随机选的吗?还是按成员编号从小到大或从大到小轮循?如果选择源IP算法,是...
  • 负载均衡设备也常被称为"四到七层交换机",那么四层和七层两者到底区别在哪里,本为将详细介绍,需要的朋友可以参考下
  • 应用交付产品/负载均衡器/迪普科技/应用负载/链路负载/配置文档说明
  • 负载均衡交换机知识

    千次阅读 2008-08-28 09:23:00
    负载均衡交换机又称四层交换机,主要工作在四层协议之上,同时负载均衡交换机还具备普通二层交换机和三层交换机的部分功能,详细信息如下:1、负载均衡交换机支持二层交换机的Vlan划分;2、负载均衡交换机支持二层...
  • 七层交换机负载均衡器通常称为四层交换机或七层交换机。四层交换机主要分析IP层及TCP/UDP层,实现四层流量负载均衡。七层交换机除了支持四层负载均衡以外,还有分析应用层的信息,如HTTP协议URI或Cookie信息。1、...
  • 配置 bond0 上联网络设备也需要做捆绑,如果是冗余的 bond 则上联不用配置H3Cs5560 交换机interface Bridge-Aggregation 1port access vlan 10创建聚合口,划入vlanint g 1/0/1port link-aggregation group 1聚合的...
  • HASH表介绍: 在交换机内部,每创建一个聚合组时,底层同时创建对应该聚合组的一个hash表,该表存在于...index数量越高,负载分担越均衡。这儿以3个成员为例: index interface 0 eth0_0 1 eth0_1
  • [注:本文【原理】部分来自转载,转载来源为...在交换机内部,每创建一个聚合组时,底层同时创建对应该聚合组的一个hash表,该表存在于交换芯片上,hash表内容如下(简化):左列index为芯片的硬性支持,现在一般是2...
  • 针对SDN中静态网络结构不能适应动态流量变化所引起的控制器负载均衡问题,提出一种...实验结果表明,与现有的负载均衡策略相比,改善了迁入控制器和交换机的选取过程,优化了网络性能,控制器的负载均衡度提升了约31.4%。
  • 硬件均衡负载与软件均衡负载

    千次阅读 2020-02-27 14:20:37
    负载均衡也分了不少技术,用以满足不同的需求,有软/硬件负载均衡、本地/全局负载均衡、更高网络层负载均衡,以及链路聚合技术。 我们用了软负载均衡,也用了硬件负载均衡,下面我们说说这两个各自的千秋。 一....
  • 四层与七层均衡负载

    2020-05-16 22:21:44
    同理,还有基于MAC地址的二层负载均衡和基于IP地址的三层负载均衡。 换句换说,二层负载均衡会通过一个虚拟MAC地址接收请求,然后再分配到真实的MAC地址;三层负载均衡会通过一个虚拟IP地址接收请求,然后再分配到...
  • F5负载均衡

    千次阅读 2022-05-20 09:53:04
    1.什么是F5负载均衡 负载均衡建立在现有网络结构之上,它提供了一种廉价有效透明的方法扩展网络设备和服务器的带宽、增加吞吐量、加强网络数据处理能力、提高网络的灵活性和可用性。需要说明的是:负载均衡设备不是...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 35,387
精华内容 14,154
关键字:

交换机均衡负载