精华内容
下载资源
问答
  • 交换机配置IP地址以及配置密码

    千次阅读 2019-07-16 20:01:32
    system-view #进入系统视图 [Huawei]interface Vlanif 1 #进入Vlan...[Huawei-Vlanif1]ip address 192.168.1.100 24 # 配置IP地址 [Huawei-Vlanif1]undo shutdown # Vlanif 1 IP地址 配置交换机登录密码 [Huawei]...

    实验拓扑

    system-view #进入系统视图
    [Huawei]interface Vlanif 1 #进入Vlanif 1视图
    [Huawei-Vlanif1]ip address 192.168.1.100 24 # 配置IP地址
    [Huawei-Vlanif1]undo shutdown # Vlanif 1 IP地址

                   配置交换机登录密码
    

    [Huawei]user-interface console 0 #进入console 0接口
    [Huawei-ui-console0]set authentication password cipher 123 #设置终端密码 cipher 暗文密码
    [Huawei-ui-console0]authentication-mode password #开启密码认证

    展开全文
  • 本文介绍配置主IP地址和从IP地址实现设备上一个接口...图1 IP地址配置组网图 配置步骤 1. Switch的配置 # 配置VLAN接口1的主IP地址和从IP地址。 <Switch> system-view [Switch] interface vlan-inter.

    本文介绍配置主IP地址和从IP地址实现设备上一个接口连接不同的子网时,设备与网络中的主机进行通信的典型配置案例。

    组网需求

    图1所示,在两个网络中的主机上采用交换机配置的主IP地址和从IP地址作为网关,实现两个网段的主机都可以通过Switch与外部网络通信。

    图1 IP地址配置组网图

     

    配置步骤

    1. Switch的配置

    # 配置VLAN接口1的主IP地址和从IP地址。

    <Switch> system-view

    [Switch] interface vlan-interface 1

    [Switch-Vlan-interface1] ip address 172.16.1.1 255.255.255.0

    [Switch-Vlan-interface1] ip address 172.16.2.1 255.255.255.0 sub

    [Switch-Vlan-interface1] return

    2. 主机的配置

    # 在172.16.1.0/24网段中的主机上配置网关为172.16.1.1;在172.16.2.0/24网段中的主机上配置网关为172.16.2.1。

     验证配置

    # 使用ping命令检测Switch与网络172.16.1.0/24内主机的连通性。

    <Switch> ping 172.16.1.2

      PING 172.16.1.2: 56  data bytes, press CTRL_C to break

        Reply from 172.16.1.2: bytes=56 Sequence=1 ttl=255 time=25 ms

        Reply from 172.16.1.2: bytes=56 Sequence=2 ttl=255 time=27 ms

        Reply from 172.16.1.2: bytes=56 Sequence=3 ttl=255 time=26 ms

        Reply from 172.16.1.2: bytes=56 Sequence=4 ttl=255 time=26 ms

        Reply from 172.16.1.2: bytes=56 Sequence=5 ttl=255 time=26 ms

     

      --- 172.16.1.2 ping statistics ---

        5 packet(s) transmitted

        5 packet(s) received

        0.00% packet loss

    round-trip min/avg/max = 25/26/27 ms

    显示信息表示Switch与网络172.16.1.0/24内的主机可以互通。

    # 使用ping命令检测Switch与网络172.16.2.0/24内主机的连通性。

    <Switch> ping 172.16.2.2

      PING 172.16.2.2: 56  data bytes, press CTRL_C to break

        Reply from 172.16.2.2: bytes=56 Sequence=1 ttl=255 time=25 ms

        Reply from 172.16.2.2: bytes=56 Sequence=2 ttl=255 time=26 ms

        Reply from 172.16.2.2: bytes=56 Sequence=3 ttl=255 time=26 ms

        Reply from 172.16.2.2: bytes=56 Sequence=4 ttl=255 time=26 ms

        Reply from 172.16.2.2: bytes=56 Sequence=5 ttl=255 time=26 ms

     

      --- 172.16.2.2 ping statistics ---

        5 packet(s) transmitted

        5 packet(s) received

        0.00% packet loss

        round-trip min/avg/max = 25/25/26 ms

    显示信息表示Switch与网络172.16.2.0/24内的主机可以互通。

    配置文件

    #

    interface Vlan-interface1

     ip address 172.16.1.1 255.255.255.0

     ip address 172.16.2.1 255.255.255.0 sub

    #

    展开全文
  • 交换机IP地址(概念)

    千次阅读 2020-07-24 01:22:17
    1. 交换机IP地址 交换机IP地址 物理层 1.信号:数字信号 2.传输介质: ​ 2.1 双绞线:直通线,交叉线。568A 568B ​ 2.2 光纤:多模,单模,光纤模块 ​ 2.3 无线信号:4G,5G,wifi 3.接口: ​ 3.1RG45接口...

    1. 交换机及IP地址

    交换机及IP地址

    物理层

    1.信号:数字信号

    2.传输介质:

    ​ 2.1 双绞线:直通线,交叉线。568A 568B

    ​ 2.2 光纤:多模,单模,光纤模块

    ​ 2.3 无线信号:4G,5G,wifi

    3.接口:

    ​ 3.1RG45接口(水晶头)

    地址

    • 物理地址:MAC地址
    • 逻辑地址:IP地址

    MAC地址

    以太网网卡的地址

    • 6个字节,48位。全球唯一地址
    • 前3个字节,代表的厂商的编码,统一分配,不能冲突
    • 后3个字节,厂商的编号
    • F8-A2-D6-F1-65-51
    • 高8位是0,单播地址
    • 高8位是1,组播地址
    • 48位都是1,FF-FF-FF-FF-FF-FF ,广播地址
    • 组播地址和广播地址不能作为源地址,只能是目的地址

    IP地址

    一个网段就代表一个网络,2个网络就要给2个网段,同一个网络中的主机通信,直接可达;不同网络主机通信,必须经过路由。

    • IP地址,4个字节,32位
    • 分为2部分,网络位+主机位
    • 网络位相同,则在同一网络,网络位不同,则在不同网段
    • 主机位不能全为0,全为0时代表网络ID
    • 主机位不能全为1,全为1时代表这个网络的广播ID
    • 让IP地址和你的子网掩码做“与”运算,得到的结果就是你的网络ID.
    #与运算,是一种二进制运算,取小
    1 和 1 结果是1
    1 和 0 结果是0
    0 和 0 结果是0
    #举例
    如果192.168.1.10/25 和192.168.1.150 通信,电脑首先要判断是否在同一网段
    # 判断自己的网络ID
    11000000 10101000 00000001 00001010
    11111111 11111111 11111111 10000000
    #结果
    11000000 10101000 00000001 00000000
    192.168.1.0
    
    # 判断对方的网络ID,以自己的子网掩码和对方的IP地址做与运算
    11000000 10101000 00000001 10010110
    11111111 11111111 11111111 10000000
    #结果
    11000000 10101000 00000001 10000000
    192.168.1.128
    #两个结果不相同,所以不在同一网段
    
    • 3个私网网段
    #当规划局域网IP的时候,就应该从以下网络中拆分
    10.0.0.0/8
    172.16.0.0/12
    192.168.0.0/16
    
    • 子网掩码决定了网络ID,掩码越长,网络越小;掩码越短,网络越大

    交换机

    属于二层的设备,交换机认识MAC地址的,认识以太网帧

    • 交换机的核心是MAC地址表
    #MAC地址表记录的是MAC地址和交换机端口对应关系
    <Huawei>display mac-address 
    MAC address table of slot 0:
    -------------------------------------------------------------------------------
    MAC Address    VLAN/       PEVLAN CEVLAN Port            Type      LSP/LSR-ID  
                   VSI/SI                                              MAC-Tunnel  
    -------------------------------------------------------------------------------
    5489-98b4-5777 1           -      -      Eth0/0/1        dynamic   0/-         
    5489-9839-5013 1           -      -      Eth0/0/2        dynamic   0/-         
    -------------------------------------------------------------------------------
    Total matching items on slot 0 displayed = 2 
    
    • 交换机根据收到的以太网帧进行转发

    以太网帧

    #以太网帧构成:
    目的MAC地址:6个字节
    源MAC地址:6个字节
    类型:2个字节
    数据:46-1500字节 #以太网的最大传输单元(MTU)是1500
    FCS:循环冗余校验  4个字节
    #以太网帧的种类
    单播帧:目的MAC地址是单播地址
    组播帧: 目的MAC地址是组播地址
    广播帧:目的MAC地址是广播地址
    
    • 交换机收到广播帧、组播帧,动作是泛洪(除接收端口外,向其它所有端口转发一份)
    • 收到未知单播(就是在MAC地址表中没有找到目的MAC地址情况),动作是泛洪
    • 收到已知单播(就是在MAC地址表中找到了目的MAC地址情况),根据MAC地址表中对应的端口进行转发
    • 当交换机从一个接口收到一个数据帧,发现还要从同一个接口将其转发出去,交换机会过滤掉这个数据帧(交换机的过滤功能是可以调的)
    • 交换机对PC来说是透明网桥的工作原理
    • 交换机工作在混杂模式(比如我收到数据帧,目的mac地址不是我的地址,但是我仍然要做出动作,故混杂模式,常见混杂模式,路由器。)
    • 交换机的上网路由,是通过下一跳来指向路由器的。(ip route-static 0.0.0.0 0 192.168.1.254一条默认路由指向网关)

    管理交换机

    • 给交换机配置IP地址,用来管理它
    [sw1]interface Vlanif 1
    [sw1-Vlanif1]ip add	
    [sw1-Vlanif1]ip address 192.168.1.200 24
    
    • 如果要想交换机和不同网段的地址通信,配置交换机的网关(默认路由)
    [sw1]ip route-static 0.0.0.0 0 192.168.1.254
    
    • 如何开启交换机的SSH管理
    #配置认证方式及开启SSH协议
    [sw1]user-interface vty 0 4
    [sw1-ui-vty0-4]authentication-mode aaa
    [sw1-ui-vty0-4]protocol inbound ssh
    
    #配置AAA,创建认证用户
    [sw1]aaa
    [sw1-aaa]local-user lisi password cipher 123456
    [sw1-aaa]local-user lisi service-type ssh
    [sw1-aaa]local-user lisi privilege level 15
    
    # 开启SSH服务及授权用户
    [sw1]stelnet server enable
    [sw1]ssh user lisi authentication-type password
    [sw1]ssh user lisi service-type stelnet
    
    #客户端进行验证即可
    [Huawei]ssh client first-time enable
    [Huawei]stelnet 192.168.1.200
    Please input the username:lisi
    Enter password:
    Info: The max number of VTY users is 5, and the number
          of current VTY users on line is 1.
          The current login time is 2019-12-11 09:41:39.
    <sw1>
    
    • 配置进入系统模式的密码(console密码)
    #配置console认证的方式
    [sw1]user-interface console 0
    [sw1-ui-console0]authentication-mode aaa
    
    #配置AAA的用户及授权
    [sw1]aaa
    [sw1-aaa]local-user zhangsan password cipher 123
    [sw1-aaa]local-user zhangsan service-type terminal
    [sw1-aaa]local-user zhangsan privilege level 15
    
    #验证
    Please Press ENTER.
    Login authentication
    
    Username:zhangsan
    Password:
    <sw1>
    
    • 配置交换机接口的双工和速率
    #默认是自动协商双工和速率
    [sw1]interface Ethernet 0/0/5
    [sw1-Ethernet0/0/5]undo negotiation auto #关闭自动协商
    [sw1-Ethernet0/0/5]duplex full   #配置双工为全双工
    [sw1-Ethernet0/0/5]speed 100     #配置速率为100兆
    交换机接口的双工和速率
    
    

    #默认是自动协商双工和速率
    [sw1]interface Ethernet 0/0/5
    [sw1-Ethernet0/0/5]undo negotiation auto #关闭自动协商
    [sw1-Ethernet0/0/5]duplex full #配置双工为全双工
    [sw1-Ethernet0/0/5]speed 100 #配置速率为100兆

    展开全文
  • 一、IP地址 使用 IP 地址,是设备能够相互查找并在 Internet 上建立端到端通信的...二、配置IP地址 手动配置 要在 Windows 主机上手动配置 IPv4 地址,请打开控制面板 > 网络共享中心 > 更改适配器设置,然后选

    一、IP地址

    使用 IP 地址,是设备能够相互查找并在 Internet 上建立端到端通信的主要方式。网络中的每个终端设备都必须配置 IP 地址。

    对于 IPv4 地址,子网掩码也是必要设置。IPv4 子网掩码是将地址的网络部分与主机部分区分开来的 32 位值。子网掩码,与 IPv4 地址相结合,可用于确定设备属于哪个特定子网。

    那么什么是子网掩码传送门

    二、配置终端IP地址

    终端手动配置

    要在 Windows 主机上手动配置 IPv4 地址,请打开控制面板 > 网络共享中心 > 更改适配器设置,然后选择适配器。接下来右键单击并选择“属性”以显示“本地连接属性”,突出显示 Internet 协议版本 4 (TCP/IPv4),并单击“属性”以打开“Internet 协议版本 4 (TCP/IPv4) 属性”窗口,不过手动配置可能因复制另一设备的 IPv4 地址而增加配置错误的风险。

    注意:DNS 服务器地址是域名系统 (DNS) 服务器的 IPv4 地址,用于将 IP 地址转换为域名

    自动配置

    PC 通常默认使用 DHCP 进行 IPv4 地址自动配置( IPv4 地址、子网掩码、默认网关和 DNS 服务器)。

    要在 Windows PC 上配置 DHCP,只需选择 “自动获取 IP 地址”和“自动获取 DNS 服务器地址”。您的 PC 将会找到 DHCP 服务器,并为其分配在网络上通信所需的地址设置。

    三、交换机虚拟接口配置

    要远程访问交换机,SVI(vlan 1) 上必须配置 IP 地址和子网掩码。要在交换机上配置SVI(vlan 1),请使用 interface vlan 1 全局配置命令。Vlan 1 并不是一个实际物理接口,而是一个虚拟接口。接下来,使用 ip address 命令分配 IPv4 地址 ip-address subnet-mask 接口配置命令。最后,使用 no shutdown 接口配置命令启用虚拟接口(默认为shutdown)。

    switch>enable											// 进入特权模式
    switch#configure terminal								// 进入全局模式
    switch(config)#interface vlan 1							// 进入vlan
    switch(config-if)#ip address 10.10.10.100 255.255.255.0	// 设置ip地址与子网掩码
    switch(config-if)#no shutdown							// 开启虚拟接口
    

    四、交换机的网关配置

    如果想通过多个网络连接到交换机并进行管理,则需要配置SVI(vlan 1)IPv4 地址、子网掩码和默认网关地址。具体的IPv4 地址、子网掩码在上面已经配置好了,而默认网关需要在 SVI(vlan 1) 里面使用 ip default-gateway 全局配置命令。配置的网关地址是交换机与路由器接口处的 IP 地址。

    switch>enable											// 进入特权模式
    switch#configure terminal								// 进入全局模式
    switch(config)#interface vlan 1							// 进入vlan
    switch(config-if)#ip address 10.10.10.100 255.255.255.0	// 设置ip地址与子网掩码
    switch(config-if)#ip default-gateway 211.25.32.1 		// 设置默认网关
    switch(config-if)#no shutdown							// 开启虚拟接口
    

    五、其他

    在命令提示符下使用 ipconfig 命令,可以显示 Windows PC 上的 IP 配置设置。输出将显示从 DHCP 服务器接收的 IPv4 地址、子网掩码和网关信息

    本文只用于学习与记录

    展开全文
  • cisco交换机通过ip地址查看mac地址

    万次阅读 2018-04-19 15:34:49
    1、查看MAC地址表show mac address-table 通过这条命令就可看到存储在当前交换机中的MAC地址表,里边记录了交换机目前学习到的所有主机MAC地址交换机端口的映射关系,二层数据正是通过查找这种映射关系发送到目的...
  • H3C交换机 配置IP映射

    千次阅读 2017-01-04 11:30:00
    输入命令:telnet 192.168.x.x(交换机IP地址) 登陆后,更换用户"sys" 输入命令:dis cur(展示当前状态) 进入后按"空格"键继续向下浏览,按"q"键退出。 查找到此处。 配置IP映射的命令为:nat server...
  • 交换机ip地址吗?

    千次阅读 2017-03-31 17:20:00
    交换机没有ip。  
  • 配置交换机名称和管理IP地址。 <Quidway>system-view [Quidway] sysname Server [Server] interface ethernet 0/0/0 //框式和盒式的管理口是不一样的哦,框式和盒式的 分别是: Ethernet 0/0/0、MEth 0/0/1。...
  • 中兴交换机配置vlan地址

    千次阅读 2019-09-18 07:35:26
    中兴交换机配置vlan地址命令:config terswitch vlan configvlan XXXexitinterf vlan XXXip add 1.1.1.1 255.255.255.0 瑞士康达传输登录方式:网线接入SNMP口电脑配置为192.168.4.1/24Telnet 192.168.4.28raisecom/...
  • 交换机IP地址配置

    千次阅读 2005-10-09 19:26:00
    交换机IP地址配置1 功能需求及组网说明IP地址配置『配置环境参数』1. 三层交换机SwitchA有两个端口ethetnet 0/1、ethernet 0/2,分别属于vlan 2、vlan 3;2. 以vlan 2的三层接口地址分别是1.0.0.1/24作为PC1的...
  • H3C三层交换机配置IP

    千次阅读 2016-11-13 09:53:00
    1.直接在物理端口上设置IP地址。 int f1/0/1 port link-mode route #链路模式采用路由 ip add 192.168.10.1 24 ...2.通过逻辑VLAN设置IP地址,先给VLAN设置IP,然后将物理端口配置在VLAN下 int vlan 100 ip ad...
  • 交换机IP地址和网关的配置

    千次阅读 2017-11-14 15:18:00
    实验网络拓扑图 ...1、配置主机IP地址 2、交换机配置模式 3、验证通信 实验总结 勤加练习交换机的命令 本文转自 无心低语 51CTO博客,原文链接:http://blog.51cto.com/fengzhankui/153878...
  • 配置交换机管理IP

    万次阅读 2018-04-11 23:53:47
    配置交换机管理IP 3.1 问题 配置交换机管理IP为192.168.1.1 ,默认网关为192.168.1.100 3.2 方案 网络拓扑图如图-3 图-3 3.3 步骤 实现此案例需要按照如下步骤进行 步骤一:配置交换机接口模式 1)配置路由器R1的...
  • dell 交换机配置ip并web访问

    千次阅读 2016-09-07 14:48:39
    转载于:https://blog.51cto.com/bluefei/1847287
  • 交换机修改IP地址池租约时间

    千次阅读 2018-01-30 15:18:00
    具体思路:  进入地址池视图,使用expired命令修改...3.找到dhcp server ip-pool XXX XXX就是地址池名字 4.system-view 进入系统视图 5.dhcp server ip-pool XXX 进入地址池视图 6.expired day 0 hour 5 修改租...
  • cisco3750交换机物理端口配置IP地址

    千次阅读 2013-06-27 08:00:35
    今天打算在cisco3750交换机物理端口下配置IP地址,并执行ip pim命令,结果进入后发现没有这些命令,头疼。折腾半天,解决。interfaceno switchportip addressendshow ip int bri 转载于:...
  • 交换机VLAN接口IP地址配置

    千次阅读 2011-03-08 22:16:00
    交换机VLAN接口IP地址配置 一、交换机VLAN接口静态IP地址配置 交换机VLAN接口静态IP地址配置 功能 需求及组网说明 『配置环境参数』 1. SwitchA 为三层交换机 2. PC1 连接到 SwitchA 的...
  • 如题,我在使用思科模拟器时设置交换机的端口,但是我不太理解这个ip是属于谁的 Switch(config)#interface vlan 1 Switch(config-if)#ip address 192.168.0.1 255.255.255.0 如上,这个配置ip是属于Switch...
  • 锐捷交换机绑定IP地址

    千次阅读 2012-01-29 22:14:29
    1、通过show mac-table看下这台想要固定ip的电脑插在交换机的哪个端口上2、知道了这个端口了,进入到这个端口模式下输入switchport port-security mac-address xxxx.xxxx.xxxx ip-address x.x.x.x保存退出3、在RSR20...
  • 服务器、交换机、IP与IP地址

    千次阅读 2017-03-25 23:54:39
    服务器: 顾名思义,是服务我们上网的机器。结构组成上和普通的PC结构相似,装了服务器版的系统后都可以作为服务器使用,但前者可靠性高。服务器是网络这个网上的中间节点,供每台...做开关用,为接入交换机的两个网络
  • 实验1计算机与交换机IP地址设置 1. 双击HostA, 输入用户名和入口令,键入"?"可以求得帮助。 PCA login:root Password:linux 设置 IP : [root#PCA root]# ifconfig eth0 10.65.1.1 netmask 255.255.0.0 查看 ...
  • Cisco 交换机 VLAN接口IP地址配置

    千次阅读 2012-06-19 13:36:20
    一、交换机VLAN接口静态IP地址配置 交换机VLAN接口静态IP地址配置 功能 需求及组网说明 『配置环境参数』 1. SwitchA 为三层交换机 2. PC1 连接到 SwitchA 的以太网端口 E0/1 ,属于 VLAN10 3. PC2 连接到 ...
  • 华为Quidway交换机DHCP IP地址排除

    千次阅读 2016-05-13 11:02:00
    设置网段192.168.20的 192.168.20.2至192.168.100 、 192.168.20.200 至192.168.20.254 两个网段不参与DHCP地址分配 1.进入Vlan20: 2.设置排除网段: dhcp server excluded-ip-address 192.168.20.2 192....
  • 源目ip不改变,目的IP地址不变,源mac为当前路由器的接口mac,目的mac为下一跳接口的目的mac。 理解:在数据进行传输时,数据链路层的MAC地址改变,网络层的原IP地址和目的IP地址不变。MAC地址是为了进行数据传输,...
  • 几个月来,我一直在想你。 一、网络拓扑 二、说明 1、拓扑说明:汇聚层交换机为CATALYST4506,核心交换机为CATALYST6506,接...4506上启 用IP DHCP SNOOPING和DAI以及IPSG,4506上连和下连的端口均配置为TRUNKING;65
  • 配置交换机的管理ip地址

    千次阅读 2010-11-09 12:30:00
    vlan vlan-idinterface vlan vlan-idip address ip地址 子网掩码
  • 思科交换机配置远程登录命令

    千次阅读 2020-07-20 21:14:16
    首先我们给每台交换机配置ip地址。 sw1(config)#interface vlan 1 sw1(config-if)#no shutdown sw1(config-if)#ip address 192.168.1.1 255.255.255.0 sw1(config-if)#exit sw1(config)#username cisco password 123...
  • 华为交换机配置

    万次阅读 多人点赞 2018-06-23 16:36:23
    在部署云环境中,需要配置交换机,现在总结自己学习到交换机的知识。1 华为交换机型号左侧:右侧:2 配置3 命令操作4 常见功能参考: http://network.51cto.com/art/201001/177448.htm史上最全华为路由器交换机...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 111,878
精华内容 44,751
关键字:

交换机怎么配置ip地址