精华内容
下载资源
问答
  • 交换机排错
    千次阅读
    2021-04-02 13:57:58

    思科交换机常用命令汇总

    show version
    show running-config
    show vlan brief
    show ip interface brief
    show running-config interface f0/1
    show ip route
    show inventory			//显示设备SN、设备名
    

    更换MAC地址

    在网管服务器上找到相应的报警信息,记录下交换机的IP地址及端口号。
    telnet交换机的IP地址(这里使用CRT)

    #show running-configuration interface f0/1
    右键标记,选择有MAC地址的那行命令,回车
    conf t
    interface f0/1
    no 右键粘贴			//删除原先绑定的MAC地址,这个端口会自动学习到新的MAC
    end
    show run interface f0/1
    wr				   //一定要保存配置MAC地址绑定才能生效
    

    更改业务

    show vlan brie
    conf t
    interface f0/1
    switchport access vlan 2	//把端口加入新的VLAN中
    end
    show run interface f0/1
    wr
    

    新增端口

    conf t
    show run interface f0/1
    switchport port-security
    switchport port-security violation restrict
    switchport port-security mac-address sticky
    
    如果没有配置过,则打开一个配置过的端口
    复制除VLAN和绑定MAC地址以外的命令行
    
    switchport access vlan 2
    no shutdown
    end
    show run interface f0/1
    看到端口在VLAN2中,已经学到MAC地址
    wr
    

    清除MAC记录

    no switchport port-security mac-address sticky XXXX.XXXX.XXXX vlan access
    

    关闭端口

    清除MAC地址
    interface f0/1
    shutdown
    

    关闭端口安全

    interface f0/1
    no switchport port-security
    

    备份配置

    copy run tftp
    Address or name of remote host []? 192.168.32.1
    Destination filename [config.text]?TEST-3560-1 
    

    恢复配置

    copy tftp: run
    Address or name of remote host []? 192.168.32.1
    Source filename []? test.text
    Destination filename [running-config]? 
    

    清除配置

    清除交换机配置命令:write erase
    	当然也可以使用erase startup-config就可以实现清除了
    删除VLAN信息:delete flash:vlan.dat
    

    IOS升级

    1.确保路由器与服务器的连通性(路由器配IP地址)
    
    2.从服务器更新IOS镜像
    #copy tftp flash
    []192.168.1.100					服务器的地址
    []c1841-advipservicesk9-mz.124-15.Tw.bin	新IOS的名称,注意大小写
    []						复制过来后的名称
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...!!!!!!	开始复制文件
    
    3.察看并删除旧的IOS(在需要更新的路由器上进行操作)
    #show flash				察看要删除的镜像名称
    #delete flash
    []c1841-ipbasek9-mz.124-12.bin		输入删除的镜像名称,注意大小写
    
    4.重新配置系统并重启
    (c)#no boot system flash 旧镜像名	不让系统从旧的镜像启动
    (c)#boot system flash 新镜像名称	让系统以新镜像启动
    #copy running-config startup-config	将新的配置写到NVROM5.重启
    #reload
    
    更多相关内容
  • Cisco 2960交换机排错

    2017-11-18 19:34:00
    Cisco 2960交换机排错 运维部一卡座的网络端口,接了一台TP-LINK 16口交换机,突然有天,发现接在这个交换机上的所有PC都不通了,简单检查了一下,发现此交换机进线口不亮灯(卡座口与TP-LINK交换机连接线),用测...

    Cisco 2960交换机排错

       

        运维部一卡座的网络端口,接了一台TP-LINK 16口交换机,突然有天,发现接在这个交换机上的所有PC都不通了,简单检查了一下,发现此交换机进线口不亮灯(卡座口与TP-LINK交换机连接线),用测线仪测了下,发现8个灯亮,初步判断是弱电井的2960相应的端口被shutdown了,于是登录交换机查看端口,发现并没有administrator down,百思不得其解。

        测线仪测出,8根线都是亮的,说明网线是没有问题的,端口又没被shutdown,说明没有被管理员关闭。
        再登录交换机,show一下该端口情况,仔细一看,发现第一行后面的括号里有err-disabled信息,百度一下关键字“err-disabled”,得出解决办法。

        线路不通,物理指示灯灭,而测试仪显示8根线通,可show int status查下,通过该命令发现46口有err-disabled,理由是loopback。

        在缺省配置下,思科交换机端口被置为err-disabled,IOS将不会试图万利接口,必须手工将它恢复,于是再输入命令errdisable recovery cause lookup,配置完这个命令后,查看端口情况,还是err-disabled,这是因为恢复时间需要300秒,输入sh errdisable recovery查看下,还需要多少时间才能恢复,从图上看,需要257秒。耐心等257秒后,该端口正常,TP-LINK交换机上的PC也正常。

     

    问题反思。
        这肯定是监控干的,在TP-LINK交换机上乱拉线,最后拉成环路了,思科交换机监控到环路,就把该端口置为错误端口,从而避免整个网络出现异常。当然思科交换机并不会自动去把有问题的端口置为环路,需要在每个端口下输入命令,控制广播风暴。





         本文转自itwork 51CTO博客,原文链接:http://blog.51cto.com/369369/790835,如需转载请自行联系原作者



    展开全文
  • 多层交换机的性能和连通排错
  • GNS3模拟思科三层交换机(排错细节)

    千次阅读 2020-10-20 17:17:24
    3、修改标识符,将其修改为三层交换机图形 4、连线:这里是易错点(排错) 之前我连接了上面f0/0和f0/1时,使用交换机命令的时候一直无法使用,例如switchport trunk encapsulation dot1q,switchport mode trunk等均...

    实验背景:

    今天想用GNS3模拟器,做一个单臂路由的实验时,发现没有三层交换机,就想着用路由器,模拟一下三层交换机和PC。将其中的步骤讲解一下。。

    使用C3660路由器+交换模块:模拟三层交换机

    1、拓扑如下:

    R2模拟三层交换机,R3,R4
    在这里插入图片描述

    2、添加 交换模块:

    右键R2,选择配置,进入卡槽,添加交换模块,NM-161SW即可。

    关于交换模块介绍,大家可以看我零一篇文档GNS3中路由器节点配置中的插槽分别具有什么功能?

    在这里插入图片描述
    在这里插入图片描述

    3、修改标识符,将其修改为三层交换机图形

    在这里插入图片描述
    在这里插入图片描述

    4、连线:这里是易错点(排错)

    之前我连接了上面f0/0和f0/1时,使用交换机命令的时候一直无法使用,例如switchport trunk encapsulation dot1q,switchport mode trunk等均不可,后来发现是接口连接错误。

    在这里插入图片描述

    5、路由器模拟PC

    自行将标识符改成PC,这里不做演示,如上所示。

    在这里插入图片描述
    双击PC,进入命令行:修改设备名,关闭路由功能。

    R4#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R4(config)#hostname PC2  //修改设备名为PC2
    PC2(config)#no ip routing   //关闭路由功能
    PC2(config)#
    

    在这里插入图片描述

    配置完成!!

    展开全文
  • H3C《中低端交换机常见故障实例分析》培训视频.
  • 非常实用,方便,能够解决一般的交换机故障。
  • # 排除网络故障以前,请打开这一命令以便实时的接收到交换机的提示信息。 TEST# TEST#sh run View Code TEST# TEST#sh ip int b #显示所有端口的状态 View Code TEST# TEST# TEST#sh vlan # 显示所有...

    TEST#terminal monitor

    # 排除网络故障以前,请打开这一命令以便实时的接收到交换机的提示信息。

    TEST#

    TEST#sh run        

     View Code

     TEST#

    TEST#sh ip int b    #显示所有端口的状态

     View Code

       

    TEST#  

    TEST#

    TEST#sh vlan # 显示所有的vlan信息

     View Code

    TEST#

    TEST#sh vtp sta            # 显示vtp协议的相关配置

     View Code

    TEST#

    TEST#

    TEST#sh int gi1/2         # 显示具体物理接口的信息

     View Code

      

    TEST#

    TEST#

    TEST#sh ip route   # 显示这台交换机的所有路由信息

     View Code

      

    TEST#

    TEST#sh processes cpu  # 显示交换机的cpu利用率。当前是正常的。

     View Code

      

    TEST#

    TEST#reload        # 这条命令可重新启动交换机

     TEST#

    TEST#sh ver          # 显示当前设备的版本信息

     View Code

      

    TEST#

    switch#write ;保存配置信息
    switch#show vtp ;查看vtp配置信息
    switch#show run ;查看当前配置信息
    switch#show interface ;查看端口信息
    switch#show int f0/0 ;查看指定端口信息

    switch#show ip int bir 查看端口VLAN IP 开启状态总览
    #show int status 查看端口状态总览
    #show int trunk #查看trunk 口
    switch#show vlan ;查看vlan配置端口分布信息
    switch#show interface vlan 11 # 查看VLAN11 详细信息
    #show spanning-tree 查看生成树状态
    #show spanning-tree mst configuration 查看多生成树状态信息


    #show access-list 查看规则状态
    #sh int etherchannel sum 查看“端口聚合/链路捆绑
    #sh int port-channel 查看“端口聚合/链路捆绑
    #show inventory 查看光模块显信
    #show history 查看历史输入命令
    #show errdisable recovery 查看哪些保护会在超时后可自动恢复
    #show errdisable detect查看 err-disabled 状态的原因

    关闭提示
    Router(config)#no logging console 如果你通过console连接,使用第一条
    Router(config)#no logging monitor 如果通过telnet,ssh之类连接就用第二条
    rack01r1(config)#no logging buffered 这个是关闭缓存

    展开全文
  • 中科曙光HPC培训教程汇总:D13-集群调试—博科交换机配置排错.pptx
  • H3C设备配置查看及网络故障排错

    千次阅读 2019-12-06 17:01:17
    交换机排错: 1、进入核心交换机,查看共有多少vlan段,分别是使用的什么vlan 命令 : display ip interface brief display vlan 2、查看电脑所接交换机的端口是否和电脑的ip 段是一致的,如果不一致,则...
  • 通常在排查交换机网络故障的时候,毫无头绪,可以从下方的故障诊断命令着手,可以帮你快速诊断出故障的原因。 华为交换机故障诊断命令 基本信息 display diagnostic-information 设备信息 display device 接口信息 ...
  • 检查收发功率(如果设备支持DDM就可以用命令排错)检查光模块和光纤波长对应关系,更换尾纤,清洁光模块 单端口收发自环测试:用单芯光纤短接光模块收发两端检查是否link up 更换法测试:更换尾纤,更换交换机端口...
  • 一、显示交换机的正常运行时间 -------------------------------------------------------------------- SNS:admin> uptime 16:59 up 39 days 6:05, 1 user, load average: 0.04, 0.02, 0.00 -------------------...
  • Brocade 交换机所有端口突然全down
  • 华为交换机基本故障排错命令

    千次阅读 2018-11-21 12:21:00
    华为交换机出现问题,一般都会手要你管display命令来排查故障,display命令是网络维护和故障处理的重要工具基本信息查询display diagnostic-information 或者简写 dis dia,此命令主要用于系统基本信息的收集查看设备...
  • 交换机故障排查常见方法与分析原则 网络知识 交换机的故障多种多样不同的故障有不同的表现形式故障分析时要通过各种现象灵活运用排除方法(如排除法对比法替换法)找出故障所在并及时排除 1.排除法 当我们面对故障现象...
  • 某企业大厦网络交换机自环故障分析 故障现象由于strong用户误操作在工位用一根网线的两端连接两个网口说明两个数据网口将引起交换机自环在某企业15楼一个数据网口连一个语音网口不会引起环路在某企业10楼一个数据...
  • 01 防火墙旁挂 Comware V7 平台交换机PBR部署流量三层转发环路故障经验案例 02 H3C S5560-EI 采用 IGMP-Snooping 承载监控二层组播业务典型配置案例 03 H3C Comware V7 平台 EPON 教育网典型基础配置案例 04 ...
  • 博科SAN交换机:常用命令行

    万次阅读 2016-03-28 21:26:14
    交换机基本配置命令 IP地址 ipaddrshow ipaddrset - 博科交换机的默认IP地址是10.77.77.77,在命令行模式下可以通过ipaddrset命令对交换机的IP地址进行设置和修改。 Switch Name / Hostname...
  • 最近折腾了一下BK300的配置,这篇很实用转载一下本文以Brocade 300 光纤交换机来举例说明。博科交换机的默认IP地址是10.77.77.77,用户名admin,密码:password。1、登陆交换机 在网络连接中添加IP地址“10.77.77.**...
  • 交换机环路检测

    2018-12-13 11:42:34
    交换机的环路检测,mac漂移,等故障争端,排错的思路和过程。
  • 本文以Brocade 300 光纤交换机来举例说明。博科交换机的默认IP地址是10.77.77.77,用户名admin,密码:password。1、登陆管理界面(1)、在网络连接中添加IP地址“10.77.77.**(子网掩码“255.0.0.0)”; (2)、在...
  • 网络排错思路

    2021-12-27 15:39:14
    说到网络排错,很多人都会头疼。 网络排错,它并不仅仅是停留在某一个小小命令的使用上,而是要有一个完整的思路和逻辑在,你才可以以不变应万变。 那么,作为一个网络工程师,想要拥有一个不错的网络排错能力...
  • 生产环境中的上百台路由器和交换机,以及其 他设备都无法在实验环境中体现出来。根据具体的问题,工程师应该只关注拓扑中的相关部分, 并且根据这部分拓扑来搭建并配置实验环境。 工程师是根据对问题的假设和理解来...
  • 交换机故障维护

    2018-09-25 09:47:48
    网络故障 排错 思路和方法
  • Cisco MDS9222i光纤交换机最常用排错命令 1.检查交换机端口 Show interface [interface-range] 查看指定端口运行状态,WWN信息,配置参数,收发包统计信息。 示范: MDS9222i-1# show interface fc1/1fc1/1 is...
  • 一、起因:因业务需要,公司新建IDC的服务器,需通过PXE方式自动装机,因DHCP及自动装机服务器在另一个IDC,遂...二、排错1、抓包,通过抓包,发现设备发起的arp request 4次询问,网关均没有响应 2、通过命令show...
  • 说到网络排错,很多人都会头疼。 网络排错,它并不仅仅是停留在某一个小小命令的使用上,而是要有一个完整的思路和逻辑在,你才可以以不变应万变。 那么,作为一个网络工程师,想要拥有一个不错的网络排错能力,...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,845
精华内容 1,538
关键字:

交换机排错