精华内容
下载资源
问答
  • 交换机本机mac地址
    万次阅读
    2020-06-28 10:05:03

    交换机如何查看各类MAC信息?
    一、查看系统MAC

    1)盒式交换机:

    display bridge mac-add
    System bridge MAC address: xxxx-xxxx-xxxx

    2)框式交换机:

    display system-mac
    default xxxx-xxxx-xxxx

    current xxxx-xxxx-xxxx

    二、查看接口MAC

    display interface GigabitEthernet0/0/10

    三、查看设备学习到的mac表项

    1)查看整机所有类型mac地址表项:

    display mac-address

    2)查看某端口下mac地址表项:

    display mac-address GigabitEthernet 0/0/X

    3)查看系统所有动态MAC地址表项:

    display mac-address dynamic

    更多相关内容
  • 华为交换机查看本机mac地址命令

    千次阅读 2021-04-22 16:32:17
    display interface

    使用命令:display interface

    在这里插入图片描述

    展开全文
  • 这里用一台华三S2126-E0002交换机为例,演示华三低端交换机如何把mac地址绑定端口
  • 华为交换机怎么绑定绑定ip地址/MAC地址?主要是预防IP地址被盗用等网络安全威胁的问题,该怎么设置绑定呢?下面我们就来看看详细的设置教程,需要的朋友可以参考下
  • 主要介绍了h3c交换机mac地址绑定、三层交换机固定ip上网、三层交换机端口配置ip地址的方法,需要的朋友可以参考下
  • mac地址,以及交换机的简单介绍

    千次阅读 2022-02-11 23:35:41
    一 ,Mac地址的概论,以及二层交换机 Mac的概念 Mac:凡是符合IEEE 802 标准的网络接口卡都必须拥有mac地址,不是所有网络接口卡都有必须有mac地址,例如SDH的网络接口卡就没有mac地址,因为此接口不遵从IEEE 802...

    一 ,Mac地址的概论,以及二层交换机

    Mac的概念

    Mac:凡是符合IEEE 802 标准的网络接口卡都必须拥有mac地址,不是所有网络接口卡都有必须有mac地址,例如SDH的网络接口卡就没有mac地址,因为此接口不遵从IEEE 802标准。

    Mac相当于一个人的身份证一样,用来标识一个接口,长度为48bit(6byte)。一块网卡的mac地址是具有全球唯一性的。

    BIA地址格式: OUI(3byte) +制造商分配(3byte)

    BIA地址只是mac地址的一种,单播mac地址

    Mac地址分为三种

    单播mac:第一字节的最低为是0 的mac地址

    xxxxxxx0. xxxxxxxx xxxxxxxx.xxxxxxxx.xxxxxxxx. xxxxxxxx

    OUI                           

    组播mac:第一字节的最低为是1 的mac地址

    xxxxxxx1. xxxxxxxx xxxxxxxx.xxxxxxxx.xxxxxxxx. xxxxxxxx

    非OUI

    广播mac:每个bit都为1的mac地址,广播mac’地址是组播mac地址的一个特例

    11111111.11111111.11111111.11111111. 11111111.11111111

    非OUI

    二,以太帧的格式

    帧的介绍

    以太网技术所使用的帧称为以太网帧,简称以太帧,以太帧格式有两个标准:IEEE 802.3定义的,称为IEEE 802.3格式;另一个由DEC,Intel,Xerox这三家公司联合定义的,称为Ethernet ll格式,也叫DIX格式,目前的网络设备都可以兼容这两种格式的帧,Ethernet ll格式的帧使用的更加广泛

    IEEE 802.3格式帧各字段省略

    根据目的mac地址的种类不同,以太网可分为3种类型

    单播帧:目的地址为一个单播mac地址

    组播帧:目的地址为一个组播mac地址

    广播帧:目的地址为一个广播mac地址

    三,以太网交换机

    交换机的定义

    交换机转发数据的端口都是以太网口的,称为以太网交换机(Ethernet Switch),根据转发数据的端口类型定义交换机类型.

    交换机三种转发操作(泛红,转发,丢弃)

    交换机会对进入端口的每一个帧都进行转发操作,交换机基本作用就是用来转发帧的

    泛红(Flooding):交换机从某一端口进来的帧通过所以其他端口转发出去(除此帧进入交换机的端口外的其他端口)

    转发(forwarding):交换机从某一端口进来的帧通过另一端口转发出去(另一端口,不能是这个帧进入交换机的那个端口)

    丢弃(Discarding):交换机把从某一端口进来的帧直接丢弃,其实就是不转发.

    总结:交换机接受到一个帧永远都不都会从接受那个帧的端口转发那个帧(只进不出)

    交换机工作原理

    如果进入交换机端口的帧为单播帧,则交换机回去mac地址表中查找目的mac地址

    如果查找不到这个目的mac地址,则交换机将对该帧执行泛红操作.

    如果查到了这个目的mac,比较此mac地址在mac地址表中对应的端口编号和此帧进入该交换机的端口编号是否就是一个端口

    是:交换机将对该帧执行丢此操作

    否:则交换机将该帧按从mac地址表中对应的端口编号进行转发出去,

    如果进入交换机某一端口的帧是一个广播帧,则交换机不会去查mac地址表,而是直接对该广播帧执行泛红操作

    为了验证上面理论下面给出实验结论

    使用使用到的工具 Windows 11 专业版21H2 环境下安装的ensp

    ensp510 +oracle VM VirtualBoX 5.2.40,以及用到Wireshar抓包软件

    拓扑图

    利用一台交换机链接三台pc,为了方便观看我把pc1,pc2,pc3的mac分别改成00-00-00-00-00-01,00-00-00-00-00-02,,00-00-00-00-00-03

    刚开始两台pc没有相互访问,查看一下交换机上面的mac地址表现情况如下

    什么也没有

    然后用pc1去ping pc2如下图

    看到此情况证明访问成功

    此时再来查看交换机什么的mac地址表如下图

    两台交换机上面都有了相应的mac地址表现了

    此时的pc1,和pc2的通信原理(仅仅讨论二层的)

    此次实验涉及到了ip地址(通过ip地址获得mac地址是通过arp协议的),我们先不讨论三层的转发,后面再来详细讲解三层的相关知识。

    我们先假设pc1知道pc2的mac地址,访问pc2直接用mac地址访问的。

    开启ensp里面的所有设备,目前没有二层帧的转发(stp帧除外),此时的两台交换机里面的mac地址表现是空的

    当pc1向pc2发送一个帧(此帧称为x)x里面携带两个mac地址(源mac地址pc1的mac地址,目的mac地址pc2的mac地址)的时候,通过Ge0/0/1口发送给sw1,sw1收到此帧之后,首先查看mac地址表现,此时的mac地址表现为空,则sw1将此帧从除了Ge0/0/1口之外的其他所以端口发送(同时在sw1里面生成一个mac表现,将x的源mac地址和x进入sw1的端口对应关系写进mac地址表),到pc收到x,比较x的目的mac与自己的mac不一样,丢弃,通过Ge0/0/3口发送到sw2,sw2此时mac地址表现也是空的和sw1做同样的操作,然后通过Ge0/0/2口传递给了pc2,x到了pc2,pc对比x的目的mac地址和自身的mac,发现和自身的mac地址相同,则接受。

    因为我们使用的ping(imcp里面的一个协议,具有双向性:及pc2收到pc1的ping会回复pc2所以此时的sw1,sw2的mac地址表现里面会有pc2的mac表现)

    注意如果是单向通信的话(pc1访问pc2,pc2不回复pc1)

    此拓扑图的sw的mac地址表现如下图所示

    Mac地址的概论,以及二层交换机

    Mac的概念

    Mac:凡是符合IEEE 802 标准的网络接口卡都必须拥有mac地址,不是所有网络接口卡都有必须有mac地址,例如SDH的网络接口卡就没有mac地址,因为此接口不遵从IEEE 802标准。

    Mac相当于一个人的身份证一样,用来标识一个接口,长度为48bit(6byte)。一块网卡的mac地址是具有全球唯一性的。

    BIA地址格式: OUI(3byte) +制造商分配(3byte)

    BIA地址只是mac地址的一种,单播mac地址

    Mac地址分为三种

    单播mac:第一字节的最低为是0 的mac地址

    xxxxxxx0. xxxxxxxx xxxxxxxx.xxxxxxxx.xxxxxxxx. xxxxxxxx

    OUI                           

    组播mac:第一字节的最低为是1 的mac地址

    xxxxxxx1. xxxxxxxx xxxxxxxx.xxxxxxxx.xxxxxxxx. xxxxxxxx

    非OUI

    广播mac:每个bit都为1的mac地址,广播mac’地址是组播mac地址的一个特例

    11111111.11111111.11111111.11111111. 11111111.11111111

    非OUI

    以太帧的格式

    帧的介绍

    以太网技术所使用的帧称为以太网帧,简称以太帧,以太帧格式有两个标准:IEEE 802.3定义的,称为IEEE 802.3格式;另一个由DEC,Intel,Xerox这三家公司联合定义的,称为Ethernet ll格式,也叫DIX格式,目前的网络设备都可以兼容这两种格式的帧,Ethernet ll格式的帧使用的更加广泛

    IEEE 802.3格式帧各字段省略

    根据目的mac地址的种类不同,以太网可分为3种类型

    单播帧:目的地址为一个单播mac地址

    组播帧:目的地址为一个组播mac地址

    广播帧:目的地址为一个广播mac地址

    以太网交换机

    交换机的定义

    交换机转发数据的端口都是以太网口的,称为以太网交换机(Ethernet Switch),根据转发数据的端口类型定义交换机类型.

    交换机三种转发操作(泛红,转发,丢弃)

    交换机会对进入端口的每一个帧都进行转发操作,交换机基本作用就是用来转发帧的

    泛红(Flooding):交换机从某一端口进来的帧通过所以其他端口转发出去(除此帧进入交换机的端口外的其他端口)

    转发(forwarding):交换机从某一端口进来的帧通过另一端口转发出去(另一端口,不能是这个帧进入交换机的那个端口)

    丢弃(Discarding):交换机把从某一端口进来的帧直接丢弃,其实就是不转发.

    总结:交换机接受到一个帧永远都不都会从接受那个帧的端口转发那个帧(只进不出)

    交换机工作原理

    如果进入交换机端口的帧为单播帧,则交换机回去mac地址表中查找目的mac地址

    如果查找不到这个目的mac地址,则交换机将对该帧执行泛红操作.

    如果查到了这个目的mac,比较此mac地址在mac地址表中对应的端口编号和此帧进入该交换机的端口编号是否就是一个端口

    是:交换机将对该帧执行丢此操作

    否:则交换机将该帧按从mac地址表中对应的端口编号进行转发出去,

    如果进入交换机某一端口的帧是一个广播帧,则交换机不会去查mac地址表,而是直接对该广播帧执行泛红操作

    为了验证上面理论下面给出实验结论

    使用使用到的工具 Windows 11 专业版21H2 环境下安装的ensp

    ensp510 +oracle VM VirtualBoX 5.2.40,以及用到Wireshar抓包软件

    拓扑图

    利用一台交换机链接三台pc,为了方便观看我把pc1,pc2,pc3的mac分别改成00-00-00-00-00-01,00-00-00-00-00-02,,00-00-00-00-00-03

    刚开始两台pc没有相互访问,查看一下交换机上面的mac地址表现情况如下

    什么也没有

    然后用pc1去ping pc2如下图

    看到此情况证明访问成功

    此时再来查看交换机什么的mac地址表如下图

    两台交换机上面都有了相应的mac地址表现了

    此时的pc1,和pc2的通信原理(仅仅讨论二层的)

    此次实验涉及到了ip地址(通过ip地址获得mac地址是通过arp协议的),我们先不讨论三层的转发,后面再来详细讲解三层的相关知识。

    我们先假设pc1知道pc2的mac地址,访问pc2直接用mac地址访问的。

    开启ensp里面的所有设备,目前没有二层帧的转发(stp帧除外),此时的两台交换机里面的mac地址表现是空的

    当pc1向pc2发送一个帧(此帧称为x)x里面携带两个mac地址(源mac地址pc1的mac地址,目的mac地址pc2的mac地址)的时候,通过Ge0/0/1口发送给sw1,sw1收到此帧之后,首先查看mac地址表现,此时的mac地址表现为空,则sw1将此帧从除了Ge0/0/1口之外的其他所以端口发送(同时在sw1里面生成一个mac表现,将x的源mac地址和x进入sw1的端口对应关系写进mac地址表),到pc收到x,比较x的目的mac与自己的mac不一样,丢弃,通过Ge0/0/3口发送到sw2,sw2此时mac地址表现也是空的和sw1做同样的操作,然后通过Ge0/0/2口传递给了pc2,x到了pc2,pc对比x的目的mac地址和自身的mac,发现和自身的mac地址相同,则接受。

    因为我们使用的ping(imcp里面的一个协议,具有双向性:及pc2收到pc1的ping会回复pc2所以此时的sw1,sw2的mac地址表现里面会有pc2的mac表现)

    注意如果是单向通信的话(pc1访问pc2,pc2不回复pc1)

    此拓扑图的sw的mac地址表现如下图所示

    展开全文
  • 对于不是很常用的MAC VLAN,许多读者都感到很陌生,本文将详细介绍H3C交换机MAC VLAN原理及配置过程,需要了解更多朋友可以参考下
  • 主要介绍了python获取本机mac地址和ip地址的方法,涉及Python获取系统相关信息的技巧,需要的朋友可以参考下
  • 交换机端口MAC地址绑定命令
  • 华为交换机怎么通过已知的mac地址查找对应的端口?华为交换机中查找端口如果通过线来查找是很麻烦的,如果通过mac地址查找就方便多了,下面我们就来看看详细的教程,需要的朋友可以参考下
  • 神州数码交换机 vlan mac地址 命令
  • 不管什么型号的交换机这对二层数据转发都会有MAC地址表来进行指导转发。 [SW1]dis mac-address summary显示MAC地址总体信息,看出可用MAC地址表共可用数量32768个。MAC的学习,是在同一个广播域里学习到的,所以一般...
  • 交换机MAC地址学习

    千次阅读 2022-04-18 16:58:17
    首先我们要了解交换机mac地址是怎么学习的之前要了解一下交换机是如何工作的。 参考模型 交换机工作在OSI模型的第二层,也就是数据链路层,数据链路层传输的数据叫数据帧。数据链路层使用的封装一般使用以太网...

    首先我们要了解交换机mac地址是怎么学习的之前要了解一下交换机是如何工作的。

    参考模型

     交换机工作在OSI模型的第二层,也就是数据链路层,数据链路层传输的数据叫数据帧。数据链路层使用的封装一般使用以太网进行封装,也就是Ethernet Ⅱ 以太帧。

    这里随便抓个包演示一下

    由于交换机工作在数据链路层,也就是说交换机收到一个报文他只会解封装到数据链路层,以太,然后在根据目的mac地址来对数据帧进行传输。

    当交换机从接口收到一个报文后,解封装,然后将源mac记录在mac地址表,记录这个mac地址来源于哪个接口,当接口为down状态或超过老化时间,交换机会将来源于该接口的mac地址删除,这里后面我会实验演示。

    1.泛洪:收到目的mac地址为ff:ff:ff:ff:ff:ff,向同一广播域的接口复制转发(一对所有)

    抓包演示

    2.转发:从一个接口接收到数据帧后,查看mac地址表,存在目的mac地址,然后一对一接口转发(一对一)

    3.丢弃:从一个接口接收到数据帧后,mac地址表不存在对应mac地址或数据帧不合法,丢弃

    有了以上基础,我们就可以实战演示一下交换机的mac地址表是怎么生成的,以及如何转发数据帧。

    以下实验使用华为模拟器实现,其他模拟器也可以同样验证,原理一样。

    拓扑图

    步骤一

    第一步我们先看看交换机的mac地址表

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname S1                                  #设置主机名
    [S1]display mac-address                             #查看mac地址表

     

     我们可以看到初始状态交换机的mac地址表是空的,华为交换机直接不显示,下一步我们看看交换机是如何将mac添加到表上的。

    步骤二

    为PC1添加IP地址,然后发送广播帧。

    由于是二层网络,这里不需要添加网关IP地址。

    然后ping一个网络中没有的主机地址,发送广播帧。

     

     抓包截取

    PC1尝试广播获取目的IP地址mac。

    步骤三

    查看交换机mac地址表

     此时可以看到交换机将PC1的mac地址记录并标明来源的接口。

    总结:也就是说当交换机收到某接口的数据帧时,将该数据帧的源mac地址记录到交换机的mac地址表并标明来源接口,下一次收到数据帧时,并通过mac地址表进行转发。

    扩展:交换机MAC地址绑定(静态)

    拓扑图

     R1

    [Huawei]sysname R1
    [R1]interface Ethernet0/0/0
    [R1-Ethernet0/0/0]ip address 192.168.1.1 24
    [R1-Ethernet0/0/0]mac-address 1-1-1          #更改mac地址

    R2

    [Huawei]sysname R2
    [R2]interface Ethernet0/0/0
    [R2-Ethernet0/0/0]ip address 192.168.1.2 24
    [R2-Ethernet0/0/0]mac-address 2-2-2          #更改mac地址

    S1

    [S1]mac-address static 1-1-1 Ethernet 0/0/1 vlan 1     #静态mac绑定
    [S1]mac-address static 2-2-2 Ethernet 0/0/2 vlan 1     #静态mac绑定
    [S1]interface Ethernet0/0/1
    [S1-Ethernet0/0/1]port link-type access                
    [S1-Ethernet0/0/1]q
    [S1]interface Ethernet0/0/2
    [S1-Ethernet0/0/2]port link-type access 
    [S1-Ethernet0/0/2]q
    

    查看交换机MAC地址表

    END

    展开全文
  • 交换机MAC地址问题

    千次阅读 2021-07-02 12:10:50
    以太网中,每一个节点,都需要一个MAC地址,而以太网交换机可以与多个终端连接,也就有多个节点,因此,交换机上也会有多个MAC地址存在,如交换机的每个接口都有一个MAC地址,包含物理接口和SVI接口。除此之外,还有...
  • 华为USG夸三层交换机识别客户端MAC地址的配置方法
  • 描述:中兴网络设备交换机路由器查看MAC地址表项命令方法 命令: show mac
  • 交换机MAC地址

    千次阅读 2021-07-04 12:31:53
    以太网MAC地址2.以太网帧格式3.交换机的工作原理3.1交换机以太网接口的工作模式3.2交换机以太网接口速率4.华为命令4.1管理路由器/交换机的方式总结 前言 1.什么是交换技术?MAC地址又有什么作用?交换机的工作原理是...
  • MAC地址飘逸也就是我们经常说的拓扑地址翻摆,交换机的不同接口可能在很短的时间内反复学习到同一个MAC地址,例如交换网络中交换机网线被误接或配置错误形成了环网;网络中某些非法用户仿冒合法的MAC地址进行MAC地址...
  • IP地址MAC地址的关系: IP地址是根据现在的IPv4标准指定的,不受硬件限制比较容易记忆的地址,长度4个字节。而 MAC地址却是用网卡的物理地址,保存在网卡的EPROM里面,与硬件有关系,比较难于记忆,长度为6个字节...
  • 交换机动态学习mac地址

    千次阅读 2020-03-19 21:01:22
    下载地址:https://www.onlinedown.net/soft/636885.htm 一、网络结构 1、选择终端、集线器、交换机 2、终端与集线器之间使用直通线,终端与交换机之间使用直通线 3、集线器与交换机之间使用交叉线 4、网络结构...
  • 路由器有一两台三四台的情况下可以进行静态路由配置,如果路由器多了的话如果在配置静态路由就会很麻烦,还要一台一台的去配置,这里面为了节省工作效率,路由器内可以设置动态路由,让他们自己学邻居的路由,章...
  • 通过这条命令就可看到存储在当前交换机中的MAC地址表,里边记录了交换机目前学习到的所有主机MAC地址交换机端口的映射关系,二层数据正是通过查找这种映射关系发送到目的主机的,下边的MAC和端口的互查命令其实...
  • 最常用的二层交换机所用的依据是MAC地址表,而三层交换机的依据是路由表,多层交换机的依据是网络协议或端口号 MAC地址MAC地址表记录了相连设备的MAC地址、接口号以及所属的VLAN ID之间的对应关系,是VLAN内数据...
  • 不会使用思科交换机绑定mac地址的老铁们可以看一下,简单实用
  • 通俗的讲,没太交换机都有一个MAC地址表,该表记录了交换机每个端口与终端设备的MAC地址的映射关系,交换机的工作原理就是跟据MAC表中的端口与主机地址的映射关系来选择目的端口,进行二层数据转发。所以通过MAC地址...
  • cisco交换机通过ip地址查看mac地址

    万次阅读 2018-04-19 15:34:49
    1、查看MAC地址表show mac address-table 通过这条命令就可看到存储在当前交换机中的MAC地址表,里边记录了交换机目前学习到的所有主机MAC地址交换机端口的映射关系,二层数据正是通过查找这种映射关系发送到目的...
  • 为了防止ARP攻击,我们经常需要在三层交换机上做IP地址MAC地址的绑定操作,以华为交换机为例,一般需要执行如下一些命令:1、查看arp记录,即ip与mac的对应表disp arp | in简单解释一下这个命令:disp:是display...
  • 交换机MAC地址绑定

    2021-07-28 06:37:51
    要求交换机实现mac地址绑定,一个端口对应一个MAC地址,非法pc连接不上,但是此端口并不断开,只能此MAC——pc机能连上2.一个端口绑定多MAC地址需求1>en#config terminal(config)#errdisable recovery cause ...
  • H3C核心交换机获取所有IP地址MAC地址 登录交换机 显示arp信息 如图所示,所有IP和mac地址都可以显示 保存结果 保存结果到文件,arp_20180928.txt 下载数据 H3C交换机内置了tftp客户端,可以将数据上传到tftp...
  • 以太网交换机端口安全MAC地址技术白皮书.docx

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 75,076
精华内容 30,030
关键字:

交换机本机mac地址