精华内容
下载资源
问答
  • 交换机default
    千次阅读
    2019-07-22 14:35:57

    原文链接:http://blog.51cto.com/jh391546079/981845

    Cisco的二层交换机上通常会有一个命令为ip default-gateway,直译就是默认网关的意思。
    一直都知道在二层上面敲这个命令,但是对其概念和用途却不是很清楚。
    网上有的朋友说这是和默认路由一个意思,今天经过一段研究,终于弄懂了其中的意思。
    其实很简单,这个命令是用于远程管理的,也就是vty,通常是在配置了vlan1的接口地址以后,在配置该地址,以指向三层的地址。
    如下:
    conf t
    int vlan 1
    ip add 192.168.0.101 255.255.255.0
    no sh
    exit
    ip default-gateway 192.168.0.254
    以上,192.168.0.254是二层上面的三层的管理地址,通常是三层的vlan1 的地址。而192.168.0.101则是该二层交换机的管理地址。
    配置了管理地址和ip default-gateway就是将该二层交换机看做是一台主机,主机总是要设置默认网关的。
    如果仅设置了valn1 的管理地址,但是没有设置默认网关的地址,是无法用vty进行远程管理连接的。
    同时需要注意的是,二层交换机的vlan1的地址必须与其配置的ip default-gateway的地址在同一个网段。这个很容易理解。

    总结:1、二层交换机上的ip default-gateway的地址总是与管理vlan的地址配合出现,以用于vty远程管理,仅此一个目的而已。如果不需要远程管理,可以不配置,不会影响其他的数据通讯(与什么vlan间通讯====的都没关系)
    2、如果配置了管理vlan的地址,就一定要配置ip default-gateway的地址。否则无法远程管理。管理vlan的地址必须与ip defaulut-gaeway地址在同一网段。

    转载于:https://blog.51cto.com/jh391546079/981845

    更多相关内容
  • RabbitMQ:交换机default exchange)

    千次阅读 2020-02-09 23:35:55
    com.rabbitmq amqp-client 3.6.5 默认交换机 默认交换机default exchange)实际上是一个由消息代理预先声明好的没有名字(名字为空字符串)的直连交换机(direct exchange)。 它有一个特殊的属性使得它对于...

    首先看看AMQP协议,对RabbitMQ的架构会更了解。

    深入理解AMQP协议

    创建一个Maven项目,根据自己服务器RabbitMQ的版本导入相应的包。
    在这里插入图片描述

    		<dependency>
    			<groupId>com.rabbitmq</groupId>
    			<artifactId>amqp-client</artifactId>
    			<version>3.6.5</version>
    		</dependency>
    

    默认交换机

    默认交换机(default exchange)实际上是一个由消息代理预先声明好的没有名字(名字为空字符串)的直连交换机(direct exchange)。

    它有一个特殊的属性使得它对于简单应用特别有用处:那就是每个新建队列(queue)都会自动绑定到默认交换机上,绑定的路由键(routing key)名称与队列名称相同。

    举个栗子:当你声明了一个名为 “search-indexing-online” 的队列,AMQP 代理会自动将其绑定到默认交换机上,绑定(binding)的路由键名称也是为 “search-indexing-online”。因此,当携带着名为 “search-indexing-online” 的路由键的消息被发送到默认交换机的时候,此消息会被默认交换机路由至名为 “search-indexing-online” 的队列中。换句话说,默认交换机看起来貌似能够直接将消息投递给队列,尽管技术上并没有做相关的操作。

    生产端

    package com.kaven.rabbitmq.exchange.defaultExchange;
    
    import com.rabbitmq.client.Channel;
    import com.rabbitmq.client.Connection;
    import com.rabbitmq.client.ConnectionFactory;
    
    import java.io.IOException;
    import java.util.concurrent.TimeoutException;
    
    public class DefaultProducer {
    
        // 自己服务器的IP
        private static String ip = "IP";
        // RabbitMQ启动的默认端口,也是应用程序进行连接RabbitMQ的端口
        private static int port = 5672;
        // RabbitMQ有一个 "/" 的虚拟主机
        private static String virtualHost = "/";
    
        // default exchange
        private static String exchange = "";
        // default exchange 的路由规则: routingKey(test) 将匹配同名的 queue(test)
        private static String routingKey = "test";
    
        public static void main(String[] args) throws IOException, TimeoutException {
            // 1 创建一个连接工厂
            ConnectionFactory connectionFactory = new ConnectionFactory();
            connectionFactory.setHost(ip);
            connectionFactory.setPort(port);
            connectionFactory.setVirtualHost(virtualHost);
    
            // 2 通过连接工厂创建连接
            Connection connection = connectionFactory.newConnection();
    
            // 3 通过连接创建一个Channel
            Channel channel = connection.createChannel();
    
            // 4 通过Channel 发送数据
            for (int i = 0; i < 5; i++) {
                String msg = "Hello RabbitMQ:" + i;
                // 1 default的exchange ,2 routingKey
                channel.basicPublish(exchange,routingKey, null , msg.getBytes());
            }
    
            // 5 关闭相关的连接
            channel.close();
            connection.close();
        }
    }
    

    消费端

    package com.kaven.rabbitmq.exchange.defaultExchange;
    
    import com.rabbitmq.client.Channel;
    import com.rabbitmq.client.Connection;
    import com.rabbitmq.client.ConnectionFactory;
    import com.rabbitmq.client.QueueingConsumer;
    
    import java.io.IOException;
    import java.util.concurrent.TimeoutException;
    
    public class DefaultConsumer {
    
        // 自己服务器的IP
        private static String ip = "IP";
        // RabbitMQ启动的默认端口,也是应用程序进行连接RabbitMQ的端口
        private static int port = 5672;
        // RabbitMQ有一个 "/" 的虚拟主机
        private static String virtualHost = "/";
    
        // 定义的队列名
        private static String queueName = "test";
    
        // default exchange
        private static String exchange = "";
    
        public static void main(String[] args) throws IOException, TimeoutException, InterruptedException {
            // 1 创建一个连接工厂
            ConnectionFactory connectionFactory = new ConnectionFactory();
            connectionFactory.setHost(ip);
            connectionFactory.setPort(port);
            connectionFactory.setVirtualHost(virtualHost);
    
            // 2 通过连接工厂创建连接
            Connection connection = connectionFactory.newConnection();
    
            // 3 通过连接创建一个Channel
            Channel channel = connection.createChannel();
    
            // 4 声明(创建)一个队列
            // 队列名、持久化、独占、自动删除、参数
            channel.queueDeclare(queueName , true,false , false , null);
    
            // 5 创建消费者
            QueueingConsumer queueingConsumer = new QueueingConsumer(channel);
    
            // 6 设置Channel
            // 队列名、自动回复ACK(收到消息后)、消费者
            channel.basicConsume(queueName , true , queueingConsumer);
    
            // 7 获取消息
            while(true){
                QueueingConsumer.Delivery delivery = queueingConsumer.nextDelivery();
                String msg = new String(delivery.getBody());
                System.out.println("消费端:" + msg);
            }
        }
    }
    

    测试一

    先启动消费端。
    看看RabbitMQ Management
    有了一个新的ConnectionChannelQueueConsumer

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    队列的Name显然和我们定义的一样。
    在这里插入图片描述
    我们再来启动生产端。
    消费端成功收到消息。

    消费端:Hello RabbitMQ0
    消费端:Hello RabbitMQ1
    消费端:Hello RabbitMQ2
    消费端:Hello RabbitMQ3
    消费端:Hello RabbitMQ4
    

    RabbitMQ Management也会有反应,有显示相应的rate
    在这里插入图片描述

    测试二

    先启动生产端。
    RabbitMQ Management也会有反应,有相应的Ready=5等。
    在这里插入图片描述
    再启动消费端。
    也成功收到了消息。

    消费端:Hello RabbitMQ0
    消费端:Hello RabbitMQ1
    消费端:Hello RabbitMQ2
    消费端:Hello RabbitMQ3
    消费端:Hello RabbitMQ4
    

    RabbitMQ Management也会有反应,有相应的Ready=0,因为消费端已经全部收到了。
    在这里插入图片描述
    无论先启动生产端还是消费端,消费端都可以收到消息,所以说消费端成功收到消息跟两个应用是否同时在线无关,跟两个应用启动的先后顺序无关,不需要两个应用一直连接,耦合度低。

    展开全文
  • 简析交换机三种端口模式

    千次阅读 2020-09-21 10:26:57
    交换机常见的三种端口模式。

    环境:华为Ensp模拟器进行实验。
    交换机端口的三种模式

    1. Access
    2. Trunk
    3. Hybrid

    Access接口通常是交换机连接电脑终端的接口,Trunk接口是交换机与交换机之间连接的接口,Hybrid接口说实话我以前都没有怎么听说过这个类型的接口,主要是access和trunk已经足够使用了。直到偶然看到有这么一个接口类型。Hybrid接口可以说是Access+Trunk的集合吧(个人理解,不对请指正)。
    先看下标准的Access和Trunk口在网络上的应用吧。
    拓扑图如下:
    在这里插入图片描述
    配置:SW1(左)

    G0/0/1口配置trunk口
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     
    G0/0/2配置划分Access口到vlan10:
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    
    G0/0/3配置Access划分到vlan20:
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    
    

    配置SW2(右)

    G0/0/1口配置trunk口
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     
    G0/0/2配置划分Access口到vlan10:
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    
    G0/0/3配置Access划分到vlan20:
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 20
    

    两边交换机配置是相似的,然后电脑配置好地址
    PC1
    在这里插入图片描述
    PC2
    在这里插入图片描述
    PC3
    在这里插入图片描述
    PC4
    在这里插入图片描述
    联通性测试:
    PC1 ping PC3,PC2 ping PC4
    在这里插入图片描述

    在这里插入图片描述
    实验结果:交换机通过1口设置Trunk口允许VLAN 10 20 通过,2口,3口分别设置Access口,证明不同交换机同一个VLAN可以通过Trunk实现通信。这个是比较常用的配置。

    下面实验Hybrid口进行实验。
    拓扑图还是差不多,就是都是使用Hybrid接口进行配置
    在这里插入图片描述
    简析:
    交换机通过G0/0/1口;连接,设置为hybrid口,两端默认的pvid保持一致,给vlan 10 vlan 20 打标记,允许通过这段链路。
    交换机连接电脑的接口也配置为hybrid接口,然后配置·对应的pvid,相当于access口划分VLAN,然后还要配置untagged,允许通过的vlan接口。

    SW1配置:

    interface GigabitEthernet0/0/1
     port hybrid tagged vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    

    SW2配置:

    interface GigabitEthernet0/0/1
     port hybrid tagged vlan 10 20
    #
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/3
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    

    交换机配置还是差不多的,就是用不到trunk口和access口。
    测试联通性截图:
    加粗样式
    在这里插入图片描述
    测试都是可以互通的。
    结论:过去都是实验Trunk+Access口来配置交换机和电脑,现在也可以使用Hybrid接口来配置,相对于其他的接口,hybrid更加灵活,兼具两种接口的特性。

    展开全文
  • Core-1# show ip Internet (IP) Service IP Routing : Disabled Default Gateway : Default TTL : 64 Arp Age : 20 Domain Suffix : DNS server : | Proxy ARP VLAN | IP Config IP Address Subnet Mask Std Local ...

    实例拓扑如下:
    在这里插入图片描述

    vlan和IP配置

    Core-1

    1. Access the terminal session with Core-1.
    2. Assign VLAN 1 the IP address 10.1.1.1 with a 24-bit mask.
      Core-1# configure
      Core-1(config)# vlan 1 ip address 10.1.1.1/24
      Core-1(config)# exit
    3. Verify the configuration.
      Core-1# show ip
      Internet (IP) Service
      IP Routing : Disabled
      Default Gateway :
      Default TTL : 64
      Arp Age : 20
      Domain Suffix :
      DNS server :
      | Proxy ARP
      VLAN | IP Config IP Address Subnet Mask Std Local
      ------------ + --------- ---------- ------------- ----------
      DEFAULT_VLAN | Manual 10.1.1.1 255.255.255.0 No No

    Access-1
    4. Repeat this process for Access-1, assigning VLAN 1 the IP address 10.1.1.3/24.
    Access-1# configure
    Access-1(config)# vlan 1 ip address 10.1.1.3/24
    Access-2
    5. Repeat this process for Access-2, assigning VLAN 1 the IP address 10.1.1.4/24.
    Access-2# configure
    Access-2(config)# vlan 1 ip address 10.1.1.4/24

    展开全文
  • 调试交换机工具.rar

    2021-07-27 15:34:26
    putty,SecureCRT工具
  • 华为核心交换机vlan配置工具
  • 二层交换机,只做同网段或同vlan转发功能,要实现vlan间的数据转发需要使用单臂路由,或者使用三层交换机2.在三层交换机上使用iprouting命令将交换机转到三层工作模式3.此时可以在每个vlan上配上不同网段的IP,不同...
  • 主要介绍了华为5700交换机OSPF配置,适合自学及初学者学习参考
  • 思科交换机配置命令大全switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3:交换机命名hostname...
  • 迈普交换机配置.doc

    2019-08-08 09:18:03
    迈普交换机基本配置命令,适用于初学者掌握,简单易懂。
  • H3C交换机802.1x配置步骤详细说明
  • CISCO三层交换机怎么配置DHCP服务?利用CISCO三层交换机自带的DHCP功能,可以实现多VLAN的IP地址自动分配,在三层交换机上如何配置DHCP服务呢,下面一起来看看
  • 华为交换机配置端口模式时报错: [500Mdaikuan-GigabitEthernet0/0/1]port link-type access Error: Please renew the default configurations. [500Mdaikuan-GigabitEthernet0/0/1]dis th [V300R019C10SPC300] # ...
  • 在华为交换机上使用混杂端口时报这个错,原因是你之前已经将此端口加入了某个vlan 所以你需要undo之前配置的命令 解决方法 sys int G 0/0/1 #替换为报错的端口 undo port default vlan undo port link-type 然后...
  • 华为S5700三层交换机,实现两个网段互通的最简单配置!自编,供参考。 以192.168.1.0/24和172.16.1.0/24两个网段作示例。
  • 思科光纤交换机,配置 Cisco FC 交换机,思科MDS系列光纤交换机配置手册,思科MDS系列光纤交换机配置手册
  • 我们将在此拓扑图的基础上进行实验 大多命令都可用tab键位来补齐 1.分别给pc机设置好ip地址 pc2为:192.168.1.1 pc3为:192.168.2.1 ...3.对交换机进行基础的配置,使pc机能远程到交换机 enable ...
  • 本实验的拓扑结构如图5-1所示(注意交换机的类型)。 2.1 PC-1连接至左边S1交换机的Ethernet0/0/2端口,PC-2连接至S1交换机的Ethernet0/0/3端口,PC-3连接至S2交换机的Ethernet0/0/3端口, PC-4连接至S2交换机的...
  • 思科2960交换机配置命令
  • S12700交换机忘记密码怎么办
  • 大家都知道的 配置交换机,核心路由的软件!
  • 所有华为系列二层三层交换机的配置都在这里了,55个配置示例
  • 华为ensp交换机配置

    2022-01-07 10:22:48
    华为ensp交换机配置
  • 华为交换机的dot1x认证[归纳].pdf
  • 在华为三层交换机上进行VLAN间路由的配置,主要就是创建VLAN,端口划分,三层VLAN接口地址配置,静态路由或是RIP协议配置
  • 主要介绍了DELL6224交换机基本配置命令一览,需要的朋友可以参考下
  • cisco 交换机中ip default-gateway命令

    千次阅读 2015-07-23 13:19:32
    ip default-gateway是指以你的交换机为源到别的子网经过的网关,跟你能不能上网是一点关系也没有的;ip route 0.0.0.0 0.0.0.0 gateway_ip是指到数据到达交换机之后,怎么查找下一跳,两个不同的概念,但有着相似的...
  • 路由与交换技术实验指导实验四 交换机的高级配置
  • ZONE功能类似于以太网交换机上的VLAN功能,它是将连接在SAN网络中的设备(主机和存储),逻辑上划到为不同的区域内,使得不同区域中的设备相互间不能FC网络直接访问,从而实现网络中的设备之间的相互隔离,起到隔离...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 40,757
精华内容 16,302
关键字:

交换机default