精华内容
下载资源
问答
  • 交换机ensp配置
    千次阅读 多人点赞
    2022-01-02 08:53:03

    华为交换机ensp基础命令

    具体参考华为官方ensp文档。

    一、ip地址

    1. 路由器ip配置
    int gi 0/0/0
    ip address 192.168.43.4(IP地址)24(掩码)
    
    1. 三层交换机设ip
      (先给vlan设ip,然后吧vlan绑定到端口上)
    vlan 2
    int vlanif 2
    ip address ***
    int gi 0/0/0
    port link-type access
    port default vlan 2
    

    二、VLAN配置

    1. access配置
    vlan 10
    int ***(进入端口)
    port link-type access
    port default vlan 10
    
    1. trunk配置
    vlan batch 2 to 3
    int ***
    port link-type trunk
    port default allow-path vlan 2 to 4094
    

    三、单臂路由

    vlan batch 2 to 3
    int ***    //进入交换机一个连接pc的接口
    port link-type access 
    port default vlan 2
    int ***  //进入交换机另一个连接pc的接口
    port link-type access
    port default vlan 3
    int *** //进入交换机与路由器相邻的接口
    port link-type trunk
    port trunk allow-pass vlan 2 to 4094
    

    四、路由一个接口配置多个Ip

    (常和单臂路由同时用)

    int gi 0/0/0.1
    dot1q termination vid 2   //一个虚拟端口绑定设定的一个vlan
    ip address ***
    arp broadcast enable
    int gi 0/0/0.2
    dot1q termination vid 3
    ip address
    arp broadcast enable
    

    五、静态路由和默认路由

    ip route-static ****(不能直连的网段地址) ***(子网掩码) ***(该条路径下一跳地址)
    ip route-static ****(不能直连的网段地址) ***(子网掩码) ***(该条路径下一跳地址) preference 100(优先级)
    

    六、动态路由

    1. rip
    rip
    (version 2)
    network ***(直连的网段)
    
    1. ospf
    ospf 1
    area 0
    network ***(直连的网段)***(反掩码)
    

    七、Telnet登录并设置密码(要先给端口设置ip地址)

    1. password模式
    user-interface vty 0
    authentication-mode password
    (set authentication password cipher 123456) 
    user privilege level 3
    
    1. aaa模式
    user-interface vty 0
    authentication-mode aaa
    
    q
    aaa
    local-user ***(你设置的用户名)password cipher ****你设置的密码
    local-user ***(你设置的用户名) privilege level 3
    

    八、ACL

    1. 基本ACL
    acl 2000
    rule 5 deny source ***(网段ip)***(反掩码)
    rule 10 permit source ***(网段ip) ***(反掩码)
    q
    int gi 0/0/1
    traffic-filter outbound/inbound acl 2000
    
    1. 高级ACL
    • 拒绝ping:
    acl 3000
    rule 5 deny icmp souce ***(网段ip)***(反掩码) destination ***(网段ip)***(反掩码)
    rule permit ip
    q
    int gi 0/0/0
    traffic-filter inbound acl 3000
    
    • 拒绝ftp:
    rule 10 deny tcp souce ***(网段ip)***(反掩码) destination ***(网段ip)***(反掩码) destination-port eq ftp
    
    • 拒绝www:
    rule 15 deny tcp souce ***(网段ip)***(反掩码) destination ***(网段ip)***(反掩码) destination-port ep www
    

    九、GRE

    int tunnel 0/0/0  //创建隧道
    tunnel-protocol gre 
    source ***(源ip)
    destination***(目的ip)
    ip address ***(隧道ip)
    
    #配置基于GRE的路由协议,即连接隧道网段和源、目的网段
    rip 1
    version
    network 192.168.10.0 (源/目网段)
    network 172.16.0.0  (隧道网段)
    

    十、展示当前信息

     1. display this #查看当前配置过的命令
     2. display  current-configuration #查看所有配置 (简写 *dis cu* )
     3. display ip interface brief #查看接口的ip
     4. display interface brief #查看接口配置信息
     5. display ip routing-table #查看路由表
     6. display mac-address #查看MAC表
     7. display arp #查看ARP表
     8. display ospf peer brief #查看ospf邻居关系
     9. display  interface Eth-Trunk #查看链路聚合状态
     10. display clock #查看系统当前时间
     11. display saved-configuration #显示保存的配置文件
     12.display port vlan #查看当前配置的vlan
     13. display acl 2000/all #查看当前配置的acl
     14.display interface tunnel #查看隧道接口状态
     15.display ip routing-table protocol static 仅查看静态路由的路由信息
    

    十一、取消之前的配置

    1.undo ip address   #取消ip
    2.undo port link-type #取消配置的端口类型
    3.undo termination monitor #关闭泛洪信息
    
    更多相关内容
  • 华为路由器交换机eNSP配置命令

    万次阅读 2020-11-14 23:49:00
    华为交换机基础配置命令参考 交换机可以隔离冲突域,路由器可以隔离广播域,这两种设备在企业网络中应用越来越广泛。随着越来越多的终端接入到网络中,网络设备的负担也越来越重,这时网络设备可以通过华为专有的VRP...

    华为交换机基础配置命令参考

    交换机可以隔离冲突域,路由器可以隔离广播域,这两种设备在企业网络中应用越来越广泛。随着越来越多的终端接入到网络中,网络设备的负担也越来越重,这时网络设备可以通过华为专有的VRP系统来提升运行效率。通用路由平台VRP(Versatile Routing Platform)是华为公司数据通信产品的通用操作系统平台,它以IP业务为核心,采用组件化的体系结构,在实现丰富功能特性的同时,还提供了基于应用的可裁剪和可扩展的功能,使得路由器和交换机的运行效率大大增加。

    ​ VRP分层的命令结构定义了很多命令行视图,每条命令只能在特定的视图中执行。每个命令都注册在一个或多个命令视图下,用户只有先进入这个命令所在的视图,才能运行相应的命令。进入到VRP系统的配置界面后,VRP上最先出现的视图是用户视图。在该视图下,用户可以查看设备的运行状态和统计信息。

    命令不区分大小写

    若要修改系统参数,用户必须进入系统视图。用户还可以通过系统视图进入其他的功能配置视图,如接口视图和协议视图。

    在这里插入图片描述

    基础配置

    用户视图

    登陆设备后,直接进入用户视图模式,只能执行少量查看配置的命令;

    在这里插入图片描述

    系统视图
    用户模式下,输入system-view进入系统视图模式,可执行设备全局配置的命令;

    ctrl+z(或者return)返回到用户试图(可以使用tab键补全命令)

    ctrl+c 停止当前命令的运行 例如ping连接 记住ctrl+c 不是复制

    crtl+] 终止当前连接或切换连接

    ⬅或者ctrl+B将光标向左移动一个字符。

    Backspace或CTRL+D 删除当前光标所在位置的字符。

    ➡将光标向右移动移动一个字符。

    空格或者CTRL+H 删除光标左侧的一个字符。

    ⬇显示历史命令缓冲区中的后一条命令。

    ⬆显示历史命令缓冲区中的前一条命令。

    CTRL+W 删除光标左侧的一个字符串。

    CTRL+X 删除光标左侧所有的字符。

    ESC+F 将光标向右移动一个字符串。

    输入一个不完整的命令并按TAB键,就可以补全该命令。

    显示信息用display

    在这里插入图片描述

    “< >”表示用户视图,“[ ]”表示除用户视图以外的其它视图。
    可输入?查看当前模式下,能执行哪些命令;还可以使用"字符或者单词?"查看当前视图下“字符或者单词”开头的命令有哪些。

    在这里插入图片描述

    然后命令行输入i之后按tab,每按一下就切换一次命令。

    VRP提供两种帮助功能,分别是部分帮助和完全帮助。

    1.部分帮助指的是,当用户输入命令时,如果只记得此命令关键字的开头一个或几个字符,可以使用命令行的部分帮助获取以该字符串开头的所有关键字的提示。

    2.完全帮助指的是,在任一命令视图下,用户可以键入“?”获取该命令视图下所有的命令及其简单描述,每按一个enter,则输出关键字(是一个确定的命令关键字)增加一个;如果键入一条命令关键字,后接以空格分隔的“?”,如果该位置为关键字,则列出后面所配的全部关键字及其描述。使用ctrl+c退出

    sysname命令,命令也可以简写(保证只有一个,可以简写)

    网络上一般都会部署不止一台设备,管理员需要对这些设备进行统一管理。在进行设备调试的时候,首要任务是设置设备名。设备名用来唯一地标识一台设备。AR2200路由器默认的设备名是HUAWEI,而S5700系列默认的设备名是APPLE。设备名称一旦设置,立刻生效。
    在这里插入图片描述

    输入quit返回上一层视图模式。

    在这里插入图片描述

    接口视图模式

    视图模式下,输入局部配置命令,如interface GigabitEthernet 0/0/0,进入GigabitEthernet 0/0/0接口视图模式。

    在这里插入图片描述

    查看设备信息(用户视图下)

    display version

    在这里插入图片描述

    查看和修改系统时间(用户视图下)

    display clock查看系统时钟
    clock timezone设置所在时区
    clock datetime设置当前时间和日期
    clock daylight-saving-time设置采用夏时制

    系统时钟是设备上的系统时间戳。由于地域的不同,用户可以根据当地规定设置系统时钟。用户必须正确设置系统时钟以确保其与其他设备保持同步。

    设置系统时钟的公式为:UTC+时区偏移量+夏时制时间偏移量。clock datetime命令设置HH:MM:SS YYYY-MM-DD格式的系统时钟。但是需要注意的是,如果没有设定时区,或者时区设定为零,那么设定的日期和时间将被认为是UTC时间,所以建议在对系统时间和日期进行配置前先设置时区。

    clock timezone命令用来对本地时区信息进行设置,具体的命令参数为time-zone-name { add | minus } offset*。其中参数add表示与UTC时间相比,time-zone-name增加的时间偏移量。即,在系统默认的UTC时区的基础上,加上offset*,就可以得到time-zone-name所标识的时区时间;参数minus指的是与UTC时间相比,time-zone-name减少的时间偏移量。即,在系统默认的UTC时区的基础上,减去offset,就可以得到time-zone-name所标识的时区时间。

    有的地区实行夏令时制,因此当进入夏令时实施区间的一刻,系统时间要根据用户的设定进行夏令时时间的调整。VRP支持夏令时功能。比如,在英国,从三月的最后一个星期天到十月最后一个星期天是夏令时区间,那么可以通过执行命令指定夏令时的开始和结束时间。

    先配置时钟,再配置当前日期和时间

    display clock

    clock timezone bj add 08:00:00

    clock datetime 18:56:56 2020-11-14
    在这里插入图片描述

    配置标题信息(系统视图下)

    在这里插入图片描述

    header命令用来设置用户登录设备时终端上显示的标题信息。

    login参数指定当用户在登录设备认证过程中,激活终端连接时显示的标题信息。

    shell参数指定当用户成功登录到设备上,已经建立了会话时显示的标题信息。

    header的内容可以是字符串或文件名。当header的内容为字符串时,标题信息以第一个英文字符作为起始符号,最后一个相同的英文字符作为结束符;通常情况下,建议使用英文特殊符号,并需要确保在信息正文中没有此符号。
    在这里插入图片描述

    在这里插入图片描述

    命令等级----建议不要乱改

    用户等级命令等级名称
    00访问级
    10 and 1监控级
    20,1 and 2配置级
    3-150,1,2 and 3管理级

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。
    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。
    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

    注:某些型号设备用户等级有0-15级,区分更细,其中15级与LEVEL 3权限一致,配置时需依据具体情况而定。

    用户界面

    路由器接口:console、mini usb

    在这里插入图片描述

    console和mini usb口属于同一个接口,不能同时连接。
    在这里插入图片描述

    VTY是路由器的远程登陆的虚拟端口,0 4表示可以同时打开5个会话,进入路由器去配置命令,并且使用的配置都是一样的。

    华为网络设备同时只能有一个用户登录Console界面,因此Console用户的编号固定为0。

    不带VTY的就是实实在在的接口。

    每类用户界面都有对应的用户界面视图。用户界面(User-interface)视图是系统提供的一种命令行视图,用来配置和管理所有工作在异步交互方式下的物理接口和逻辑接口,从而达到统一管理各种用户界面的目的。在连接到设备前,用户要设置用户界面参数。系统支持的用户界面包括Console用户界面和VTY用户界面。控制口(Console Port)是一种通信串行端口,由设备的主控板提供。虚拟类型终端(Virtual Type Terminal)是一种虚拟线路端口,用户通过终端与设备建立Telnet(远程登陆)或SSH连接后,也就建立了一条VTY,即用户可以通过VTY方式登录设备。设备一般最多支持15个用户同时通过VTY方式访问。执行**user-interface maximum-**vty number 命令可以配置同时登录到设备的VTY类型用户界面的最大个数。如果将最大登录用户数设为0,则任何用户都不能通过Telnet或者SSH登录到路由器。display user-interface 命令用来查看用户界面信息。

    不同的设备,或使用不同版本的VRP软件系统,具体可以被使用的VTY接口的最大数量可能不同。

    SSH 为 Secure Shell 的缩写,SSH 为建立在应用层基础上的安全协议。SSH 是较可靠,专为远程登录会话和其他网络服务提供安全性的协议。利用 SSH 协议可以有效防止远程管理过程中的信息泄露问题。

    telnet和ssh的区别:

    telnet:使用明文传输口令和数据,是不安全的。(ftp、pop)

    ssh:对所有的数据进行加密,而且传输的数据是经过压缩的,所以传输速度快。

    配置console登录认证方式及超时时间

    Console登录:默认console登录无密码,任何人通过串口线直连设备console接口,可直接修改配置,管理员可配置console密码,登录不需要用户名,初次配置时使用console;

    超时时间:指连接设备后,一段时间内无操作,系统自动退出,需重新登录,默认超时时间为10min;

    进入console配置模式

    [HUAWEI]user-interface console 0

    Console认证方式为password,设置密码

    [HUAWEI-ui-console0]authentication-mode password

    在这里插入图片描述

    设置console密码为密文形式huawei@123 修改密码

    [HUAWEI-ui-console0]set authentication password cipher huawei@123

    在这里插入图片描述

    设置超时时间为20min0秒

    [HUAWIE-ui-console0]idle-timeout 20 0

    然后quit,使用display current-configuration检查配置结果,乱码是加密后的密码;

    在这里插入图片描述

    telnet配置

    配置密文登录验证

    [HUAWEI]user-interface vty 0 4

    指定认证方式为password

    [HUAWEI-ui-vty0-4]authentication-mode password

    在这里插入图片描述

    配置telnet使用密文认证,密码huawei123

    [HUAWEI-ui-vty0-4]set authentication password cipher huawei123

    在这里插入图片描述

    配置用户等级3,缺省为级别1,若不设,则很多命令用不了。

    [HUAWEI-ui-vty0-4]user privilege level 3

    配置用户界面命令(这些命令都要在用户界面中,也就是user-interface中)

    在这里插入图片描述

    用户可以设置Console界面和VTY界面的属性,以提高系统安全性。如果一个连接上设备的用户一直处于空闲状态而不断开,可能会给系统带来很大风险,所以在等待一个超时时间后,系统会自动中断连接。这个闲置切断时间又称超时时间,默认为10分钟。

    当display命令输出的信息超过一页时,系统会对输出内容进行分页,使用空格键切换下一页。

    如果一页输出的信息过少或过多时,用户可以执行screen-length命令修改信息输出时一页的行数。默认行数为24,最大支持512行。不建议将行数设置为0,因为那样将不会显示任何输出内容了。

    每条命令执行过后,执行的记录都保存在历史命令缓存区。用户可以利用(↑),(↓) 这些快捷键调用这些命令。历史命令缓存区中默认能存储10条命令,可以通过运行history-command max-size改变可存储的命令数,最多可存储256条。

    可以使用display history-command查看历史命令,默认10条。

    配置AAA登录认证

    AAA认证

    如果没有权限限制,未授权的用户就可以使用设备获取信息并更改配置。从设备安全的角度考虑,限制用户的访问和操作权限是很有必要的。用户权限和用户认证是提升终端安全的两种方式。用户权限要求规定用户的级别,一定级别的用户只能执行特定级别的命令。

    配置用户界面的用户认证方式后,用户登录设备时,需要输入密码进行认证,这样就限制了用户访问设备的权限。在通过VTY进行Telnet连接时,所有接入设备的用户都必须要经过认证。

    设备提供三种认证模式,AAA模式、密码认证模式和不认证模式。AAA认证模式具有很高的安全性,因为登录时必须输入用户名和密码。密码认证只需要输入登录密码即可,所以所有的用户使用的都是同一个密码。使用不认证模式就是不需要对用户认证直接登陆到设备。需要注意的是,Console界面默认使用不认证模式。

    对于Telnet登录用户,授权是非常必要的,最好设置用户名、密码和指定和帐号相关联的权限。

    authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处radius(远程拨号认证系统)服务或hwtacacs(华为终端访问控制系统)服务器完成认证/授权;

    进入vty配置模式

    [HUAWEI]user-interface vty 0 4

    退出vty配置模式后,进入aaa配置模式

    [HUAWEI]aaa

    配置本地用户huawei密码为密文huawei123

    [HUAWEI-aaa]local-user huawei password cipher huawei123

    配置huawei用户服务类型为telnet

    [HUAWEI-aaa]local-user huawei service-type telnet

    配置huawei用户特权等级15(模拟器不支持此配置,只有用户等级0-3)

    [HUAWEI-aaa]local-user huawei privilege level 15

    配置完成后查看结果,其中aaa认证模式无特殊要求,均采用默认模式

    telnet登录时会要求输入username和password

    配置设备超级密码

    超级密码

    在用户权限较低时(例如Telnet登陆时,可以定义权限级别为0或1),此时

    可以使用super命令进行权限提升。为避免非法权限提升带来的危害,应该配置

    超级密码进行防护。

    为HUAWEI设置超级密码,密码以simple(明文)方式存储(模拟器不支持)

    [HUAWEI]super password simple huawei

    保存及查看配置

    保存所有配置信息,先提交后保存

    [HUAWEI]commit

    save

    img

    查看已保存的所有配置

    [HUAWEI]display saved-configuration

    查看当前所有配置

    [HUAWEI]display current-configuration

    IP及路由配置

    配置接口IP地址

    拓扑图如下:

    [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-xSH1m6qN-1605368257533)(C:\Users\hzy\AppData\Roaming\Typora\typora-user-images\image-20201114212650945.png)]

    要在接口运行IP服务,必须为接口配置一个IP地址。一个接口一般只需要一个IP地址。在特殊情况下,也有可能为接口配置一个次要IP地址。例如,当路由器AR2200的接口连接到一个物理网络时,该物理网络中的主机属于两个网段。为了让两个网段的主机都可以通过路由器AR2200访问其它网络,可以配置一个主IP地址和一个次要IP地址。一个接口只能有一个主IP地址,如果接口配置了新的主IP地址,那么新的主IP地址就替代了原来的主IP地址。

    用户可以利用ip address <ip-address > { mask | mask-length } 命令为接口配置IP地址,这个命令中,mask代表的是32 比特的子网掩码,如255.255.255.0,mask-length 代表的是可替换的掩码长度值,如24,这两者可以交换使用。

    Loopback接口是一个逻辑接口,可用来虚拟一个网络或者一个IP主机。在运行多种协议的时候,由于Loopback接口稳定可靠,所以也可以用来做管理接口。Loopback接口是一种逻辑接口,在未创建之前,Loopback接口并不存在。从创建开始,Loopback接口就一直存在,并一直保持Up状态,除非被手动关闭。

    在给物理接口配置IP地址时,需要关注该接口的物理状态。默认情况下,华为路由器和交换机的接口状态为up;如果该接口曾被手动关闭,则在配置完IP地址后,应使用undo shutdown打开该接口。

    RTA配置

    [RTA]undo portswitch batch GE 1/0/0 GE 1/0/0开启三层转发

    [RTA]interface GE 1/0/0 进入接口配置模式

    [RTA-GE1/0/0]ip address 10.0.12.1 24 配置IP及netmask

    [RTA-GE1/0/0]description this port connect to RTA GE 1/0/0 添加端口说明(可选)

    [RTA-GE1/0/0]undo shutdown 激活接口

    [RTA]commit 提交配置

    [RTA]interface LoopBack 1 创建一个逻辑接口

    保存后查看配置:

    在这里插入图片描述

    命令功能
    display version查看路由器基本信息
    display interface GigabitEthernet 0/0/0查看接口状态信息
    display ip interface brief查看全部接口的IP简要信息,含IP地址
    display ip routing-table查看路由表
    display current-configuration查看当前的配置(内存中)
    display saved-configuration查看保存的配置(Flash中)
    dir flash:查看Flash中的文件
    save保存配置文件
    reboot重启设备

    1、FE是快速以太网接口:快速以太网是一类新型的局域网,其名称中的“快速”是指数据速率可以达到100Mbps,是标准以太网的数据速率的十倍。

    2、GE是千兆以太网接口:千兆

    S口

    Serial接口的意思,也叫高速异步串口,主要是连接广域网的V.35线缆用的,说白了就是路由器和路由器连接时候用的,可以用命令设置带宽,一般也就在10M、8M左右。

    E口

    是Ethernet接口,叫以太网接口,也是主要连接以太网(局域网)用的,也是用普通的双绞线就可以连接,速率默认是10Mbps,现在新型的设备上已经把这个接口淘汰了。另外,路由器上还有一个必不可少的接口是Console口,叫控制口,这个接口是用来调试路由器的。有的路由器还有AUX接口,也是控制接口;还有G口,是千兆以太网接口,是连接以太网用的。

    F口

    是FastEthernet接口,快速以太网口,也叫百兆口。主要连接以太网(局域网)用的,说白了就是连接交换机或电脑用的,用普通的双绞线就可以连接,速率默认是100Mbps,可以用命令限速,但是不可能超过100Mbps。

    G口

    G口是Gigabitethernet的意思,是千兆口。Gigabit只表示它是千兆口,不管是光口还是电口显示都是一样的,你要详细看的话,可以display int查看。

    GigabitEthernet可以是光口,也可以是电口,具体看设备参数。Ethernet是以太网端口,GigabitEthernet是千兆以太网端口,两者都是由IEEE 802.3-2005标准定义,可以采用网线也可以采用光纤。

    路由器和猫是不一样的。

    计算机需要连接互联网必须使用路由器。猫是在不同媒体之间传输的网络信号切换设备。

    区别:

    1、外形不同。

    2、用途不同。

    路由器的作用是关于网络信号的再分配,也就是说通过路由器的使用,能够让多台电脑共同使用一根网线来上网。
    猫的作用是为了能够转接不同介质的网络信号,比如说将ADSL,光线,有线通等等不同的网络信号通过猫来转变成为标准的电脑网络信号。
    3、端口数量不同。

    路由器一般是4端口和8端口。猫一般是2端口,接入端口有两种,一种是用来连接电话线的,还有一种是用来连接RJ-45口网线的。

    展开全文
  • 关于交换机配置 这是最基本的网络拓扑。不需要配置交换机,直接pc1就可以ping到pc2.这里通过抓包可以理解一下原理:首先arp协议寻找目的IP的mac地址。这个arp包被交换机转发到各个端口。当收到arp回应知道目的mac...

    关于交换机的配置

    在这里插入图片描述
    这是最基本的网络拓扑。不需要配置交换机,直接pc1就可以ping到pc2.在这里插入图片描述这里通过抓包可以理解一下原理:首先arp协议寻找目的IP的mac地址。这个arp包被交换机转发到各个端口。当收到arp回应知道目的mac后利用icmp测试连通性。
    在这里插入图片描述

    下面看一下稍微复杂一点点的拓扑:
    在这里插入图片描述

    这里对pc1和pc3都配置为VLAN10;
    对pc2和pc4都配置为VLAN20.
    这里等效于说pc1和pc3在同一局域网,他们之间能相互ping通,同理,pc2和pc4也是在同一局域网。但不同局域网之间却不能直接ping通,例如pc1就不能ping通pc2。

    这里给出交换机的配置方法:

    [S2]un in en  //关闭很烦人的提示信息
    Info: Information center is disabled.
    [S2]vlan 10  //创建vlan10
    [S2-vlan10]q
    [S2]vlan 20 //创建vlan20
    [S2]int G0/0/1//进入交换机001号接口
    [S2-GigabitEthernet0/0/1]port link-type access //配置端口类型
    [S2-GigabitEthernet0/0/1]port default vlan 10//配置该接口的所属vlan
    [S2-GigabitEthernet0/0/1]int G0/0/2  //这里和配置第一个端口方法相同
    [S2-GigabitEthernet0/0/2]port link-type access
    [S2-GigabitEthernet0/0/2]port default vlan 20
    [S2-GigabitEthernet0/0/2]int G0/0/3	//配置3号端口和前两个略微不一样,后面会介绍两张端口类型的区别
    [S2-GigabitEthernet0/0/3]port link-type trunk //设置端口类型
    [S2-GigabitEthernet0/0/3]port trunk allow-pass vlan all //设置运行通过的vlan包,这里直接设置可以通过所有vlan的包
    

    关于acess和truck端口的区别:

    1、端口用途不同:truck端口为与其它交换机端口相连的VLAN汇聚口,access端口为交换机与VLAN域中主机相连的端口;
    2、trunk一般是打tag标记的,一般只允许打了该tag标记的vlan 通过,所以该端口可以允许多个打tag标记的vlan 通过,而access端口一般是untag不打标记的端口,而且一个access vlan端口只允许一个access vlan通过。
    (回答来自百度知道)

    展开全文
  • 通过与华为合作伙伴共同组织,现提供完整的华为 eNSP关于 路由器、交换机设备,配置单臂路由、链路聚合、三层交换机的实例,包含拓朴图、配置命令及详细设置,亲测可用。希望有需要的朋友下载,交流。
  • eNSP交换机配置VLAN

    千次阅读 2021-12-22 20:42:17
    运行eNSP>新建拓扑>搭建如下图的拓扑结构>启动设备 2.测试主机间连通性 四台主机基础配置如下 10.10.1.0/24 PC1: IP地址:10.10.1.1 子网掩码:255.255.255.0 网关:10.10.1.0 PC2: IP地址:10.10....

    一、VLAN配置过程

    1. 搭建拓扑结构

    运行eNSP>新建拓扑>搭建如下图的拓扑结构>启动设备

     2.测试主机间连通性

      四台主机基础配置如下      10.10.1.0/24

    PC1:   IP地址:10.10.1.1   子网掩码:255.255.255.0   网关:10.10.1.0
    PC2:   IP地址:10.10.1.2   子网掩码:255.255.255.0   网关:10.10.1.0
    PC3:   IP地址:10.10.1.3   子网掩码:255.255.255.0   网关:10.10.1.0
    PC4:   IP地址:10.10.1.4   子网掩码:255.255.255.0   网关:10.10.1.0

    测试主机间连通性: 运用ping命令测试各主机间连通性

    PC 1 :

    PC>ping 10.10.1.2

    Ping 10.10.1.2: 32 data bytes, Press Ctrl_C to break

    From 10.10.1.2: bytes=32 seq=1 ttl=128 time=47 ms


    PC1>ping 10.10.1.3

    Ping 10.10.1.3: 32 data bytes, Press Ctrl_C to break

    From 10.10.1.3: bytes=32 seq=1 ttl=128 time=63 ms

    PC>ping 10.10.1.4

    Ping 10.10.1.4: 32 data bytes, Press Ctrl_C to break

    From 10.10.1.4: bytes=32 seq=1 ttl=128 time=78 ms

    如上,PC1与其他三台主机都能联通

    PC2 ,PC3,PC4经测试都能与其他三台主机联通

    3 . 配置交换机

    配置交换机LSW1 :

    进入管理员系统,构建VLAN1 , VLAN2 

    将0/0/1和0/0/2端口设置为access类型

    将0/0/3端口设置为trunk类型

     查看 VLAN :  display vlan

     配置交换机LSW 2:

    步骤同上

     4 . 实验验证

    测试VLAN中个主机间连通性

    ping命令测试

    PC1:

    PC>ping 10.10.1.2

    Ping 10.10.1.2: 32 data bytes, Press Ctrl_C to break

    From 10.10.1.1: Destination host unreachable

    PC>ping 10.10.1.3

    Ping 10.10.1.3: 32 data bytes, Press Ctrl_C to break

    From 10.10.1.3: bytes=32 seq=1 ttl=128 time=78 ms

    PC>ping 10.10.1.4

    Ping 10.10.1.4: 32 data bytes, Press Ctrl_C to break

    From 10.10.1.1: Destination host unreachable

    测试结果:
    通过ping命令测试,可得结果为:

    PC1与PC3之间相互连通,与PC2、PC4不通

    PC2与PC4之间相互连通,与PC1、PC3不通

    实验结论:

    PC1与PC3属于VLAN1;
    PC2与PC4属于VLAN2.
    VLAN构建成功

    二、相关知识点。

    1.什么是VLAN?
    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。

    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。

    2.VLAN的作用。
    通过划分不同的VLAN,VLAN内的主机间可以直接通信,而VLAN间不能直接互通,从而将广播报文限制在一个VLAN内。
    作用:限制广播域、增强局域网的安全性(不同VLAN用户不能直接通信)、提高网络的健壮性(限制故障)、灵活构建虚拟工作组(同一VLAN用户不局限于固定的物理范围)。

    3. VLAN的优点。
    3.1 端口的分隔。
    即便在同一个交换机上,处于不同VLAN的端口也是不能通信的。这样一个物理的交换机可以当作多个逻辑的交换机使用。
    3.2 网络的安全。
    不同VLAN不能直接通信,杜绝了广播信息的不安全性。
    3.3 灵活的管理。
    更改用户所属的网络不必换端口和连线,只需更改软件配置。
    VLAN技术的出现,使得管理员根据实际应用需求,把同一物理局域网内的不同用户逻辑地划分成不同的广播域,每一个VLAN都包含一组有着相同需求的计算机工作站,与物理上形成的LAN有着相同的属性。由于它是从逻辑上划分,而不是从物理上划分,所以同一个VLAN内的各个工作站没有限制在同一个物理范围中,即这些工作站可以在不同物理LAN网段 。由VLAN的特点可知,一个VLAN内部的广播和单播流量都不会转发到其他VLAN中,从而有 助于控制流量、减少设备投资、简化网络管理、提高网络的安全性。 VLAN除了能将网络划 分为多个广播域,从而有效地控制广播风暴的发生,以及使网络的拓扑结构变得非常灵活 的优点外,还可以用于控制网络中不同部门、不同站点之间的互相访问。

    4.交换机端口类型。
    4.1 Access
    Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;
    4.2 Trunk
    Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;
    4.3 Hybrid
    Hybrid类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

    Hybrid端口和Trunk端口在接收数据时,处理方法一样,唯一不同之处在于发送数据时:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签

    展开全文
  • 交换机 ensp基本命令

    千次阅读 2021-03-08 15:11:06
    以太网交换机工作原理以太网以太网MAC地址交换机工作原理交换机工作模式华为交换机基本命令 以太网 以太网工作在数据链路层 (1)X-WIRE ---------- 2.94M实验性以太网 (2)DIX --------------- 10兆以太网 (3)...
  • eNSP交换机配置IP

    万次阅读 2022-03-20 12:24:20
    交换机配置 在聊交换机设置IP的前,首先聊以下方面,这也是为了新手更好的去理解。如果基础的可以直接看VLAN的命令的配置 1、交换机的工作原理 2、VLAN的的作用 3、 VLAN的命令配置 交换机的工作原理 1、学习:把...
  • 配置华为ensp三层交换机
  • 华为ensp交换机配置

    2022-01-07 10:22:48
    华为ensp交换机配置
  • ENSP路由交换机配置

    千次阅读 2022-05-14 09:54:48
    目的:对交换机配置DHCP,实现PC自动获取IP地址。 设备概述: 设置两个vlan,分别为vlan10 和 vlan 20。然后将两个PC分别划分到两个vlan里。设置两个交换机S5700,分别为辅助交换机(acsw)和核心交换机(coresw)...
  • eNSP交换机的DHCP配置(萌新版)

    千次阅读 2022-04-21 20:06:51
    交换机的dhc配置快速入门系列
  • 华为ENSP路由+交换机实验配置

    千次阅读 2022-03-13 13:07:36
    华为ENSP路由+交换机实验配置一、拓扑图二、主机配置PC1PC2PC3PC4PC5PC6三、交换机与路由器运行代码SW1SW2R1R2四、检验结果1. PC1 和 PC3 能 Ping 通 PC52.PC2 能 Ping 通 PC43.PC6 能 Ping 通 PC4,但是不能Ping ...
  • 华为 eNSP—三层交换机配置 完整配置文件
  • ensp三层交换机配置实验

    万次阅读 2021-08-20 19:05:59
    ​ 文章目录前言 前言 一、怎么实现不同网段不同VLAN通信? 二、使用步骤1....设备说明:三个S5700-28C-HI三层交换机和四个PC机,其中LSW和2LSW3充当二层交换机使用。 2.配置: PC1 PC2 PC3 PC4 LSW2
  • 华为交换机_禁止ensp配置更改警报.docx华为交换机_禁止ensp配置更改警报.docx华为交换机_禁止ensp配置更改警报.docx华为交换机_禁止ensp配置更改警报.docx华为交换机_禁止ensp配置更改警报.docx华为交换机_禁止ensp...
  • 华为交换机_禁止ensp配置更改警报.pdf华为交换机_禁止ensp配置更改警报.pdf华为交换机_禁止ensp配置更改警报.pdf华为交换机_禁止ensp配置更改警报.pdf华为交换机_禁止ensp配置更改警报.pdf华为交换机_禁止ensp配置...
  • ENSP静态路由实验,两台交换机不同网段间互通。适用于高速行业收费及监控网络。新手必回技能。配置简单,适用性强。
  • 通俗讲解
  • 交换机Telnet配置【华为eNSP模拟】

    千次阅读 2021-04-23 00:31:03
    # 可允许同时打开五个连接 [LSW1]user-interface vty 0 4 # 缺省情况下,设备同时支持Telnet和SSH协议,使用该命令配置的协议将在用户下次使用该用户线登录时生效 [LSW1-ui-vty0-4]protocol inbound telnet # 创建...
  • 华为ensp 二层交换机的基础配置

    千次阅读 2021-08-16 20:21:13
    使用一台交换机通过VLAN来隔离不同网段之间的通信 提前配置好IP及端口地址 LSW1配置: # vlan batch 10 20 # interface Ethernet0/0/1 port link-type access port default vlan 10 # interface Ethernet0/0...
  • LSW5三层交换机配置: # sysname LSW5 # vlan batch 10 20 # dhcp enable # ip pool 1 gateway-list 192.168.1.254 network 192.168.1.0 mask 255.255.255.0 dns-list 8.8.8.8 # ip pool 2 gateway-list 192....
  • ENSP配置 实例八 三层交换机dhcp配置加vlan划分实验 LW1配置 [SW1]vlan batch 10 20 [SW1-GigabitEthernet0/0/1]port link-type trunk [SW1-GigabitEthernet0/0/1]p t a vlan 10 20 [SW1]int Vlanif 10 [SW1-Vlanif...
  • 华为ENSP Telnet配置交换机

    千次阅读 2020-12-23 20:15:06
    配置文件: SW1 配置文件 interface Vlanif1 ip address 192.168.1.10 255.255.255.0 [sw1]user-interface vty 0 4 [sw1-ui-vty0-4]authentication-mode password [sw1-ui-vty0-4]set authentication password ...
  • eNSP上模拟华为S5700三层交换机的vlan入门配置 一、实验拓扑图如下 二、实验目的 1、将S5700交换机上端口G0/0/1按照默认在vlan1,并设置网关为192.168.1.1; 2、G0/0/2划入vlan20,并设置网关为192.168.20.1; 3...
  • ensp交换机划分VLAN的配置

    千次阅读 2022-01-31 17:39:36
    int e0/0/2 [LSW2-Ethernet0/0/2]port link-type access [LSW2-Ethernet0/0/2]port default vlan 3 [LSW2]int g0/0/1 [LSW2-GigabitEthernet0/0/1]port link-type trunk 对交换机配置好之后 查看VLAN 可以看到上述...
  • 华为eNSP实验:三层交换机配置

    万次阅读 多人点赞 2019-12-17 15:41:31
    文章目录一、实验环境二、实验拓扑三、实验需求四、实验步骤pc1设置pc2设置pc3设置pc4设置LSW1交换机设置LSW2交换机设置LSW3三层交换机设置R1路由设置五、验证需求六、注意事项 一、实验环境 eNSP V100R003C00SPC100...
  • ensp交换机console口telnet配置.docxensp交换机console口telnet配置.docxensp交换机console口telnet配置.docxensp交换机console口telnet配置.docxensp交换机console口telnet配置.docxensp交换机console口telnet配置....
  • 一、要求 vlanif 10 192.168.1.254---接口地址池 dns:8.8.8.8 租期:1天12小时 保留地址:1.100-1.200 绑定地址:1.50--PC5 ...vlanif 20 192.168.2.254---全局地址池 ...二、配置 [Huawei]int e0/0/1 [Hua...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,333
精华内容 1,733
关键字:

交换机ensp配置