精华内容
下载资源
问答
  • 交换机mac地址冲突
    千次阅读
    2020-12-20 10:26:52

    进入程序/附件/通讯/超级终端

    com1 /还原默认值/确定

    回车

    &ltH3C&gt

    %Jul 31 03:09:43:616 2000 H3C SHELL/5/LOGIN:- 1 - Console(aux0) in unit1 login

    &ltH3C&gt

    &ltH3C&gtsys //进入配置模式

    System View: return to User View with Ctrl+Z.

    [H3C]dis cur //显示vlan信息

    #

    sysname H3C

    #

    radius scheme system

    #

    domain system

    #

    vlan 1

    #

    interface Aux1/0/0

    #

    interface Ethernet1/0/1

    #

    interface Ethernet1/0/2

    #

    interface Ethernet1/0/3

    #

    interface Ethernet1/0/4

    #

    interface Ethernet1/0/5

    #

    interface Ethernet1/0/6

    #

    interface Ethernet1/0/7

    #

    interface Ethernet1/0/8

    #

    interface Ethernet1/0/9

    #

    interface Ethernet1/0/10

    #

    interface Ethernet1/0/11

    #

    interface Ethernet1/0/12

    #

    interface Ethernet1/0/13

    #

    interface Ethernet1/0/14

    #

    interface Ethernet1/0/15

    #

    interface Ethernet1/0/16

    #

    interface Ethernet1/0/17

    #

    interface Ethernet1/0/18

    #

    interface Ethernet1/0/19

    #

    interface Ethernet1/0/20

    #

    interface Ethernet1/0/21

    #

    interface Ethernet1/0/22

    #

    interface Ethernet1/0/23

    #

    interface Ethernet1/0/24

    #

    interface GigabitEthernet1/1/1

    #

    interface GigabitEthernet1/1/2

    #

    interface GigabitEthernet1/1/3

    #

    interface GigabitEthernet1/1/4

    #

    undo irf-fabric authentication-mode

    #

    interface NULL0

    #

    voice vlan mac-address 0001-e300-0000 mask ffff-ff00-0000

    #

    user-interface aux 0 7

    user-interface vty 0 4

    #

    return

    [H3C]int vlan 1 //定义vlan

    [H3C-Vlan-interface1]

    %Jul 31 03:12:05:644 2000 H3C L2INF/5/VLANIF LINK STATUS CHANGE:- 1 -

    Vlan-interface1: is UP

    [H3C-Vlan-interface1]

    [H3C-Vlan-interface1]

    [H3C-Vlan-interface1]ip add 192.168.0.241 255.255.255.0 //定义ip地址

    [H3C-Vlan-interface1]

    %Jul 31 03:14:04:894 2000 H3C IFNET/5/UPDOWN:- 1 -Line protocol on the interface

    Vlan-interface1 is UP

    [H3C-Vlan-interface1]

    [H3C-Vlan-interface1]ping 192.168.0.5 //ping 冲突ip

    PING 192.168.0.5: 56 data bytes, press CTRL_C to break

    Reply from 192.168.0.5: bytes=56 Sequence=1 ttl=127 time=21 ms

    Reply from 192.168.0.5: bytes=56 Sequence=2 ttl=127 time=4 ms

    Reply from 192.168.0.5: bytes=56 Sequence=3 ttl=127 time=5 ms

    Reply from 192.168.0.5: bytes=56 Sequence=4 ttl=127 time=6 ms

    Reply from 192.168.0.5: bytes=56 Sequence=5 ttl=127 time=6 ms

    --- 192.168.0.5 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 4/8/21 ms

    [H3C-Vlan-interface1]dis arp //显示冲突地址来源端口号 AL ID

    Type: S-Static D-Dynamic

    IP Address MAC Address VLAN ID Port Name / AL ID Aging Type

    192.168.0.5 0060-6774-b747 1 Ethernet1/0/9 20 D

    --- 1 entry found ---

    [H3C-Vlan-interface1]qu //退出vlan设置

    [H3C]undo int vlan 1 //删除刚设置的vlan ip

    [H3C]

    %Jul 31 03:17:24:319 2000 H3C L2INF/5/VLANIF LINK STATUS CHANGE:- 1 -

    Vlan-interface1: is DOWN

    %Jul 31 03:17:24:429 2000 H3C IFNET/5/UPDOWN:- 1 -Line protoco

    更多相关内容
  • 当计算机使用过程中出现“计算机探测到IP地址与您的网卡物理地址发生冲突”的错误时,您就无法使用网络。如果在网络用户连网的同时,建立IP地址MAC地址的信息档案,自始至终地对局域网客户执行严格的管、登记制度...
  • 交换机如何解决IP地址冲突

    千次阅读 2020-12-20 10:26:50
    如何防止IP地址冲突故障?这个在实际项目中经常会遇到,网络用户如果没有按照规定设置IP地址的话,IP地址冲突现象就不可避免,一旦这种现象频繁发生,不但会影响上网效率,而且也不利于局域网网络的稳定运行。为了...

    如何防止IP地址冲突故障?这个在实际项目中经常会遇到,网络用户如果没有按照规定设置IP地址的话,IP地址冲突现象就不可避免,一旦这种现象频繁发生,不但会影响上网效率,而且也不利于局域网网络的稳定运行。

    为了提高局域网运行稳定性,我们不能等IP地址冲突故障发生时,才想办法去应对,而应该主动出击,让上网用户无法抢用局域网中的其他IP地址。

    一、发生ip冲突的原因是什么?

    发生IP地址冲突的原因:

    1、很多用户不知道“IP地址”、“子网掩码”、“默认网关”等参数如何设置,有时用户不是从管理员处得到的上述参数的信息,或者是用户无意和私自修改了这些信息所导致的;

    2、有时管理员或用户根据管理员提供的参数进行设置时,由于失误造成参数输错也会导致该情况发生;

    3、出现得最多的是在客户机维修调试时,维修人员使用临时IP地址应用造成;

    二、组网举例

    举例:

    局域网大约有150个网络节点,这些网络节点平均分布在六个楼层,每一个楼层中的网络节点都通过100M双绞线与普通二层交换机保护连接,而每一个普通二层交换机又通过1000M光纤线缆连接到路由交换机上,为了保证网络访问安全,所有网络节点都通过硬件防火墙与Internet网络互联互通。

    目前,单位局域网使用的是10.168.163.0网段的IP地址:

    该网段中使用的默认网关地址为10.168.163.1,子网掩码地址255.255.255.0,

    由于该网段最多能拥有250多个IP地址,在平时工作中实际只用到150多个地址,显然足够大的地址空间余量完全可以满足工作站数量不断增加的需求。

    但由于单位局域网采用了静态地址分配方法,每当工作站系统发生突然崩溃或遭遇病毒攻击不能正常启动时,上网用户都自行其是,随意重新安装系统、修改上网地址,结果局域网中频繁出现IP地址冲突现象,这不但严重影响了他人的正常上网访问,而且也加大了网络管理员的维护工作量。

    三、解决方案

    为了有效避免上网用户任意改动IP地址,所以打算采用地址绑定的方法,将工作站的IP地址与对应网卡设备的物理地址(MAC)绑定在一起,然而这种方法还并不是最有效的,是治标不治本,因为上网用户仍然可以采用修改电脑网卡物理地址的方法,来窃取他人的IP地址,很显然这种不是最有效的解决办法。

    四、如何才能有效的解决

    分析

    核心交换机上对普通工作站的IP地址和网卡物理地址(MAC)进行绑定操作,可是简单地进行绑定操作,也不能解决上网用户随意设置IP地址的现象,

    因为某个IP地址一旦被设置绑定后,虽然上网用户不能继续抢用这个IP地址,但是他仍然可以抢用局域网中处于空闲的IP地址,这样一来IP地址冲突现象仍然可能会发生。

    这也是很多网络管理员百思不得其解的问题:在核心交换机中将所有工作站使用的IP地址绑定到对应MAC地址上后,仍然无法有效避免地址冲突故障。

    要想彻底解决IP地址冲突故障,我们不但需要将局域网中已分配出去的IP地址绑定到对应网卡设备上。而且还需要对那些处于空闲状态的IP地址进行绑定。

    这样一来上网用户既不能使用已经连网工作站的IP地址,又不能使用局域网中空闲的IP地址,因此只要局域网中的上网用户随意改动IP地址的话,他就不能正常接入到局域网网络中。

    不过这样配置后,也带来了另外一个麻烦,那就是如果局域网中有新的用户需要上网访问时,就不能由自己作主任选IP地址,而必须事先向网络管理员单独申请上网,网络管理员接受到申请后需要登录进入交换机后台管理系统对空闲地址进行放号,上网用户才能正常连接到局域网中。实践证明,这种方法不但可以有效避免IP地址冲突故障发生,而且还能有效地防止网络病毒通过局域网非法传播,从而可以有效地保障局域网的稳定运行!

    五、实施过程

    依照上述理论分析,打算先将局域网中默认网关地址10.168.1.143绑定到对应的物理地址上,这样可以有效控制局域网中ARP病毒的爆发,之后再想办法对已经上网工作站的IP地址执行绑定操作,最后将那些处于空闲状态的IP地址集中绑定到一个虚拟的网卡物理地址上,如此一来就能实现一石二鸟的效果了。

    1、那么如何绑定ip地址与mac物理地址呢?

    首先输入cmd进入命令配置符,然后输入命令ipconfig/all,查看本机ip及mac地址情况。

    输入字符串命令“arp -s 10.168.1.1 34-F3-9A-2B-9E-13“,即可绑定。

    紧接着输入命令arp -a查询绑定是否成功。

    很明显,默认网关地址10.168.1.143就被成功绑定36-F3-9A-2B-9E-13, MAC地址上了,其他工作站日后上网时如果抢用10.168.1.143地址时,就会出现无法上网的故障现象,如此一来整个局域网的运行稳定性就能得到保证了。

    为了防止用户抢用其他IP地址,我们需要把已经上网的150个左右网络节点地址绑定起来,由于待绑定的地址数量比较多,单纯依靠手工方法获取每台工作站的网卡物理地址和IP地址,工作量将会十分巨大,所以在交换机后台系统的全局配置状态下,执行“display arp”字符串命令,之后将显示出来的交换机ARP表中的内容复制拷贝到本地纪事本编辑窗口中,通过简单的编辑修改后,再将修改后的ARP表内容复制粘贴到交换机ARP表中,这样一来就能快速完成已上网工作站地址的绑定任务。

    2、绑定空闲的ip地址

    对于剩下100个左右的空闲IP地址,我们可以采用手工方法依次将每一个空闲的IP地址绑定到虚拟的MAC地址上,例如要将 10.168.1.156地址绑定到07-1e-33-ea-89-75上时,我们可以在交换机后台系统的全局配置状态下,执行字符串命令“arp 10.168.1.143 07 1e 33 ea 89 75”,之后我们再按同样的方法将其他空闲IP地址绑定到虚拟MAC地址07 1e 33 ea 89 75上。

    3、对于新用户来了,可以释放ip地址给他

    完成上面的地址绑定任务后,任何用户都不能随意更改IP地址,倘若此时有新的用户需要使用空闲的10.168.1.156地址上网访问时,网络管理员可以按照下面的操作步骤,将10.168.1.156地址从绑定地址列表中释放出来:

    a、首先在路由交换机后台管理系统执行“system”命令,将系统状态切换到全局配置状态,在该状态下输入字符串命令“display arp”,单击回车键后,从其后出现的ARP列表中检查一下10.168.1.156地址是否处于空闲状态,要是目标IP地址处于空闲状态,我们就能继续执行下面的释放步骤了:

    b、其次输入字符串命令“no arp 10.168.1.156 07 1e 33 ea 89 75 arpa”,单击回车键后,目标IP地址10.168.1.156就从地址绑定列表中释放出来了;

    c、下面将10.168.1.156地址告诉给需要上网的用户,让他将该IP地址设置到对应工作站系统中,如此一来新增用户就能顺利地接入到单位局域网网络中了;

    d、之后在核心交换机的后台管理系统,继续执行字符串命令“display arp in 10.168.1.156”,从其后返回的结果界面中我们可以查看得到对应10.168.1.156地址的网卡物理地址为00-bb-eb-c3-c6-d0;

    e、得到该MAC地址后,我们可以继续执行字符串命令“arp 10.168.1.156 00 bb eb c3 c6 d0 arpa”,这样一来新上网用户的IP地址与网卡物理地址就被成功绑定在一起了,

    最后依次执行字符串命令“quit”、“save”,将上述配置操作保存到交换机系统中,结束交换机配置任务。

    在煤矿通信中,安全性和传输距离是非常重要的两个因素。矿井的传统通信方式,一般使用RS485总线进行低波特率远距离传输,这样传输的问题在于,传输安全性无法得到保证。在通信电缆发生故障时,问题在短时间内很难排查,给用户造成了很大的不便。MIE5408交换机有哪些优点在新型的矿井通信中……阅读全文 >>

    交换机对于我们来说并不陌生,因为我们每天上网,尤其是在办公室里面,都需要用到交换机。电话交换机作为交换机的一种,其功能也是分配和转换信息。只不过电话交换机转换的是语音信息。有了这个交换机,对于接通电话的管理上来说的确是方便了不少。那么,对于这样的新产品,在使用上出现故障的情况也是……阅读全文 >>

    交换机可以说是局域网里面相对较重要的网络连通设备,在一些公共场所局域网的管理还是会依靠交换机来进行。但是就目前来说还有很多朋友对于网管交换机相对比较陌生,那么小编下面就结合实际的情况来给大家介绍一下网管交换机怎么设置,以便给大家一些参考。网管交换机怎么设置之具体功能对于网管交换机……阅读全文 >>

    交换机是什么?它是一种用于电信号转发的网络设备,它在生活中占据着重要的地位,而华为交换机在交换机市场中也占据着不可或缺的地位,下面小编将要向大家大致介绍一下华为交换机以及某些华为交换机的价格介绍,希望能够帮助到大家。华为交换机怎么样?华为拥有雄厚的实力以及优秀的技术研发人才,由它……阅读全文 >>

    国民品牌华为旗下的产品数目众多,包括手机、交换机等等多个系列,不同型号的产品对应不同的消费人群和适用场景,因此在市面上的报价和销售定位也会有所差异。今天为大家带来的是关于华为H3C交换机的两个方面的内容——包括华为H3C交换机的简介以及限制网速的教程。有意向购买华为H3C交换机的……阅读全文 >>

    很多人可能都会疑问,分VLAN就是为了让不一样虚拟网段之间不能互访,为何还要画蛇添足,又让不一样VLAN之间能够互访呢?这不是自相矛盾吗?其实不是的,这种情况在很多时候还是需要的。单臂路由和三层交换机有什么区别比如,我们将各个部门,比如,老板办公室、财务部、业务部、人事部、生产部……阅读全文 >>

    交换机是一种常见的网络设备,交换机的主要作用是可以任意的接入两个网络节点,享受两个节点的电信号作用。格林威尔交换机主要生产的是以太网交换机,在现在被广泛使用。下面是小编认为几款比较好的格林威尔交换机,大家可以看看。格林威尔交换机推荐格林威尔EasyPathGH2528POE是可网……阅读全文 >>

    作为家喻户晓的国民品牌,华为不仅在智能手机的设计制造领域成就显著,旗下每一款产品基本上都拥有一大批忠实的拥护者,而且华为经过多年的发展,还将产品延伸到了其他领域。比如接下来小编要为大家介绍的华为s1224这款交换机就是一款在各个方面均有出色表现的产品。希望以下相关的文字图片内容能……阅读全文 >>

    相信很多使用思科路由器的用户都遇到过这样那样的问题,没有关系,下面我们分析了两种常见的cisco交换机故障排除方法。单位前几天新买了一台思科的cisco交换机,配了WS-X6548-GE-TX这个思科在去年四月才新推出的10兆、100兆、1000兆自适应的48口RJ-45交换模块……阅读全文 >>

    电话交换机一般在工作上使用的比较多,电话交换机是一种特殊用途的用户交换机,它有若干电话机共用外线,适用于机关、团体、中小企业等单位,也可以用于住宅和秘书电话。电话交换机只要不停电,指示就会一直灯一闪一闪,有电话出进工作正常,给我们简单提示有电话需要交换。那么下面我们一起来了解下深……阅读全文 >>

    展开全文
  • 交换机解决电脑IP地址冲突

    千次阅读 2020-07-27 20:31:33
    很多朋友提到,如何防止IP地址冲突故障?这个在实际项目中经常会遇到,网络用户如果没有按照规定设置IP地址的话,IP地址冲突现象就不可避免,一旦这种现象频繁发生,不但会影响上网效率,而且也不利于局域网网络的...

    很多朋友提到,如何防止IP地址冲突故障?这个在实际项目中经常会遇到,网络用户如果没有按照规定设置IP地址的话,IP地址冲突现象就不可避免,一旦这种现象频繁发生,不但会影响上网效率,而且也不利于局域网网络的稳定运行。
    为了提高局域网运行稳定性,我们不能等IP地址冲突故障发生时,才想办法去应对,而应该主动出击,让上网用户无法抢用局域网中的其他IP地址。
    在这里插入图片描述

    一、发生ip冲突的原因是什么?

    发生IP地址冲突的原因:

    1、很多用户不知道“IP地址”、“子网掩码”、“默认网关”等参数如何设置,有时用户不是从管理员处得到的上述参数的信息,或者是用户无意和私自修改了这些信息所导致的;
    2、有时管理员或用户根据管理员提供的参数进行设置时,由于失误造成参数输错也会导致该情况发生;

    3、出现得最多的是在客户机维修调试时,维修人员使用临时IP地址应用造成;

    二、组网举例

    举例:
    局域网大约有150个网络节点,这些网络节点平均分布在六个楼层,每一个楼层中的网络节点都通过100M双绞线与普通二层交换机保护连接,而每一个普通二层交换机又通过1000M光纤线缆连接到路由交换机上,为了保证网络访问安全,所有网络节点都通过硬件防火墙与Internet网络互联互通。

    目前,单位局域网使用的是10.168.163.0网段的IP地址:
    该网段中使用的默认网关地址为10.168.163.1,子网掩码地址255.255.255.0,
    由于该网段最多能拥有250多个IP地址,在平时工作中实际只用到150多个地址,显然足够大的地址空间余量完全可以满足工作站数量不断增加的需求。
    在这里插入图片描述
    但由于单位局域网采用了静态地址分配方法,每当工作站系统发生突然崩溃或遭遇病毒攻击不能正常启动时,上网用户都自行其是,随意重新安装系统、修改上网地址,结果局域网中频繁出现IP地址冲突现象,这不但严重影响了他人的正常上网访问,而且也加大了网络管理员的维护工作量。

    三、解决方案

    为了有效避免上网用户任意改动IP地址,所以打算采用地址绑定的方法,将工作站的IP地址与对应网卡设备的物理地址(MAC)绑定在一起,然而这种方法还并不是最有效的,是治标不治本,因为上网用户仍然可以采用修改电脑网卡物理地址的方法,来窃取他人的IP地址,很显然这种不是最有效的解决办法。
    在这里插入图片描述

    四、如何才能有效的解决

    分析

    核心交换机上对普通工作站的IP地址和网卡物理地址(MAC)进行绑定操作,可是简单地进行绑定操作,也不能解决上网用户随意设置IP地址的现象,

    因为某个IP地址一旦被设置绑定后,虽然上网用户不能继续抢用这个IP地址,但是他仍然可以抢用局域网中处于空闲的IP地址,这样一来IP地址冲突现象仍然可能会发生。

    这也是很多网络管理员百思不得其解的问题:在核心交换机中将所有工作站使用的IP地址绑定到对应MAC地址上后,仍然无法有效避免地址冲突故障。

    要想彻底解决IP地址冲突故障,我们不但需要将局域网中已分配出去的IP地址绑定到对应网卡设备上。而且还需要对那些处于空闲状态的IP地址进行绑定。
    这样一来上网用户既不能使用已经连网工作站的IP地址,又不能使用局域网中空闲的IP地址,因此只要局域网中的上网用户随意改动IP地址的话,他就不能正常接入到局域网网络中。
    在这里插入图片描述
    不过这样配置后,也带来了另外一个麻烦,那就是如果局域网中有新的用户需要上网访问时,就不能由自己作主任选IP地址,而必须事先向网络管理员单独申请上网,网络管理员接受到申请后需要登录进入交换机后台管理系统对空闲地址进行放号,上网用户才能正常连接到局域网中。实践证明,这种方法不但可以有效避免IP地址冲突故障发生,而且还能有效地防止网络病毒通过局域网非法传播,从而可以有效地保障局域网的稳定运行!

    五、实施过程

       依照上述理论分析,打算先将局域网中默认网关地址10.168.1.143绑定到对应的物理地址上,这样可以有效控制局域网中ARP病毒的爆发,之后再想办法对已经上网工作站的IP地址执行绑定操作,最后将那些处于空闲状态的IP地址集中绑定到一个虚拟的网卡物理地址上,如此一来就能实现一石二鸟的效果了。
    

    1、那么如何绑定ip地址与mac物理地址呢?
    首先输入cmd进入命令配置符,然后输入命令ipconfig/all,查看本机ip及mac地址情况。
    在这里插入图片描述
    输入字符串命令“arp -s 10.168.1.1 34-F3-9A-2B-9E-13“,即可绑定。
    在这里插入图片描述
    紧接着输入命令arp -a查询绑定是否成功。
    很明显,默认网关地址10.168.1.143就被成功绑定36-F3-9A-2B-9E-13, MAC地址上了,其他工作站日后上网时如果抢用10.168.1.143地址时,就会出现无法上网的故障现象,如此一来整个局域网的运行稳定性就能得到保证了。

       为了防止用户抢用其他IP地址,我们需要把已经上网的150个左右网络节点地址绑定起来,由于待绑定的地址数量比较多,单纯依靠手工方法获取每台工作站的网卡物理地址和IP地址,工作量将会十分巨大,所以在交换机后台系统的全局配置状态下,执行“display arp”字符串命令,之后将显示出来的交换机ARP表中的内容复制拷贝到本地纪事本编辑窗口中,通过简单的编辑修改后,再将修改后的ARP表内容复制粘贴到交换机ARP表中,这样一来就能快速完成已上网工作站地址的绑定任务。
    

    2、绑定空闲的ip地址
    对于剩下100个左右的空闲IP地址,我们可以采用手工方法依次将每一个空闲的IP地址绑定到虚拟的MAC地址上,例如要将 10.168.1.156地址绑定到07-1e-33-ea-89-75上时,我们可以在交换机后台系统的全局配置状态下,执行字符串命令“arp 10.168.1.143 07 1e 33 ea 89 75”,之后我们再按同样的方法将其他空闲IP地址绑定到虚拟MAC地址07 1e 33 ea 89 75上。

    3、对于新用户来了,可以释放ip地址给他
    完成上面的地址绑定任务后,任何用户都不能随意更改IP地址,倘若此时有新的用户需要使用空闲的10.168.1.156地址上网访问时,网络管理员可以按照下面的操作步骤,将10.168.1.156地址从绑定地址列表中释放出来:

    a、首先在路由交换机后台管理系统执行“system”命令,将系统状态切换到全局配置状态,在该状态下输入字符串命令“display arp”,单击回车键后,从其后出现的ARP列表中检查一下10.168.1.156地址是否处于空闲状态,要是目标IP地址处于空闲状态,我们就能继续执行下面的释放步骤了:

    b、 其次输入字符串命令“no arp 10.168.1.156 07 1e 33 ea 89 75
    arpa”,单击回车键后,目标IP地址10.168.1.156就从地址绑定列表中释放出来了;

    c、下面将10.168.1.156地址告诉给需要上网的用户,让他将该IP地址设置到对应工作站系统中,如此一来新增用户就能顺利地接入到单位局域网网络中了;

    d、之后在核心交换机的后台管理系统,继续执行字符串命令“display arp in 10.168.1.156”,从其后返回的结果界面中我们可以查看得到对应10.168.1.156地址的网卡物理地址为00-bb-eb-c3-c6-d0;

    e、得到该MAC地址后,我们可以继续执行字符串命令 “arp 10.168.1.156 00 bb eb c3 c6 d0 arpa”,这样一来新上网用户的IP地址与网卡物理地址就被成功绑定在一起了,
    最后依次执行字符串命令“quit”、“save”,将上述配置操作保存到交换机系统中,结束交换机配置任务。

    解决网络中IP地址发生冲突故障

    一、个人IP地址冲突解决方案

    1、如果您使用的计算机的操作系统是:windows(windows7或window10都行)。
    这里面需要用到命信令:

    ipconfig /release 释放IP地址。
    

    然后还需要ipconfig /renew在重新获取一下。

    我们来看下它们的如何解决:
    可以点击左下角“开始”→“运行”,键入:ipconfig /release,点击“确定”,把ip地址释放出来。
    在这里插入图片描述
    这时网络会断开,因为ip地址已释放出来了。

    再次点击**“开始”→“运行”**,键入:ipconfig /renew,点击“确定”,重新获取ip地址,即可解决IP地址冲突。
    在这里插入图片描述
    这时网络会重新连接,但ip地址已经与原来不一样了,重新分配到了可用的ip地址连接网络了。

    二、局域网IP地址冲突解决方案

    方案一、逐一排查
      这是最原始的方法,就是发生IP地址冲突时,在局域网内,挨着每台计算机查看,找到与其冲突的计算机后修改IP地址就可以了。不过这样比较耗时间,也不适合在大型局域网中使用,只适合在很小的网络环境中采用。
    在这里插入图片描述
    方案二、MAC地址绑定
    1、检查本地计算机的MAC并绑定:通过在本地计算机系统中运行Winipcfg/all,即可测知网卡的MAC地址。

    那么如何绑定ip地址与mac物理地址呢?
    首先输入cmd进入命令配置符,然后输入命令ipconfig/all,查看本机ip及mac地址情况。
    在这里插入图片描述
    输入字符串命令“arp -s 10.168.1.1 34-F3-9A-2B-9E-13“,即可绑定。
    在这里插入图片描述
    紧接着输入命令arp -a查询绑定是否成功。
    很明显,默认网关地址10.168.1.143就被成功绑定36-F3-9A-2B-9E-13, MAC地址上了,其他工作站日后上网时如果抢用10.168.1.143地址时,就会出现无法上网的故障现象,如此一来整个局域网的运行稳定性就能得到保证了。

    方案三:端口隔离

    对于所遇到的IP地址冲突,还可以利用交换机的端口把不同的部门隔离开来解决,这是因为利用交换机可以对不同的区域实行不同的管理,经过分割的网段之间互不干扰,可以在 一定程度上解决IP地址冲突的问题与数据的问题。
    对于只有一个VLAN的网络,端口隔离还是有必要的。
    我们来看个例子:

    例如
    一般情况下某个分公司都只能有一个vlan。在同一个VLAN下,在不阻碍所有部门跟总部机房服务器数据交换的情况下,实现分公司内业务部门A和业务部门B之间的数据屏蔽,但是为了保证订单准确下达至生产部门,所以部门A和部门B又可以与生产部数据通信。

    网络拓扑图
    在这里插入图片描述
    1、设置三个部门的IP地址:

    业务部A的IP地址:
    92.168.10.2  255.255.255.0  
    业务部B的IP地址:
    192.168.10.3 255.255.255.0 
    生产部的IP地址:
    192.168.10.4 255.255.255.0
    

    2、三层交换机配置(以华为交换机为例

    <Huawei>system 配置
    [Huawei]sysname S5700
    [S5700]vlan 10
    [S5700-vlan10]quit
    [S5700]int vlanif 10
    [S5700-Vlanif10]ip address 192.168.10.1/24 //配置网关
    [S5700-Vlanif10]quit
    
    [S5700]int g0/0/1    //进入端口g0/0/1
    [S5700-GigabitEthernet0/0/1]port link-type access //配置端口模式
    [S5700-GigabitEthernet0/0/1]port default vlan 10 //加入vlan10
    [S5700-GigabitEthernet0/0/1]port-isolate enable //加入端口隔离组1,且隔离模式为二层隔离三层互通。
    [S5700-GigabitEthernet0/0/1]quit
    
    [S5700]int g0/0/2   //进入端口g0/0/2 
    [S5700-GigabitEthernet0/0/2]port link-type access
    [S5700-GigabitEthernet0/0/2]port default vlan 10
    [S5700-GigabitEthernet0/0/2]port-isolate enable //缺省加入端口隔离组1,且隔离模式为二层隔离三层互通。
    [S5700-GigabitEthernet0/0/2]quit
    [S5700]int g0/0/3    //进入端口 g0/0/3
    [S5700-GigabitEthernet0/0/3]port link-type access
    [S5700-GigabitEthernet0/0/3]port default vlan 10
    [S5700-GigabitEthernet0/0/1]quit
    

    3、测试结果
    业务部A测试结果,业务部B类似
    在这里插入图片描述
    生产部测试结果
    在这里插入图片描述

    方案四:划分vlan

    虽然可以用交换机来实现网段隔离,从而在一定程度上避免IP地址冲突的发生,但它仍不能防止由于同一个端口下的网段内用户配置错误而引起的IP地址冲突。更好的解决方法就是,利用交换机来划分VLAN,再利用MAC地址绑定的方法来综合处理。
    在这里插入图片描述
    划分vlan的方法我们昨天的文章提到过了,大家可以去看下。

    总结:

    如果需要避免局域网ip地址冲突,最好是ip地址绑定计算机MAC地址,统一安排IP地址。计算机用户不能自行更改IP地址,如更改IP地址则不能上网,新增加用户需要在管理员那里获取已分配好的ip地址,这样大部分ip冲突的问题都可以避免。

    #交换机如何设置控制IP地址冲突故障

    单位局域网使用的是 10.168.163.0网段的IP地址,
    该网段中使用的默认网关地址为10.168.163.1,子网掩码地址为255.255.255.0;

    应对方案

    百思不得其解的问题:在核心交换机中将所有工作站使用的IP地址绑定到对应网卡设备上后,仍然无法有效避免地址冲突故障。

    要想彻底解决IP地址冲突故障,我们不但需要将局域网中已分配出去的IP地址绑定到对应网卡设备上,而且还需要对那些处于空闲状态的IP地址进行绑定
    也带来了另外一个麻烦,那就是如果局域网中有新的用户需要上网访问时,就不能由自己作主任选IP地址,而必须事先向网络管理员单独申请上网

    参考链接 :
    交换机如何解决IP地址冲突? : https://mp.weixin.qq.com/s/6Lys_LAZnBeWzjeRD6jPnQ

    解决网络中IP地址发生冲突故障 https://mp.weixin.qq.com/s/XAzuDi_LP6dAmYlYGiwzOw

    交换机如何设置控制IP地址冲突故障

    https://mp.weixin.qq.com/s/zTCkCtYPLoOt-GMG5WYOtA

    展开全文
  • 原标题:交换机如何设置控制IP地址冲突故障网络用户如果没有按照规定设置IP地址的话,IP地址冲突现象就不可避免,一旦这种现象频繁发生,不但会影响上网用户的冲浪效率,而且也不利于局域网网络的稳定运行。...

    原标题:交换机如何设置控制IP地址冲突故障

    网络用户如果没有按照规定设置IP地址的话,IP地址冲突现象就不可避免,一旦这种现象频繁发生,不但会影响上网用户的冲浪效率,而且也不利于局域网网络的稳定运行。为了提高局域网运行稳定性,我们不能等IP地址冲突故障发生时,才想办法去应对,而应该主动出击,让上网用户无法抢用局域网中的其他IP地址;为此,本文就从实战角度出发,通过巧妙设置交换机,来控制IP地址冲突故障反复出现!

    组网情况

    举例:局域网大约有150个网络节点,这些网络节点平均分布在六个楼层,每一个楼层中的网络节点都通过100M双绞线与普通二层交换机保护连接,而每一个普通二层交换机又通过1000M光纤线缆连接到路由交换机上,为了保证网络访问安全,所有网络节点都通过硬件防火墙与Internet网络互联互通。

    目前,单位局域网使用的是 10.168.163.0网段的IP地址,该网段中使用的默认网关地址为10.168.163.1,子网掩码地址为255.255.255.0;由于该网段最多能拥有250多个IP地址,在平时工作中实际只用到150多个地址,显然足够大的地址空间余量完全可以满足工作站数量不断增加的需求。

    但由于单位局域网采用了静态地址分配方法,每当工作站系统发生突然崩溃或遭遇病毒攻击不能正常启动时,上网用户都自行其是,随意重新安装系统、修改上网地址,结果局域网中频繁出现IP地址冲突现象,这不但严重影响了他人的正常上网访问,而且也加大了网络管理员的维护工作量。

    为了有效避免上网用户任意改动IP地址,笔者打算采用地址绑定的方法,将工作站的IP地址与对应网卡设备的物理地址绑定在一起;然而这种方法还没有正式实施,就遭到了同为网络管理员同事的反对,他认为这种方法治标不治本,因为上网用户仍然可以采用修改网卡物理地址的方法,来窃取他人的IP地址,很显然这种不是最有效的解决办法。

    应对方案

    经过上网查阅相关资料以及深入分析之后,笔者和另外一位网络管理员决定在核心交换机上对普通工作站的IP地址和网卡物理地址进行绑定操作,可是简单地进行绑定操作,也不能解决上网用户随意设置IP地址的现象,因为某个IP地址一旦被设置绑定后,虽然上网用户不能继续抢用这个IP地址,但是他仍然可以抢用局域网中处于空闲的IP地址,这样一来IP地址冲突现象仍然可能会发生,这也是很多网络管理员百思不得其解的问题:在核心交换机中将所有工作站使用的IP地址绑定到对应网卡设备上后,仍然无法有效避免地址冲突故障。

    要想彻底解决IP地址冲突故障,我们不但需要将局域网中已分配出去的IP地址绑定到对应网卡设备上,而且还需要对那些处于空闲状态的IP地址进行绑定,这样一来上网用户既不能使用已经连网工作站的IP地址,又不能使用局域网中空闲的IP地址,因此只要局域网中的上网用户随意改动IP地址的话,他就不能正常接入到局域网网络中。不过这样配置后,也带来了另外一个麻烦,那就是如果局域网中有新的用户需要上网访问时,就不能由自己作主任选IP地址,而必须事先向网络管理员单独申请上网,网络管理员接受到申请后需要登录进入交换机后台管理系统对空闲地址进行放号,上网用户才能正常连接到局域网中。实践证明,这种方法不但可以有效避免IP地址冲突故障发生,而且还能有效地防止网络病毒通过局域网非法传播,从而可以有效地保障局域网的稳定运行!

    实施过程

    依照上述理论分析,笔者打算先将局域网中默认网关地址10.168.163.1绑定到对应的物理地址上,这样可以有效控制局域网中ARP病毒的爆发;之后再想办法对已经上网工作站的IP地址执行绑定操作,最后将那些处于空闲状态的IP地址集中绑定到一个虚拟的网卡物理地址上,如此一来就能实现一石二鸟的效果了。

    在绑定网关地址时,笔者先是以系统管理员身份登录进入路由交换机后台管理系统,在该系统的命令行状态执字符串命令“system”,将系统切换到交换配置全局状态;下面在该全局配置状态下,输入字符串命令“arp 10.168.163.1 0215.9cae.1156 arpa”,单击回车键后,默认网关地址10.168.163.1就被成功绑定到0215.9cae.1156MAC地址上了,其他工作站日后上网时如果抢用10.168.163.1地址时,就会出现无法上网的故障现象,如此一来整个局域网的运行稳定性就能得到保证了。

    为了防止用户抢用其他IP地址,我们需要把已经上网的150个左右网络节点地址绑定起来;由于待绑定的地址数量比较多,单纯依靠手工方法获取每台工作站的网卡物理地址和IP地址,工作量将会十分巨大,为此笔者在交换机后台系统的全局配置状态下,执行“display arp”字符串命令,之后将显示出来的交换机ARP表中的内容复制拷贝到本地纪事本编辑窗口中,通过简单的编辑修改后,再将修改后的ARP表内容复制粘贴到交换机ARP表中,这样一来就能快速完成已上网工作站地址的绑定任务。

    对于剩下100个左右的空闲IP地址,我们可以采用手工方法依次将每一个空闲的IP地址绑定到虚拟的MAC地址上,例如要将 10.168.163.156地址绑定到071e.33ea.8975上时,我们可以在交换机后台系统的全局配置状态下,执行字符串命令“arp 10.168.163.156 071e.33ea.8975 arpa”,之后我们再按同样的方法将其他空闲IP地址绑定到虚拟MAC地址071e.33ea.8975上。

    完成上面的地址绑定任务后,任何用户都不能随意更改IP地址;倘若此时有新的用户需要使用空闲的10.168.163.156地址上网访问时,网络管理员可以按照下面的操作步骤,将10.168.163.156地址从绑定地址列表中释放出来:

    首先在路由交换机后台管理系统执行“system”命令,将系统状态切换到全局配置状态,在该状态下输入字符串命令“display arp”,单击回车键后,从其后出现的ARP列表中检查一下10.168.163.156地址是否处于空闲状态,要是目标IP地址处于空闲状态,我们就能继续执行下面的释放步骤了:

    其次输入字符串命令“no arp 10.168.163.156 071e.33ea.8975 arpa”,单击回车键后,目标IP地址10.168.163.156就从地址绑定列表中释放出来了;

    下面将10.168.163.156地址告诉给需要上网的用户,让他将该IP地址设置到对应工作站系统中,如此一来新增用户就能顺利地接入到单位局域网网络中了;

    之后在核心交换机的后台管理系统,继续执行字符串命令“display arp   in 10.168.163.156”,从其后返回的结果界面中我们可以查看得到对应10.168.163.156地址的网卡物理地址为00bb.ebc3.c6d0;

    得到该MAC地址后,我们可以继续执行字符串命令“arp 10.168.163.156 00bb.ebc3.c6d0 arpa”,这样一来新上网用户的IP地址与网卡物理地址就被成功绑定在一起了;最后依次执行字符串命令“quit”、“save”,将上述配置操作保存到交换机系统中,结束交换机配置任务。

    通过上面的配置,局域网中的所有IP地址都被成功控制起来,任何用户私自改动IP地址,都将不能接入网络;整个控制过程虽然有点复杂,但是可以很好地控制网络的接入安全,避免不明真相的工作站将网络病毒或木马程序带入到局域网工作环境中。当然,上面的控制方案还不能保证万无一失,还有一种情况会引发地址冲突现象发生,那就是非法用户窃取了交换机ARP列表中的内容,他只要同时修改自己工作站的网卡物理地址以及IP地址,并且在被窃用户没有在线的情况下,就能成功抢用他人地址进行上网访问了,不过这种情况出现的可能性相当低,除非网络管理员有意而为之。返回搜狐,查看更多

    责任编辑:

    展开全文
  • 为什么说交换机可以隔离冲突域?

    千次阅读 2021-04-06 17:31:17
    为什么交换机可以隔离冲突域? 交换机在数据链路层,作用是...假如数据帧的目的MAC地址不在交换机MAC地址表里时,交换机会把数据帧转发到除接收端口外的其它所有端口,此时交换机就是hub,不能起到隔离冲突域的作用
  • 为此,本文就从实战角度出发,通过巧妙设置交换机,来控制IP地址冲突故障反复出现!组网情况举例:局域网大约有150个网络节点,这些网络节点平均分布在六个楼层,每一个楼层中的网络节点都通过100M双绞线与普通二层...
  • 伴随着互联网的广泛运用,使互联网经营规模不断发展,相对的IP地址分派也在持续增加,IP地址矛盾状况日益增加,在一定水平上危害了互联网的一切正常运作。维护保养互联网平稳、高效率运作,处理IP地址矛盾难题,已...
  • 如何解决IP地址发生冲突故障?

    万次阅读 2021-06-26 10:06:11
    我们之前发布了关于交换机如何解决IP地址冲突?这里面是以实例的方式讲解了如何防止交换机冲突,有一些朋友反映这个设置起来有些复杂,有没有其它的一些方法呢?其实是有的,我们今天来看下。 随着网络的广泛应用...
  • 故障-因为MAC地址冲突造成的故障

    千次阅读 2019-10-02 07:08:53
    笔者有一部分物理机做了虚拟化,由于体量小就直接通过命令行工具创建,在创建时并没有通过kvm的clone命令,而是手工修改一些属性,所以就造成了产生了重复的MAC地址。 虽然问题是一个很low的问题,但是中间还是有...
  • 环境: 第一层交换机是华为6700,第二层使用华为5700s交换机 问题: 网络不通,ping网关不通,需要十几分钟有可能能通。 第二层交换机换了华为同款的24口或48口都不行,更换了其他交换机就正常了 另如果第二层是普通...
  • 交换机根据收到数据帧中的源MAC地址建立该地址交换机端口的映射,并将其写入MAC地址表中。2.交换机将数据帧中的目的MAC地址同已建立的MAC地址表进行比较,以决定由哪个端口进行转发。3.如数据帧中的目的MAC地址不...
  • 交换机基础原理,冲突域和广播域

    千次阅读 2020-07-25 15:52:15
    可以识别数据包中的MAC地址信息,根据MAC地址进行转发数据,并且会将这些MAC地址与对应的端口记录在自己内部的一个MAC地址表中。 分类: 按传输介质,传输速率:百兆以太网交换机(常用),千兆以太网交换机(常用...
  • 华为交换机ARP防网关冲突

    千次阅读 2022-05-13 19:03:08
    如果有攻击者仿冒网关,在局域网内部发送源IP地址是网关IP地址的ARP报文,会导致局域网内其他用户主机的ARP表记录错误的网关地址映射关系。这样其他用户主机就会把发往网关的流量均发送给了攻击者,攻击者可轻易窃...
  • CCNA第三天主要讲了交换机mac地址的静态绑定,以及这个实验的一些前置知识。 OSI参考模型: 这一天我们主要学习前两层:物理层和数据链路层。 物理层: 作用:定义线缆标准,例如:电压、线速、规格等。 设备:...
  • 其实也很简单,在设置指定IP前,先广播一个ARP包(询问这个IP地址),然后看是否有应答,如果没有,那就代表可用。 从原理上解释如何检测IP冲突: 让一台设备/路由发送ARP广播,然后所有收到的设备都会应答,这样...
  • 当计算机使用过程中出现“计算机探测到IP地址与您的网卡物理地址发生冲突”的错误时,您就无法使用网络。如果在网络用户连网的同时,建立IP地址MAC地址的信息档案,自始至终地对局域网客户执行严格的管、登记制度...
  • 华为交换机上如何识别ARP攻击

    千次阅读 2020-12-20 10:26:50
    2 网关设备侧攻击识别如发现网关设备(通常都为三层交换机)下挂的主机存在ping网关不通,无法访问外网的情况,则可通过以下步骤来判断是否受到ARP攻击:2.1 查看设备日志display logbufferLogging Buffer ...
  • 理解冲突域与广播域,交换机与路由器

    千次阅读 多人点赞 2019-11-28 14:28:14
     交换机是根据MAC地址转发 数据帧 ,而路由器则是根据IP地址来转发 IP数据报/分组 。数据帧是在IP数据包/分组的基础上封装了帧头(源MAC和目的MAC等)和帧尾(CRC校验码)。而对于MAC地址和IP地址大家也许就搞不...
  • mac地址全称是Media Access Control,即媒体访问控制。也被称为计算机的物理地址或硬件地址。在网络OSI模型中,MAC地址由数据链路层负责管理,因此每一个主机都会有一个MAC地址,而且是唯一的,而且MAC地址由计算机...
  • 网络管理员希望在NMS上可以获取到SwitchA和SwitchB之间的二层配置信息,用于了解网络的详细拓扑信息、判断网络中是否有配置冲突的情况。 图1LLDP兼容CDP协议配置组网图 配置思路 采用如下的思路配置LLDP兼容CDP协议...
  • 交换机原理

    2022-07-12 15:05:11
    交换机工作原理: 交换机工作在二层,可以用来隔离冲突域,在OSI参考模型中,二层的作用是寻址,这边寻址指的是MAC地址,而交换机就是对MAC地址进行转发,在每个交换机中,都有一张MAC地址表,这个表是交换机自动...
  • 用图说话——浅析交换机MAC地址学习

    万次阅读 热门讨论 2013-09-10 20:59:38
    在现实生活中,我们已经离不开网络,网络已经融入我们的生活,电脑,网络已经成为我们这代人的必须品,信息资源也已经成为国家的一种站略资源,我们在享受网络便利的同时...交换机,重点介绍交换机MAC地址学习原理。
  • IP地址冲突的原因及其解决方法

    千次阅读 2022-03-31 11:13:09
    IP地址冲突的原因及其解决方法:在同一个局域网里如果有两个用户同时使用了相同的IP地址,或者一个用户已经通过DHCP得到了一个IP地址,而此时又有其他用户以手工分配方式设定了与此相同的IP地址,这将造成IP地址冲突...
  • 1、首先show arp 找到对应的ip和mac2、然后 show ethernet-switching table 找到对应的接口3、接着干掉该接口4、最后在dhcp下面去绑定ip地址mac地址 set system services dhcp static-binding 08:ed:b9:e2:8a:89 ...
  • Cisco Packet Tracer查看交换机mac

    万次阅读 多人点赞 2020-03-19 22:46:02
    查看交换机mac地址表 为了验证交换机具有分隔不同网段的作用,我们通常借用Cisco Packet Tracer(下面简称CPT)来模拟网络环境。 1. 搭建网络环境 在CPT主界面右下角添加6台计算机设备 在该界面添加一个集线器...
  • 巧用dhcp和交换机mac地址表解决局域网冲突
  • 冲突域 我们把以太网想象为对讲机,电脑想象为使用对讲机的人,数据传输想象为使用对讲机说话。现在一群人打真人CS,两个及以上的人同时通过对讲机说话,就听不清在说什么了,这就是冲突。对讲机通道只能一人单独...
  • 目前在做个项目,底层是通过多台olt下的onu,通过ptn设备回到汇聚...现在怀疑mac漂移和ip地址冲突,但是从h3c查arp表,没发现有同一个ip对应多个mac的情况,但是有一个mac对应多个ip.的情况,请问剩下的还需怎么排查?

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 18,832
精华内容 7,532
关键字:

交换机mac地址冲突