精华内容
下载资源
问答
  • 交换机mac地址表建立过程
    千次阅读
    2021-07-15 07:57:17

    交换机在转发包的过程中,还需要对MAC地址表的内容进行维护,维护操作分为两种。

    第一种是收到包时,将发送方MAC地址以及其输入端口的号码写入MAC地址表中。由于收到包的那个端口就连接着发送这个包的设备,所以只要将这个包的发送方MAC地址写入地址表,以后当收到发往这个地址的包时,交换机就可以将它转发到正确的端口了。交换机每次收到包时都会执行这个操作,因此只要某个设备发送过网络包,它的MAC地址就会被记录到地址表中

    另一种是删除地址表中某条记录的操作,这是为了防止设备移动时产生问题。比如,我们在开会时会把笔记本电脑从办公桌拿到会议室,这时设备就发生了移动。从交换机的角度来看,就是本来连接在某个端口上的笔记本电脑消失了。这时如果交换机收到了发往这台已经消失的笔记本电脑的包,那么它依然会将包转发到原来的端口,通信就会出错,因此必须想办法删除那些过时的记录。然而,交换机没办法知道这台笔记本电脑已经从原来的端口移走了。因此地址表中的记录不能永久有效,而是要在一段时间不使用后就自动删除

    那么当笔记本电脑被拿到会议室之后,会议室里的交换机又会如何工作呢?只要笔记本电脑连接到会议室的交换机,交换机就会根据笔记本电脑发出的包来更新它的地址表。因此,对于目的地的交换机来说,不需要什么特别的措施就可以正常工作了。

    综合来看,为了防止终端设备移动产生问题,只需要将一段时间不使用的过时记录从地址表中删除就可以了。

    过时记录从地址表中删除的时间一般为几分钟,因此在过时记录被删除之前,依然可能有发给该设备的包到达交换机。这时,交换机会将包转发到老的端口,通信就会发生错误,这种情况尽管罕见,但的确也有可能发生。不过大家不必紧张,遇到这样的情况,只要重启一下交换机,地址表就会被清空并更新正确的信息,然后网络就又可以正常工作了。

    总之,交换机会自行更新或删除地址表中的记录,不需要手动维护。当地址表的内容出现异常时,只要重启一下交换机就可以重置地址表,也不需要手动进行维护。

    总结

    • 交换机需要定时更新mac地址表
    更多相关内容
  • 最常用的二层交换机所用的依据是MAC地址表,而三层交换机的依据是路由表,多层交换机的依据是网络协议或端口号 MAC地址表 MAC地址表记录了相连设备的MAC地址、接口号以及所属的VLAN ID之间的对应关系,是VLAN内数据...

    概述

    交换机一般工作在OSI模型的第二层,是目前网络中使用最多的设备。另外,交换机也可工作在OSI模型的第三层及第四层以上,对应的交换机分别称为三层交换机和多层交换机。交换机工作在不同的OSI模型层次,其实质是交换机交换数据包的依据不一样。

    最常用的二层交换机所用的依据是MAC地址表,而三层交换机的依据是路由表,多层交换机的依据是网络协议或端口号

    MAC地址表

    MAC地址表记录了相连设备的MAC地址、接口号以及所属的VLAN ID之间的对应关系,是VLAN内数据转发的决策表,是决定交换机转发行为的标准,交换机就是根据这张表负责将数据帧传输到指定的主机上的

    MAC表一般包含动态MAC地址、静态MAC地址和黑洞MAC地址

    1. 动态MAC地址:由接口通过报文中的源MAC地址学习获得,表项可老化,默认老化时间为300s,可以通过命令修改老化时间,老化时间到后,会清除学习到的动态MAC地址。

    2. 静态MAC地址:由用户手工配置,不会老化,接口和MAC地址静态绑定后,其他接口收到目的MAC是该MAC地址的报文将会被丢弃,但是一个接口和MAC地址静态绑定后,不会影响该接口动态MAC地址表项的学习。

    3. 黑洞MAC地址:设备收到源MAC或者目的地址是该MAC地址的报文将会被丢弃。

    MAC地址表建立

    交换机技术在转发数据前必须知道它的每一个端口所连接的主机的MAC地址,构建出一个MAC地址表。当交换机从某个端口收到数据帧后,读取数据帧中封装的目的地MAC地址信息,然后查阅事先构建的MAC地址表,找出和目的地地址相对应的端口,从该端口把数据转发出去,其他端口则不受影响,这样避免了与其它端口上的数据发生碰撞。

    所谓MAC地址数量是指交换机的MAC地址表中可以最多存储的MAC地址数量,存储的MAC地址数量越多,那么数据转发的速度和效率也就就越高

    例如:

    假设主机A主机C发送一个数据帧(每一个数据帧中都包含有源MAC地址和目的MAC地址),当该数据帧从E0端口进入交换机后,交换机通过检查数据帧中的源MAC地址字段,将该字段的值(主机A的MAC地址)放入MAC地址表中,并把它与E0端口对应起来,表示E0端口所连接的主机是A。此时,由于在MAC地址表中没有关于目的地MAC地址(主机C的MAC地址)的条目。交换机技术将此帧向除了E0端口以外的所有端口转发,从而保证主机C能收到该帧(这种操作叫flooding)。

    泛洪(flooding):交换机把某一端口接受到的数据帧向除了接收端口意外的所有端口转发。泛洪就是一点到多点的转发行为。

    同理,当交换机收到主机B、C、D的数据后也会把他们的地址学习到,写入地址表中,并将相应的端口和MAC地址对应起来。最终会把所有的主机地址都学习到,构建出完整的地址表。此时,若主机A再向主机C发送一个数据帧,应用交换机技术则根据它的MAC地址表中的地址对应关系,将此数据帧仅从它的E2端口转发出去。从而仅使主机C接收到主机A发送给它的数据帧,不再影响其他端口。那么在主机A和主机C通信的同时其他主机(比如主机B和主机D)之间也可以通信。

    展开全文
  • 在这次实验中我了解交换机MAC地址表的自动形成过程。对MAC地址表有了一个更透澈的了解。交换机在初始状态下,它的MAC地址表为空,,其中并不包含任何条目。每当交换机通过自己的某个接口接收到一个数据帧时,它就会...

    目录

    一,实验1: 交换机MAC地址表学习过程实验

    【实验目的】

    【实验环境】

    【实验过程】

    步骤一 建立拓扑

    步骤二 配置终端系统

    步骤三 查询交换机初始状态下MAC地址表

    步骤四 使交换机接收到数据帧

    【实验总结】


    一,实验1交换机MAC地址表学习过程实验

    【实验目的】

    握eNSP拟器的交换机的基本设置方法

    了解交换机为自己的MAC地址表动态添加条目的方式

    【实验环境】

    在本实验中,您将通过两台pc和一台交换机之间的连系了解交换机MAC地址表的形成过程。

    【实验过程】

    步骤一 建立拓扑

    在左侧面板顶部,单击“终端”图标。在显示的端设备中,选中“PC”图

    标,把图标拖到空白界面上。同上拖动交换机。在左侧面板顶部,单击“设备连线”图标。在显示的媒介中,选择“Copper (Ethernet)”图标。单击图标后,光标代表一个连接器。单击客户端设备,会显 示该模拟设备包含的所有端口。单击“Ethernet 0/0/1”选顷,连接此端口。

     

    步骤二 配置终端系统

    选择“基础配置”标签页,在“主机名”文本框中输入主机名称。在“IPv4

    配置”区域,单击“静态”选顷按钮。在“IP地址”文本框中输入IP地址。建议按照下图所示配置IP地址。配置完成后,单击窗口右下角的“应用”按钮。再单击“CLIENT1”窗口右上角的 关闭该窗口。

    使用相同步骤配置CLIENT2。和3

     

    步骤三 查询交换机初始状态下MAC地址表

    执行display mac-address命令,查看交换机MAC地址表

     命令回显信息中为空白说明交换机MAC地址表是空的。

    步骤四 使交换机接收到数据帧

    Ip地址配置完成后,下面我们通过从PC1向PC2发起ping测试的方式,来人工生成去往交换机的数据包,ping测试结果如图所示。

     

    Pc2回应了pc1,回应了五次。此时在当前设备里有数据流通。PC1可以与PC2之间实现双向通信,这也验证了前文中关于二层交换机可以即插即用的说法。下面我们再次回到交换机LSW上查看交换机的MAC地址表

    再次打开交换机执行display mac-address命令,查看交换机MAC地址表

     

    此时我们看到交换机MAC地址表中不在是空白的。由于PCI和PC2通过交换机相互发送了lcmP 消息,因此交换机接收到了从这两台PC发来的数据帧。于是, 交换机在MAC地址表中为这两台PC和它们对应的接口之间建立了映射关系。但由于日前交换机还没有接收过PC3发来的数据帧,因此交换机的MAC地址表中并没有记录PC3和交换机的Eth0/0/3端口之间的对应关系。

    在用pc1pingpc3得到:

     

     

    再用同样的操作查询交换机MAC地址表得到下图

     

    【实验总结】

    在这次实验中我了解交换机MAC地址表的自动形成过程。对MAC地址表有了一个更透澈的了解。交换机在初始状态下,它的MAC地址表为空,,其中并不包含任何条目。每当交换机通过自己的某个接口接收到一个数据帧时,它就会将这个数据帧的品源MAC地址、接收到这个数据帧的接口编导作为一个条目保存在自己的MAC地址表中,同时在接收到这个数据帧时重置老化计时器的时间。这就是交换机为自己的MAC地址表动态添加条目的方式。。

    展开全文
  • 交换机MAC地址学习

    千次阅读 2022-04-18 16:58:17
    首先我们要了解交换机mac地址是怎么学习的之前要了解一下交换机是如何工作的。 参考模型 交换机工作在OSI模型的第二层,也就是数据链路层,数据链路层传输的数据叫数据帧。数据链路层使用的封装一般使用以太网...

    首先我们要了解交换机mac地址是怎么学习的之前要了解一下交换机是如何工作的。

    参考模型

     交换机工作在OSI模型的第二层,也就是数据链路层,数据链路层传输的数据叫数据帧。数据链路层使用的封装一般使用以太网进行封装,也就是Ethernet Ⅱ 以太帧。

    这里随便抓个包演示一下

    由于交换机工作在数据链路层,也就是说交换机收到一个报文他只会解封装到数据链路层,以太,然后在根据目的mac地址来对数据帧进行传输。

    当交换机从接口收到一个报文后,解封装,然后将源mac记录在mac地址表,记录这个mac地址来源于哪个接口,当接口为down状态或超过老化时间,交换机会将来源于该接口的mac地址删除,这里后面我会实验演示。

    1.泛洪:收到目的mac地址为ff:ff:ff:ff:ff:ff,向同一广播域的接口复制转发(一对所有)

    抓包演示

    2.转发:从一个接口接收到数据帧后,查看mac地址表,存在目的mac地址,然后一对一接口转发(一对一)

    3.丢弃:从一个接口接收到数据帧后,mac地址表不存在对应mac地址或数据帧不合法,丢弃

    有了以上基础,我们就可以实战演示一下交换机的mac地址表是怎么生成的,以及如何转发数据帧。

    以下实验使用华为模拟器实现,其他模拟器也可以同样验证,原理一样。

    拓扑图

    步骤一

    第一步我们先看看交换机的mac地址表

    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sysname S1                                  #设置主机名
    [S1]display mac-address                             #查看mac地址表

     

     我们可以看到初始状态交换机的mac地址表是空的,华为交换机直接不显示,下一步我们看看交换机是如何将mac添加到表上的。

    步骤二

    为PC1添加IP地址,然后发送广播帧。

    由于是二层网络,这里不需要添加网关IP地址。

    然后ping一个网络中没有的主机地址,发送广播帧。

     

     抓包截取

    PC1尝试广播获取目的IP地址mac。

    步骤三

    查看交换机mac地址表

     此时可以看到交换机将PC1的mac地址记录并标明来源的接口。

    总结:也就是说当交换机收到某接口的数据帧时,将该数据帧的源mac地址记录到交换机的mac地址表并标明来源接口,下一次收到数据帧时,并通过mac地址表进行转发。

    扩展:交换机MAC地址绑定(静态)

    拓扑图

     R1

    [Huawei]sysname R1
    [R1]interface Ethernet0/0/0
    [R1-Ethernet0/0/0]ip address 192.168.1.1 24
    [R1-Ethernet0/0/0]mac-address 1-1-1          #更改mac地址

    R2

    [Huawei]sysname R2
    [R2]interface Ethernet0/0/0
    [R2-Ethernet0/0/0]ip address 192.168.1.2 24
    [R2-Ethernet0/0/0]mac-address 2-2-2          #更改mac地址

    S1

    [S1]mac-address static 1-1-1 Ethernet 0/0/1 vlan 1     #静态mac绑定
    [S1]mac-address static 2-2-2 Ethernet 0/0/2 vlan 1     #静态mac绑定
    [S1]interface Ethernet0/0/1
    [S1-Ethernet0/0/1]port link-type access                
    [S1-Ethernet0/0/1]q
    [S1]interface Ethernet0/0/2
    [S1-Ethernet0/0/2]port link-type access 
    [S1-Ethernet0/0/2]q
    

    查看交换机MAC地址表

    END

    展开全文
  • 拓朴图 ...如图所示:PC1 想要传输数据帧到 PC2,交换机从 E0/0/1 口接收到数据帧,查看其源MAC地址并将与其对应的E0/0/1口记录进MAC地址表。 ② 泛洪(Flooding):交换机收到需转发的数...
  • 最近有几个学生粉丝后台私信我,让我说说交换机与 VLAN。我在阅读这几个粉丝私信中发现一个有趣的现象,那就是吐槽大学计算机网络课程的晦涩枯燥,而不是去深层次解释协议出现的原因或者用来去解决什么问题。帅天...
  • 中兴二层交换机MAC地址学习

    千次阅读 2021-04-19 11:14:52
    1、通过对中兴二层交换机2850的MAC地址表的查看和老化时间的修改,加深对二层交换机MAC地址表建立过程和MAC地址表老化时间的理解。 三、实验过程 1、实验任务说明 如下图所示,将一台中兴2850交换机port4口和一个...
  • MAC地址 MAC(Media Access Control,介质访问控制)地址,或称为MAC位址、硬件地址,用来定义网络设备的位置。MAC集成在网卡,由48bit的16进制的数字组成,0~23位数字叫作组织唯一标志符(organizationally unique...
  • 相信有很多人在学习网络的过程中,都会对路由器与交换机的区别与联系感到疑惑不解,因为这两台设备的功能看起来似乎一样。然而,其实路由器与交换机大有不同,下面是我对此的一些理解,希望能够帮助到你!青春是萤火...
  • 交换机根据收到数据帧中的源MAC地址建立该地址同交换机端口的映射,并将其写入MAC地址表中。2.交换机将数据帧中的目的MAC地址同已建立MAC地址表进行比较,以决定由哪个端口进行转发。3.如数据帧中的目的MAC地址不...
  • 中兴二层交换机MAC地址学习实验

    千次阅读 2021-01-26 11:03:31
    1、通过对中兴二层交换机2850的MAC地址表的查看和老化时间的修改,加深对二层交换机MAC地址表建立过程和MAC地址表老化时间的理解。 三、实验过程 1、实验任务说明 如图1-1所示,将一台中兴2850交换机的port口和一...
  • 一、交换网络基础 1、越来越多的用户需要接入到网络,交换机提供的大量的接入端口能够很好地...1、交换机中有一个MAC地址表,里面存放了MAC地址与交换机端口的映射关系。MAC地址表也称为CAM(Content Addressabl...
  • 今天不经意间从电脑里发现了自己大学时的一课程...路由器和交换机已广泛应用于计算机局域网及互联网中,掌握路由器和交换机的使用方法和配置知 识及相关内容,对于学好《路由与交换技术》这门课程有很大的帮助。希望同
  • 1、网桥和交换机 网桥: ...交换机 ...-(2) 每个交换机可以支持多个spanning-tree switch ...3、交换机的工作原理(地址学习) ...地址学习的过程就是建立MAC表的过程 ...初始时,MAC地址表是空的 主机A向主...
  • 原文引用地址:http://blog.51cto.com/dengqi/1223132MAC地址表 说到MAC地址表,就不得不说一下交换机的工作原理了,因为交换机是根据MAC地址表转发数据帧的。在交换机中有一张记录着局域网主机MAC地址与交换机接口...
  • 1.学习交换机的工作原理;2.学习交换机建立MAC地址表过程;3.学习交换机转发数据包的规则;4.验证交换机转发数据包的过程;5.观察交换机对单播包和广播包的处理过程
  • mac地址全称是Media Access Control,即媒体访问控制。也被称为计算机的物理地址或硬件地址。在网络OSI模型中,MAC地址由数据链路层负责管理,因此每一个主机都会有一个MAC地址,而且是唯一的,而且MAC地址由计算机...
  • -理解交换机转发原理 -能完成交换机的基本配置 提示:以下是本篇文章正文内容,下面案例可供参考 参考 : https://blog.csdn.net/weixin_51486343/article/details/109219242 一、数据链路层  数据链路层...
  • MAC地址由48比特长、12位的16进制数字组成,其中从左到右开始,0到23bit是厂商向IETF等机构申请用来标识厂商的代码,24到47bit由厂商自行分派,是各个厂商制造的所有网卡的一个唯一编号。 MAC地址可以分为3种类型:
  • 如果在网络用户连网的同时,建立IP地址MAC地址的信息档案,自始至终地对局域网客户执行严格的管、登记制度,将每个用户的IP地址MAC地址、上联端口、物理位置和用户身份等信息记录在网络管理员的数据库中。...
  • 从ARP工作过程中了解交换机

    千次阅读 2022-01-28 19:23:45
    每台交换机中都有一个MAC地址表,存放了MAC地址与交换机端口编号之间的映射关系。还记得吗?ARP缓存表是MAC地址与IP地址的一一映射。 基于上一篇文章我们知道在PC1的ARP缓存条目中没有PC2但又要与其建立联系时,...
  • python3 miniedit.py(建立拓扑图) 编辑拓扑信息 root@ubuntu:/home/yuzai/mininet/examples# gedit demo3.py 上面是添加后主机mac地址 运行起来 root@ubuntu:/home/yuzai/mininet/examples# python3 demo3.py 链路...
  • 1.MAC(Media Access Control, 介质访问控制)地址是识别LAN节点的标识。网卡的物理地址通常是由网卡生产厂家烧入网卡的EPROM(一种闪存芯片,通常可以通过程序擦写),它存储的是传输数据时真正赖以标识发出数据的...
  • 计算机网络-交换机/转发帧的过程

    千次阅读 2021-11-22 16:26:35
    交换机 转发帧过程
  • ●历史CQOS Inc的R. Mandeville, J. Perser提交在2000年8月成为正式标准●功能将...RFC 2285Benchmarking Terminology for LAN Switching Devices定义性能评测的内容: MAC地址容量, MAC地址学习速率, 拥塞控制…●RFC
  • 同时,交换机更新它的MAC地址和端口映射,即将192.168.0.3绑定它所连接的端口。 3.网关收到A的ARP请求后,发出带有自身MAC地址的ARP响应。 4.网关更新ARP缓存,绑定A的IP地址MAC地址。 5.交换机收到网关对A的...
  • 不断的循环这个过程,对于全网的MAC地址信息都可以学习到,二层交换机就是这样建立和维护它自己的地址表。 从二层交换机的工作原理可以推知以下三点: (1) 由于交换机对多数端口的数据进行同时交换,这就要求具有...
  • 一、交换机的工作原理   ...交换机之所以能实现这一功能,是因为交换机内部有一个MAC地址表MAC地址表记录了网络中所有MAC地址与该交换机各端口的对应信息。某一数据帧需要转发时,交换...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 26,536
精华内容 10,614
热门标签
关键字:

交换机mac地址表建立过程