精华内容
下载资源
问答
  • 交换机MAC地址表管理

    2020-02-04 19:29:13
    文章目录交换机MAC地址表管理 交换机MAC地址表管理 Switch#show mac address table //查看MAC 地址 Switch(config)#mac address table aging time 120 //设置 交换机的 MAC 地址老化时间 Switch#clear mac ...

    交换机MAC地址表管理

    Switch#show mac address table //查看MAC 地址表
    Switch(config)#mac address table aging time 120 //设置 交换机的 MAC 地址表老化时间
    Switch#clear mac address table dynamic //删除动态 MAC 地址
    Switch(config)#mac address table static 00D0.9713.DE18 vlan 1 interface fastEthernet 0/4 //上添加静态地址表,把 PC1 的 MAC 地址绑定到F0/4 接口

    展开全文
  • 交换机MAC地址表

    2017-11-12 18:28:00
    交换机在转发数据时,需要根据MAC地址表来做出相应转发,如果目标主机的MAC地址不在中,交换机将收到的数据包在所有活动接口上广播发送。当交换机上的接口状态变成UP之后,将动态从该接口上学习MAC地址,并且将...
    交换机在转发数据时,需要根据MAC地址表来做出相应转发,如果目标主机的MAC地址不在表中,交换机将收到的数据包在所有活动接口上广播发送。当交换机上的接口状态变成UP之后,将动态从该接口上学习MAC地址,并且将学习到的MAC地址与接口相对应后放入MAC地址表。

    交换机的MAC地址表除了动态学习之外,还可以静态手工指定,并且在指定MAC地址时,还可以指定在某个VLAN的某个接口收到相应的MAC后,将数据包作丢弃处理。

    注:交换机上,一个接口可以对应多个MAC地址,地址的数量无上限,但不超过交换机所支持的MAC地址最大数量。

    一个MAC地址可以同时出现在交换机的多个接口上,但此特性并不被所有型号的交换机支持,在某些型号的交换机上,一个MAC地址只能出现在一个接口上,如果出现在另外一个接口上,将会报错,并且数据转发也会出错。

    1.查看交换机MAC地址表

    (1)查看接口F0/1的MAC地址表

    Switch#sh mac-address-table interface f0/1

    Mac Address Table
    -------------------------------------------
    Vlan Mac Address Type Ports
    ---- ----------- -------- -----
    2 0013.1a2f.0680 DYNAMIC Fa0/1

    Total Mac Addresses for this criterion: 1

    说明:交换机从F0/1上学习到了MAC地址0013.1a2f.0680,并且说明是动态学习到的。
     

    2.手工静态指定MAC地址

    (1)手工静态指定MAC地址
    Switch(config)#mac-address-table static 0013.1a2f.0680 vlan 1 interface f0/2
    说明:指定VLAN 1的接口F0/2的MAC地址为0013.1a2f.0680。

    (2)查看接口F0/2的MAC地址表
    Switch#sh mac-address-table interface f0/2

    Mac Address Table
    -------------------------------------------
    Vlan Mac Address Type Ports
    ---- ----------- -------- -----
    1 0013.1a2f.0680 STATIC Fa0/2
    1 0013.1a7f.a4a0 DYNAMIC Fa0/2
    Total Mac Addresses for this criterion: 2

    说明:接口F0/2上除了动态学习到的MAC地址之外,还有静态手工指定的地址。

    (3)指定丢弃某个MAC地址

    Switch(config)#mac-address-table static 0013.1a2f.0680 vlan 2 drop

    说明:此配置将使源MAC为0013.1a2f.0680的数据包在VLAN 2被丢弃,但在别的VLAN通信正常。

    3.MAC地址老化时间(aging-time)

    交换机在一个接口上学习到MAC地址之后,该MAC与接口的映射并不会永远被保存在MAC地址表中,除非是手工静态指定的。当一台主机从某个接口转移后,交换机再将目标MAC为该主机的数据从该接口发出去是毫无意义的,所以MAC地址在MAC地址表中是有最大停留时间的,称为老化时间(aging-time),当相应MAC地址在超出老化时间后还没有数据传输时,该MAC地址将从表中被清除。默认的MAC地址老化时间为300秒(5分钟)。

    (1)修改MAC地址的老化时间

    说明:只能针对VLAN作修改

    Switch(config)#mac-address-table aging-time 60 vlan 1

    说明:将VLAN 1的MAC地址老化时间改为60秒。

    (2)查看MAC地址的老化时间

    Switch#sh mac-address-table aging-time

    Global Aging Time: 300

    Vlan Aging Time
    ---- ----------
    1 60
    2 300
    3 300
    4 300

    说明:可以看到,VLAN 1的MAC地址老化时间为60秒,其它VLAN保存默认300秒。

    交换机自身MAC地址

    以太网中,每一个节点,都需要一个MAC地址,而以太网交换机可以与多个终端连接,也就有多个节点,因此,交换机上也会有多个MAC地址存在,如交换机的每个接口都有一个MAC地址,包含物理接口和SVI接口。除此之外,还有一个MAC地址是用来表示整台交换机的。

    注:都知道2层交换机的VLAN 1为管理VLAN,一个表示整台交换机的MAC地址通常就是VLAN 1的MAC地址,但这种情况又需要根据交换机型号而定,并不适用于任何型号的交换机。

    某些型号的交换机,所有VLAN的SVI接口MAC地址全部相同,但某些型号却是不同的,但是连续的。


    1.查看交换机的MAC地址

    (1)查看表示整台交换机的MAC地址

    Switch#sh version

    (输出被省略)

    512K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address : 00:1A:6C:6F:FB:00
    Motherboard assembly number : 73-9897-06
    Power supply part number : 341-0097-02
    Motherboard serial number : CAT10475C57
    Power supply serial number : AZS104407JE
    Model revision number : D0
    Motherboard revision number : A0
    Model number : WS-C3560-24TS-S
    System serial number : CAT1047RJNU
    Top Assembly Part Number : 800-26160-02
    Top Assembly Revision Number : C0
    Version ID : V02
    CLEI Code Number : COMMG00ARB
    Hardware Board Revision Number : 0x01

    Switch Ports Model SW Version SW Image
    ------ ----- ----- ---------- ----------
    * 1 26 WS-C3560-24TS 12.2(35)SE1 C3560-ADVIPSERVICESK

    说明:表示整台交换机的MAC地址为00:1A:6C:6F:FB:00。

    (2)查看物理接口的MAC地址

    Switch#sh int f0/1

    FastEthernet0/1 is up, line protocol is up (connected)

    Hardware is Fast Ethernet, address is 001a.6c6f.fb03 (bia 001a.6c6f.fb03)

    (输出被省略)

    说明:可以看到,物理接口的MAC地址是连续的,但无论什么型号的交换机,物理接口的MAC地址一定是不同的。

     
    (3)查看SVI接口的MAC地址

    Switch#sh int vlan 1
    Vlan1 is up, line protocol is up
    Hardware is EtherSVI, address is 001a.6c6f.fb40 (bia 001a.6c6f.fb40)
    (输出被省略)

    Switch#sh int vlan 2
    Vlan2 is up, line protocol is up
    Hardware is EtherSVI, address is 001a.6c6f.fb41 (bia 001a.6c6f.fb41)
    (输出被省略)

    说明:可以看到,交换机SVI接口的MAC地址是连续的,但某些型号的交换机,所有SVI接口的MAC地址全部是相同的。

     



    本文转自zcm8483 51CTO博客,原文链接:http://blog.51cto.com/haolun/991593

    展开全文
  • 查看及配置交换机管理地址 问题 交换机是目前用于组建局域网的主要设备,交换机根据MAC地址实现数据帧的转发,...查看交换机MAC地址表 查看CISCO设备邻居信息 交换机地址配置及默认网关 方案 网络拓扑,如图-1所...
    1. 查看及配置交换机管理地址
    • 问题

    交换机是目前用于组建局域网的主要设备,交换机根据MAC地址表实现数据帧的转发,通过查看MAC地址表更加有利于交换机工作原理的理解;通过查看CISCO设备邻居信息来了解网络拓扑;通过telnet方式远程访问、配置交换机,这种方式要求此交换机已配置有IP地址。

    • 查看交换机MAC地址表
    • 查看CISCO设备邻居信息
    • 交换机地址配置及默认网关
    • 方案

    网络拓扑,如图-1所示。

    图-1

    步骤一:查看交换机MAC地址表

    1)按拓扑配置PC1及PC2的IP地址并查看,如下所示:

    PC>ipconfig

     

    FastEthernet0 Connection:(default port)

     

    Link-local IPv6 Address.........: FE80::2D0:97FF:FED2:2DB0       //PC1的MAC地址

    IP Address......................: 192.168.1.1   //PC1的IP地址

    Subnet Mask.....................: 255.255.255.0

    Default Gateway.................: 0.0.0.0

     

    PC>ipconfig

     

    FastEthernet0 Connection:(default port)

     

       Link-local IPv6 Address.........: FE80::2D0:BCFF:FE56:AB31  //PC2的MAC地址

    IP Address......................: 192.168.1.2   //PC2的IP地址

       Subnet Mask.....................: 255.255.255.0

       Default Gateway.................: 0.0.0.0

    2)PC1通过ping命令测试与PC2的连通性:

    PC>ping 192.168.1.2

     

    Pinging 192.168.1.2 with 32 bytes of data:

     

    Reply from 192.168.1.2: bytes=32 time=2ms TTL=128

    Reply from 192.168.1.2: bytes=32 time=0ms TTL=128

    Reply from 192.168.1.2: bytes=32 time=3ms TTL=128

    Reply from 192.168.1.2: bytes=32 time=0ms TTL=128

     

    Ping statistics for 192.168.1.2:

        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    Approximate round trip times in milli-seconds:

        Minimum = 0ms, Maximum = 3ms, Average = 1ms

    3)查看交换机MAC地址表:

    Switch#show mac-address-table

              Mac Address Table

    -------------------------------------------

     

    Vlan    Mac Address       Type        Ports

    ----    -----------       --------    -----

     

       1    00d0.97d2.2db0    DYNAMIC     Fa0/1

       1    00d0.bc56.ab31    DYNAMIC     Fa0/2

    步骤二:查看CISCO设备邻居信息

    1)配置路由器接口IP:

    Router>enable

    Router#configure terminal

    Router(config)#interface fastEthernet 0/0

    Router(config-if)#ip address 192.168.1.254 255.255.255.0

    Router(config-if)#no shutdown

    2)进入交换机特权模式通过命令查看CISCO设备邻居信息:

    Switch#show cdp neighbors

    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                      S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

    Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID

    Router       Fas 0/3          179            R       C2600       Fas 0/0

    步骤三:交换机地址配置及默认网关

    1)配置IP地址(192.168.1.10/24)

    执行“int vlan1”(或interface vlan1)指令进入交换机的vlan1接口配置,再执行“ip add 192.168.1.10 255.255.255.0”配置IP地址(ip add指令相当于ip address),执行“no shutdown”启用此接口,如下所示:

    Switch(config)# int vlan1   //进入vlan1接口

    Switch(config-if)# ip add 192.168.1.10 255.255.255.0   //配置IP地址

    Switch(config-if)# no shutdown  //启用接口

    %LINK-5-CHANGED: Interface Vlan1, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

    2)进入交换机全局配置模式配置交换机默认网关地址:

    Switch#configure terminal

    Switch(config)#ip default-gateway 192.168.1.254

     

    3)确认当前的运行配置

    直接执行“end”指令返回特权模式:

    Switch(config-if)# end   //返回特权模式

    Switch#

    %SYS-5-CONFIG_I: Configured from console by console

    4)确认vlan1接口的IP及网关地址信息:

    Switch#show running-config

    Building configuration...

     

    Current configuration : 1026 bytes

    !

    version 12.1

    no service timestamps log datetime msec

    no service timestamps debug datetime msec

    no service password-encryption

    !

    hostname Switch

    !

    !

    !

    spanning-tree mode pvst

    !

    interface FastEthernet0/1

    !

    interface FastEthernet0/2

    !

    interface FastEthernet0/3

    !

    interface FastEthernet0/4

    interface FastEthernet0/5

    !

    interface FastEthernet0/6

    !

    interface FastEthernet0/7

    !

    interface FastEthernet0/8

    !

    interface FastEthernet0/9

    !

    interface FastEthernet0/10

    !

    interface FastEthernet0/11

    !

    interface FastEthernet0/12

    !

    interface FastEthernet0/13

    !

    interface FastEthernet0/14

    !

    interface FastEthernet0/15

    !

    interface FastEthernet0/16

    !

    interface FastEthernet0/17

    !

    interface FastEthernet0/18

    !

    interface FastEthernet0/19

    !

    interface FastEthernet0/20

    !

    interface FastEthernet0/21

    !

    interface FastEthernet0/22

    !

    interface FastEthernet0/23

    !

    interface FastEthernet0/24

    !

    interface Vlan1

    ip address 192.168.1.10 255.255.255.0  //IP地址与配置一致

    !

    ip default-gateway 192.168.1.254       //网关地址与配置一致

    !

    !

    !

    !

    line con 0

    !

    line vty 0 4

    login

    line vty 5 15

    login

    !

    !

    end

     

    展开全文
  • 请教各位大神,交换机MAC地址表满了,接收到的新的MAC如何处理?前提是还没过老化时间。先谢谢大神的不吝赐教!
  • 交换机MAC地址表转发

    千次阅读 2012-09-30 10:22:01
    很实用的实验:交换机MAC地址表转发 http://wenku.baidu.com/view/0be673e9aeaad1f346933f39.html
    展开全文
  • 动态项由接口通过对报文中的源MAC地址学习方式动态获取到,这类MAC地址有老化的时间,并且可以自己修改,老化时间越短,交换机对周边的网络变化越敏感,适合在网络拓扑变化比较环境中,老化时间越长,越适合在网络...
  • 查看交换机MAC地址/查看交换机MAC地址表 查看邻居信息 配置SW1交换机连接主机的接口速率为10M 6.2 方案 使用Ensp搭建实验环境,如图-8所示。 图-8 6.3 步骤 实现此案例需要按照如下步骤进行。 1)配置各PC的IP地址...
  • 华为交换机MAC地址表以及命令配置

    千次阅读 2020-07-24 14:32:41
    MAC地址表:记录了交换机学习到的其他设备的MAC地址与接口的对应关系,以及接口所属VLAN等信息 mac地址表的组成 一、三类mac地址表 静态项:由用户手工配置,并下发到各接口板,项不可老化,重启不会丢失。...
  • 巧用dhcp和交换机mac地址表解决局域网冲突
  • IVL(independentvlan learning)网上大部分资料都说为每个vlan建一个,看起来好像有很多,其实这里所说的是指逻辑上的,实际上在交换机中还是只有一个,如果将VID相同的记录都提取出来组成一个...
  • 查看MAC地址表交换机的地址

    千次阅读 2019-03-24 23:34:15
    (3)PC1 ping PC3后立即查看PC1、PC2、PC3的MAC地址表:arp –a查看 查看交换机的地址:display mac-address 2.组网 (1)搭建环境 (1)设置PC1,PC2,PC3,PC4的IP地址和子网掩码 (2)PC1 ping PC4...
  • 交换机MAC地址学习

    千次阅读 2015-07-31 11:10:14
    1:交换机MAC地址学习 sw1.JPG (24.76 KB) 2012-5-15 09:42 在交换机初始化的,也就是刚启动的时候,交换机的MAC地址是没有任何MAC地址和端口的映射条目的 sw2.JPG (28.08 KB) 2012-...
  • ###锐捷交换机 刷新mac地址表 #先通过enable进入到高权限的状态 clear mac-address-table dynamic ##查找mac 地址 ruijie#configure Enter configuration commands, one per line. End with CNTL/Z. ruijie(config)#...
  • 今天不经意间从电脑里发现了自己大学时的一课程...路由器和交换机已广泛应用于计算机局域网及互联网中,掌握路由器和交换机的使用方法和配置知 识及相关内容,对于学好《路由与交换技术》这门课程有很大的帮助。希望同
  • 交换机mac地址表是记录与该交换接口相连的设备的mac地址,接口编号以及所属vlan。根据mac地址表可以实现数据的快速转发,从而减少广播波动。mac地址表可以分为三类:静态mac地址,动态mac地址,黑洞mac地址。静态...
  • 交换机MAC地址学习与转发机制

    千次阅读 2019-12-13 16:54:53
    PC发送数据帧,SW记录(或更新)端口和数据帧的源mac地址(即PC的mac地址);(src_mac | port) 根据数据帧的目的mac,查询mac地址表,有则转发,无则洪泛,将数据帧发送至目的地;(dst_mac | port) MAC地址老化...
  • 浅谈交换机MAC地址学习和数据转发

    万次阅读 多人点赞 2017-07-15 11:51:29
    下面将谈谈MAC地址学习这块的东西,欢迎...假定PC1的arp项中没有对应通信的PC2的MAC地址B与IP映射,那么PC1将广播一个“arp请求”,交换机通过port1 接收到PC1广播的arp请求报文,通过查找交换机内部的转发表,发现
  • 交换机MAC地址过滤

    千次阅读 2012-11-28 15:10:39
    一、IOS版本的Cisco交换机(二层): 1.Config模式下,配置Mac Access-list Switch#conf t Switch(config)#mac access-list extended XXXX Switch(config-ext-macl)#deny any host MAC-Add Switch(confi.....
  • Cisco Packet Tracer查看交换机mac表

    千次阅读 2020-03-19 22:46:02
    查看交换机mac地址表 为了验证交换机具有分隔不同网段的作用,我们通常借用Cisco Packet Tracer(下面简称CPT)来模拟网络环境。 1. 搭建网络环境 在CPT主界面右下角添加6台计算机设备 在该界面添加一个集线器...
  • 1:交换机MAC地址学习   在交换机初始化的,也就是刚启动的时候,交换机的MAC地址是没有任何MAC地址和端口的映射条目的   当PCA要想和PCC,PCB,PCD进行通信时,当该二层数据帧通过端口E1/0/1发送到交换机上...
  • 交换机学习完MAC之后 假设我将端口为7和8的主机进行对换 那么之后端口为1的主机发送给端口为7的主机数据包的时候,查找MAC的目的MAC地址,对应的端口号是8(因为之前主机调换了顺序),那数据包会发错。...
  • 描述:华为网络设备交换机路由器查看MAC地址表项命令方法 命令: display mac-address summary
  • 交换机 MAC地址老化时间

    千次阅读 2014-06-27 09:16:33
    华三的交换机: [SW1]mac-address timer aging ? mac-address timer aging ?  INTEGER Global aging time (second)
  • 描述:中兴网络设备交换机路由器查看MAC地址表项命令方法 命令: show mac
  • 计算机网络-实验3-交换机的交换MAC地址管理

    万次阅读 多人点赞 2019-04-20 20:48:12
    交换机MAC地址表的配置 实验内容 一:交换的工作原理 存储转发方式 把整个数据帧先缓存后再进行处理。 交换机建立一个交换,根据交换来转发数据。 1.1 以太网交换机的自学习功能 以太网交换机运行...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 62,505
精华内容 25,002
关键字:

交换机mac地址表更新