精华内容
下载资源
问答
  • 交换机配置实验报告,和号很实用,是思科的配置
  • 实验需求:实现全网互通 首先先将IP地址以及网段划分好。 如下图 首先进入交换机SW0 将vlan命名以及划分。以及端口的封装 同理将SW1划分VLAN 30和40 并且封装 然后进入三层交换机配置 首先加入VLAN 10和VLAN 20 并...

    在这里插入图片描述
    实验需求:实现全网互通

    首先先将IP地址以及网段划分好。
    如下图在这里插入图片描述
    首先进入交换机SW0 将vlan命名以及划分。以及端口的封装
    在这里插入图片描述
    同理将SW1划分VLAN 30和40 并且封装
    在这里插入图片描述
    然后进入三层交换机配置
    首先加入VLAN 10和VLAN 20 并分别对2个vlan进行IP地址的划分。并且将F0/2开启封装。 F0/1口进行no switchport 操作 然后进行IP地址的划分。然后进行动态路由的配置。
    在这里插入图片描述
    在这里插入图片描述

    然后进入三层交换机SW3进入配置
    加入VLAN 30和VLAN 40 并分别对2个vlan进行IP地址的划分。并且将F0/2开启封装。 F0/1口进行no switchport 操作 然后进行IP地址的划分。然后进行动态路由的配置。
    在这里插入图片描述
    在这里插入图片描述
    在路由器Route6上分别对G0/1口和G0/0口配置IP地址,然后进行OSPF的配置。
    在这里插入图片描述

    List item
    同理对路由器ROUTE7 进行配置
    在这里插入图片描述
    在这里插入图片描述
    配置完成后,进入PC进行验证。
    在这里插入图片描述

    展开全文
  • 计算机网络路由技术,OSPF路由配置的几个步骤和实验代码。
  • 自制OSPF配置实验大全

    2017-05-04 10:13:30
    OSPF综合实验(gns模拟器)   注意点: Ospf实验推荐用gns制作 //图中的交换机可以视觉忽略或缩小...1.Ospf 基础配置... 1 2.环回口改成点到点网络... 2 3.改优先级... 2 4.ospf的手动汇总... 2 5.ospf认证

    OSPF综合实验gns模拟器)

     

    注意点:

    Ospf实验推荐用gns制作


    //图中的交换机可以视觉忽略或缩小成一个点。(^ v^

     

    Ospf

    实验拓扑图

    目录

    OSPF综合实验... 1

    Ospf实验拓扑图... 1

    1.Ospf 基础配置... 1

    2.环回口改成点到点网络... 2

    3.改优先级... 2

    4.ospf的手动汇总... 2

    5.ospf认证... 2

    6.ospf发布缺省路由更新... 2

    7.孤岛区域和区域分割... 2

    8.STUB  NSSA的配置... 2

     

     

    1.Ospf 

    基础配置

    R1

    R1#conf t

    R1(config)#inte0/0

    R1(config-if)#ipadd 14.14.14.1 255.255.255.0

    R1(config-if)#noshut

    R1(config-if)#intlo0

    R1(config-if)#ipadd 10.1.1.1 255.255.255.0

    R1(config-if)#end

    R1#conf t

    R1(config)#routerospf 1

    R1(config-router)#router-id1.1.1.1

    R1(config-router)#net10.1.1.0 0.0.0.255 a 1

    R1(config-router)#net14.14.14.0 0.0.0.255 a 1

    R2

    R2#conf t

    R2(config)#inte0/1

    R2(config-if)#ipadd  123.123.123.2 255.255.255.0

    R2(config-if)#noshut

    R2(config-if)#intlo0

    R2(config-if)#ipadd 20.2.2.2 255.255.255.0

    R2(config-if)#noshut

    R2(config-if)#end

    R2#conf t

    R2(config)#routerospf 1

    R2(config-router)#router-id2.2.2.2

    R2(config-router)#net123.123.123.2 0.0.0.0 a 0  

    R2(config-router)#net20.2.2.2 0.0.0.0 a 0

    R2(config-router)#end

    R3

    R3#conf t

    R3(config)#inte0/1

    R3(config-if)#ipadd 123.123.123.3 255.255.255.0

    R3(config-if)#noshut

    R3(config-if)#exit

    R3(config)#routerospf 1

    R3(config-router)#router-id3.3.3.3

    R3(config-router)#net123.123.123.3 0.0.0.0 a 0

    R3(config-router)#end

    R4

    R4#conf t

    R4(config)#inte0/0

    R4(config-if)#ipadd 14.14.14.4 255.255.255.0

    R4(config-if)#noshut

    R4(config-if)#inte0/1

    R4(config-if)#ipadd 123.123.123.4 255.255.255.0

    R4(config-if)#noshut

    R4(config)#intlo0

    R4(config-if)#ipadd 90.9.9.9 255.255.255.0

    R4(config-if)#end

    R4#conf t

    R4(config)#routerospf 1

    R4(config-router)#router

    R4(config-router)#router-id4.4.4.4

    R4(config-router)#net14.14.14.0 0.0.0.255 a 1

    R4(config-router)#net123.123.123.4 0.0.0.0 a 0

    R4(config-router)#end

    R5

    R5#conf t

    R5(config)#inte0/0

    R5(config-if)#ipadd 56.56.56.5 255.255.255.0

    R5(config-if)#noshut

    R5(config-if)#inte0/1

    R5(config-if)#ipadd 123.123.123.5 255.255.255.0

    R5(config-if)#noshut 

    R5(config-if)#end

    R5#conf t

    R5(config)#routerospf 1

    R5(config-router)#router-id5.5.5.5

    R5(config-router)#net123.123.123.5 0.0.0.0 a 0

    R5(config-router)#net56.56.56.0 0.0.0.255 a 2

    R5(config-router)#end

    R6

    R6#conf t

    R6(config)#inte0/0

    R6(config-if)#ipadd 56.56.56.6 255.255.255.0

    R6(config-if)#noshut

    R6(config-if)#inte0/1

    R6(config-if)#ipadd 67.67.67.6 255.255.255.0

    R6(config-if)#noshut

    R6(config-if)#intlo0

    R6(config-if)#ipadd 60.6.6.6 255.255.255.0

    R6(config-if)#end

    R6#conf t

    R6(config)#routerospf 1

    R6(config-router)#router-id6.6.6.6

    R6(config-router)#net60.6.6.0 0.0.0.255 a 2

    R6(config-router)#net56.56.56.0 0.0.0.255 a 2

    R6(config-router)#net67.67.67.0 0.0.0.255 a 3

    R6(config-router)#end

    R7

    R7#conf t

    R7(config)#inte0/1

    R7(config-if)#ipadd 67.67.67.7 255.255.255.0

    R7(config-if)#noshut

    R7(config-if)#intlo 0

    R7(config-if)#ipadd 70.7.7.7 255.255.255.0

    R1(config-if)#intlo 1

    R1(config-if)#ipadd 80.8.8.8 255.255.255.0

    R7(config-if)#end

    R7#conf t

    R7(config)#routerospf 1

    R7(config-router)#router-id7.7.7.7

    R7(config-router)#net70.7.7.0 0.0.0.255 a 3

    R7(config-router)#net67.67.67.0 0.0.0.255 a 3

    R7(config-router)#end

    检验邻居关系

    R4#show ip ospf neighbor

    NeighborID     Pri   State           Dead Time   Address         Interface

    2.2.2.2           1  FULL/DROTHER    00:00:30    123.123.123.2   Ethernet0/1

    3.3.3.3           1  FULL/DROTHER    00:00:35    123.123.123.3   Ethernet0/1

    5.5.5.5           1  FULL/DR         00:00:34    123.123.123.5   Ethernet0/1

    1.1.1.1           1  FULL/BDR        00:00:35    14.14.14.1      Ethernet0/0

    R4#show ip routeospf

         20.0.0.0/32is subnetted, 1 subnets

    O       20.2.2.2[110/11] via 123.123.123.2, 00:33:28, Ethernet0/1

         10.0.0.0/32 issubnetted, 1 subnets

    O       10.1.1.1 [110/11]via 14.14.14.1, 00:33:28, Ethernet0/0

         56.0.0.0/24 is subnetted, 1 subnets

    O IA    56.56.56.0 [110/20] via 123.123.123.5,00:33:28, Ethernet0/1

         60.0.0.0/32 is subnetted, 1 subnets

    O IA    60.6.6.6 [110/21] via 123.123.123.5,00:33:28, Ethernet0/1

     

    2.

    环回口改成点到点网络

    由于环回口被视为主机,环回口网络总被当作主机路由学习

    10.0.0.0/32 is subnetted, 1 subnets

    O       10.1.1.1[110/11] via 14.14.14.1, 00:33:28, Ethernet0/0

    现在将R1 环回口改成点到点网络

    R1#show ip ospf interface loopback 0

    Loopback0is up, line protocol is up

      Internet Address 10.1.1.1/24,Area 1

      Process ID 1, Router ID 1.1.1.1,Network Type LOOPBACK, Cost: 1

    Loopbackinterface is treated as a stub Host

    R1

    R1#CONF T

    R1(config)#intlo 0

    R1(config-if)#ipospf network point-to-point

    检验:

    R1#show ip ospf interface loopback 0

    Loopback0is up, line protocol is up

      Internet Address 10.1.1.1/24,Area 1

      Process ID 1, Router ID 1.1.1.1,Network Type POINT_TO_POINT, Cost: 1

      Transmit Delay is 1 sec, StatePOINT_TO_POINT,

      Timer intervals configured, Hello 10, Dead40, Wait 40, Retransmit 5

        oob-resync timeout 40

      Supports Link-local Signaling (LLS)

      Index 1/1, flood queue length 0

      Next 0x0(0)/0x0(0)

      Last flood scan length is 0, maximum is 0

      Last flood scan time is 0 msec, maximum is 0msec

      Neighbor Count is 0, Adjacent neighbor countis 0

    Suppresshello for 0 neighbor(s)

    R4#show ip route ospf

         20.0.0.0/32is subnetted, 1 subnets

    O       20.2.2.2[110/11] via 123.123.123.2, 00:45:58, Ethernet0/1

         10.0.0.0/24is subnetted, 1 subnets

    O       10.1.1.0[110/11] via 14.14.14.1, 00:01:39, Ethernet0/0

         56.0.0.0/24 is subnetted, 1 subnets

    O IA    56.56.56.0 [110/20] via 123.123.123.5,00:01:39, Ethernet0/1

        60.0.0.0/32 is subnetted, 1 subnets

    O IA    60.6.6.6 [110/21] via 123.123.123.5,00:01:39, Ethernet0/1

    3.

    改优先级

    由于ospf配置后,先配置的就变为DR,BDR。因此如果先配置R2R3R2R3DR,BDR

    现在要将R5变成DR,R4变为BDR。那么就是将R2R3R4的优先级变为0,放弃DR,BDR竞选,然后再将其R4R3R2优先级恢复为1.

     

    R2R3R4的优先级变为0,放弃DR,BDR竞选

    R2:

    R2(config)#INTE0/1

    R2(config-if)#IPOSPF PRI

    R2(config-if)#IPOSPF PRIority 0

    R3:

    R3#conf t

    R3(config)#inte0/1

    R3(config-if)#ipospf priority 0

    R4:

    R4#conf t

    R4(config)#inte0/1

    R4(config-if)#ipospf priority 0

    R4R3R2优先级恢复为1.

    R4:

    R4#conf t

    R4(config)#inte0/1

    R4(config-if)#ipospf priority 1

    R3:

    R3#conf t

    R3(config)#inte0/1

    R3(config-if)#ipospf priority 1

    R2:

    R2#conf t

    R2(config)#inte0/1

    R2(config-if)#ipospf priority 1

    检验:

    R2#show ip ospf nei

    NeighborID     Pri   State           Dead Time   Address         Interface

    3.3.3.3           1  2WAY/DROTHER    00:00:37    123.123.123.3   Ethernet0/1

    4.4.4.4           1  FULL/BDR        00:00:37    123.123.123.4   Ethernet0/1

    5.5.5.5           1  FULL/DR         00:00:32    123.123.123.5   Ethernet0/1

    4.ospf

    的手动汇总

    4.1)区域间手动汇总(只能在ABR上做)

    R4#conf t

    R4(config)#routerospf 1    //进入ospf 1

    R4(config-router)#area1  range 10.0.0.0 255.0.0.0

    验证:

    R5#show ip route ospf

         20.0.0.0/32is subnetted, 1 subnets

    O       20.2.2.2[110/11] via 123.123.123.2, 01:22:01, Ethernet0/1

    O IA 10.0.0.0/8 [110/21]via 123.123.123.4, 00:01:19, Ethernet0/1

         14.0.0.0/24is subnetted, 1 subnets

    O IA    14.14.14.0[110/20] via 123.123.123.4, 01:22:01, Ethernet0/1

         60.0.0.0/32 is subnetted, 1 subnets

    O       60.6.6.6 [110/11] via 56.56.56.6,01:22:01, Ethernet0/0

    R6#show ip route ospf

         70.0.0.0/32 is subnetted, 1 subnets

    O       70.7.7.7 [110/11] via 67.67.67.7,01:23:44, Ethernet0/1

         20.0.0.0/32is subnetted, 1 subnets

    O IA    20.2.2.2 [110/21]via 56.56.56.5, 01:23:34, Ethernet0/0

    O IA 10.0.0.0/8[110/31] via 56.56.56.5, 00:02:57, Ethernet0/0

         123.0.0.0/24 is subnetted, 1 subnets

    O IA    123.123.123.0 [110/20] via 56.56.56.5,01:23:34, Ethernet0/0

         14.0.0.0/24is subnetted, 1 subnets

    O IA    14.14.14.0[110/30] via 56.56.56.5, 01:23:34, Ethernet0/0

    5.ospf

    认证

     

    链路认证:ABR 常规

    明文:

    R1:

    R1#conf t

    R1(config)#inte0/0

    R1(config-if)#ipospf authentication     //启用明文认证

    R1(config-if)#ipospf authentication-key abc123

    R4:

    R4#conf t

    R4(config)#inte0/0

    R4(config-if)#ipospf authentication

    R4(config-if)#ipospf authentication-key abc123

    密文:

    R6#conf t

    R6(config)#inte0/0

    R6(config-if)#ipospf authentication message-digest

    R6(config-if)#ipospf message-digest-key 1 md5 abc

     

    R5#conf t

    R5(config)#inte0/0

    R5(config-if)#ipospf authentication message-digest

    R5(config-if)#ipospf message-digest-key 1 md5 abc

    区域认证:骨干

    密文:

    R2#conf t

    R2(config)#routerospf 1

    R2(config-router)#area0 authentication message-digest

    R2(config-router)#exit

    R2(config)#inte0/1

    R2(config-if)#ipospf message-digest-key 2 md5 CHINA

     

    R3#conf t

    R3(config)#routerospf 1

    R3(config-router)#area0 authentication message-digest

    R3(config-router)#ipospf message

    R3(config-router)#exit

    R3(config)#inte0/1

    R3(config-if)#ipospf message-digest-key 2 md5 CHINA

     

    R4#conf t

    R4(config)#routerospf 1

    R4(config-router)#area0 authentication message-digest

    R4(config-router)#exit

    R4(config)#inte0/1

    R4(config-if)#ipospf message-digest-key 2 md5 CHINA

     

    R5#conf t

    R5(config)#routerospf 1

    R5(config-router)#area0 authentication message-digest

    R5(config-router)#exit

    R5(config)#inte0/1

    R5(config-if)#ipospf message-digest-key 2 md5 CHINA

     

    区域所有设备接口参与,除环回口

    6.ospf

    发布缺省路由更新

    R2#conf t

    R2(config)#router ospf 1

    R2(config-router)#default-informationoriginate always metric 2

    现象:

    R5#showip route ospf

         20.0.0.0/32 is subnetted, 1 subnets

    O       20.2.2.2 [110/11] via 123.123.123.2,00:00:33, Ethernet0/1

    O IA10.0.0.0/8 [110/21] via 123.123.123.4, 00:00:33, Ethernet0/1

         14.0.0.0/24 is subnetted, 1 subnets

    O IA    14.14.14.0 [110/20] via 123.123.123.4,00:00:33, Ethernet0/1

         60.0.0.0/32 is subnetted, 1 subnets

    O       60.6.6.6 [110/11] via 56.56.56.6,00:52:03, Ethernet0/0

    O*E2 0.0.0.0/0 [110/2] via 123.123.123.2, 00:00:33,Ethernet0/1

     

    7.

    孤岛区域和区域分割

    孤岛区域就是没有通过ABR和骨干区域相连的常规区域(图中的area 3

    解决方案:虚电路virtual-link

    骨干区域做链路认证,虚电路必须启动认证

    R6#conf t

    R6(config)#routerospf 1

    R6(config-router)#area2 virtual-link 5.5.5.5  //虚链路配置完成(没有认证的话)

    R6(config-router)#AREA2 virtual-link 5.5.5.5 authentication message-digest    

    R6(config-router)#area2 virtual-link 5.5.5.5 message-digest-key 2 md5 CHINA

    R6(config-router)#end

     

    R5#conf t

    R5(config)#routerospf 1

    R5(config-router)#area2 virtual-link 6.6.6.6

    R5(config-router)#AREA2 virtual-link 6.6.6.6 authentication message-digest

    R5(config-router)#area2 virtual-link 6.6.6.6 message-digest-key 2 md5 CHINA

    R5(config-router)#end

    测试:

    1.R7#ping 10.1.1.1 so 70.7.7.7

    2. 

    R6#showip ospf neighbor

    NeighborID     Pri   State           Dead Time   Address         Interface

    5.5.5.5           0  FULL/  -           -        56.56.56.5      OSPF_VL1

    5.5.5.5           1  FULL/BDR        00:00:34    56.56.56.5      Ethernet0/0

    7.7.7.7           1  FULL/DR         00:00:35    67.67.67.7      Ethernet0/1

    3.路由表对比

    虚拟链路前:

    R2#show ip route

    Codes: C- connected, S - static, R - RIP, M - mobile, B - BGP

           D - EIGRP, EX - EIGRP external, O -OSPF, IA - OSPF inter area

           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

           E1 -OSPF external type 1, E2 - OSPF external type 2

           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-ISlevel-2

           ia - IS-IS inter area, * - candidatedefault, U - per-user static route

           o - ODR, P - periodic downloaded staticroute

     

    Gatewayof last resort is not set

     

         20.0.0.0/24 is subnetted, 1 subnets

    C       20.2.2.0 is directly connected,Loopback0

    O IA10.0.0.0/8 [110/21] via 123.123.123.4, 00:38:57, Ethernet0/1

         56.0.0.0/24 is subnetted, 1 subnets

    O IA    56.56.56.0 [110/20] via 123.123.123.5,00:38:57, Ethernet0/1

         123.0.0.0/24 is subnetted, 1 subnets

    C       123.123.123.0 is directly connected,Ethernet0/1

         14.0.0.0/24 is subnetted, 1 subnets

    O IA    14.14.14.0 [110/20] via 123.123.123.4,00:38:57, Ethernet0/1

        60.0.0.0/32 is subnetted, 1 subnets

    O IA    60.6.6.6 [110/21] via 123.123.123.5,00:38:59, Ethernet0/1

    虚拟链路后:

    R2#show ip route

    Codes: C- connected, S - static, R - RIP, M - mobile, B - BGP

           D - EIGRP, EX - EIGRP external, O -OSPF, IA - OSPF inter area

           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

           E1 -OSPF external type 1, E2 - OSPF external type 2

           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-ISlevel-2

           ia - IS-IS inter area, * - candidatedefault, U - per-user static route

           o - ODR, P - periodic downloaded staticroute

     

    Gatewayof last resort is not set

     

         70.0.0.0/32 issubnetted, 1 subnets

    O IA    70.7.7.7[110/31] via 123.123.123.5, 00:00:02, Ethernet0/1

         20.0.0.0/24 is subnetted, 1 subnets

    C       20.2.2.0 is directly connected,Loopback0

         67.0.0.0/24 is subnetted, 1 subnets

    O IA    67.67.67.0[110/30] via 123.123.123.5, 00:00:02, Ethernet0/1

    O IA10.0.0.0/8 [110/21] via 123.123.123.4, 00:00:02, Ethernet0/1

         56.0.0.0/24 is subnetted, 1 subnets

    O IA    56.56.56.0 [110/20] via 123.123.123.5,00:00:02, Ethernet0/1

         123.0.0.0/24 is subnetted, 1 subnets

    C       123.123.123.0 is directly connected,Ethernet0/1

         14.0.0.0/24 is subnetted, 1 subnets

    O IA    14.14.14.0 [110/20] via 123.123.123.4,00:00:04, Ethernet0/1

         60.0.0.0/32 is subnetted, 1 subnets

    O IA    60.6.6.6 [110/21] via 123.123.123.5,00:05:40, Ethernet0/1

     

    8.STUB 

    NSSA的配置

    8.1)将外部路由嵌套入ospf

    R7#conf t

    R7(config)#routerrip

    R7(config-router)#version2

    R7(config-router)#noauto-summary

    R7(config-router)#net80.8.8.0

    R7(config-router)#exit

    R7(config)#routerospf 1

    R7(config-router)#redistributerip  subnets

    R7(config-router)#end

     

    R4#conf t

    R4(config)#routereigrp 1

    R4(config-router)#noauto-summary

    R4(config-router)#eigrp router-id 40.4.4.4

    R4(config-router)#net90.9.9.0 0.0.0.255

    R4(config-router)#exit

    R4(config)#routerospf 1

    R4(config-router)#redistributeeigrp 1 subnets

    R4(config-router)#end

    测试:

    R2#show ip rout ospf

         70.0.0.0/32 is subnetted, 1 subnets

    O IA    70.7.7.7 [110/31] via 123.123.123.5,00:06:45, Ethernet0/1

         80.0.0.0/24 is subnetted, 1 subnets

    O E2    80.8.8.0 [110/20] via 123.123.123.5,00:00:39, Ethernet0/1

         67.0.0.0/24 is subnetted, 1 subnets

    O IA    67.67.67.0 [110/30] via 123.123.123.5,00:06:45, Ethernet0/1

    O IA10.0.0.0/8 [110/21] via 123.123.123.4, 00:06:45, Ethernet0/1

         56.0.0.0/24 is subnetted, 1 subnets

    O IA    56.56.56.0 [110/20] via 123.123.123.5,00:06:45, Ethernet0/1

         14.0.0.0/24 is subnetted, 1 subnets

    O IA    14.14.14.0 [110/20] via 123.123.123.4,00:06:45, Ethernet0/1

         90.0.0.0/24 is subnetted, 1 subnets

    O E2    90.9.9.0 [110/20] via 123.123.123.4,00:06:45, Ethernet0/1

         60.0.0.0/32 is subnetted, 1 subnets

    O IA    60.6.6.6 [110/21] via 123.123.123.5,00:06:45, Ethernet0/1

    8.2T-STUB

    R4

    R4#conf t

    R4(config)#routerospf 1

    R4(config-router)#area1 stub no-summary

     

    R1

    R1#conf t

    R1(config)#routerospf 1

    R1(config-router)#area1 stub

     

    检验:

    建立前:

    R1#showip  rou ospf

         70.0.0.0/32 is subnetted, 1 subnets

    O IA    70.7.7.7 [110/41] via 14.14.14.4, 00:10:18,Ethernet0/0

         80.0.0.0/24 is subnetted, 1 subnets

    O E2    80.8.8.0 [110/20] via 14.14.14.4, 00:05:38,Ethernet0/0

         20.0.0.0/32 is subnetted, 1 subnets

    O IA    20.2.2.2 [110/21] via 14.14.14.4, 00:10:18,Ethernet0/0

         67.0.0.0/24 is subnetted, 1 subnets

    O IA    67.67.67.0 [110/40] via 14.14.14.4,00:10:18, Ethernet0/0

         56.0.0.0/24 is subnetted, 1 subnets

    O IA    56.56.56.0 [110/30] via 14.14.14.4,00:10:18, Ethernet0/0

         123.0.0.0/24 is subnetted, 1 subnets

    O IA    123.123.123.0 [110/20] via 14.14.14.4,00:10:18, Ethernet0/0

         90.0.0.0/24 is subnetted, 1 subnets

    O E2    90.9.9.0 [110/20] via 14.14.14.4, 00:10:18,Ethernet0/0

         60.0.0.0/32 is subnetted, 1 subnets

    O IA    60.6.6.6 [110/31] via 14.14.14.4, 00:10:18,Ethernet0/0

    O*E2 0.0.0.0/0 [110/2] via 14.14.14.4, 00:10:18,Ethernet0/0

    建立后

    R1#show ip route ospf

    O*IA 0.0.0.0/0 [110/11] via 14.14.14.4, 00:00:34,Ethernet0/0

     

    8.3)T-NSSA

    R5#conf t

    R5(config)#routerospf 1

    R5(config-router)#area3 nssa no-summary

     

    R7#conf t

    R7(config)#routerospf 1

    R7(config-router)#area2 nssa

    R7(config-router)#end

    ————完——
    展开全文
  • 03-三层交换机OSPF实验

    千次阅读 2018-12-09 01:28:00
    三层交换机OSPF实验 1.OSPF介绍  开放式最短路径优先(英语:Open Shortest Path First,缩写为 OSPF)是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。采用戴克斯特拉算法...

    三层交换机的OSPF实验

    1.OSPF介绍

      开放式最短路径优先(英语:Open Shortest Path First,缩写为 OSPF)是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。采用戴克斯特拉算法(Dijkstra's algorithm)被用来计算最短路径树。它使用“代价(Cost)”作为路由度量。链路状态数据库(LSDB)用来保存当前网络拓扑结构,路由器上属于同一区域的链路状态数据库是相同的(属于多个区域的路由器会为每个区域维护一份链路状态数据库)。

      OSPF分为OSPFv2和OSPFv3两个版本,其中OSPFv2用在IPv4网络,OSPFv3用在IPv6网络。OSPFv2是由RFC 2328定义的,OSPFv3是由RFC 5340定义的。

      OSPF协议是大中型网络上使用最为广泛的IGP(Interior Gateway Protocol)协议。节点在创建邻接,接受链路状态通告(Link-state Advertisement,LSA)时,可以通过MD5或者明文进行安全验证。

      OSPF提出了“区域(Area)”的概念,一个网络可以由单一区域或者多个区域组成。其中,一个特别的区域被称为骨干区域(Backbone Area),该区域是整个OSPF网络的核心区域,并且所有其他的区域都与之直接连接。所有的内部路由都通过骨干区域传递到其他非骨干区域。所有的区域都必须直接连接到骨干区域,如果不能创建直接连接,那么可以通过虚链路(virtual link)和骨干区域创建虚拟连接。

    2.三层交换机的OSPF实验

    2.1实验拓扑

    2.2实验配置

    设备 接口 IP Netmask Gateway Vlan
    Sw1 GE0/0/1 10.0.0.1 255.255.255.252   1000
    Ethernet0/0/1       10
    Ethernet0/0/2       20

    Sw2

    GE0/0/1 10.0.0.2 255.255.255.252   1000
    Ethernet0/0/1       30
    Ethernet0/0/2       40
    PC1 Ethernet0/0/1 192.168.10.1 255.255.255.0 192.168.10.254 10
    PC2 Ethernet0/0/2 192.168.20.1 255.255.255.0 192.168.20.254 20
    PC3 Ethernet0/0/1 192.168.30.1 255.255.255.0 192.168.30.254 30
    PC4 Ethernet0/0/2 192.168.40.1 255.255.255.0 192.168.40.254 40

     

    2.3交换机配置

    2.3.1配置交换机,使同一交换机连接的两台PC相互ping通

    Sw1基本配置

    #
    sysname Sw1
    #
    vlan batch 10 20 1000
    #
    interface Vlanif10
     ip address 192.168.10.254 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.20.254 255.255.255.0
    #
    interface Vlanif1000
     ip address 10.0.0.1 255.255.255.252
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 20
    #

    Sw2基本配置

    #
    sysname Sw2
    #
    vlan batch 30 40 1000
    #
    interface Vlanif30
     ip address 192.168.30.254 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.40.254 255.255.255.0
    #
    interface Vlanif1000
     ip address 10.0.0.2 255.255.255.252
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 30
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 40
    #

    2.3.2配置OSPF使所有PC互相ping通

    Sw1 OSPF配置

    #在交换机的GE1端口配置truk
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30 40 1000
    #配置OSPF,并进行宣告
    #
    ospf 1
     area 0.0.0.0
      network 192.168.10.0 0.0.0.255
      network 192.168.20.0 0.0.0.255
      network 10.0.0.0 0.0.0.3
    #

    Sw2 OSPF配置

    #在交换机的GE1端口配置trunk
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30 40 1000
    #配置OSPF,并进行宣告
    #
    ospf 1
     area 0.0.0.0
      network 192.168.30.0 0.0.0.255
      network 192.168.40.0 0.0.0.255
      network 10.0.0.0 0.0.0.3
    #

    2.4实验结果

    转载于:https://www.cnblogs.com/gongniue/p/10084410.html

    展开全文
  • 2:交换机路由协议配置OSPF配置 要求PC1能访问PC2,交换机使用OSPF协议 具体实验操作如图,路由数量不够。。。 配置规划 PC1: IP:100.1.1.2 PC2: IP:30.1.1.3 SA: VLAN 100 IP:100.1.1.1 VLAN 10 IP:...

    2:交换机路由协议配置OSPF配置

    要求PC1能访问PC2,交换机使用OSPF协议

    具体实验操作如图,路由数量不够。。。

    配置规划  
    PC1:
    IP:100.1.1.2
    
    PC2:
    IP:30.1.1.3
    
    SA:
    VLAN 100
    IP:100.1.1.1
    VLAN 10
    IP:10.1.1.2
    
    SB:
    VLAN 10
    IP:10.1.1.1
    VLAN 20
    IP:20.1.1.1
    
    SC:
    VLAN 20
    IP:20.1.1.2
    VLAN 30
    IP:30.1.1.1
    

    代码:

    A:
    
    创建VLAN100、VLAN10
    
    conf t
    vlan 100
    exit
    vlan 10
    exit
    
    将端口加入VLAN
    int f0/1
    switchport mode access
    switchport access vlan 100
    exit
    
    int f0/2
    switchport mode access
    switchport access vlan 10
    exit
    
    设置VLAN的IP地址
    int vlan 100
    ip address 100.1.1.1 255.255.255.0
    no shutdown
    exit
    
    int vlan 10
    ip address 10.1.1.2 255.255.255.0
    no shutdown
    exit
    
    设置路由
    ip routing
    router ospf 1
    network 100.1.1.0 0.0.0.255 area 0
    network 10.1.1.0 0.0.0.255 area 0
    end
    
    B:
    
    创建VLAN10、VLAN20
    
    conf t
    vlan 10
    exit
    vlan 20
    exit
    
    将端口加入VLAN
    int f0/1
    switchport mode access
    switchport access vlan 10
    exit
    
    int f0/2
    switchport mode access
    switchport access vlan 20
    exit
    
    设置VLAN的IP地址
    int vlan 10
    ip address 10.1.1.1 255.255.255.0
    no shutdown
    exit
    
    int vlan 20
    ip address 20.1.1.1 255.255.255.0
    no shutdown
    exit
    
    设置路由
    ip routing
    router ospf 1
    network 10.1.1.0 0.0.0.255 area 0
    network 20.1.1.0 0.0.0.255 area 0
    end
    
    C:
    
    创建VLAN20、VLAN30
    
    conf t
    vlan 20
    exit
    vlan 30
    exit
    
    将端口加入VLAN
    int f0/1
    switchport mode access
    switchport access vlan 30
    exit
    
    int f0/2
    switchport mode access
    switchport access vlan 20
    exit
    
    设置VLAN的IP地址
    int vlan 20
    ip address 20.1.1.2 255.255.255.0
    no shutdown
    exit
    
    int vlan 30
    ip address 30.1.1.1 255.255.255.0
    no shutdown
    exit
    
    设置路由
    ip routing
    router ospf 1
    network 20.1.1.0 0.0.0.255 area 0
    network 30.1.1.0 0.0.0.255 area 0
    end
    

    设备连接方式:

    如上图,Fa0/1表示交换机的1口,连接完毕之后进行ping操作即可

    cmd使用pathping操作进行检查,要求能看到交换机上vlan的ip

     

    展开全文
  • ospf配置实验

    2015-06-04 23:29:30
    从左到右依次对路由器进行配置然后对要求进行验证接下来把路由器改为三层交换机从左到右依次对三层交换机进行设置接下来对要求进行验证 转载于:https://blog.51cto.com/bin06/1658682...
  • eNsp华为模拟器 ospf配置实验

    千次阅读 2020-05-02 00:10:33
    基础ospf协议配置需要注意地点: ①在启用ospf时,需要声明area区域,在同一个区域内才能通信。(要实现不同区域的配置我后面扩展中有写) ②network宣布地网段是自己的直连网段(与rip相同),但是需要加上反掩码 ...
  • 思科交换机配置ipv6实验

    千次阅读 2020-03-18 10:14:10
    本次实验主要关注基于三层vlan下ipv6地址如何配置 实验拓扑: 一台核心交换机 两台接入交换机 3台服务器分别在vlan50、vlan21、vlan13 1、接入交换机1配置: ipv6 unicast-routing #开启 nterface GigabitEthernet0...
  • 29、OSPF配置实验之被动接口

    千次阅读 2017-11-15 20:07:00
    当我们不想某个接口收发OSPF报文时,我们可以在OSPF路由进程下将其配置成被动接口。network通告路由和发送hello包,当我们将接口配置成被动接口后,它只是不收发hello报文而已,网络还是会通告出来,其他路由器同样...
  • 在工作中遇到了H3C和HW的RRPP配置,以下就以华为模拟器再作一次实验。大家共同来论讨论遇到的问题。
  • 实验 1 交换机的基本配置 实验 2 VLAN 配置 实验3 生成树协议 实验 4 路由器的基本配置 实验5 静态路由 实验 6 动态路由(RIP) 实验 7 配置帧中继(F-R) 实验 8 IP 访问列表 实验 9 802.3ad 冗余备份测试 实验 10 ...
  • 实验二 交换机TELNET配置实验 实验三 RIP路由协议 实验四 防火墙ACL规则配置 实验五 ASPF状态检测功能测试 实验六 帧中继 实验七 华为:x.25试验 实验八 PPP验证PAP和CHAP 实验九 华为MPLS 技术特色 实验十 ...
  • 软考网络工程师级配置题总结一、 交换机配置1. 交换机的基本配置Enable 进入特权模式 Config terminal进入配置模式Enable password cisco设置enable password 为 cisco Enable secret cisco1设置enable secret 为 ...
  • 实验一:交换机的基本配置
  • HCL配置 OSPF 验证实验

    2020-04-22 22:45:15
    引入 ...通过本实验内容,应该能够掌握OSPF验证的配置方法和应用场合。 实验要求 RTA、RTB和RTC启动OSPF的区域验证,并且在相关接口下配置验证密码。RTA的 G0/0使用密码123, RTB的G0/0使用密码123,...
  • 华为ospf路由配置实例操作
  • 链路状态通告---LSA,及OSPF配置实验 一、内部网关协议和外部网关协议 1、AS 2、协议分类 二.LSA的分类: 1.Type-1 LSA : Router LSA 2.Type-2 LSA : Network LSA 3.Type-3 LSA : Network Summary LSA 4.Type-4 LSA:...
  • VLan与ospf基本配置实验

    千次阅读 2020-04-14 10:38:23
    Vlan与ospf基本配置实验 1、实验拓扑 2、实验目的 全网互通并且PC1和PC4可以ping通AR4的环回地址4.4.4.4,但是AR3与AR4之间不配置ospf 3、实验步骤 1、安照如图所示配置ip地址 2、在LSW1和LSW2上配置vlan及各个接口...
  • 实验OSPF路由实验

    千次阅读 2019-12-29 11:52:06
    实验OSPF路由实验OSPF路由实验一、 ...2) 利用ensp实验平台完成路由器和交换机的基本配置 二、实验要求 在AR1和AR2之间运行OSPF路由协议,在AR2和AR3之间运行RIPv2协议,在AR2上的RIP和OSPF进程间交换路由信息...
  • Hello大家好,本篇博文讲述的是大学网络工程思科路由器之ospf路由配置实验,供各大专院校学生与老师参考,如需转载,需注原创 接下来,我们来讲一讲,如何进行OSPF路由配置实验 首先,我们选好进行实验的器材:分别...
  • 三层交换机配置综合实验

    千次阅读 2009-10-28 04:24:00
    实验拓扑第一步,配置VTP域,创建VLAN3550:3550#vlan database3550(vlan)#vtp server3550(vlan)#vtp domain sy3550(vlan)#vtp password cisco3550(vlan)#vlan 23550(vlan)#vtp 33550(vlan)#vtp pruning3550(vlan)#...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,566
精华内容 1,426
关键字:

交换机ospf配置实验