精华内容
下载资源
问答
  • SSH是在传统的Telnet协议之基础上发展起来的一种安全的远程登录协议。相比于Telnet,SSH无论是在认证方式或者数据传输的安全性上,都有很大的提高。步骤一、生成本地密钥对[Huawei]rsa local-key-pair createThe key...

    SSH是在传统的Telnet协议之基础上发展起来的一种安全的远程登录协议。相比于Telnet,SSH无论是在认证方式或者数据传输的安全性上,都有很大的提高。

    步骤一、生成本地密钥对

    [Huawei]rsa local-key-pair create

    The key name will be: Huawei_Host

    The range of public key size is (512 ~ 2048).

    NOTES: If the key modulus is greater than 512,

    it will take a few minutes.

    Input the bits in the modulus[default = 512]:1024

    Generating keys...

    ............................++++++

    ...++++++

    ..++++++++

    ......++++++++

    步骤二、配置VTY用户界面

    [Huawei]user-interface vty 0 4

    [Huawei-ui-vty0-4]authentication-mode aaa

    [Huawei-ui-vty0-4]protocol inbound ssh

    [Huawei-ui-vty0-4]quit

    步骤三、创建SSH用户,并配置用户的认证方式为password

    [Huawei]ssh user  shxke authentication-type password

    步骤四、配置SSH用户的用户名和密码

    [Huawei]aaa

    [Huawei-aaa]local-user shxke password cipher shxke

    Info: Add a new user.

    [Huawei-aaa]local-user shxke privilege level 3

    [Huawei-aaa]local-user shxke service-type ssh

    [Huawei-aaa]quit

    步骤五、使能STelent功能,并配置用户的服务类型为STelnet

    [Huawei]stelnet server enable

    Info: Succeeded in starting the Stelnet server.

    [Huawei]ssh user shxke service-type stelnet

    配置完成,就这么简单,你学会了吗??

    展开全文
  • 如何配置交换机SSH远程登录

    千次阅读 2021-01-12 10:17:27
    如何配置交换机SSH远程登录,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。如何配置锐捷SSH远程登陆?一、配置思路配置ssh远程登陆,一般是有四个步骤:1、首先选择Console方式登陆交换机2、开启交换机...

    如何配置交换机SSH远程登录,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。

    如何配置锐捷SSH远程登陆?

    一、配置思路

    配置ssh远程登陆,一般是有四个步骤:

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    3、生成加密密钥

    4、配置SSH管理的登入口令

    二、配置步骤(以锐捷交换机的配置为例)

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    switch>enable //进入特权模式

    switch#configure terminal //进入全局配置模式

    switch(config)#enable service ssh-server //开启ssh-server

    switch(config)#interface vlan 1 //进入vlan 1接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 //为vlan 1接口上设置管理ip 192.168.1.1

    switch(config-if)#exit //退回到全局配置模式

    3、生成加密密钥

    switch(config)#crypto key generate dsa //加密方式有两种:DSA和RSA,可以随意选择

    然后等待密钥生成,然后直接敲回车就好

    4、配置SSH管理的登入口令

    switch(config)#line vty 0 4 //进入SSH密码配置模式,0 4表示允许共5个用户同时SSH登入到交换机

    switch(config-line)#login local //启用SSH时使用本地用户和密码功能

    switch(config-line)#transport input ssh //设置传输模式是SSH,设置远程登入只允许使用SSH登入,不能使用telnet登入

    switch(config-line)#exit //回到全局配置模式

    switch(config)#username Ruijie password 123456 //配置远程登入的用户名为Ruijie,密码为123456

    switch(config)#end //退出到特权模式

    switch#write //确认配置正确,保存配置

    5、验证命令(查看SSH的参数信息(版本信息,重认证次数等参数)

    switch#show ip ssh //显示配置信息

    然后就配置完了,从配置中可以看出,ssh远程登陆方式确实比telnet要安全一些,适用于企业中。

    三、远程登陆进入

    配置后了ssh远程登陆后,可以使用PUTTY或者SecureCRT远程登陆就行。

    用刚刚配置的ip地址,及用户名和密码进行登陆,我们就是SecureCRT登陆为例。

    那么,这个就ssh远程登陆成功了。

    最后补充下:

    配置需要开启SSH功能,且PC与交换机在同一个网段,如果不在的话,可以设置下网关。

    可以用show service命令确认SSH服务功能是否开启。

    精品学习资料,有弱电、室分工程学习资料。入行必备,培训必备!

    展开全文
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...

    上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。

    一、如何配置锐捷SSH远程登陆?

    一、配置思路

    配置ssh远程登陆,一般是有四个步骤:

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    3、生成加密密钥

    4、配置SSH管理的登入口令

    二、配置步骤(以锐捷交换机的配置为例)

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    switch>enable //进入特权模式

    switch#configure terminal //进入全局配置模式

    switch(config)#enable service ssh-server //开启ssh-server

    switch(config)#interface vlan 1 //进入vlan 1接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 //为vlan 1接口上设置管理ip 192.168.1.1

    switch(config-if)#exit //退回到全局配置模式

    3、生成加密密钥

    switch(config)#crypto key generate dsa //加密方式有两种:DSA和RSA,可以随意选择

    然后等待密钥生成,然后直接敲回车就好

    4、配置SSH管理的登入口令

    switch(config)#line vty 0 4 //进入SSH密码配置模式,0 4表示允许共5个用户同时SSH登入到交换机

    switch(config-line)#login local //启用SSH时使用本地用户和密码功能

    switch(config-line)#transport input ssh //设置传输模式是SSH,设置远程登入只允许使用SSH登入,不能使用telnet登入

    switch(config-line)#exit //回到全局配置模式

    switch(config)#username Ruijiepassword 123456//配置远程登入的用户名为Ruijie,密码为123456

    switch(config)#end //退出到特权模式

    switch#write //确认配置正确,保存配置

    5、验证命令(查看SSH的参数信息(版本信息,重认证次数等参数)

    switch#show ip ssh //显示配置信息

    然后就配置完了,从配置中可以看出,ssh远程登陆方式确实比telnet要安全一些,适用于企业中。

    二、远程登陆进入

    配置后了ssh远程登陆后,可以使用PUTTY或者SecureCRT远程登陆就行。

    用刚刚配置的ip地址,及用户名和密码进行登陆,我们就是SecureCRT登陆为例。

    那么,这个就ssh远程登陆成功了。

    最后弱电行业网补充下:

    配置需要开启SSH功能,且PC与交换机在同一个网段,如果不在的话,可以设置下网关。

    可以用show service命令确认SSH服务功能是否开启。

    弱电行业网官网:www.rdhyw.com

    最新弱电资料更新—弱电智能化方案与5G施工报价2020年7月7日

    展开全文
  • 1,问题描述S5700 SSH配置此功能在S交换机中通用,如S2700,S3700,S5700,S6700,S7700,S9300,S9700。2,解决方案[Quidway]aaa //配置用户信息[Quidway-aaa]local-user huawei password cipher huawei[Quidway-aaa]...

    1,问题描述

    S5700 SSH配置

    此功能在S交换机中通用,如S2700,S3700,S5700,S6700,S7700,S9300,S9700。

    2,解决方案

    [Quidway]aaa //配置用户信息

    [Quidway-aaa]local-user huawei password cipher huawei

    [Quidway-aaa]local-user huawei service-type ssh telnet

    [Quidway-aaa]local-user huawei privilege level 15

    [Quidway-aaa]quit

    [Quidway]stelnet server enable

    [Quidway]user-interface vty 0 4

    [Quidway-ui-vty0-4]authentication-mode aaa

    [Quidway-ui-vty0-4]protocol inbound all

    [Quidway-ui-vty0-4]quit

    [Quidway]rsa local-key-pair create //创建公钥,以便分发给客户端

    The range of public key size is (512 ~ 2048).

    [Quidway]ssh user huawei authentication-type password //配置ssh验证及业务,非常重要

    [Quidway]ssh user huawei service-type stelnet

    关于SSH版本:

    版本主要有1.3,1.5,2.0。

    交换机做SSH服务器时,默认同时支持SSH1.x和SSH 2,登陆设备后会显示SSH 1.99,其实就是v1 v2的兼容模式。

    [HUAWEI] ssh server compatible-ssh1x enable (默认开启)

    如果客户端的协议版本号低于1.3或高于2.0,则版本协商失败,断开连接。

    如果客户端的协议版本为大于等于1.3并且小于1.99,如果系统配置为兼容SSH1.X方式,则进入SSH1.5 SERVER模块,后续进行SSH1.x协议流程,否则版本协商失败,断开与客户端的连接。

    如客户端协议版本为1.99或2.0,则进入SSH2.0 SERVER模块,后续进行SSH2.0协议流程。

    展开全文
  • 华为的 ssh 叫 STelnet(1)配置STelnet服务器功能及参数rsa local-key-pair create [1]stelnet server enable [2]undo ssh server keepalive disable [3][1] 创建密钥对,这个是必须的。可以选用 rsa dsa ecc 等加密...
  • Stelnet(安全telnet)登陆也成为shh(sercure shell,安全外壳)登陆-----------必要配置---------------1、先根据加密算法生成秘钥对,用于传输数据时加密保护,保存在交换机中但不保存在配置文件中[Huawei]rsa local-...
  • H3C交换机SSH配置完全攻略 1.使用SSH+密码认证(基本SSH配置方法)** 注:在用户使用SSH登录交换机时,交换机对所要登录的用户使用密码对其进行身份验证 生成RSA和DSA密钥对 [H3C]public-key local create rsa [H3C]...
  • 华为交换机 ssh和Telnet远程登录配置命令 ##定位合肥 ,有没有大的公司招人 ,正在考IE中 联系方式 QQ481715271 ** 简单拓扑 ** LSW4 vlan 20配置地址的原因是SSH Telnet 都可以登录 LSW3 配置 vlan batch 10 20 ...
  • 华为交换机SSH登录失败原因

    千次阅读 2021-05-15 07:59:00
    2、设备作为SSH服务器,协议版本号高于客户端的协议版本号,版本不一致导致SSH登录失败。处理方法:系统视图下,执行命令ssh server compatible-ssh1x enable,配置SSH服务器兼容低版本功能。缺省情况...
  • 你只需要一份配置模板,一列ip表。这个脚本会把模板刷对应ip设备里。 适合网络人员,支持ssh登陆的交换机或者服务器
  • 交换机配置IP2.生成密钥3.配置VTY4.创建ssh用户,配置password认证5.开启stelnet功能配置如下:< HUAWEI >< HUAWEI >sysEntersystem view, return user view with Ctrl+Z.[HUAWEI] intterface Vlanif 1...
  • 交换机SSH登陆失败故障排查

    千次阅读 2021-01-06 17:14:27
    操作方法:用户视图下,执行命令kill user-interface { ui-number | ui-type ui-number1 } 三、检查SSH服务器状态 操作步骤 在任意视图下,执行命令 display ssh server status,检查SSH服务器状态。 display ssh ...
  • SSH的优势在现在这个信息时代,网络安全变得越来越重要,当然路由器交换机作为数据传输的环节,安全性更为重要。现在的网络设备一般都是支持SSH和Telnet远程登录的,新设备一般默认建议SSH登录。Telnet是明文传送,...
  • 交换机交换机如何配置ssh管理

    千次阅读 2020-12-29 10:38:18
    一、组网需求通过ssh功能远程登录管理设备二、配置步骤:1)全局开启SSH服务,并制定SSH的版本Ruijie>enableRuijie#configure terminalRuijie(config)#enable service ssh-server ------>开启SSH服务,默认关闭...
  • H3C交换机SSH配置(20200922)

    千次阅读 2020-09-23 21:03:36
    H3C交换机SSH配置(20200922)H3C SSH配置方案1: (AAA认证+Password认证)H3C SSH配置方案2: (AAA认证+Publickey认证+FTP上传文件) 实验拓扑: H3C SSH配置方案1: (AAA认证+Password认证) #配置VLAN...
  • enable ...enable service ssh-server ip ssh version 2 username user01 privilege 15 password 7 mima211 username user01 login mode ssh lin vty 0 4 login local transport input all end write
  • 通过串口线配置S5700 的管理IP地址,串口线接在交换机的console口,ip设置完成后网线接在ETH口: system-view[Quidway] interface MEth 0/0/1[Quidway] interface MEth 0/0/1[Quidway-MEth0/0/1]ip address x.x.x.x ...
  • 前几天研究了下SSH2通信的加密与认证过程,针对publickey认证方式,服务器端将公钥放入authorized_keys文件就可以了,但是交换机方面如何配置呢?So,今天主要说一下交换机是如何配置的。 在介绍之前提前提及一下...
  • H3C交换机SSH配置

    2020-12-30 20:18:43
    交换机配置管理地址interfaceVlan-interface1ipaddress192.168.1.1255.255.255.0配置rsa密钥对并开启ssh服务器public-ketlocalcreatersasshserverenable设置登录用户认证方式为AAA认证并设置SWA上远程登录协议为...
  • 如图,配置华为交换机ssh远程登录,先配置交换机的管理地址和vlan,此处为vlan10 ,把接口GE0/0/1划入vlan10,管理地址为192.168.10.100/24,通过桥接到本地电脑网卡。 一,配置管理地址和接口vlan [SW1]vlan 10 [SW...
  • H3C交换机配置SSH

    万次阅读 2020-03-27 20:31:49
    一般连接交换机可以使用telnet协议,虽然Telnet较为简单实用也很方便,并不怎么安全。原因在于Telnet是一个明文传送协议,它将用户的所有内容,包括用户名和密码都明文在互联网上传送,具有一定的安全隐患,因此许多...
  • H3C交换机SSH配置举例

    千次阅读 2016-03-02 10:46:49
    注:本文仅供个人学习参考,禁止用作商业用途。...Host采用SSH协议登录Switch上,以保证数据信息交换的安全。SSH用户采用的认证方式为password认证,用户名和密码保存在Switch上。2.组网图SSH passwor...
  • */ public class SSHClient { /** * 执行shell命令 * @param session session会话 * @param shell 命令 * @param endShell 退出命令(交换机服务器不同,exit或quit) * @return */ public static String ...
  • 使用SSH登录交换机(RSA方式)

    千次阅读 2020-12-20 05:59:06
    本文介绍了在Linux及puttygen上生成密钥对,并上传公钥到交换机,实现私钥登录的过程。这种方式的话,用于验证的私钥存放在用户端,并且可以使用密码保护公钥,比使用用户密码认证方式更安全。一、密钥对的生成,两...
  • 3、H3C交换机SSH登录

    千次阅读 2019-09-18 05:25:07
    //生成本地密钥[switch] public-key local create { dsa | rsa |ecdsa }//使能SSH服务器功能[switch] ssh server enable//进入VTY用户线视图[switch] line vty first-number [ last-number ] //配置登录用户线的认证...
  • 2019独角兽企业重金招聘Python工程师标准>>> ...完成上述操作后,用户成功登录到SSH Server,故障排除。 转载于:https://my.oschina.net/u/914655/blog/3038173
  • #服务器端配置 \\配置虚拟中断接口 VTYuser-interface vty 0 4authentication-mode aaaidle-timeout 10 0protocol inbound ssh \\配置远程登陆用户及密码、服务类型、登陆级别aaalocal-user huawei password cipher ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 12,607
精华内容 5,042
关键字:

交换机ssh到服务器