精华内容
下载资源
问答
  • 如何配置交换机SSH远程登录,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。如何配置锐捷SSH远程登陆?一、配置思路配置ssh远程登陆,一般是有四个步骤:1、首先选择Console方式登陆交换机2、开启交换机...

    如何配置交换机SSH远程登录,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。

    如何配置锐捷SSH远程登陆?

    一、配置思路

    配置ssh远程登陆,一般是有四个步骤:

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    3、生成加密密钥

    4、配置SSH管理的登入口令

    二、配置步骤(以锐捷交换机的配置为例)

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    switch>enable //进入特权模式

    switch#configure terminal //进入全局配置模式

    switch(config)#enable service ssh-server //开启ssh-server

    switch(config)#interface vlan 1 //进入vlan 1接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 //为vlan 1接口上设置管理ip 192.168.1.1

    switch(config-if)#exit //退回到全局配置模式

    3、生成加密密钥

    switch(config)#crypto key generate dsa //加密方式有两种:DSA和RSA,可以随意选择

    然后等待密钥生成,然后直接敲回车就好

    4、配置SSH管理的登入口令

    switch(config)#line vty 0 4 //进入SSH密码配置模式,0 4表示允许共5个用户同时SSH登入到交换机

    switch(config-line)#login local //启用SSH时使用本地用户和密码功能

    switch(config-line)#transport input ssh //设置传输模式是SSH,设置远程登入只允许使用SSH登入,不能使用telnet登入

    switch(config-line)#exit //回到全局配置模式

    switch(config)#username Ruijie password 123456 //配置远程登入的用户名为Ruijie,密码为123456

    switch(config)#end //退出到特权模式

    switch#write //确认配置正确,保存配置

    5、验证命令(查看SSH的参数信息(版本信息,重认证次数等参数)

    switch#show ip ssh //显示配置信息

    然后就配置完了,从配置中可以看出,ssh远程登陆方式确实比telnet要安全一些,适用于企业中。

    三、远程登陆进入

    配置后了ssh远程登陆后,可以使用PUTTY或者SecureCRT远程登陆就行。

    用刚刚配置的ip地址,及用户名和密码进行登陆,我们就是SecureCRT登陆为例。

    那么,这个就ssh远程登陆成功了。

    最后补充下:

    配置需要开启SSH功能,且PC与交换机在同一个网段,如果不在的话,可以设置下网关。

    可以用show service命令确认SSH服务功能是否开启。

    精品学习资料,有弱电、室分工程学习资料。入行必备,培训必备!

    展开全文
  • # sftp server enable stelnet server enable ssh user admin ssh user admin authentication-type password ssh user root ssh user root service-type all ssh user test ssh user test authentication-type ...

    我上一部分配置吧:

    #

    aaa

    authentication-scheme default

    authorization-scheme default

    accounting-scheme default

    domain default

    domain default_admin

    local-user root password irreversible-cipher %@%@d|)3=]k;%DVqD&Zd%URL^&^"0yeD"F~Jr*PqH]+"@fg:&^%^%@%@

    local-user root privilege level 3

    local-user root service-type ssh

    local-user test password irreversible-cipher %@%@On{^/Um;|>8>Y7S%:+/Mn!Tr|!KbB*$J%PWQl9TcrgB"!Tun%@%@

    local-user test privilege level 3

    local-user test service-type ssh

    local-user admin password irreversible-cipher %@%@9I"s$UjiP3o98

    local-user admin privilege level 3

    local-user admin service-type ssh

    #

    #

    sftp server enable

    stelnet server enable

    ssh user admin

    ssh user admin authentication-type password

    ssh user root

    ssh user root service-type all

    ssh user test

    ssh user test authentication-type password

    ssh user test service-type stelnet

    #user-interface con 0

    authentication-mode password

    set authentication password cipher $1a$pDCnH[}-&;$$iY

    user-interface vty 0 4

    authentication-mode aaa

    user-interface vty 16 20

    #

    return

    另外,如果我想设置console口登录和SSH登录的账号密码一模一样,要怎么设置,我在设置SSH账号时报错,提示:

    [Quidway-aaa]local-user ***** password cipher ****

    Error: The password encryption mode cannot be changed.

    展开全文
  • 华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。一、如何配置锐捷SSH...

    华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。

    一、如何配置锐捷SSH远程登陆?

    一、配置思路

    配置ssh远程登陆,一般是有四个步骤:

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    3、生成加密密钥

    4、配置SSH管理的登入口令

    二、配置步骤(以锐捷交换机的配置为例)

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    switch>enable //进入特权模式

    switch#configure terminal //进入全局配置模式

    switch(config)#enable service ssh-server //开启ssh-server

    switch(config)#interface vlan 1 //进入vlan 1接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 //为vlan 1接口上设置管理ip 192.168.1.1

    switch(config-if)#exit //退回到全局配置模式

    3、生成加密密钥

    switch(config)#crypto key generate dsa //加密方式有两种:DSA和RSA,可以随意选择

    然后等待密钥生成,然后直接敲回车就好

    4、配置SSH管理的登入口令

    switch(config)#line vty 0 4 //进入SSH密码配置模式,0 4表示允许共5个用户同时SSH登入到交换机

    switch(config-line)#login local //启用SSH时使用本地用户和密码功能

    switch(config-line)#transport input ssh //设置传输模式是SSH,设置远程登入只允许使用SSH登入,不能使用telnet登入

    switch(config-line)#exit //回到全局配置模式

    switch(config)#username Ruijie password 123456 //配置远程登入的用户名为Ruijie,密码为123456

    switch(config)#end //退出到特权模式

    switch#write //确认配置正确,保存配置

    5、验证命令(查看SSH的参数信息(版本信息,重认证次数等参数)

    switch#show ip ssh //显示配置信息

    然后就配置完了,从配置中可以看出,ssh远程登陆方式确实比telnet要安全一些,适用于企业中。

    二、远程登陆进入

    配置后了ssh远程登陆后,可以使用PUTTY或者SecureCRT远程登陆就行。

    用刚刚配置的ip地址,及用户名和密码进行登陆,我们就是SecureCRT登陆为例。

    那么,这个就ssh远程登陆成功了。

    最后弱电行业网补充下:

    配置需要开启SSH功能,且PC与交换机在同一个网段,如果不在的话,可以设置下网关。

    可以用show service命令确认SSH服务功能是否开启。

    展开全文
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...

    上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。

    一、如何配置锐捷SSH远程登陆?

    一、配置思路

    配置ssh远程登陆,一般是有四个步骤:

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    3、生成加密密钥

    4、配置SSH管理的登入口令

    二、配置步骤(以锐捷交换机的配置为例)

    1、首先选择Console方式登陆交换机

    687309562d625e006c33a3270cded1ff.png

    2、开启交换机的SSH服务功能并配置IP

    switch>enable     //进入特权模式

    switch#configure terminal     //进入全局配置模式

    switch(config)#enable service ssh-server     //开启ssh-server

    switch(config)#interface vlan 1       //进入vlan 1接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0    //为vlan 1接口上设置管理ip 192.168.1.1

    switch(config-if)#exit //退回到全局配置模式

    3、生成加密密钥

    switch(config)#crypto key generate dsa    //加密方式有两种:DSA和RSA,可以随意选择

    然后等待密钥生成,然后直接敲回车就好

    4、配置SSH管理的登入口令

    switch(config)#line vty 0 4     //进入SSH密码配置模式,0 4表示允许共5个用户同时SSH登入到交换机

    switch(config-line)#login local    //启用SSH时使用本地用户和密码功能

    switch(config-line)#transport input ssh    //设置传输模式是SSH,设置远程登入只允许使用SSH登入,不能使用telnet登入

    switch(config-line)#exit     //回到全局配置模式

    switch(config)#username Ruijie password 123456 //配置远程登入的用户名为Ruijie,密码为123456

    switch(config)#end     //退出到特权模式

    switch#write       //确认配置正确,保存配置

    5、验证命令(查看SSH的参数信息(版本信息,重认证次数等参数)

    switch#show ip ssh    //显示配置信息

    cbfbf4e9ee326834750d927b31e8f9fd.png

    然后就配置完了,从配置中可以看出,ssh远程登陆方式确实比telnet要安全一些,适用于企业中。

    二、远程登陆进入

    配置后了ssh远程登陆后,可以使用PUTTY或者SecureCRT远程登陆就行。

    用刚刚配置的ip地址,及用户名和密码进行登陆,我们就是SecureCRT登陆为例。

    509c4a1c64b4e598996d088a89b3142a.png

    05cfadc22b4cd92830c55ac187b260c5.png

    340f0da71617eac8df9ba80757d368ee.png

    那么,这个就ssh远程登陆成功了。

    最后弱电行业网补充下:

    配置需要开启SSH功能,且PC与交换机在同一个网段,如果不在的话,可以设置下网关。

    可以用show service命令确认SSH服务功能是否开启。

    1199134ad42ee437f6690824abf4de8a.png

    10d9b86f6b2c1a61873e986cfb3587ed.png

    弱电行业网官网:www.rdhyw.com

    最新弱电资料更新—弱电智能化方案与5G施工报价2020年7月7日

    展开全文
  • 本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。如何配置锐捷SSH远程登陆?一、配置思路配置ssh远程登陆,一般是有四个步骤:1、首先选择Console方式登陆交换机2、开启交换机SSH服务功能并配置IP3、生成...
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...
  • 华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。一、如何配置锐捷SSH...
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...
  • 华为交换机 ssh和Telnet远程登录配置命令 ##定位合肥 ,有没有大的公司招人 ,正在考IE中 联系方式 QQ481715271 ** 简单拓扑 ** LSW4 vlan 20配置地址的原因是SSH Telnet 都可以登录 LSW3 配置 vlan batch 10 20 ...
  • 3、H3C交换机SSH登录

    2019-09-18 05:25:07
    public-key local create { dsa | rsa |ecdsa }//使能SSH服务器功能[switch] ssh server enable//进入VTY用户线视图[switch] line vty first-number [ last-number ] //配置登录用户线的认证方式为scheme方式...
  • Host采用SSH协议登录到Switch上,以保证数据信息交换的安全。SSH用户采用的认证方式为password认证,用户名和密码保存在本地设备上。2. 组网图3. 配置步骤(1) 配置SSH服务器# 生成RSA及DSA密钥对,并启动SSH服务器。...
  • 前几天研究了下SSH2通信的加密与认证过程,针对publickey认证方式,服务器端将公钥放入authorized_keys文件就可以了,但是交换机方面如何配置呢?So,今天主要说一下交换机是如何配置的。 在介绍之前提前提及一下...
  • 交换机配置ssh密码验证登录方式

    千次阅读 2017-12-24 15:19:12
    交换机配置ssh密码验证登录方式一、背景:1、由于PC机串口不支持热插拔,请不要在交换机带电的情况下,将串口插入或者拔出PC机。当连接PC和交换机时,请先安装配置电缆的DB-9端到PC机,再连接RJ-45到交换机;在拆下...
  • 本文介绍了在Linux及puttygen上生成密钥对,并上传公钥到交换机,实现私钥登录的过程。这种方式的话,用于验证的私钥存放在用户端,并且可以使用密码保护公钥,比使用用户密码认证方式更安全。一、密钥对的生成,两...
  • 通过交换的console口连接PC,进行如下配置,具体连接方式可参考我另外一篇博客 <HUAWEI(guangkou-48)>sys # 进入系统视图 [HUAWEI(guangkou-48)]aaa [HUAWEI(guangkou-48)-aaa]local-user kobe password ...
  • 实验拓扑及描述在上图所示的拓扑中,Cloud1与交换机LSW1直连,我们将...实验需求完成交换机的配置,使得物理机能够通过SSH方式登录到该交换机。实现步骤及配置cloud的配置如下:SW1的配置如下:创建VLAN100:[...
  • h3c交换机配置ssh密码验证登录方式

    万次阅读 2018-11-07 17:45:57
    当连接PC和交换机时,请先安装配置电缆的DB-9端到PC机,再连接RJ-45到交换机;在拆下时,先拔出RJ-45端,再拔下DB-9端。 2、恢复出厂设置的交换机 &lt;H3C&gt;reset saved-configuration 3、重启设备 ...
  • 交换机配置管理地址interfaceVlan-interface1ipaddress192.168.1.1255.255.255.0配置rsa密钥对并开启ssh服务器public-ketlocalcreatersasshserverenable设置登录用户认证方式为AAA认证并设置SWA上远程登录协议为...
  • 华为交换机配置SSH登录首先说一下配置的基本步骤1、虚拟终端VTY设置2、SSH用户设置3、SSH服务器设置下面具体说一下1、虚拟终端VTY设置[huawei]user-interfacevty4[huawei-ui-vty4]authentication-modeaaa#用户认证...
  • 如何利用华为交换机配置SSH登录

    千次阅读 2017-11-17 12:04:00
    SSH是在传统的Telnet协议之基础上发展起来的一种安全的远程登录协议。相比于Telnet,SSH无论是在认证方式或者数据传输的安全性上,都有很大的提高。 步骤一、生成本地密钥对 [Huawei]rsa local-key-pair create The ...
  • 如有侵权请联系网站删除谢谢1为交换机配置管理地址interfaceVlan-interface1ipaddress192.168.1.1255.255.255.0配置rsa密钥对并开启ssh服务器public-ketlocalcreatersasshserverenable设置登录用户认证方式为AAA认证...
  • 华为交换机配置ssh rsa认证登录方式

    千次阅读 2016-11-16 10:27:00
    systemrsa local-key-pair createstelnet server enable输入公钥* * *New Key from Linux ssh-keygen```systemrsa peer-public-key newpublic-key-code beginpublic-key-code endpeer-public-key end```配置ssh...
  • H3C交换机SSH配置举例

    千次阅读 2016-03-02 10:46:49
    注:本文仅供个人学习参考,禁止用作商业用途。...Host采用SSH协议登录到Switch上,以保证数据信息交换的安全。SSH用户采用的认证方式为password认证,用户名和密码保存在Switch上。2.组网图SSH passwor...
  • 注:本文仅供个人学习参考,禁止用作...Host采用SSH协议登录到Switch上,以保证数据信息交换的安全。SSH用户采用的认证方式为password认证,用户名和密码保存在Switch上。2.组网图SSH password认证配置组网图3.配置...
  • 今天给大家带来的是如何在华为交换机配置Telnet和SSH的配置。实验拓扑如下 实验拓扑 实验需求 按照图示连接到真机,并配置IP地址(真机IP地址配置到VirtualBox Host-Only Ethernet Adapter网卡) 在SW1开启Telnet...

空空如也

空空如也

1 2 3 4 5 6
收藏数 119
精华内容 47
关键字:

交换机ssh方式登录