精华内容
下载资源
问答
  • 交换机trunk配置
    千次阅读
    2019-05-15 13:49:30

    在路由器上配置DHCP服务为客户端自动分配IP地址如图
    在这里插入图片描述
    1,VLAN 1:192.168.1.0/24
    2,网关192.168.1.244
    3,首选DNS为202.106.0.20
    4,预留IP地址打印服务器:192.168.1.1
    5,预留IP地址文件服务器:192.168.1.10

    步骤一:路由器R1配置DHCP服务

    1)配置路由器接口IP
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip address 192.168.1.254 255.255.255.0
    R1(config-if)#no shutdown
    2)DHCP服务配置

    R1(config)#ip dhcp pool vlan1
    R1(dhcp-config)#network 192.168.1.0 255.255.255.0
    R1(dhcp-config)#default-router 192.168.1.254
    R1(dhcp-config)#dns-server 202.106.0.20
    R1(config)#ip dhcp excluded-address 192.168.1.1
    R1(config)#ip dhcp excluded-address 192.168.1.100
    3)设置主机A的IP配置为自动获取如图
    在这里插入图片描述

    更多相关内容
  • 交换机Trunk详解

    千次阅读 2019-10-10 13:21:26
    文章目录一、Trunk概述二、封装协议三...Trunk两端的交换机需要采用相同的干道协议 一般见于交换机之间或交换机与路由器、服务器之间 二、封装协议 ISL 801.1Q Cisco私有 共有标准 采用封装的方式 采用ta...

    一、Trunk概述

    在这里插入图片描述

    • 当一条链路,需要承载多VLAN信息的时候,需要使用trunk来实现
    • Trunk两端的交换机需要采用相同的干道协议
    • 一般见于交换机之间或交换机与路由器、服务器之间

    二、封装协议

    ISL801.1Q
    Cisco私有共有标准
    采用封装的方式采用tag的方式
    在原始帧的基础上封装上新帧头及新的FCS在原始的帧头中插入tag字段,去掉原有FCS,重新计算FCS
    1. baby giant frame 大于标准的MTU1500字节,但是小于2000字节
      对于采用ISL封装的,MTU=1548(下文有解释)
      对于Dot1Q,MTU=1522
    2. Vlan范围和映射
      ISL支持的vlan编号是1~1005(默认允许正常的)
      802.1q支持的vlan编号是1~4094(默认允许所有正常和扩展的)
      所以当穿过802.1q和ISL的干道的时候就需要映射。
      (1)单台交换机上最多允许8个802.1q到ISL vlan的映射
      (2)只能映射到Ethernet的vlan
      (3)该被映射的Ethernet vlan将被阻塞
      (4)映射仅在本地有效
    3. 链路聚集模式
      trunk 永久链路聚集模式,强制trunk,发送DTP帧
      Nonegotiate 永久链路聚集模式,必须手动将邻居配为干道口,不发送DTP帧。一般用于对端设备不支持DTP的情况。
      Desirable主动尝试将链路成为干道(默认模式),发送DTP帧,如果邻接接口为trunk、desirable、auto,那么此接口成为trunk。
      Auto接口愿意成为trunk,如果邻接接口被设置为trunk或desirable,那么接口就成为trunk
      Access永久的nontrunking模式,并且与对端接口协商,使其成为nontrunking链路
    Dynamic AutoDynamic DesirableTrunkAccess
    Dynamic AutoAccessTrunkTrunkAccess
    Dynamic DesirableTrunkTrunkTrunkAccess
    TrunkTrunkTrunkTrunk不建议
    AccessAccessAccess不建议Access

    三、ISL

    在这里插入图片描述

    • Cisco私有协议
    • 支持PVST
    • 在原始的数据帧基础上封装上ISL头及新的FCS
    • 没有修改原始的数据帧,因此处理效率比802.1Q高
    • VLAN字段,15个比特目前用了10个,那么最多支持210=1024个VLAN
    • “原始以太帧”最大是1518个字节,1500的ip MTU,加上源目的MAC地址共12,类型字段2个,CRC4个,再加上3字节的ISL封装,就是1548字节了
    • 上图中几个字段(ISL)的描述如下
      DA 40bit的组播地址用于标示这个FRAME是ISL的
      TYPE 标示这个帧是什么类型的,如以太、令牌环等
      SA 发送帧的原交换机MAC
      AAAA03 SNAP(固定值)
      VLAN 15个比特目前用了10个,那么最多支持210=1024 VLAN
      INDEX 这个帧的对端交换机来源端口

    所以ISL帧最大1548bytes(1518+26+4)

    四、Dot1Q

    1. 帧格式
      在这里插入图片描述
      802.1Q Tag包含4个字段,其含义如下:
    • Type长度为2字节,表示帧类型。取值为0x8100时表示802.1Q Tag帧。如果不支持802.1Q的设备收到这样的帧,会将其丢弃。
    • PRI Priority,长度为3比特,表示帧的优先级,取值范围为0~7,值越大优先级越高。用于当交换机阻塞时,优先发送优先级高的数据包。
    • CFI Canonical Format Indicator,长度为1比特,表示MAC地址是否是经典格式。CFI为0说明是经典格式,CFI为1表示为非经典格式。用于区分以太网帧、FDDI(Fiber Distributed Digital Interface)帧和令牌环网帧。在以太网中,CFI的值为0.
    • VID VLAN ID ,长度为12比特,表示该帧所属的VLAN。在VRP中,可配置的VLAN ID取值范围是1~4094。
    1. 优缺点
    • 缺点是破环了原始以太网帧以及重新计算FCS,ISL是直接封装头和尾。
    • Dot1Q公用,ISL私有
    • 802.1Q支持4096个VLAN 最大帧:1518+4=1522
    1. Native Vlan
    • 在802.1q的native vlan是不打标签的,使用Dot1q的交换机把所有未标记的frame转发到native vlan中,而ISL会对所有的数据帧,包括native vlan进行封装,因此如果没有封装的数据帧它会丢弃(ISL没有native vlan的概念)
    • Native vlan所属的帧在经过trunk时不打标签
    • Native vlan在Trunk两端必须匹配,否则会出现vlan流量互串
    • 默认的native vlan时vlan 1
    • 建议将一个生僻的vlan配置为native vlan

    在这里插入图片描述
    我们看上面这个图,两台交换机trunk两端native vlan不一样,会有什么问题?首先两端的vlan2通信肯定是没有问题的,但是vlan3和vlan4通信就有问题了,左边vlan3的用户发出来的数据帧从左交换机出去上trunk,是不打标签的,但是这些数据帧到了右交换机,它会认为这些数据帧是属于vlan4的,这就出现了问题。

    • 相关配置:
      Switch(config-if)# switchport trunk native vlan ?
      在trunk上设置native vlan
      Switch(config)# vlan dot1q tag native
      上述命令将对native vlan也打标签
    1. Vlan范围
    VLAN的范围作用
    0,4095保留,系统使用
    1Cisco默认vlan
    2~1001For Ethernet VLANS
    1002~1005Cisco默认为FDDI及TokenRIng定义
    1006~4094只能为Ethernet使用,在一些特殊平台被保留使用

    五、DTP

    • Trunk可以手工静态配置或者通过DTP进行协商
    • DTP使得交换机之间能够进行Trunk协商
    Trunk永久链路聚集模式,强制trunk,发送DTP帧
    Nonegotiate不发送DTP帧。一般用于对端设备不支持DTP的情况;需要搭配手工指定的trunk或access 模式命令
    Desirable主动尝试将链路成为干道(默认模式)。发送DTP帧,如果邻接接口为trunk、desirable、Auto,那么此接口成为Trunk
    Auto接口有意愿成为trunk,但是不会主动发送DTP/如果邻接接口被设置为trunk或desirable,那么接口就成为trunk,会被动响应DTP协商数据帧
    Access永久的nontrunking模式,并且与对端接口协商,使其成为nontrunking链路
    Dynamic AutoDynamic DesirableTrunkAccess
    Dynamic AutoAccessTrunkTrunkAccess
    Dynamic DesirableTrunkTrunkTrunkAccess
    TrunkTrunkTrunkTrunk不建议
    AccessAccessAccess不建议Access

    六、Trunk配置

    Switch(config-if)# switchport mode access
    将接口设置为access模式
    Switch(config-if)# switchport mode encapsulation {dot1q | ISL}
    如果接口为trunk,设置干道协议类型
    Switch(config-if)# switchport mode dynamic {auto | desirable}
    将接口设置为DTP动态协商,可选auto或desirable
    Switch(config-if)# switchport nonegotiate
    将接口设置为nonegotiate,不发送DTP帧,如果配置为非协商,那么就必须手工
    配置接口模式,为access或trunk

    在这里插入图片描述

    SW1(config)# interface fast0/23
    SW1(config-if)# switchport trunk encapsulation dot1q
    SW1(config-if)# switchport mode trunk
    SW1(config-if)# switchport native vlan 1
    SW1(config-if)# switchport nonegotiate
    SW1(config-if)# switchport trunk allowed vlan ?
      WORD   VLAN IDs of the allowed VLANs when this port is in trunking mode
      add     add VLANs to the current list
      all     all VLANs
      except   all VLANs except the following
      none     no VLANs
      remove   remove VLANs from the current list
    

    上图中,两端PC都属于vlan10的话,如果SW1的Fa0/23口将vlan10 remove掉,那么PC肯定就无法通信了。

    七、MTU问题

    MTU就是最大传输单元,不同的系统对于MTU的设定和理解使不同的。Cisoc IOS善,interface x接口模式下:

    • MTU指的使二层的MTU,这是接口MTU,值得是不包含二层帧头的、payload的MTU,这个MTU值一般是不能手工修改的,默认是1500字节。如此一来Cisco路由器支持的二层数据帧最大值就是1500的payload加上二层帧头及二层FCS:目的MAC 6字节+源MAC 6字节+类型字段2字节+FCS 4字节,所以总的就是1518字节。
    • IP MTU值得是三层的MTU,这个值可以手工修改,但是最大值必须小于接口的二层MTU值也就是1500.这个MTU指的是三层IP包的总大小,如果接口发出的包大于这个接口的IP MTU,那么这个ip包将被分片
      在这里插入图片描述
      做个测试:上图中,R1的fa0/0口 ip mtu为1500,
      我们去ping 1.1.1.2 repeat 1 size 1500,我们会发现R1直接将一个ICMP包发出去了,没有分片。
      从报文中我们可以得出,这个IP包的大小为1500字节。
      其中ip报头20字节,ICMP报头8字节,ICMP data荷载1472字节,刚好1500字节。
      因此在CISCO IOS设备上,ping后面跟着的size指的就是发出去的IP包整个的大小。而在windows PC 的cmd下,ping后跟的包大小就是ICMP data大小,ping –l 1472,产生的包就是1500字节
      还是上面的例子,如果我们在R1上,ping 1.1.1.2 repeat 1 size 1501,这个时候,R1由于产生的这个IP包大于mtu 1500,因此会被分片,然后在R2上,这两个分片被重组。

    转载:鸿鹄论坛

    展开全文
  • 1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访; 2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口10的IP地址为10.1.1.254/24,VLAN接口20的IP地址为...
  • 华为交换机Trunk配置

    千次阅读 2019-11-13 18:12:37
    华为交换机Trunk配置 Trunk 采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继...

    华为交换机Trunk配置

    Trunk
    采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继链路上进行传输前,会先打上一个标记,表明该数据包是Vlan2的,到达对方交换机时,交换机会将该标记去掉,只发送到属于Vlan2的端口上。

    例:以下拓扑图中,子网掩码都为255.255.255.0
    Vlan1:
    左:192.168.1.1 192.168.1.2
    右:192.168.1.3 192.168.1.4
    Vlan2:
    左:192.168.:2.1 192.168.2.2
    右:192.168.2.3 192.168.2.4
    Vlan3:
    左:192.168.3.1 192.168.3.2
    右:192.168.3.3 192.168.3.4
    在这里插入图片描述

    S3700-LSW1

    <Huawei>system-view
    [Huawei]interface Eth0/0/7
    [Huawei-Ethernet0/0/7]port link-type trunk
    [Huawei-Ethernet0/0/7]port trunk allow-pass vlan all
    [Huawei]display current-configuration
    #
    interface Ethernet0/0/1
     port link-type access
    #
    interface Ethernet0/0/2
     port link-type access
    #
    interface Ethernet0/0/3
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/4
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/5
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/6
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/7
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    

    S3700-LSW2

    <Huawei>system-view
    [Huawei]interface Eth0/0/3
    [Huawei-Ethernet0/0/3]port link-type trunk
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan all
    [Huawei]display current-configuration
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface Ethernet0/0/4
     port link-type access
    #
    interface Ethernet0/0/5
     port link-type access
    #
    interface Ethernet0/0/6
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/7
     port link-type access
     port default vlan 3
    

    测试
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    不同交换机同网段Vlan之间能够互相ping通,说明两个交换机接口配置的Trunk中继链路技术实现成功。

    ↓↓↓↓↓↓

    最近刚申请了个微信公众号,上面也会分享一些运维知识,大家点点发财手关注一波,感谢大家。 【原创公众号】:非著名运维 【福利】:公众号回复 “资料” 送运维自学资料大礼包哦!
    在这里插入图片描述

    如果你觉得这篇文章还不错,就请动动你的发财手为本文留个言点个在看,或者转发一下吧,因为这将是我持续输出更多优质文章的最强动力

    展开全文
  • 在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,直接用原文。... 在电信网络的语音级的线路中,Trunk指“主干网络、电话干线”,即两个交换局或交换机之间的连接电路或信道,它能
  • 还有在具体的交换机产品中怎样来交换机TRUNK配置,下面我们来了解一下这些方面的知识。在二层交换机的性能参数中。  常常提到一个重要的指标:TRUNK,许多的二层交换机产品在介绍其性能时,都会提到能够支持TRUNK...
  • 华为交换机怎么配置Trunk接口实现通信?交换机不配置置Trunk接口VLAN之间的数据是不能互通的,Trunk接口能收到所有VLAN的广播包信息,但是怎么配置Trunk接口?请看下文详细介绍
  • 大部分的公司选用的交换机同时有cisco、h3c,如果在cisco接口上启用的协议不当,cisco的交换机和h3c的交换机在作trunk后就会不通。本文通过实例,分析了该现象产生的原因和解决办法。
  • 交换机trunk接口

    千次阅读 2020-05-08 11:49:28
    以太网通常由多台交换机组成,为了使VLAN的数据帧跨越多台交换机传递,交换机之间互连的链路需要配置为干道链路(Trunk Link)。 干道链路是用在不同的设备之间(如交换机和路由器之间、交换机交换机之间)承载多个...

    在以太网中,通过划分VLAN来隔离广播域和增强网络通信的安全性。以太网通常由多台交换机组成,为了使VLAN的数据帧跨越多台交换机传递,交换机之间互连的链路需要配置为干道链路(Trunk Link)。
    干道链路是用在不同的设备之间(如交换机和路由器之间、交换机和交换机之间)承载多个不同VLAN数据的,它不属于任何一个具体的VLAN,可以承载所有的VLAN数据,也可以配置为只能传输指定VLAN的数据。
    Trunk端口一般用于交换机之间连接的端口, Trunk端口可以属于多个VLAN,可以接收和发送多个VLAN的报文。
    当Trunk端口收到数据帧时,如果该帧不包802.1Q(802.1Q是一个支持多VLAN在一个交换性环境中通信的封装协议,一个交换机上有多个VLAN,在同一VLAN之间通信就不需要802.1Q协议。例如2个交换机之间的相同VLAN要进行通信就要进行802.1Q封装。简单来说的话就是多个2层设备相连的VLAN要进行通信就要使用802.1Q来封装以用于标示不同的VLAN信息。)的VLAN标签,将打上该Trunk端口的PVID;如果该帧包含802.1Q的VLAN标签,则不改变。
    当Trunk端口发送数据帧时,当该所发送帧的VLAN ID与端口的PVID不同时,检查是否允许该VLAN通过,若允许的话直接透传,不允许就直接丢弃;当该帧的VLAN ID与端口的PVID相同时,则剥离VLAN标签后转发。
    二.本实验模拟某公司网络场景。
    公司规模较大,员工200余名,内部网络是-一个大的局域网。公司放置了多台接入交换机(如S1和S2)负责员工的网络接入。接入交换机之间通过汇聚交换机S3相连。公司通过划分VLAN来隔离广播域,由于员工较多,相同部门的员工通过不同交换机接入。为了保证在不同交换机下相同部门的员工能互相通信,需要配置交换机之间链路为干道模式,以实现相同VLAN跨交换机通信。
    三.建立如图所示拓扑

    四.过程
    (1)为两个接入层交换机,汇集成交换机分别创建两个VLAN 10 20
    在这里插入图片描述
    (2)配置每一个Access接口(配置完后可用 display port vlan查看VLAN和接口配置)
    在这里插入图片描述
    (3)建查同一VLAN不通
    在这里插入图片描述
    (4)配置trunk口
    a.为接入层交换机与汇聚成交换机连接的口配置
    在这里插入图片描述

    b.为汇聚层交换机配置(两个端口都配置)在这里插入图片描述
    c.测试连通性
    在这里插入图片描述

    展开全文
  • 在二层交换机的性能参数中,常常提到一个重要的指标:TRUNK,许多的二层交换机产品在介绍其性能时,都会提到能够支持TRUNK功能,从而可以为互 连的交换机之间提供更好的传输性能。那到底什么是TRUNK呢?使用TRUNK...
  • 交换机远程登录 以下实验基于 锐捷-交换机 RG-S3760E-24 目录 需求 思路 实现 ...然后配置相应的 trunk 端口,使用网线连接, 这样交换机的数据就会包含相应的vlan属性,共用端口通信 实现 设备: ...
  • 交换机Trunk端口配置,功能需求及组网说明,配置环境参数,数据配置步骤,配置命令代码,利用将端口配置为Trunk端口来完成在不同交换机之间透传VLAN,达到属于相同VLAN的PC机,跨交换机进行二层访问;或者不同VLAN的...
  • 交换机TRUNK配置问题

    2020-10-23 14:26:24
    TRUNK作为一个重要的指标,常常在二层交换机的性能参数中被提到,许多的二层交换机产品在介绍其性能时,都会提到能够支持TRUNK功能,从而可以为互连的交换机之间提供更好的传输性能。一下就是TRUNK的介绍
  • Cisco交换机Trunk配置命令是什么?

    千次阅读 2020-12-28 20:22:40
    展开全部TRUNK(端口636f707962616964757a686964616f31333431356633汇聚)是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于...
  • 核心交换机TRUNK配置功能非常重要,同时对TRUNK进行合理的配置,可以为互连的交换机之间提供更好的传输性能。到底什么是TRUNK呢?使用TRUNK功能到底能给我们带来哪些应用方面的优势?还有在具体的核心交换机产品中...
  • centos 7 下双网卡bond 与 trunk口的交换机通信 做这个首先要明白什么是trunktrunk 是实现不同网络设备的不同Vlan之间的通信 注意: 网卡也属于网络设备,设置vlan后也可以通信 先说下我的环境 网络工程师在两台...
  • Trunk与三层交换机技术

    千次阅读 2020-05-31 16:18:31
    文章目录一、Ttunk简介:二、Ttunk作用三、Ttunk通讯过程:四、VLAN标识:五、IEEE 802.1q帧的格式:六、三层交换介绍七、传统的MLS(多层交换)八、基于CEF(Cisco快速转发)的MLS九、三层交换机的转发过程:十、三...
  • 交换机trunk模式工作原理

    万次阅读 2017-03-02 10:20:46
    TRUNK是端口汇聚的意思,允许交换机交换机交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行连接同时传输以提供更高带宽、更大吞吐量, 大幅度提供整个网络能力。VLAN TRUNK一般是你设置了多个...
  • 交换机TRUNK配置的问题.docx
  • H3C交换机与CISCO交换机trunk设置注意事项收集.pdf
  • H3C交换机与CISCO交换机trunk设置注意事项[参照].pdf
  • Unifi Switch新发布了交换机,那么很多网友想知道Unifi Switch交换机怎么配置vlan及trunk口?下面就为大家介绍下Unifi Switch交换机配置vlan及trunk口的方法,仅供参考
  • 实验四 交换机TRUNK口和单臂路由实验 一、实验目的 1、理解交换机VLAN口的工作原理; 2、理解交换机TRUNK口的工作原理; 3、掌握单臂路由的配置方法; 二、实验的网络拓扑结构图 1.交换机VLAN配置实验 ...
  • 一: 连接 ...三:利用主机2进行配置,划分端口到VLAN10,并设置交换机和路由器的一号端口为 trunk模式 1.en 2.conf 3.vlan 10 4.name vlan10 5.exit 6.interface f0/2 7.switchport access vlan 10 8..
  • 华为交换机配置trunk接口

    万次阅读 2020-02-11 18:37:12
    trunk端口一般用于交换机之间连接的端口,trunk端口可以属于多个vlan,可以接受发发送多个vlan的报文。 本次的实验如下图: 模拟两天办公区怎么互信通信,切互不影响,PC1与PC3是同网段,PC2与PC4是相同网段 rd代表...
  • 没带交换机,接口又是trunk口,咋办?电脑发送出带vlan的数据,交换机trunk口与电脑直连通信
  • 交换机access trunk等的作用

    千次阅读 2012-07-19 15:03:09
    交换机的端口工作模式一般可以分为三种:Access,Multi,Trunktrunk模式的端口用于交换机交换机交换机与路由器,大多用于级联网络设备。Access多用于接入层也叫接入模式。主要是将端口静态接入。 详细点的: ...
  • H3C交换机配置trunk

    千次阅读 2021-12-21 00:11:49
    H3C交换机配置trunk 建vlan vlan 520 给当前端口添加vlan 520 port ethernet 1/0/1 to ethernet 1/0/10 进入vlan的地址配置 interface vlan-interface 520 为当前vlan配ip地址 ip address 224.220.3.2 255.255.255.0...
  • 思科交换机如何配置trunk

    千次阅读 2021-04-02 14:43:43
    1、理解Trunk的运行原理 2、掌握Trunk的配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 24,652
精华内容 9,860
关键字:

交换机trunk作用