精华内容
下载资源
问答
  • 交换机trunk端口配置的作用
    千次阅读
    2021-05-06 20:41:57

    交换机端口配置Trunk端口的配置

    前面提到交换机端口的Access端口的配置,直白的的说就是对于交换机与用户相连接的端口的划分配置,能够对广播风暴起到抵御作用,提高了网络的安全性。今天,继续对交换机与交换机(路由器)之间的连接,端口的划分进行学习----Trunk配置。
    以太网通常会由多台交换机组成,对数据跨越不同交换机设备的传输,交换机之间的互连链路需要配置为Trunk模式(干道链路)。与之前学习的Access(接入链路)不同,Trunk是用在交换机和路由器,或者交换机和交换机之间,承载多个不同的VLAN数据。不属于任何任何一个具体的VLAN,能够承载所有的VLAN数据。
    另外,对Trunk的收发数据时的表现形式,当Trunk端口收到数据帧,如果该帧不包含802.1Q的VLAN标签,将会打上Trunk端口的PVID;如果该帧包含802.1Q的VLAN标签,则不会发生改变。当Trunk端口发送数据帧时,所发送的数据帧的VLAN ID与端口的PVID不同时,检查是否允许该VLAN通过,若允许直接传输,不允许直接丢弃;当该帧的VLAN ID与PVID相同时,则剥离VLAN标签转发。

    操作拓扑结构

    更多相关内容
  • 交换机Trunk端口配置,功能需求及组网说明,配置环境参数,数据配置步骤,配置命令代码,利用将端口配置为Trunk端口来完成在不同交换机之间透传VLAN,达到属于相同VLAN的PC机,跨交换机进行二层访问;或者不同VLAN的...
  • 1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访; 2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口10的IP地址为10.1.1.254/24,VLAN接口20的IP地址为...
  • 第二周开始了,开始搞真机,看着那个比我还高的机柜,莫名的紧张和兴奋。。。 首先得熟络H3CSE实验手册,内含六项内容。...真机上四个交换机和两个AP需要进行console口连接笔记本电脑进行初始配置,然而下午又全好...

    第二周开始了,开始搞真机,看着那个比我还高的机柜,莫名的紧张和兴奋。。。

    首先得熟络H3CSE实验手册,内含六项内容。

    我想着还是得先从HCL模拟器上配置出来,再到真机上配置。

    配出来了,还是得认真,忘记保存了一次。。。

    进行真机的talet连接时必须用火狐浏览器,或者用其他浏览器得安装注册表。

    真机上四个交换机和两个AP需要进行console口连接笔记本电脑进行初始配置,然而下午又全好了,我记得我没干嘛呀:

     

    展开全文
  • 华为交换机Trunk配置

    千次阅读 2021-03-12 15:11:15
    华为交换机Trunk配置 Trunk 采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继...

    华为交换机Trunk配置

    Trunk
    采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继链路上进行传输前,会先打上一个标记,表明该数据包是Vlan2的,到达对方交换机时,交换机会将该标记去掉,只发送到属于Vlan2的端口上。

    例:以下拓扑图中,子网掩码都为255.255.255.0
    Vlan1:
    左:192.168.1.1 192.168.1.2
    右:192.168.1.3 192.168.1.4
    Vlan2:
    左:192.168.:2.1 192.168.2.2
    右:192.168.2.3 192.168.2.4
    Vlan3:
    左:192.168.3.1 192.168.3.2
    右:192.168.3.3 192.168.3.4
    在这里插入图片描述
    S3700-LSW1

    <Huawei>system-view
    [Huawei]interface Eth0/0/7
    [Huawei-Ethernet0/0/7]port link-type trunk
    [Huawei-Ethernet0/0/7]port trunk allow-pass vlan all
    [Huawei]display current-configuration
    #
    interface Ethernet0/0/1
     port link-type access
    #
    interface Ethernet0/0/2
     port link-type access
    #
    interface Ethernet0/0/3
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/4
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/5
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/6
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/7
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    

    S3700-LSW2

    <Huawei>system-view
    [Huawei]interface Eth0/0/3
    [Huawei-Ethernet0/0/3]port link-type trunk
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan all
    [Huawei]display current-configuration
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface Ethernet0/0/4
     port link-type access
    #
    interface Ethernet0/0/5
     port link-type access
    #
    interface Ethernet0/0/6
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/7
     port link-type access
     port default vlan 3
    

    测试
    在这里插入图片描述
    不同交换机同网段Vlan之间能够互相ping通,说明两个交换机接口配置的Trunk中继链路技术实现成功。

    https://mp.weixin.qq.com/s/d9oJ121SubyTyf7d-F3LeQ

    展开全文
  • 6. 交换机端口链路类型介绍6.1 交换机端口链路类型介绍交换机以太网端口共有三种链路类型:Access、Trunk 和 Hybrid。1.Access 类型的端口只能属于 1 个 VLAN,一般用于连接计算机的端口;2.Trunk 类型的端口可以...

    6. 交换机端口链路类型介绍

    6.1 交换机端口链路类型介绍

    交换机以太网端口共有三种链路类型:Access、Trunk 和 Hybrid。

    1.Access 类型的端口只能属于 1 个 VLAN,一般用于连接计算机的端口;

    2.Trunk 类型的端口可以属于多个 VLAN,可以接收和发送多个 VLAN 的报文, 一般用于交换机之间连接的端口;

    3.Hybrid 类型的端口可以属于多个 VLAN,可以接收和发送多个 VLAN 的报文, 可以用于交换机之间连接,也可以用于连接用户的计算机。

    其中,Hybrid 端口和 Trunk 端口的相同之处在于两种链路类型的端口都可以允许多个 VLAN 的报文发送时打标签;不同之处在于 Hybrid 端口可以允许多个VLAN 的报文发送时不打标签,而 Trunk 端口只允许缺省 VLAN 的报文发送时不打标签。

    三种类型的端口可以共存在一台以太网交换机上,但 Trunk 端口和 Hybrid 端口之间不能直接切换,只能先设为 Access 端口,再设置为其他类型端口。例如:

    Trunk 端口不能直接被设置为 Hybrid 端口,只能先设为 Access 端口,再设置为Hybrid 端口。

    6.2 各类型端口使用注意事项

    配置 Trunk 端口或 Hybrid 端口,并利用 Trunk 端口或 Hybrid 端口发送多个 VLAN

    报文时一定要注意:本端端口和对端端口的缺省 VLAN ID(端口的 PVID)要保持一致。

    当在交换机上使用 isolate-user-vlan 来进行二层端口隔离时,参与此配置的端口的链路类型会自动变成 Hybrid 类型。

    Hybrid 端口的应用比较灵活,主要为满足一些特殊应用需求。此类需求多为在无法下发访问控制规则的交换机上,利用 Hybrid 端口收发报文时的处理机制, 来完成对同一网段的 PC 机之间的二层访问控制。

    6.3 各类型端口在接收和发送报文时的处理

    1.端口接收报文时的处理:

    2.端口发送报文时的处理:

    6.4 交换机 Trunk 端口配置

    6.4.1 组网需求:

    1.SwitchA 与 SwitchB 用 trunk 互连,相同 VLAN 的 PC 之间可以互访,不同

    VLAN 的 PC 之间禁止互访;

    2.PC1 与 PC2 之间在不同 VLAN,通过设置上层三层交换机 SwitchB 的 VLAN接口 10 的 IP 地址为 10.1.1.254/24,VLAN 接口 20 的 IP 地址为 20.1.1.254/24可以实现 VLAN 间的互访。

    6.4.2 组网图:

    1.VLAN 内互访,VLAN 间禁访

    2.通过三层交换机实现 VLAN 间互访

    6.4.3 配置步骤:

    实现 VLAN 内互访 VLAN 间禁访配置过程

    SwitchA 相关配置:

    1.创建(进入)VLAN10,将 E0/1 加入到 VLAN10 [SwitchA]vlan 10

    [SwitchA-vlan10]port Ethernet 0/1

    2.创建(进入)VLAN20,将 E0/2 加入到 VLAN20 [SwitchA]vlan 20

    [SwitchA-vlan20]port Ethernet 0/2

    3.将端口 G1/1 配置为 Trunk 端口,并允许 VLAN10 和 VLAN20 通过

    [SwitchA]interface GigabitEthernet 1/1

    [SwitchA-GigabitEthernet1/1]port link-type trunk [SwitchA-GigabitEthernet1/1]port trunk permit vlan 10 20

    SwitchB 相关配置:

    1.创建(进入)VLAN10,将 E0/10 加入到 VLAN10 [SwitchB]vlan 10

    [SwitchB-vlan10]port Ethernet 0/10

    2.创建(进入)VLAN20,将 E0/20 加入到 VLAN20 [SwitchB]vlan 20

    [SwitchB-vlan20]port Ethernet 0/20

    3.将端口 G1/1 配置为 Trunk 端口,并允许 VLAN10 和 VLAN20 通过

    [SwitchB]interface GigabitEthernet 1/1

    [SwitchB-GigabitEthernet1/1]port link-type trunk [SwitchB-GigabitEthernet1/1]port trunk permit vlan 10 20

    通过三层交换机实现 VLAN 间互访的配置

    SwitchA 相关配置:

    1.创建(进入)VLAN10,将 E0/1 加入到 VLAN10 [SwitchA]vlan 10

    [SwitchA-vlan10]port Ethernet 0/1

    2.创建(进入)VLAN20,将 E0/2 加入到 VLAN20 [SwitchA]vlan 20

    [SwitchA-vlan20]port Ethernet 0/2

    3.将端口 G1/1 配置为 Trunk 端口,并允许 VLAN10 和 VLAN20 通过

    [SwitchA]interface GigabitEthernet 1/1

    [SwitchA-GigabitEthernet1/1]port link-type trunk [SwitchA-GigabitEthernet1/1]port trunk permit vlan 10 20

    SwitchB 相关配置:

    1.创建 VLAN10 [SwitchB]vlan 10

    2.设置 VLAN10 的虚接口地址

    [SwitchB]interface vlan 10

    [SwitchB-int-vlan10]ip address 10.1.1.254 255.255.255.0

    3. 创 建 VLAN20 [SwitchB]vlan 20 4.设置 VLAN20 的虚接口地址[SwitchB]interface vlan 20

    [SwitchB-int-vlan20]ip address 20.1.1.254 255.255.255.0

    5.将端口 G1/1 配置为 Trunk 端口,并允许 VLAN10 和 VLAN20 通过

    [SwitchA]interface GigabitEthernet 1/1

    [SwitchA-GigabitEthernet1/1]port link-type trunk [SwitchA-GigabitEthernet1/1]port trunk permit vlan 10 20

    展开全文
  • 有的思科交换机用户不知道怎么配置,这次我们来介绍一下思科交换机虚拟串口配置VLAN Trunk的步骤。交换机串口(Trunk)的作用:在以太网上通过交换机的串口实现中继可以使用如下两种封装类型:—IEEE 802.1Q—ISL...
  • 在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,直接用原文。... 在电信网络的语音级的线路中,Trunk指“主干网络、电话干线”,即两个交换局或交换机之间的连接电路或信道,它能
  • 还有在具体的交换机产品中怎样来交换机TRUNK配置,下面我们来了解一下这些方面的知识。在二层交换机的性能参数中。  常常提到一个重要的指标:TRUNK,许多的二层交换机产品在介绍其性能时,都会提到能够支持TRUNK...
  • 华为交换机配置trunk接口

    万次阅读 2020-02-11 18:37:12
    trunk端口一般用于交换机之间连接的端口,trunk端口可以属于多个vlan,可以接受发发送多个vlan的报文。 本次的实验如下图: 模拟两天办公区怎么互信通信,切互不影响,PC1与PC3是同网段,PC2与PC4是相同网段 rd代表...
  • 配置思路:1.创建vlansw1#vlan database 进入vlan数据库sw1(vlan)#vlan 2 name jishu 创建名为:技术的vlanVLAN 40 modified:Name: jishusw1(vlan)#vlan 3 name caiwu 创建名为:财务的vlanVLAN 41 modified:Name: ...
  • 思科交换机如何配置trunk

    千次阅读 2021-04-02 14:43:43
    2、掌握Trunk配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应的接口划入VLAN10和VLAN20; 4...
  • 思科交换机配置trunk模式及vtp

    千次阅读 2022-03-21 09:12:25
    如果交换机交换机之间存在多条链路,交换机每增加一个vlan,交换机交换机就会增加一条链路。这样会存在链路浪费,就产生了 DTP ( dynamic trunk protocols)采用trunk后,所有的vlan都走一条线。 二、 TRUNK ...
  • 思科交换机如何配置Trunk

    千次阅读 2021-02-25 14:30:58
    2、掌握Trunk配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应的接口划入VLAN10和VLAN20...
  • 华为交换机VLAN配置TRUNK

    千次阅读 2022-01-17 16:29:55
    Lsw1配置(Lsw2同样): <Huawei>u t m Info: Current terminal monitor is off. <Huawei>SYS Enter system view, return user view with Ctrl+Z. [Huawei]sysname lsw1 //更改交换机名称lsw1 [lsw1...
  • Cisco交换机Trunk配置命令是什么?

    千次阅读 2020-12-28 20:22:40
    展开全部TRUNK(端口636f707962616964757a686964616f31333431356633汇聚)是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于...
  • 交换机之间trunk端口的设置问题

    千次阅读 2020-12-28 20:22:39
    如图:(R1)------(SW1)------(PC1)//PC1属于vlan2,属于192.168.2.0网段||(SW2)------(PC2) //PC2属于vlan3,属于192.168.3.0网段sw1和sw2都用自身的fa0/3连接,把他们配置trunk模式,在设置sw1和sw2之间连接端口...
  • 2.配置1号交换机的E4端口为trunk端口,pvid为10,允许vlan102030通过。 3.测试6台PC能否通信?(同一台交换机下可以,WHY?) 4.根据图示分别配置两台交换机的E1-3号端口。 5.将2号交换机E4端口配置成hybrid端口。 6...
  • Cisco交换机配置VLAN与TRUNK

    千次阅读 2020-12-28 20:22:37
    0x00前言:今日在学校里学习了如何搭建vlan和配置等等还有trunk。由于快下课了。尽快写。0x01准备:Cisco模拟器0x02正文:要求:VLAN 10 左边的IP:192.168.1.11 192.168.2.11 192.168.3.11 右边的IP:192.168.1.12 ...
  • 万事开头难It is the first step that costs. / The first step is the hardest. 好的开始是成功的一半 A good beginning is half the battle.... SecurtCRT的talent地址为...在真机上清空配置: >rese...
  • ESXI 虚拟交换机配置 Trunk 端口

    万次阅读 2019-06-27 19:16:42
    背景介绍 ESXI 标准 vSwitch 支持自定义 VLAN ID,以实现...VLAN ID 4095 允许通过携带任何 VLAN tag 的数据包(trunk) VLAN ID 1~4094 仅允许携带指定 VLAN ID tag 的数据包 默认地,在未做更改的情况下,虚...
  • 交换机trunk接口

    千次阅读 2020-05-08 11:49:28
    以太网通常由多台交换机组成,为了使VLAN的数据帧跨越多台交换机传递,交换机之间互连的链路需要配置为干道链路(Trunk Link)。 干道链路是用在不同的设备之间(如交换机和路由器之间、交换机交换机之间)承载多个...
  • 【CCNA】cisco交换机配置trunk

    万次阅读 2018-08-14 11:57:22
    a、不同vlan之间的通信需要依赖三层设备,图中的单臂路由就是实现不同vlan间通信用的,通过单臂路由配置不同的子接口ip,该子接口ip设置成相关需要通信vlan的网关地址即可。 b、经过trunk口的数据包会封装新的包头...
  • Trunk端口配置

    万次阅读 2019-03-27 09:37:51
    以太网通常由多台交换机组成,需要在交换机之间互连的链路上配置为干道链路(Trunk Link)。和接入的链路不同,干道链路是用来在不同的设备之间(例如:交换机交换机之间、交换机与路由器之间)承载多个不同VLAN...
  • H3C交换机配置trunk

    千次阅读 2021-12-21 00:11:49
    H3C交换机配置trunk 建vlan vlan 520 给当前端口添加vlan 520 port ethernet 1/0/1 to ethernet 1/0/10 进入vlan的地址配置 interface vlan-interface 520 为当前vlan配ip地址 ip address 224.220.3.2 255.255.255.0...
  • 交换机端口模式配置

    2022-03-31 20:45:31
    实验题目: 交换机端口模式配置 实验拓扑: 实验过程: 首先开启各个设备,然后给每台PC机配IP地址和子网掩码。 PC1:IP地址为192.168.10.1 /24 PC2:IP地址为192.168.10.2 /24 PC3:IP地址为192.168....
  • 交换机端口配置

    千次阅读 2020-05-09 18:53:44
    在以太网中,通过划分VLAN来隔离广播域和增强网络通信的安全性。以太网通常由多台交换机组成,为了使VLAN的数据帧跨越...Trunk端口一般用于交换机之间连接的端口, Trunk端口可以属于多个VLAN,可以接收和发送多个VLAN的
  • 交换机trunk、access 配置

    千次阅读 2020-07-27 23:38:24
    路由器的作用: 1.路由寻址 2.实现不同网络之间相连的功能 3.通过路由决定数据的转发,转发策略称为 路由选择。 VLAN相关技术 什么是VLAN? VLAN(虚拟局域网)是Virtual Local Area Network的简称,它是交换所特有...
  • 华为交换机基本配置命令

    万次阅读 2020-12-22 19:41:28
    华为交换机基本配置命令交换机是按照通信两端传输信息的需要,用人工或设备自动完成的方法,把要传输的信息送到符合要求的相应路由上的技术的统称。那么华为交换机配置命令有哪些呢?下面跟yjbys小编一起来看看吧!...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 18,196
精华内容 7,278
热门标签
关键字:

交换机trunk端口配置的作用