精华内容
下载资源
问答
  • 交换机 VLAN 端口类型

    千次阅读 2017-12-04 21:21:52
    交换机VLAN端口可以分为Access、Trunk和Hybrid 3中类型。Access端口是交换机上用来直接连接...Access端口发往用户终端的帧一定不带VLAN标签。Trunk端口是交换机上用来连接其他交换机的端口,他可以允许属于多个VLAN

    交换机的VLAN端口可以分为Access、Trunk和Hybrid 3中类型。Access端口是交换机上用来直接连接用户终端的端口,它只允许属于该端口的缺省VLAN的帧通过;Access端口发往用户终端的帧一定不带VLAN标签。Trunk端口是交换机上用来连接其他交换机的端口,他可以允许属于多个VLAN的帧通过。Hybrid端口是交换机上既可以连接用户终端,又可以连接其他交换机的端口。Hybrid端口也可以允许属于多个VLAN的帧通过,并且可以在出端口的方向上将某些VLAN帧的标签剥掉。

    对于没有配置PVID的 untagged hybrid 端口,即使配置了port hybrid untagged vlan 10 30 其所配置允许通过的vlan为(10 30) 。vlan 1 即使不在允许的列表中也默认允许通过(端口默认pvid 为vlan 1),可以与同一交换机上默认属于VLAN 1的主机通信,故untagged hybrid 端口必须配置PVID(接终端设备配置untag hybrid ,必须配置PVID ,否则 配置的untagged vlan 10 30 会不起作用,按照默认的vlan 1 继续转发)。

    交换机每个VLAN下都有所属终端的Mac。

    在一个广播域内,任何两台终端计算机之间都可以进行二层(数据链路层)通信。所谓二层通信,是指通信双方是以直接交换帧的方式来传递信息的,也即是,目的计算机所接收到的帧与源计算机发出的帧都是一模一样的,帧的目的MAC地址、源MAC地址、类型值、载荷数据、CRC等内容都没有发生任何改变。二层通信一定不会经过路由器(或具有三层功能的交换机)进行三层转发。

    源计算机在向目的计算机传递信息时,如果源计算机发出的帧经过了路由器(或三层交换机)的转发,那么目的计算机接收的帧一定不再是源计算机发出的那个帧。至少目的MAC和源MAC地址一定不同。
    示例:
    本实用模拟了一个简单的公司网络场景,SW1和SW2尾楼层交换机,PC1和PC3属于公司的部门A,PC2和PC4属于公司的部门B,PC5属于部门A和B的上级部门C。在网络规划中,部门A属于VLAN 10 ,部门B属于VLAN 20 ,部门C属于VLAN30。公司希望通过VLAN划分和配置,使各个部门内部之间可以互相通信,部门A和部门B均能够与部门C进行通信,但是部门A与部门B间不能相互通信。
    拓扑如下:
    拓扑如下:
    这里写图片描述
    hybrid端口类型可以允许不同VLAN的终端通信。

    188 5699 2079
    LSW1:
    interface GigabitEthernet0/0/1
    port hybrid pvid vlan 10
    port hybrid untagged vlan 10 30

    interface GigabitEthernet0/0/2
    port hybrid pvid vlan 20
    port hybrid untagged vlan 20 30

    interface GigabitEthernet0/0/24
    port link-type trunk
    port trunk allow-pass vlan 10 20 30

    LSW2:
    interface GigabitEthernet0/0/1
    port hybrid pvid vlan 10
    port hybrid untagged vlan 10 30

    interface GigabitEthernet0/0/2
    port hybrid pvid vlan 20
    port hybrid untagged vlan 20 30

    interface GigabitEthernet0/0/3
    port hybrid pvid vlan 30
    port hybrid untagged vlan 10 20 30

    interface GigabitEthernet0/0/24
    port link-type trunk
    port trunk allow-pass vlan 10 20 30

    展开全文
  • 华三交换机VLAN

    2017-02-18 18:33:04
    VLAN ×××技术的原理和配置VLAN ×××技术介绍VLAN ×××可以提供廉价、简洁的二层...VLAN ×××是基于802.Q封装的隧道协议,其核心思想是:用私网VLAN标签和公网的VLAN标签对数据帧做两次封装,帧着两层标...

    VLAN ×××技术的原理和配置

    VLAN ×××技术介绍

    VLAN ×××可以提供廉价、简洁的二层×××解决方案,不需要信令协议的支持,可以通过纯静态配置实现,而且只需要网络边缘设备支持VLAN ×××功能,内部只需要支持802.1Q的设备即可。

    VLAN ×××是基于802.Q封装的隧道协议,其核心思想是:用私网VLAN的标签和公网的VLAN标签对数据帧做两次封装,帧带着两层标签穿越运营商的骨干网络,从而为用户提供种较为简单的二层×××隧道。因为其利用携带双层标签方式来实现类似于××× 的封装格式和转发方式,所以VLAN ×××也被称为Qinq( 802.1Q in 802.1Q嵌套802.1Q)。

    用QinQ协议实现小型局域网的优点。

    1. 可以解决公网VLAN ID 的资源紧缺问题。

    2. 用户可以比较自由的规划自己的私网VLAN ID,不会导致与公网VLAN ID的冲突。

    3. 提供一种较为简单的二层×××解决方案。

    4. 使用户网络具有较高的独立性,在服务提供商升级网络时,用户网络不必更改原有配置。

    5. 可以按不同层次的VLAN ID来区分不同业务。

    6. QinQ技术可以实现多层嵌套,仅受以太帧长度的限制,具有很好的扩充性。

    QinQ时基于端口实现的,当端口开启了QinQ功能后,不论从该端口收到的数据帧是否带有VLAN标签,设备都会为该数据打上本端口默认VLAN标签。

    1. 如果收到的是带有VLAN标签的数据帧,该数据帧就成为带双标签的数据帧。

    2. 如果收到的是不带VLAN标签的数据帧,该数据帧就成为仅带有本端口默认VLAN标签的数据帧。

    VLAN ×××实现过程简述:用户设备将带有VLAN标签的数据帧发送到,运营商边缘设备,运营商收到用户的VLAN数据帧后,为此数据增加外层标签,而用户私网标签将被当作帧的数据部分进行传输,直至数据帧抵达另一边缘设备,会将外层的VLAN标签剥离将还原为用户的VLAN标签。

    VLAN ×××技术配置

    实验目的验证以上原理

    实验使用模拟器版本:HCL 7.1.59

    实验使用的设备:四台交换机、两台主机(因为该版本没有多个主机,所以使用路由器代替主机,效果是一样的,不过有兴趣的,可以尝试HCL 2.0.1版本增加了很多新功能,不够不够稳定)

    实验主机地址范围:192.168.1.0 \24

    实验拓扑图

    主机地址配置

    Pc1

    Pc2并测试其连通性,没配置交换机的时候,只要交换机开机,主机就能互相通信。

    Sw1的配置(注意:这里的VLAN1是交换机默认的

    配置完sw1就可以到主机上ping一下看是否能够连通。

    Sw2的配置

    Sw3的配置(与sw2的配置一致就不在叙述)

    Sw4的配置(与sw1的配置一致就不在叙述)

    在主机上验证效果

    (由于模拟器版本原因,没法验证,配置完成之后还是不能连通,如有高手看见望赐教,在此谢过)

     


    转载于:https://blog.51cto.com/12192021/1899083

    展开全文
  • 华三交换机VLAN

    2017-02-18 18:31:52
    VLAN ×××技术的原理和配置VLAN ×××技术介绍VLAN ×××可以提供廉价、简洁的二层...VLAN ×××是基于802.Q封装的隧道协议,其核心思想是:用私网VLAN标签和公网的VLAN标签对数据帧做两次封装,帧着两层标...

    VLAN ×××技术的原理和配置

    VLAN ×××技术介绍

    VLAN ×××可以提供廉价、简洁的二层×××解决方案,不需要信令协议的支持,可以通过纯静态配置实现,而且只需要网络边缘设备支持VLAN ×××功能,内部只需要支持802.1Q的设备即可。

    VLAN ×××是基于802.Q封装的隧道协议,其核心思想是:用私网VLAN的标签和公网的VLAN标签对数据帧做两次封装,帧带着两层标签穿越运营商的骨干网络,从而为用户提供种较为简单的二层×××隧道。因为其利用携带双层标签方式来实现类似于××× 的封装格式和转发方式,所以VLAN ×××也被称为Qinq( 802.1Q in 802.1Q嵌套802.1Q)。

    用QinQ协议实现小型局域网的优点。

    1. 可以解决公网VLAN ID 的资源紧缺问题。

    2. 用户可以比较自由的规划自己的私网VLAN ID,不会导致与公网VLAN ID的冲突。

    3. 提供一种较为简单的二层×××解决方案。

    4. 使用户网络具有较高的独立性,在服务提供商升级网络时,用户网络不必更改原有配置。

    5. 可以按不同层次的VLAN ID来区分不同业务。

    6. QinQ技术可以实现多层嵌套,仅受以太帧长度的限制,具有很好的扩充性。

    QinQ时基于端口实现的,当端口开启了QinQ功能后,不论从该端口收到的数据帧是否带有VLAN标签,设备都会为该数据打上本端口默认VLAN标签。

    1. 如果收到的是带有VLAN标签的数据帧,该数据帧就成为带双标签的数据帧。

    2. 如果收到的是不带VLAN标签的数据帧,该数据帧就成为仅带有本端口默认VLAN标签的数据帧。

    VLAN ×××实现过程简述:用户设备将带有VLAN标签的数据帧发送到,运营商边缘设备,运营商收到用户的VLAN数据帧后,为此数据增加外层标签,而用户私网标签将被当作帧的数据部分进行传输,直至数据帧抵达另一边缘设备,会将外层的VLAN标签剥离将还原为用户的VLAN标签。

    VLAN ×××技术配置

    实验目的验证以上原理

    实验使用模拟器版本:HCL 7.1.59

    实验使用的设备:四台交换机、两台主机(因为该版本没有多个主机,所以使用路由器代替主机,效果是一样的,不过有兴趣的,可以尝试HCL 2.0.1版本增加了很多新功能,不够不够稳定)

    实验主机地址范围:192.168.1.0 \24

    实验拓扑图

    主机地址配置

    Pc1

    Pc2并测试其连通性,没配置交换机的时候,只要交换机开机,主机就能互相通信。

    Sw1的配置(注意:这里的VLAN1是交换机默认的

    配置完sw1就可以到主机上ping一下看是否能够连通。

    Sw2的配置

    Sw3的配置(与sw2的配置一致就不在叙述)

    Sw4的配置(与sw1的配置一致就不在叙述)

    在主机上验证效果

    (由于模拟器版本原因,没法验证,配置完成之后还是不能连通,如有高手看见望赐教,在此谢过)

     


    转载于:https://blog.51cto.com/12192021/1899082

    展开全文
  • 实现两个交换机之间多个VLAN带标签通过,并且同一VLAN可以连通拓扑图:●概述:Question:什么是VLAN?Answer:中文名为"虚拟局域网",是英文Virtual Local Area Network的缩写。-----------是物理设备上连接的受...

    实验名称:掌握VLAN原理与配置

    实验目的:

    1.实现两个交换机之间多个VLAN带标签通过,并且同一VLAN可以连通

    第一.jpg

    拓扑图:

    ●概述:

    Question:什么是VLAN?

    Answer:中文名为"虚拟局域网",是英文Virtual Local Area Network的缩写。

    -----------是物理设备上连接的不受物理位置限制的用户的一个逻辑组,设备可以从逻辑上划分(注意,不是从物理上划分)成一个个网段(或者说是更小的局域网LAN),从而实现虚拟工作组(单元)的数据交换技术。

    Question:VLAN的作用?

    Answer:①可以隔离广播域 ;②增强安全性;③提升网络效率;④降低网络延迟;

    Question:实现VLAN划分的方法?

    Answer:基于端口的静态VLAN划分。


    配置思路:

    1.PC1机的配置,将PC机下的IP地址及子网掩码对应输入。如下图PC机1

    000009.jpg

    2.交换机的配置

    涉及技术:access,trunk

    涉及命令:

    access

    [Huawei]vlan 2       //创建VLAN 2

    [Huawei]interface e0/0/2  //进入接口视图

    [Huawei-Ethernet0/0/2]port link-type access      //更改接口链路类型为ACCESS

    [Huawei-Ethernet0/0/2]port default vlan 2         //将端口加入VLAN 2

    [Huawei]interface e0/0/3

    [Huawei-Ethernet0/0/3]port link-type access

    trunk:

    [Huawei]interface e0/0/1     //进入接口视图

    [Huawei-Ethernet0/0/1]port link-type trunk       //更改接口链路类型为trunk

    [Huawei-Ethernet0/0/1]port trunk allow-pass vlan all  //配置允许通过的VLAN

    右边LSW10交换机配置省略,同LSW9一样,只需更改端口号;

    补充一些本次操作没能用到的命令;如下

    [Huawei]undo vlan 25  //删除VLAN

    [Huawei]vlan batch 10 to20  //批量创建连续VLAN 

    [Huawei]vlan batch 10 20 30//批量创建不连续Vlan

    [Huawei]undo vlan batch 2 to 8  //批量删除连续VLAN 

    [Huawei]undo vlan batch 22 66 88//批量删除不连续Vlan

    [Huawei]port-group 1                 //创建组

    [Huawei-port-group-1]group-member Ethernet 0/0/1 Ethernet 0/0/2

                                    //将多个端口一起加入组成为组成员

    [Huawei-port-group-1]port link-type access //更改链路类型为access

    [Huawei-Ethernet0/0/1]port link-type access           

    [Huawei-Ethernet0/0/2]port link-type access          

    [Huawei-port-group-1]port default vlan 2  //将端口加入VLAN 2

    [Huawei-Ethernet0/0/1]port default vlan 2

    [Huawei-Ethernet0/0/2]port default vlan 2

    [Huawei]display port-group all //查看组的信息

    以下命令为交换机配置及查看

    交换机1的配置

    000001.jpg

    交换机2的配置

    000002.jpg

    查看交换机1 VLAN信息  命令:display vlan

    000003.jpg

    查看交换机2 VLAN信息

    000004.jpg

    查看交换机1端口的VLAN信息

    000005.jpg

    查看交换机2端口的VLAN信息

    000006.jpg

    验证、测试:

    PC1 VLAN 10  与 PC3 VLAN 10 互通

    000007.jpg

    PC2 VLAN 20  与PC4 VLAN20 互通

    000008.jpg


    转载于:https://blog.51cto.com/13935002/2167524

    展开全文
  • 思路:PC机识别VLAN标签,所以PC5想要接收VLAN4所发的数据,就应该在LSW8中的GE 0/0/1的接口设置取掉VLAN4和VLAN2的标签, 同理,PC6也要取掉VLAN4和VLAN3的标签。而服务器则要取掉所有VLAN标签。1)先...
  • 方案二:用户端口采用Access类型,而交换机连接的端口采用带标签的Hybrid类型。 SwitchA配置 interface GigabitEthernet0/0/1 port hybrid tagged vlan 2 to 3 SwitchB与SwitchA 配置一样 方案三:用户端采用...
  • 一、仪表端口A收到1000个数据包,不带vlan标签 仪表端口B收到2000个数据包, 其中1000个为vlan 10,其中1000个不带vlan 二、如果将port 3,port 4 改为以hybrid tagged 加入vlan 10 则仪表端口A不会...
  • 每一个交换机端口是独立带宽配置VLAN一个VLAN=一个广播域=一个逻辑子网H3C交换机的二层接口类型:1.Access接入接口(才能够被划分VLAN)2.Trunk中继接口(Trunk链路可以承载多个Vlan的信息)(仅仅允许默认Vlan的...
  • 交换机的测试过程中发现一个问题,组播报文可以通过交换芯片发送到cpu,但是cpu的socket却接收此组播报文,由于想要接收的组播报文来自不同的vlan有不同的vlan标签,所以一直排查到问题。 1. 下面就是这...
  • 转载标注: IEEE802.1Q 我粗略理解为对交换机入口规则和出口规则设置,入口打上VID,设置从哪些口可以出去,并且是否带标签。 一 VLAN的概念 VLAN(Virtual Local Area Network)即虚拟局域网,是一种通过将局域网...
  • vlan标签详解 access、trunk和hybrid的区别 我们知道,不同网段间需要通过路由转发才能通信;...数据进入时,默认是要带标签进入的 若数据没标签,我们可以选择给数据打上标签后放通和打标签放通 若有标签,
  • vlan实验

    2021-04-14 21:45:06
    VLAN实验 1.vlan划分 如图划分 2.pc1.3为access vlan为2 pc2。4.5.6.为混杂模式 ...交换机1与路由器为混杂,且vlan3.4.5.6不带标签进入路由 4.vlan2使用子接口管理IP获取 3.4.5.6使用物理接口管理 ...
  • Vlan练习

    2020-05-17 16:51:20
    实验题目: ...4.PC1、3和PC2、4、5、6分别在同一网段,在SW1进路由器的接口配置为hybird模式,vlan 3-5不带标签vlan2带标签,出路由器接口则带vlan1的标签并剥离可通过交换机(相当于vlan3-5为v
  • VLAN

    2021-04-12 22:29:04
    PC1发送数据到达SW1的 e1口,因为是不带tag的数据帧,所以accss口会打上pvid 1的标签转发(access口不接受带tag的帧,不带tag的帧转发时会打上端口缺省的pvid),数据帧转发到交换机所有允许vlan1 通过的端口,到达...
  • 交换机的端口类型

    2021-05-18 22:40:01
    Access、Trunk、Hybrid三种定义: Access:常用于服务器-...允许一个不带标签的数据通过,这个数据包要属于trunk 口的native vlan Hybrid: 常用于服务器-交换机。 或者常用于交换机-交换机 Access,Trunk,Hybid...
  • 你遨游VLAN中的知识

    2018-05-09 23:02:20
    VLAN:虚拟的局域网 0-4095 个VLAN 头尾能用1 交换机分割冲突域,能分割广播域2 提高网络效率3 Vlan分割广播域 VLAN 的作用1 广播控制2 安全性3 带宽利用4 延迟 VLAN 的种类1 静态:使用端口划分静态VLAN 2 动态...
  • 交换机基础 4.11

    2018-04-11 20:41:36
    access :默认模式,只允许这个接口输入一个vlan,用在接入层trunk: 用在交换机级联,设置成这个接口以后就属于汇聚链路,做策略的话,所有的vlan都允许通过,识别有tag标签hybrid: 混合模式,可以属于一个vlan,...
  • vlan介绍

    2018-09-19 12:01:41
    首先我们介绍vlan的5种划分方式按优先级由低到高分别是1、基于端口划分vlan:手动的为交换机端口划分vlan,端口所属vlan,就是连接到端口的主机 的...然后端口接收不带vlan标签 的帧时,根据mac地址与vlan id的映射...
  • vlan 简单实验

    2021-04-13 17:52:29
    其他 vlan 使用 hybrid 进行配置,把允许进入的 pc 对应的 vlan 配置为不带 标签,把不允许访问的 pc 对应的 vlan 配置为进入时带标签vlan 三、所有交换机之间配置为 trunk 通道,但是在一号交换机与路由器之间配...
  • VLAN通信原理

    2018-02-24 17:42:19
    vlan 的通信原理PVID(Port Default VLAN ID):接口的默认vlan① 报文在交换机内部处理的...注意:由于PC不识别vlan 的tag 标签,因此pc发出的报文默认不带标签,且发向PC的报文也必须去掉tag 标签。 转载于:https...
  • trunk端口:端口收发数据帧不会做任何处理,但是发送缺省vlan帧时,trunk端口会剥离标签,收到不带标签的数据帧会打上缺省vlan标签,只允许缺省vlan不带标签通过。可以允许多个vlan帧通过。 hybrid端口:端口是...
  • vlan综合实验

    2021-01-16 19:15:17
    pc2归为vlan 3,pc4/5/6归为vlan4/5/6,在路由器上开启一个子接口,单独管理vlan2,为vlan 2分配ip地址,物理接口为其他接口分配ip地址,在根据电脑能识别带标签vlan的特性,在3号交换机的0/0/3号接口,使 vlan4/...
  • VLAN接口类型

    2021-04-13 21:26:37
    如果该端口收到对端设备发送的帧是untagged(不带VLAN标签),交换机将强制加上该端口的PVID。如果该端口收到对端设备发送的帧是tagged(带VLAN标签),交换机会检查该标签内的VLAN ID。当VLAN I.
  • 交换机端口tagged与untagged

    万次阅读 2016-11-25 14:46:58
    trunk hybrid access虽然大家经常念叨,但是对于其细微理解可能存在疑惑,这里重要记录了自己的疑惑以帮助和我一样的小白 经过实验自己理解如下: 1、在交换机内部的vlan数据必定是有vlan标签... 不带标签的打上默认
  • HCNA-VLAN

    2020-08-13 17:22:45
    VLAN(虚拟局域网 Virtual Local Area Network) 背景:交换网络扩大,广播域扩大,安全性变差,冲突变多 VLAN概述:在逻辑上把...原理:通过给数据帧插入VLAN标签使交换机区分所属VLAN VLAN帧格式: 携带Tag的 T
  • vlan的划分

    2019-11-28 20:36:27
    一、交换机三种端口类型:...trunk类型:需要指定缺省vlan,当通过的帧为缺省vlan时把帧的标签去掉,当不是缺省vlan时,标签tag的帧直接传输。(用于交换机之间) hybrid类型:通过untagged去掉帧的标...
  • native Vlan

    千次阅读 2018-08-19 13:53:17
    交换机vlan端口模式中:access,trunk !!!PC识别tag的帧,故所有发往主机的帧的标签都会被剥离; access模式 二层帧到达access链路发送端时会检测其tag,若符合则丢弃,符合则发送,发送时将帧上的...
  • 华为交换机接口模式

    2020-07-17 22:05:10
    ·2 将pc2/4/5/6划入一个网段,华为中,进入路由器的流量不带标签默认划入vlan1,r1的物理接口默认vlan1 ·3 pc2可以访问pc4/5/6,pc4可以访pc5,不能访问pc6 -----pc2为vlan3,pvid3;pc4/5为vlan4,pvid4;pc5为...
  • VLAN笔记

    2020-02-22 16:16:20
    vlan原理和配置】 链路类型: Access 接入链路(连终端设备) ...1.收到一个不带Tag的数据帧,根据接口的PVID打上标签转发 2.收到一个tag的数据帧,查看所携带的tag是否匹配接口的PVID,如果匹配带...

空空如也

空空如也

1 2 3 4
收藏数 74
精华内容 29
关键字:

交换机vlan不带标签