精华内容
下载资源
问答
  • 最近有不少同学在后台留言,咨询华为三层交换机配置问题,今天小编也整理了下华为交换机的文章,大家来一起学习交流下~1、给交换机划分VLANVlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解...

    最近有不少同学在后台留言,咨询华为三层交换机的配置问题,今天小编也整理了下华为交换机的文章,大家来一起学习交流下~

    1、给交换机划分VLAN

    Vlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的vlan,比如vlan 2就是编号为2的vlan,只是一个编号而已,并不是说vlan 2的网段一定要是2网段,vlan2的IP地址是可以随便设置的。

    下面我将三层交换机的第20个端口添加到vlan 10里,步骤如下:

    A.在交换机里添加VLAN 10
     system-view     (一般用缩写:sys)
    [Quidway] vlan 10           (添加编号为10的vlan)
    [Quidway-vlan10] quit       (一般缩写:q)

    B.设置vlan 10的IP地址为192.168.66.66 网关为255.255.255.0

    [Quidway]interface vlanif 10 (interface一般可以缩写为:int  ;vlanif也可以只写vlan)

    [Quidway-vlanif10] ip address 192.168.66.66  255.255.255.0 (address缩写add)

    [Quidway-vlanif10]quit

    C.设定交换机上第20个端口模式为access (默认为trunk,需在将端口划入VLAN前转为ACCESS)
    [Quidway] int gigabitethernet 0/0/20     (gigabitethernet:千兆以太网口)
    [Quidway-GigabitEthernet0/0/20] port link-type access   (port:端口)
    [Quidway-GigabitEthernet0/0/20]quit

    D.将第20个端口加入到vlan 10里

    [Quidway] vlan 10
    [Quidway-vlan10] port gigabitethernet 0/0/20 (如果是多个连续端口,用XX to XX)
    [Quidway-Vlan10]quit

    这样就是成功的将交换机上的第20个端口添加到了编号为10的Vlan 里,划分VLAN就是这4个步骤,2个步骤设置vlan,2个步骤设置端口。现在可以用网线把交换机的第20个端口和电脑网卡连接起来,设置网卡地址为192.168.66.XX,网关为192.168.66.66,在CMD里ping192.168.66.66可以ping通。

    2、删除VLAN

    A.

    在系统视图下,用“undo int vlan 2”命令删除vlan 2的3层口,这样vlan 2就没有了,但是划分给vlan 2的那些端口依然还处于vlan 2里,这时可以将那些端口释放出来,让他们不再属于任何vlan

    B.

    在系统视图下,用“undo vlan 2”命令删除2层口,这个命令可以释放那些原先划分给了vlan 2的端口,现在它们不属于任何vlan了。

    当然,将交换机上的某个端口更换到某个vlan里,是可以直接在vlan视图里添加端口的。

    注意:交换机上的某个端口被设置成了access模式,且加入了一个vlan,要想将这个端口的模式更改为trunk,直接在端口视图里打上“port link-type trunk”是不行的,会出现Error: Please renew the defaultconfigurations.这时需要先从VLAN里删除这个端口,也就是前面说的让这个端口不属于任何vlan,才能将这个端口设置为trunk。

    3、通过端口进行限速

    现在要对交换机上的第2个端口进行限速操作,让通过这个端口的下载速度不超过128KB/S

    配置命令说明:

    Inbound:对入端口报文进行限速

    Outbound:对出端口报文进行限速

     sys
    [Quidway] intgigabitethernet 0/0/2

    [Quidway-GigabitEthernet0/0/2] qos lr outbound cir 1024 cbs204800  (1024代表1M的带宽,理论下载速度就是128KB/S,204800=1024*200,cbs代表突发信息速率 cir代表承诺信息速率 )

    这个命令执行后,端口2的下载速度就被限制在128KB/S以内,实际测速表明,这个限速数值是该端口数据流量稳定后的速度,它的短暂峰值高出128KB/S很多,这个应该是交换机从侦测端口流量到启动限速需要一个过程,下载速度稳定后是在128KB/S上下徘徊,效果还是不错的,比路由器限速和限速软件的效果都要好很多,最关键的交换机稳定。

    注:取消限速方法

    [Quidway-GigabitEthernet0/0/2] undo qos lr outbound

    4、配置基于地址池的DHCP服务器

    A.全局启动DHCP服务。

    sys

    [Quidway] dhcp enable

    B.配置IP地址池10的属性(地址池范围,dns地址,出口网关,地址池租期)

    [Quidway] ip pool 10

    Info:It's successful to create an IP address pool.

    [Quidway-ip-pool-10] network 192.168.10.0 mask 255.255.255.0

    [Quidway-ip-pool-10] dns-list 202.103.24.68

    [Quidway-ip-pool-10] gateway-list 192.168.10.1

    [Quidway-ip-pool-10] lease day 10

    [Quidway-ip-pool-10] q

    C.将接口GE0/0/1加入到VLAN 10

    [Quidway] vlan 10
    [Quidway-vlan10] port gigabitethernet 0/0/1 (如果是多个连续端口,用XX to XX)
    [Quidway-Vlan10]quit

    D. 配置VLANIF10接口下的客户端从全局地址池中获取IP地址

    [Quidway]int vlan 10

    [Quidway-vlanif10] ip add 192.168.10.1 24

    [Quidway-vlanif10] dhcp select global

    [Quidway-vlanif10] q

    这时,可以用“dis ip pool”命令查看IP地址池配置情况

    最后可以在电脑上验证是否成功

    4dea0b29efd120dc678f444db11a2eae.png

    5、telnet远程登录设置

    system-view

    [Quidway]aaa                          (进入aaa视图)
    [Quidway-aaa] local-user tcwq passwordcipher tcwq 
    (cipher是暗号的意思,password cipher就是指密码显示出来的是乱码,在用dis cur命令时,看到的密码是乱码)

    [Quidway-aaa] local-user tcwq passwordsimple tcwq (simple是简单的意思,passwor simple:弱口令,可以理解为明文,和cipher是相对的,在用dis cur命令时,看到的密码是明文)

    [Quidway-aaa] local-user tcwq  service-type  telnet (设置用户tcwq的登录方式为telnet)

    [Quidway-aaa] local-user tcwqprivilege level 3 (privilege level:权限级别,3为最高级别,拥有最高权限)

    [Quidway-aaa] q
    [Quidway]user-interface vty 04  
    (vty:虚拟终端,0 4代表有0到4一共最多5个终端可以同时登录到交换机)

    [Quidway-vty0-4]authentication-modeaaa (authentication:认证,验证。验证模式设置为aaa模式)

    [Quidway -ui-vty0-4]q

    设置完毕,这时可以在cmd里telnet 网关,即可登录到交换机。

    下面是S5324和S5700成功配置telnet后的截图

    26f7f92971a5b4314f2495ba840312bd.png

    df783b8836c209c41dd0c3ecb1e86a23.png

    注意:当提示验证失败时,将网卡禁用再启用可以解决问题。

    6、配置FTP服务器

    建立一个FTP服务器,用户名为tcwq,密码为tcwq

    sys

    [Quidway] ftp server enable  (开启FTP服务)

    [Quidway] aaa

    [Quidway-aaa] local-user tcwq passwordsimple tcwq

    [Quidway-aaa] local-usertcwq  service-type ftp

    [Quidway-aaa] local-usertcwq  ftp-directory  flash:/  (配置FTP用户的访问路径,如果不配置这一项,登录时会提示“530 logged incorrect”)

    [Quidway-aaa] q

    这时用网线把电脑网卡和交换机的某个端口相连,电脑IP设置为和该端口所在Vlan的网关同一网段的地址(如IP:192.168.1.128,网关:192.168.1.1),在CMD命令行里输入FTP 192.168.1.1即可进入FTP的验证界面,输入账号tcwq,密码tcwq,即可登录

    cf3da7c04286bf4156ee56148f99c69a.png

    登录到ftp后,可以从交换机的Flash里下载文件到电脑里(下载的文件所在位置是登录到ftp服务器前的盘符,如上图中是从F盘根目录登录到FTP的,那么文件都会被下载到F盘的根目录里),也可以从电脑里选择文件上传到交换机的Flash里(速度很快,比串口烧录快多了),还可以删除flash里文件

    ftp>dir             (查看文件)

    ftp>getvrpcfg.zip     (下载文件名为“vrpcfg.zip”的文件)

    ftp>put f:\S5700\web.zip  (将电脑F盘里名字为S5700的文件夹里的web.zip文件上传的交换机的Flash里)

    ftp>deleteweb.zip          (删除文件名为“web.zip”的文件) 

    7、WEB网页管理

    三层交换机可以进行网页管理,前提是HTTP服务要开启,且交换机Flash里有web管理文件并被成功加载。

    上一步进行了FTP服务器配置,如果交换机里没有ZIP后缀名的WEB管理文件,就需要先用FTP把WEB管理文件上传到Flash里

    ftp> put f:\S5700\web.zip

    200 Port command okay.

    150 Opening ASCII mode data connection for web.zip.

    226 Transfer complete.

    显示到这里就说明web.zip文件被成功上传到Flash里了。 

    下面就需要在终端或者telnet里将刚刚上传的web.zip进行加载

    sys

    [Quidway] http server loadweb.zip  (加载web.zip)

    接下来就可以开启HTTP服务了,在没有加载web.zip之前,HTTP服务是开启不了的

    [Quidway] http server enable

    现在建立一个网管账号,账户名xiaodong,密码xiaodong

    [Quidway] aaa

    [Quidway-aaa] local-user xiaodong passwordsimple xiaodong

    [Quidway-aaa] local-user xiaodong  service-typehttp

    [Quidway-aaa] q

    这时可以在电脑上打开浏览器,输入192.168.1.1,进入登录验证界面,输入账号xxx,密码xxx,验证码,即可登录。

    d6d2a7abc52c4b93e3b711405fae2af8.png

    c90e93aac956f1269b90f4f73a01c151.gif

    以上,就是今日思博为你带来的华为三层交换机配置,希望对你能有所启发~

    如果你觉得今天的分享还不错,欢迎你把本文分享到其他群里或者朋友圈,邀请身边的人一起学习~

    最后,送你一份学习资料合集,入群即可免费获得

    · 华为资料合集

    · 网络电子书合集

    · 每日一案例帮你学

    · ......

    每天为你推送常用技术讲解+实战干货解析+现网案例复盘。让你能比同行的人获得更高速的成长,且这个成长真实可见。

    d4c4fcc6ded4bcc0cd01dc7cbcf4d2a8.png

    我知道爱学习的你“在看”

    bb09d0e0020ba92ec35570ad51a91baa.gif

    展开全文
  • 配置交换机名称和管理IP地址。 <Quidway>system-view [Quidway] sysname Server [Server] interface ethernet 0/0/0 //框式和盒式的管理口是不一样的哦,框式和盒式的 分别是: Ethernet 0/0/0、MEth 0/0/1。...

    S5700/S2700/S3700/S6700/7700/S9700 都没有默认管理IP地址,需要手工配置

    配置交换机名称和管理IP地址。

    <Quidway>system-view
    [Quidway] sysname Server
    [Server] interface ethernet 0/0/0  //框式和盒式的管理口是不一样的哦,框式和盒式的
    

    分别是: Ethernet 0/0/0、MEth 0/0/1。有些盒式设备没有管理口,可使用VLANIF接口(int vlanif X)配置管理IP地址。

    [Server-Ethernet0/0/0] ip address 10.10.10.10 24
    [Server-Ethernet0/0/0] quit
    S23/33/27/57/67/77/97/127 使用interface vlanif 配置管理IP地址配置如下::
    # 进入VLANIF1接口视图。
    <Quidway> system-view
    [Quidway] vlan 1
    [Quidway-vlan1] quit 
    [Quidway] interface vlanif 1
    [Quidway-Vlanif1]ip address 192.168.10.1 24
    

    一般地,3层交换机可配置多个vlanif接口;而2层交换机只支持创建一个vlanif接口,设备默认已有vlanif1,所以如需配置其他vlanif,须先删除vlanif1。

    [Quidway]undo int vlanif 1
    [Quidway]vlan 2
    [Quidway-vlan2] quit 
    [Quidway]int vlanif 2
    [Quidway-Vlanif2]ip address 192.168.20.1 24
    

    修改管理IP地址:

    <S5700>sys
    [S5700]interface Vlanif 10
    [S5700-Vlanif10]di th //查看当前接口下已有配置
    #
    interface Vlanif10
    ip address 192.168.1.250 255.255.255.0
    #
    [S5700-Vlanif10]undo ip address //删除当前已配IP地址
    [S5700-Vlanif10]ip add 192.168.1.248 255.255.255.0 //重新配置IP地址
    [S5700-Vlanif10]di th //再次查看是否修改成功
    #
    interface Vlanif10
    ip address 192.168.1.248 255.255.255.0 //已修改成功
    

    设置管理口的IP地址

    #interface MEth0/0/1
     ip address 192.168.1.240 255.255.255.0
    开启SNMP
    #snmp-agent community read public  //注意这里的community就是SNMP的密码,需要配合SNMP管理软件来设置
    

    参考链接 :
    https://mp.weixin.qq.com/s/StVPR_i0y6IXG91BZWPtew

    展开全文
  • 3.给vlan分配一个ip地址命令: 先进入网络配置模式 config router set ipport 0 ipaddress 192.168.0.2 255.255.255.0 set ipport 0 vlan 100 set ipport 0 enable 4.删除给vlan分配的ip地址命令: 先进入...

    1.创建vlan命令:set vlan 100 enable

    2.删除vlan命令:set vlan 100 disenable

    3.给vlan分配一个ip地址命令:

       先进入网络配置模式

      config router
      set ipport 0 ipaddress 192.168.0.2 255.255.255.0    
      set ipport 0 vlan 100
      set ipport 0 enable

    4.删除给vlan分配的ip地址命令:

     先进入网络配置模式

      config router
      set ipport 0 disable
      clear ipport 0

    5.把vlan应用到端口

    set port 1 pvid 100   //把vlan 100应用到端口 1
    set port 2 pvid 100   //把vlan 100应用到端口 2
    set port 3 pvid 100   //把vlan 100应用到端口 3

    如何删除?

    set port 1 pvid 1
    set port 2 pvid 1
    set port 3 pvid 1

    6.如何关闭端口?

    set port 1 disable
    set port 2 disable
    set port 3 disable

    7.如何开启端口?

    set port 1 enable
    set port 2 enable
    set port 3 enable

    8.给vlan打标签,untag和tag          //untag相当于华三的access     tag相当于华三的trunk

      set vlan 100 add port 1 untag
      set vlan 100 add port 2 untag
      set vlan 100 add port 3 untag

    允许多个vlan 通过

    set vlan 100,200 add port 24 tag

    如何删除?

      set vlan 100 del port 1 
      set vlan 100 del port 2 
      set vlan 100 del port 3 

    set vlan 100,200 del port 24 

    展开全文
  • 一、简介 三层交换工作在三层(网络层),我们三层设备不是有路由器了么为啥还需要三层交换机呢?...二、三层交换机如何配置IP地址 路由器的IP地址是进入相应接口配置的,那么三层交换机呢? 其实三层交

    一、简介
    三层交换工作在三层(网络层),我们三层设备不是有路由器了么为啥还需要三层交换机呢?
    路由器的缺点:接口比较少,价格贵,机器多了不可能买好多个路由器。
    三层交换机:具备交换机的vlan划分隔离广播域功能,接口好多个,又具有路由功能。
    这样我们就可以初步优化我们的网络部署,办公室(交换机)楼层(三层交换机)大楼(路由器),这里只是举个例子啊,形象的理解一下这三种网络设备的大概作用和在网络系统中的定位。
    二、三层交换机如何配置IP地址
    路由器的IP地址是进入相应接口配置的,那么三层交换机呢?
    其实三层交换机有个vlanif虚拟接口,我们在配置好vlan后,相应的vlan就会有一个vlanif接口我们需要把IP地址配在这个虚拟接口里面。
    第一步划分vlan

    system-view ##进入系统试图
    vlan 50     ##创建vlan 50
    in g 0/0/1  ##进入接口视图
    port link-type access
    port default vlan 50 ##将接口加入vlan 50 
    quit ##回到系统试图

    第二步进入vlan(虚拟接口)配置IP

    interface vlanif 50 ##
    ip add 192.168.2.1 255.255.255.0 ##配置IP地址
    

    这样三层交换机的IP就配置好啦,接口 g 0/0/1 的IP 就是 192.168.2.1 这里提示一下不要多个接口属于同一个vlan,三层交换机作为三层设备,和路由器一样,每个接口都要连接不同网段,你可以多创建些vlan 用来配置IP。

    display vlan   ##查看本机的vlan配置
    display ip routing-table ##查看本机的路由表
    display ip interface brief  ##查看虚拟接口的IP配置

    三、交换机和三层交换机的一些细节操作
    删除操作

    undo 之前的指令 ##删除之前这个指令的配置
    如果之前针对某个接口的操作很多的话就需要undo很多次,而且还要按顺序undo很麻烦
    clear configuration interface g 0/0/1 ##清楚在 g 0/0/1 端口的所有配置
    in g 0/0/1
    undo shutdown ##重新打开接口,因为使用清楚所有配置会关闭端口,这里需要重新打开一下

    查看这个端口都做了哪些配置

    in g 0/0/1
    dis this  

    保存你所作的配置 (交换机 三层交换机 路由器都一样)

    一直quit 退到用户视图 就是<  交换机>  这样的标识
    save 
    提示按Y

    恢复出厂设置

    一直quit 退到用户视图 就是<  交换机>  这样的标识
    reset saved-configuration
    提示 按Y 

    修改设备的主机名

    进入系统试图
    syaname hahaha  ##把名字改成hahaha

    添加用户和密码,并使用账号和密码登录

    进入系统视图
    aaa 
    local-user xixi password cipher 123 ##设置用户xixi 密码123 cipher表示加密模式
    quit ##退回系统试图
    user-interface console 0 ##进入用户控制台接口
    authentication-mode aaa  ##应用设置

    然后保存并退出 就可以用账号密码登陆啦

    展开全文
  • h3c交换机配置telnet配置教程H3C交换机如何设置TELNET登陆?...配置实例一:通过Console口连接配置交换机Vlan1的IP地址system-view[h3c]interface vlan-interface 1[h3c-vlan-interface1]ip address 192.168.2.1...
  • 一、VLAN划分 VLAN以及VLAN的划分 system-view ##sys ##这个命令的作用是进入系统试图 下面所有的操作都得进入系统试图哦 display vlan ## dis vlan ##显示当前机器的vlan列表 创建VLAN 创建vlanVLAN1 是系统默认...
  • 这个是交换机在划分网络的时候会常用到。为什么要划分VLAN1、减少广播风暴VLAN最大的好处是可以隔离冲突域和广播域。如果一个局域网内有上百台主机,如果一旦产生广播风暴,那么,这个网络就会被彻底的瘫痪。这是...
  • 0x00前言:今日在学校里学习了如何搭建vlan配置等等还有trunk。由于快下课了。尽快写。0x01准备:Cisco模拟器0x02正文:要求:VLAN 10 左边的IP:192.168.1.11 192.168.2.11 192.168.3.11 右边的IP:192.168.1.12 ...
  • 步骤一:给交换机配置IP地址 S2724G#conf S2724G(config)#int vlan 1 S2724G(config-if)#ip addess 192.168.0.100 255.255.255.0 ----给VLAN 1配置IP地址 S2724G(config-if)#no shutdown...
  • 通过本次实验,让读者能够实现在多个交换机之间如何来进行VLAN配置。 二:实验要求 按照下面的网络模型图,进行VLAN配置。 (图2-1网络模型图) 计算机 PC1到PC6的IP地址和子网掩码分配如下表所示: 设备 IP ...
  • 一、系统IP配置:[H3C]vlan20[H3C]management-vlan20[H3C]interfacevlan-interface20创建并进入管理VLAN[H3C]undointerfacevlan-interface20删除管理VLAN接口[H3C-Vlan-interface20]ipaddress192.168.1.2255.255.255....
  • 5、配置三层交换 到这里,VLAN已经基本划分完毕。但是,VLAN如何实现三层(网络层)交换呢?这时就要给各VLAN分配网络(IP)地址了。给VLAN分配IP地址分两种情况,其一,给VLAN所有的节点分配静态IP地址;其二,给...
  • 你要看的IP应是VLANIPinterface vlan 1ip address 172.16.1.7 255.255.255.0 看到这就是交换机IP。像H3C Quaidway 6506这是个三层的交换机,可能会划很多VLAN,所以它会有很我IPvlan1的IP可以做管理IP(就是做...
  • 今日在学校里学习了如何搭建vlan配置等等还有trunk。 由于快下课了。尽快写。 0x01准备: Cisco模拟器 0x02正文: 要求: VLAN 10 左边的IP:192.168.1.11 192.168.2.11 192.168.3.11 右边的IP:192.168.1.12...

空空如也

空空如也

1 2 3 4 5 ... 13
收藏数 241
精华内容 96
关键字:

交换机vlan如何配置ip