精华内容
下载资源
问答
  • 今天我们来看下具体应用,以华为交换机为例,也是的比较多,来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你以对vlan了解不多,那么这篇文章可以带你深入学习vlan,都详细注释。...

    f47779ccc30bd5d18a75b2b0afbc8f42.png

    前面我们发布了华为交换机的基本配置,这篇内容是华为交换机的基本配置,今天我们来看下具体应用,以华为交换机为例,也是用的比较多,来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你以对vlan了解不多,那么这篇文章可以带你深入学习vlan,都有详细注释。

    端口类型

    在学习划分vlan前,必须要了解华为交换机的端口类型,以及他们的使用方法,因为端口的类型在实际配置中是必须会用到的,因为下面的vlan划分会用到。

    1、Access类型端口

    执行命令port default vlan vlan-id,将端口加入到指定的VLAN中。

    Access类型端口只能属于1个VLAN,一般用于连接计算机端口;

    2、Trunk类型端口

    Trunk类型端口可以允许多个VLAN通过,可以接收和发送多个VLAN 报文,

    3、Hybrid类型端口

    – 选择执行其中一个步骤配置Hybrid端口加入VLAN的方式:Hybrid类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文。

    我们前面曾说到,关于vlan的划分方法有很多,项目应用中较多的方法就是基于端口划分vlan基于mac地址划分vlan基于ip地址划分vlan,要真正对vlan了解,必须熟悉这三次划分方法,以便于根据实际项目进行应用。

    一、基于端口的vlan划分方法

    这里面为了方便大家理解,直接用实例讲解更清楚。

    1、组网需求
    如图1所示,某企业的交换机连接有很多用户,且相同业务用户通过不同的设备接入企业网络。为了通信的安全性,也为了避免广播报文泛滥,企业希望业务相同用户之间可以互相访问,业务不同用户不能直接访问。


    可以在交换机上配置基于端口划分VLAN,把业务相同的用户连接的端口划分到同一VLAN。

    也就是不同VLAN的用户不能直接进行二层通信同一VLAN内的用户可以直接互相通信。

    4d7cbb1cd4701837abdc6b43d1b597a3.png

    2、配置步骤

    步骤1 在SwitchA创建VLAN2和VLAN3,并将连接用户的端口分别加入VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [Quidway] system-view //进入配置视图
    [Quidway] sysname SwitchA //给交换机命名
    [SwitchA] vlan batch 2 3 //同时创建vlan2与vlan3
    [SwitchA] interface ethernet 0/0/1 //进入端口0/0/1
    [SwitchA-Ethernet0/0/1] port link-type access //设置端口模式为access
    [SwitchA-Ethernet0/0/1] port default vlan 2 //将端口加入vlan2中
    [SwitchA-Ethernet0/0/1] quit //退出
    [SwitchA] interface ethernet 0/0/2 //进入端口0/0/2
    [SwitchA-Ethernet0/0/2] port link-type access //端口模式为access
    [SwitchA-Ethernet0/0/2] port default vlan 3 //将端口加入vlan3中
    [SwitchA-Ethernet0/0/2] quit //退出

    步骤2 配置SwitchA上与SwitchB连接的端口类型及通过的VLAN。SwitchB配置与SwitchA类似,不再赘述。

    [SwitchA] interface ethernet 0/0/3 //进入端口0/0/3
    [SwitchA-Ethernet0/0/3] port link-type trunk //设置端口模式为trunk
    [SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3 //trunk口允许通过vlan2与vlan3的数据包

    步骤3 验证配置结果将User1和User2配置在一个网段,比如192.168.100.0/24;将User3和User4配置在一个网段,比如192.168.200.0/24。

    User1和User2能够互相ping通,但是均不能ping通User3和User4。User3和User4能够互相ping通,但是均不能ping通User1和User2。

    二、基于MAC地址vlan划分方法

    1、组网需求
    某个公司的网络中,网络管理者将同一部门的员工划分到同一VLAN。为了提高部门内的信息安全,要求只有本部门员工的PC才可以访问公司网络。

    如图2所示,PC1、PC2、PC3为本部门员工的PC,要求这几台PC可以通过SwitchA、Switch访问公司网络,如换成其他PC则不能访问。可以配置基于MAC地址划分VLAN,将本部门员工PC的MAC地址与VLAN绑定,从而实现该需求。

    6bae59fd28ce63aac7cc1636c8386b5f.png

    2、操作步骤

    这里面弱电君对上面重复的注释就不再解释了,和上面一样,大家也可以验证下,经过上面的理解,是否能认识下面的配置代码。

    步骤1 配置Switch

    # 创建VLAN
    [Quidway] system-view
    [Quidway] vlan batch 10 100

    # 配置接口的PVID和加入VLAN
    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] port hybrid pvid vlan 100 //将接口以加入到vlan100

    [Quidway-Ethernet0/0/1] port hybrid untagged vlan 10 //untagged是指当数据离开端口时脱掉标签,指定端口允许VLAN 10的数据帧通过,且发送时不带VLAN标签

    [Quidway-Ethernet0/0/1] quit #退出

    [Quidway] interface ethernet 0/0/2 #进入端口0/0/2
    [Quidway-Ethernet0/0/2] port hybrid tagged vlan 10 //tagged是指当数据离开端口时带着标签,指定允许VLAN 10的数据帧通过,且发送时必须带有VLAN标签

    [Quidway-Ethernet0/0/2] quit

    # PC的MAC地址与VLAN10关联
    [Quidway] vlan 10
    [Quidway-Vlan10] mac-vlan mac-address 22-22-22

    //关联pc1的mac地址
    [Quidway-Vlan10] mac-vlan mac-address 33-33-33

    //关联pc2的mac地址

    [Quidway-Vlan10] mac-vlan mac-address 44-44-44

    //关联pc3的mac地址

    [Quidway-Vlan10] quit

    # 使能接口的基于MAC地址划分VLAN功能
    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] mac-vlan enable

    //起动端口的mac-vlan功能

    [Quidway-Ethernet0/0/1] quit

    三、基于IP子网的vlan划分

    1、组网需求

    某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务使用的IP地址网段各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

    如图3所示,Switch接收到用户报文有数据、IPTV、语音等多种业务,用户设备的IP地址网段各不相同。现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLANID分流到不同的远端服务器上以实现业务互通。

    这类在实际应用中是比较多的。

    34001eb952e4167a92a72e0817072968.png

    2、配置思路

    采用如下的思路配置基于IP子网划分VLAN:

    a、创建VLAN,确定每种业务所属的VLAN。
    b、关联IP子网和VLAN,实现根据报文中的源IP地址或指定网段确定VLAN。
    c、配置端口加入VLAN,实现基于IP子网的VLAN通过当前端口。
    d、配置VLAN划分方式的优先级,确保优先选择基于IP子网划分VLAN。
    e、使能基于IP子网划分VLAN。

    3、操作步骤

    步骤1 创建VLAN
    # 在Switch上创建VLAN100、VLAN200和VLAN300。
    [Quidway] system-view
    [Quidway] vlan batch 100 200 300

    步骤2 配置接口

    # 在Switch上配置接口Eth0/0/1为Hybrid类型,并加入VLAN100、VLAN200和VLAN300。

    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] port link-type hybrid //设置端口为hybrid模式

    [Quidway-Ethernet0/0/1] port hybrid untagged vlan100 200 300 //指定端口允许VLAN 100、vlan200、vlan300的数据帧通过,且发送时不带VLAN标签

    [Quidway-Ethernet0/0/1] quit

    # 在Switch上配置接口Eth0/0/2加入VLAN100。

    [Quidway] interface ethernet 0/0/2
    [Quidway-Ethernet0/0/2] port link-type trunk
    [Quidway-Ethernet0/0/2] port trunk allow-pass vlan 100 //接口0/0/2加入vlan100

    [Quidway-Ethernet0/0/2] quit

    # 在Switch上配置接口Eth0/0/3加入VLAN200。
    [Quidway] interface ethernet 0/0/3
    [Quidway-Ethernet0/0/3] port link-type trunk
    [Quidway-Ethernet0/0/3] port trunk allow-pass vlan 200 //接口0/0/3加入vlan200

    [Quidway-Ethernet0/0/3] quit

    # 在Switch上配置接口Eth0/0/4加入VLAN300。
    [Quidway] interface ethernet 0/0/4
    [Quidway-Ethernet0/0/4] port link-type trunk
    [Quidway-Ethernet0/0/4] port trunk allow-pass vlan 300 //接口0/0/4加入vlan300

    [Quidway-Ethernet0/0/4] quit

    # 在Switch上配置接口Eth0/0/1使能基于IP子网划分VLAN功能。
    [Quidway] interface ethernet 0/0/1
    [Quidway-Ethernet0/0/1] ip-subnet-vlan enable
    [Quidway-Ethernet0/0/1] quit

    步骤3 配置基于IP子网划分VLAN

    # 在Switch上配置VLAN100与IP地址192.168.1.2/24关联,优先级为2。

    [Quidway] vlan 100
    [Quidway-vlan100] ip-subnet-vlan 100 ip 192.168.1.2 24 priority 2
    [Quidway-vlan100] quit


    # 在Switch上配置VLAN200与IP地址192.168.2.2/24关联,优先级为3。
    [Quidway] vlan 200
    [Quidway-vlan200] ip-subnet-vlan 200 ip 192.168.2.2 24 priority 3
    [Quidway-vlan200] quit


    # 在Switch上配置VLAN300与IP地址192.168.3.2/24关联,优先级为4。
    [Quidway] vlan 300
    [Quidway-vlan300] ip-subnet-vlan 300 ip 192.168.3.2 24 priority 4
    [Quidway-vlan300] quit

    步骤4 验证配置结果

    在Switch上执行以下命令,显示信息如下:
    [Quidway] display ip-subnet-vlan vlan all
    ----------------------------------------------------------------
    Vlan Index IpAddress SubnetMask Priority
    ----------------------------------------------------------------
    100 1 192.168.1.2 255.255.255.0 2
    200 1 192.168.2.2 255.255.255.0 3
    300 1 192.168.3.2 255.255.255.0 4
    ----------------------------------------------------------------
    ip-subnet-vlan count: 3 total count: 3

    即为组网配置成功。

    展开全文
  • 前面我们曾提到关于vlan组网,很多朋友反映没有更详细、更简单的内容,这次我们一个实例来讲解vlan的创建及组网过程,且所有的命令都注释,我们一起来看下。在了解vlan同时,我们也来简单的了解下三层交换机...

    前面我们曾提到关于vlan组网,有很多朋友反映有没有更详细、更简单的内容,这次我们用一个实例来讲解vlan的创建及组网过程,且所有的命令都有注释,我们一起来看下。在了解vlan同时,我们也来简单的了解下三层交换机。

    一、为什么要使用三层交换机

    1、使用二层交换机+路由器进行VLAN间通信的问题

    现在,我们知道只要能提供VLAN间路由,就能够使分属不同VLAN的计算机互相通信。

    但是,如果使用路由器进行VLAN间路由的话,随着VLAN之间流量的不断增加,很可能导致路由器成为整个网络的瓶颈。

    交换机使用被称为ASIC的专用硬件芯片处理数据帧的交换操作,在很多机型上都能实现缆线速度交换。而路由器,则基本上是基于软件处理的。

    就VLAN间路由而言,流量会集中到路由器和交换机互联的汇聚链路部分,这一部分尤其特别容易成为速度瓶颈。

    2、三层交换机

    为了解决上述问题,三层交换机应运而生。三层交换机,本质上就是“带有路由功能的(二层)交换机”。路由属于OSI参照模型中第三层网络层的功能,因此带有第三层路由功能的交换机才被称为“三层交换机”。

    关于三层交换机的内部结构,可以参照下面的简图。

    a690d69f142674fd64328bcfb2e841d0.png

    在一台本体内,分别设置了交换机模块和路由器模块;而内置的路由模块与交换模块相同,使用ASIC硬件处理路由。因此,与传统的路由器相比,可以实现高速路由。

    二、vlan配置详细教程实例

    VLAN生成后交换机是互不相通的。因此,在交换机上设置VLAN后,如果未做其他处理,VLAN间是无法通信的。

    为了使大家理解,我们用个实例来讲解三层交换机的配置,实例不同vlan间进行通信,很详细。

    实例

    如下图,有一个公司的网络,共有4个vlan,有4个交换机(分别为S1S2S3S4),用三层交换机让不同vlan的主机能互相通信,也就是让vlan10、vlan20、vlan30、vlan40之间实现通信。

    一、拓扑图如下:

    f37d7516f2cc14a6c1dfaedc38d5ff1f.png

    二、配置步骤如下:

    1、S1三层交换机配置:

    Switch>en--进入特权模式

    Switch#conf t--进入全局配置模式

    Switch(config)#hostname S1 --修改三层交换机主机名为S1

    S1(config)#vtp domain test --创建vtp

    Domain name already set to test.

    S1(config)#vtp mode server--设置当前交换机在vtp的工作模式为server

    Device mode already VTP SERVER.

    S1(config)#vlan 10--创建vlan 10

    S1(config-vlan)#vlan 20--创建vlan 20

    S1(config-vlan)#vlan 30--创建vlan 30

    S1(config-vlan)#vlan 40--创建vlan40

    S1(config-vlan)#interface f0/1--进入端口

    S1(config-if)#switchport mode access--将端口模式改为access模式

    S1(config-if)#switchport mode trunk --将端口模式改为trunk模式

    S1(config-if)#interface range f0/2-3 --进入端口

    S1(config-if-range)#switchport mode access--将端口模式改为access模式

    S1(config-if-range)#switchport access vlan 40--将端口划入vlan 40

    S1(config-if-range)#exit--返回上一级

    S1(config)#ip routing--启动三层交换机的路由功能

    S1(config)#interface vlan 10 --进入vlan 10

    S1(config-if)#ip address 192.168.1.254 255.255.255.0--给vlan 10添加ip地址

    S1(config-if)#interface vlan 20 --进入vlan 20

    S1(config-if)#ip address 192.168.2.254 255.255.255.0--给vlan 20添加ip地址

    S1(config-if)#interface vlan 30--进入vlan 30

    S1(config-if)#ip address 192.168.3.254 255.255.255.0--给vlan 30添加ip地址

    S1(config-if)#interface vlan 40 --进入vlan 40

    S1(config-if)#ip address 192.168.4.254 255.255.255.0--给vlan 40添加ip地址

    S1(config-if)#end--返回特权模式

    S1#copy running-config startup-config--保存配置

    [OK]--保存成功

    2、S2交换机配置

    Switch>en--进入特权模式

    Switch#conf t --进入全局配置模式

    Switch(config)#hostname S2--修改交换机名为S2

    S2(config)#vtp mode client--设置当前交换机在vtp中为客户机模式

    Device mode already VTP CLIENT.

    S2(config)#interface f0/10--进入端口

    S2(config-if)#switchport mode trunk--将端口设置为trunk模式

    S2(config-if)#interface f0/1--进入端口

    S2(config-if)#switchport mode access--将端口设置为access模式

    S2(config-if)#switchport access vlan 30--将端口划入vlan30

    S2(config-if)#interface f0/2--进入端口

    S2(config-if)#switchport mode access--将端口设置为access模式

    S2(config-if)#switchport access vlan 20--将端口划入vlan 20

    S2(config-if)#interface f0/3--进入端口

    S2(config-if)#switchport mode access --将端口设置为access模式

    S2(config-if)#switchport access vlan 10--将端口划入vlan 10

    S2(config-if)#end--返回特权模式

    S2#copy running-config startup-config--保存配置

    [OK] --保存成功

    3、S3交换机配置

    Switch>en--进入特权模式

    Switch#conf t --进入全局配置模式

    Switch(config)#hostname S3--修改交换机名为S3

    S3(config)#vtp mode client --设置当前交换机在vtp中为客户模式

    Device mode already VTP CLIENT.

    S3(config)#interface range f0/10-12--进入端口

    S3(config-if-range)#switchport mode trunk--将端口设置为trunk模式

    S3(config-if-range)#interface f0/1--进入端口

    S3(config-if)#switchport mode access--将端口设置为access模式

    S3(config-if)#switchport access vlan 30--将端口划入vlan 30

    S3(config-if)#interface f0/2 --进入端口

    S3(config-if)#switchport mode access--将端口设置为access模式

    S3(config-if)#switchport access vlan 20 --将端口划入vlan20

    S3(config-if)#interface f0/3--进入端口

    S3(config-if)#switchport mode access--将端口设置为access模式

    S3(config-if)#switchport access vlan 10--将端口划入vlan 20

    S3(config-if)#end--返回特权模式

    S3#copy running-config startup-config --保存配置

    [OK]--保存成功

    4、S4交换机配置

    Switch>en--进入特权模式

    Switch#conf t--进入全局配置模式

    Switch(config)#hostname S4--修改交换机名为S4

    S4(config)#vtp mode client--设置当前交换机在vtp中为客户模式

    S4(config)#interface f0/10--进入端口

    S4(config-if)#switchport mode trunk--将端口设置为trunk模式

    S4(config-if)#interface f0/1--进入端口

    S4(config-if)#switchport mode access--将端口设置为access模式

    S4(config-if)#switchport access vlan 30--将端口划入vlan 30

    S4(config-if)#interface f0/2--进入端口

    S4(config-if)#switchport mode access--将端口设置为access模式

    S4(config-if)#switchport access vlan 20 --将端口划入vlan 20

    S4(config-if)#interface f0/3 --进入端口

    S4(config-if)#switchport mode access--将端口设置为access模式

    S4(config-if)#switchport access vlan 10 --将端口划入vlan 10

    S4(config-if)#end --返回特权模式

    S4#copy running-config startup-config --保存配置

    [OK]--保存成功

    三、验证

    测试不同vlan下的主机是否互通。

    1、PC11PC33

    c3a9fb1989854c873fce02f7828eb1df.png

    vlan10与vlan30互通

    2、PC13PC21

    f8d83d9318550cd51354dc0c87b6b5d4.png

    vlan10与vlan20互通。

    最新弱电资料更新—弱电工程各系统施工报价清单(12月21日)

    展开全文
  • 前面我们系统介绍我们安防行业需要用到的网络知识里,讲到VLAN的概念和划分,很多朋友要求写一写交换机VLAN划分的命令。交换机的配置过程还是比较复杂的,品牌和产品不同也会差异,我们今天一起学习一下通用的配置...
    31c1da16eff218de1c7ec56c3831442f.png

    前面我们系统介绍我们安防行业需要用到的网络知识里,讲到VLAN的概念和划分,很多朋友要求写一写交换机VLAN划分的命令。交换机的配置过程还是比较复杂的,品牌和产品不同也会有差异,我们今天一起学习一下通用的配置方法。

    更多历史网络知识文末有链接。

    要配置交换机,首先要把交换机和电脑连接,连接方法是用专门的console线连接交换机的console端口和计算机的COM口。现在电脑如果没有COM口,用RS232转USB数据线即可。

    硬件连接好了,就要进行软件配置,安装CONSOLE数据线的驱动,并使用系统自带的仿真终端软件,设置好波特率、数据位等信息后,通过交换机的出厂默认用户名和密码就可以登陆交换机。

    de8cb4cb935bced56646d5b5d38fc647.png

    交换机的基本配置模式:

    用户模式:

    switch>

    特权模式:

    Switch#

    进入方法:在默认的用户模式下输入:enable 进入。

    退出方法:输:exit 退回到用户模式。

    注意用户模式和特权模式的前面代码的区别:一个是switch>;一个是Switch#。

    VLAN模式:

    Switch(vlan)#

    进入方法:从#模式输入 vlan database 进入

    全局配置模式:

    Switch(config)#

    进入方法:从#模式输入 config terminal 进入

    接口配置模式:

    Switch(config-if)#

    进入方法:从(config)#模式输入 interface+接口号进入

    终端线路配置模式:

    Switch(config-line)#

    进入方法:从(config)#模式输入 line+终端标识进入

    要记住这些交换机的配置模式,要知道如何进入和退出,也有能看懂当前处于哪个模式下,在所有模式中,输入exit返回上级,输入end或ctrl+z退出。

    VLAN的常用配置命令:

    交换机没有被划分VLAN的时候,交换机默认只有VLAN1,所有的端口都在VLAN1里面,所以我们是不能创建也不能删除VLAN1的。

    创建VLAN

    Switch#vlan database (进入VLAN数据库)

    Switch(vlan)# vlan 10 name vlan10

    switch(vlan)# vlan 20 name vlan20

    第一条命令:进入VLAN数据库

    第二条命令:创建一个名称为VLAN10的VLAN10

    第三条命令:创建一个名称为VLAN20的VLAN20

    这里Name属性最好定义一下,如果不定义会和默认VLAN名称冲突,这样一一对应比较好。

    663d42e1da80b7b1dfc9f32b24b02e86.png

    端口划入VLAN

    Switch(config)#interface fa0/1

    Switch(config-if)#switchport access vlan 10

    第一条命令的意思是:进入接口fa0/1,这里的0表示第1个插槽,1表示第2个端口。(设备第一个端口通常为0,第二个端口通常为1)。

    第二条命令:把fa0/1这个端口划分给VLAN 10 这样配置之后,接在这个端口的所有设备就属于VLAN 10 了。

    查看VLAN信息

    Switch#show vlan 查看所有VLAN信息

    Switch#show vlan id 10 查看vlan 10的信息

    删除VLAN

    switch#vlan database

    Switch(vlan)#no vlan 10

    删除VLAN 10后,所有分配给VLAN10的端口都变回非活动状态,直到下次再次分配给别的VALN为止。

    一个VLAN可以有多个端口,如果要将某个端口从VLAN中删除

    Switch(config)# interface f0/2

    Switch(config-if)#no switchport access vlan 10

    当然这些只是交换机配置的皮毛,这些配置基础我们一定要掌握,再在此基础上配置其他命令,就应该没有什么问题了!

    展开全文
  • 一篇文章讲清楚交换机VLAN的创建与划分 前面我们曾提到关于vlan组网,很多朋友反映没有更详细、更简单的内容,这次我们一个实例来讲解vlan的创建及组网过程,且所有的命令都注释,我们一起来看下。在了解...

    一篇文章讲清楚交换机VLAN的创建与划分

    前面我们曾提到关于vlan组网,有很多朋友反映有没有更详细、更简单的内容,这次我们用一个实例来讲解vlan的创建及组网过程,且所有的命令都有注释,我们一起来看下。在了解vlan同时,我们也来简单的了解下三层交换机。

    一、为什么要使用三层交换机

    1、使用二层交换机+路由器进行VLAN间通信的问题

    现在,我们知道只要能提供VLAN间路由,就能够使分属不同VLAN的计算机互相通信。

    但是,如果使用路由器进行VLAN间路由的话,随着VLAN之间流量的不断增加,很可能导致路由器成为整个网络的瓶颈。

    交换机使用被称为ASIC的专用硬件芯片处理数据帧的交换操作,在很多机型上都能实现缆线速度交换。而路由器,则基本上是基于软件处理的。

    就VLAN间路由而言,流量会集中到路由器和交换机互联的汇聚链路部分,这一部分尤其特别容易成为速度瓶颈。

    2、三层交换机

    为了解决上述问题,三层交换机应运而生。三层交换机,本质上就是“带有路由功能的(二层)交换机”。路由属于OSI参照模型中第三层网络层的功能,因此带有第三层路由功能的交换机才被称为“三层交换机”。

    关于三层交换机的内部结构,可以参照下面的简图。

    在一台本体内,分别设置了交换机模块和路由器模块;而内置的路由模块与交换模块相同,使用ASIC硬件处理路由。因此,与传统的路由器相比,可以实现高速路由。

    二、vlan配置详细教程实例

    VLAN生成后交换机是互不相通的。因此,在交换机上设置VLAN后,如果未做其他处理,VLAN间是无法通信的。

    为了使大家理解,我们用个实例来讲解三层交换机的配置,实例不同vlan间进行通信,很详细。

    实例:

    如下图,有一个公司的网络,共有4个vlan,有4个交换机(分别为S1S2S3S4),用三层交换机让不同vlan的主机能互相通信,也就是让vlan10、vlan20、vlan30、vlan40之间实现通信。

    一、拓扑图如下:

    二、配置步骤如下:

    1、S1三层交换机配置:

    Switch>en--进入特权模式

    Switch#conf t--进入全局配置模式

    Switch(config)#hostname S1 --修改三层交换机主机名为S1

    S1(config)#vtp domain test --创建vtp

    Domain name already set to test.

    S1(config)#vtp mode server--设置当前交换机在vtp的工作模式为server

    Device mode already VTP SERVER.

    S1(config)#vlan 10--创建vlan 10

    S1(config-vlan)#vlan 20--创建vlan 20

    S1(config-vlan)#vlan 30--创建vlan 30

    S1(config-vlan)#vlan 40--创建vlan40

    S1(config-vlan)#interface f0/1--进入端口

    S1(config-if)#switchport mode access--将端口模式改为access

    S1(config-if)#switchport mode trunk --将端口模式改为trunk

    S1(config-if)#interface range f0/2-3 --进入端口

    S1(config-if-range)#switchport mode access--将端口模式改为access

    S1(config-if-range)#switchport access vlan 40--将端口划入vlan 40

    S1(config-if-range)#exit--返回上一级

    S1(config)#ip routing--启动三层交换机的路由功能

    S1(config)#interface vlan 10 --进入vlan 10

    S1(config-if)#ip address 192.168.1.254 255.255.255.0--给vlan 10添加ip地址

    S1(config-if)#interface vlan 20 --进入vlan 20

    S1(config-if)#ip address 192.168.2.254 255.255.255.0--给vlan 20添加ip地址

    S1(config-if)#interface vlan 30--进入vlan 30

    S1(config-if)#ip address 192.168.3.254 255.255.255.0--给vlan 30添加ip地址

    S1(config-if)#interface vlan 40 --进入vlan 40

    S1(config-if)#ip address 192.168.4.254 255.255.255.0--给vlan 40添加ip地址

    S1(config-if)#end--返回特权模式

    S1#copy running-config startup-config--保存配置

    [OK]--保存成功

    2、S2交换机配置

    Switch>en--进入特权模式

    Switch#conf t --进入全局配置模式

    Switch(config)#hostname S2--修改交换机名为S2

    S2(config)#vtp mode client--设置当前交换机在vtp中为客户机模式

    Device mode already VTP CLIENT.

    S2(config)#interface f0/10--进入端口

    S2(config-if)#switchport mode trunk--将端口设置为trunk

    S2(config-if)#interface f0/1--进入端口

    S2(config-if)#switchport mode access--将端口设置为access

    S2(config-if)#switchport access vlan 30--将端口划入vlan30

    S2(config-if)#interface f0/2--进入端口

    S2(config-if)#switchport mode access--将端口设置为access

    S2(config-if)#switchport access vlan 20--将端口划入vlan 20

    S2(config-if)#interface f0/3--进入端口

    S2(config-if)#switchport mode access --将端口设置为access

    S2(config-if)#switchport access vlan 10--将端口划入vlan 10

    S2(config-if)#end--返回特权模式

    S2#copy running-config startup-config--保存配置

    [OK] --保存成功

    3、S3交换机配置

    Switch>en--进入特权模式

    Switch#conf t --进入全局配置模式

    Switch(config)#hostname S3--修改交换机名为S3

    S3(config)#vtp mode client --设置当前交换机在vtp中为客户模式

    Device mode already VTP CLIENT.

    S3(config)#interface range f0/10-12--进入端口

    S3(config-if-range)#switchport mode trunk--将端口设置为trunk

    S3(config-if-range)#interface f0/1--进入端口

    S3(config-if)#switchport mode access--将端口设置为access

    S3(config-if)#switchport access vlan 30--将端口划入vlan 30

    S3(config-if)#interface f0/2 --进入端口

    S3(config-if)#switchport mode access--将端口设置为access

    S3(config-if)#switchport access vlan 20 --将端口划入vlan20

    S3(config-if)#interface f0/3--进入端口

    S3(config-if)#switchport mode access--将端口设置为access

    S3(config-if)#switchport access vlan 10--将端口划入vlan 20

    S3(config-if)#end--返回特权模式

    S3#copy running-config startup-config --保存配置

    [OK]--保存成功

    4、S4交换机配置

    Switch>en--进入特权模式

    Switch#conf t--进入全局配置模式

    Switch(config)#hostname S4--修改交换机名为S4

    S4(config)#vtp mode client--设置当前交换机在vtp中为客户模式

    S4(config)#interface f0/10--进入端口

    S4(config-if)#switchport mode trunk--将端口设置为trunk

    S4(config-if)#interface f0/1--进入端口

    S4(config-if)#switchport mode access--将端口设置为access

    S4(config-if)#switchport access vlan 30--将端口划入vlan 30

    S4(config-if)#interface f0/2--进入端口

    S4(config-if)#switchport mode access--将端口设置为access

    S4(config-if)#switchport access vlan 20 --将端口划入vlan 20

    S4(config-if)#interface f0/3 --进入端口

    S4(config-if)#switchport mode access--将端口设置为access

    S4(config-if)#switchport access vlan 10 --将端口划入vlan 10

    S4(config-if)#end --返回特权模式

    S4#copy running-config startup-config --保存配置

    [OK]--保存成功

    三、验证

    测试不同vlan下的主机是否互通。

    1、PC11PC33

    vlan10与vlan30互通

    2、PC13PC21

     

    vlan10与vlan20互通。

    展开全文
  • 交换机到底有什么用

    千次阅读 2018-07-18 14:54:18
    交换机有什么作用? 交换机的主要功能包括物理编址、网络拓扑结构、错误校验、帧序列以及流控。交换机还具备了一些新的功能,如对VLAN(虚拟局域网)的支持、对链路汇聚的支持,甚至有的还具有防火墙的功能。 电...
  • 尤其是三层交换机在项目中的应用配置,本期我们一个实例来讲解vlan的创建及组网过程,且所有的命令都解释,我们一起来看下。一、什么是三层交换机?在了解vlan之间,我们先来简单的了解下三层交换机。要实现vlan...
  • 今天我们来看下具体应用,以华为交换机为例,也是的比较多,来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你以对vlan了解不多,那么这篇文章可以带你深入学习vlan,都详细注释。...
  • 抗浪涌防雷插座什么是抗浪涌插座?防雷插座顾名思义具有防雷功效。能够在雷电环境中保护电器和确保用电安全。抗浪涌插座就是在插座内置一个防雷模块,起到当电压大变化的瞬间,它能快速转移电压的作用,从而保护...
  • 今天我们来看下具体应用,以华为交换机为例,也是的比较多,来看下它的具体配置,这个在实际项目中经常会遇到,实用性比较强,如果你以对vlan了解不多,那么这篇文章可以带你深入学习vlan,都详细注释。...
  • 尤其是三层交换机在项目中的应用配置,本期我们一个实例来讲解vlan的创建及组网过程,且所有的命令都解释,我们一起来看下。一、什么是三层交换机?在了解vlan之间,我们先来简单的了解下三层交换机。要实现vlan...
  • 确实,因为网络技术在弱电中确实应用非常广泛,我们平时在vip技术群中也是不断的讨论到网关、vlan、三层交换机或子网掩码等问题,今天我们就一起通俗方式一次性了解清楚。 一、什么vlan? VLAN中文是“虚拟...
  • 转载:一文讲懂什么vlan、三层交换机、网关、DNS、子网掩码、MAC地址一、什么vlan?二、单臂路由与三层交换机三、什么是网关四、什么是DNS五、MAC地址六、子网掩码补充 一、什么vlan? VLAN中文是“虚拟局域网”...
  • vlan的虚接口IP地址 2.1 是我现在也不知道有什么用 因为划分好了vlan 客户端得到的IP地址 是10.2-254 网关10.1 我这里Lan1默认Vlan1 而Lan2分Vlan2 LAN2设置好了 然后设置DHCP服务器 设置Lan...
  • 前面我们曾提到关于vlan组网,很多朋友反映没有更详细、更简单的内容,这次我们一个实例来讲解vlan的创建及组网过程,且所有的命令都流释,我们一起来看下。在了解vlan之间,我们先来简单的了解下三层交换机...
  • 什么VLAN VLAN中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器分割的网络——也就是广播域。 听上面的概念,肯定不少...
  • 1.什么vlan? VLAN中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器分割的网络——也就是广播域。听上面的概念,肯定不少...
  • 什么VLAN

    2013-10-23 09:59:12
    即从一个交换机换到其他的交换机时,VLAN不用重新配置,所以,可以认为这种根据MAC地址的划分方法是基于用户的VLAN,这种方法的缺点是初始化时,所有的用户都必须进行配置,如果几百个甚至上千个用户的话,配置是...
  • 确实,因为网络技术在弱电中确实应用非常广泛,我们平时在vip技术群中也是不断的讨论到网关、vlan、三层交换机或子网掩码等问题,今天我们就一起通俗方式一次性了解清楚。 一.什么vlan VLAN中文是“虚拟局域网”...
  • vlan、三层交换机、网关、DNS、子网掩码、MAC地址专有名词解释 VLAN中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。 一、VLAN VLAN中文是“虚拟局域网”...
  • 一、什么VLAN VLAN中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器分割的网络——也就是广播域。 听上面的概念,肯定...
  • 交换机配置

    2012-04-12 12:26:44
    实验三 交换机VLAN实验 1. 规划ip地址 PCA的ip 地址: 10.65.1.1 PCB的ip 地址: 10.66.1.1 PCC的ip 地址: 10.65.1.3 PCD的ip 地址: 10.66.1.3 SWA的ip 地址: 10.65.1.7 SWB的ip 地址: 10.65.1.8 SWA的f0/5~...
  • 一、什么VLAN VLAN中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器分割的网络——也就是广播域。 听上面的概念,肯定...
  • 一、什么vlan? VLAN中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用路由器分割的网络——也就是广播域。 听上面的概念,肯定...
  • 听上面的概念,肯定不少朋友是一头雾水的,什么是虚拟局域网?好好的,为什么要划分vlan? 一、什么VLAN VLAN中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成...
  • 今天突然发现个问题:公司几台交换机,a交换机有vlan 2 3 4,b交换机有vlan 2 3 5 现在我a连接的属于vlan4的机器ping b连接的属于vlan5的机器,可以ping通,但是,在b交换机上找不到属于vlan4的那台机器的...
  • 路由器和交换机的不同之处哈喽,大家好,上周小编给大家介绍完VLAN的工作原理,今天小编给大家讲讲路由器和交换机的不同之处。首先我们的交换机分为二层交换机和三层交换机什么是二层交换机呢简单来说,二层交换机...
  • 机房控制器可实现对机房的防火墙及交换机进行管理,后台添加对应可用区的防火墙及交换机,即可实现管理可用区的防火墙及交换机,如实现防火墙自动化域名白名单,交换机带宽调整、VLAN调整、IP-MAC地址绑定、流量信息...
  • H3C交换机的简易设置

    2019-10-03 13:46:27
    我们一般要设置的: 交换机的名称、管理ip地址(这个也可以不设置的)、登陆的用户和密码以及划分合适的vlan 等。... 每个交换机默认都是一个vlan 1存在的,在H3C交换机里,这个vlan 1默认就是管理vlan, 管理...

空空如也

空空如也

1 2 3 4 5
收藏数 96
精华内容 38
关键字:

交换机vlan有什么用