精华内容
下载资源
问答
  • 交换机vlan配置

    2012-11-17 22:10:33
    1、虚拟局域网(VirtualLocalAreaNetwork,VLAN)是一种将局域网lan从逻辑上划分(注意不是从物理上划分)成一个个网段(或者说更小的局域网),从而实现虚拟交换组的数据交换技术。之所以开发出VLAN技术,主要有...

    一、VLAN技术简介

    1、虚拟局域网(Virtual Local Area NetworkVLAN)是一种将局域网lan从逻辑上划分(注意不是从物理上划分)成一个个网段(或者说更小的局域网),从而实现虚拟交换组的数据交换技术。之所以开发出VLAN技术,主要有一下三方面的考虑:

    (1)基于网络性能考虑:主要解决局域网中无法限制广播域的问题,划分了VLAN后,每个VLAN就是一个广播域,广播域被限制在一个VLAN内,不影响其他的VLAN

    (2)基于安全性的考虑:一个VLAN内的单播和广播流量都不会转发到其他VLAN中,即使两个VLAN有着相同的ip子网,只要他们没有相同的VLAN号,他们各自的广播流量就不会相互转发。

    (3)基于组织结构考虑:由于是逻辑而不是物理的划分,可以讲在不同地域的有相同需要的计算机划分到一个VLAN中。

    2、valn的原理

    假设有vlan10valn20,其中计算机A位于vlan10中,计算机B位于vlan20中,现在计算机A发出一个广播帧,交换机接收到这个广播帧后会查询自己的地址表(地址表中记录了每台计算机对应的vlan号和端口号),发现该广播帧是从端口1接收,为vlan10的广播,那么交换机就会按照地址表(上面记录了所有vlan10的主机地址)向所有vlan10的主机发送这个广播帧,而不会向vlan20发送,从而实现隔离广播。

    再假设计算机A想要和计算机B通信,计算机不知计算机B的地址,计算机发出arp广播请求,希望获得计算机BMAC地址,但是交换机根本不会将这个arp转发给计算机B,也就无法获得B的地址,当然没法通信。另外即使A知道了B的地址,计算机A发出一个目的地址是B的单播帧出来,这个单播帧到达交换机后,交换机根据MAC地址也会发现,这个单播帧是VLAN10发出的,而且MAC地址是VLAN20,那么交换机也不会转发这个单播帧。

    3、VLAN主要优点及注意事项

      优点:

    (1)控制广播风暴

    (2)提高网络整体安全性

    (3)企业LAN中的部门组织结构不再受物理地域的限制

    (4)增强网路管理

      注意事项:

    (1)不同交换机平台、不同的IOS版本支持的VLAN最大数量不同

    (2)VLAN1不能创建、删除或重命名,交换机出厂时VLAN1默认创建

    (3)一些与广播有关的协议技术与VLAN有冲突,如DHCP服务

    (4)VLAN之间互访需要三层设备,在一定程度上会造成网路延时

    4、VLAN划分方式

    (1)基于端口划分VLAN

    (2)基于MAC地址划分VLAN

    5、单台交换机VLAN的配置

    1)在没有进行配置的情况下,查看VLAN情况

    Switch>en

    Switch#show vlan

    VLAN Name                             Status    Ports

    ---- -------------------------------- --------- -------------------------------

    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4

                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8

                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12

                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16

                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20

                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24

                                                    Gig1/1, Gig1/2

    1002 fddi-default                     act/unsup 

    1003 token-ring-default               act/unsup 

    1004 fddinet-default                  act/unsup 

    1005 trnet-default                    act/unsup 

    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

    1    enet  100001     1500  -      -      -        -    -        0      0

    1002 fddi  101002     1500  -      -      -        -    -        0      0   

    1003 tr    101003     1500  -      -      -        -    -        0      0   

    1004 fdnet 101004     1500  -      -      -        ieee -        0      0   

    1005 trnet 101005     1500  -      -      -        ibm  -        0      0   

     --More-- 

    从上面可以看出默认情况下,所有的端口都属于VLAN1.

    (2)创建VLAN的命令如下所示

    Switch(config)#vlan 100

    //创建vlan100,并进入vlan配置模式,no vlan100是删除vlan100

    Switch(config-vlan)#name cao1

    //vlan100指定名称cao1

    Switch(config-vlan)#

    (3)将交换机的端口添加到对应的vlan

    Switch(config-vlan)#exit

    Switch(config)#interface range fastethernet 0/1-5

    //从全局模式进入到端口范围配置模式

    Switch(config-if-range)#switchport access vlan 100

    //设置交换机端口fastethernet0/10/20/30/40/5允许访问vlan100,即1-5号端口添加到vlan100中,no switchport access vlan 100可以从vlan100删除端口成员.

    Switch(config-if-range)#exit

    Switch(config)#

    (4)通过以上配置,可以通过show vlan命令来验证VLAN配置结果,部分结果如下:

    (5)Switch#show vlan

    VLAN Name                             Status    Ports

    ---- -------------------------------- --------- -------------------------------

    1    default                          active    Fa0/6, Fa0/7, Fa0/8, Fa0/9

                                                    Fa0/10, Fa0/11, Fa0/12, Fa0/13

                                                    Fa0/14, Fa0/15, Fa0/16, Fa0/17

                                                    Fa0/18, Fa0/19, Fa0/20, Fa0/21

                                                    Fa0/22, Fa0/23, Fa0/24, Gig1/1

                                                    Gig1/2

    10   VLAN0010                         active    

    100  cao1                             active    Fa0/1, Fa0/2, Fa0/3, Fa0/4

                                                    Fa0/5

    1002 fddi-default                     act/unsup 

    1003 token-ring-default               act/unsup 

    1004 fddinet-default                  act/unsup 

    1005 trnet-default                    act/unsup 

    可以看到刚才创建的cao1,并且相应的端口也已经加入到了这个vlan中。

    6、IEEE802.1q和跨交换机的配置

    (1)不同的交换机可以划分相同的VLAN,可以将有相同VLAN的交换机通过Trunk端口互连,处于不同交换机、但具有相同VLAN定义的主机可以相互通信,TRUNK链路的含义就是骨干链路或主干链路,该链路上可以运载多个VLAN信息。

    (2)过程解析

    交换机A上有一个VLAN10,主机C1就在这个VLAN10上,交换机B上也有一个VLAN10,主机C2B这个VLAN10上,交换机A和交换机B通过trunk连接,现在C1想要和C2通信,C1发出的数据帧并不带有VLAN信息,数据帧到了交换机A后,由交换机负责对这个数据帧进行标识,标识是数据帧是VLAN10的数据帧,然后通过Trunk链路再将数据帧交付给交换机B,这样当交换机B收到数据帧后,交换机B就可以根据交换机BMAC地址表来决定是否将数据帧转发给主机C2.

    在数据帧中加入VLAN标识,这项技术就是帧标记法,现在主要有两种帧标记法,一种是ISL,是思科专用的帧标记法,另一种是IEEE802.1q,现在大部分的网络产品厂商都能遵循IEEE802.1q,主要的就是这一个。

    7、跨交换机的vlan配置

    注:1.10主机连接到交换机f0/1,1.20主机连到f0/20,1.30连到f0/1,1.40连到f0/10

    交换机A上的配置

    Switch(config)#vlan 10

    Switch(config-vlan)#exit

    Switch(config)#vlan 20

    Switch(config-vlan)#exit

    Switch(config)#interface range fastethernet 0/1-10

    Switch(config-if-range)#switchport access vlan 10

    Switch(config-if-range)#exit

    Switch(config)#interface range fastethernet 0/11-20

    Switch(config-if-range)#switchport access vlan 20

    Switch(config-if-range)#exit

    Switch(config)#interface GigabitEthernet1/1

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#

    交换机B上的配置

    Switch(config)#vlan 10

    Switch(config-vlan)#exit

    Switch(config)#vlan 20

    Switch(config-vlan)#exit

    Switch(config)#interface range fastethernet0/1-5

    Switch(config-if-range)#switchport access vlan 10

    Switch(config-if-range)#exit

    Switch(config)#interface range fastethernet0/6-10

    Switch(config-if-range)#switchport access vlan 20

    Switch(config-if-range)#exit

    Switch(config)#interface gigabitethernet1/1

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan 10,20

    Switch(config-if)#exit

    Switch(config)#exit

    pc机上进行测验:

    1.10ping1.30

    PC>ping 192.168.1.30

    Pinging 192.168.1.30 with 32 bytes of data:

    Reply from 192.168.1.30: bytes=32 time=94ms TTL=128

    Reply from 192.168.1.30: bytes=32 time=94ms TTL=128

    可以ping通,虽然在两个交换机上,但是都在vlan10,通过trunk可以连接。

    1.10ping1.40

    PC>ping 192.168.1.40

    Pinging 192.168.1.40 with 32 bytes of data:

    Request timed out.

    不可以ping通,因为属于不同的vlan

    转载于:https://blog.51cto.com/dreamingo/1062748

    展开全文
  • 注意事项 1. WLAN业务配置时,一般是一个管理VLAN,一个或多个业务VLAN。 2. AP自身发出的报文(包括AP DHCP获取地址及与AC交互的CAPWAP控制报文)默认是不带VLAN TAG信息的,一般我们会在与AP直接相连的交换机...

    说明

    分享一些配置过程中的总结,也容易被忽略的地方,比如为什么隧道转发的时候,交换机只需要放行对应的管理VLAN的流量即可,而直接转发则管理流量与业务流量都需要放行等。

    注意事项

    1. WLAN业务配置时,一般是一个管理VLAN,一个或多个业务VLAN。

     

    2. AP自身发出的报文(包括AP DHCP获取地址及与AC交互的CAPWAP控制报文)默认是不带VLAN TAG信息的,一般我们会在与AP直接相连的交换机接口上为AP发出的报文打上管理VLAN的TAG,然后通过网络中VLAN和路由的控制,使报文到达DHCP Server或者AC等。

    3. STA发出的报文也是不带TAG的,业务VLAN TAG由AP给报文打上。

    4. 直接转发时,需保证AP上行接口一直到用户的网管都要通行业务VLAN,接口一般可以配置为hybrid或者trunk,不能配置为access,同时允许管理VLAN和业务VLAN通行。例如(以管理vlan10,业务vlan20为例):
    port link-type trunk
    port trunk pvid vlan 10
    port trunk allow-pass vlan 10 20

    port link-type hybrid
    port hybrid pvid vlan 10
    port hybrid untagged vlan 10
    port hybrid tagged vlan 20

    5. 隧道转发时,由于业务报文被封装在CAPWAP报文中,对外不感知,AP上行接口可仅允许管理VLAN通行(同时允许业务vlan可能会出问题哦),此时接口可以设置为access、trunk或hybrid。例如(以管理vlan10,业务vlan20为例):
    port link-type access
    port default-vlan 10

    port link-type trunk
    port trunk pvid vlan 10
    port trunk allow-pass vlan 10

    port link-type hybrid
    port hybrid pvid vlan 10
    port hybrid untagged vlan 10

    6. 当AC与AP之间是三层组网时,由于CAPWAP默认是广播报文,在AP获取地址后,无法发现AC并进行注册,此时最常用的是使用DHCP的option43将AC的IP地址在AP获取地址的同时传递给AP,之后AP会使用CAPWAP单播报文去发现AC,从而完成AC与AP三层组网下的上线注册。当然还可以使用option15通过DNS信息告知AC的位置。option43的配置方式可以参考DHCP Option 43配置方法 这个帖子。

    7. AP获取IP地址有三种方式:DHCP获取、静态IP设置和PPPOE获取,据我所知DHCP是最多的,静态IP地址次之,PPPOE用的较少,应该主要在运营商市场用。

    8. WDS配置时,在更改AP的bridge角色(root, middle, leaf)后重启AP才会生效,这一点要注意,否则容易造成AP无法注册的问题。

    如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路Blog(其他平台同名),版权归网络之路Blog所有,原创不易,侵权必究,觉得有帮助的,关注、转发、点赞支持下!~。

    展开全文
  • 交换机配置注意事项:(防止自己又给忘记了) 1、查看交换机的版本是否一致,show version,如果不是一个版本或者版本比较低需要升级,这里需要用到 3CDaemon软件做服务器便于文件的上传和下载,这里需要注意的是...

            交换机配置的注意事项:(防止自己又给忘记了)

       1、查看交换机的版本是否一致,show version,如果不是一个版本或者版本比较低需要升级,

    这里需要用到 3CDaemon软件做服务器便于文件的上传和下载,这里需要注意的是上传下载的路径,设置完后,需要上传和下载的文件一定在此处找。

       2、升级的时候可能会隐藏掉后缀名,因此需要连.bin后缀一起复制。

       3、设置开机的ios版本并保存重启交换机。

       4、配置vlan的时候,由于有vtp 此时同步的时候 应该指定相应的IP段,例如:vlan 26 为10.99.16.47 而不是在交换机上配置vlan 1的ip地址了。(vlan1 是便于交换机与调试的笔记本通过console连接后通过tftp服务器上传)

    转载于:https://blog.51cto.com/zhouzongxi/1550289

    展开全文
  • 配置交换机VLAN

    2014-03-01 16:12:23
    配置交换机VLANSwitch#config tSwitch(config)#vlan 2Switch(config-vlan)#exitSwitch(config)#interface rang fastEthernet 0/13 - 24Switch(config-if-range)#switchport mode access Switch(config-if-ran...

    配置跨交换机VLAN

    Switch#config t

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#interface rang fastEthernet 0/13 - 24

    Switch(config-if-range)#switchport mode access

    Switch(config-if-range)#switchport access vlan 2

    Switch(config-if-range)#exit

    Switch(config)#interface gigabitEthernet 1/1

    Switch(config-if)#switchport mode trunk

    Switch#configure t

    Switch(config)#interface range gigabitEthernet 0/1 -2

    Switch(config-if-range)#switchport trunk encapsulation dot1q

    Switch(config-if-range)#switchport mode trunk

    配置跨交换vlan 间通讯

    Switch(config)# ip routing  启用三层路由功能(启用后VLAN之间就能互相访问)

    Switch(config-if)no switchport 让该接口成为三层接口,并且可以在该接口上配置IP地址

    Switch(config)#interface vlan 1

    Switch(config-if)#ip address 192.168.0.1 255.255.255.0

    Switch(config)#interface vlan 2

    Switch(config-if)#ip address 192.168.1.1 255.255.255.0

    转载于:https://blog.51cto.com/xzty1/1365522

    展开全文
  • 交换机基本配置及VLAN配置

    千次阅读 2013-11-17 14:53:02
    4. 熟练掌握单交换机VLAN配置。 5. 掌握多交换机VLAN配置。 【实验须知】 1. 实验室共有五套实验设备,同学分为五个实验组  2. 每个实验组(全部是真实设备): a) 一个实验台:8台计算机
  • 交换机VLAN划分实验

    千次阅读 2018-04-10 21:37:53
    交换机VLAN划分实验一、 实验目的1、 了解VLAN原理;2、 熟练掌握二层交换机VLAN的划分方法;3、 了解如何验证VLAN的划分。二、 应用环境学校实验楼中有两个实验室位于同一楼层,一个是计算机软件实验室,一个...
  • 【实训背景】企业有两个主要部门,技术部和销售部,分别在不同的办公室,为了安全和便于管理对两个部门的...【实训目的】掌握三层交换机基本配置方法、掌握三层交换机VLAN路由的配置方法【技术原理】在交换网络中,...
  • 如图: 1.首先进入系统视图:system-view 进入后<>... 2.然后创建vlan 我这里是批量创建,你也可以单个单个创建...3.配置vlanif接口的ip地址 int vlan * 进入vlanif接口视图 vlan10网段10,vlan20网段20,...
  • 多层交换机VLAN的划分和VLAN间路由

    千次阅读 2018-04-10 21:35:31
    多层交换机VLAN的划分和VLAN间路由一、 实验目的1、 了解VLAN原理;2、 学会使用各种多层交换设备进行VLAN的划分;3、 理解VLAN之间路由的原理和实现方法;二、 应用环境软件实验室的IP地址段是192.168.10.0/24...
  • 1、二层交换机VLAN配置 要求:P1与P3之间可以通信,与P2,P4不通;P2与P4之间可以通信,与P1,P3不通。 1.修改交换机名称; 2.创建VLAN2和VLAN3; 3.将PC1和PC3加入VLAN2,PC2和PC4加入VLAN3; 4....
  • 单台交换机VLAN配置

    千次阅读 2010-06-06 09:39:00
     实验名称: 单台交换机VLAN配置 2. 实验目的: 通过本次实验,掌握单台交换机的虚拟局域网VLAN的配置方法。 3. 背景描述: 在简单的网络环境中,在单个交换机上进行VLAN配置,4台PC...
  • 对于小型企业来说,可以在一台交换机上实现多个Vlan,以满足用户在安全与性能上的需求。不过对于中型以上的企业来说,一台...在这篇文章中,笔者就这个问题展开说明,谈谈跨交换机Vlan配置与管理的要点解析。 ...
  • VLAN(Virtual Local Area Network)即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。VLAN内的主机间可以直接通信,而VLAN间不能直接通信,从而将广播报文限制在...许多VLAN厂商都利用交换机的端
  • 交换机VLAN划分详细手册 -------------------------两年砍柴(2010.08.08) VLAN的含义... 2 VLAN的目的... 3 VLAN的优点... 3 VLAN的标准... 5 VLAN技术简单谈... 5 VLAN的定义及特点... 6 VLAN的分类及优...
  • 二、注意事项 1.必须先创建配置每个sub-vlan、再创建、配置Super-vlan 2.当Super-vlan开启了、VLAN内ARP代理功能时、各个sub-vlan之间可以通信 3.sub-vlan,不用配置vlanif接口地址,而super-vlan配置vlanif的接口...
  • 1.在交换机配置到路由器的默认路由 [R1]ip route-static 0.0.0.0 0 next-hop 2.在路由器配置静态路由到...3.交换机连接路由器接口配置成access,该接口属于与路由器连接的那个网段的vlanvlanif对应的vlan) ...
  • 交换机大家肯定都经常听到过,一般的交换机工作在数据链路层,它能实现vlan划分,隔离广播域的功能。关键词VLAN ,大家一定要把vlan的基本理论理解清楚,还不清楚的请赶紧去百度。交换机用户视图,系统视图,接口...
  • VTP使用的注意事项 1、 VTP使用组播的形式发送通告,每5分钟发送一次,或者当有变化是触发更新。 2、 Client和server都会学习,判断依据是修订编号的高低,所以在加入新的交机之 前,一定要确保新加入交换机的修订...
  • 交换机实现VLAN

    2016-09-29 09:21:03
    交换机实现VLAN。【实验名称】 跨交换机实现VLAN。【实验目的】 掌握如何在交换机上划分基于端口的VLAN、如何给VLAN内添加端口,理解跨交换机之间VLAN的特点。 【背景描述】 假设某企业有两个主要部门:销售部和...
  • 三层交换机配置

    万次阅读 2017-10-18 19:27:57
    交换机上划分VLAN后,VLAN间的计算机就无法通信了。VLAN间的通信需要借助第三层设备,我们可以使用路由器来实现这个功能,如果使用路由器通常会采用单臂路由模式。实践上,VLAN间的路由大多是通过三层交换机实现的...
  • 交换机相同VLAN间通讯

    千次阅读 2018-04-10 21:43:32
    交换机相同VLAN间通讯一、 实验目的1、 了解IEEE802.1q的实现方法,掌握跨二层交换机相同VLAN间通信的调试方法;2、 了解交换机接口的trunk模式和access模式;3、 了解交换机的tagged端口和untagged端口的区别...
  • 一、VLAN划分 VLAN以及VLAN的划分 system-view ##sys ##这个命令的作用是进入系统试图 下面所有的操作都得进入系统试图哦 display vlan ## dis vlan ##显示当前机器的vlan列表 创建VLAN 创建vlanVLAN1 是系统默认...
  • 实验一、交换机基本配置 实验拓扑: 实验步骤: •进入交换机的第一个模式为用户模式,系统提示符为 switch> •switch> Enable !进入特权模式(可以对交换机配置文件进行管理,查看配置信息,进行...
  • 交换机基本配置

    2012-06-23 23:44:03
    一,交换机的基本配置 实验内容:华为中低端交换机常用配置命令 实验目的:掌握中低端交换机的基本命令行 ...注意:第一次进行交换机,路由器配置时必须使用Console本地配置.华为以太网交换机 支持T...
  • 交换机实现vlan

    2016-10-08 15:13:35
    【实验目的】掌握如何在交换机上划分基于端口的VLAN,给VLAN内添加端口,理解跨交换机之间VLAN的特点。【需求分析】通过划分port VLAN来实现交换机的端口隔离,然后使在同一个VLAN里的计算机系统能跨交换机进行相互...
  • 交换机实现VLAN通信

    2016-09-19 19:54:52
    实验目的: 掌握如何在交换机上划分基于端口的VLAN、给VLAN内添加端口,理解跨交换机之间VLAN的特点。...实验原理: VLAN是一种用于隔离广播域的技术,配置VLAN交换机内,相同VLAN内主机之间...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,636
精华内容 654
关键字:

交换机vlan配置注意事项