精华内容
下载资源
问答
  • SISCO交换机VTP配置实例,提供给大家学习共享。
  • 交换机VTP配置(Cisco Packet Tracer) 1.实验目的 理解VTP的3种模式、熟悉VTP的配置。 2.实验拓扑 3.实验步骤 ①先将交换机间的端口工作在trunk模式下。 SW0 SW1 SW2 ②开始配置VTP,SW0配置成Server模式,SW1...

    交换机VTP配置(Cisco Packet Tracer)

    1.实验目的
    理解VTP的3种模式、熟悉VTP的配置。
    2.实验拓扑
    在这里插入图片描述
    3.实验步骤
    ①先将交换机间的端口工作在trunk模式下。
    SW0
    在这里插入图片描述
    SW1
    在这里插入图片描述
    SW2
    在这里插入图片描述
    ②开始配置VTP,SW0配置成Server模式,SW1配置成transparent模式,SW2配置成Client模式。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    ③在SW0上(VTP Server)创建vlan 10和vlan 20,然后在SW1和SW2上查看vlan情况
    在这里插入图片描述
    SW2上学到了SW0创建的vlan10和vlan20.
    在这里插入图片描述
    SW1没有,因为SW1(transparent模式)只转发不学习。
    在这里插入图片描述
    这时再在SW1上创建vlan 30 ,SW0和SW2上没有vlan 30,因为只有client学习server的,server之间也学习,另外,若在SW2(client)上创建一个vlan 40,会报错,client不能创建vlan,自行验证。
    在这里插入图片描述
    ④现在在SW0和SW2上查看CR数。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    SW0和SW2上CR数都是2,因为SW0上创建了vlan 10和vlan 20,两条操作,SW2跟着改,而SW1不改变CR数。
    ⑤在SW0上配置版本2。
    在这里插入图片描述
    在这里插入图片描述
    在SW0上改版本2,SW2也跟着改了,CR数也都+1,SW1上依然不变。
    ⑥VTP pruning,配置VTP修剪,思科模拟器不支持。

    总结:
    ①在配置VTP域前必须先把交换机之间相连的端口配置成trunk模式。
    ②所有的交换机都在同一个domain中,才共同执行vtp;
    ③Mode:分为server、client、transparent三种;
    ④Server模式的switch负责创建、删除、发布;
    ⑤Client模式的switch只学,不管创建、删除、发布等;
    ⑥Transparent模式的switch只负责转VTP消息,不学。

    展开全文
  • CISCO交换机 VTP配置

    千次阅读 2019-01-23 16:13:06
    VTP配置 VTP协议 VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道协议。它是思科私有协议。作用是十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP ...

    VTP配置

    VTP协议

    VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道协议。它是思科私有协议。作用是十几台交换机在企业网中,配置VLAN工作量大,可以使用VTP协议,把一台交换机配置成VTP Server, 其余交换机配置成VTP Client,这样他们可以自动学习到server 上的VLAN 信息。

    VTP协议用途

    VTP有三种工作模式:VTP Server、VTP Client 和 VTP Transparent。新交换机出厂时的默认配置是预配置为VLAN1,VTP 模式为服务器。 一般,一个VTP域内的整个网络只设一个VTP Server。VTP Server维护该VTP域中所有VLAN 信息列表,VTP Server可以建立、删除或修改VLAN,发送并转发相关的通告信息,同步vlan配置,会把配置保存在NVRAM中。VTP Client虽然也维护所有VLAN信息列表,但其VLAN的配置信息是从VTP Server学到的,VTP Client不能建立、删除或修改VLAN,但可以转发通告,同步vlan配置,不保存配置到NVRAM中。VTP Transparent相当于是一项独立的交换机,它不参与VTP工作,不从VTP Server学习VLAN的配置信息,而只拥有本设备上自己维护的VLAN信息。VTP Transparent可以建立、删除和修改本机上的 VLAN信息,同时会转发通告并把配置保存到NVRAM中。

    VTP配置

    在这里插入图片描述

    配置要求:

    1、sw1与sw2 配置vtp domain域ccie,密码为cisco,模式为server,创建vlan 100 ,200
    2、sw3与sw4配置为client模式

    配置代码

    sw1 与 sw2

    Switch(config)#vtp domain ccie  #建立domain域
    Domain name already set to ccie.
    Switch(config)#vtp password cisco #配置密码
    Setting device VLAN database password to cisco
    Switch(config)#vtp mode server  #设定模式
    Switch(config)#int range f0/3-4
    Switch(config-if-range)#sw tr en do
    Switch(config-if-range)#sw mo tr  #将转发端口设置为trunk模式
    Switch(config)#vlan 100
    Switch(config)#vlan 200	
    

    sw3 与 sw4

    Switch(config)#int range f0/1-2
    Switch(config-if-range)#sw mode tr
    Switch(config)#vtp domain ccie
    Domain name already set to ccie.
    Switch(config)#vtp mode client 
    Setting device to VTP CLIENT mode.
    Switch(config)#vtp password cisco
    

    验证

    Switch#show vtp status
    VTP Version                     : 2
    Configuration Revision          : 2
    Maximum VLANs supported locally : 255
    Number of existing VLANs        : 7
    VTP Operating Mode              : Server
    VTP Domain Name                 : ccie
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x90 0xC6 0x74 0xDB 0xB2 0x7A 0x20 0xD3 
    Configuration last modified by 0.0.0.0 at 3-1-93 00:01:35
    Local updater ID is 0.0.0.0 (no valid interface found)
    

    查看sw3上是否同步 vlan信息
    Switch#show vlan brief

    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                    Fa0/23, Fa0/24, Gig0/1, Gig0/2
    100  VLAN0100                         active    
    200  VLAN0200                         active    
    300  VLAN0300                         active    
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    
    

    现网中建议还是只有一台vtp server即可,本实验只为了验证vtp server之间是否能同步vlan信息。

    展开全文
  • Cisco交换机 vtp 配置

    千次阅读 2018-03-30 13:11:41
    先确定核心 交换机是哪台 ,然后再进行分支设置 基本步骤为: 1、配置Server端主交换机,也就是domain管理域; 2、分别在各分支交换机配置为client客户端以及domain管理域(注: 管理域和...设置核心交换机 VTP...

    先确定核心 交换机是哪台 ,然后再进行分支设置

    基本步骤为:

    1、配置Server端主交换机,也就是domain管理域;
    2、分别在各分支交换机上配置为client客户端以及domain管理域(注: 管理域Server端的管理域名字相同)
    3、配置Trunk线,核心交换机分支交换机上都要配置;
    4、建立VLAN与配置VLAN地址;
    5、测试连通性。

    设置核心交换机 VTP DOMAIN

    s1#vlan database   进入VLAN配置模式 ,在全局配置模式下也可以
    
    s1(vlan)#vtp domain COM   设置VTP管理域名称COM 
    
    s1(vlan)#vtp server   设置交换机为服务器模式

    设置分支交换机 VTP DOMAIN

    s2#vlan database   进入VLAN配置模式
    
    s2(vlan)#vtp domain COM   设置VTP管理域名称COM 
    
    s2(vlan)#vtp Client   设置交换机为客户端模式
    s3#vlan database   进入VLAN配置模式
    
    s3(vlan)#vtp domain COM   设置VTP管理域名称COM 
    
    s3(vlan)#vtp Client   设置交换机为客户端模式

    配置中继

    可以采用指定某几个端口 为 vlan的中继,然后允许全部vlan通过

    核心交换机配置

    设置 gigabitEthernet 2/1-2 为trunk接口
    
    s1(config)#interface range gigabitEthernet 2/1-2  
    
    s1(config-if)#switchport 
    
    s1(config-if)#switchport trunk encapsulation isl
    
    s1(config-if)#switchport mode trunk
    

    分支交换机配置

    设置 gigabitEthernet 0/1 为trunk接口
    
    s2(config)#interface gigabitEthernet 0/1
    
    s2(config-if)#switchport mode trunk
    
    s3(config)#interface gigabitEthernet 0/1
    
    s3(config-if)#switchport mode trunk

    已经配置完成,所有vlan动作将统一执行

    创建VLAN

    s1(vlan)#Vlan 10 name COUNT   创建了一个编号为10名字为 COUNT 的VLAN 
    
    s1(vlan)#Vlan 11 name MARK    创建了一个编号为11名字为 MARK 的VLAN

    将分支交换机 端口 划入指定 VLAN

    因核心交换机一般只会接分支交换机 ,所以再核心交换机设定好的vlan 将会自动同步到分支交换机上 , 而 分支交换机只需将每个端口 添加到固定vlan中即可(可以指定模式为只允许pc接入的access)

    s2(config)#interface fastEthernet 0/1       配置端口1
    
    s2(config-if)#switchport access vlan 10     归属COUNT VLAN 
    
    s2(config)#interface fastEthernet 0/2       配置端口2
    
    s2(config-if)#switchport access vlan 11     归属 MARK VLAN
    s3(config)#interface fastEthernet 0/1       配置端口1
    
    s3(config-if)#switchport access vlan 10     归属COUNT VLAN 
    
    s3(config)#interface fastEthernet 0/2       配置端口2
    
    s3(config-if)#switchport access vlan 11     归属MARK VLAN

    配置核心交换机 指定 vlanip

    静态IP分配

    s1(config)#interface vlan 10                                配置 vlan10 的 ip 网关
    
    s1(config-if)#ip address 172.16.58.1 255.255.255.0          VLAN10   接口IP
    
    s1(config)#interface vlan 11                                配置 vlan11 的 ip 网关
    
    s1(config-if)#ip address 172.16.59.1 255.255.255.0          VLAN11   接口IP

    动态IP分配(DHCP) (一般会在路由器上做)

    s1(config)#interface vlan 10 
    
    s1(config-if)#ip address 172.16.58.1 255.255.255.0              VLAN10 接口IP 网关
    
    s1(config-if)#ip helper-address 172.16.1.11                     vlan10 子网 DHCP Server IP
    
    s1(config)#interface vlan 11                                    
    
    s1(config-if)#ip address 172.16.59.1 255.255.255.0              VALN11 接口IP 网关
    
    s1(config-if)#ip helper-address 172.16.1.11                     vlan10 子网 DHCP Server IP
    展开全文
  • cisco 交换机 VTP 配置

    2017-11-13 01:27:00
    VTP有三种工作模式: 1、VTP Server,可以建立、删除或修改VLAN 2、VTP Client, 不可以建立、删除或修改VLAN 3、VTP Transparent可以建立、删除和修改本机上的VLAN信 息,转发VTP消息 ...一、配置VTP 1...

    VTP有三种工作模式:

    1、VTP Server, 可以建立、删除或修改VLAN
    2、VTP Client, 不可以建立、删除或修改VLAN
    3、VTP Transparent 可以建立、删除和修改本机上的 VLAN信 
                   息, 转发VTP消息
    一个网络内可以有多台server,一般只要一台就可以了。
     
    一、配置VTP
    1、server配置
    2、transparent配置
    3、client配置
    好了,vtp已经配置完了,下面验证是否生效。
    先在server上创建vlan2~vlan4.
    然后去client看下,是否有这几个vlan。
     
    然后再去看transparent的vlan信息。
     
    看以看到client模式可以学到到server模式创建的vlan,而transparent模式是学习不到的。
     
    下面再去client创建vlan看是什么反应。可以看到vtp client模式是不能创建vlan的。
     
     
    再看下transparent模式,它可以创建维护自己的vlan
     
    VTP配置命令
     
    进入Vlan数据库
    Switch#vlan database
    建立VTP域
    Switch(vlan)#vtp domain name
    修改交换机vtp的模式
    Switch(vlan)#vtp{client|server|transparent}
    配置vtp密码
    Switch(vlan)#vtp password ……
    配置VTP修剪
    switch (vlan) # vtp pruning
    查看VTP运行状态
    Switch#show vtp status
    查看交换机收到和发出广告的数目
    Switch#show vtp counters
    配置接口为trunk模式
    Switch(config)#interface  f0/1
    Switch(config-if)#switchport mode trunk
    Switch(config-if)#no shutdown
    配置注意:
    VTP domain 一致
    VTP password  一致
    将交换机互联的的交换机端口改称为trunk模式
    可以不配置VTP password
    默认的模式是server模式
     

    本文转自zhaoyun00 51CTO博客,原文链接:http://blog.51cto.com/zhaoyun/631666

    展开全文
  • VTP在系统级管理增加,删除,调整的VLAN,自动地将信息向网络中其它的交换机广播。此外,VTP减小了那些可能导致安全问题的配置。便于管理,只要在vtp server做相应设置,vtp client会自动学习vtp server上的vlan信息...
  • 思科交换机VTP配置

    2015-04-09 12:06:09
    通常情况下,我们需要在整个园区网或者企业网中的一组的交换机中保持VLAN数据库...如果仅凭网络工程师手工配置的话是一个非常大的工作量,并且也不利于日后维护——每一次添加修改或删除VLAN都需要在所有的交换机上...
  • 掌握交换机远程访问配置方法,实现交换机的远程管理 实验环境 Windows 2003 XP3操作系统、cisco模拟器 相关知识 VTP,vlan trunking protocol,是Cisco的专用协议,大多数交换机都支持该协议。VTP负责在VTP域内同步...
  • 上一节我们讲解了vlan配置,本节我们讲解vtp配置。vtp主要用户交换机之间相互学习各自的vlan设置。 1. 准备两台交换机,用交叉线将各自0/1端口连接起来。 2. 配置Switch1的端口: 全局配置模式下,首先输入...
  • 交换机vtp功能配置

    2020-04-08 18:33:26
    在思科的交换机上,可以通过vtp功能的配置,来减少管理员的重复操作。 那么,如何来实现这一过程呢? 第一步,我们需要用一个交换机来用作标杆,也就是把这个交换机设置为服务端模式:server模式 在服务交换机上: ...
  • 在思科模拟器上怎么配置交换机VTP?VTP 被组织成管理域(VTP Domain),VTP 可以分为三种模式:服务器模式(Server),客户机模式(Client),透明模式,下面我们来看看配置方法
  • 配置交换机VTP协议.doc

    2008-08-08 15:53:01
    配置交换机VTP协议.doc
  • 交换机VTP通告配置

    2015-05-05 23:15:47
    VTP是一种消息协议,在交换机间传递vlan信息。在同一个VTP域中的交换机共享他们的vlan信息。------------------------------------------------------------------------------------------------------------------...
  • 当创建vlan时,必须要决定是否使用VTP,使用VTP,能使配置在一个或多个交换机上被改变时,那些改变会自动传送给在同一个VTP域中的其他交换机VTP 被组织成管理域(VTP Domain),相同域中的交换机能共享VLAN 信息。...
  • 5-CONFIG_I: Configured from console by console sA#show vtp status //查看VTP配置信息 VTP Version : 2 //显示设备支持扳本2 Configuration Revision : 2 //目前的配置修改编号 Maximum VLANs supported ...
  • 配置交换机VTP协议

    2017-11-23 00:57:00
    首先我们来认识一下什么是VTP VLAN可以使用Trunk技术跨...在一台或几台交换机配置VLAN的工作量不是很大,但是,在企业网环境中通常由许多的相互连接的交换机组成,因此,要对数量很多的交换机配置VLAN和管理就很...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,052
精华内容 2,020
关键字:

交换机vtp配置