精华内容
下载资源
问答
  • “功能对等”翻译理论--------奈达翻译理论体系的核心
    千次阅读
    2020-12-20 10:16:18

    翻译方法相关论文

    只围绕直译与意译之争,而奈达从《圣经》翻译提出功能对等即读

    者同等反应。

    “功能对等”翻译理论是奈达翻译理论体系的核心

    ,

    是从新的视角提出的新的翻译方法,

    它既有深厚的理论基础

    ,

    也有丰富的实践基础,对翻译理论的进一步完善是一大贡献。

    [关键词]功能对等;奈达翻译;英语论文范文

    尤金·

    A

    ·奈达博士是西方语言学翻译理论学派的代表人物之一。在他的学术生涯中,从事过语言学、

    语义学、人类学、通讯工程学等方面的研究,还从事过《圣经》的翻译工作,精通多国文字,调查过

    100

    多种语言。经过五十多年的翻译实践与理论研究,取得了丰硕的成果。至今他已发表了

    40

    多部

    专著、

    250

    余篇论文。“自八十年代初奈达的理论介绍入中国以来,到现在已经成为当代西方理论中

    被介绍的最早、最多、影响最大的理论。他把信息论与符号学引进了翻译理论,提出了‘动态对等’

    的翻译标准;把现代语言学的最新研究成果应用到翻译理论中来;在翻译史上第一个把社会效益(读

    者反应)原则纳入翻译标准之中。尤其是他的动态对等理论,一举打破中国传统译论中静态分析翻译

    标准的局面,提出了开放式的翻译理论原则,为我们建立新的理论模式找到了正确的方向。奈达在中

    国译界占据非常重要的地位。”

    “奈达的理论贡献,主要在于他帮助创造了一种新姿态对待不同语言

    和文化的气氛,以增进人类相互之间的语言交流和了解。”

    [1]

    翻译作为一项独立的学科,

    首先应回答的问题就是:

    什么是翻译?传统翻译理论侧重语言的表现形式,

    人们往往醉心于处理语言的特殊现象,

    如诗的格律、

    诗韵、

    咬文嚼字、

    句子排比和特殊语法结构等等。

    现代翻译理论侧重读者对译文的反应以及两种反应

    (原文与原作读者、

    译文与译作读者)

    之间的对比。

    奈达指出:

    “所谓翻译,

    就是指从语义到文体在译语中用最贴切而又最自然的对等语再现原语的信息”

    奈达在《翻译理论于实践》一书中解释道,所谓最切近的自然对等,是指意义和语体而言。但在《从

    一种语言到另一种语言》中,奈达又把对等解释为是指功能而言。语言的“功能”是指语言在使用中

    所能发挥的言语作用;不同语言的表达形式必然不同,不是语音语法不同就是表达习惯不同,然而他

    们却可以具有彼此相同或相似的功能。

    奈达所强调的是“对等”“、信息”“、意义”和“风格”,奈达从语义学和信息论出发,强调翻译

    的交际功能,正如他自己所说“:翻译就是交际”,目的是要寻求原语和接受语的“对等”。他所说

    的“信息”包括“意义”和“风格”,着重于交际层面。他实质上要打破的是传统的翻译标准。他把

    翻译看成是“语际交际”,也就是在用交际学的观点来看问题。交际至少应当是三方的事情:信息源

    点———信息内容———信息受者,

    也就是说话者———语言———听话者。

    奈达注重译文的接受者,

    即读者,而且都对读者进行了分类。奈达根据读者的阅读能力和兴趣把读者分为四类:儿童读者、初

    等文化水平读者、普通成人读者和专家。他曾说过,一些优秀的译者,常常设想有一位典型的译文读

    者代表就坐在写字台的对面听他们口述译文,或者正在阅读闪现在电脑显示屏上的译文。这样,就好

    像有人正在听着或读着译文,翻译也就不仅仅是寻求词汇和句法的对应过程。运用这种方法,译者就

    可能更自觉地意识到“翻译就是翻译意思”的道理。

    可译性与不可译性是翻译界长期争论的一个问题。

    奈达对不同的

    更多相关内容
  • 功能对等理论的简要介绍及其原则

    千次阅读 2020-12-20 10:16:16
    而后者在前者 范式的指导下, 对翻译过程、 翻译方法等范畴进行描述, 以期得出具有普适的翻译模式 —— 语言学模式。 布拉格学派的创始人雅可布逊( Roman Jakobson )较早注意到翻译问题与普通语言学 理论的...

    翻译思想史表明,

    随着现代语言学的形成与日臻完善,

    20

    世纪中叶以来,

    建立在语言学

    ——

    普通语言学或结构主义语言学基础上的翻译研究获得了长足的发展,

    产生了许多积极的理论

    成果,在翻译研究领域逐步形成了独具

    范式

    的语言学派。由于语言学派的努力,翻译研究

    在学科化进程中迈出了坚实的一步,

    从而也使得翻译研究在很大程度上摆脱了

    经验陈述

    模式而更具有科学的特性。

    多年来,

    国内外学者就翻译的语言学研究取得的成就所作介绍或

    论述,虽说不是汗牛充栋,却也是林林总总,举不胜举,在此就不赘述了。

    然而,在对语言学派的研究文献作详尽的观察之后,我们就会发现,这一学派的翻译研

    究还存在着理论偏向。

    虽然交际理论、

    社会符号学等的引入使得这一理论偏向在一定程度上

    得到修正。比如,纽马克(

    Peter Newmark

    )运用语义学理论分析了思维、言语与翻译的关

    系,阐述了语义翻译与交际翻译的特点,在其成名作《翻译研究途径》中所提出的

    语义翻

    交际翻译

    在理论上与实践上至今仍为人们所引用

    (

    Newmark

    1981

    1998

    )

    但是,

    翻译的语言学研究的偏向始终存在着。

    纵观语言学派研究文献,我们可以将它们分为两类:一类是结构主义语言学家关于翻译

    的论述;

    另一类是以现代语言学理论为基础专门从事翻译问题研究的学者的论述。

    前者立足

    于结构主义语言学自身的研究,

    仅将翻译问题作为语言结构分析的个例或个别途径,

    其有关

    翻译的论述与其说是翻译研究,

    不如说是借助翻译来探索语言研究的方法论;

    而后者在前者

    范式的指导下,

    对翻译过程、

    翻译方法等范畴进行描述,

    以期得出具有普适性的翻译模式

    ——

    语言学模式。

    布拉格学派的创始人雅可布逊(

    Roman Jakobson

    )较早注意到翻译问题与普通语言学

    理论的关系。

    他认为,

    语言符号的意义在于将一种符号翻译为另一种的符号,

    翻译实际上就

    是语符和信息的诠释,

    因此翻译是语言学方法不可分割的组成部分。

    雅可布逊在其著名论文

    《翻译的语言观》中列举了诠释语符的三种方式:语内翻译、语际翻译和符际翻译。其中,

    语际翻译涉及到一般意义上的翻译概念。

    在此雅可布逊意在强调在诠释语言现象时语言学对

    翻译行为的依赖性。

    同样,英国语言学家弗斯(

    J. R. Firth

    )在《语言分析和翻译》一文中详尽地阐述了结合

    翻译进行语言分析的观点。

    弗斯肯定了翻译理论本身在语言学中的地位。

    他认为,

    把翻译作

    为语言分析的一种形式,

    用来阐明语义,

    这具有一定的可行性。

    弗斯指出,

    在英国语言学史

    上马林诺夫斯基首次系统地把翻译用于阐明某些民族话语的意义,并把这种方法称之为

    言分析

    。弗斯提出了

    全面翻译(

    total translation

    )

    的概念,既要全面运用一切可能的手段

    传达意义,

    在语法、

    词汇、

    词的搭配和语境等四个层次上进行语言分析。

    弗斯将翻译的意义

    归纳为:

    其存在这一事实的本身就是对语言理论和语言哲学的挑战;

    语言分析与翻译结合可

    以为语言学家和社会学家提供广阔的研究空间。

    在语言学派翻译研究的第一类文献中,韩礼德(

    M. A. Halliday

    )的观点较为著名。他指

    出句子是翻译的基本单位,

    翻译过程包括三个阶段:

    寻找等值物、

    检验等值物以及调整译语

    结构。

    然而,

    韩礼德对翻译的论述,

    其出发点是外语教学。

    他认为利用母语进行语言对比可

    展开全文
  • 功能对等理论的要简介绍及其原则功能对等理论的简?要介绍及其原则?翻译思想史表明,?随着现代语言学的?形成与日臻完善,?20世纪中叶以来?,建立在语言学—?—普通语言学或结?构主义语言学基础?上的翻译研究获得?了...

    功能对等理论的要简介绍及其原则

    功能对等理论的简?要介绍及其原则?翻译思想史表明,?随着现代语言学的?形成与日臻完善,?20世纪中叶以来?,建立在语言学—?—普通语言学或结?构主义语言学基础?上的翻译研究获得?了长足的发展,产?生了许多积极的理?论成果,在翻译研?究领域逐步形成了?独具“范式”的语?言学派。由于语言?学派的努力,翻译?研究在学科化进程?中迈出了坚实的一?步,从而也使得翻?译研究在很大程度?上摆脱了“经验陈?述”的模式而更具?有科学的特性。多?年来,国内外学者?就翻译的语言学研?究取得的成就所作?介绍或论述,虽说?不是汗牛充栋,却?也是林林总总,举?不胜举,在此就不?赘述了。 ? 然而,在对语言?学派的研究文献作?详尽的观察之后,?我们就会发现,这?一学派的翻译研究?还存在着理论偏向?。虽然交际理论、?社会符号学等的引?入使得这一理论偏?向在一定程度上得?到修正。比如,纽?马克(Peter? Newmark?)运用语义学理论?分析了思维、言语?与翻译的关系,阐?述了语义翻译与交?际翻译的特点,在?其成名作《翻译研?究途径》中所提出?的“语义翻译”与?“交际翻译”在理?论上与实践上至今?仍为人们所引用(?Newmark,?1981,199?8)。但是,翻译?的语言学研究的偏?向始终存在着。? 纵观语言?学派研究文献,我?们可以将它们分为?两类:一类是结构?主义语言学家关于?翻译的论述;另一?类是以现代语言学?理论为基础专门从?事翻译问题研究的?学者的论述。前者?立足于结构主义语?言学自身的研究,?仅将翻译问题作为?语言结构分析的个?例或个别途径,其?有关翻译的论述与?其说是翻译研究,?不如说是借助翻译?来探索语言研究的?方法论;而后者在?前者范式的指导下?,对翻译过程、翻?译方法等范畴进行?描述,以期得出具?有普适性的翻译模?式——语言学模式?。 布拉?格学派的创始人雅?可布逊(Roma?n Jakobs?on)较早注意到?翻译问题与普通语?言学理论的关系。?他认为,语言符号?的意义在于将一种?符号翻译为另一种?的符号,翻译实际?上就是语符和信息?的诠释,因此翻译?是语言学方法不可?分割的组成部分。?雅可布逊在其著名?论文《翻译的语言?观》中列举了诠释?语符的三种方式:?语内翻译、语际翻?译和符际翻译。其?中,语际翻译涉及?到一般意义上的翻?译概念。在此雅可?布逊意在强调在诠?释语言现象时语言?学对翻译行为的依?赖性。 ?同样,英国语言学?家弗斯(J. R?. Firth)?在《语言分析和翻?译》一文中详尽地?阐述了结合翻译进?行语言分析的观点?。弗斯肯定了翻译?理论本身在语言学?中的地位。他认为?,把翻译作为语言?分析的一种形式,?用来阐明语义,这?具有一定的可行性?。弗斯指出,在英?国语言学史上马林?诺夫斯基首次系统?地把翻译用于阐明?某些民族话语的意?义,并把这种方法?称之为“语言分析?”。弗斯提出了“?全面翻译(tot?al trans?lation)”?的概念,既要全面?运用一切可能的手?段传达意义,在语?法、词汇、词的搭?配和语境等四个层?次上进行语言分析?。弗斯将翻译的意?义归纳为:其存在?这一事实的本身就?是对语言理论和语?言哲学的挑战;语?言分析与翻译结合?可以为语言学家和?社会学家提供广阔?的研究空间。? 在语言学派?翻译研究的第一类?文献中,韩礼德(?M. A. Ha?lliday)的?观点较为著名。他?指出句子是翻译的?基本单位,翻译过?程包括三个阶段:?寻找等值物、检验?等值物以及调整译?语结构。然而,韩?礼德对翻译的论述?,其出发点是外语?教学。他认为利用?母语进行语言对比?可以使学生注意到?两种语言的异同,?因为他认为翻译是?一种特殊的语言对?比形式,它包括两?个方面:语际等值?和语法结构的全面?对比。因此,他得?出结论:翻译理论?是普通语言学的重?要组成部分。? 通过上述研?究我们可以发现,?语言学家在讨论翻?译问题时,首先将?翻译研究纳入语言?学理论研究的框架?,以结构主义语言?学的理论与方法来?描述翻译现象。他?们研究翻译的根本?目的在于将翻译研?究作为语言研究的?重要途径。因此,?将翻译研究作为个?例以补证语言学理?论、突出翻译研究?的工具性功能是第?一类翻译研究的共?同特征。 ? 这类翻译研究由?于其语言研究功利?的前设性,直接导?致其研究的理论偏?向——研究的工具?性目的,因而影响?了其分析结论的普?适性,给翻译研究?带来了一定的局限?。海德格尔认为,?前设和前有、前见?一样,是任何解释?的基础,它们一起?构成了理解的前结?构,事物的作为结?构出自理解的前结?构。前设即运用一?个观念来弄清作为?结构。当我们面对?研究对象时,总是?对它预先做出假设?,然后才能把它解?释成“作为”某物?(刘放桐等,19?90

    展开全文
  • BGP以及BGP对等体之间的交互原则

    千次阅读 2021-01-14 10:49:23
    边界网关协议:是一种实现自治系统AS之间的路由可达并选择最佳路由矢量协议。早期发布的三个版本分别是BGP-1(RFC1105)、BGP-2(RFC1163)和BGP-3(RFC1267),1944年开始使用BGP-4(RFC1171),2006年以后单播IPv4网络...

    BGP——边界网关协议

    BGP概述

    边界网关协议:是一种实现自治系统AS之间的路由可达并选择最佳路由矢量性协议。早期发布的三个版本分别是BGP-1(RFC1105)、BGP-2(RFC1163)和BGP-3(RFC1267),1944年开始使用BGP-4(RFC1171),2006年以后单播IPv4网络使用的版本是BGP-4(RFC4271),其他网络使用的版本是MP-BGP(RFC4760)。
    BGP路由协议的特点
    1.BGP能够承载大批量的路由协议,能够支撑大规模的网络。
    2.BGP使用TCP协调一作为其传输层协议(监听号端口为179),提高了协议的可靠性。
    3.BGP是外部路由协议,用来在AS之间传递数据,对稳定性要求非常高,所以用TCP协议的高可靠性来保证BPG协议的稳定性。
    4.BGP的对等体之间必须逻辑联通,并进行TCP连接,用的端口号为179,本地端口任意。
    5.BGP对等体和TGP对等体不同,BG对等体是指使用TCP建立连接的两端,而非与IGP同概念的直连邻居,只要TCP能够建立连接并不一定需要直连。
    6.BGP本身只负责控制路由,数据转发依然靠静态或TGP路由。
    7.BGP支持无类别域间路由CIDR。
    8.路由更新时,BGP只发送更新的路由,大大减少了BGP传播路由所占用的带宽,适用于再internet上传播大量的路由信息。
    9.BGP是一种增强的距离矢量协议,从设计上避免了环路的发生。
    10.AS之间:BGP通过携带AS-Path信息标记途径的AS,带有本地AS号的路由将被丢弃,从而避免了域间产生环路。
    11.AS内部:BGP在AS内学到的路由不会再通告给AS内的BGP邻居,避免了AS内产生环路。
    12.BGP提供了丰富的路由策略,能够对路由实现灵活的过滤和选择。
    13.BGP提供了防止路由振荡的机制,有效提高了interent网络的稳定性。
    14.BGP易于扩展,能够适应新的发展,主要是通过TVB进行扩展。
    BGP分类:按照运行方式分为EBGP和IBGP
    EBGP:运行于不同AS之间的BGP ,为了防止AS之间产生环路,当BGP设备接受IBGP对等体发送的路由时,会将带有本地AS号的路由丢弃。
    IBGP:运行于同一AS内的BGP,为了防止AS内部产生环路,BGP设备不将从IBGP对等体学到的路由通告给其他IBGP对等体,并与所有IBGP对等体建立全连接,为了防止连接数量太多,BGP设计了路由反射器和BGP联盟。
    BGP的路由器号(Router-ID)
    BGP的Router-ID是一个用于标识BGP设备的32位值,通常是IPv4地址的形成,在BGP会话建立时发送OPEN报文中携带,对等体之间建立BGP会话时,每个BGP设备都必须有唯一的Router-ID,否则对等体之间不能建立BGP连接。
    BGP的Router-ID在BGP网络中必须是唯一的,可以采用手工配置,也可以让设备自动选取,缺省情况下,BGP选择设备上的Loopback接口上的IPv4地址作为BGP的Router-ID,如果设备有Loppback接口,系统会选择接口中最大的IP地址作为BGP的Router-ID。

    BGP工作原理
    BGP的报文:BGP对等体之间通过5种报文进行交互,其中keepalive为周期性发送,其余报文为触发式发送。
    OPEN报文:用于协商BGP对等体之间的各项参数,主要包括BGP版本,AS号等信息,建立BGP对等体的连接。
    Update报文:用于对等体之间交换路由信息。连接建立后,有路由需要发送或者路由变化时,发送Update通告对端可达或者撤销路由属性及路由信息。
    Notification报文:用于终端BGP连接。当BGP在运行中发现错误时,发送Notification报文通告BGP对端,随后与之相邻的邻居关系将被关闭。
    Keepalive报文:用于保持BGP连接。定时发送Keepalive报文以保持BGP对等体关系的有效性,响应收到正确的Open报文。
    Router-refresh报文:用于在改变路由策略后软复位BGP路由表请求对等体重新发送路由信息。只有支持路由刷新能力的BGP设备才会接受和响应此报文。
    BGP状态机
    BGP对等体的交互过程中存在6种状态机。
    空闲(Idle)、连接(connect)、活跃(Active)、Open报文以发送(Opensent)、Open报文已确认(Openconfirm)和连接已建立(Established)。
    在BGP对等体建立的过程中,通常可见的3个状态为Idle、Active和Established。
    1.Idle为初始状态,在Idle状态下,BGP拒绝邻居连接请求,只有收到本设备的start事件后,BGP才开始尝试与其他BGP对等体进行TCP连接,并转至connect状态。
    2.在connect状态下,BGP启动连接重传定时器,等待TCP完成连接。
    TCP连接成功:BGP向对等体发送Open报文,并转至opensent状态。
    TCP连接失败:BGP转至Active状态,反复尝试连接。
    连接重传定时器超时:BGP没有收到对等体的响应,则尝试与其他对等体进行TCP连接,停留在connect状态。
    3.在Active状态下,BGP总是在试图建立TCP连接。
    TCP连接成功:BGP向对等体发送open报文,关闭连接重传定时器,转至opensent状态。
    TCP练级失败:BGP停留在Active状态。
    连接重传定时器超时:BGP没有收到对等体响应,则转至connect状态。
    4.在opensent状态下,BGP等待对等体的open报文,并对收到的open报文中的AS号,版本号,认证号等进行检查。
    收到open报文正确:BGP发送keepalive白问,转至openconfirm状态。
    收到open报文错误:发送Notification报文给对等体,并转至Idle状态。
    5.在openconfirm状态下,BGP等待keepalive或Notification报文,如果收到keepalive报文,则转至Established状态,如果收到Notification报文,则转至Idle状态。
    6.在Established状态下,BGP可以和对等体交换Update、keepalive、Route-refresh报文和Notification报文。
    如果收到正确的Update或keepalive报文,那么BGP就认为对端处于正常运行状态,将保持BGP连接。
    如果收到错误的Update或keepalive报文,那么BGP发送Notification报文通知对端,并转至Idle状态。
    如果收到Notification报文,那么BGP转至Idle状态。
    如果说到TCP拆链通知,那么BGP断开连接,转至Idle状态。
    Route-refresh不会改变BGP状态。
    BGP对等体之间的交互原则
    BGP设备将最优路由加入BGP路由表,形成BGP路由,BGP设备与对等体建立邻居关系后,采取以下交互原则:
    从IBGP对等体获得的BGP路由,BGP设备只发送给他的EBGP对等体。
    从EBGP对等体获得的BGP路由,BGP设备发送给他所有EBGP和IBGP对等体。
    当存在多条到达同一目的地址的有效路由时,BGP只将最优路由发送给对等体。
    路由更新时,BGP只发送更新的路由。
    所有对等体发送的路由,BGP设备都会接收。
    所有EBGP对等体在传递过程中下一跳改变。
    所有IBGP对等体在传递过程中下一跳不变。
    默认EBGP传递时TTL值为1.
    默认IBGP传递时TTL值为255.
    *建立对等体注意点:建立TBGP对等体时要让下一跳可达,处于边界的IBGP对等体需要将下一跳指向自己,才能建立IBGP对等体。
    *建立EBGP对等体时,因为EBGP只能传下一跳,因而在建立时,需要修改EBGP多跳的跳数为2以上(默认为1跳)。

    BGP路径属性

    路径属性分类
    公认属性:
    公认必遵:所有的BGP都必须能识别且在Update报文中必须携带。
    公认自决:所有的BGP都必须能识别,但不必须包含在Update报文中携带。
    可选属性:
    可选传递:设备可以不支持该属性,但也应当接受包含该属性的路由并传递给其他对等体。
    可选非传递:设备可以不支持该属性,不识别的BGP进程忽略包含该属性的路由更新,并且不传递给其他对等体。
    BGP选路原则
    1.如果吓一跳不可达,忽略此路由。
    2.Preferred-Value值数值越高越优先,华为私有属性,仅本地有意义。
    3.Local-Preference值最高的路由优先。
    4.聚合路由优先于非聚合路由。
    5.本地手动聚合路由优先于本地自动聚合路由。
    6.本地通过network命令引入的路由的优先级高于import-route命令引入的路由。
    7.AS-Path的长度最短的路径最优。
    8.比较origin属性,IGP优于EGP,EGP优于Incomplete。
    9.选择MED较小的路由。
    10.EBGP路由优于IBGP路由。
    11.BGP优先选择到BGP下一跳的TGP度量值最低的路径。
    当以上全部相同时,为等价路由,可以负载分担(AS-Path必须一致,当负载分担时,以下3条原则无效)。
    12.比较Cluster-list长度,短的优先。
    13.比较Originator-ID,值较小的优先。
    14.比较对等体的IP地址,小的优先。

    BGP实例
    在这里插入图片描述
    配置
    R1

    The device is running!
    
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info-center en
    Info: Information center is disabled.
    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 12.0.0.1 24	
    [Huawei-GigabitEthernet0/0/0]undo shutdown 
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [Huawei-GigabitEthernet0/0/0]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add 23.0.0.1 24	
    [Huawei-GigabitEthernet0/0/1]undo shutdown 
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [Huawei-GigabitEthernet0/0/1]q
    [Huawei]int LoopBack 0
    [Huawei-LoopBack0]ip add 1.1.1.1 32
    [Huawei-LoopBack0]q
    [Huawei]bgp 100
    [Huawei-bgp]router-id 1.1.1.1
    [Huawei-bgp]peer 2.2.2.2 as-number 200	
    [Huawei-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    [Huawei-bgp]peer 2.2.2.2 ebgp-max-hop 2
    [Huawei-bgp]peer 3.3.3.3 as-number 200	
    [Huawei-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    [Huawei-bgp]peer 3.3.3.3 ebgp-max-hop 2
    [Huawei-bgp]q
    [Huawei]ip route-static 2.2.2.2 32 12.0.0.2
    [Huawei]ip route-static 3.3.3.3 32 23.0.0.2
    [Huawei]bgp 100
    [Huawei-bgp]net 1.1.1.1 32
    [Huawei-bgp]net 2.2.2.2 32
    [Huawei-bgp]net 3.3.3.3 32
    

    R2

    The device is running!
    
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 12.0.0.2 24	
    [Huawei-GigabitEthernet0/0/0]undo shutdown 
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [Huawei-GigabitEthernet0/0/0]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add 24.0.0.1 24
    [Huawei-GigabitEthernet0/0/1]undo shutdown 
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [Huawei-GigabitEthernet0/0/1]q	
    [Huawei]int LoopBack 0
    [Huawei-LoopBack0]ip add 2.2.2.2 32
    [Huawei-LoopBack0]q	
    [Huawei]ospf
    [Huawei-ospf-1]a 0	
    [Huawei-ospf-1-area-0.0.0.0]network 24.0.0.0 0.0.0.255
    [Huawei-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
    [Huawei-ospf-1-area-0.0.0.0]q
    [Huawei-ospf-1]q
    [Huawei]bgp 200
    [Huawei-bgp]route-select
    [Huawei-bgp]router-id 2.2.2.2
    [Huawei-bgp]peer 1.1.1.1 as-number 100
    [Huawei-bgp]peer 1.1.1.1 connect-interface LoopBack 0
    [Huawei-bgp]peer 1.1.1.1 ebgp-max-hop 2
    [Huawei-bgp]peer 3.3.3.3 as-number 200	
    [Huawei-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    [Huawei-bgp]peer 3.3.3.3 next-hop-local
    [Huawei-bgp]peer 4.4.4.4 as-number 200
    [Huawei-bgp]peer 4.4.4.4 connect-interface LoopBack 0
    [Huawei-bgp]peer 4.4.4.4 next-hop-local
    [Huawei-bgp]q
    [Huawei]ip route-static 1.1.1.1 32 12.0.0.1
    [Huawei]bgp 200
    [Huawei-bgp]net 1.1.1.1 32
    [Huawei-bgp]net 2.2.2.2 32
    [Huawei-bgp]net 3.3.3.3 32
    [Huawei-bgp]net 4.4.4.4 32
    

    R3

    The device is running!
    
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo in en
    Info: Information center is disabled.
    [Huawei]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add 23.0.0.2 24	
    [Huawei-GigabitEthernet0/0/1]undo shutdown 
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [Huawei-GigabitEthernet0/0/1]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 34.0.0.1 24
    [Huawei-GigabitEthernet0/0/0]undo shutdown 
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [Huawei-GigabitEthernet0/0/0]q
    [Huawei]int LoopBack 0
    [Huawei-LoopBack0]ip add 3.3.3.3 32
    [Huawei-LoopBack0]q
    [Huawei]ospf
    [Huawei-ospf-1]a 0
    [Huawei-ospf-1-area-0.0.0.0]net	
    [Huawei-ospf-1-area-0.0.0.0]network 34.0.0.0 0.0.0.255
    [Huawei-ospf-1-area-0.0.0.0]net	
    [Huawei-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
    [Huawei-ospf-1-area-0.0.0.0]q
    [Huawei-ospf-1]q
    [Huawei]bgp 200
    [Huawei-bgp]router-id 3.3.3.3
    [Huawei-bgp]peer 1.1.1.1 as-number 100	
    [Huawei-bgp]peer 1.1.1.1 connect-interface LoopBack 0
    [Huawei-bgp]peer 1.1.1.1 ebgp-max-hop 2
    [Huawei-bgp]peer 2.2.2.2 as-number 200
    [Huawei-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    [Huawei-bgp]peer 2.2.2.2 next-hop-local
    [Huawei-bgp]peer 4.4.4.4 as-number 200
    [Huawei-bgp]peer 4.4.4.4 connect-interface LoopBack 0
    [Huawei-bgp]peer 4.4.4.4 next-hop-local
    [Huawei-bgp]q
    [Huawei]ip route-static 1.1.1.1 32 23.0.0.1
    [Huawei]bgp 200
    [Huawei-bgp]net 1.1.1.1 32
    [Huawei-bgp]net 2.2.2.2 32
    [Huawei-bgp]net 3.3.3.3 32
    [Huawei-bgp]net 4.4.4.4 32
    

    R4

    The device is running!
    
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info-center en
    Info: Information center is disabled.
    [Huawei]int g0/0/0
    [Huawei-GigabitEthernet0/0/0]ip add 34.0.0.2 24	
    [Huawei-GigabitEthernet0/0/0]undo shutdown 
    Info: Interface GigabitEthernet0/0/0 is not shutdown.
    [Huawei-GigabitEthernet0/0/0]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]ip add 24.0.0.2 24	
    [Huawei-GigabitEthernet0/0/1]undo shutdown 
    Info: Interface GigabitEthernet0/0/1 is not shutdown.
    [Huawei-GigabitEthernet0/0/1]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]ip add 45.0.0.1 24	
    [Huawei-GigabitEthernet0/0/2]undo shutdown 
    Info: Interface GigabitEthernet0/0/2 is not shutdown.
    [Huawei-GigabitEthernet0/0/2]q
    [Huawei]int LoopBack 0
    [Huawei-LoopBack0]ip add 4.4.4.4 32
    [Huawei-LoopBack0]q
    [Huawei]ospf
    [Huawei-ospf-1]a 0
    [Huawei-ospf-1-area-0.0.0.0]network 34.0.0.0 0.0.0.255
    [Huawei-ospf-1-area-0.0.0.0]network 24.0.0.0 0.0.0.255
    [Huawei-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
    [Huawei-ospf-1-area-0.0.0.0]q
    [Huawei-ospf-1]q
    [Huawei]bgp 200
    [Huawei-bgp]router-id 4.4.4.4
    [Huawei-bgp]peer 2.2.2.2 as-number 200
    [Huawei-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    [Huawei-bgp]peer 2.2.2.2 next-hop-local
    [Huawei-bgp]peer 3.3.3.3 as-number 200	
    [Huawei-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    [Huawei-bgp]peer 3.3.3.3 next-hop-local
    [Huawei-bgp]peer 5.5.5.5 as-number 300	
    [Huawei-bgp]peer 5.5.5.5 connect-interface LoopBack 0
    [Huawei-bgp]peer 5.5.5.5 ebgp-max-hop 2
    [Huawei-bgp]q
    [Huawei]ip route-static 5.5.5.5 32 45.0.0.2
    [Huawei]bgp 200
    [Huawei-bgp]net 2.2.2.2 32
    [Huawei-bgp]net 3.3.3.3 32
    [Huawei-bgp]net 4.4.4.4 32
    [Huawei-bgp]net 5.5.5.5 32
    

    R5

    The device is running!
    
    <Huawei>sys	
    <Huawei>system-view 
    Enter system view, return user view with Ctrl+Z.
    [Huawei]undo info-center enable 
    Info: Information center is disabled.
    [Huawei]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]ip add 45.0.0.2 24
    [Huawei-GigabitEthernet0/0/2]undo shutdown 
    Info: Interface GigabitEthernet0/0/2 is not shutdown.
    [Huawei-GigabitEthernet0/0/2]q
    [Huawei]int LoopBack 0
    [Huawei-LoopBack0]ip add 5.5.5.5 32
    [Huawei-LoopBack0]q
    [Huawei]bgp 300
    [Huawei-bgp]peer 4.4.4.4 as-number 200
    [Huawei-bgp]peer 4.4.4.4 connect-interface LoopBack 0
    [Huawei-bgp]peer 4.4.4.4 ebgp-max-hop 2
    [Huawei-bgp]q
    [Huawei]ip route-static 4.4.4.4 32 45.0.0.1
    

    路由学习结果
    R1

    [Huawei]dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 15       Routes : 15       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  Direct  0    0           D   127.0.0.1       LoopBack0
            2.2.2.2/32  Static  60   0          RD   12.0.0.2        GigabitEthernet
    0/0/0
            3.3.3.3/32  Static  60   0          RD   23.0.0.2        GigabitEthernet
    0/0/1
            4.4.4.4/32  EBGP    255  1          RD   2.2.2.2         GigabitEthernet
    0/0/0
            5.5.5.5/32  EBGP    255  0          RD   2.2.2.2         GigabitEthernet
    0/0/0
           12.0.0.0/24  Direct  0    0           D   12.0.0.1        GigabitEthernet
    0/0/0
           12.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
         12.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           23.0.0.0/24  Direct  0    0           D   23.0.0.1        GigabitEthernet
    0/0/1
           23.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
         23.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    

    R2

    [Huawei]dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 16       Routes : 16       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  Static  60   0          RD   12.0.0.1        GigabitEthernet
    0/0/0
            2.2.2.2/32  Direct  0    0           D   127.0.0.1       LoopBack0
            3.3.3.3/32  OSPF    10   2           D   24.0.0.2        GigabitEthernet
    0/0/1
            4.4.4.4/32  OSPF    10   1           D   24.0.0.2        GigabitEthernet
    0/0/1
            5.5.5.5/32  IBGP    255  0          RD   4.4.4.4         GigabitEthernet
    0/0/1
           12.0.0.0/24  Direct  0    0           D   12.0.0.2        GigabitEthernet
    0/0/0
           12.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
         12.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           24.0.0.0/24  Direct  0    0           D   24.0.0.1        GigabitEthernet
    0/0/1
           24.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
         24.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           34.0.0.0/24  OSPF    10   2           D   24.0.0.2        GigabitEthernet
    0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    

    R3

    [Huawei]dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 16       Routes : 16       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  Static  60   0          RD   23.0.0.1        GigabitEthernet
    0/0/1
            2.2.2.2/32  OSPF    10   2           D   34.0.0.2        GigabitEthernet
    0/0/0
            3.3.3.3/32  Direct  0    0           D   127.0.0.1       LoopBack0
            4.4.4.4/32  OSPF    10   1           D   34.0.0.2        GigabitEthernet
    0/0/0
            5.5.5.5/32  IBGP    255  0          RD   4.4.4.4         GigabitEthernet
    0/0/0
           23.0.0.0/24  Direct  0    0           D   23.0.0.2        GigabitEthernet
    0/0/1
           23.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
         23.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           24.0.0.0/24  OSPF    10   2           D   34.0.0.2        GigabitEthernet
    0/0/0
           34.0.0.0/24  Direct  0    0           D   34.0.0.1        GigabitEthernet
    0/0/0
           34.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
         34.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    

    R4

    [Huawei]dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 18       Routes : 18       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  IBGP    255  0          RD   2.2.2.2         GigabitEthernet
    0/0/1
            2.2.2.2/32  OSPF    10   1           D   24.0.0.1        GigabitEthernet
    0/0/1
            3.3.3.3/32  OSPF    10   1           D   34.0.0.1        GigabitEthernet
    0/0/0
            4.4.4.4/32  Direct  0    0           D   127.0.0.1       LoopBack0
            5.5.5.5/32  Static  60   0          RD   45.0.0.2        GigabitEthernet
    0/0/2
           24.0.0.0/24  Direct  0    0           D   24.0.0.2        GigabitEthernet
    0/0/1
           24.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
         24.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           34.0.0.0/24  Direct  0    0           D   34.0.0.2        GigabitEthernet
    0/0/0
           34.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
         34.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           45.0.0.0/24  Direct  0    0           D   45.0.0.1        GigabitEthernet
    0/0/2
           45.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/2
         45.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/2
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    

    R5

    [Huawei]dis ip routing-table 
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 12       Routes : 12       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  EBGP    255  0          RD   4.4.4.4         GigabitEthernet
    0/0/2
            2.2.2.2/32  EBGP    255  1          RD   4.4.4.4         GigabitEthernet
    0/0/2
            3.3.3.3/32  EBGP    255  1          RD   4.4.4.4         GigabitEthernet
    0/0/2
            4.4.4.4/32  Static  60   0          RD   45.0.0.1        GigabitEthernet
    0/0/2
            5.5.5.5/32  Direct  0    0           D   127.0.0.1       LoopBack0
           45.0.0.0/24  Direct  0    0           D   45.0.0.2        GigabitEthernet
    0/0/2
           45.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/2
         45.0.0.255/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/2
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    
    展开全文
  • 2. 综合布线是对传统布线技术的进一步发展,与传统布线相比有着明显的优势,具体表现在 开放 、 灵活 、可靠 、先进 、 兼容 等几个方面。3. 压线钳具有种用途。4. EIA/TIA的布线标准中规定了两种双绞线的...
  • 互联网的成功和端到端原则

    千次阅读 2022-03-24 18:02:51
    互联网之所以发展迅速,得益于端到端原则: 保持一个极简的核心,将复杂留在端。 道理很简单。 核心若不极简,互联网将无法适应变化。随着接入节点的增加,核心的负担将指数增加,互联网规模终将停滞。 全文完。...
  • 软件开发编程规范及原则

    万次阅读 2016-12-07 22:05:54
    包含在一个include.h文件中,然后在每一个.c源代码文件中包含include.h头文件,这样做可以让代码看上去简洁,但实际忽视了编译效率问题,而且代码的可移植也不好。   原则 : A. 头文件中适合放置接口的...
  • 关于互联网技术的原则Rule很多、Law很少,大多都是经验的。在架构设计过程中大家都容易互喷,因为极少人思考Law。KISS、SOLID、高内低耦是经典的三大原则,没有经过反思和批判的学习,是不彻底的,是一知半解的。...
  • > [场景是这样的: >...> 服务实例注册信息(例:多... 三个原则性上 ,Eureka 只选择里 A原则(一致(Consistency)),这样的化 没有两位两个的夹持对比下 所做的就不是 ‘强一致’ 而是定义的 ‘最终
  • 对等角速度模型和等角加速度模型的状态方程输入矩阵G(忌)进行了计算。根据Kalman预测曲线与实测曲线误差的标准方差最小原则,确定了两模型的状态噪声与测试噪声的方差比值Q/R,并优化了两模型适合经纬仪的比值Q/R。...
  • 通过求解非线性广义相对论方程,我们提出了非相对论物质流适时超曲面上物质密度波动的三阶解析解。 适当时间的超曲面提供了... 通过适当的坐标缩放,我们证明了对等原则得到了遵守,并且相对论效应在大范围内消失了。
  • 一、从集中式到分布式 1、集中式 ... 2、对等性 3、并发性 4、缺乏全球时钟(由于分布式系统由一些列的空间上任意分布的多个进程组成,具有分布性,很难定义两个事件究竟是谁先谁后) 5、故障总是
  • 常用的保留UDP端口号有DNS 53、BootP 67(server)/ 68(client)、TFTP 69、SNMP 161、LDP646、TDP711等 三、RIP 四个计时器 1.update更新计时器:每30S一次的周期更新(15%-5S的偏移——25S到30S之间) 2....
  • 长期以来,戏剧翻译被等同于其他文学形式的翻译,“对等”“忠实”“信”成为衡量其成功与否的唯一标准。 然而,戏剧不同于诗歌和小说等文学形式,它更加关注言语传递的即时、舞台表演和交际。因此,一部戏剧 译本...
  • 有许多技术可用于服务器优化,方法是通过在对等服务器之间分配负载来增强可用。 据我们所知,没有人在整个OSI模型中实现这种拆分架构。 在本文中,我们介绍了多层拆分协议(MLSP),一种跨OSI模型吐出应用程序或...
  • 分析了这类协议的设计目标,将协议的安全归纳为对协议中所建立会话密钥的四点需求:保密、真实、新鲜和一致, 并进一步通过实例说明了不满足这些需求的协议可能遭受到的攻击。最后给出对于设计这类协议的...
  • 书籍《P2P对等网络原理与应用》笔记:1. DHT算法:DHT(Distributed Hash Table,分布式哈希表)类似Tracker的根据种子特征码返回种子信息的网络。DHT全称叫分布式哈希表(Distributed Hash Table),是一种分布式存储...
  • 所谓“无规矩,不成方圆”,那就在全面学习设计模式时,先涉及个原则。 单一职责原则 开放-封闭原则 依赖倒转原则 迪米特法则
  • 基于诚实反馈是节点间交互主流的原则,采用最大密度方法,构建滑动窗口定位主流评价值聚类中心。用评价值拟合度、交互活跃度和交易数等参数,确定评价值的可信度,使全局信任度真实反映节点服务或交易质量,惩罚虚假...
  • 提出了一种用于文件共享系统的激励机制,将节点享受服务的能力和提供服务的能力进行区分,贡献节点享有更高的服务优先级,而搭便车节点受...仿真实验表明,该激励机制充分体现了公平性原则,同时大大提高了下载成功率。
  • 里氏替换原则:一个软件实体如果使用的是一个父类的话,那么他一定适用于其子类。 用代码来讲就是:如果程序中的某段代码调用了某个父类对象,那么将这个父类替换为其子类,则程序的行为应该没有变化。 即:子类型...
  • 突出重点,抓主要矛盾原则 分级,分类原则 向目标倾斜原则 责任结果导向 你有能力,但没有完成责任,没有达到服务要求。我们就不能给予肯定,给予你高待遇。 以正向考核为主,但要抓住关键事件的逆向考事,事...
  •  1、项目组织特征 (1)组织目标单一,工作内容庞杂 (2)项目组织是一个临时机构 (3)项目组织应精干高效 (4)项目经理是项目组织的关键 2、项目组织设置原则 (1)有效幅度管理原则 (2)权责对等原则...
  • 开好迭代回顾会议的5个原则

    千次阅读 2020-10-05 17:45:21
    在很多敏捷团队中,最容易忽略该活动,很多团队没有意识到该活动的重要。为什么呢?最主要的原因是开了会议,没有实际效果,大家认为没用,所以也就不开了。实践中,在开迭代回顾会议时常犯的错误有: ...
  • ) :优先级最低 BPG路由反射器 在As内部,为保证IBGP对等体之间的连通,需要在IBGP对等体之间建立全连接关系。当TBGP对等体数目很多时建立全连接网络的开销很大。使用路由反射器RR (Route Reflector)可以解决这...
  • 只有那些成功通过输出策略引擎的路由,才会被安装到输出RIB (Adj-RIB-Out)中 输入策略引擎、输出策略引擎通过配置route-policy然后在peer相应邻居时调用 五、BGP通告原则 四条通告原则 1.只将最优路由传递给邻居 ...
  • 高效持续交付的7大原则

    千次阅读 2017-06-09 22:52:14
    持续交付不仅仅是一个很好的想法,就像每一个使用敏捷方法的...它很重要,然而,不论是你正在将他引入到你的组织当中,还是想要优化你的持续交付方法,你都需要使用正确的持续集成原则,来保持你的素质更快和更有效率。
  • 分布式一致协议Raft & Paxos 简单 v.s. 完美
  • 该解决方案应适应并包含最终的一致概念(稍后详细介绍)。 Due to the granularity of services, there might be many requests. It can be inefficient and increase latency. Although there are ways to reduce ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 16,405
精华内容 6,562
关键字:

对等性原则