精华内容
下载资源
问答
  • 目录 一、前言 二、基础知识 2.2 spanning tree--生成树 2.2.1使用场景: ... 为了更加了解交换机的技术,那么今天我们将交换机的三种常见的基础模式进行研究。...2.1交换机三种工作模式原理 ...

    目录

     

    一、前言

    二、基础知识

    2.2  spanning tree--生成树

          2.2.1使用场景:

          2.2.2环路会引起的问题

          2.2.3STP的作用

         2.2.4BPDU报文

        2.2.5生成树算法的步骤

    三、如何选择根网桥

    四、如何选择根端口

    五、如何选择指定端口


    一、前言

         为了更加了解交换机的技术,那么今天我们将交换机的三种常见的基础模式进行研究。

    二、基础知识

    2.1交换机的三种工作模式原理

    •        access

              接收:如果是无标记帧,则会打上接口的缺省vlan,接收
                        如果是标记帧,对比缺省vlanid,相同接收,不相同丢弃

              发送:对比接口vlanid,如果不相同不能从该接口发送

                         如果相同,就删除标签,发送出去。

    •      trunk

             接收:如果是无标记帧,则会打上接口的缺省vlanid,接收
                       如果是标记帧,检查允许列表,允许则接收,不允许就丢弃

              发送:如果标记帧的vlanid与接口pvid相同,并且在允许列表中,则标记帧的tag被删除发送
                        如果标记帧的vlanid与接口pvid不同,并且在允许列表中,则标记帧带原tag发送

    •   hybrid

                接收:如果是无标记帧,接收并打上接口的缺省vlanid,接收
                          如果是标记帧,检查允许列表,允许则接收,不允许就丢弃

                发送:如果以太帧在untagged或tagged列表,则表示可以从此端口通过,
                          对于untagged列表中的以太帧,在发送的时候去掉vlan标签后再从端口发送出去;
                         对于tagged列表中的以太帧,在发送的时候带着vlan标签从端口发送出去。
                        如果以太帧不在untagged或tagged列表,表示不从此端口通过。

    2.2  spanning tree--生成树

          2.2.1使用场景:
     

             为了提高网络可好性,交换网络中通常会使用冗余链路,然而,冗余链路会交给交换网络带来环路风险,并导致广播风暴以及MAC地址表不稳定等问题,进而会影响到用户的通信质量。生成树协议STP(spanning tree protocol)可以在提高可靠性的同时用能避免环路带来的各种问题。

          2.2.2环路会引起的问题
     

            (1)环路会引起广播风暴,网络中的主机会收到重复数据帧。
            (2)环路会引起MAC地址表震荡。

          2.2.3STP的作用
     

            STP通过阻塞端口来消除环路,并能够实现链路备份的目的。(防止环路)
            运行该协议的交换机可以自动找出导致环路的链路,并将其临时阻塞,再链路发生故障的时候,再自动恢复阻塞链路,保障网络既有冗余有无环运行。

         2.2.4BPDU报文


             STP需要网络设备相互交换消息来检测桥接环路,该消息称为网桥协议数据单元BPDU。STP之所以能够良好的工作并构建一个无环的网络,是依赖于BPDU报文的泛洪,并根据报文中相关字段计算的结果


    2.2.5生成树算法的步骤

     

    1. 选择根网桥 
    2. 每个非根网桥上选择根端口(RP)
    3. 在每条链路上都要选择一个指定端口(DP)
    4. 阻塞既不是根端口又不是指定端口的端口(AP)

    三、如何选择根网桥

    • 依据:网桥ID(BID)
    • 网桥ID=网桥优先级+网桥的MAC地址
    • 网桥优先级的取值范围:0-65535
    • 默认值:32768   
    • 优先比较优先级,选最小
    • 当优先级相等的情况下,选MAC地址小的


    四、如何选择根端口

    • 到根桥最低的根路径成本
    • 某个网桥到达根网桥的中间所有线路的路径成本之和
    • 用来代表一条线路带宽的大小
    • 直连的网桥ID最小的
    • 对端端口ID(PID)最小的
    • 端口ID=端口优先级+端口编号
    • 端口优先级:0-255  默认值:128


    五、如何选择指定端口

    • 根网桥上的每个端口都是指定端口,都不会被阻塞
    • 比较到达根桥的RPC(Root Path Cost),越小越优。
    • 比较BPDU包发送者的BID,越小越优。
    • 比较BPDU包发送者的PID,越小越优。
    • 比较BPDU包接收者的PID,越小越优。
    • 总结:stp算法中的比较都是选小的
       

    六、实验

    (1)实验一

    解题思路:

            1.查找根网桥,对比三台交换机的优先级及网卡,发现三个交换机的优先级一致。

              

             网卡信息对比,sw1最小,根据越小越优先原则,则sw1作为根网桥。

            2.找根端口,根据第二条原则,开销越小则作为根端口,则sw3如图位置为根端口、sw2如图位置为根端口

    u

    3.找指定端口和阻塞端口,根据开销越小,越优先原则,如图

     

    (2)实验二

    操作步骤

    (1)配置对应的PCIP和网关

    (2)在sw1和sw2中配置链路聚合、设定vlan、设定Tag 和untag

    3.配置路由器的链接聚合

    展开全文
  • 一、交换机的行为 ...Huawei交换机存在三种工作模式 Access,接入模式 Trunk,中继模式 Hybrid,混杂模式 接入模式 使用场景:常用于连接PC、终端设备、路由器等不能识别VLAN标记的流量

    一、交换机的行为

    交换机的行为无非分为接收数据、发送数据;任何流量在一个交换机内部转发时必须携带标签;PC接收到的流量必须为正常流量,不识别携带标签的流量。

    接收数据
    流量进入一个接口时,先看该流量是否携带标签。
    发送数据
    流量从一个接口出时,查询该接口的vlan允许列表,关注是否标记。

    Huawei交换机存在三种工作模式

    • Access,接入模式

    • Trunk,中继模式

    • Hybrid,混杂模式

    接入模式
    使用场景:常用于连接PC、终端设备、路由器等不能识别VLAN标记的流量的

    中继模式
    使用场景:常用于两台交换机之间相连的链路,用于承载所有的VLAN流量的

    混杂模式
    使用场景:任意场景,但Hybrid的灵活性很高不易于配置

    Access端口只属于1个VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;
    Hybrid端口和Trunk端口属于多个VLAN,所以需要设置缺省VLAN ID。缺省情况下,Hybrid端口和Trunk端口的缺省VLAN为VLAN 1

    Tag和Untag,tag是指vlan的标签,即vlan的id,用于指名数据包属于那个vlan,untag指数据包不属于任何vlan,没有vlan标记pvid,即端口vlan id号。


    access
    接收:如果是无标记帧,则会打上接口的缺省vlan,接收
              如果是标记帧,对比缺省vlanid,相同接收,不相同丢弃

    发送:对比接口vlanid,如果不相同不能从该接口发送

    trunk
    接收:如果是无标记帧,则会打上接口的缺省vlanid,接收
              如果是标记帧,检查允许列表,允许则接收,不允许就丢弃

    发送:如果标记帧的vlanid与接口pvid相同,并且在允许列表中,则标记帧的tag被删除发送
              如果标记帧的vlanid与接口pvid不同,并且在允许列表中,则标记帧带原tag发送

    hybrid
    接收:如果是无标记帧,接收并打上接口的缺省vlanid,接收
              如果是标记帧,检查允许列表(允许列表是tag和untag),允许则接收,不允许就丢弃

    发送:如果以太帧在untagged或tagged列表,则表示可以从此端口通过,
    对于untagged列表中的以太帧,在发送的时候去掉vlan标签后再从端口发送出去;
    对于tagged列表中的以太帧,在发送的时候带着vlan标签从端口发送出去。
    如果以太帧不在untagged或tagged列表,表示不从此端口通过。

    hybrid接口
    华为默认接口,翻译过来就是混杂接口,因为它结合了access和trunk的功能


    主要配置


    int e0/0/1  //进接口

    port link hybrid  //配置接口模式为hybrid(华为交换机默认为hybrid)

    port hybrid pvid vlan 2 //配置接口pvid (vlan1为接口默认加入的,可以不用配置)

    Port hybrid untagged vlan 1 2 //配置脱标签的vlan号

    port hybrid tagged vlan 1 2 //配置携带标签的vlan号

    实验

    下面进行配置(因为是同网段,所以用不到路由器):

    ping一下可以发现满足要求

     

    stp生成树协议STP(spanning tree protocol)


    为了提高网络可好性,交换网络中通常会使用冗余链路,然而,冗余链路会交给交换网络带来环路风险,并导致广播风暴以及MAC地址表不稳定等问题,进而会影响到用户的通信质量。生成树协议STP(spanning tree protocol)可以在提高可靠性的同时用能避免环路带来的各种问题。

    环路会引起的问题
    (1)环路会引起广播风暴,网络中的主机会收到重复数据帧。
    (2)环路会引起MAC地址表震荡。

    STP的作用
    STP通过阻塞端口来消除环路,并能够实现链路备份的目的。(防止环路)
    运行该协议的交换机可以自动找出导致环路的链路,并将其临时阻塞,再链路发生故障的时候,再自动恢复阻塞链路,保障网络既有冗余有无环运行。

    BPDU报文
    STP需要网络设备相互交换消息来检测桥接环路,该消息称为网桥协议数据单元BPDU。STP之所以能够良好的工作并构建一个无环的网络,是依赖于BPDU报文的泛洪,并根据报文中相关字段计算的结果


    生成树算法的步骤
    1、选择根网桥 
    2、每个非根网桥上选择根端口(RP)
    3、在每条链路上都要选择一个指定端口(DP)
    4、阻塞既不是根端口又不是指定端口的端口(AP)

    一、如何选择根网桥
    依据:网桥ID(BID)
    网桥ID=网桥优先级+网桥的MAC地址
    网桥优先级的取值范围:0-65535
    默认值:32768   

    优先比较优先级,选最小
    当优先级相等的情况下,选MAC地址小的


    二、何选择根端口?
    1、到根桥最低的根路径成本
    某个网桥到达根网桥的中间所有线路的路径成本之和
    用来代表一条线路带宽的大小
    2、直连的网桥ID最小的
    3、对端端口ID(PID)最小的
    端口ID=端口优先级+端口编号
    端口优先级:0-255  默认值:128


    三、如何选择指定端口?
    根网桥上的每个端口都是指定端口,都不会被阻塞
    1、比较到达根桥的RPC(Root Path Cost),越小越优。
    2、比较BPDU包发送者的BID,越小越优。
    3、比较BPDU包发送者的PID,越小越优。
    4、比较BPDU包接收者的PID,越小越优。

     

    题目

    首先网桥优先级都一样,MAC地址最小的是sw1,所以sw1为根网桥,它的两个端口为指定端口,然后根据路径开销最小最优先可以确定sw2和sw3的根端口分别为上面的端口和下面的端口,最后可以判断出指定端口sw2下面那个端口及阻塞端口sw3上面那个端口。

    展开全文
  • 交换机三种工作模式及实验Access(接入模式)Trunk(中继模式)Hybrid(混合模式)实验1实验2 Access(接入模式) 接收:当接收到一个无标记帧时,打上自己的pvid标签并接收,当接收到一个有标记的帧的时候,对比...

    Access(接入模式)

    接收:当接收到一个无标记帧时,打上自己的pvid标签并接收,当接收到一个有标记的帧的时候,对比自己的pvid,如果相同则接收,不同则丢弃
    发送:对比vlanid是否恨自己的pvid,相同就剥离vlanid发送,不同就丢弃

    Trunk(中继模式)

    接收:当接收到一个无标记帧时,打上自己的pvid标签并接收,当接收到一个有标记的帧的时候,对比允许列表,如果相同则接收,不同则丢弃
    发送:对比vlanid是否跟自己的pvid,相同就剥离vlanid发送,不同就携带原来vlanid发送

    Hybrid(混合模式)

    接收:当接收到一个无标记帧时,查询允许列表,如果有,就打自己的pvid接收,无就不接收,当收到一个有标记的帧时,查询允许列表,有就接收,无就丢弃
    发送:对比tagged和untagged表,如果是tagged,就带标签转发,如果是untagged就不带标签转发,如果不在表中就直接丢弃

    tagged表:带标签的表
    untagged表:不带标签的表

    实验1

    在这里插入图片描述

    在sw1上配置与主机连接的端口配置,并设置不带标签

    [sw1]vlan b  10 2 3
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]dis vl
    The total number of vlans is : 4
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(U)     
                    Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    
    2    common  
    3    common  
    10   common  
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    10   enable  default       enable  disable    VLAN 0010                         
    [sw1]
    
    [sw1-Ethernet0/0/1]port hybrid pvid vlan 1
    [sw1-Ethernet0/0/1]int e0/
    Apr  8 2021 18:30:48-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 6, the c
    hange loop count is 0, and the maximum number of records is 4095.0/2
    [sw1-Ethernet0/0/2]int e0/0/1
    [sw1-Ethernet0/0/1]port hybrid untagged vl 1 2
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port hybrid  untagged 
    Apr  8 2021 18:32:38-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 8, the c
    hange loop count is 0, and the maximum number of records is 4095.vl 1 2
    [sw1-Ethernet0/0/2]int e0/
    Apr  8 2021 18:32:48-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 9, the c
    hange loop count is 0, and the maximum number of records is 4095.0/3
    [sw1-Ethernet0/0/3]port hybrid  pvid v 10
    [sw1-Ethernet0/0/3]port hybrid untagged  vl 3 10
    Apr  8 2021 18:33:18-08:00 sw1 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 11, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw1-Ethernet0/0/3]
    
    

    在sw1的e0/0/4口上设置带标签的和不带标签的

    [sw1-Ethernet0/0/3]int e0/0/4
    [sw1-Ethernet0/0/4]port hybrid pvid vl 1
    [sw1-Ethernet0/0/4]
    [sw1-Ethernet0/0/4]port hybrid untagged vl 1 2
    [sw1-Ethernet0/0/4]port hybrid  tagged vl 3 10
    [sw1-Ethernet0/0/4]dis cu
    #
    sysname sw1
    #
    vlan batch 2 to 3 10
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port hybrid untagged vlan 2
    #
    interface Ethernet0/0/2
     port hybrid untagged vlan 2
    #
    interface Ethernet0/0/3
     port hybrid pvid vlan 10
     port hybrid untagged vlan 3 10
    #
    interface Ethernet0/0/4
     port hybrid tagged vlan 3 10
     port hybrid untagged vlan 2
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
    user-interface vty 0 4
    #
    return
    [sw1-Ethernet0/0/4]
    

    sw2上同样配置

    [sw2]vlan ba 2 3 10
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2]dis vl
    The total number of vlans is : 4
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(D)     
                    Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    
    2    common  
    3    common  
    10   common  
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    10   enable  default       enable  disable    VLAN 0010                         
    [sw2]int e0/0/1
    [sw2-Ethernet0/0/1]
    [sw2-Ethernet0/0/1]port hybrid p vl 2
    [sw2-Ethernet0/0/1]port hybrid untagged vl 1 2
    [sw2-Ethernet0/0/1]int 
    Apr  8 2021 18:35:38-08:00 sw2 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 7, the c
    hange loop count is 0, and the maximum number of records is 4095.e0/0/2
    [sw2-Ethernet0/0/2]port hybrid  p vl 3
    [sw2-Ethernet0/0/2]port hybrid untagged 
    Apr  8 2021 18:35:58-08:00 sw2 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 8, the c
    hange loop count is 0, and the maximum number of records is 4095.vl 3 10
    [sw2-Ethernet0/0/2]int e0/0/3
    [sw2-Ethernet0/0/3]port h p vl 1
    [sw2-Ethernet0/0/3]port hybrid  untagged vl 1 2
    Apr  8 2021 18:36:38-08:00 sw2 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 10, the 
    change loop count is 0, and the maximum number of records is 4095.
    [sw2-Ethernet0/0/3]port hybrid  tagged 
    Apr  8 2021 18:36:48-08:00 sw2 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25
    .191.3.1 configurations have been changed. The current change number is 11, the 
    change loop count is 0, and the maximum number of records is 4095.vl 3 10
    [sw2-Ethernet0/0/3]
    [sw2-Ethernet0/0/3]dis cu
    #
    sysname sw2
    #
    vlan batch 2 to 3 10
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port hybrid pvid vlan 2
     port hybrid untagged vlan 2
    #
    interface Ethernet0/0/2
     port hybrid pvid vlan 3
     port hybrid untagged vlan 3 10
    #
    interface Ethernet0/0/3
     port hybrid tagged vlan 3 10
     port hybrid untagged vlan 2
    #
    interface Ethernet0/0/4
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
    user-interface vty 0 4
    #
    return
    [sw2-Ethernet0/0/3] 
    

    此时pc1,pc2,pc5能互通
    在这里插入图片描述
    pc1不能与pc3,pc5通信
    在这里插入图片描述
    pc3与pc5互通
    在这里插入图片描述
    pc3不能与pc1,pc2,pc4互通
    在这里插入图片描述
    在这里插入图片描述

    实验2

    在这里插入图片描述
    sw1上配置

    [sw1]vlan ba 10 20 30
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]int e0/0/2
    [sw1-Ethernet0/0/2]p h p v 10
    [sw1-Ethernet0/0/2]p h u vl 10 30
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]p h p v 20
    [sw1-Ethernet0/0/3]p h u v 20 30
    [sw1-Ethernet0/0/3]int e0/0/4
    [sw1-Ethernet0/0/4]p h t vl 10 20 30
    <sw1>dis cu
    #
    sysname sw1
    #
    undo info-center enable
    #
    vlan batch 10 20 30
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
    #
    interface Ethernet0/0/2
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10 30
    #
    interface Ethernet0/0/3
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20 30
    #
    interface Ethernet0/0/4
     port hybrid tagged vlan 10 20 30
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
    user-interface vty 0 4
    #
    return
    <sw1>
    

    sw2上配置

    [sw2]vlan ba 10 20 30
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2]
    [sw2]int e0/0/1
    [sw2-Ethernet0/0/1]
    [sw2-Ethernet0/0/1]p h t vl 10 20 30
    [sw2-Ethernet0/0/1]int e0/0/2
    [sw2-Ethernet0/0/2]p h p v 10
    [sw2-Ethernet0/0/2]p h u vl 10 30
    [sw2-Ethernet0/0/2]int e0/0/3
    [sw2-Ethernet0/0/3]p h p v 20
    [sw2-Ethernet0/0/3]p h u vl 20 30
    [sw2]int e0/0/4
    [sw2-Ethernet0/0/4]
    [sw2-Ethernet0/0/4]p h p v 30
    [sw2-Ethernet0/0/4]p h u	
    [sw2-Ethernet0/0/4]p h u vl 10 30 20
    [sw2-Ethernet0/0/4]
    [sw2-Ethernet0/0/4]
    [sw2-Ethernet0/0/4]dis cu
    #
    sysname sw2
    #
    undo info-center enable
    #
    vlan batch 10 20 30
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port hybrid tagged vlan 10 20 30
    #
    interface Ethernet0/0/2
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10 30
    #
    interface Ethernet0/0/3
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20 30
    #
    interface Ethernet0/0/4
     port hybrid pvid vlan 30
     port hybrid untagged vlan 10 20 30
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
    user-interface vty 0 4
    #
    return
    [sw2-Ethernet0/0/4]
    

    此时vlan10 vlan20能ping通pc5
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    但是vlan10 vlan20之间不能通信
    在这里插入图片描述
    在这里插入图片描述

    展开全文
  • 交换机三种端口模式Access、Hybrid和TrunkTag,untag以及交换机的各种端口模式是网络工程技术人员调试交换机时接触最多的概念了,然而笔者发现在实际工作中技术人员往往对这些概念似懂非懂,笔者根据自己的理解再...

    交换机三种端口模式

    Access

    Hybrid

    Trunk

    Tag

    untag

    以及交换机的各种端口模式是网络工程技术人员调试交换机时接触

    最多的概念了,然而笔者发现在实际工作中技术人员往往对这些概念似懂非懂,

    笔者根据自己的理解再结合一个案例,试图向大家阐明这些概念

    untag

    就是普通的

    ethernet

    报文,

    普通

    PC

    机的网卡是可以识别这样的报文进行

    通讯;

    tag

    报文结构的变化是在源

    mac

    地址和目的

    mac

    地址之后,

    加上了

    4bytes

    vlan

    信息,也就是

    vlan

    tag

    头;一般来说这样的报文普通

    PC

    机的网卡是不能识别的

    下图说明了

    802.1Q

    封装

    tag

    报文帧结构

    802.1Q

    的帧是在标准以太网帧上插入了

    4

    个字节的标识。其中包含:

    2

    个字节的协议标识符

    (

    TPID)

    当前置

    0x8100

    的固定值,

    表明该帧带有

    802.1Q

    的标记信息。

    2

    个字节的标记控制信息(

    TCI

    ),包含了三个域。

    Priority

    域,占

    3bits

    ,表示报文的优先级,取值

    0

    7

    7

    为最高优先级,

    0

    为最低优先级。该域被

    802.1p

    采用。

    规范格式指示符(

    CFI)

    域,占

    1bit

    0

    表示规范格式,应用于以太网;

    1

    表示非

    规范格式,应用于

    Token Ring

    VLAN ID

    域,占

    12bit

    ,用于标示

    VLAN

    的归属。

    以太网端口有三种链路类型:

    Access

    Hybrid

    Trunk

    Access

    类型的端口只能属于

    1

    VLAN

    ,一般用于连接计算机的端口;

    Trunk

    类型的端口可以允许多个

    VLAN

    通过,可以接收和发送多个

    VLAN

    的报文,

    一般用于交换机之间连接的端口;

    Hybrid

    类型的端口可以允许多个

    VLAN

    通过,

    可以接收和发送多个

    VLAN

    的报文,

    可以用于交换机之间连接,也可以用于连接用户的计算机。

    Hybrid

    端口和

    Trunk

    端口在接收数据时,处理方法是一样的,唯一不同之处在

    于发送数据时:

    Hybrid

    端口可以允许多个

    VLAN

    的报文发送时不打标签,

    Trunk

    端口只允许缺省

    VLAN

    的报文发送时不打标签。

    在这里先要向大家阐明端口的缺省

    VLAN

    这个概念

    展开全文
  • 【转】交换机的端口工作模式一般可以分为三种:Access,Multi,Trunk 交换机的端口工作模式一般可以分为三种:Access,Multi,Trunk 交换机的端口工作模式一般可以分为三种:Access,Multi,Trunk...
  • 目录1.交换机三种接口模式2.STP生成树2.1 STP生成树的部分知识2.2 BPDU 报文3.实验题3.1 实验一:3.2实验二:3.3 实验三: ...工作模式: access 接入链路,接入模式 trunk 中继链路,中继模式 放通多个vlan hybrid
  • 文章目录交换机接口三种工作模式 交换机接口三种工作模式 以太网端口有三种链路类型:Access、Trunk和Hybrid。  Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口;  Trunk类型的端口可以允许多个VLAN...
  • 交换机的端口工作模式一般可以分为三种:Access,Multi,Trunk(树干)。 trunk模式的端口用于交换机交换机交换机与路由器,大多用于级联网络设备。 Access多用于接入层也叫接入模式。主要是将端口静态接入。 ...
  • 下面是交换机6大工作原理: 1、基于源MAC地址学习 2、基于目标MAC地址转发 3、同一接口可以学习到多个MAC地址 4、同一个MAC地址被多...交换机三种转发模式: 1、直通式转发: 是指交换机在收到数据帧后,不...
  • 交换机的端口工作模式一般可以分为三种:Access,Multi,Trunk(树干)。 trunk模式的端口用于交换机交换机交换机与路由器,大多用于级联网络设备。 Access多用于接入层也叫接入模式。主要是将端口静态接入。 ...
  • 华为交换机三种交换模式

    千次阅读 2018-08-21 10:40:24
    作为我们用户,在使用交换机的时候,也应该了解一些交换机的相关知识,才能更好的运用,下面为大家介绍三种交换机的交换模式。 存储转发模式 存储转发(Store-and-forward)模式是指交换机收完整个数据帧,并在CRC...
  • 方法一:用户当前所处的命令模式决定了可以使用的命令。在用户模式输入“?”如果如下:Switch>?Exec commands:access-enable Create a temporary Access-List entryclear Reset functionsconnect Open a ...
  • 文章目录链路聚合一、手工负载分担模式二、LACP模式2.1静态LACP模式2.2动态LACP模式总结 链路聚合 一、手工负载分担模式 二、LACP模式 2.1静态LACP模式 2.2动态LACP模式 总结 提示:这里对文章进行总结: 例如:以上...
  • 关于交换机的三种模式 一、交换机的行为 交换机的行为无非分为接收数据、发送数据 ...Huawei交换机存在三种工作模式 Access,接入模式 Trunk,中继模式 Hybrid,混杂模式 接入模式 使用场景:常用于连接PC、终端...
  • 交换机工作模式实验 access trunk hybrid一、Trunk端口拓扑图Ⅰ配置目标Ⅱ配置过程Ⅲ实验效果二、Hybrid端口拓扑图①配置目标②配置过程③实验效果 一、Trunk端口拓扑图 Ⅰ配置目标 1)实现vlan10内PC可以相互ping...
  • Tag,untag以及交换机的各种端口模式是网络工程技术人员调试交换机时接触最多的概念了,然而笔者发现在实际工作中技术人员往往对这些概念似懂非懂,笔者根据自己的理解再结合一个案例,试图向大家阐明这些概念 ...
  • 交换机的端口工作模式

    千次阅读 2012-02-22 15:23:22
    交换机的端口工作模式一般可以分为三种:Access(普通模式),Multi(多vlan模式),Trunk(中继模式)。 1、允许多个vlan的是multi模式,而不是trunk模式。 2、两个都设为trunk模式: 一:如果在同一交换机上,...
  • 交换机Access、Hybrid和Trunk三种模式

    千次阅读 2018-09-17 11:34:37
    交换机端口工作模式简介: 端口类型 工作模式 Access类型 端口只能属于1个VLAN,一般用于连接计算机的端口 Trunk类型 端口可以允许多个VLAN通过,可以接收和发送多...
  • 一、实验目标用命令进入交换机的几种模式,熟练掌握交换机的配置命令。二、实验环境CiscoPacketTracer、实验步骤1、为5台PC机配置IP地址PC0:192.168.1.1PC1:192.168.1.2PC2:192.168.1.3PC3:192.168.1.4PC4:192.168...
  • 如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有...当我们在port link-type 后面打问号的时候,会出现下图的样子这是华为端口的工作模式,有四种,今天我们来讲解其中的三种:access ,trunk,hybridAc...
  • 因为自己在配置交换机端口模式的时候...交换机端口工作模式简介: 端口类型 工作模式 Access类型 端口只能属于1个VLAN,一般用于连接计算机的端口 Trunk类型 端口可以允许多个VLAN通过,可以接收和发送多个VL
  • 如果这篇文章对您有帮助,请关注并点赞,感谢您的支持,如果还有...当我们在port link-type 后面打问号的时候,会出现下图的样子这是华为端口的工作模式,有四种,今天我们来讲解其中的三种:access ,trunk,hybridAc...
  • Access、Hybrid和Trunk三种模式的理解Tag,untag以及交换机的各种端口模式是网络工程技术人员调试交换机时接触最多的概念了,然而笔者发现在实际工作中技术人员往往对这些概念似懂非懂,笔者根据自己的理解再结合一...

空空如也

空空如也

1 2 3 4 5 ... 19
收藏数 367
精华内容 146
关键字:

交换机三种工作模式