精华内容
下载资源
问答
  • 交换机端口聚合如何配置
    2021-06-25 07:25:46

    交换机的端口聚合配置又是怎么回事呢,那么的呢?下面是小编收集整理的,希望对大家有帮助~~

    交换机的端口聚合配置的方法

    工具/原料

    计算机网络

    工具软件

    方法/步骤

    配置交换机Switch0:

    Switch>en

    Switch#conf

    Switch***config***#interface range fa0/1-2

    Switch***config-if-range***#switchport mode trunk //设置端口模式为trunk

    Switch***config-if-range***#

    Switch***config-if-range***#channel-group 1 mode on //加入链路组1并开启

    Switch***config-if-range***#

    Switch***config-if-range***#exit

    Switch***config***#port-channel load-balance dst-ip //按照目标主机IP地址数据分发来实现负载平衡

    Switch***config***#exit

    Switch#show etherchannel summary

    配置交换机Switch1:

    Switch>en

    Switch#config t

    Switch***config***#interface range fa0/1-2

    Switch***config-if-range***#switchport mode trunk //设置端口模式为trunk

    Switch***config-if-range***#channel-group 1 mode on //加入链路组1并开启

    Switch***config-if-range***#

    Switch***config-if-range***#exit

    Switch***config***#port-channel load-balance dst-ip //按照目标主机IP地址数据分发来实现以太网通道组负载平衡

    Switch***config***#exit

    Switch#

    Switch#show etherchannel summary//显示以太网通道组的情况

    计算机PC0的设置:

    子网掩码:255.255.255.0

    计算机PC1的设置:

    子网掩码:255.255.255.0

    PC0 ping PC1 :测试PC0到PC1的连通。

    PC1 ping PC0 :测试PC1到PC0的连通。

    更多相关内容
  • 交换机端口聚合

    2021-06-29 23:20:25
    交换机端口聚合,可实现交换机之间的链路具有较高的带宽和可靠性,并在交换机之间实现数据流量的负载分担。 相关命令: 创建Eth-Trunk system-view [Quidway] sysname S-switch-A [S-switch-A] interface eth-...

    交换机端口聚合,可实现交换机之间的链路具有较高的带宽和可靠性,并在交换机之间实现数据流量的负载分担。
    相关命令:

    1. 创建Eth-Trunk
      system-view
      [Quidway] sysname S-switch-A
      [S-switch-A] interface eth-trunk 1
      [S-switch-A-Eth-Trunk1] quit
    2. 配置交换机A上的eth-trunk 1
      [S-switch-A] interface eth-trunk 1
      [S-switch-A-Eth-Trunk1]port link-type trunk
      [S-switch-A-Eth-Trunk1]port trunk allow-pass vlan all
      [S-switch-A-Eth-Trunk1]quit
    3. 加入Eth-Trunk 的成员接口
      [S-switch-A] interface Ethernet0/0/1
      [S-switch-A-Ethernet0/0/1]undo port default vlan
      [S-switch-A-Ethernet0/0/1]undo ntdp enable
      ntdp “邻居拓扑发现协议”
      [S-switch-A-Ethernet0/0/1]undo ndp enable
      ndp “邻居发现协议”
      [S-switch-A-Ethernet0/0/1]bpdu disable
      bpdu “网桥协议数据单元”
      [S-switch-A-Ethernet0/0/1]eth-trunk 1
      需要几分钟
      [S-switch-A-Ethernet0/0/1] quit
      [S-switch-A] interface Ethernet0/0/2
      [S-switch-A-Ethernet0/0/2]undo port default vlan
      [S-switch-A-Ethernet0/0/2]undo ntdp enable
      [S-switch-A-Ethernet0/0/2]undo ndp enable
      [S-switch-A-Ethernet0/0/2]bpdu disable
      [S-switch-A-Ethernet0/0/2] eth-trunk 1
      [S-switch-A-Ethernet0/0/2] quit
      [S-switch-A] interface Ethernet0/0/3
      [S-switch-A-Ethernet0/0/3]undo port default vlan
      [S-switch-A-Ethernet0/0/3]undo ntdp enable
      ntdp
      [S-switch-A-Ethernet0/0/3]undo ndp enable
      [S-switch-A-Ethernet0/0/3]bpdu disable
      [S-switch-A-Ethernet0/0/3] eth-trunk 1
      [S-switch-A-Ethernet0/0/3] quit
      实验拓扑如下:
      在这里插入图片描述
    展开全文
  • 交换机端口聚合配置

    借鉴网址:(23条消息) Packet Tracer 思科模拟器入门教程 之四 交换机的端口聚合配置_柚子君.的博客-CSDN博客_思科模拟器如何配置聚合端口

     

    姓 名

    彭彭头

    实验日期

    2022-03-22

    学 号

    实验序号

    4

    实验名称

    交换机端口聚合配置

    • 实验目的及要求

    目标:

    理解端口聚合基本原理,掌握一般交换机端口聚合的配置方法。

    要求:

    1.熟悉Cisco Packet Tracer使用环境;

    2.在交换机到交换机之间提供冗余的高速的连接方式;

    3.使用端口聚合技术,把两个100M链路聚合成一个200M的逻辑链路,当一条链路出现故障,另一条链路会继续工作;

    4.组内的端口号必须连续,但对起始端口无特殊要求;

    5.所有参加聚合的端口都必须工作在全双工模式下,且工作速率相同才能进行聚合,并且聚合功能需要在链路两端同时配置方能生效。

    • 实验环境

    1.Cisco Packet Tracer软件;

    2.2台Switch_2960 、2台PC 、直通线。 

    • 实验内容

    1.添加2台Switch_2960交换机、2台PC;

    2.通过直通线连接交换机和PC;

    3.点击PC,配置IP地址、子网掩码;

    4.点击交换机,选择CLI,进入命令行界面,设置端口模式为trunk,加入链路组,实现负载均衡,显示以太信道概况;

    5. 通过console端口互相ping通2台PC。

    • 实验步骤
    1. 添加2台Switch_2960交换机、2台PC:PC0、PC1

    2.通过直通线连接交换机和PC

    3.点击PC,分别配置PC0、PC1的IP地址/子网掩码

     

    4.点击交换机Switch0,选择CLI,进入命令行界面

    1)选择端口fa0/1-2,设置端口模式为trunk;

    2)加入链路组1并启动;

    3)按照目标主机IP地址数据分发来实现负载均衡;

    4)显示以太信道概况。

    Switch>enable

    Switch#config  t

    Switch(config)#interface range fa 0/1-2         //同时选择端口fa0/1 fa0/2

    Switch(config-if-range)#switchport mode trunk   //设置端口模式为trunk

    Switch(config-if-range)#channel-group 1 mode on   //加入链路组1并开启

    Switch(config-if-range)#exit

    Switch(config)#port-channel load-balance dst-ip  //按照目标主机IP地址数据分发来实现负载平衡

    Switch(config)#exit

    Switch#show etherchannel summary                 //显示以太信道概况

     

    5.点击交换机Switch1,选择CLI,进入命令行界面

    1)选择端口fa0/1-2,设置端口模式为trunk;

    2)加入链路组1并启动;

    3)按照目标主机IP地址数据分发来实现负载均衡;

    4)显示以太信道概况。

    Switch>enable

    Switch#config  t

    Switch(config)#interface range fa 0/1-2         //同时选择端口fa0/1 fa0/2

    Switch(config-if-range)#switchport mode trunk   //设置端口模式为trunk

    Switch(config-if-range)#channel-group 1 mode on   //加入链路组1并开启

    Switch(config-if-range)#exit

    Switch(config)#port-channel load-balance dst-ip  //按照目标主机IP地址数据分发来实现负载平衡

    Switch(config)#exit

     

    Switch#show etherchannel summary                //显示以太信道概况

    6.实验验证:

    1)PC0 ping PC1,能够ping通

    2)PC1 ping PC0,能够ping通

     

    • 总结

    通过本次实验我掌握了:

    1. 如何利用Cisco Packet Tracer软件,配置交换机的端口聚合;
    2. 交换机只能有1个汇聚组,1个汇聚组最多可以有4个端口。;
    3. 在一个端口汇聚组中,端口号最小的作为主端口,其他的作为成员端口。同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致;
    4. 熟悉端口聚合主要应用的场合: 1)交换机与交换机之间的连接; 2)交换机与服务器之间的连接;3)交换机与路由器之间的连接;4)服务器和路由器之间的连接。

    注意:端口聚合将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端口,可以实现负载分担,并提供冗余链路。

    (在全局模式下:聚合端口;在特权模式下:显示相关汇聚端口组的信息。)

    展开全文
  • 一、服务器环境和交换机环境 1、服务器 ubuntu18 4.15.0-159-generic 2、交换机 Huawei Versatile Routing Platform Software VRP (R) software, Version 5.170 (S5720 V200R010C00SPC600) Copyright (C) 2000-...

    一、服务器环境和交换机环境

    1、服务器

    ubuntu18  4.15.0-159-generic  

    2、交换机

    Huawei Versatile Routing Platform Software
    VRP (R) software, Version 5.170 (S5720 V200R010C00SPC600)
    Copyright (C) 2000-2016 HUAWEI TECH CO., LTD
    HUAWEI S5720S-28P-SI-AC Routing Switch uptime is 0 week, 1 day, 5 hours, 8 minutes

    3、网卡绑定的作用

    • 当一个网卡不够用的时候,可以使用两个网卡绑定在一起增加带宽
    • 当一个网卡断的话,另一个网卡可以形成备份,增加链路冗余
    • 主备模式只能做成链路备份,不能负载,负载需要服务器和交换机互相配合

    4、bond 的七种模式

    每种模式的特点可以参考(Linux----bond技术及mode模式详解_weixin_45726050的博客-CSDN博客

    这七种模式分别是:
    802.3ad balance-alb balance-tlb broadcast active-backup balance-rr balance-xor

    mode=0 round-robin轮询策略(Round-robin policy)
    mode=1 active-backup主备策略(Active-backup policy)
    mode=2 load balancing (xor)异或策略(XOR policy)
    mode=3 fault-tolerance (broadcast)广播策略(Broadcast policy)
    mode=4 lacp IEEE 802.3ad 动态链路聚合(IEEE 802.3ad Dynamic link aggregation) #我这边使用是这种模式
    mode=5 transmit load balancing适配器传输负载均衡(Adaptive transmit load balancing)
    mode=6 adaptive load balancing适配器负载均衡(Adaptive load balancing)

    二、服务器配置

    1、查看有没有bonding kernel module,一般ubuntu18,默认就有的。

    modinfo bonding | head -n 3

    filename: /lib/modules/4.15.0-159-generic/kernel/drivers/net/bonding/bonding.ko
    author: Thomas Davis, tadavis@lbl.gov and many others
    description: Ethernet Channel Bonding Driver, v3.7.1

    2、网络配置

    vim /etc/network/interfaces

    # interfaces(5) file used by ifup(8) and ifdown(8)

    auto lo

    iface lo inet loopback

    auto eno1

    iface eno1 inet manual

    bond-master bond0

    bond-primary eno1

    bond-mode 4

    auto eno2

    iface eno2 inet manual

    bond-master bond0

    bond-primary eno2

    bond-mode 4

    auto bond0

    iface bond0 inet static

    address 192.168.10.113

    netmask 255.255.255.0

    gateway 192.168.10.254

    slaves eno1 eno2

    bond-mode 4

    bond-miimon 100

    bond-downdelay 200

    bond-updelay 200

    3、重启网卡

    #/etc/init.d/networking restart

    4、查看bonding状态

    #cat /proc/net/bonding/bond0

    Ethernet Channel Bonding Driver: v3.7.1 (April 272011)

    Bonding Mode: IEEE 802.3ad Dynamic link aggregation

    Transmit Hash Policy: layer2 (0)

    MII Status: up

    MII Polling Interval (ms): 100

    Up Delay (ms): 200

    Down Delay (ms): 200

    802.3ad info

    LACP rate: slow

    Min links: 0

    Aggregator selection policy (ad_select): stable

    System priority: 65535

    System MAC address: ac:1f:6b:e1:d6:05

    Active Aggregator Info:

            Aggregator ID: 1

            Number of ports: 2

            Actor Key: 9

            Partner Key: 561

            Partner Mac Address: e8:68:19:c9:7d:60

    Slave Interface: eno2

    MII Status: up

    Speed: 1000 Mbps

    Duplex: full

    Link Failure Count: 0

    Permanent HW addr: ac:1f:6b:e1:d6:05

    Slave queue ID: 0

    Aggregator ID: 1

    Actor Churn State: none

    Partner Churn State: none

    Actor Churned Count: 0

    Partner Churned Count: 0

    details actor lacp pdu:

        system priority: 65535

        system mac address: ac:1f:6b:e1:d6:05

        port key: 9

        port priority: 255

        port number: 1

        port state: 61

    details partner lacp pdu:

        system priority: 32768

        system mac address: e8:68:19:c9:7d:60

        oper key: 561

        port priority: 32768

        port number: 2

        port state: 61

    Slave Interface: eno1

    MII Status: up

    Speed: 1000 Mbps

    Duplex: full

    Link Failure Count: 0

    Permanent HW addr: ac:1f:6b:e1:d6:04

    Slave queue ID: 0

    Aggregator ID: 1

    Actor Churn State: none

    Partner Churn State: none

    Actor Churned Count: 0

    Partner Churned Count: 0

    details actor lacp pdu:

        system priority: 65535

        system mac address: ac:1f:6b:e1:d6:05

        port key: 9

        port priority: 255

        port number: 2

        port state: 61

    details partner lacp pdu:

        system priority: 32768

        system mac address: e8:68:19:c9:7d:60

        oper key: 561

        port priority: 32768

        port number: 1

        port state: 61

    三、交换机配置


    1、首先进入system-view 进入以太网端口视图

    >system-view

    #进入聚合口trunk2
    interface Eth-Trunk2

    #配置为接入模式
    port link-type access 

    # 放行vlan,如果用的是默认的vlan1,那可以不需要执行
    port default vlan ID

    #模式
    mode lacp 

    #流量分流算法模式,总共有6总,常用的是src-dst-ip
    load-balance src-dst-ip

    #配置之后可以 dis this 查看一下配置

    display this
    #
    interface Eth-Trunk2
    port link-type access
    port default vlan 192
    mode lacp
    #


    ** 注意:
    加入聚合之前请删除端口中的配置**

    undo eth-trunk
    undo link-type

    2、配置聚合端口信息

    # 进入g 1/0/19 端口

    interface GigabitEthernet1/0/19

    #** 加入trunk2**
    eth-trunk 2


    #跟上面一样进入另一个端口加入聚合

    #进入g 2/0/2 端口
    interface GigabitEthernet2/0/20

    #加入trunk2
    eth-trunk 2

    查询: dis interface Eth-Trunk 查看所有聚合表

    display interface Eth-Trunk

    Eth-Trunk2 current state : UP

    Line protocol current state : UP

    Description:

    Switch Port, Link-type : access(configured),

    PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 2G, Current BW: 2G, The Maximum Frame Length is 9216

    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is e868-19c9-7d60

    Current system time: 2021-10-12 12:52:24

    Last 300 seconds input rate 6984 bits/sec, 6 packets/sec

    Last 300 seconds output rate 19608 bits/sec, 12 packets/sec

    Input:  24351 packets, 2528598 bytes

      Unicast:                      23372,  Multicast:                         372

      Broadcast:                      607,  Jumbo:                               0

      Discard:                          0,  Pause:                               0

      Frames:                           0

      Total Error:                      0

      CRC:                              0,  Giants:                              0

      Runts:                            0,  DropEvents:                          0

      Alignments:                       0,  Symbols:                             0

      Ignoreds:                         0

    Output:  39962 packets, 5490082 bytes

      Unicast:                      23702,  Multicast:                       10219

      Broadcast:                     6041,  Jumbo:                               0

      Discard:                          0,  Pause:                               0

      Total Error:                      0

      Collisions:                       0,  Late Collisions:                     0

      Deferreds:                        0

        Input bandwidth utilization  :    0%

        Output bandwidth utilization :    0%

    -----------------------------------------------------

    PortName                      Status      Weight

    -----------------------------------------------------

    GigabitEthernet0/0/20         UP          1

    GigabitEthernet0/0/19         UP          1

    -----------------------------------------------------

    The Number of Ports in Trunk : 2

    The Number of UP Ports in Trunk : 2

    四、验证

    验证的方式较为简单,两个网卡同时插上网线,并连接到交换机上,断掉其中任何一个,不影响使用。

    展开全文
  • 思科交换机端口聚合

    千次阅读 2020-10-27 20:32:33
    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。但是,失去了路径冗余的优点,因为STP的链路切换会很慢,在50s左右。使用以太通道的话,交换机会把一组物理端口联合起来,做为一个逻辑的通道...
  • ■ 任务描述某服务器间的物理连接如图1所示,服务器A、B、C需要通过交换机与对端的服务器D、E、F通信,现需拓展链路带宽、同时提升服务器间访问的可靠性,传统的方式是更换更高级别的设备或者更换更高带宽的业务板。...
  • 端口聚合使用的是EtherChanne特性,在交换机交换机之间提供冗余的高速的连接方式,将两个设备之间多条FashEthernet或GigabitEthernet物理链路捆在一起组成一条设备间逻辑链路,从而增强带宽,提供冗余...
  • 2、组网拓扑3、配置要点1)、将端口加入AP口2)、配置AP口属性3)、更改流量平衡算法为源MAC关键字注意:Vmware系统不支持LACP动态聚合,ESXi虚拟机服务器多网卡绑定有四种负载均衡方式,,虚拟机如果使用基于IP的负载...
  • 04. 交换机端口聚合配置

    万次阅读 多人点赞 2018-11-20 13:21:33
    交换机端口聚合配置   技术原理   1)端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端口,可以实现负载分担,并提供冗余链路。 2)端口...
  • 端口聚合介绍: TRUNK是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立...
  • 组网需求·Device ADevice B通过各自的以太网接口Ten-GigabitEthernet1/0/1~Ten-GigabitEthernet1/0/3相互连接。·在DeviceA和DeviceB上分别配置静态链路聚合组,并实现设备间VLAN 10和VLAN 20分别互通。2.组网图...
  • H3C交换机端口聚合

    千次阅读 2020-01-20 11:30:29
    四台服务器1、2、3、4做好端口聚合,并接入堆叠交换机,堆叠交换机再连接外网核心交换机聚合端口。服务器都配置属于vlan 83,接入交换机与核心交换机端口都配置Trunk口,核心和接入都通过聚合组18互联。 2、组网...
  • 服务器多网卡绑定与交换机链路聚合对接探讨服务器多网卡绑定与交换机链路聚合对接探讨--综合支持部 王光明目前服务器的多网卡绑定技术在企业网中得到了广泛应用,常见为双网卡绑定,绑定后既能增加网络带宽,同时又...
  • 网络管理人人员在日常工作中,...打开今日头条,查看更多图片1 端口聚合简述端口聚合是指将多个物理端口和所连接的链路进行捆绑,构成一个逻辑端口或者链路,从而达到增加带宽、提供冗余、负载均衡的目的。端口聚...
  • 华三交换机配置端口聚合之三层端口配置静态和动态聚合 一,配置三层端口静态聚合 创建端口三层聚合口 [SW1]interface Route-Aggregation 1 [SW1-Route-Aggregation1]ip add 10.1.1.1 24 [SW1-Route-Aggregation1]qu...
  • 配置 bond0 上联网络设备也需要做捆绑,如果是冗余的 bond 则上联不用配置H3Cs5560 交换机interface Bridge-Aggregation 1port access vlan 10创建聚合口,划入vlanint g 1/0/1port link-aggregation group 1聚合的...
  • 测试主题:服务器主机与交换机网络端口绑定后的互通性、可靠性和读写速率。 交换机流量网络测试 测试环境: 主机:centos7.4bond0绑定 主机A和主机B网络配置一样如下图: 交换机:华为5720-56pc-EI千兆...
  • 学习目标:理解和掌握交换机端口聚合的基本原理和配置方法 1.定义:端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有较大宽带的端口,可以实现负载分担,并...
  • (1) 配置Device A创建VLAN 10,并将端口GigabitEthernet1/0/4加入到该VLAN中。 system-view[DeviceA] vlan 10[DeviceA-vlan10] port gigabitethernet 1/0/4[DeviceA-vlan10] quit创建VLAN 20,并将端口...
  • ifenslave bond0 eth0 eth2 #测试绑定网络 ping 10.3.3.1 常用3种网卡绑定模式对比 mode=0 中断任意一条链路或恢复链路,网络0丢包 优点:流量提高1倍 缺点:需要接入同一交换机聚合配置,无法保证物理交换机高...
  • 场景介绍:Cisco 2960x单台交换机, 物理服务器全部单网卡接入Cisco2960x. 要解决单点故障问题。环境介绍:Cisco 2960x-24TS-L 2台Dell R720(Broadcom网卡) 2台操作系统 Windows Server 2008 R2目的: 通过交换机堆叠...
  • 1.端口聚合(参考拓扑)。描述应用情景,设计方案,实现并验证。 2.交换机堆叠。描述应用情景,设计方案,实现并验证。 3.交换机端口地址的绑定和结果验证.。将PC1的网卡mac地址和交换机s0的端口5绑定,PC2的...
  • 服务器多网卡绑定与交换机链路聚合对接探讨》由会员分享,可在线阅读,更多相关《服务器多网卡绑定与交换机链路聚合对接探讨(9页珍藏版)》请在人人文库网上搜索。1、服务器多网卡绑定 与交换机链路聚合对接探讨 - ...
  • 4交换机端口聚合配置 实验目标 理解端口聚合基本原理; 掌握一般交换机端口聚合的配置方法; 实验背景 端口聚合(又称为链路聚合),将交换机上的多个端口在物理上连接起来,在逻辑上捆绑在一起,形成一个拥有...
  • 1:配置要求 给服务器单独规划一个网段和VLAN,给计算机PC1和PC3单独规划一个网段和VLAN,计算机...1:在两S1和S2之间的F0/1、F0/2上作端口聚合PAgP,并把聚合口设置为TRUNK; 2:把S1设置为VTP的server模式,S2设...
  • linux bond和交换机端口配置,并且在linux端口绑定时注意hash算法,不然网口bond后会出现负载均衡的问题,可能你需要两个1G变2G结果没有提升。
  • 1故障现象 在实际组网环境中,将1台HP DL380服务器集成的双网卡进行双千兆网卡捆绑,并盒式千兆3层交换机H3C S5500-28TP-SI的2个GE光口进行连接,该交换机的2个GE光口进行(linkaggregation control protocol。...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,557
精华内容 3,022
关键字:

交换机与服务器端口聚合