精华内容
下载资源
问答
  • H3C三层交换机配置VLAN之间不能互相访问2010-11-2013:30:54|分类:H3C|标签:qosvlanh3c交换机traffic|举报|字号订阅由于H3C交换机的VLAN之间可以互访,为了数据的安全性及链路需求,要让VLAN之间不能互访。...

    H3C

    三层交换机配置

    VLAN

    之间不能互相访问

    2010-11-20 13:30:54|

    分类:

    H3C

    |

    标签:

    qos  vlan  h3c

    交换机

    traffic

    |

    举报

    |

    字号

    订阅

    由于

    H3C

    交换机的

    VLAN

    之间可以互访,为了数据的安全性及链路需求,要让

    VLAN

    之间不能互访。

    通过下午的配置发现有两种实现方式:应用到端口和应用到

    VLAN

    1.

    定义

    ACL

    acl number 3000

    rule 0 deny ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255

    rule 1 deny ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255

    应用到端口:

    2.

    应用

    QoS

    策略

    #

    定义类

    c_rd

    ,对匹配

    IPv4 ACL 3000

    的报文进行分类

    traffic classifier c_rd

    if-match acl 3000

    #

    定义流行为

    b_rd

    ,动作为拒绝报文通过

    traffic behavior b_rd

    filter deny

    #

    定义

    QoS

    策略

    p_rd

    ,为类

    c_rd

    指定流行为

    b_rd

    qos policy p_market

    classifier c_market behavior b_market

    #

    QoS

    策略

    p_rd

    应用到端口

    GigabitEthernet 1/0/2

    interface GigabitEthernet 1/0/2

    qos apply policy p_rd inbound

    应用到

    VLAN

    #

    把策略应用到

    vlan 100

    interface vlan 100

    packet-filter 2010 inbound

    展开全文
  • 一、前置条件1.1目的:利用三层交换机,实现二次交换机的所有功能,同时具有路由功能,节省路由器费用,完成多个vlan之间的通信1.2基本设备及配置:三层交换机s5700,1.2.1交换机的ge0/0/1连接pc1,ge0/0/2连接pc2,...

    一、前置条件

    1.1目的:

    利用三层交换机,实现二次交换机的所有功能,同时具有路由功能,节省路由器费用,完成多个vlan之间的通信

    1.2基本设备及配置:

    三层交换机s5700,

    1.2.1交换机的ge0/0/1连接pc1,ge0/0/2连接pc2,接口均配置为access模式

    1.2.1 pc1 ip:192.168.10.10/24 vlan 10

    gw:192.168.10.1/24

    1.2.2 pc2 ip:192.168.20.20/24 vlan 20

    gw:192.168.20.1/24

    1.3拓扑图:

    fb48d167b3933d499f5d18fe453cf149.png

    二、交换机配置

    #用户模式下,输入system-view进入视图模式,可执行设备全局配置的命令

    sys

    Enter system view, return user view with Ctrl+Z.

    #修改设备名称为sw1

    [Huawei]sysname sw1

    [sw1]

    f4a5f6be2786bad3583dee09454e0e84.png

    #批量创建2个vlan;vlan 10,vlan 20

    [sw1]vlan batch 10 20

    ad63dad72ff1aa9de942cd5acd68d4d0.png

    #进入接口ge 0/0/1里面

    [sw1]interface GigabitEthernet 0/0/1

    26dbd96d787b8b38c3ca84cfb222bcfe.png

    #设置端口链接类型为 access 型(access一般为PC和交换机连接)

    [sw1-GigabitEthernet0/0/1]port link-type access

    8b3bbe962a55fb619a4fbbe8685806ff.png

    #把ge 0/0/1端口加入到vlan 10

    [sw1-GigabitEthernet0/0/1]port default vlan 10

    8ce86405321d516d7dd944afec2445a4.png

    验证

    [sw1-GigabitEthernet0/0/1]disp th

    b73de87764201922e330acaddbe18d61.png

    #进入接口ge 0/0/2里面

    [sw1]int g0/0/2

    6552cc95a1a283c23e01766fed9c957f.png

    #设置端口链接类型为 access 型

    [sw1-GigabitEthernet0/0/2]port link-type access

    c0f0702aa3286e4a1113e6b36fc9b1da.png

    #把eth 0/0/2端口加入到vlan 20

    [sw1-GigabitEthernet0/0/2]port default vlan 20

    cfed39aca27ebdc50461a3573309834a.png

    验证

    [sw1-GigabitEthernet0/0/2]dis th

    7ed9cc6c80b694454a0226cc270ce8fc.png

    用下面这条命令可知vlan 10里面包含端口ge0/0/1,vlan 20里面包含端口ge0/0/2。

    [sw1]display port vlan active

    0bbcd5a06a5a05bedb86858d88457ed0.png

    #进入接口vlanif 10里面

    这里的10是对应刚才PC1所在的vlan,这是一个三层接口,该接口地址是PC1对应的网关192.168.10.1。

    [sw1]interface vlanif 10

    9dff75c50aa1dd383fd1935110b4d632.png

    [sw1-Vlanif10]ip address 192.168.10.1 24

    958da33972277af55f065cc14d758fcb.png

    验证

    [sw1-Vlanif10]disp this

    e379e577f6f839ea019f7f8da3e5495e.png

    #进入接口vlanif 20里面

    这里的20是对应刚才PC2所在的vlan,这是一个三层接口,该接口地址是PC2对应的网关192.168.20.1。

    [sw1]interface vlanif 20

    b301ea65574e21b5fc2390278884e38c.png

    [sw1-Vlanif20]ip address 192.168.20.1 255.255.255.0

    033c7eecb7a7f067cbd3adf0c46f4aa6.png

    验证

    [sw1-Vlanif20]disp this

    226950ca0379cb1bd9cf0e4b4e0f532c.png

    自此交换机配置完成

    三、查看路由表

    [sw1]disp ip routing-table

    1c6f6dacf7468fd435c962468de81408.png

    四、配置PC的地址

    配置PC1的IP地址

    27aaa04dde3610a5965eb240ce4861e6.png

    配置PC2的Ip地址

    e50bc652f96522ca5cc2155f458410a7.png

    验证

    在pc1上ping pc2

    7b5d60eb381ed54a311bddce115a7718.png

    用tracert命令检查路径

    b0ecf94635b76bd85179e294f82adf3e.png

    在pc2上ping pc1

    556ee097d10fa8edce96fba933509288.png

    用tracert命令检查路径

    11a160648710d320f4613a58af43597b.png

    至此pc1和pc2相通,实现不同vlan之间的通信。

    五、总结

    利用三层交换机实现vlan之间的通信,是现在企业中高频使用的功能,是必备网络知识储备。

    至此,vlan之间通信的三种方式都完成,需要了解的小伙伴可以点点关注,在文章中查看。

    2 / 2

    展开全文
  • 下面我们就来看看三层交换机设置vlan路由的方法,需要的朋友可以参考下网络设备中三层交换机具有网络层的功能,相当于交换机和路由器的结合,利用三层交换机实现不同VLAN的PC之间进行通信。1、首先打开思科模拟器...

    华为三层交换机VLAN间路由怎么设置

    三层交换机怎么设置VLAN间路由?三层交换机相当于交换机和路由器的结合,可以生鲜不同VLAN的PC之间进行通信,下面我们就来看看三层交换机设置vlan路由的方法,需要的朋友可以参考下

    网络设备中三层交换机具有网络层的功能,相当于交换机和路由器的结合,利用三层交换机实现不同VLAN的PC之间进行通信。

    1、首先打开思科模拟器软件,找出一台三层交换机和两台PC,如下图所示:

    2、将三层交换机和两台PC用直通线连接起来,如下图所示:

    3、在三层交换机上划分VLAN,命令是:

    复制内容到剪贴板Switch#conf tEnter configuration commands, one per line. End with CNTL/Z.Switch(config)#vlan 2Switch(config-vlan)#exitSwitch(config)#int f0/5Switch(config-if)#switchport mode access Switch(config-if)#switchport access vlan 1Switch(config-if)#int f0/6Switch(config-if)#switchport mode access Switch(config-if)#switchport access vlan 2

    如下图所示:

    4、开启三层交换机的'三层交换路由功能,命令是:ip routing,如下图所示:

    5、给PC配置IP地址和网关,如下图所示:

    6、进入三层交换机里面配置VLAN,命令是:

    复制内容到剪贴板Switch(config)#int vlan 1Switch(config-if)#no shutSwitch(config-if)#ip add 172.16.10.1 255.255.255.0Switch(config-if)#int vlan 2 Switch(config-if)#no shutSwitch(config-if)#ip add 172.16.20.1 255.255.255.0

    如下图所示:

    7、利用ping命令对PC之间进行通信测试,可以ping通的结果如下图所示:

    注意事项:

    1、配置PC时一定要让它们处于不同IP和网关。

    2、配置三层交换机的VLAN,要让它们的VLAN为PC之间的网关,切记,这很重要。

    3、三层交换机一定要开启路由功能,命令是“ip routing"。

    4、配置三层交换机一定要在全局模式下配置。

    【华为三层交换机VLAN间路由怎么设置】相关文章:

    展开全文
  • 1.单臂路由:单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或"逻辑接口",并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。2.单臂路由的子接口路由器...

    1.单臂路由:

    单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或"逻辑接口",并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

    2.单臂路由的子接口

    路由器的物理接口可以被划分为成多个逻辑接口,这些被划分后的逻辑接口被形象的称为子接口。值得注意的是这些逻辑子接口不能被单独的开启或关闭,也就是说,当物理接口被开启或关闭时,所有的该接口的子接口也随之被开启或关闭。

    3.三层交换机

    三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发。对于数据包转发等规律性的过程由硬件高速实现,而像路由信息更新、路由表维护、路由计算、路由确定等功能,由软件实现。三层交换技术就是二层交换技术+三层转发技术。传统交换技术是在OSI网络标准模型第二层--数据链路层进行操作的,而三层交换技术是在网络模型中的第三层实现了数据包的高速转发,既可实现网络路由功能,又可根据不同网络状况做到最优网络性能。

    4.VLAN:

    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。

    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点: 网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。

    在计算机网络中,一个二层网络可以被划分为多个不同的广播域,一个广播域对应了一个特定的用户组,默认情况下这些不同的广播域是相互隔离的。不同的广播域之间想要通信,需要通过一个或多个路由器。这样的一个广播域就称为VLAN。

    实验:

    dd83fa7aa041b32da46d7196f051dd1e.png

    实验拓补图

    Pc1:ip 192.168.1.1网关:192.168.1.254

    Pc2:ip 192.168.2.1网关:192.168.2.254

    pc3 ip:172.16.1.1网关:172.16.1.254

    pc4:ip 172.16.2.1 网关:172.16.2.254

    详细配置:

    LSW1:

    sys

    [Huawei]undo in e---关闭日志消息

    [Huawei]vlan batch 10 20---创建vlan

    [Huawei]int e0/0/1

    [Huawei-Ethernet0/0/1]port link-type access---改变链路类型为access

    [Huawei-Ethernet0/0/1]port default vlan 10---把次端口加入到vlan

    [Huawei-Ethernet0/0/1]int e0/0/2

    [Huawei-Ethernet0/0/2]port link-type access

    [Huawei-Ethernet0/0/2]port default vlan 20

    [Huawei-Ethernet0/0/2]int e0/0/4

    [Huawei-Ethernet0/0/4]port link-type trunk----交换机间相连的要用trunk链路

    [Huawei-Ethernet0/0/4]port trunk allow-pass vlan 10 20---允许通过的vlan

    [Huawei-Ethernet0/0/4]q

    R1:

    sys

    [Huawei]undo in e

    [Huawei]int e0/0/0.10---进入子接口

    [Huawei-Ethernet0/0/0.10]ip add 192.168.1.254 24---配置IP

    [Huawei-Ethernet0/0/0.10]dot1q termination vid 10---封装

    [Huawei-Ethernet0/0/0.10]arp broadcast enable---开启arp广播

    [Huawei-Ethernet0/0/0.10]int e0/0/0.20

    [Huawei-Ethernet0/0/0.20]ip add 192.168.2.254 24

    [Huawei-Ethernet0/0/0.20]dot1q termination vid 20

    [Huawei-Ethernet0/0/0.20]arp broadcast enable

    [Huawei-Ethernet0/0/0.20]q-------------------到此单臂路由配置完毕:PC1能ping通PC2

    [Huawei]int e0/0/1

    [Huawei-Ethernet0/0/1]ip add 12.0.0.1 24

    [Huawei-Ethernet0/0/1]q

    [Huawei]ip route-static 172.16.1.0 24 12.0.0.2---静态路由

    [Huawei]ip route-static 172.16.2.0 24 12.0.0.2

    LSW2:

    sys

    [Huawei]undo in e

    [Huawei]vlan batch 10 20

    [Huawei]int e0/0/1

    [Huawei-Ethernet0/0/1]port link-type access

    [Huawei-Ethernet0/0/1]port default vlan 10

    [Huawei-Ethernet0/0/1]int e0/0/2

    [Huawei-Ethernet0/0/2]port link-type access

    [Huawei-Ethernet0/0/2]port default vlan 20

    [Huawei-Ethernet0/0/2]int e0/0/3

    [Huawei-Ethernet0/0/3]port link-type trunk

    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan 10 20

    [Huawei-Ethernet0/0/3]q

    LSW3:

    sys

    [Huawei]undo in e

    [Huawei]vlan batch 10 20

    [Huawei]int vlan 10

    [Huawei-Vlanif10]ip add 172.16.1.254 24

    [Huawei-Vlanif10]int vlan 20

    [Huawei-Vlanif20]ip add 172.16.2.254 24

    [Huawei-Vlanif20]q

    [Huawei]int g0/0/2

    [Huawei-GigabitEthernet0/0/2]port link-type trunk

    [Huawei-GigabitEthernet0/0/2]port trunk allow-pass vlan 10 20

    [Huawei-GigabitEthernet0/0/2]q------到此三层交换机配置完毕:PC3能ping通PC4

    [Huawei]vlan 30

    [Huawei-vlan30]q

    [Huawei]int g0/0/1

    [Huawei-GigabitEthernet0/0/1]port link-type access

    [Huawei-GigabitEthernet0/0/1]port default vlan 30

    [Huawei-GigabitEthernet0/0/1]int vlan 30

    [Huawei-Vlanif30]ip add 12.0.0.2 24

    [Huawei-Vlanif30]q

    [Huawei]ip route-static 192.168.1.0 24 12.0.0.1

    [Huawei]ip route-static 192.168.2.0 24 12.0.0.1

    配置完成:测试

    PC1pingPC2

    9a9b7759cd00bb5579ba3c0fe1918e0a.png

    PC1pingPC2

    PC3pingPC4

    f3fdc18c21194f616214042fa88b1a74.png

    PC3pingPC4

    PC1,PC2和PC3,PC4间的通信:

    96a4777d43dcedd1f0142c65a8eae167.png

    PC1pingPC3,PC4

    80402360be250cdc5fcbd24d00e07726.png

    PC2pingPC3,PC4

    模拟器:华为eNSP模拟器。

    展开全文
  • 满意答案罗志198503182015.05.17采纳率:40%等级:12已帮助:3055人(1)在二层交换机上配置VLAN2...(3)在三层交换机上配置VLAN2、VLAN3,此时验证二层交换机VLAN2、VLAN3下带主机之间不能互相通信;(4)设置三层交换机...
  • 时可以利用hybrid属性定义分属于不同的vlan的端口之间的互访,这是access和trunk端口所不能实现的。在一台交换机上不允许trunk端口和hybrid端口同时存在。1.先创建业务需要的vlan[SwitchA]vlan10[SwitchA]vlan20...
  • 前面我们曾提到关于vlan组网及一些配置,仍然...在了解vlan之间,我们先来简单的了解下三层交换机。要实现vlan间通信,就需要路由;解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用...
  • 昨晚搭建的ubuntu可以ping宿主,今天重启vmware就ping不通宿主了,虚拟机之间却可以ping通。 桥接模式下,虚拟机的网络需要检查四个地方:宿主网络连接设置、虚拟机网络连接设置、vmware网络设置、交换机或...
  • VLAN的局限性VLAN在分割广播域的同时也限制了不同VLAN间的主机进行二层...一、VLAN路由-单臂路由将交换机和路由器之间的链路配置为Trunk链路,并且在路由器上创建子接口以支持VLAN路由。解决VLAN间通信问题的第二...
  • 单臂路由单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。链路类型:链接主机的端口为...
  • 时可以利用hybrid属性定义分属于不同的vlan的端口之间的互访,这是access和trunk端口所不能实现的。在一台交换机上不允许trunk端口和hybrid端口同时存在。1.先创建业务需要的vlan[SwitchA]vlan10[SwitchA]vlan20...
  • 主要原因:在NAT模式中,...原来我们的VMware Network Adapter VMnet8虚拟网卡主要是为了实现主机与虚拟机之间的通信。vmnet8是在虚拟机内部的虚拟交换机,和 win下 ​​​​​​VMware Network Adapter VMnet8是两...
  • 能够PING通同网段的节点,但却如PING不通其他网段的所有节点的最可能的原因 A: 本机网关设置错误 B: 本机没有正确设置DNS C: 对方运行的是不同的操作系统 D: 二层交换机故障 正确答案:A 解析:PING命令用于验证与...
  • 三层交换机 建立vlan2 3 4三个vlan 起虚拟口vlan1 1.0.0.1管理地址 vlan2 2.0.0.254 下面pc的网关 vlan4 192.168.0.1 写路由0.0.0.0 0 192.168.0.2 ...交换机怎么样才能ping通路由器 为什么我ping不通
  • 7、 有一台交换机上的所有用户都获取不了 IP 地址,但手工配置后这台交换机上的同一 vlan 间的用户之间能够相互 ping 通,但 ping 不通外网,请说 出排障思路. ** 首先判断连接网关的物理线路是否正常;然后本网段网关...
  • 1、检查交换机与网关间线路情况,接口协议是否是UP; 2、查询网关设备是否正确配置了DHCP服务...5、交换机之间是否正确开启了trunk 6、ping不同外网查看边界路由器是否做了NAT以及ACL是否有问题,缺省是否下发。 ...
  • 网络拓扑图如下: 让PC0给PC1发送一个数据包 由上图你可以看到:因为交换机生成树协议STP,交换机1的Fa0/1端口是阻塞的。 接下来,我们手动的关闭交换机2的Fa0/2端口。 再让PC0给PC1发送一个...导致主机ping不通
  • 在R2611访问控制内容不变的情况下,对S3526AC进行逐条访问控制命令添加,测试各业务间的隔离情况,各机器之间相互ping通试验。 测试内容 首先,在S3526-AC上添加ACL 100后,PCA与PCB、PCC不通, PCB与PCC通;然后,...
  • 使用两台电脑直连发现联不通,通过交换机进行连接,就可以联通了,这是什么问题??? 两台主机之间应该用交叉线 交换机和主机之间用直通线。 因此,原因是有一个设备的网卡比较老,两主机之间必须使用交叉线,但是...
  • 跨网段主机无法ping

    千次阅读 2017-05-04 14:19:40
    昨天遇到一个故障,两个跨网段的主机已经开通网络服务,防火墙或者交换机没有限制的情况下,两个主机就是不通。 现象:需求是不同网段A和B通信,A能ping通B,B无法ping通A。A能访问B提供的服务,B却无法访问A提供的...
  • 发现那些电脑都ping不通网关,但可以互ping。说明小型傻瓜交换机没有问题,是小型傻瓜交换机和原来交换机之间连接出现故障。查看原来交换机配置,发现配置了portfast 。且后面有spanning-tree bpduguard enable。...
  • 1:配置vlan ...结论:相同VLAN的计算机之间可ping通,不同VLAN的计算机之间ping不通。 4:trunk只转发vlan10 的数据,不转发vlan20的数据 测试结果:PC4->PC0通,PC4->PC2不通。 ...
  • 如上图的配置,两个交换机之间端口VLAN ID不同但是能互相PING通,原理是交换机自己从access发送出的数据不带有VLAN标签到了对端G0/0/1口带上标签,交换机收到了能回应。从SW4也不能PING通PC5,因为PC5回应的数据在SW...
  • 文章目录路由静态路由配置交换机交换机vlan通信(Trunk配置)VTP协议...此时,Router3是ping不通10.10.10.11的 我们需要在Router3配置下一跳地址 ip route 第一个参数 子网掩码 第三个参数 第一个参数是Router6...
  • 注:记得配置PC的基础配置,敲命令之前或者之后都可以,但一定别忘了,否则最后PING不通的 PC基础配置 配置交换机 各端口配置 配置VLAN虚接口 三层交换机是具有路由功能的,因此可以配置虚接口 PING一下 ...
  • 学习中遇见的问题

    2009-06-03 17:58:09
    在学习CCNA的路由交换那一块的知识时,...在配置交换机之间的端口聚合实验时出现了问题: 不同vlan间相互ping不通。 为了证明端口聚合是否成功: 我又增加了两台pc,其中一台连到2层交换机上,另一台连到3层交换...
  • 如果ping不通,可以查看: 1)网线接触是否正常,如果是网线连接没有问题的话,网线头指示灯会亮。 2)如果是通过交换机连接的话,查看是否是交换机有问题,此时可以将网线通过直连的方式,如果网络正常,则是...
  • vlan间路由

    2021-01-27 16:29:33
    不同的vlan在二层肯定不能通信,只能在三层通信,交换机连上处于不同vlan的pc,他们之间通信就要走到三层,vlan多的话,路由器口不够用,通常路由器会以一个以太网接口和交换机连接,交换机的这个接口设置为trunk. ...
  • PC与日志主机之间不通,网络管理员通过tracert命令判断交换机(S9300-B)与路由器(Router)之间链路不通,但并不知道具体是哪一台设备发生了故障。考虑到ping命令是基于ICMP报文实现的,所以可以通过debugging命令...
  • 高手帮哈菜鸟!

    2009-06-13 20:16:59
    最近在做交换配置,实验图如下: 当没有把f0/8和f0/1设置成trunk口的时候,从PCA ping PCC能通,ping switchB也能通(注:两个交换机的F0/5.6.7划分给vlan 2,其他的接口默认...交换机之间也失去了了联系,哎呀 郁...

空空如也

空空如也

1 2
收藏数 40
精华内容 16
关键字:

交换机之间ping不通