精华内容
下载资源
问答
  • 目录交换机接口的三种模式1.access接口模式(接入链路,接入模式)2.trunk接口模式(中继模式,放通多个vlan)3.hybrid接口模式(混杂模式,混合模式)STP生成树协议1.stp生成树协议的介绍2.stp算法的步骤实验题1....

    交换机接口的三种模式

    1.access接口模式(接入链路,接入模式)

    接收数据:当接收到一个无标记帧的时候,打上自己的PVid并接受(就是自己的vlan标签)。当接收到一个有标记帧的时候,对比自己的pvid,如果相同就接收,不同就丢弃。
    发送数据:发送的时候对比vlanid是否跟自己的pvid相同,相同会剥离标签然后在链路上输送,如果不同就不发送,然后丢弃。

    2.trunk接口模式(中继模式,放通多个vlan)

    接收:当trunk接收到一个无标记帧的时候打上自己的pvid,对比允许列表有就接收(老师说的)。当接收到一个有标记帧的时候,对比允许列表,如果有就接收,没有就丢弃。
    发送:对比自己的pvid如果相同,发送的时候就剥离vlanid,如果不同就携带原id的标签发送。

    3.hybrid接口模式(混杂模式,混合模式)

    hybrid接口模式既有access的功能又有trunk的功能,比较复杂。
    交换机接口默认hybrid接口模式。
    hybrid相比另外两个模式多了tagged列表和untagged列表。
    接收:当接收到一个无标记帧的时候,查询自己的允许列表,如果有就打上自己的pvid并接收,无就不接收。 当接收到一个有标记帧的时候查询允许列表,有就接收无则丢弃。
    发送: 发送数据的时候对比tag表和untag表,如果是tag,就带标签发送,如果是untagged,就剥掉标签发送。如果数据不在tag和untag表中就丢弃。

    STP生成树协议

    1.stp生成树协议的介绍

    由于企业一般会使用多的交换机做数据链路的备份,而交换机超过两个后形成环状链路造成广播风暴,为了避免这种情况的产生便有了stp生成树协议。
    stp生成树协议通过在交换网络中部署生成树(Spanning-tree) 技术,能够防止网络中出现二层环路。STP运行后,如果网络中存在环路,那么STP通过阻塞(Block)特定的接口从而打破环路,并且在网络出现拓扑变更时及时收敛,以保证网络的冗余性。

    2.stp算法的步骤

    一、如何选择根网桥
    依据:网桥ID(BID)
    网桥ID=网桥优先级+网桥的MAC地址
    网桥优先级的取值范围:0-65535
    默认值:32768
    优先比较优先级,选最小
    当优先级相等的情况下,选MAC地址小的
    二、何选择根端口?
    1、到根桥最低的根路径成本
    某个网桥到达根网桥的中间所有线路的路径成本之和
    用来代表一条线路带宽的大小
    2、直连的网桥ID最小的
    3、对端端口ID(PID)最小的
    端口ID=端口优先级+端口编号
    端口优先级:0-255 默认值:128
    三、如何选择指定端口?
    根网桥上的每个端口都是指定端口,都不会被阻塞
    1、比较到达根桥的RPC(Root Path Cost),越小越优。
    2、比较BPDU包发送者的BID,越小越优。
    3、比较BPDU包发送者的PID,越小越优。
    4、比较BPDU包接收者的PID,越小越优。
    四、阻塞非指定端口(NonDesignated Port)。

    实验题

    实验一

    在这里插入图片描述

    首先配好各个pc的配置
    sw1的配置

    The device is running!
    
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sys sw1
    [sw1]
    [sw1]vlan batch 10 2 3
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]inter e0/0/1
    [sw1-Ethernet0/0/1]port hybrid pvid vlan 1
    [sw1-Ethernet0/0/1]q
    [sw1]dis vlan
    The total number of vlans is : 4
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(U)     
                    Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    
    2    common  
    3    common  
    10   common  
    
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    
    1    enable  default       enable  disable    VLAN 0001                         
    2    enable  default       enable  disable    VLAN 0002                         
    3    enable  default       enable  disable    VLAN 0003                         
    10   enable  default       enable  disable    VLAN 0010                         
    [sw1]inter e0/0/1
    [sw1-Ethernet0/0/1]p	
    [sw1-Ethernet0/0/1]port h	
    [sw1-Ethernet0/0/1]port hybrid un	
    [sw1-Ethernet0/0/1]port hybrid untagged vlan 1
    [sw1-Ethernet0/0/1]port hybrid untagged vlan 2
    [sw1-Ethernet0/0/1]inter e0/0/2
    [sw1-Ethernet0/0/2]port hybrid untagged vlan 1 
    [sw1-Ethernet0/0/2]port hybrid untagged vlan 2
    [sw1-Ethernet0/0/2]inter e0/0/3
    [sw1-Ethernet0/0/3]port hybrid pvid vlan 10
    [sw1-Ethernet0/0/3]port hybrid untagged vlan 3 
    [sw1-Ethernet0/0/3]port hybrid untagged vlan 10
    [sw1-Ethernet0/0/3]inter e0/0/4
    [sw1-Ethernet0/0/4]port hybrid untagged vlan 1
    [sw1-Ethernet0/0/4]port hybrid untagged vlan 2
    [sw1-Ethernet0/0/4]port hybrid tagged vlan 3
    [sw1-Ethernet0/0/4]port hybrid tagged vlan 10
    

    sw2的配置

    The device is running!
    
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sys sw2
    [sw2]
    [sw2]interface e0/0/1
    [sw2-Ethernet0/0/1]port hybrid pvid vlan 2
    Error: The VLAN does not exist.
    [sw2-Ethernet0/0/1]q
    [sw2]vlan batch 2 3 10
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2]inter e0/0/1
    [sw2-Ethernet0/0/1]port hybrid pvid vlan 2
    [sw2-Ethernet0/0/1]port hybrid untagged vlan 1
    [sw2-Ethernet0/0/1]port hybrid untagged vlan 2
    [sw2-Ethernet0/0/1]inter e0/0/2
    [sw2-Ethernet0/0/2]port hybrid pvid vlan 3
    [sw2-Ethernet0/0/2]port hybrid untagged vlan 3
    [sw2-Ethernet0/0/2]port hybrid untagged vlan 10
    [sw2-Ethernet0/0/2]inter e0/0/3
    [sw2-Ethernet0/0/3]port hybrid untagged vlan 1
    [sw2-Ethernet0/0/3]port hybrid untagged vlan 2
    [sw2-Ethernet0/0/3]port hybrid tagged vlan 3
    [sw2-Ethernet0/0/3]port hybrid tagged vlan 10
    [sw2-Ethernet0/0/3]
    

    之后互ping发现pc1,2和pc4通,pc3和pc5互通。

    实验二

    在这里插入图片描述
    先配好pc的ip和子网掩码,路由器和pc6用来迷惑的,不考虑。
    sw1的配置

    The device is running!
    
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sys
                ^
    Error:Incomplete command found at '^' position.
    [Huawei]sys sw1
    [sw1]
    [sw1]vlan batch 10 20 30 
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw1]inter e0/0/1
    [sw1-Ethernet0/0/1]port hybrid pvid vlan 10
    [sw1-Ethernet0/0/1]port hybrid untagged vlan 10
    [sw1-Ethernet0/0/1]port hybrid untagged vlan 30
    [sw1-Ethernet0/0/1]inter e0/0/2
    [sw1-Ethernet0/0/2]port hybrid pvid vlan 20
    [sw1-Ethernet0/0/2]port hybrid untagged vlan 30
    [sw1-Ethernet0/0/2]port hybrid untagged vlan 20
    [sw1-Ethernet0/0/2]interface e0/0/3
    [sw1-Ethernet0/0/3]port hybrid tagged vlan 10
    [sw1-Ethernet0/0/3]port hybrid tagged vlan 20
    [sw1-Ethernet0/0/3]port hybrid tagged vlan 30
    

    sw2的配置

    The device is running!
    
    <Huawei>sys
    Enter system view, return user view with Ctrl+Z.
    [Huawei]sys sw2
    [sw2]vl
    [sw2]vlan batch 10 20 30
    Info: This operation may take a few seconds. Please wait for a moment...done.
    [sw2]inter e0/0/1
    [sw2-Ethernet0/0/1]port hybrid tagged vlan 10
    [sw2-Ethernet0/0/1]port hybrid tagged vlan 20
    [sw2-Ethernet0/0/1]port hybrid tagged vlan 30
    [sw2-Ethernet0/0/1]inter e0/0/2
    [sw2-Ethernet0/0/2]port hybrid pvid vlan 10
    [sw2-Ethernet0/0/2]port hybrid untagged vlan 10
    [sw2-Ethernet0/0/2]port hybrid untagged vlan 30
    [sw2-Ethernet0/0/2]inter e0/0/3
    [sw2-Ethernet0/0/3]port hybrid pvid vlan 20
    [sw2-Ethernet0/0/3]port hybrid untagged vlan 30
    [sw2-Ethernet0/0/3]port hybrid untagged vlan 20
    [sw2-Ethernet0/0/3]inter e0/0/4
    [sw2-Ethernet0/0/4]port hybrid pvid vlan 30
    [sw2-Ethernet0/0/4]port hybrid untagged vlan 10
    [sw2-Ethernet0/0/4]port hybrid untagged vlan 20
    [sw2-Ethernet0/0/4]port hybrid untagged vlan 30
    

    配置好后ping一下
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    实验三

    在这里插入图片描述
    1.首先看优先级和mac地址来确定根网桥
    三个交换机都是默认优先级32768,再看mac地址确定sw1为根网桥。
    2.再看路径花销确定根接口
    sw2到sw1的cost是19,sw3到sw2到sw1的cost是38>sw3到sw1的100,
    所以根接口是sw2的连sw1的接口,sw3的连sw2的接口
    3.再看指定端口是哪些
    根网桥的端口都是指定端口,再看每一段的接口得知sw2的连sw3的接口
    是指定端口,通过对比优先级等得知sw2的与sw1连线的端口是阻塞端口。

    展开全文
  • 交换机的三种接口模式2.STP生成树2.1 STP生成树的部分知识2.2 BPDU 报文3.实验题3.1 实验一:3.2实验二:3.3 实验三: 1.交换机的三种接口模式 目的就是在研究 发送数据跟接收数据的操作 在交换机的内部,数据永远是...

    1.交换机的三种接口模式

    目的就是在研究 发送数据跟接收数据的操作
    在交换机的内部,数据永远是带着标签的,不做任何更改的
    在主机,路由器中,数据是不识别带标签的帧,根据IP地址 做路由转发
    主机发送数据,原始数据,不带任何标签
    工作模式:
    access 接入链路,接入模式
    trunk 中继链路,中继模式 放通多个vlan
    hybrid 混杂模式,混合模式,access+trunk

    交换机的三种接口模式分析
    access:
    接收 :
    当接收到一个无标记帧的时候,打上自己的PVID (属于哪一个段的vlan) 并接收
    当接收到一个有标记帧的时候,对比自己的PVID (属于哪一个段的vlan)
    如果相同就接收,不同就丢弃

    发送 :发送时对比vlan id标签,是否跟自己的pvid相同,相同的话就剥离vlan 标签,不同的就丢弃

    trunk
    接收:
    当接收到一个无标记帧的时候,打上自己的PVID ,对比允许列表,如果有就接收,没有就丢弃
    当接收到一个有标记帧的时候,对比自己的PVID,对比允许列表,如果有就接收,没有就丢弃

    发送:对比自己的PVID,如果相同,发送的时候就剥离vlan id 标签发送
    如果不同,就携带原来id标签发送

    access 接入链路,发送级剥离,进入就添标签,只允许一个vlan
    trunk 多条链路之间

    hybrid
    hybrid交换机上默认的模式
    接收:
    当接受到一个无标记帧的时候,查询允许列表,如果有,就打pvid 接收,无就不接收
    当接受到一个有标记帧的时候,查询允许列表,有就接收,无则丢弃
    打了标签的数据 tagged
    没有打标签的数据 untagged
    发送:
    对比tag 和untag表
    如果有,如果是tag,就带标签发送
    如果是untag,就剥离标签发送
    如果不存在 tag 和untag 表中,则直接丢弃

    Access端口只属于1个VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;
    Hybrid端口和Trunk端口属于多个VLAN,所以需要设置缺省VLAN ID。缺省情况下,Hybrid端口和Trunk端口的缺省VLAN为VLAN 1

    Tag和Untag,tag是指vlan的标签,即vlan的id,用于指名数据包属于那个vlan,untag指数据包不属于任何vlan,没有vlan标记

    pvid,即端口vlan id号

    简述access、trunk和hybrid在使用场景上的区别
    接入模式
    使用场景:常用于连接PC、终端设备、路由器等不能识别VLAN标记的流量的

    中继模式
    使用场景:常用于两台交换机之间相连的链路,用于承载所有的VLAN流量的

    混杂模式
    使用场景:任意场景,但Hybrid的灵活性很高不易于配置

    三层交换机就是具有部分路由器功能的交换机,其最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发

    2.实验题

    2.1 实验一:

    解释:
    如图所示SW1为根交换机,根据到根桥最低的路径成本可以确定SW2的1端口和SW3的2端口为根端口。再根据根网桥的每个端口都是指定端口和开销越小越优先可以确定SW1的1、2端口和SW2的2端口为指定端口,最后确定SW3的1端口为阻塞端口。

    2.2实验二:

    检测哪些可以ping 通

    sw1:
    <Huawei>sys
    [Huawei]sysname sw1
    [sw1]vlan b 1 2 3 10
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]port link-type hybrid
    [sw1-Ethernet0/0/1]port hybrid pvid vlan 1
    [sw1-Ethernet0/0/1]port hybrid untagged vlan 1 2
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port hybrid pvid vlan 1
    [sw1-Ethernet0/0/2]port hybrid untagged vlan 1 2
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]port hybrid pvid vlan 10
    [sw1-Ethernet0/0/3]port hybrid untagged vlan 3 10
    [sw1-Ethernet0/0/3]int g0/0/1
    [sw1-GigabitEthernet0/0/1]port hybrid untagged vlan 1 2
    [sw1-GigabitEthernet0/0/1]port hybrid tagged vlan 3 10
    [sw1-GigabitEthernet0/0/1]
    
    sw2:
    The device is running!
    [Huawei]sysname sw2
    Enter system view, return user view with Ctrl+Z.
    [sw2]vlan b 1 2 3 10
    [sw2]int g0/0/1
    [sw2-GigabitEthernet0/0/1]port link-type hybrid
    [sw2-GigabitEthernet0/0/1]port hybrid untagged vlan 1 2
    [sw2-GigabitEthernet0/0/1]port hybrid tagged vlan 3 10
    [sw2-GigabitEthernet0/0/1]int e0/0/1
    [sw2]int e0/0/1
    [sw2-Ethernet0/0/1]port hybrid pvid vlan 2
    [sw2-Ethernet0/0/1]port hybrid untagged vlan 1 2
    [sw2-Ethernet0/0/1]int e0/0/2
    [sw2-Ethernet0/0/2]port hybrid pvid vlan 3
    [sw2-Ethernet0/0/2]port hybrid untagged vlan 3 10
    [sw2-Ethernet0/0/2]
    
    

    得出的结果是
    pc1-pc2
    pc1-pc4
    pc2-pc4
    pc3-pc5 这些可以互通

    2.3 实验三:

    sw1:
    
    <Huawei>
    <Huawei>sys
    [Huawei]sysname sw1
    [sw1]vlan b 10 20 30
    [sw1]int e0/0/1
    [sw1-Ethernet0/0/1]p l h
    [sw1-Ethernet0/0/1]p h p v 10
    [sw1-Ethernet0/0/1]port hybrid untagged vlan 10 30
    [sw1-Ethernet0/0/1]int e0/0/2
    [sw1-Ethernet0/0/2]port hybrid pvid vlan 20
    [sw1-Ethernet0/0/2]port hybrid untagged vlan 20 30
    [sw1-Ethernet0/0/2]int e0/0/3
    [sw1-Ethernet0/0/3]port hybrid tagged vlan 10 20 30
    [sw1-Ethernet0/0/3] User interface con0 is available
    
    sw2:
    [Huawei]sysname sw2
    [sw2]vlan b 10 20 30
    [sw2]int e0/0/1
    [sw2-Ethernet0/0/1]port link-type hybrid 
    [sw2-Ethernet0/0/1]port hybrid tagged vlan 10 20 30
    [sw2-Ethernet0/0/1]int e0/0/2
    [sw2-Ethernet0/0/2]port hybrid pvid vlan 10
    [sw2-Ethernet0/0/2]port hybrid untagged vlan 10 30
    [sw2-Ethernet0/0/2]int e0/0/3
    [sw2-Ethernet0/0/3]port hybrid pvid vlan 20
    [sw2-Ethernet0/0/3]port hybrid untagged vlan 20 30
    [sw2-Ethernet0/0/3]int e0/0/4
    [sw2-Ethernet0/0/4]port hybrid untagged vlan 30
    [sw2-Ethernet0/0/4]undo port hybrid untagged vlan 30
    [sw2-Ethernet0/0/4]port hybrid pvid vlan 30
    [sw2-Ethernet0/0/4]undo port hybrid untagged vlan 10 20 30
    Error: The hybrid port does not join the VLAN.
    [sw2-Ethernet0/0/4]port hybrid untagged vlan 10 20 30
    [sw2-Ethernet0/0/4]
    


    展开全文
  • #交换机的堆叠优先级默认为100,数值越大越优先,SWA修改为200 [SWA]stack slot 0 priority 200 #配置要启用的堆叠接口 [SWA]interface stack-port 0/1 [SWA-stack-port0/1]port interface XGigabitEthernet 0/0/3 ...
  • 交换机原理

    2018-07-08 15:13:22
    交换机原理Ethernet是...路由器的一个接口下的网络是一个广播域。所以路由器可以隔离广播域。1原理应用▪冲突域▪广播域2以太网▪识别标准▪接线标准▪接线方法3工作原理▪地址表▪转发决策▪生存期▪三层交换机...

    交换机原理

    Ethernet以太网的意思,历史上使用的是十兆标准,现代基本上是百兆到桌面,千兆做干线。对数据业务量大的多采用千兆到桌面,万兆做干线。
    交换机和 集线器对广播帧是透明的,所以用交换机和HUB组成的网络是一个广播域。 路由器的一个接口下的网络是一个广播域。所以路由器可以隔离广播域。

    原理应用

    交换机是根据网桥的原理发展起来的,学习交换机先认识两个概念

    冲突域

    冲突域是数据必然发送到的区域。
    HUB是无智能的信号 驱动器,有入必出,整个由HUB组成的网络是一个冲突域。
    交换机的一个接口下的网络是一个冲突域,所以交换机可以隔离冲突域

    广播域

    广播数据时可以发送到的区域是一个 广播域
    交换机和 集线器对广播帧是透明的,所以用交换机和HUB组成的网络是一个广播域。
    路由器的一个接口下的网络是一个广播域。所以路由器可以隔离广播域
    以太网

    识别标准

    常见的标准有:
    10BASE-2 细缆以太网
    10BASE-5 粗缆以太网
    10BASE-T星型以太网
    100BASE-T 快速以太网
    接线标准
    星型以太网采用双绞线连接,双绞线是8芯,分四组,两芯一组绞在一起,故称双绞线。
    8芯双绞线只用其中4芯:1、2、3、6。
    常见接线方式有两种:
    568B接线规范: 白橙 橙 白绿 蓝 白蓝 绿 白棕 棕
    1 2 3 4 5 6 7 8
    568A接线规范: 白绿 绿 白橙 蓝 白蓝 橙 白棕 棕
    3 6 14 5 2 7 8
    将568B的1和3对调,2和6对调,就得到568A。
    接线方法
    两边采用相同的接线方式叫做平接,两边采用不同的接线方式叫扭接。
    不同的设备之间连接,使用平接线;相同的设备连接使用扭接线。
    电脑、 路由器集线器、交换机连接时使用平接线。
    这是因为网线中的4条线,一对是输入,一对是输出,输入应该与输出对应。
    如果将1和3连接,2和6连接,相当于自己的输出送给自己的输入。
    这样可以使网卡 进入工作状态,阻止空接口关闭,而影响有些程序的运行。

    工作原理

    地址表

    端口地址表记录了端口下包含 主机的MAC地址。端口地址表是交换机上电后自动建立的,
    保存在RAM中,并且自动维护。
    交换机隔离 冲突域的原理是根据其端口地址表和转发决策决定的。

    转发决策

    交换机的转发决策有三种操作:丢弃、转发和扩散。
    丢弃:当本端口下的主机访问已知本端口下的主机时丢弃。
    转发:当某端口下的主机访问已知某端口下的主机时转发。
    扩散:当某端口下的 主机访问未知端口下的主机时要扩散。
    每个操作都要记录下发包端的MAC地址,以备其它主机的访问。

    生存期

    生存期是端口地址列表中表项的寿命。每个表项在建立后开始进行倒记时,每次发送
    数据都要刷新记时。对于长期不发送数据的主机,其MAC地址的表项在生存期结束时删除。
    所以端口地址表记录的总是最活跃的主机的MAC地址。

    (4)应该说交换机有很多值得学习的地方,这里我们主要介绍交换机结构及组网方式,21世纪10年代以来网络应用越来越广泛,交换机作为网络中的纽带发挥了越来越大的作用。简单的说,交换机就是将它与用户计算机相连就行了,完成各个计算机之间的数据交换。复杂来说,交换机针对在整个网络中的位置而言,一些高层交换机如三层交换、网管型的产品,在交换机结构方面就没这么简单了。


    三层交换机

    通常,普通的交换机只工作在 数据链路层上, 路由器则工作在网络层。而功能强大的 三层交换机可同时工作在数据链路层和网络层,并根据 MAC地址或IP地址转发 数据包。但是要注意到三层交换机并不能完全取代路由器,因为它主要是为了实现处于两个不同 子网的Vlan进行通讯,而不是用来作数据传输的复杂路径选择。

    网管功能

    一台交换机所支持的管理程度反映了该设备的可管理性与可操作性。带网管功能的交换机可对每个端口的流量进行监测,设置每个端口的速率,关闭/打开端口连接。通过对交换机端口进行监测,便于对网络业务流量的区分和迅速进行 网络故障定义,提高了网络的可管理性。

    端口聚合

    这是一种封装技术,它是一条点到点的链路,链路的两端可以都是交换机,也可以是交换机和 路由器,还可以是 主机和交换机或路由器。基于 端口汇聚(Trunk)功能,允许交换机与交换机、交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行连接同时传输以提供更高带宽、更大吞吐量, 大幅度提供整个网络能力。

    华为交换机6700(SwitchA和SwitchB)上聚合配置:
    interface Eth-Trunk1     //创建聚合
     port link-type trunk
     port trunk allow-pass vlan 100 to 200 //这条聚合链路上放通vlan 100-200
     undo port trunk allow-pass vlan 1
     bpdu enable    //可不加
    quit
    interface GigabitEthernet0/0/1
     eth-trunk 1              //端口号聚合
     lacp priority 100        //可不加
     undo negotiation auto    //可不加
    quit
    interface GigabitEthernet0/0/2
     eth-trunk 1
     lacp priority 100       //可不加
     undo negotiation auto   //可不加
    quit
    interface GigabitEthernet0/0/3
     eth-trunk 1
     lacp priority 100       //可不加

     undo negotiation auto   //可不加

    quit



    结构

    级联方式

    这是最常用的一种组网方式,它通过交换机上的 级联口(UpLink)进行连接。需要注意的是交换机不能无限制级联,超过一定数量的交换机进行级联,最终会引起 广播风暴,导致网络性能严重下降。

    聚合方式

    前面我们已接触到 端口聚合的特点,此种方式相当于用多个端口同时进行级联,它提供了更高的互联 带宽和线路 冗余,使网络具有一定的可靠性。

    堆叠方式

    交换机的堆叠是扩展端口最快捷、最便利的方式,同时堆叠后的带宽是单一交换机 端口速率的几十倍。但是,并不是所有的交换机都支持堆叠的,这取决于交换机的品牌、型号是否支持堆叠;并且还需要使用专门的堆叠电缆和堆叠模块;最后还要注意同一叠堆中的交换机必须是同一品牌。

    分层方式

    这种方式一般应用于比较复杂的交换机结构中,按照功能可划分为: 接入层汇聚层、核心层。

    后记

    作为网络的重要连接设备,交换机在实际使用中相当频繁。对于一般家庭用户而言,比较复杂的应用就是交换机的级联结构了;而三层路由、堆叠等高级应用一般在企业中应用较多。

    协议术语

    (1)网桥协议 数据单元:BPDU(Bridge Protocol Data Unit)
    BPDU是 生成树协议交换机间通讯的数据单元,用于确定角色。
    (2)网桥号:Bridge ID
    交换机的标识号,它由优先级和MAC地址组成,优先级16位,MAC地址48位。
    (3)根网桥:Root bridge
    根网桥定义为网桥号最小的交换机,根网桥所有的端口都不会阻塞。
    (4)根端口:Root port
    非根网桥到根网桥累计路径花费最小的端口,负责本网桥与根网桥通讯的接口。
    (5)指定网桥:Designated bridge
    网络中到根网桥累计路径花费最小交换机,负责收发本 网段数据。
    (6)指定端口:Designated port
    网络中到根网桥累计路径花费最小的交换机端口,根网桥每个端口都是指定端口。
    (7)非指定端口:NonDesignated port
    余下的端口是非指定端口,它们不参与数据的转发,也就是被阻塞的端口。
    (根端口是从非根网桥选出,指定端口是网段中选出)。
    生成树协议的状态:
    生成树协议工作时,所有端口都要经过一个端口状态的建立过程。
    生成树协议通过BPDU广播,确定各交换机及其端口的工作状态和角色,
    交换机上的端口状态分别为:关闭、阻塞、侦听、学习和转发状态。
    (1)关闭状态:Disabled 不收发任何报文,当接口 空连接或人为关闭时处于关闭状态。
    (2) 阻塞状态:Blocking 在机器刚启动时,端口是阻塞状态(20秒),但接收BPDU信息。
    (3)侦听状态:listening 不接收用户数据(15秒),收发BPDU,确定网桥及接口角色。
    (4)学习状态:learning 不接收用户数据(15秒),收发BPDU,进行地址学习。
    (5)转发状态:Forwarding 开始收发用户数据,继续收发BPDU和地址学习,维护STP。

    网络环路

    以太网是总线或星型结构,不能构成环路,否则会产两个严重后果:
    (1)产生 广播风暴,造成网络堵塞。
    (2)克隆帧会在各个口出现,造成地址学习(记录帧源地址)混乱。
    解决环路问题方案:
    (1)网络在设计时,人为的避免产生环路。
    (2)使用 生成树STP(Spanning Tree Protocol)功能,将有环的网络剪成无环网络。
    STP被IEEE802规范为802.1d标准。

    VLAN

    Virtual Lan是虚拟 逻辑网络,交换机通过VLAN设置,可以划分为多个逻辑网络,
    从而隔离 广播域。具有三层模块的交换机可以实现VLAN间的路由。
    (1)端口模式
    交换机端口有两种模式,access和 trunk。access口用于与计算机相连,而交换机之间
    的连接,应该是trunk。
    交换机端口默认VLAN是VLAN1,工作在access模式。
    Access口收发数据时,不含VLAN标识。具有相同VLAN号的端口在同一个广播域中。
    Trunk口收发数据时,包含VLAN标识。Trunk又称为干线,可以设置允许多个VLAN通过。
    (2)VLAN中继协议:
    VLAN中继协议有两种:
    ISL(Inter-Switch Link): ISL是Cisco专用的VLAN中继协议。
    802.1q(dot1q):802.1q是标准化的,应用较为普遍。
    (3)VTP
    VTP(Vlan Trunking Protocol)是VLAN 传输协议,在含有多个交换机的网络中,可以
    将中心交换机的VLAN信息发送到下级的交换机中。
    中心交换机设置为VTP Server,下级交换机设置为VTP Client。
    VTP Client要能学习到VTP Server的VLAN信息,要求在同一个VTP域,并要口令相同。
    (4)VLAN共享
    如果要求某个VLAN与其他VLAN访问,可以设置VLAN共享或主附VLAN。
    共享模式的VLAN端口,可以成为多个VLAN的成员或同时属于多个VLAN。
    在主附VLAN结构中,子VLAN与主VLAN可以相互访问,子VLAN间的端口不能互相访问。
    一般的VLAN间使用不同 网络地址;主附VLAN中主VLAN和子VLAN使用同一个网络地址。

    口令恢复

    交换机的口令恢复的操作是先启动 超级终端,在交换机上电时按住的mode键.
    几秒后松手,进入ROM状态,将nvram中的配置文件config.txt改名或删除,再重启。
    参考命令为:
    switch:rename flash:config.text flash:config.bak
    switch:erase flash:config.text
    路由器的口令恢复操作先启动超级终端,在路由器上电时按计算机的Ctrl+Break键,
    进入ROM监控状态rommon>,用配置寄存器命令confreg设置参数值0x2142,跳过配置文件
    设置口令后再还原为0x2102。
    参考命令为:
    rommon>confreg 0x2142
    router(config)#config-register 0x2102
    没有特权口令无法进入特权状态,只能进入ROM监控状态,使用confreg 0x2142命令。
    当口令修改完后,可以在特权模式下恢复为使用配置文件状态。

    三层概念

    链路层

    使用MAC地址,完成对帧的操作。
    交换机的IP地址做管理用,交换机的IP地址实际是VLAN的IP。
    一个VLAN一个 广播域,不同VLAN的主机间访问,相当于网络间的访问,要通过 路由实现。
    不同VLAN间主机的访问有以下几种情况:
    (1)两个VLAN分别 接入路由器的两个物理接口。这是 路由器的基本应用。
    (2)两个VLAN通过 trunk接入路由器的一个物理接口,这是应用于 子接口单臂路由
    (3)使用具有三层交换模块的交换机。Cisco的3550和华为的3526都是基本的 三层交换机
    1)通过VLAN的IP地址做 网关,实现 三层交换,要求设置VLAN的IP地址。
    2)将端口设置在三层工作,要求端口设置no switchport,再设置端口的IP地址。 [3]  

    通道技术

    交换机通道技术是将交换机的几个端口捆绑使用,即端口的聚合。
    使用通道技术一个方面提高了 带宽,同时提高了线路的可靠性。
    但是如果设置不当,有可能产生环路,造成 广播风暴堵塞网络。
    要聚合的端口要划分到指定的VLAN或 trunk
    配置三层通道时,先要进入通道,再用no switchport命令关闭二层,设置通道IP地址。
    一个通道一般小于8个接口,接口参数应该一致,如工作模式、封装的协议、端口类型。

    协商方式

    端口的聚合有两种方式,一种是手动的方式,一个是自动协商的方式。
    手动的方式很简单,设置端口成员链路两端的模式为“on”。命令格式为:
    channel-group <number> mode on
    自动方式有两种类型:
    PAgP(Port Aggregation Protocol)和LACP(Link aggregation Control Protocol)。
    PAgP:Cisco设备的 端口聚合协议,有auto和desirable两种模式。
    auto模式在协商中只收不发,desirable模式的端口收发协商的 数据包
    LACP:标准的端口聚合协议802.3ad,有active和passive两种模式。
    active相当于PAgP的auto,而passive相当于PAgP的desirable。

    负载平衡

    通道端口间的负载平衡有两种方式,基于源MAC的转发和基于目的MAC的转发。
    scr-mac:源MAC地址相同的 数据帧使用同一个 端口转发
    dst-mac:目的MAC地址相同的数据帧使用同一个端口转发。

    四层技术

    随着宽带的普及,各种网络应用的深入,我们的局域网络正在承担着繁重的业务流量。网络系统中的音频、视频、数据等信息的传输量充斥着占用带宽,我们不得不为这些数据流量提供差别化的服务,让时延敏感性的和重要的数据优先通过,这就不得不考虑 第四层交换,以满足基于策略调度、QoS(Quality of Service:服务质量)以及安全服务的需求。

    区别

    第二层交换实现局域网内主机间的快速信息交流,第 三层交换可以说是交换技术与 路由技术的完美结合,而第四层交换技术则可以为网络应用资源提供最优分配,实现应用服务服务质量、 负载均衡及安全控制。四层交换并不是要取代谁,其实2013年泾渭分明的二层交换和三层交换已融入四层交换技术。
    第二层交换机,是根据第二层 数据链路层的MAC地址和 MAC地址表来完成端到端的数据交换的。第二层交换机只须识别 数据帧中的MAC地址,而直接根据MAC地址转发,非常便于采用ASIC专用芯片实现。第二层交换的解决方案,是一个“处处交换”的方案,虽然该方案也能划分 子网、限制广播、建立VLAN,但它的控制能力较小、灵活性不够,也无法控制流量,缺乏路由功能。
    第三层交换机,是根据第三层的网络层IP地址来完成端到端的数据交换的,主要应用于不同VLAN子网间的 路由。当某一信息源的第一个 数据流进行第 三层交换(路由)后,交换机会产生一个MAC地址与IP地址的映射表,并将该表存储起来,如同一信息源的后续数据流再次进入交换机,交换机将根据第一次产生并保存的 地址映射表,直接从第二层由源地址传输到目的地址,不再经过第三路由系统处理,提高了 数据包的转发效率,解决了VLAN 子网间传输信息时传统 路由器产生的速率瓶颈。
    第四层交换机不仅可以完成端到端交换,还能根据端口 主机的应用特点,确定或限制它的交换流量。简单地说,第四层交换机是基于传输层数据包的交换过程的,是一类基于 TCP/IP协议 应用层的用户应用交换需求的新型 局域网交换机。第四层交换机支持TCP/UDP第四层以下的所有协议,可根据TCP/UDP 端口号来区分数据包的应用类型,从而实现应用层的 访问控制和服务质量保证。可以查看第三层数据包头源地址和目的地址的内容,可以通过基于观察到的信息采取相应的动作,实现带宽分配、故障诊断和对TCP/IP应用程序 数据流进行访问控制的关键功能。 第四层交换机通过任务分配和 负载均衡优化网络,并提供详细的流量统计信息和记帐信息,从而在应用的层级上解决 网络拥塞、网络安全和网络管理等问题,使网络具有智能和可管理。

    技术简介

    OSI网络参考模型的第四层是传输层。传输层负责 端到端通信,即在网络源和目标系统之间协调通信。在IP协议栈中这是TCP( 传输控制协议)和UDP( 用户数据报协议)所在的协议层。TCP和UDP包含 端口号,它可以唯一区分每个 数据包包含哪些应用协议(例如HTTP、FTP、telnet等等)。TCP/UDP端口号提供的附加信息可以为 网络交换机所利用,四层交换机利用这种信息来区分包中的数据,这是第四层交换的基础。

    功能介绍

    1.数据包过滤:在传统 路由器上,采用第四层信息端口号去定义 访问控制列表过滤规则。四层交换也借用了控制列表的概念,但和基于软件的路由器不一样,第四层交换是在ASIC专用高速芯片中实现的,从而使过滤控制可以线速进行。
    2.服务质量:TCP/UDP第四层信息还可以用于建立应用通信的优先级。 第四层交换允许用基于 端口号(应用)来区分优先级,设置 优先级队列,确保重要的流量(如:VOIP、视频)在得到最快的处理,使紧急应用获得网络的高级别服务。
    3. 负载均衡:第四层交换负载均衡的原理,就是按照IP地址和TCP端口进行虚拟连接的交换,直接将 数据包发送到目的计算机的相应端口中。具备第四层交换能力的交换机,能作为一个硬件 负载均衡器,完成服务器的负载均衡。由于第四层交换基于硬件芯片,因此性能非常优秀,尤其是对于网络传输的速度,交换的速度远远超过普通的数据包转发。采用 第四层交换机设备,所有的集群 主机通过第四层交换机与外部Internet相连,外部客户防问服务器时通过第四层交换机动态分配服务器,实现动态 负载均衡,当其中一台服务器出现故障时,由交换机动态将所有流量分配到集群中的其他主机上,这类只适合在大型流量大的服务器。
    4.主机备用连接:主机备用连接为端口设备提供了 冗余连接,从而在交换机发生故障时有效保护系统,这种服务允许定义主备交换机,同 虚拟服务器定义一样,它们有相同的配置参数。由于 第四层交换机共享相同的MAC地址,备份交换机接收和主单元全部一样的数据。这使得备份交换机能够监视主交换机服务的通信内容。主交换机持续地通知备份交换机第四层的有关数据、MAC数据以及它的电源状况。主交换机失败时,备份交换机就会自动接管,不会中断对话或连接。
    5.统计与报告:通过查询第四层 数据包,第四层交换机能够提供更详细的统计记录。因为管理员可以收集到更详细的哪一个IP地址在进行通信的信息,甚至可根据通信中涉及到哪一个 应用层服务来收集通信信息。当服务器支持多个服务时,这些统计对于考察服务器上每个应用的负载尤其有效。增加的统计服务对于使用交换机的服务器 负载均衡服务连接同样十分有用。包含详尽的实时报告和历史纪录报告,全面的报告功能为管理员提供了对带宽资源的充分掌握,从而使企业可以作出更合适的业务决策。
    第四层交换机在业界有一通用的名字叫做“应用交换机”,比较有名的有如下几款:
    美国的F5公司的BIG-IP 2400系列链路应用交换机可实定制 负载平衡,流量优先级安排,基于政策的流量引导,来源、目的地和应用交换。
    Radware公司的Web Server Director应用交换机可保障服务器群的完全可用性、优化运行以及完备的安全性,从而保证网络和数据中心范围内的应用能获得高度可靠性和性能。
    美国Foundry公司 ServerIronGT-C2404F应用交换机可实现全局服务器 负载均衡,高性能 VPN/ 防火墙负载均衡,透明缓存交换, 链路负载均衡,防DoS攻击保护服务器。

    总结

    随着网络信息系统由小型到中型到大型的发展趋势,交换技术也由原来最初的基于MAC地址的交换,发展到基于IP地址的交换,进一步发展到基于IP+端口的交换,本文对第四层交换技术作了一个比较全面的介绍,如今也有产品更提出了第七层交换(基于内容的交换)。可见,网络交换技术的不断发展使得原来由基于数据的交换变成了基于应用的交换,不仅提高了网络的访问速度,而且不断地优化了网络的整体性能。





    展开全文
  • 华为交换机

    2020-08-24 14:08:22
    当网络阻塞时,交换机优先发送优先级高的数据帧CFI1bit标准格式指示位,表示MAC地址在不同的传输介质中是否以标准格式进行封装,用于兼容以太网和令牌环网。表示MAC地址以标准格式进行封装,为1表示以非标准格式封装...

    背景简介作用优缺点MAC地址配置 背景简介作用优缺点 是由IEEE电气与电子工程师协会分配的。全球唯一 用来定义网络设备的位置,MAC地址由48比特长、12位的16进制数字组成,其中从左到右开始,0到23bit是厂商向IETF等机构申请用来标识厂商的代码,24到47bit由厂商自行分派,是各个厂商制造的所有网卡的一个唯一编号。 物理地址标识了以太网上的一个终端, 广播地址用来标识局域网内所有终端设备 组播地址用来标识局域网中的一组设备,第八位为1的地址为组播mac地址。 全球唯一MAC地址表背景分类作用优缺点mac地址表记录了交换机学习到的其他设备的mac地址与接口的对应关系,以及接口所属的VLAN信息。1、动态表项 通过查看动态表项可以判断两台设备之间是否有数据转发2、静态表项 和接口绑定,防止非法用户伪装3、黑洞表项 过滤非法用户,丢弃 用于指导报文进行单播转发。交换机在转发报文时,根据报文中的目的MAC地址查询MAC地址表。 优点:可以自己学习和老化,老化时间默认300s 缺点:mac地址表会造成mac地址漂移 mac漂移:是指一个VLAN中,有两个端口同时学习到了一个MAC地址。MAC地址防漂移作用: 1、通过mac防漂移,可以防止用户攻击 2、通过mac防漂移,可以快速判定是否存在环路实现方式: 1、配置接口MAC地址优先级背景简介作用优缺点配置接口的mac地址优先级后,可以防止mac地址漂移当设备不同接口学习到相同MAC时,高优先级接口学到的表项会覆盖低优先级学到的表项防止mac地址漂移 2、配置不允许相同优先级接口mac地址漂移背景简介作用优缺点如果与交换机接口连接的网络设备例如:服务器,下电后,交换机上另外的接口学习到与该网络设备同样的MAC地址,当网络设备再次上电后不能学习到正确的MAC地址。配置不允许相同优先级的接口发生MAC地址表项覆盖,可以防止MAC地址漂移防止mac地址漂移,提高网络的安全性。端口桥背景简介作用应用场景 同源同宿报文即源MAC地址和目的MAC地址均在设备的同一接口上学习到的报文,设备判断为非法报文并直接丢弃该报文 转发同源同宿报文 当接口收到同源同宿报文时,若设备上的MAC地址表中存在与该报文的目的MAC地址对应的表项,则将报文从本接口转发出去。1、设备下挂有不具备二层转发能力的设备,当它们有通信需求时,会将报文送到设备完成。由于报文 的源宿地址都是设备同一接口学习到的,此时需要使用端口桥功能。2、在数据中心做接入设备且下挂服务器,一台服务器启动多个虚拟机,多个虚拟机之间需要通信。配置重新标记报文的目的MAC地址背景简介作用优缺点 通过配置重标记,设备对符合流分类规则的报文的指定字段进行设置 重标记报文某些字段,不会影响当前设备对报文的QoS处理,仅会影响下游设备对报文的QoS处理。报文某些字段:标记QoS:报文质量 将指定流分类的报文重标记报文目的MAC地址,方便下游设备对报文进行识别,提供相应的QoS服务。以太网链路聚合—8月21日简介作用优缺点 Eth-Trunk简称链路聚合,通过将多个物理接口捆绑成一个逻辑接口,可以在不进行硬件升级的条件下,达到增加链路带宽的目的。增加带宽提高可靠性负载均衡增加带宽提高可靠性负载均衡链路聚合组和链路聚合接口 链路聚合组LAG是指将若干条以太链路捆绑在一起所形成的逻辑链路。 链路聚合接口:背景简介作用优缺点 每个聚合组唯一对应着一个逻辑接口,这个逻辑接口称之为链路聚合接口或Eth-Trunk。链路聚合接口可以作为普通的以太网接口来使用。与普通以太网接口相比:转发的时候链路聚合组需要从成员接口中选择一个或多个接口来进行数据转发成员接口:组成Eth-Trunk的各个物理接口成为成员接口。成员链路:成员接口对应的链路称为成员链路VLAN背景简介作用优缺点 虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术 限制广播域 增强局域网的安全性 提高了网络的健壮性 网络构建和维护更方便灵活VLAN标签背景简介作用优缺点IEEE802.1Q协议规定,在以太网数据帧的目的MAC地址和源MAC地址字段之后、协议类型字段之前加入4个字节的VLAN标签,用以标识VLAN信息要使交换机能够分辨不同VLAN的报文,需要在报文中添加标识VLAN信息的字段。用来标识VLAN信息 VLAN标签包含4个字段 :字段长度含义取值TPID2Byte(标签协议标识符)表示数据帧类型 取值为0x8100时表示IEEE802.1Q的VLAN数据帧。如果不支持802.1Q的设备收到这样的帧,会丢弃。 设备厂商可以自定义该值。当邻居设备将该值配置为非0x8100时,为了能够识别这样的报文,必须在本设备上修改TPID值,确保和邻居设备的TPID值一致。PRI3bitPriority,表示数据帧的802.1p优先级取值范围0~7,值越大优先级越高。当网络阻塞时,交换机优先发送优先级高的数据帧CFI1bit标准格式指示位,表示MAC地址在不同的传输介质中是否以标准格式进行封装,用于兼容以太网和令牌环网。表示MAC地址以标准格式进行封装,为1表示以非标准格式封装。在以太网中,CFI值为0VID12bitVLAN ID,表示该数据帧所属的VLAN的编号。VLAN ID取值范围是0~4095.由于0和4095为协议保留取值,所以VLAN ID的有效取值是1~4094. 交换机利用VLAN标签中的VID来标识数据帧所属的VLAN,广播帧只在同一VLAN内转发,这就将广播帧限制在一个VLAN内。接口的链路类型Access接口Trunk接口Hybrid接口QinQ接口 一般用于和不能识别Tag的用户终端相连,或不需要区分不同的VLAN成员时使用。 大部分情况只能收发Untagged帧,且只能为Untagged帧添加唯一VLAN的Tag。 一般用于连接交换机、路由器、AP以及同时收发Tagged帧和Untagged帧的语音终端。它可以允许多个VLAN的帧带Tag通过,但只允许一个VLAN的帧从该类接口上发出时不带Tag 既可以用于连接不能识别Tag的用户终端和网络设备,也可以用于连接交换机、路由器以及可同时收发Tagged和Untagged帧的语音终端、AP。 使用QinQ协议,一般用于私网与公网之间的连接。可以给帧加双层Tag。 以太网链路包括接入链路(Access Link)和干道链路(Trunk Link)。 接入链路用于连接交换机和用户终端(如用户主机、服务器、傻瓜交换机等),只可以承载1个VLAN的数据帧。 干道链路用于交换机间互连或连接交换机与路由器,可以承载多个不同VLAN的数据帧。 在接入链路上传输的帧都是Untagged帧,在干道链路上传输的数据帧必须都打上Tag。

    展开全文
  • 纯光纤接口以太网交换机参考介绍(转)[@more@]  光纤以太网技术是现在两大主流通信技术的融合和发展,即以太网和光网络。它集中了以太网和光网络的优点,如以太网应用普遍、价格低廉、组网灵活、管理简单,光网络...
  • 什么是程控电话  1、什么是程控电话  程控电话是指接入程控电话交换机的电话,程控电话交换机是利用电子计算机来控制的交换机, 它以预先编好的程序来控制交换机的接续动作。此程控电话与...
  • 锐捷交换机配置命令

    千次阅读 2019-09-24 16:41:37
    锐捷交换机配置命令 交换机基本操作 1.进入特权模式 Switch>enable Switch# 2.返回用户模式 Switch#exit Press RETURN to get started! Switch>...全局配置模式[主机名(config)#]:配置交换机的整体...2.接口配...
  • 三层交换机

    2019-10-22 18:09:08
    三层交换机: 三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。 出于安全和管理方便的考虑,主要是为了减小广播风暴的危害,必须把大型 局域网按功能或地域等因素划成一个个小...
  • 交换机所有接口默认属于同一个广播域. 二丶VLAN概述 什么是VLAN Virtual LAN(虚局域网是物理设备上的连接不受物理位置限制的用户的一个逻辑组 为什么介入Vlan 交换机的所有接口默认属于同一个广播域 随着接入...
  • 光纤交换机 和 SAN交换机 概念

    万次阅读 2012-12-24 15:43:41
    交换机时特别要注意的一些事项,其实光纤交换机技术非常复杂,所支持的协议和接口类型也在日益增多,性能不断增强,要注意的方面还有很多,但限于篇幅原因在此文只能为大家起到抛砖引玉的作用,希望对各位在选购光纤...
  • 交换机堆叠模式

    2021-08-25 14:51:32
    堆叠是指将一台以上的交换机组合起来共同工作,以便在优先的空间内提供尽可能多的端口。多台交换机经过堆叠形成一个堆叠单元。可堆叠的交换机性能指标中有一个“最大可堆叠数”的参数,它是指一个堆叠单元中所能堆叠...
  • rabbitMq 交换机介绍

    千次阅读 2017-04-18 11:23:18
    rabbitMq有四种类型的交换机fanout、direct、topic、headers一 不用交换机的队列生产者示例: //声明队列 channel.queueDeclare(QUEUE_NAME, false, false, false, null); //发送10条消息,依次在消息后面附加1-...
  • 交换机堆叠

    2020-01-04 21:06:52
    iStack,全称Intelligent Stack,智能堆叠,适用于S2700、S3700、S5700和S6700中低端交换机。而高端交换机中叫做CSS,全称Cluster Switch System,集群交换系统,适用于S7700、S9300、S9700等高端交换机。 此类技术...
  • 锐捷交换机命令

    万次阅读 多人点赞 2018-12-03 13:43:27
    &gt;Enable进入特权模式  #Exit返回上一级操作模式  #End返回到特权模式  #write memory或copy ... #del flash:config.text删除配置文件(交换机及1700系列路由器)  #erase startup-config删除配置文件(2...
  • 交换机网络搭建

    千次阅读 2019-04-04 16:12:47
    实验环境: eNSP虚拟设备配置、PC四台、服务器一台、交换机两台、路由器一台 实验拓扑: 实验内容: ... 本实验共采用4台PC、2台三层交换机、1台路由器、1台...按要求规划接口,配置trunk和access接口;增加Acc...
  • 路由器 交换机

    2014-02-17 17:04:30
    交换机原理与应用 一、基本以太网 1、以太网标准:  以太网是Ethernet的意思,过去使用的是十兆标准,现在是百兆到桌面,千兆做干线。  常见的标准有:  10BASE-2 细缆以太网  10BASE-5 粗缆以太网 ...
  • 华为交换机常用配置

    千次阅读 多人点赞 2020-05-26 13:43:53
    浮动静态路由(主备备份) 一条链路优先,增大优先级。一条down了用另一条 2、缺省路由(只有一个下一跳的、末梢网络)优先级低于其他静态路由 IP route-static 0.0.0.0 0 下一跳网络 3、RIP 距离矢量 rip 编号 rip ...
  • 原因:这是由于配置Eth-Trunk时优先配置了接口模式(trunk/access)并且将其应用到了接口,使该配置生效了。所以在这些trunk/access链路模式生效后,该交换机是不允许配置LACP的。由此就报了Erro...
  • 交换机与路由器的配置

    万次阅读 多人点赞 2019-05-30 11:02:14
    交换机与路由器的配置 一、交换机的基本配置 配置enable口令、密码和主机名 Switch> (用户执行模式提示符) Switch>enable (进入特权模式) Switch# ...
  • 交换机工作原理 ...路由器的一个接口下时一个广播域。所以路由器可以隔离广播域 交换机工作原理: MAC地址表:交换机端口与主机的MAC地址的对应关系,可初始化并自动学习 转发:位于MAC地址表中的单帧数
  • 修改分布式交换机的上行链路数量 网络,DSwitch,右键设置,编辑设置,常规(上行链路数由3改为4个,编辑名称) 为迁移准备分布式端口组 数据中心/网路-右键DSwitch-新建分布式端口组 D-VM Network D-...
  • 交换机的基础知识

    千次阅读 2017-05-20 17:38:45
    交换机(Switch)  #建立和维护一个表示MAC地址与交换机端口对应关系的交换表  #在发送结点所在的交换机端口和接受结点所在的交换机端口之间建立一条虚连接  #完成数据帧的转发或过滤(根据MAC地址查询交换...
  • 交换机Trunk详解

    千次阅读 2019-10-10 13:21:26
    文章目录一、Trunk概述二、封装协议三、ISL四、Dot1Q五、DTP六、Trunk配置七、...一般见于交换机之间或交换机与路由器、服务器之间 二、封装协议 ISL 801.1Q Cisco私有 共有标准 采用封装的方式 采用ta...
  • 交换机基础原理

    2019-03-29 07:18:05
    交换机基础原理 交换机和集线器HUB的区别 交换机SW有MAC地址,集线器HUB没有MAC地址,HUB泛洪,占用带宽,转发效率慢 交换机支持VLAN协议,能学习MAC地址,单播、一对一转发,缓存,一个网段,隔离广播域、冲突域...
  • 华为交换机修改radius服务器地址 内容精选换一换IPoIB(Internet Protocol over InfiniBand),指利用物理IB网络(包括服务器上的IB卡、IB连接线、IB交换机等)通过IP协议进行连接,并进行数据传输。它提供了基于RDMA之...
  • 锐捷交换机配置手册完整

    万次阅读 多人点赞 2017-06-01 10:55:13
    第一部分:交换机概述 一:交换机的几种配置方法 本部分包括以下内容: 控制台 远程登录 其它配置方法 本部分内容适用于交换机、路由器等网络设备。   控制台 用一台...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 14,113
精华内容 5,645
关键字:

交换机优先接口