精华内容
下载资源
问答
  • 本文对交换机端口汇聚配置进行说明

    配置思科交换机冗余链路汇聚

     


    一、端口聚合技术(EtherChannel)

    EtherChannel是Cisco研发的,应用于交换机之间的多链路捆绑技术。

    EtherChannel的基本原理和作用是:

    1.增加带宽

    将两个设备间多条相同特性的快速以太或千兆物理链路捆绑在一起组成一条逻辑链路,从而达到带宽倍增的目的。

    2.链路冗余

    除了增加带宽外,EtherChannel还可以在多条链路上均衡分配流量,起到负载均衡的作用;当一条或多条链路故障时,只要还有链路正常,流量将转移到其他的链路上,整个过程在几毫秒内完成,从而起到链路冗余的作用,增强了网络的稳定性和安全性。在EtherChannel中,负载在各个链路上的分布可以根据源IP地址、目的IP地址、源MAP地址、目的MAC地址、源IP地址和目的IP地址组合,以及源MAC地址和目的MAC地址组合等来进行分布。


    二、端口汇聚协议

    两台交换机之间是否形成EtherChannel也可以采用协议自动协商。

    目前有两种PAgP(端口汇聚协议)和LACP(链路汇聚控制协议)协商协议。

    PAgP(端口汇聚协议,Port Aggregation Protocol)是Cisco的私有协议。

    LACP(链路汇聚控制协议,Link Aggregation Protocol)是基于IEEE802.3ad的国际标准。


    三、链路汇聚语法

    channel-group+编号+mode+auto/on/desirable

    其中,auto:被动协商,on:不协商,desirable:主动协商。


    四、配置冗余链路汇聚

    1.创建和定义port-channel端口

    swtich-core#config terminal

    swtich-core(config)#interface prot-channel 10

    swtich-core(config-if)#no switchport

    2.分配ip地址

    swtich-core(config-if)#ip address 192.168.102.1 255.255.255.0

    swtich-core(config-if)#no shutdown

    swtich-core(config-if)#exit

    4.分配端口,并启用端口汇聚

    swtich-core(config)#interface range fastEthernet 0/1-4

    swtich-core(config-if-range)#no switchport

    swtich-core(config-if-range)#no ip address

    swtich-core(config-if-range)#channel-group 10 mode on

    swtich-core(config-if-range)#no shutdown

    swtich-core(config-if-range)#exit

    5.添加路由

    swtich-core(config)#ip route 192.168.40.0 255.255.255.0 192.168.102.2

    展开全文
  • 冗余环网 交换机 必须配置 配置指导说明
  • 还可以通过这种方式切换网关通信 配置脚本: 二层交换机 undo t m sys vlan 10 vlan 20 q stp enable stp mode mstp stp region-configuration region-name MSTP revision-level 1 instance 1 vlan 10 instance 2 ...

    华为的MSTP在我看来与思科的PVST是极其相似的,PVST为思科私有的,是按vlan给局域网中的每一个vlan生成一颗树便于流量管理,有不清楚的可以看我前面的博客。
    而华为用的MSTP则相对比较灵活,需要先创建一个承载区域,然后在区域中创建instance,最后把一个或多个vlan放入instance中。
    这是在说什么呢,也就是说如果给每一个vlan单独做一个instance那么就是一颗另类的PVST,区别在于instance可以根据情况承载多个vlan
    可能看实验会清楚一点:
    在这里插入图片描述
    在这里插入图片描述
    通过手工改变pc网关的地址可以实现负载均衡
    如果其中一个网关坏了,还可以通过这种方式切换网关通信
    在这里插入图片描述
    在这里插入图片描述
    配置脚本:

    二层交换机
    undo t m
    sys
    vlan 10
    vlan 20
    q
    stp enable
    stp mode mstp
    stp region-configuration
    region-name MSTP
    revision-level 1
    instance 1 vlan 10
    instance 2 vlan 20
    active region-configuration
    q
    int e0/0/1
    port link-type access
    port default vlan 10
    int e0/0/2
    port link-type access
    port default vlan 20
    q
    int e0/0/3
    port link-type trunk
    port trunk allow-pass vlan all
    int e0/0/4
    port link-type trunk
    port trunk allow-pass vlan all
    
    三层交换机1
    undo t m
    sys
    vlan 10
    vlan 20
    int vlan 10
    ip add 192.168.10.254 24
    int vlan 20
    ip add 192.168.20.254 24
    q
    stp enable
    stp mode mstp
    stp region-configuration
    region-name MSTP
    revision-level 1
    instance 1 vlan 10
    instance 2 vlan 20
    active region-configuration
    q
    stp instance 1 root primary
    stp instance 2 root secondary
    int g0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    int g0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    q
    
    三层交换机2
    undo t m
    sys
    vlan 10
    vlan 20
    int vlan 10
    ip add 192.168.10.253 24
    int vlan 20
    ip add 192.168.20.253 24
    q
    stp enable
    stp mode mstp
    stp region-configuration
    region-name MSTP
    revision-level 1
    instance 1 vlan 10
    instance 2 vlan 20
    active region-configuration
    q
    stp instance 1 root secondary
    stp instance 2 root primary
    int g0/0/1
    port link-type trunk
    port trunk allow-pass vlan all
    int g0/0/2
    port link-type trunk
    port trunk allow-pass vlan all
    q
    
    展开全文
  • IBM刀柜中的博科交换机配置方法,描述较为详细,图形化配置,适合小白和一些初初接触IBM刀片服务器的技术人员。
  • 交换机怎么配置RSTP协议?在一些通讯要求比较严格的行业,一般不允许通讯中断,那么为了防止链路因为某种原因而无法通讯,就需要将其配置冗余链路,当主链路因为某种原因而断开时,会马上切换到备用链路,下面就...
  • 在双核心交换机环境中,使用单台NetScreen防火墙进行冗余连接,要求能够与双核心交换机的Layer2生成树环境结合,同时能够支持Layer3 VRRP环境。 SW-1和SW-2为H3C交换机,启用MSTP生成树协议。 SW-1为主根桥,SW-2...

    Juniper NetScreen(Redundant)+ H3C Switch(MSTP)


    拓扑:

    在双核心交换机环境中,使用单台NetScreen防火墙进行冗余连接,要求能够与双核心交换机的Layer2生成树环境结合,同时能够支持Layer3 VRRP环境。

    netscreen_01.gif

    SW-1和SW-2为H3C交换机,启用MSTP生成树协议。
    SW-1为主根桥,SW-2为辅根桥。
    SW-1的VLAN IP为:172.16.1.2。
    SW-2的VLAN IP为:172.16.1.3。

    NetScreen的物理接口eth0/1和物理接口eth0/2。
    加入到逻辑接口Redundant1,IP地址为:172.16.1.1。

     


    配置:
    1,Juniper NetScreen Redundant配置:

    1.1 设置redundant组1,并且设置为Trust区域。

    set interface redundant1 zone trust

    1.2 设置redundant1 IP地址(Layer3 Interface)。

    set interface redundant1 ip 172.16.1.1/24

    1.3 将物理接口eth0/1与eth0/2加入redundant组1。

    set interface eth0/1 group redundant1
    set interface eth0/2 group redundant1

    1.4 设置redundant1的primary端口为eth0/1(Layer2 Redunant)

    set interface redundant1 primary ethernet0/1

    1.5 设置redundant1 monitor track IP地址。(Layer3 Redunant)

    set interface redundant1 monitor track-ip ip 172.16.1.254


    2,Juniper NetScreen Redundant检查:

    2.1 查看Interface端口信息:get interface

    netscreen_02.gif

    2.2 查看Redunant1状态:get interface red1

    netscreen_03.gif

    2.3 查看Track IP状态:get interface red1 monitor track-ip

    netscreen_04.gif


    3,H3C Switch-A(MSTP)检查:

    3.1 Ping交换机SW-A(192.168.1.2),交换机SW-B(192.168.1.3)

    netscreen_05.gif

    3.2 查看交换机SW-A(MSTP)生成树状态:display stp

    netscreen_06.gif

    STP使用了MSTP模式。
    CIST Root Type显示为Primary root模式。

    3.3 查看交换机SW-A(MSTP)端口状态:display stp brief

    netscreen_07.gif

    Eth1/0/2为指定端口,连接NetScreen防火墙Redunant1的Primary端口。
    Eth1/0/24为指定端口,连接交换机SW-B。
    Eth1/0/2与Eth1/0/24端口状态均为Forwarding。

    3.4 交换机SW-A配置文件汇总:

    #
     stp instance 0 root primary
     stp enable
    stp region-configuration
     region-name TEST
     active region-configuration
    #
    vlan 1
    #
    interface Vlan-interface1
     ip address 172.16.1.2 255.255.255.0
    #


    4,H3C Switch-B(MSTP)检查:

    4.1 查看交换机SW-B(MSTP)生成树状态:display stp

    netscreen_08.gif

    STP使用了MSTP模式。
    CIST Root Type显示为Secondary root模式。

    4.2 查看交换机SW-B(MSTP)端口状态:display stp brief

    netscreen_09.gif

    Eth1/0/2为指定端口,连接NetScreen防火墙Redunant1的Secondary端口。
    Eth1/0/24为根端口,连接交换机SW-A。
    Eth1/0/2与Eth1/0/24端口状态均为Forwarding。

    4.3 交换机SW-B配置文件汇总:

    #
     stp instance 0 root secondary
     stp enable
    stp region-configuration
     region-name TEST
     active region-configuration
    #
    vlan 1
    #
    interface Vlan-interface1
     ip address 172.16.1.3 255.255.255.0
    #
    摘自:http://www.reistlin.com/blog/180
    展开全文
  • 华三核心交换机冗余配置实例,配置协议为irf,将两台网络设备虚拟成一台
  • 配置交换机后,使用 “writ” 命令保存配置,保存完成后使用 “show running-config” 和 “show startup-config” 查看配置情况都是正常。模拟因机房断电导致交换机重启,可以使用 “reload” 命令重启交换...

    故障场景:

    网络环境里有2台Cisco 3850交换机,因业务数据较为重要,两台交换机采用集群线做了堆叠,以此提高设备的冗余。

    故障描述:

    配置好交换机后,使用 “writ” 命令保存配置,保存完成后使用 “show  running-config” 和 “show  startup-config” 查看配置情况都是正常。模拟因机房断电导致交换机重启,可以使用 “reload” 命令重启交换机,当重启完成后已配置的内容全部丢失,交换机回到初始化状态,使用“show  startup-config”查看,发现配置还在,执行“copy startup-config running-config”命令恢复配置。

    问题:

    不能每次重启后都要使用Console口去执行配置恢复命令。

    注意事项:

    备份配置到本地!!!备份配置到本地!!!备份配置到本地!!!

    排错:

    以下是设备版本信息:

    [BEGIN] 2019/10/8 16:42:34
    *Oct  8 00:21:05.597: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/23, changed state to up
    13F_SC_ZD_S3850#
    13F_SC_ZD_S3850#
    13F_SC_ZD_S3850#show ver
    13F_SC_ZD_S3850#show version 
    Cisco IOS Software, IOS-XE Software, Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version 03.06.05E RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2016 by Cisco Systems, Inc.
    Compiled Thu 02-Jun-16 09:03 by prod_rel_team

    Cisco IOS-XE software, Copyright (c) 2005-2015 by cisco Systems, Inc.
    All rights reserved.  Certain components of Cisco IOS-XE software are
    licensed under the GNU General Public License ("GPL") Version 2.0.  The
    software code licensed under GPL Version 2.0 is free software that comes
    with ABSOLUTELY NO WARRANTY.  You can redistribute and/or modify such
    GPL code under the terms of GPL Version 2.0.
    (http://www.gnu.org/licenses/gpl-2.0.html) For more details, see the
    documentation or "License Notice" file accompanying the IOS-XE software,
    or the applicable URL provided on the flyer accompanying the IOS-XE
    software.

    ROM: IOS-XE ROMMON
    BOOTLDR: CAT3K_CAA Boot Loader (CAT3K_CAA-HBOOT-M) Version 3.58, RELEASE SOFTWARE (P)
              
    13F_SC_ZD_S3850 uptime is 8 minutes
    Uptime for this control processor is 13 minutes
    System returned to ROM by reload
    System image file is "flash:packages.conf"
    Last reload reason: Reload command

    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email to
    export@cisco.com.
              
    License Level: Ipbase
    License Type: Permanent
    Next reload license Level: Ipbase

    cisco WS-C3850-24T (MIPS) processor with 4194304K bytes of physical memory.
    Processor board ID FOC2034U0U8
    2 Virtual Ethernet interfaces
    56 Gigabit Ethernet interfaces
    8 Ten Gigabit Ethernet interfaces
    2048K bytes of non-volatile configuration memory.
    4194304K bytes of physical memory.
    252000K bytes of Crash Files at crashinfo:.
    252000K bytes of Crash Files at crashinfo-1:.
    1611414K bytes of Flash at flash:.
    1611414K bytes of Flash at flash-1:.
    0K bytes of Dummy USB Flash at usbflash0:.
    0K bytes of Dummy USB Flash at usbflash0-1:.
    0K bytes of  at webui:.

    Base Ethernet MAC Address          : 00:59:dc:7d:08:00
    Motherboard Assembly Number        : 73-16297-05
    Motherboard Serial Number          : FOC20343XSF
    Model Revision Number              : AB0
    Motherboard Revision Number        : A0
    Model Number                       : WS-C3850-24T
    System Serial Number               : FOC2034U0U8


    Switch Ports Model              SW Version        SW Image              Mode   
    ------ ----- -----              ----------        ----------            ----   
         1 32    WS-C3850-24T       03.06.05E         cat3k_caa-universalk9 INSTALL
    *    2 32    WS-C3850-24T       03.06.05E         cat3k_caa-universalk9 INSTALL


    Switch 01
    ---------
    Switch uptime                      : 13 minutes 
    Base Ethernet MAC Address          : 00:59:dc:ac:4c:80
    Motherboard Assembly Number        : 73-16297-05
    Motherboard Serial Number          : FOC20343XMJ
    Model Revision Number              : AB0
    Motherboard Revision Number        : A0
    Model Number                       : WS-C3850-24T
    System Serial Number               : FCW2034C0ZY

    Configuration register is 0x142 (will be 0x102 at next reload)


    [END] 2019/10/8 16:43:00
     

    解决方法一:

    https://quickview.cloudapps.cisco.com/quickview/bug/CSCui54490

    以上链接是官网给出的处理方式,总结一下就是在config t (全局模式)下执行

    1、“system ignore startupconfig switch all”

    2、“no system ignore startupconfig switch all”

    3、“writ”

    4、“reload”

    命令,忽略系统启动错误,测试过后无效,还是会丢失配置内容。有时间的朋友可以去试一试

    解决方法二:

    在config t (全局模式)下执行

    1、“no setup express” 

    2、“writ”

    3、“reload”

    我是使用第二种方法后解决问题的,希望能给在读文章的你带来帮助!

    展开全文
  • 详尽的数据库实验,要求,分析,实用!计算机网络实验报告,专业设计,内容详尽,学习计算机网络实用技巧!大致内容有:交换机基本配置交换机堆叠,利用TFTP管理路由器配置,802.3ad 冗余备份测试
  • 四层交换机AppDirector冗余配置手册
  • 华为 交换机简要配置手册(中文) 目 录 1. 连接设备 3 1.1. 从CONSOLE连接 3 1.2. 远程TELNET连接 6 2. 基本信息配置 6 2.1. 配置机器名、TELNET、密码 6 2.2. 配置SNMP网管串 6 3. 冗余及系统高可用性配置...
  • Catlyst 6509告警信息处理—冗余交换机IP地址配置错误 Catlyst 6509核心交换告警信息处理—冗余交换机IP地址配置错误 故障诊断 (JJ) 两台冗余的...
  • 配置手工负载分担模式链路聚合示例组网需求如图1所示,SwitchA和SwitchB通过以太链路分别...同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。图1 配置手工负载分担模式链路聚合组网图配置思路采用...
  • IBM刀箱Nortel_32R1860配置实例 配置要求: 1、 每交换机模块双链路上联,实现链路冗余 2、 对刀片服务器来讲,实现网络高可靠 3、 Vlan信息透传 拓扑图如下 配置概述: 1、 建立vlan,将相应的端口加入vlan 2、 ...
  • S5700交换机如何配置链路聚合

    万次阅读 2018-02-15 16:30:41
    配置手工负载分担模式链路聚合示例组网需求如图1所示,SwitchA和SwitchB通过以太链路分别...同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。图1 配置手工负载分担模式链路聚合组网图 配置思路采...
  • 1问题描述S5700交换机如何配置链路聚合?2处理过程配置手工负载分担模式链路聚合示例组网需求如图1所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20的网络,且SwitchA和SwitchB之间有较大的数据流量。...
  • 华为三层交换机STP配置

    千次阅读 2017-11-27 17:32:00
    学习目的 掌握启用和关闭STP的方法 了解不同的STP模式的差异 掌握修改网桥优先级影响根网桥选举的方法 ...掌握修改端口优先级影响根端口与指定端口选举的方法 ...采用了冗余网络,为避免存在的环路问题,...
  • 交换机; interface vlanif 10 vrrp vrid 1 virtual-ip ... vrrp vrid 1 priority 120 //配置交换机优先级为120 vrrp vrid 1 preempt-mode timer delay 20 //配置交换机抢占延时20秒 vrrp vrid 1 track in...
  • 楼层1和楼层2分别通过两条线路做冗余接入交换机(本示例只考虑vrrp,暂不考虑其他方面)。当其中一段链路故障时,能通过另外一条链路传输。 配置信息: <lsw9>dis cu # sysname lsw9 # vlan ...
  • 西门子交换机SCALANCE X 冗余环网介绍手册,尤其在1500冗余系统配置时,参考价值很大,希望多大家有所帮助!!!!
  • 展开全部Linux下双网卡绑定七种模式现在一般的企业都会使用双网卡接入,62616964757a686964616fe59b9ee7ad9431333337613838这样既能添加网络带宽,同时又能做相应的冗余,可以说是好处多多。而一般企业都会使用linux...
  • 什么是核心交换机的链路聚合、冗余、堆叠、热备份,今天我们一起来了解这些专业术语!链路聚合是将两个或更多数据信道结合成一个单个的信道,该信道以一个单个的更高带宽的逻辑链路出现。链路聚合一般用来连接一个或...
  • dell 交换机 双链路冗余 公司海外机房引入2G带宽,是由2个电口绑定实现的。因业务需要扩容到3G,在绑定端口扩展性不太好,因此直接上10G光纤模块。 机房技术人员建议,2g老线路不撤做备份,3g新线路...
  • 解决方案配置手工负载分担模式链路聚合示例组网需求如图1所示,SwitchA和SwitchB通过以太链路分别...同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。图1 配置手工负载分担模式链路聚合组网图配置...
  • 最近为了上一批设备,针对交换机配置也学习了一番,本文记录几个在实操中用到的实例。2. 概念在系统运维中,经常会用冗余的方式来保证业务、服务、系统的高可用性,而在网络中也存在冗余和高可用的方式。对于...
  • 本文介绍了哪种工业以太网交换机可以在介质冗余的环形拓扑下使用和支持冗余管理器和备用主站功能。介质冗余功能用于确保网络与系统可用性。冗余传输路径 (环形拓扑) 保证当一个传输路径失效时,可以建立另一个有效...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 718
精华内容 287
关键字:

交换机冗余配置