精华内容
下载资源
问答
  • ***什么是VLANVLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。 虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们...

    ***什么是VLAN?

    VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。

    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点: 网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。

    ***开始划分操作!

    我们这里用Cisco Packet Tracer 6.0下的SW2950-24进行演示。

    首先进入交换机特权模式:

    1
    2
    3
    4
    5
    
    Switch>en
    
    Switch#conf t
    
    Switch(config)#

    ***接着,输入你要创建的VLAN名称,如vlan 10。

    输入完成后回车并退出VLAN配置模式。

    1
    2
    3
    
    Switch(config)#vlan 10
    
    Switch(config-vlan)#ex

    现在我们就可以输入在此VLAN下的端口号码了。

    1
    
    Switch(config)#interface range f0/1-12

    像这样,我们把f0下的1到12端口分配给了vlan 10,回车后保存。

    ***保存后我们需要为vlan 10指定VLAN的工作模式,如access模式:

    1
    2
    3
    
    Switch(config-if-range)#sw mode access
    
    Switch(config-if-range)#sw access vlan 10

    ***至此,我们就完成了VLAN 10的配置。

    交换机的1-12端口已经被我们指定成VLAN10的端口并且以access模式进行操作。


    @本地磁盘姬 整理

    ohayou.moeres.org

    微博@萌萌的本地磁盘w

    2016.06.04

    展开全文
  • 掌握一般交换机按端口划分VLAN的配置方法; 掌握Tag VLAN配置方法。 实验背景 某一公司内财务部、销售部的PC通过2台交换机实现通信;要求财务部和销售部的PC可以互通,但为了数据安全起见,销售部和财务部需要...

    实验目标

    • 理解虚拟LAN(VLAN)基本配置;
    • 掌握一般交换机按端口划分VLAN的配置方法;
    • 掌握Tag VLAN配置方法。

    实验背景

    • 某一公司内财务部、销售部的PC通过2台交换机实现通信;要求财务部和销售部的PC可以互通,但为了数据安全起见,销售部和财务部需要进行互相隔离,现要在交换机上做适当配置来实现这一目标。

    技术原理

    • VLAN是指在一个物理网段内。进行逻辑的划分,划分成若干个虚拟局域网,VLAN做大的特性是不受物理位置的限制,可以进行灵活的划分。VLAN具备了一个物理网段所具备的特性。相同VLAN内的主机可以相互直接通信,不同VLAN间的主机之间互相访问必须经路由设备进行转发,广播数据包只可以在本VLAN内进行广播,不能传输到其他VLAN中。
    • Port VLAN是实现VLAN的方式之一,它利用交换机的端口进行VALN的划分,一个端口只能属于一个VLAN。
    • Tag VLAN是基于交换机端口的另一种类型,主要用于是交换机的相同Vlan内的主机之间可以直接访问,同时对不同Vlan的主机进行隔离。Tag VLAN遵循IEEE802.1Q协议的标准,在使用配置了Tag VLAN的端口进行数据传输时,需要在数据帧内添加4个字节的8021.Q标签信息,用于标示该数据帧属于哪个VLAN,便于对端交换机接收到数据帧后进行准确的过滤。

    实验说明

    • 在同一个局域网中,要实现PC0、PC2为同一个分组,PC1、PC3属于同一个分组,PC0和PC1,PC2和PC3分别使用同一个交换机;
    • 在4个PC使用同一个网关的情况下,将4个PC进行Vlan分组划分,实现两个分组之间的相互隔离;

    实验步骤

    • 新建Packet Tracer拓扑图;
    • 划分VLAN;
    • 将端口划分到相应VLAN中;
    • 设置Tag VLAN Trunk属性;
    • 测试

    实验设备

    Switch_2960 2台;PC 4台;直连线

    1.配置PC1

           IP: 192.168.1.2

           Submark: 255.255.255.0

           Gateway: 192.168.1.1

    2.配置PC2

           IP: 192.168.1.3

           Submark: 255.255.255.0

           Gateway: 192.168.1.1

    3.配置PC3

           IP: 192.168.1.4

           Submark: 255.255.255.0

           Gateway: 192.168.1.1

    4.配置PC4

           IP: 192.168.1.5

           Submark: 255.255.255.0

           Gateway: 192.168.1.1

    5.配置交换机Switch1

    Switch>en
    Switch#conf t
    Switch(config)#vlan 2    //向交换机添加新的虚拟端口 vlan 2
    Switch(config-vlan)#exit  
    Switch(config)#vlan 3    //添加新的vlan 3
    Switch(config-vlan)#exit
    
    Switch(config)#interface fa 0/1   //切换到fa 0/1端口,并将该端口绑定到vlan2
    Switch(config-if)#switch access vlan 2 
    Switch(config-if)#exit
    
    Switch(config)#interface fa 0/2      //切换到fa 0/2端口,并将该端口绑定到vlan3
    Switch(config-if)#switch access vlan 3
    Switch(config-if)#exit
    
    Switch(config)#inter fa 0/24      //切换到fa 0/24(示例中为交换机连接端口),
    Switch(config-if)#switchport mode trunk  //并将更改其连接模式为trunk
    Switch(config-if)#end
    
    Switch#show vlan      //显示交换机的 vlan 配置情况

    6.以相同的方式配置交换机Switch2

    Switch>en
    Switch#conf t
    Switch(config)#vlan 2    //向交换机添加新的虚拟端口 vlan 2
    Switch(config-vlan)#exit  
    Switch(config)#vlan 3    //添加新的vlan 3
    Switch(config-vlan)#exit
    
    Switch(config)#interface fa 0/1   //切换到fa 0/1端口,并将该端口绑定到vlan2
    Switch(config-if)#switch access vlan 2 
    Switch(config-if)#exit
    
    Switch(config)#interface fa 0/2      //切换到fa 0/2端口,并将该端口绑定到vlan3
    Switch(config-if)#switch access vlan 3
    Switch(config-if)#exit
    
    Switch(config)#inter fa 0/24      //切换到fa 0/24(示例中为交换机连接端口),
    Switch(config-if)#switchport mode trunk  //并将更改其连接模式为trunk
    Switch(config-if)#end
    
    Switch#show vlan      //显示交换机的 vlan 配置情况

    7.实验验证

    PC1 ping PC2(或PC3 ping PC4),超时

    PC1 ping PC3(或PC2 ping PC4),ping通

    本实验主要目的是为了让我们学会如何划分VLAN。

    展开全文
  • 阅读本文如有无法理解的地方,建议先阅读前面的vlan理论知识部分1、基于接口划分VLAN(静态配置链路类型)1.按端口划分vlanVlan是二层协议,仅可把二层以太网端口(物理以太网端口和eth-trunk链路口)划分到vlan中,划为...

    阅读本文如有无法理解的地方,建议先阅读前面的vlan理论知识部分

    1、基于接口划分VLAN(静态配置链路类型)

    1.按端口划分vlan

    Vlan是二层协议,仅可把二层以太网端口(物理以太网端口和eth-trunk链路口)划分到vlan中,划为交换机以太网端口虽然可以转换为三层模式(undo portswitch),但仍不能直接配置IP地址。

    二层以太网端口类型

    1、Access端口:

    用来连接用户主机;仅允许一个vlan的帧通过(仅允许加入一个vlan);发送的以太网帧永远是不带标签(untagged)的。

    2、trunk端口:

    与其他交换机二层以太网口相连;允许多个vlan的帧通过;发送的帧都是带标签tagged的,除了发送vlanID与

    PVID(port default vlanID端口缺省vlanID)一致的vlan帧。

    3、Hybrid端口:

    access端口和trunk端口的混合体,具有access端口和trunk端口特性。

    4、QinQ端口:

    二层隧道协议,核心思想是将用户私网vlan封装在公网vlan标签中,这样报文带着两层vlan标签(一个公网vlan标签,一个私网vlan标签)穿越网络运营商的骨干网络,为用户提供一种较为简单的二层VPN隧道。

    交换机内部数据传输都是带vlan标签的(前提是交换机支持vlan);默认情况下二层以太网端口是hybrid类型,以不带vlan标签方式加入vlan1。

    为什么要配置缺省vlan:以太网帧在交换机内部都是以tagged形式处理转发的,因此交换机必须给端口收到的untagged帧加上vlan标签。

    具体配置:

    1、设置端口链路类型

    [Huawei-GigabitEthernet0/0/2]port link-type

    ?

    access        Access port

    dot1q-tunnel  QinQ port

    hybrid        Hybrid port

    trunk         Trunk port

    2、设置端口加入vlan

    2.1 access端口加入vlan

    [Huawei-GigabitEthernet0/0/2]port default

    vlan ?

    INTEGER<1-4094>  VLAN ID

    2.2

    trunk端口加入vlan

    [Huawei-GigabitEthernet0/0/2]port trunk

    pvid vlan ? #缺省vlan

    INTEGER<1-4094>  VLAN ID

    ------------------

    [Huawei-GigabitEthernet0/0/2]port trunk

    allow-pass vlan ? #允许通过的vlan

    INTEGER<1-4094>  VLAN ID

    all              All

    2.3hybrid端口加入vlan

    [Huawei-GigabitEthernet0/0/5]port hybrid

    pvid vlan ?#缺省vlan

    INTEGER<1-4094>  VLAN ID

    ----------

    [Huawei-GigabitEthernet0/0/7]port hybrid

    untagged vlan ?#不带标签端口允许通过的vlan

    INTEGER<1-4094>  VLAN ID

    all              All

    ---------------

    [Huawei-GigabitEthernet0/0/7]port hybrid

    untagged vlan ?#带标签端口允许通过的vlan

    INTEGER<1-4094>  VLAN ID

    all              All

    2.4dot1q-tunne的外层标签

    [Huawei-GigabitEthernet0/0/5]port default

    vlan

    2、基于接口划分VLAN(LNP动态协商链路类型)

    当前,交换机支持的以太网接口的链路类型有:Access、Hybrid、Trunk和Dot1q-tunnel。这四种链路类型分别用于不同的网络位置,均由手工配置指定。

    如果网络拓扑变更,以太网接口的链路类型也需要重新配置,配置较为繁琐。

    为了简化用户配置,可通过自动协商出接口的链路类型为access或者trunk,并加入相应VLAN。

    具体配置

    操作步骤

    1、system-view

    进入系统视图。

    2、undo lnp disable

    全局使能链路类型自协商功能。缺省情况下,全局LNP处于使能状态,此时所有接口的链路类型自协商功能处于使能状态。

    3、interface

    interface-type interface-number

    进入需要使能链路类型自协商功能的以太网接口视图。

    4、undo port

    negotiation disable

    基于二层以太网接口使能链路类型自协商功能。缺省情况下,设备上所有接口的链路类型自协商功能处于使能状态。

    执行该配置时需保证接口是二层接口,如果不是,可通过命令portswitch,设置接口为二层接口。

    当支持链路类型自协商功能的设备和不支持链路类型自协商功能的设备互通时,支持链路类型自协商功能的设备会不断发送自协商报文,导致带宽浪费。此时,可通过在对应的二层以太网接口视图下执行命令port negotiation disable去使能链路类型自协商功能。

    为了保证链路类型自协商功能生效,必须保证全局下和接口视图下的链路类型自协商功能都处于使能状态。

    5、port link-type {

    negotiation-desirable | negotiation-auto }

    设置二层以太网接口的链路类型的自协商方式。缺省情况下,二层以太网接口的链路类型的自协商方式是negotiation-desirable。

    配置为negotiation-desirable或negotiation-auto的接口有以下约束:

    不支持创建子接口

    不支持使能MUX VLAN

    不支持作为VLAN-Switch的源端口或目的端口

    不支持配置自动模式Voice

    VLAN

    6、port trunk

    allow-pass only-vlan { { vlan-id1 [ to vlan-id2 ] } &<1-10> | none }

    配置通过LNP协议自协商为trunk后只允许通过的VLAN。缺省情况下,协商为trunk类型的接口允许所有VLAN通过。

    由于协商为Trunk类型的接口缺省会加入所有VLAN,因此需要配置环网协议来破除环路。

    可通过执行命令port

    trunk pvid vlan vlan-id来配置接口的PVID。

    当接口允许通过大量VLAN时,不要频繁创建、删除VLAN,否则会导致CPU偏高。

    (当协商为Access类型时)执行命令port

    default vlan vlan-id,配置通过LNP协议自协商为access后加入的VLAN。

    缺省情况下,协商为access类型的接口加入VLAN1。

    3、基于MAC地址划分VLAN

    基于MAC地址划分的VLAN只处理untagged报文,对于tagged报文处理方式和基于接口的VLAN一样。当接口收到的报文为untagged报文时,接口会以报文的源MAC地址为根据去匹配MAC-VLAN表项。如果匹配成功,则按照匹配到的VLAN ID和优先级进行转发。如果匹配失败,则按其它匹配原则进行匹配。

    交换机整机支持1024个MAC-VLAN。MAC-VLAN总数=配置的MAC-VLAN数*下发接口数。

    具体配置

    1、创建vlan(与MAC关联的vlan)

    [Huawei]vlan 10

    2、配置vlan-MAC映射表

    [Huawei-vlan10]mac-vlan

    mac-address 5489-9841-0BA6

    3、配置端口以hybrid模式(只能是hybrid模式)不带标签的方式加入指定vlan中

    [Huawei-Ethernet0/0/1]port link-type hybrid

    [Huawei-Ethernet0/0/1]port hybrid untagged

    vlan 10

    4指定优先基于MAC地址划分vlan(可选-默认策略>MAC=子网>协议>端口)

    [Huawei-Ethernet0/0/1]vlan

    precedence mac-vlan

    5、使能MAC地址划分vlan功能(通常在网络设备之间连接的hybrid端口上配置)

    [Huawei-GigabitEthernet0/0/1]mac-vlan enable

    MAC-VLAN与MUX-VLAN冲突,不允许在同一接口配置。不能在同一接口上配置MAC-VLAN和MAC认证功能。带掩码的MAC-VLAN对接收到的VLAN ID为0的报文不生效。

    4、基于子网划分VLAN

    基于子网划分VLAN和基于协议划分VLAN统称为基于网络层划分VLAN,可减少手工配置VLAN的工作量,也可保证用户自由地增加、移动和修改。

    基于子网划分VLAN适用于对安全需求不高,对移动性和简易管理需求较高的场景中。

    基于IP子网的VLAN只处理untagged报文,对于tagged报文处理方式和基于接口的VLAN一样。

    当设备接口接收到untagged报文时,设备根据报文的源IP地址或指定网段来确定报文所属的VLAN,然后将报文自动划分到指定VLAN中传输。

    具体配置

    1、创建vlan(与IP关联的vlan)

    [Huawei]vlan 11

    2、配置vlan-IP映射表和vlan-IP对应vlan 802.1P优先级 。

    [Huawei-vlan11]ip-subnet-vlan ip

    192.168.1.1 28 priority 7

    3、配置端口以hybrid模式(只能是hybrid模式)不带标签的方式加入指定vlan中

    [Huawei-Ethernet0/0/3]port link-type hybrid

    [Huawei-Ethernet0/0/3]port hybrid untagged

    vlan 11

    4、指定优先基于IP地址划分vlan(可选-默认策略>MAC=子网>协议>端口)

    [Huawei-Ethernet0/0/11]vlan precedence

    ip-subnet-vlan

    5、使能IP地址划分vlan功能(通常在网络设备之间连接的hybrid端口上配置)

    [Huawei-GigabitEthernet0/0/2]ip-subnet-vlan

    enable

    5、基于策略划分VLAN

    基于策略划分VLAN也可称为Policy

    VLAN,可实现用户终端的即插即用功能,同时可为终端用户提供安全的数据隔离。

    基于策略划分VLAN分为:

    基于MAC地址+IP地址组合策略

    基于MAC地址+IP地址+接口组合策略。

    基于策略的VLAN只处理untagged报文,对于tagged报文处理方式和基于接口的VLAN一样。

    当设备接口接收到untagged报文时,设备根据用户报文中的MAC地址和IP地址与配置的MAC地址和IP地址组合策略来确定报文所属的VLAN,然后将报文自动划分到指定VLAN中传输。

    具体配置步骤

    1、创建vlan

    [Huawei]vlan 10

    2、创建策略与vlan映射

    [Huawei-vlan10]policy-vlan mac-address

    11-22-33 ip 192.168.1.1 priority 6

    [Huawei-vlan10]policy-vlan mac-address

    11-22-44 ip 192.168.10.1 interface Ethernet 0/0/5 priority 6

    #此命令需要先把要指定的端口加入相应的vlan中

    3、配置端口为混合端口并允许不带标签vlan通过

    [Huawei-GigabitEthernet0/0/1]port hybrid

    untagged vlan 10 to 20

    6、基于协议划分vlan

    划分思想是把用户计算机上运行的协议与vlan进行关联;基于协议划分的vlan只处理不带标签的数据帧,只能在混合端口上进行配置。

    配置步骤

    1、创建vlan

    [Huawei]vlan

    100

    2、关联vlan与协议

    [Huawei-vlan100]protocol-vlan

    ?

    INTEGER<0-15>  Protocol

    index

    at             AT(AppleTalk

    Protocol) configuration information

    ipv4           IPv4 configuration information

    ipv6           IPv6 configuration information

    ipx            IPX(Internetwork Packet eXchange)

    configuration information

    mode           Other protocol mode configuration

    information

    3设置端口类型并加入vlan(只能是hybrid类型不带标签)

    [Huawei-Ethernet0/0/5]port link-type hybrid

    [Huawei-Ethernet0/0/5]port hybrid untagged vlan

    100

    4、配置协议vlan与协议(号)关联(通常在网络设备之间连接的hybrid端口上配置)

    [Huawei-GigabitEthernet0/0/2]protocol-vlan

    vlan 100 0

    #协议号是根据协议与vlan关联的先后顺序自动产生的,如(同一接口下)先关联IPV4协议则产生协议0,再关联IPV6则产生协议号1.

    展开全文
  • 1、通过VLANIF接口实现VLAN间的通信划分VLAN后,同一VLAN内的用户可以互相通信,但是属于不同VLAN的用户不能直接通信。为了实现VLAN间通信,可通过配置逻辑的三层接口——VLANIF接口来实现。当VLAN中接口状态变为...

    1、通过VLANIF接口实现VLAN间的通信

    划分VLAN后,同一VLAN内的用户可以互相通信,但是属于不同VLAN的用户不能直接通信。为了实现VLAN间通信,可通过配置逻辑的三层接口——VLANIF接口来实现。

    当VLAN中接口状态变为Down而引起VLAN状态变为Down时,VLAN会向VLANIF接口上报Down事件,从而引起VLANIF接口状态变化。为避免由于VLANIF接口状态变化引起的网络震荡,可以在VLANIF接口上启动VLAN Damping功能。

    当VLAN中最后一个处于Up状态的成员接口变为Down后,启动VLAN

    Damping功能的设备会抑制设定的时间后再上报给VLANIF接口。如果在抑制的时间内VLAN中有成员口状态变为Up,则VLANIF接口状态保持Up不变。

    MTU称为最大传输单元(Maximum Transmission Unit)。MTU的大小决定了发送端一次能够发送报文的最大字节数,如果MTU超过了接收端所能够承受的最大值,或者是超过了发送路径上途经的某台设备所能够承受的最大值,这样就会造成报文分片甚至丢弃,加重网络传输的负担。

    可以配置VLANIF接口的MTU值来避免这一情况。

    可以选择配置VLANIF接口的带宽用于网管获取带宽,便于监控流量。为了成功实现VLAN间互通,VLAN内主机的缺省网关必须是对应VLANIF接口的IP地址。创建某VLAN对应的VLANIF接口后,该VLAN不能再用作子接口配置的VLAN。

    1、同一交换机vlan之间通信:只需配置VLANif IP地址即可(要求在不同IP子网中,如172.16.1.0/24与92.168.1.0/24可通信),因为华为交换机在同一交换机上默认启用IP路由功能,也就是同一交换机上是直连路由。

    2、不同交换机上的vlan间通信

    :配置VLANif IP地址,配置VLANif IP地址所在网段可达路由

    不同交换机可以有相同的vlan,且不同物理交换机上的相同vlan间一般情况下是可以直接互访的(前提是他们都位于同一IP网段,且物理连接端口上允许这些vlan通过);位于不同交换机上不同vlan处于同一IP网段,且交换机之间连接的两个端口分别隶属于双方vlan的access或不带vlan标签的hybrid端口,则这两个vlan也可以直接通信。

    具体配置

    1、创建VLANif并进入VLANif视图

    [Huawei]interface Vlanif 10

    2、配置vlanif IP地址

    [Huawei-Vlanif10]ip address 10.1.1.1 24

    [Huawei-Vlanif10]ip address 10.10.10.1 24

    sub

    #有时为了使一个接口与多个子网相连,可以在接口上配置多个IP地址。

    3、配置vlan damping功能的抑制时间(可选-目的是避免VLANif接口频繁变化引起网络震荡)

    [Huawei-Vlanif10]damping time 5

    #使用mtu命令改变接口最大传输单元MTU后,需要重启接口以保证配置的MTU生效。可以先执行shutdown命令将接口关闭,再执行undo shutdown命令将接口重启;也可以在接口视图下执行restart命令重启接口。

    VLANIF接口下mtu的值加上二层帧头后的帧长度要小于对端接口jumboframe的取值,否则,可能会导致部分报文被丢弃。

    由于QoS(Quality of

    Service)队列长度有限,如果MTU太小而报文尺寸较大,可能会造成分片过多,报文被QoS队列丢弃。为避免这种情况,可通过命令qos queue length适当增大QoS队列的长度。

    4、配置vlanif接口的MTU(最大传输单元)【可选配置-默认值1500】

    [Huawei-Vlanif10]damping time 5

    5、配置VLANif接口的带宽

    Bandwidth 1000(5700无法模拟)

    2、通过子接口支持VLAN间的通信

    三层以太网子接口是一种同时具备三层以太网物理接口和二层以太网物理接口双重属性的逻辑接口,同时具有三层路由功能和二层封装vlan标签特性。通过三层以太网子接口实现不同vlan间的三层互通,即我们通常所说的单臂路由。

    具体配置

    1、进入子接口视图。

    [Huawei]interface GigabitEthernet0/0/1.1

    [Huawei-GigabitEthernet0/0/1.1]

    2、配置子接口的IP地址。

    [Huawei-GigabitEthernet0/0/1.1]ip address

    1.1.1.1 24

    3、配置dot1q子接口通过的VLAN。

    [Huawei-GigabitEthernet0/0/1.1]dot1q

    termination vid 2 to 4

    不同主接口下的子接口可以关联相同的VLAN ID,但是同一主接口下的不同子接口一定不能关联相同的VLAN ID。

    当子接口用于三层转发时,既使指定多个内层VLAN,也只有第一个VLAN生效。

    4、使能子接口的ARP广播功能。

    [Huawei-GigabitEthernet0/0/1.1]arp

    broadcast enable

    使能或去使能子接口的ARP广播功能,会使该子接口的路由状态发生一次先Down再Up的变化,从而可能导致整个网络的路由发生一次震荡,影响正在运行的业务。

    3、通过VLAN Switch支持VLAN间的通信

    VLAN Switch是一种按照VLAN Tag进行数据转发的技术,需要预先在网络中的各交换机上建立一条静态转发路径。当交换机接收到符合转发条件的VLAN数据后,根据VLAN Switch表将报文直接转发到相应的出接口,无需查看MAC地址表,提高了转发效率及安全性,可有效的避免MAC地址攻击及广播风暴。

    替换外层VLAN Tag,即VLAN Switch

    switch-vlan功能,与VLAN间通信。

    添加外层VLAN Tag功能,即VLAN

    Switch stack-vlan功能,与VLAN Stacking功能类似,是一种针对用户不同VLAN封装外层VLAN Tag的二层技术。

    本章节主要介绍VLAN Switch switch-vlan功能配置。关于VLAN Switch

    stack-vlan功能的配置,请见配置基于VLAN ID的灵活QinQ。

    具体配置

    [Huawei]vlan-switch ?

    STRING<1-32>  Name of

    vlan-switch #vlan switch的名称

    [Huawei]vlan-switch test ?

    interface  Interface #要替换外层vlan标签的端口,即源端口

    [Huawei]vlan-switch test interface ?

    Ethernet         Ethernet

    interface

    GigabitEthernet  GigabitEthernet

    interface

    [Huawei]vlan-switch test interface Ethernet

    0/0/1 ?

    vlan  The VLAN of received packet

    #要替换的外层VLAN id

    [Huawei]vlan-switch test interface Ethernet

    0/0/1 vlan 10 ?

    inner-vlan  The inner VLAN of

    received packet #要替换的内层vlan

    interface   Interface #替换外出vlan后发出帧的端口,即目的端口

    to          Range link symbol #可以同时替换多个vlan

    [Huawei]vlan-switch test interface Ethernet

    0/0/1 vlan 10 interface GigabitEthernet 0/0/1 ?

    stack-vlan   Stack VLAN  #添加外层vlan

    switch-vlan  Switch VLAN #替换外层vlan

    [Huawei]vlan-switch test interface Ethernet

    0/0/1 vlan 10 interface GigabitEther

    net 0/0/1 switch-vlan ?

    INTEGER<1-4094>  VLAN ID #添加或替换后的 外层vlanID

    [Huawei]vlan-switch test interface Ethernet

    0/0/1 vlan 10 interface GigabitEther

    net 0/0/1 switch-vlan 5

    vlan-switch中指定的源接口和目的接口必须是Hybrid或Trunk类型接口,不能是Access类型接口或Eth-Trunk接口成员口。目的端口和源端口不能加入到相应的vlan。

    vlan-switch中的任意VLAN ID与全局VLAN ID冲突。如果指定VLAN ID已经应用到VLAN Switch功能中,那么全局中将无法创建该VLAN。

    如果指定VLAN ID已经用于QinQ中,那么该VLAN ID不能再应用到VLAN

    Switch功能中。

    若报文携带两层Tag,如果外层VLAN ID已经用于port

    vlan-stacking、port vlan-mapping或控制VLAN中,那么报文中的外层VLAN ID将不能成功应用于VLAN Switch功能。

    环网情况下,即使已经配置了破环协议,匹配VLAN Switch的报文也会穿过被破环协议block的接口继续转发,可能会造成广播风暴等情况,因此这种情况下不建议使用VLAN Switch功能。

    展开全文
  • 二层、三层交换机配置及VLAN划分教程
  • 某企业有两个主要部门,技术部和销售部,分处于不同的办公室,为了安全和便于管理对两个部门的主机进行了VLAN划分,技术部和销售部分处于不同的VLAN,先由于业务的需求需要销售部和技术部的主机能够相互访问,获得...
  • 1、通过VLANIF接口实现VLAN间的通信划分VLAN后,同一VLAN内的用户可以互相通信,但是属于不同VLAN的用户不能直接通信。为了实现VLAN间通信,可通过配置逻辑的三层接口——VLANIF接口来实现。当VLAN中接口状态变为...
  • 方法/步骤 1、打开Cisco Packet Tracer,点击【交换机】,选择第三个图标2960交换机,按住鼠标左键拖动到工作区。这里有很多类型的交换机,但是我们比较常用的...4、用标签标示三台主机的Vlan号、连接交换机端口、...
  • WORD格式 整理分享范文范例 参考指导一、标识交换机二、设置口令及用户三、配置VTP(Vlan中继协议)四、配置中继线(Trunk)五、创建、描述Vlan及设置Vlan IP六、划分、描述及设置Vlan端口七、配置STP(生成树协议)八、...
  • 网络VLAN划分配置图解教程下载 ┆绝对让你学习会VLAN知识网络VLAN划分配置图解教程发布!目前网络上最完美最全面的VLAN知识大全,整理了好一阵子,终于整理好了,马上发布出来与大家分享。其实VLAN就是一个小圈子,...
  • 一般教程第一课都讲交换机/路由器的操作系统(IOS)的基本操作,例如介绍普通模式、特权模式,修改密码等。我们反其道而行之,先动手做VLAN划分操作,先讲实操,再说概念。1、实验1(配置vlan access):1.1搭建...
  • 交换机在局域网中的应用交换机在局域网中的应用分为两种:1、作为二层交换机使用,为多个用户划分VLAN,实现同网段数据访问。2、作为三层交换机使用,部署用户的网关,实现跨网段数据访问。三种典型组网1.一个用户pc...
  • 计算机网络工程实践教程——基于华为路由器和交换机目录第2章交换机VLAN配置55 2.1交换机VLAN的端口划分和配置55 2.1.1操作内容和环境55 2.1.2VLAN划分56 2.1.3操作步骤57 2.2VLAN之间的路由协议配置58 2.2.1操作...
  • Cisco Packet Tracer教程

    千次阅读 2018-11-20 13:16:37
    01. 开篇:组建小型局域网  02. 交换机的基本配置和管理 ... 04. 交换机的端口聚合配置 ...05. 交换机划分Vlan配置 06. 三层交换机实现VLAN间路由 07. 快速生成树协议 08. 路由器的基本配置和Tal...
  • 教程名称:Packet Tracer 5.0使用指南及实验实训教程课程目录:【】第1章_认识packet_tracer5.0软件【】第2章_交换机的基本配置与管理【】第3章_交换机的Telnet远程登陆配置【】第4章_交换机划分Vlan配置【】第5章_...
  • 静态路由和默认路由的配置,rip协议、igrp协议、eigrp协议、ospf协议的配置,交换机的基本配置,vlan的配置,维护管理路由器和交换机,配置访问控制列表,配置ppp和ddr,帧中继的配置,配置nat和dhcp的实用技术等,...
  • **逻辑隔离:**用VLAN来控制广播,VLAN技术是在交换机上实现的而且是通过逻辑隔离划分的广播域 VLAN(虚拟局域网) 作用: 分割广播域(我来给他理解成局域网中,在创建一片局域网),控制广播,逻辑隔...
  • 第六章 交换机划分Vlan配置 9 第七章 三层交换机基本配置 11 第八章 利用三层交换机实现VLAN间路由 13 第九章 快速生成树配置 16 第十章 路由器的基本配置 18 第十一章 路由器单臂路由配置 20 第十二章 ...
  • 本笔记的实验来源是上学校...交换机划分Vlan配置 三层交换机实现VLAN间路由 快速生成树协议 路由器的基本配置和Talent配置 路由器单臂路由配置 路由器静态路由配置 路由器RIP动态路由配置 路由器OSPF动
  • Vlan是用来在交换机上重新划分广播域的网络技术,在以后部署云平台openstack的时候会用到vxlan,为了更好的理解vxlan,故先要熟悉vlan. 环境说明: 1.一台物理机:安装centos7u3 2.物理机器上安装kvm虚拟机四台 复制代码...
  • 网路设备模拟器Packet Tracer教程 第一章 认识Packet Tracer软件... 1 第二章 交换机的基本配置与管理......第六章 交换机划分Vlan配置... 9 第七章 三层交换机基本配置... 12 第八章 利用三层交换机实现...
  • 第四章 交换机划分Vlan配置 5 第五章 利用三层交换机实现VLAN间路由 7 第六章 快速生成树配置 10 第七章 路由器的基本配置 12 第八章 路由器单臂路由配置 14 第九章 路由器静态路由配置 16 第十章 路由器RIP...
  • 第六章 交换机划分Vlan配置 9 第七章 三层交换机基本配置 12 第八章 利用三层交换机实现VLAN间路由 13 第九章 快速生成树配置 16 第十章 路由器的基本配置 19 第十一章 路由器单臂路由配置 21 第十二章...
  • 第四章 交换机划分Vlan配置 5 第五章 利用三层交换机实现VLAN间路由 7 第六章 快速生成树配置 10 第七章 路由器的基本配置 12 第八章 路由器单臂路由配置 14 第九章 路由器静态路由配置 16 第十章 路由器RIP...
  • 第六章 交换机划分Vlan配置 9 第七章 三层交换机基本配置 12 第八章 利用三层交换机实现VLAN间路由 13 第九章 快速生成树配置 16 第十章 路由器的基本配置 19 第十一章 路由器单臂路由配置 21 第十二章 ...
  • Packet_Tracer使用教程

    2014-01-18 12:35:38
    第四章 交换机划分 Vlan 配置... ... 5 第五章 利用三层交换机实现 VLAN 间路由... . 7 第六章 快速生成树配置... .. 10 第七章 路由器的基本配置... . 12 第八章 路由器单臂路由配置... ... 14 第九章 路由器静态...
  • 第1章 认识packet tracer5.0软件,第2章 交换机的基本配置与管理,第3章 交换机的Telnet远程登陆配置,第4章 交换机划分Vlan配置,第5章 利用三层交换机实现VLAN间路由,第6章 快速生成树配置,第7章 路由器的基本配置,第8...

空空如也

空空如也

1 2 3
收藏数 43
精华内容 17
关键字:

交换机划分vlan教程