精华内容
下载资源
问答
  • 华为交换机基本配置命令详解
    千次阅读
    2020-12-24 08:24:45

    1:配置登录用户,口令等

    //用户直行模式提示符,用户视图

    system-view //进入配置视图

    [Quidway] //配置视图(配置密码后必须输入密码才可进入配置视图)

    [Quidway] sysname xxx //设置主机名成为xxx这里使用

    [Quidway] aaa //进入aaa认证模式定义用户账户

    [Quidway-aaa] local-user wds password cipher wds

    [Quidway-aaa] local-user wds level 15

    [Quidway-aaa] local-user wds service-type telnet terminal ssh //有时候这个命令是最先可以运

    //行的,上边两个命令像password,level都是定义完vty 的

    // authentication-mode aaa后才出现

    [Quidway-aaa] quit

    [Quidway] user-interface vty 0 4 //当时很奇怪这个命令就是找不到,最后尝试了几次才能运行

    [Quidway-ui-vty0-4] authentication-mode aaa

    [Quidway-ui-vty0-4] quit

    2:华为S9303 VLan设置

    创建vlan:

    //用户直行模式提示符,用户视图

    system-view //进入配置视图

    [Quidway] vlan 10 //创建vlan 10,并进入vlan10配置视图,如果vlan10存在就直接进入vlan10配置视

    [Quidway-vlan10] quit //回到配置视图

    [Quidway] vlan 10

    更多相关内容
  • 华为交换机启动配置命令详解大全

    千次阅读 2021-01-14 09:09:16
    华为交换机启动配置命令详解大全1、自动保存配置[Huawei]set save-configuration ?backup-to-server Back up theconfiguration to the server on the network#保存配置文件到服务器cpu-limit Specify theupper limit...

    华为交换机启动配置命令详解大全

    1、自动保存配置

    [Huawei]set save-configuration ?

    backup-to-server  Back up the

    configuration to the server on the network

    #保存配置文件到服务器

    cpu-limit         Specify the

    upper limit of CPU usage when the system automatically backup the current

    configuration #备份配置时CPU使用上限

    delay             Specify the

    delay time of the automatical backup after the current configuration change #配置变更发生后自动备份配置的延时时间

    interval          Specify the

    interval for backuping the current configuration automatically  #自动备份当前配置的时间间隔

    [Huawei]set save-configuration

    backup-to-server ?

    server  Server on the network

    [Huawei]set save-configuration

    backup-to-server server ?

    X.X.X.X  Specify the IP address of

    the server

    [Huawei]set save-configuration

    backup-to-server server 10.1.1.1 ?

    transport-type  Specify the type

    of the transmission

    user            Specify the user

    accessing the server

    [Huawei]set save-configuration

    backup-to-server server 10.1.1.1 user ?

    STRING<1-64>  Name of the

    user

    [Huawei]set save-configuration

    backup-to-server server 10.1.1.1 user ftp ?

    password  Specify the password

    used to access the server

    [Huawei]set save-configuration

    backup-to-server server 10.1.1.1 user ftp password 023wg.com ?

    path  Specify the path on the

    server

    [Huawei]set save-configuration

    backup-to-server server 10.1.1.1 user ftp password 023wg.com path ?

    STRING<1-64>  Name of the

    path

    [Huawei]set save-configuration

    backup-to-server server 10.1.1.1 user ftp password 023wg.com path back ?

    2、手动保存配置

    save ?

    STRING<5-64>  The name of

    specific file ( *.cfg , *.zip)

    all           All configuration

    including those of unavailable cards or slots

    save all

    在第一次保存配置文件时,如果不指定可选参数configuration-file,则设备将提示是否将文件名保存为“vrpcfg.zip”。“vrpcfg.zip”是系统缺省的配置文件,初始状态是空配置。

    3、查看系统当前启动配置文件名

    display startup

    MainBoard:

    Configured startup system software:        NULL

    Startup system software:                   NULL

    Next startup system software:              NULL

    Startup saved-configuration file:          NULL

    Next startup saved-configuration file:     flash:/vrpcfg.zip

    Startup paf file:                          NULL

    Next startup paf file:                     NULL

    Startup license file:                      NULL

    Next startup license file:                 NULL

    Startup patch package:                     NULL

    Next startup patch package:                NULL

    4、比较配置文件

    用户可以通过比较当前配置和下次启动的配置文件,查看哪些配置项是不一致的,决定是否需要将当前配置设置为下次启动时加载的配置文件。

    系统在比较出不同之处时,将从两者有差异的地方开始显示字符(默认显示150个字符),如果该不同之处到文件末尾不足150个字符,将显示到文件尾为止。

    比较当前配置和下次启动的配置文件时,如果下次启动的配置文件为空,或者下次启动的配置文件存在,但是内容为空,系统将提示读文件失败。

    所比较的配置文件必须以“.cfg”或“.zip”作为扩展名。

    compare configuration ?

    INTEGER<0-65535>  The line

    of current-configuration to begin comparing

    STRING<5-48>      Specify

    configuration file to be compared

    compare configuration

    Warning: The current configuration is not

    the same as the next startup configura

    tion file. There may be several

    differences, and the following are some configur

    ations beginning from the first:

    ====== Current configuration line 40 ======

    ip address 10.1.1.10 255.255.255.0

    #

    interface

    GigabitEthernet0/0/3

    #

    wlan

    #

    interface NULL0

    #

    user-interface con 0

    ====== Configuration file line 41 ======

    interface

    GigabitEthernet0/0/3

    #

    wlan

    #

    interface NULL0

    #

    user-interface con 0

    user-interface vty 0 4

    user-interface vty 16 20

    如果不输入参数,表示从配置文件的首行开始进行比较。current-line-number和save-line-number这两个参数用来在发现配置文件不同之处后,跳过该不同处继续进行比较。

    为什么compare configuration会失败

    V100R003之前版本执行compare configuration命令是用来比较当前的配置文件与存储设备中保存的配置文件内容是否一致,通过display startup命令查询,当上一次启动时使用的配置文件为NULL时,会导致compare configuration失败。因此设备初次上电,配置好并save之后,建议整机复位一下设备。

    V100R003及以后的版本执行compare configuration命令是用来比较当前的配置与下次启动的配置文件内容是否一致,所以没有这样的问题。

    5、备份配置

    为防止设备意外损坏,导致配置文件无法恢复,可以通过以下三种方法进行备份配置文件:

    1、直接屏幕拷贝。

    2、备份配置文件到存储器中。

    3、通过FTP、TFTP、FTPS、SFTP和SCP备份配置文件。

    5.1、直接拷贝配置文件

    在命令行界面上,执行display

    current-configuration命令,并拷贝所有显示信息到TXT文本文件中,从而将配置文件备份到维护终端的硬盘中。

    屏幕上显示的配置信息受终端软件的影响,可能会出现某配置过长而换行的情况。对于换行的配置,拷贝至TXT文本中时,需要删除换行,保证一条配置信息在只处在一行中。否则当使用制作的TXT文本恢复配置时,换行的配置可能无法恢复。

    5.2、备份配置文件到cfcard中

    该步骤主要便于用户在设备的cfcard中及时备份当前配置文件。在设备启动之后,使用如下命令在设备的cfcard中备份配置文件。

    如果不是保存在设备的默认存储器中,需要指定绝对路径。

    save

    config.cfg

    copy

    config.cfg backup.cfg

    5.3、通过FTP、TFTP、FTPS、SFTP和SCP备份配置文件

    设备支持通过FTP、TFTP、FTPS、SFTP和SCP备份配置文件。其中使用FTP和TFTP备份配置文件比较简单,但是存在安全风险。在安全要求比较高的场景中,建议使用FTPS、SFTP和SCP备份配置文件。以下仅以FTP作为示例介绍备份配置文件。

    5.3.1、设备作为FTP服务器,启动FTP服务。

    在设备上启动FTP服务器功能,并创建用户名为huawei,密码为023wg.com的FTP用户,授权此用户可访问的目录是“cfcard:”。

    system-view

    [HUAWEI] ftp server enable

    Warning: FTP is not a secure protocol, and it is recommended to use

    SFTP.

    Info: Succeeded in starting the FTP server.

    [HUAWEI] aaa

    [HUAWEI-aaa] local-user

    huawei password irreversible-cipher 023wg.com

    [HUAWEI-aaa] local-user huawei

    ftp-directory cfcard:

    [HUAWEI-aaa] local-user

    huawei service-type ftp

    [HUAWEI-aaa] local-user

    huawei privilege level 15

    5.3.2、从维护终端向设备发起FTP连接。

    在PC上,通过FTP客户端与设备建立FTP连接(例如设备的IP地址是10.110.24.254)。

    C:\Documents and Setting\Administrator> ftp 10.110.24.254

    Connected to 10.110.24.254.

    220 FTP service ready.

    User (10.110.24.254:(none)): huawei

    331 Password required for huawei.

    Password:

    230 User logged in.

    5.3.3、设置传输参数。

    FTP用户验证通过后,FTP客户端显示提示符“ftp>”,在“ftp>”提示下键入binary(二进制传输模式),并设置FTP客户端存放上载文件的目录路径。

    ftp> binary

    200 Type set to I.

    ftp> lcd c:\temp

    Local directory now C:\temp.

    5.3.4、传输配置文件。

    在PC上,使用get命令将配置文件下载至本地指定目录中,并保存为backup.cfg。

    ftp> get

    cfcard:/config.cfg backup.cfg

    5.3.5、确认config.cfg和backup.cfg的文件大小是否一致。如果文件大小一致则认为备份成功。

    6、恢复配置

    用户进行了错误的配置,导致功能异常,可以通过以下三种方法进行配置恢复:

    根据操作记录重新配置或根据保存的配置文件重新配置

    从存储器恢复配置文件。

    通过FTP、TFTP、FTPS、SFTP和SCP恢复配置文件。

    在恢复配置文件后,为了让配置文件生效,需要重新启动设备。先使用startup saved-configuration命令指定重新启动使用的配置文件(如果配置文件命名没有变,则该步骤省略),然后使用reboot命令重新启动设备。

    1、从存储器恢复配置文件

    该步骤主要便于用户将存储在设备cfcard中的备份配置文件恢复成当前系统运行的配置文件。在设备正常工作时,使用如下命令。

    copy cfcard:/backup.cfg cfcard:/config.cfg

    2、通过FTP、TFTP、FTPS、SFTP和SCP恢复配置文件

    设备支持通过FTP、TFTP、FTPS、SFTP和SCP恢复配置文件。其中使用FTP和TFTP恢复配置文件比较简单,但是存在安全风险。在安全要求比较高的场景中,建议使用FTPS、SFTP和SCP恢复配置文件。以下仅以FTP作为示例介绍恢复备份在PC上的配置文件。

    6.2.1、设备作为FTP服务器,启动FTP服务。

    在设备上启动FTP服务器功能,并创建用户名为huawei,密码为023wg.com的FTP用户,授权此用户可访问的目录是“cfcard:”。

    system-view

    [HUAWEI] ftp server enable

    Warning: FTP is not a secure protocol, and

    it is recommended to use SFTP.

    Info: Succeeded in starting the FTP server.

    [HUAWEI] aaa

    [HUAWEI-aaa] local-user huawei password irreversible-cipher Helloworld@6789

    [HUAWEI-aaa] local-user huawei ftp-directory cfcard:

    [HUAWEI-aaa] local-user huawei service-type ftp

    [HUAWEI-aaa] local-user huawei privilege level 15

    6.2.2、从维护终端向设备发起FTP连接。

    在PC上,通过FTP客户端与设备建立FTP连接(例如设备的IP地址是10.110.24.254)。

    C:\Documents and Setting\Administrator> ftp 10.110.24.254

    Connected to 10.110.24.254.

    220 FTP service ready.

    User (10.110.24.254:(none)): huawei

    331 Password required for huawei.

    Password:

    230 User logged in.

    6.2.3、设置传输参数。

    FTP用户验证通过后,FTP客户端显示提示符“ftp>”,在“ftp>”提示下键入binary(二进制传输模式),并设置FTP客户端存放上载文件的目录路径。

    ftp> binary

    200 Type set to I.

    ftp> lcd c:\temp

    Local directory now C:\temp.

    6.2.4、传输配置文件。

    在PC上,使用put命令将配置文件上传至本地指定目录中,并保存为backup.cfg。

    ftp> put cfcard:/config.cfg backup.cfg

    6.2.5、在设备上确认上传的backup.cfg文件是否成功。如果设备上存在backup.cfg文件,且文件大小正确则认为恢复配置文件成功。

    7、清除配置

    7.1、空设备下次启动使用的配置文件的内容,并取消指定系统下次启动时使用的配置文件,从而使设备配置恢复到缺省值

    reset

    saved-configuration

    Warning:

    The action will delete the saved configuration in the device.

    The configuration

    will be erased to reconfigure. Continue? [Y/N]:y

    Warning:

    Now clearing the configuration in the device.

    Info:

    Succeeded in clearing the configuration in the device.

    reboot

    Info: The

    system is now comparing the configuration, please wait.

    Warning:

    All the configuration will be saved to the configuration file for the n

    ext

    startup:, Continue?[Y/N]:n

    System

    will reboot! Continue?[Y/N]:y

    reset

    saved-configuration命令会清空设备下次启动使用的配置文件信息,请慎重执行该命令。

    执行该命令后,如果当前启动配置文件与下次启动配置文件相同,当前启动的配置文件也会被清空。

    执行该命令后,用户手动重启设备时,系统会提示用户是否保存配置,这时候选择不保存才能清空配置。

    取消指定系统下次启动时使用的配置文件后,如果不使用startup saved-configuration命令重新指定新的配置文件,或者不保存配置文件,设备重启后,将会以缺省配置启动。

    如果设备下次启动的配置文件为空,设备会提示配置文件不存在。

    7.2、一键式清除指定接口下配置信息或将配置恢复到缺省值。

    当用户需要将设备上的某个接口用作其他用途时,原始的配置需要逐条删除。如果该接口下存在大量的配置,那么用户将耗费大量的时间进行删除动作,增大了用户的维护量。为了减少用户的维护量和降低操作的复杂度,可以一键式清除接口下的配置。

    [Huawei]clear configuration ?

    interface  Specify the interface

    [Huawei]clear configuration interface g

    [Huawei]clear configuration interface

    GigabitEthernet ?

    <0-0>  Slot number

    [Huawei]clear configuration interface

    GigabitEthernet 0/0/2

    Warning: All configurations of the

    interface will be cleared, and its state will be shutdown. Continue? [Y/N] :y

    Info: Total execute 0 command(s), 0

    successful, 0 failed.

    [Huawei]

    [Huawei-GigabitEthernet0/0/2]clear

    configuration this

    无论是在系统视图下还是在接口视图下执行命令清除指定接口下配置信息或将配置恢复到缺省值,使用时请慎重。被清除配置文件的接口将被置为shutdown状态。

    8、配置系统启动文件

    配置系统启动文件包括指定系统启动用的系统软件和配置文件,这样可以保证设备在下一次启动时以指定的系统软件启动以及以指定的配置文件初始化配置。如果系统启动时还需要加载新的补丁,则还需指定补丁文件。

    在进行配置前,用户可以使用display

    startup命令查看当前设备指定的下次启动时加载的文件。

    如果没有配置设备下次启动时加载的系统软件,则下次启动时将默认启动此次加载的系统软件。当需要更改下次启动的系统文件(如设备升级)时,则需要指定下次启动时加载的系统软件,此时还需要提前将系统软件通过文件传输方式保存至设备,系统软件必须存放在存储器的根目录下,文件名必须以“.cc”作为扩展名。

    如果设备是双主控环境,只需确保系统软件保存在主用主控板,当指定备用主控板的系统软件时,设备会自动拷贝至备用主控板。

    如果没有配置下次启动时加载的配置文件,则下次启动采用缺省配置文件(如vrpcfg.zip)。如果默认存储器中没有配置文件,则设备启动时将使用缺省参数初始化。

    配置文件的文件名必须以“.cfg”或“.zip”作为扩展名,而且必须存放在存储器的根目录下。

    补丁文件的扩展名为“.pat”,在指定下次启动时加载的补丁文件前也需要提前将补丁文件保存至设备存储器的根目录下。

    如果设备是双主控环境,用户将补丁文件上传至主用主控板,需要执行copysource-filename

    destination-filename命令手动拷贝至备用主控板,从而确保补丁文件分别保存至主用主控板和备用主控板。

    8.1、设备下次启动时加载的系统软件

    startup system-software ?

    STRING<4-64>  Specify the

    system-software name,in the format of [drive][file-name](Default drive is

    flash:/)

    8.2、如果设备是双主控环境设置备用主控板下次启动时加载的系统软件

    startup system-software ?

    STRING<4-64>  Specify the

    system-software name,in the format of

    [drive][file-name](Default

    drive is flash:/)

    startup system-software

    software.cfg ?

    slave-board  For the slave board

    startup system-software

    software.cfg slave-board ?

    8.3、系统下次启动时使用的配置文件

    startup saved-configuration ?

    STRING<5-64>  Specify the

    saved-configuration name,in the format of [drive][file-name](Default drive is

    flash:/)

    8.4、设备下次启动时加载的补丁文件

    startup patch ?

    STRING<5-64>  Specify the

    patch name,in the format of

    [drive][file-name](Default

    drive is flash:/)

    startup patch patch.pat ?

    slave-board  For the slave board

    9、重新启动设备

    为了使指定的系统软件及相关文件生效,需要在配置完系统启动文件后,对设备进行重新启动。

    重新启动设备有以下两种方式:

    立即重新启动设备:

    执行命令行后立即重新启动,也可通过在本地按动设备上的“RST”重启按钮,重新启动设备。

    定时重新启动设备:

    可以设置在未来的某一时刻重新启动设备。配置完下次系统启动文件后,为了不影响当前设备的运行,可以将设备设置在业务量少的时间点进行定时重新启动。

    设备每一次重新启动或某一单板复位的相关信息都会被详细记录下来,包括重新启动的次数、详细信息以及原因等,可以通过display reset-reason命令进行查看。

    一般情况下,不要轻易重新启动设备,因为这将导致在短时间内服务中断。

    在重新启动设备之前,如果需要将当前配置在重新启动设备后仍生效,请先确保当前配置已保存。

    9.1、立即重新启动设备

    reboot ?

    fast  Reboot system fast   #表示快速重启设备,不会提示是否保存配置文件

    save  Save system information  #表示快速重启设备,不会提示是否保存配置文件

    9.2、定时重启设备

    schedule reboot ?

    at     Specify the exact time  #设备定时重新启动的具体时间

    delay  Specify the time interval  #设备在定时重新启动前等待的时间

    schedule reboot at ?

    STRING  Exact time(hh:mm)

    schedule reboot at 11:22 ?

    YYYY/MM/DD  Date to reboot

    (YYYY/MM/DD)

    schedule reboot at 11:22

    2016/4/4 ?

    schedule reboot delay ?

    STRING  Delay time, total minutes

    or hours:minutes(mm or hh:mm), the max

    value is 720 hours.

    schedule reboot delay 1:00 ?

    force  Force the schedule reboot.  #强制按照计划重启

    如果不指定force参数,系统首先会将当前配置与配置文件进行比较,如果不一致,则会提示是否保存当前配置,用户进行选择后系统又将提示用户确认设置的定时重启时间,键入“Y”或者“y”后,设置生效。

    如果指定force参数,则系统不会出现任何提示,设置生效,当前配置不会被比较及保存。

    展开全文
  • 华为交换机常用命令

    万次阅读 2021-01-17 17:05:43
    华为交换机常用命令视图分类用户视图登陆设备后,直接进入用户模式,只能执行少量查看配置的命令Info: The max number of VTY users is 10, and the numberof current VTY users on line is 1.The current login ...

    华为交换机常用命令

    视图分类

    用户视图

    登陆设备后,直接进入用户模式,只能执行少量查看配置的命令Info: The max number of VTY users is 10, and the number

    of current VTY users on line is 1.

    The current login time is 2020-04-10 12:15:00+00:00.

    系统视图

    用户模式下,输入system-view命令进入视图模式,可执行设备全局配置的命令system-view

    Enter system view, return user view with Ctrl+Z.

    [ZD_agg_5720]

    局部视图

    系统视图模式下,输入局部配置命令,进入局部对像的配置视图。如interface GE 1/0/0,进入GE1/0/0端口配置模式system-view

    Enter system view, return user view with Ctrl+Z.

    [ZD_agg_5720]interface GigabitEthernet 1/0/1

    [ZD_agg_5720-GigabitEthernet1/0/1]

    常用命令

    命令简介命令缩写解释displaydis查看相应对象信息

    undo撤消或反向操作对应命令

    system-viewsy进入系统视图

    sysname设置交换机名称

    quitq退出当前视图

    reboot交换机重启

    reset

    restart重新启动当前接口

    shutdown关闭当前接口

    信息查看命令

    交换机信息查看display version 查看交换机软件版本

    display clock 查看交换机时钟

    交换机配置查看display saved-configuration 显示系统保存配置

    display current-configuration 显示系统当前配置

    当前对象信息查看display this 显示当前信息。

    display this include-default 显示当前接口视图下的接口信息,包括默认值。

    display this interface 显示当前接口视图下的接口信息。

    查看接口display interface 查看接口当前运行状态和接口统计信息

    display interface brief 查看接口状态和配置的简要信息。

    display interface description 查看指定接口的描述信息

    display interface vlanif 查看VLANIF接口的状态信息、配置信息和统计信息。

    查看IP相关display ip interface 查看接口与IP相关的配置和统计信息,包括接口接收和发送的报文数、字节数和组播报文数,以及接口接收、发送、转发和丢弃的广播报文数。

    display ip interface brief 看接口与IP相关的简要信息,包括IP地址、子网掩码、物理链路和协议的Up/Down状态以及处于不同状态的接口数目。

    display ip interface description 查看接口与IP相关的简要信息,包括IP地址、子网掩码、物理层状态、链路层协议状态,及接口描述信息和处于不同状态的接口数目。

    display ip pool 显示所有ip pool

    display ip pool name {pool name} {all|conflict|expired|used} 显示ip pool详细信息

    display ip host 查看静态DNS表项

    display ip socket 查看已创建的IPv4 Socket信息。

    display ip statistics 显示IP流量统计信息。

    查看路由display ip routing-table 显示路由信息

    display ospf peer 查看ospf邻接等信息

    display ospf peer brief 查看ospf邻接等简要信息

    display rip 查看rip路由信息

    网络及流量display network status { all|tcp|udp|port port-number } 显示IP流量统计信息

    display tcp statistics 查看TCP流量统计信息

    display udp statistics 查看UDP流量统计信息

    VLAN查看display vlan 显示VLAN信息

    display vlan {pvid} verbose 查看vlan的详细信息

    display port vlan 查看VLAN中包含的接口信息

    display sub-vlan 查看Sub-VLAN类型的VLAN表项信息

    display super-vlan 查看Super-VLAN类型的VLAN表项信息

    display mac-vlan mac-address all 查看所有MAC地址划分VLAN的配置信息

    display mac-vlan vlan 2 查看vlan 2 MAC地址划分VLAN的配置信息

    查看ACL配置display acl {all | name | ipv6} 查看ACL

    display traffic classifier user-defined 查看用户定义的流分类

    display traffic behavior user-defined 查看用户定义的流行为

    display traffic policy user-defined {policy name} 查看用户定义的流策略

    display traffic-applied {inbound | outbound | interface | vlan} 查看流策略应用情况

    display traffic policy {global | interface | statistics | vlan } {inbound | outbound} 查看更多流策略信息

    display traffic policy statistics {global | interface | vlan} {inbound | outbound} 查看流策略统计信息

    display traffic-filter applied-record 查看acl应用的接口

    查看NAT配置#路由器命令

    display nat static {acl | global | inside | interface} 查看静态NAT信息

    display nat session {all | dest | number | protocol | source} 查看动态NAT信息

    display nat server {acl | global | inside | interface} 查看NAT server信息

    配置管理命令

    端口管理port 配置接口的缺省VLAN并加入该VLAN

    port description 配置接口的描述信息,描述与接口相连的设备类型。

    port gigabitethernet 0/0/1 to 0/0/4

    port default vlan 配置接口的缺省VLAN并同时加入这个VLAN。

    port link-type {access | hybird | trunk} 配置接口的链路类型

    port trunk allow-pass vlan {vlanid} 将trunk接口加入vlan

    端口配置speed {10|100|auto} 配置端口工作速率

    duplex {half|full|auto} 配置端口工作状态

    端口组操作display port-group {all} 查看端口组

    port-group {id} 创建端口组

    group-member gigabitethernet 0/0/2 to gigabitethernet 0/0/10 将2到10端口加入端口组

    VLAN管理vlan {id} 创建VLAN并进入VLAN视图,如果VLAN已存在,直接进入该VLAN的视图。

    vlan batch 10 to 20 批量创建VLAN

    vlan range 10 to 20 创建临时VLAN组,并进入VLAN-Range视图

    vlan statistics 配置VLAN的流量统计模式,即配置按包或按字节进行VLAN流量统计。

    vlan statistics interval 配置VLAN的流量统计的时间间隔

    ip address 用来配置接口的IP地址。

    接口管理interface gigabitethernet 0/0/1 进入指定的接口或子接口视图,进入0/0/1的接口

    DNS管理#查看

    display dns dynamic-host 查看动态DNS表项

    display dns domain 查看域名后缀的相关信息

    display dns server 查看DNS服务器的相关信息

    #设置

    dns domain domain-name 命令用来配置域名后缀,如 dns domain com.cn。

    dns resolve 命令用来使能动态域名解析功能

    dns server {ip} 命令用来配置DNS服务器的IP地址

    ip host {domain} {ip} 命令用来配置静态DNS表项 ip host www.huawei.com 10.10.10.4。

    DHCP管理dhcp enable 命令用来开启DHCP功能。

    dhcp select global 从全局配置中获取dhcp配置

    ACL管理acl {name | number | ipv6} 创建acl

    rule [{ruleid}] permit ip source {源ip} {反掩码} [ destination {源ip} {反掩码} ] 创建允许规则

    rule [{ruleid}] deny ip source {源ip} {反掩码} [ destination {源ip} {反掩码} ] 创建拒绝规则

    traffic-filter {inbound | outbound} acl {acl number} 在接口上应用acl规则

    #创建流分类

    traffic classifier {classifier name} operator { and |or }

    if-match acl {acl number} 为流分类设置匹配规则

    #创建流行为

    traffic behavior {behavior name}

    permit | deny | redirect 为流行为配置动作

    #创建流策略

    traffic policy {policy name}

    classifier {classifier name} behavior {behavior name} 关联流分类与流行为

    #将流策略应用到接口

    interface g0/0/1

    traffic-policy {policy name} {inbound | outbound} 接口绑定流策略

    NAT管理#边界路由器接口上配置静态NAT

    nat static global {外部ip} inside {内部ip} 添加静态nat,内外部ip一对一

    #动态NAT,使用dis nat session查看

    nat address-group {groupid} {ip开始} {ip结束} 添加外部可用地址池

    nat outbound {acl id} address-group {address-group id} no-pat 添加动态地址转换

    #NAPT,使用dis nat session查看

    nat outbound {acl id} [address-group {address-group id}] 添加动态端口地址转换

    #NAT server,使用dis nat server查看

    nat server protocol tcp global {外部ip} {外部端口} inside {内部ip} {内部端口} 添加nat server转换

    用户管理#查看本地用户

    display local-user

    #查看用户接口

    display user-interface

    #设置用户vty0为4个并发

    user-interface vty 0 4

    #进入用户console0接口

    user-interface console 0

    #用户管理

    local-user {username} password cipher {password}

    local-user {username} level 15

    local-user {username} service-type telnet terminal ssh

    绑定IP与MACuser-bind ip-address 10.0.0.2 mac-address 0001-0203-0405

    user privilege level 3

    LEVEL 0(访问级):可以执行用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。

    LEVEL 1(监控级):可以执行用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal等命令,执行该级别命令的结果不能被保存到配置文件中。

    LEVEL 2(系统级):可以执行用于业务配置的命令,主要包括路由等网络层次的命令,用于向用户提供网络服务。

    LEVEL 3(管理级):最高级,可以运行所有命令:关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem下载、用户管理命令、级别设置命令等。

    日志与统计#打开统计

    display counters 查看接口的流量统计计数

    statistic enable

    trace mac enable

    trace mac aa99-6600-5600 vlan 2

    其它命令display stp 显示生成树信息

    display mac-address 显示MAC地址表

    display bridge mac-address 查看当前桥接设备mac地址

    display arp 显示ARP信息表

    display voice-vlan oui 查看Voice VLAN的OUI及其相关属性。

    display voice-vlan status 查看当前Voice VLAN的相关信息

    mac-vlan mac-address

    操作实战

    VLAN操作

    创建vlan,设置vlan的ip,并将端口加入vlan中。#进入全局配置视图

    system-view

    #新建vlan2

    [Huawei] vlan 2

    #进入vlan2的接口视图

    [Huawei] interface vlan 2

    #设置vlan2的三层网关路由

    [Huawei-Vlanif2] ip address 10.0.0.1 255.255.255.0

    #进入0/0/1接口,配置为access接口并加入vlan2中

    [Huawei] interface GigabitEthernet 0/0/1

    [Huawei-GigabitEthernet0/0/1] port link-type access

    [Huawei-GigabitEthernet0/0/1] port default vlan 2

    #进入0/0/2接口,配置为trunk接口并加入vlan2中

    [Huawei] interface GigabitEthernet 0/0/2

    [Huawei-GigabitEthernet0/0/2] port link-type trunk

    [Huawei-GigabitEthernet0/0/2] port trunk allow-pass vlan 2

    #查看端口配置的信息

    [Huawei-GigabitEthernet0/0/2] dis this

    #进入vlan2,将0/0/2到0/0/5端口加入到vlan2中(port link-type需要是access类型)

    [Huawei] vlan 2

    [Huawei-vlan2] port GigabitEthernet 0/0/2 to 0/0/5

    端口组操作

    需要对多个端口进行相同操作时,可以创建端口组进行批量操作。#创建端口组1,进行批量端口操作

    [Huawei] port-group 1

    #将6到10端口加入端口组

    [Huawei-port-group-1] group-member gigabitethernet 0/0/6 to gigabitethernet 0/0/10

    #批量将2~10端口修改为access模式

    [Huawei-port-group-1] port link-type access

    #批量将6~10端口加入到vlan 2中

    [Huawei-port-group-1] port default vlan 2

    IP POOL操作 system-view

    #进入ip pool中

    [Huawei] ip pool vlan10

    #在ip pool中添加dns server

    [Huawei-ip-pool-vlan10] dns-list 8.8.8.8

    #设置网关

    [Huawei-ip-pool-vlan10] gateway-list 10.0.0.1

    #设置ip pool的ip段和池,需要与vlanif接口配置匹配,否则ip分配不了

    [Huawei-ip-pool-vlan10] network 10.0.0.0 mask 255.255.255.0

    #过期时间

    [Huawei-ip-pool-vlan10] lease day 10

    DHCP操作 system-view

    #全局打开DHCP服务

    [Huawei] dhcp enable

    #进入vlan的接口视图

    [Huawei] interface vlanif 2

    #设置vlan2的三层网关路由

    [Huawei-Vlanif2] ip address 10.0.0.1 255.255.255.0

    #从全局配置中获取dhcp配置

    [Huawei-Vlanif2] dhcp select global

    静态添加路由 system-view

    display ip routing-table

    #ip route-static 目的ip 目标地址掩码 下一跳ip

    [Huawei] ip route-static 10.0.1.0 255.255.255.0 10.0.0.1

    #删除路由

    [Huawei] undo ip route-static 10.0.1.0 255.255.255.0 10.0.0.1

    RIP路由管理 system-view

    #修改loopback0地址

    [Huawei] int LoopBack 0

    [Huawei-LoopBack0] ip address 1.1.1.1 0

    #创建rip进程

    [Huawei] rip 1

    #启动版本2

    [Huawei-rip-1] version 2

    #宣告网段

    [Huawei] network 10.0.0.0

    [Huawei] network 1.0.0.0

    OSPF路由管理 system-view

    #创建ospf

    [Huawei] ospf 1 router-id 1.1.1.1

    #创建area0区域

    [Huawei-ospf-1] area 0

    #加入192.168.0.0/24子网

    [Huawei-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255

    [Huawei-ospf-1-area-0.0.0.0]dis this

    #

    area 0.0.0.0

    network 192.168.0.0 0.0.0.255

    #

    [Huawei-ospf-1-area-0.0.0.0]

    ACL管理 system-view

    #配置acl

    [Huawei] acl 3000

    [Huawei-acl-adv-3000] rule permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255

    [Huawei-acl-adv-3000] rule permit ip source 192.168.2.0 0.0.0.255

    [Huawei-acl-adv-3000] quit

    #配置流分类,匹配acl

    [Huawei] traffic classifier c0 operator or

    [Huawei-classifier-c0] if-match acl 3000

    [Huawei-classifier-c0] quit

    #配置流行为,设置动作

    [Huawei-behavior-b0] traffic behavior b0

    [Huawei-behavior-b0] permit

    [Huawei-behavior-b0] quit

    #配置流策略,关联流分类c0与流行为b0

    [Huawei] traffic policy p0

    [Huawei-trafficpolicy-p1] classifier c0 behavior b0

    [Huawei-trafficpolicy-p1] quit

    #配置流策略应用到接口

    [Huawei] interface g0/0/1

    [Huawei-GigabitEthernet0/0/1] traffic-policy p0 inbound

    [Huawei-GigabitEthernet0/0/1] return

    用户管理#查看本地用户

    display local-user

    system-view

    #进入aaa配置模式

    [Huawei] aaa

    #配置本地用户账号密码

    [Huawei-aaa] loca-user user1 password cipher 123456

    #用户服务类型为telnet,使用telnet登陆

    [Huawei-aaa] local-user user1 service-type telnet

    #配置用户特权等级15

    [Huawei-aaa] local-user user1 privilege level 15

    展开全文
  • 交换机:H3C S5000P系列以太网交换机 二、常用命令 1.进入系统视图 <Quidway> system-view #可简写作sys 进入系统视图 2.修改交换机名字 [Quidway] sysname Switch #将设备的名称修改为Switch 3.进入...

    目录

    一、实验环境

    二、常用命令

    三、名词解释

    1.交换机

    2.交换机的配置

    3.端口汇聚

    4.端口镜像

    5.端口绑定

    6.VLAN


    一、实验环境

            交换机:H3C S5000P系列以太网交换机


    二、常用命令

    1.进入系统视图
    <Quidway> system-view    #可简写作sys 进入系统视图
    
    2.修改交换机名字
    [Quidway] sysname Switch    #将设备的名称修改为Switch
    
    3.进入以太网端口视图
    [Quidway] interface GigabitEthernet0/1    #可简写作int g0/1
    
    4.进入VLAN视图
    [Quidway] vlan 1    #进入VLAN1视图
    
    5.进入VLAN接口视图
    [Quidway-vlan1] interface vlan-interface 1    #进入VLAN1接口视图
    
    6.返回上一级视图
    [Quidway-vlan1] quit
    [Quidway]
    
    7.返回用户视图
    [Quidway-vlan1] return    #也可以使用[Ctrl]+[Z]
    <Quidway>
    8.交换机的重启
    [Quidway] restore default    #擦除EEPROM中的配置信息
    [Quidway] Reboot    #重新启动交换机
    9.端口配置
    #修改端口的工作方式 duplex {auto|full|half}
    #设置端口速率 speed {10|100|1000|auto}
    [Switch1-GigabitEthernet0/1] duplex full    #使端口处于全双工状态
    [Switch1-GigabitEthernet0/1] speed 100    #设置端口速率为100Mb/s
    
    [Switch1-GigabitEthernet0/1] undo duplex    #取消端口工作模式配置,回复至默认状态auto
    [Switch1-GigabitEthernet0/1] undo speed    #取消端口速率配置,回复至默认状态auto
    
    
    10.端口汇聚
    [Switch1] link g0/1 to g0/3    #将端口g0/1到g0/3汇聚成一个汇聚组
    [Switch1] display link    #查看端口汇聚的信息
    
    11.端口镜像
    实例:将g0/1-g0/2端口上的报文复制到指定镜像端口g0/3 
    [Switch1] monitor-port g0/3    #设置镜像端口
    [Switch1] mirroring-port g0/1 to g0/2    #设置被镜像的端口
    [Switch1] display mir    #查看端口镜像的信息
    
    12.端口绑定
    实例:将主机MAC地址和VLAN 1的端口G0/1绑定。    
    配置步骤:
    <Quidway> system-view
    [Quidway] mac-address mac-learning g0/1 disable    #取消端口地址学习功能
    [Quidway] mac-address static xxxx-xxxx-xxxx interface g0/1 vlan 1    #配置静态地址表项
    
    13.查看MAC地址表
    查看MAC地址表
    [Switch1] display mac-address
    
    14.VLAN配置
    <Quidway> sys
    [Quidway] vlan 2    #进入VLAN 2视图
    [Quidway-vlan2] management-vlan    #配置为管理VLAN。
    #注意:VLAN1不能配置为管理VLAN
    [Quidway-vlan2] quit    #退出VLAN视图。
    [Quidway] interface vlanif 2,创建并进入Vlanif接口视图。
    [Quidway-Vlanif2] ip address 192.168.10.1 24    #配置Vlanif接口的IP地址
    
    15.将端口配置为Access接口
    [Quidway] int e0/1    #进入e0/1端口
    [Quidway-Ethernet0/1] port link-type access
    [Quidway-Ethernet0/1] port default vlan 10    #配置access端口的PVID
    [Quidway-Ethernet0/1] ip address 192.168.10.1 24    #配置端口的IP地址
    
    16.将端口配置为Trunk接口
    [Quidway] int e0/1    #进入e0/1端口
    [Quidway-Ethernet0/1] port link-type trunk
    [Quidway-Ethernet0/1] port trunk allow-pass vlan 10 20    #设置trunk端口e0/1允许vlan10 vlan20的数据帧通过
    [Quidway-Ethernet0/1] ip address 192.168.10.1 24    #配置端口的IP地址
    17.其他
    display + ... 查看某些信息,例如:
    [Quidway] display current-configuration
    #显示以太网交换机当前生效的配置参数。
    
    [Quidway] display saved-configuration
    #显示EEPROM中交换机配置文件,即以太网交换机重新启动时所用的配置文件。
    
    
    ... + ? 查看帮助,例如:
    [Quidway] dis a?
    
    

    三、名词解释

    1.交换机

            交换机是工作在OSI参考模型数据链路层(第二层)的设备。它的功能有:地址学习、转发/过滤、消除环路。

    2.交换机的配置

            1)通过Console口的配置

            2)通过Telnet访问的配置

    3.端口汇聚

            端口汇聚是指将多个端口聚合在一起,以实现出入负荷在各成员端口中的分担。

            一个汇聚组可以看作是一个带宽更大的端口,端口汇聚在实现负荷分担的同时增加了链路带宽,同时又不会形成环路。当汇聚组中的端口出现故障时,数据可以从汇聚组中的其他端口进行转发。

            汇聚的端口满足以下三个条件:

            1)必须工作在全双工方式下

            2)必须工作在相同的速率下

            3)端口的VLAN端口类型必须一致。

            参与端口汇聚的端口只能是连续的。

    4.端口镜像

            基于端口的镜像功能,可将指定的一个或多个端口的报文复制到镜像端口,用于报文的分析和监视。

    5.端口绑定

            端口绑定是指MAC地址与端口绑定的功能。用户可以通过配置,只允许某些授权的设备通过该端口访问网络,而非授权设备不能通过该端口访问网络。

            端口绑定功能实现的基本原理:

            1)取消该端口的MAC地址学习功能。

            2)以静态的方式将授权设备的MAC地址添加到交换机的MAC地址表中

    6.VLAN

            VLAN即虚拟局域网,是将一个物理的LAN在逻辑上划分成多个广播域的通信技术。

            VLAN的功能:

            1)限制广播域:广播的范围被限制在一个VLAN里

            2)增强局域网的安全性:一个VLAN内的用户不能直接和其它VLAN内的用户通信

            3)提高了网络的健壮性:故障被限制在一个VLAN内,本VLAN内的故障不会影响其他VLAN的正常工作

            4)可以灵活地构建虚拟工作组

            在一个VLAN交换网络中,以太网帧主要以两种形式存在:有标记帧(Tagged帧),加入了4字节VLAN标签的MAC数据帧;无标记帧(Untagged帧),未加入4字节VLAN标签的MAC数据帧。

            交换机内部处理的数据帧都带有VLAN标签,而现网中交换机连接的设备有些只会收发Untagged帧;同时跨交换机之间的通信由于可能存在多个VLAN,连接两台交换机的端口需要对数据帧的VLAN标签做一些处理。

            根据接口连接对象以及对收发数据帧处理的不同。华为定义了4种接口的链路类型:Access、Trunk、Hybrid和QinQ。


            Access接口一般用于和不能识别Tag的用户终端(如用户主机、服务器等)相连,或者不需要区分不同VLAN成员时使用。

           Trunk接口一般用于连接交换机、路由器以及其它可同时收发Tagged帧和Untagged帧的设备。

    展开全文
  • h3c交换机清空配置命令

    千次阅读 2021-01-16 21:11:08
    h3c交换机清空配置命令H3C CAS云计算管理平台融合了华三通信在网络安全领域的积累,通过对IEEE 802.1Qbg(EVB)标准的支持,为虚拟机在安全、可视、可监管的环境下运行奠定了基础。下面是小编收集的h3c交换机清空配置...
  • 1、创建vlan(进入特权模式即可配置) ...2、交换机命名(进入特权模式即可配置) (GSM5212P) #set prompt name ——更改交换机命名。 3、接口配置(先进入配置模式) (1)上联口配置(相当
  • 思科交换机常用命令汇总

    千次阅读 2021-04-02 13:57:58
    思科交换机常用命令汇总 show version show running-config show vlan brief show ip interface brief show running-config interface f0/1 show ip route show inventory //显示设备SN、设备名 更换MAC地址 在...
  • H3C交换机常用配置命令

    万次阅读 多人点赞 2018-04-21 09:28:25
    [H3C]undo snmp-agent 禁止SNMP Agent的运行,若配置任何SNMP命令重新启动SNMP Agent [H3C]display snmp-agent community read [H3C]display snmp-agent sys-info contact [H3C]display snmp-agent sys-info ...
  • 路由/交换机命令大全~!路由/交换机命令大全~!交换机命令switch> 用户模式1:进入特权模式enableswitch> enableswitch#2:进入全局配置模式configure terminalswitch> enableswitch#configure terminal...
  • 锐捷交换机配置命令总结中篇

    千次阅读 2021-07-08 02:58:49
    锐捷交换机显示命令:显示交换机硬件及软件的信息 Switch#show version显示当前运行的配置参数 Switch#show running-config显示保存的配置参数 Switch#show configure常用锐捷交换机EXEC命令将当前运行的配置参数...
  • Extreme交换机在你丢失或忘记密码后,需要重新启动交换机,常按空格键,进入Bootrom模式,输入“h”,选择“d: Force Factory default configuration”清除配置文件,最后选择“f: Boot on board flash”重新启动后...
  • Cisco交换机启动命令

    2014-06-27 09:31:16
    sw1924_b#delete nvram ...重新启动交换机(初始提示符为> ) sw1924_b#hostname sw1924设置交换机的主机名 sw1924_b#enable secret cisco 设置加密密码 sw1924_b#enable password level 1 cisco1 设置等...
  • 思科三层交换机配置命令

    千次阅读 2019-05-21 14:29:03
    1.交换机支持的命令 思科交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式 ...
  • 交换机常用配置命令(华为)

    千次阅读 2021-04-30 08:12:23
    如果想通过WEB方式管理交换机,必须首先将一个用于支持WEB管理的文件载入交换机的flash中,该文件需要与交换机当前使用的软件版本相配套。WEB管理文件的扩展名为”tar”或者”zip”,可以从网站上下载相应的交换机...
  • 华三交换机重启命令(范文篇).doc

    千次阅读 2020-12-23 17:53:26
    [华三交换机重启命令篇一]重启交换机命令程控交换机中RF重启命令组所能解决的故障类型重新启动命令所能解决的故障类型大致上可以归纳为以下3个方面:一是由于交换机出现某些干扰后软件运行故障;二是在交换机系统...
  • 交换机基本命令模式

    千次阅读 2019-05-16 13:04:53
    交换机基本命令模式 对于思科交换机来说,主要有2种配置途径:其一,使用交换机自带的Console线缆连接到计算机的COM口,然后利用计算机的超级终端软件直接配置,首次配置通常使用这种方式;其二,通过telnet方式...
  • H3C交换机基本配置命令明细一览

    千次阅读 2020-12-18 22:47:19
    5: 交换机保存设置和重置命令 save //保存配置信息 reset saved-configuration /重置交换机的配置 reboot //重新启动交换机后配置恢复到出厂设置。 6:交换机常用的显示命令 用户视图模式下: display current...
  • 阿尔卡特交换机常用命令

    千次阅读 2020-12-31 11:15:27
    OmniSwitch查看日志的命令是:格式:show log swlog [timestamp start_time [end_time]]show log swlog timestamp 05/21/2015 11:30 05/21/2015 12:30发现私自添加路由器导致DHCP分发确认路由器IP,查到MAC,交换机...
  • H3C交换机巡检常用命令

    千次阅读 2019-04-17 13:38:43
    display version 查看版本信息,最近一次重新启动的时间 display enviroment 设备温度 display device 单板运行状态 display power 查看电源状况 display fan 查看风扇状况 display cpu-usage 查看cpu最近5S、1m...
  • [Quidway]description string ;指定VLAN描述字符 [Quidway]description ;删除VLAN描述字符 [Quidway]display vlan [vlan_id] ;查看VLAN设置 [Quidway]stp {enable|disable} ;...重新启动。 全部
  • H3C交换机常用巡检命令

    千次阅读 2020-05-21 11:45:34
    system-view #进入系统视图 user-interface vty 0 4 #vty就是用telnet/ssh远程进入交换机的界面(虚拟界面) ...display version #查看版本信息,最近一次重新启动的时间 display enviroment #设备温度 display 
  • 锐捷网络交换机的配置命令

    万次阅读 2018-07-08 09:50:15
    交换机 &gt;Enable 进入特权模式 #Exit 返回上一级操作模式 #End 返回到特权模式 #write memory 或copy running-config startup-config 保存配置文件 #del flash:config.text 删除配置文件(交换机及...
  • cisco 思科三层交换机配置命令

    千次阅读 2020-09-29 10:25:28
    1.交换机支持的命令 交换机基本状态: hostname> ;用户模式 hostname# ;特权模式 hostname(config)# ;全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式 ...
  • 我们在配置交换机的时候首先要了解的就是交换机命令模式,那么,网络交换机命令配置模式有哪些呢?接下来小编就来用飞畅科技系列交换机为例带大家了解下交换机的6种配置模式,感兴趣的朋友就一起来看看吧! 飞畅...
  • 交换机命令

    2021-06-29 07:54:17
    交换机命令,一种计算机语言,用来控制交换机的语言。中文名交换机命令外文名Switchboard CommandH3C Switch命令:一、模式命令:1. 用户模式:Switch>2. 特权模式:Switch>enableSwitch#3. 全局配置模式:...
  • 思科(Cisco)交换机路由器命令大全

    千次阅读 2021-06-20 20:06:16
    思科(Cisco)路由器常用命令总结 视图模式介绍 普通视图router> 特权视图router# / 在普通模式下输入enable 全局视图router(config)#/ 在特权模式下输入configt 接口视图router(config-if)#/在全局模式下输入int ...
  • H3C交换机常用命令大全

    万次阅读 多人点赞 2019-05-15 09:55:25
    [H3C]undo snmp-agent 禁止SNMP Agent的运行,若配置任何SNMP命令重新启动SNMP Agent [H3C]display snmp-agent community read [H3C]display snmp-agent sys-info contact [H3C]display snmp-agent sys-info ...
  • H3C交换机常用配置命令大全

    万次阅读 多人点赞 2018-09-12 13:51:33
    H3C交换机常用配置命令大全 一.用户配置: &lt;H3C&gt;system-view [H3C]super password H3C 设置用户分级密码 [H3C]undo super password 删除用户分级密码 [H3C]localuser bigheap 123456 1 Web...
  • 其实对网工来说,懂得交换机是啥,真的远远不够。NAT等等各大网络公司对网络工程师的必备要求就是:会配置主要型号的交换机和路由器,不熟悉的设备能够独立查资料配置。 然而,在学习这件事上,是没有捷径的。想要...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 23,548
精华内容 9,419
关键字:

交换机重新启动命令