精华内容
下载资源
问答
  • 三台JBoss(node1, node2, node3)组成的集群(其中node1为协调者),新节点node4加入集群,JBoss集群中所有节点状态要保持一致,这就需要node4从集群的协调者node1交换状态交换状态过程使用JGroups,本文通过实验...

    内容概要

    如下图


    三台JBoss(node1, node2, node3)组成的集群(其中node1为协调者),新节点node4加入集群,JBoss集群中所有节点状态要保持一致,这就需要node4从集群的协调者node1交换状态,交换状态过程使用JGroups,本文通过实验测试JBoss集群中新节点加入状态交换过程,以及群组通信的成员获取群组状态的过程,明白JBoss集群中新节点加入状态交换原理。测试群组通信状态交换的吞吐量等。我们分下面六个方面介绍:

    • 实验描述
    • 实验步骤说明
    • 实验示例代码
    • 明白状态交换的具体过程
    • 明白状态交换的性能
    • 明白状态交换可能发生的异常

    实验描述

    本实验集群中有两个成员: node1,node2,node1 为协调者(第一个启动)作为状态提供者,node2 作为状态变化请求者通过 Channel.getState() 发送状态交换请求给集群,集群协调者node1负责将集群状态交换给node2。

    实验步骤说明

    本实验步骤包括以下三步:

    1. 使用JBoss Cluster Framework Demo 介绍所示的方法,任意从SourceForge下载或编译生成DEMO_HOME,本测试的测试程序启动脚本位于DEMO_HOME/bin下

    2. 启动node1,node1将作为状态提供者,也是集群中两个节点的协调者,我们使用启动脚本启动时需要附件-provider,同时我们必须指定jGroups配置文件和节点的名字,我们使用DEMO_HOME/conf下config.xml为状态交换实现的jGroups配置文件,node1为节点名字,同样我们也可指定要交换状态的大小,具体使用如下参数启动:

    ./largestate.sh -size 10000000 -provider -name node1 -props config.xml
    • -size 10000000 表示我们进行状态交换的大小为10MB,即node2从node1得到10MB的状态
    • -provider 表示node1为状态提供者
    • -name node1 表示节点的名字为node1
    • -props config.xml 表示使用jGroups配置文件为config.xml
    注意,Windows操作系统使用largestate.bat。

    3. 启动node2,node2为状态交换的请求者,类似于启动状态提供者节点,我们必须指定jGroups配置文件和节点的名字,且配置文件与状态提供者指定的配置文件相同,名字与状态提供者不同,这里我们同样使用DEMO_HOME/conf下config.xml为状态交换实现的jGroups配置文件,node2为状态交换的请求者节点名字,交换状态的大小我们也可以通过启动参数指定,我们可以使用如下命令启动:

    ./largestate.sh -size 10000000 -name node2 -props config.xml
    • -size 10000000 表示我们进行状态交换的大小为10MB
    • -name node2 表示为状态交换的请求者的名字为node2
    • -props config.xml 表示使用jGroups配置文件为config.xml
    注意,Windows操作系统使用largestate.bat。

    实验示例代码

    https://github.com/kylinsoong/cluster/.../LargeState.java

    明白状态交换的具体过程

    使用实验步骤说明中的步骤进行实验操作,通过node1及node2输出的日志我们可以总结状态交换的具体过程如下图所示:


    如上图所示,状态交换一般可以分为以下四步:

    1. 状态提供者node1启动,等待状态交换请求者请求交换状态
    2. 状态请求者node2启动,在启动的过程中向状态提供者node1发送状态交换请求,代码层面是node2通道的getState()方法被调运(channel.getState(null,0))
    3. 状态提供者node1通过输出流将状态交换给状态请求者node2,代码层面是node1的getState(OutputStream ostream)方法被调运
    4. 状态请求者node2通过输入流接收状态提供者node1输出的状态,代码层面是node2的setState(InputStream istream)方法被调运

    明白状态交换的性能

    使用实验步骤说明中的步骤进行实验,使用-size指定状态交换的大小为100MB,状态交换完成后在状态请求者node2端会输出状态交换的总时间,如下为我测试中的输出:

    [2013-04-27 15:50:29,981] <-- received 100MB in 841ms

    如上日志输出说明交换100MB的状态数据花费了841毫秒。jGroups状态交换的性能与运行jGroups应用的物理机器的网络设备(网卡)有关。如果使用100MB每秒大小吞吐量的网卡设备,则理论上来说每秒可以交换100MB大小的状态,1分钟可以交换6GB左右的状态;如果使用1000MB每秒大小吞吐量的网卡设备,则理论上来说每秒可以交换1GB大小的状态,1分钟可以交换60GB作用的状态。我测试中使用的是百兆网卡,所以传输100MB耗费了841毫秒是正常的。在后面第四部分我们将介绍Infinispan数据网格,企业应用可以使用Infinispan数据网格做数据存储,试想如果我们使用千兆吞吐量的网卡,数据传输的性能上是相当可观的。另外在使用jGroups为底层通信的应用比如JBoss,如果怀疑集群网络交换不正常,可以使用本实验进行测试,如果测试结果与理论上的值差别很大,则很可能网络欢迎有问题。

    明白状态交换可能发生的异常

    JBoss集群具有高可用及容错的功能是因为JBoss集群底层使用jGroups进行状态复制。JBoss集群中如果某一节点发生异常,重启节点的过程中会进行状态交换,常见可能发生错误包括:状态提供者getState(OutputStream ostream)实现将状态以输出流的方式写出时出错;状态接收者setState(InputStream istream)实现以输入流的方式接收状态时出错。本实验也可以模拟这两种种情况,具体在启动状态提供者时附加-provider_fails启动参数,或在启动状态接收者时附加-requester_fails启动参数,如下所示:

    ./largestate.sh -size 100000000 -provider -name node1 -props config.xml -provider_fails
     ./largestate.sh -size 100000000 -name node2 -props config.xml -requester_fails

    可能出现的错误如下:

    org.jgroups.StateTransferException: state transfer failed
    	at org.jgroups.JChannel.getState(JChannel.java:584)
    	at org.jgroups.JChannel.getState(JChannel.java:512)
    展开全文
  • CCNP知识点总结——交换部分

    千次阅读 多人点赞 2018-03-30 23:59:03
    CCNP交换部分学习笔记。

    1、交换机
    交换机工作在OSI的数据链路层, 可分为2层和多层交换机。按照网络位置可划分为接入层、分布层、核心层交换机。其重要参数有:背板带宽、接口速率、转发速率。

    2、VLAN技术
    VLAN是一个单独的广播域。交换机的一个端口只能承载单个VLAN的流量, Trunk技术可承载多个VLAN的流量。

    配置VLAN
    (1)创建VLAN:Switch(config)#vlan vlan-id
    (2)(可选)命名VLAN:Switch(config-vlan)#name vlan-name
    (3) 删除VLAN:Switch(config)#no vlan vlan-id
    (4)将端口指定为access端口,将端口放入某个VLAN中:
    Switch(config)#interface interface_id
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan vlan-id
    (5)验证VLAN:
    show vlan
    show running-config interface interface-type slot/port
    show mac-address-table interface interface-type slot/port

    3、Trunk技术
    (1)Trunk简介
    要使得交换机的端口承载多个VLAN,那么就必须将其配置为Trunk。使用环境:可以是两个交换机,也可以是交换机和路由器相连,还可以是交换机和支持trunk封装的主机。


    (2)DTP技术
    DTP是Cisco私有点到点协议,使用DTP来协商链路聚集的状态。
    作用:<1>协商使用哪种协议: ISL/802.1Q;<2>协商使用哪种模式: access、 trunk、 desirable、 auto。


    (3)Trunk的配置
    Switch(config)#interface interface_id Switch(config)#switchport trunk encapsulation {isl|dot1q|negotiate} Switch(config)#switchport mode {trunk|auto|desirable} Switch(config)#switchport nonegotiate Switch(config)#switchport trunk native vlan vlan-id Switch(config)#switchport trunk allowed vlan {add|except |all|remove} vlan-id[,vlan-id,vlan-id…]
    (4)Trunk的验证
    show running-config interface_id show interface interface_id switchport show interface interface_id trunk

    4、VTP技术
    (1)VTP协议的作用是在整个交换网络中分发和同步与VLAN的相关信息。

    (2)VTP通过Trunk链路传播消息,Cisco交换机每5分钟就会通过管理VLAN以二层组播(组播地址: 01-00-0C-CC-CC-CC)数据帧的形式传输一次VTP汇总通告。每台交换机只能支持单个VTP域。
    (3)VTP工作模式
    <1>Server:可创建、修改和删除VLAN,发送或转发通告消息,同步VLAN配置,将VLAN配置保存在NVRAM中。
    <2>Client:不能创建、更改和删除VLAN,转发通告,同步VLAN配置,不会将VLAN配置保存在NVRAM中。
    <3>Transparent:只在本地交换机中创建、删除和修改VLAN,转发通告消息,不同步VLAN配置,将VLAN配置保存在NVRAM中。


    (4)VTP版本
    VTP版本1:不支持令牌环网,透明模式检测版本和域名;
    VTP版本2:支持令牌环网,支持TLV,透明模式不检测版本;
    VTP版本3:支持扩展VLAN,支持创建和通告pVLAN,增强服务器认证,能与版本1和版本2互动,能够基于端口来配置VTP。
    (5)VTP消息类型
    <1>汇总通告消息:用于通知邻接的交换机目前的VTP域名和配置修订编号。每5分钟发送一次汇总通告消息,配置改变的时候发送通告。交换机对比数据包中的VTP域名,域名不同则忽略这个数据包。VTP域名相同将对比修订号:修订号大于等于通告消息中的修订号,忽略这个数据包;修订号小于通告消息中的修订号,发送通告请求消息。
    <2>子集通告消息:包含VLAN的详细信息。交换机上添加、删除或修改VLAN时,增加配置修订号,发送汇总通告,随后发送一条或多条子集通告消息。子集通告消息包含一个VLAN信息的列表。多个VLAN,发送多条子集通告消息。
    <3>通告请求消息:需要发送VTP通告请求消息:交换机重启、 VTP域名被修改、交换机收到修订号较大的VTP汇总通告消息。收到通告请求消息后, VTP设备发送一条汇总通告消息,再发送一条或多条子集通告消息。
    (6)VTP配置
    Switch(config)#vtp mode server Switch(config)#vtp domain domain_name Switch(config)#vtp version 2 Switch(config)#vtp password password_string
    (7)VTP验证
    show vtp status show vtp counters show vtp password

    5、VLAN间路由
    (1)提供VLAN间路由选择功能的设备:三层交换机、路由器。
    路由器:单臂路由;多层交换机:路由端口或SVI交换机虚拟接口。
    (2)使用路由器实现VLAN间路由
    注意点:<1>交换机和路由器之间链路为trunk;<2>路由器的物理链路至少应该是FastEthernet或者更快的链路。

    单臂路由配置:
    Router(config)#interface fastethernet0/0 Router(config-if)#no shutdown Router(config)#interface fastethernet0/0.1 Router(config-subif)#description VLAN1 Router(config-subif)#encapsulation dot1q 1 native Router(config-subif)#ip address 10.1.1.1 255.255.255.0 Router(config-subif)#interface fastethernet0/0.2 Router(config-subif)#description VLAN2 Router(config-subif)#encapsulation dot1Q 2 Router(config-subif)#ip address 10.2.2.1 255.255.255.0 Router(config-subif)#exit

    switch(config)#interface fastethernet 4/2 switch(config)#switchport trunk encapsulation dot1q switch(config)#switchport mode trunk switch(config)#end
    (3)SVI接口实现VLAN间路由

    SVI接口配置:
    switch(config)#ip routing switch(config)# interface vlan 10 switch(config-if)#ip address 10.1.10.1 255.255.255.0 switch(config-if)#no shutdown switch(config)# interface vlan 20 switch(config-if)#ip address 10.1.20.1 255.255.255.0 switch(config-if)#no shutdown
    使用SVI接口实现VLAN间路由,默认情况下, SVI接口满足下列条件,那么该接口处于Up状态:
    <1>存在这个VLAN;
    <2>存在这个VLAN接口,并且状态不是管理性关闭;
    <3>交换机上至少一个二层端口,这个VLAN至少有一条链路处于启用状态。
    (4)在多层交换机上配置路由端口
    Catalyst 3550和4500系列交换机默认都是用二层接口,Catalyst 6500系列交换机默认使用三层接口。
    配置:
    switch(config)#interface gigabitethernet1/1 switch(config)# no switchport switch(config-if)#ip address 10.10.1.1 255.255.255.0 switch(config-if)#no shutdown
    (5)VLAN间路由验证
    show ip interface interface_type_port | svi_number show interface interface_type_port | svi_number show running interface_type_port | svi_number show vlan show interface trunk ping

    6、交换机的管理地址

    限制远程管理源地址
    switch(config)# access-list 99 permit host 192.168.1.100 switch(config)# line vty 0 4 switch(config-line)# access-class 99 in

    7、802.1Q Tunneling(QinQ)



    8、生成树协议
    (1)二层转发特征:<1>转发时不用修改数据帧中的信息,<2>MAC地址学习是基于源地址的学习方式,<3>转发广播帧,<4>泛洪未知单播帧,<5>直接转发已知单播帧。
    (2)STP作用:<1>逻辑上打破二层环路,<2>保持冗余链路。
    (3)STP步骤:<1>在一个广播域中选一个根桥,<2>选择所有非根桥的根端口,<3>选择各个网段的指定端口,<4>阻塞所有非指定端口。
    <1>根桥的选举:BPDU每2S发送一次,Bridge ID=Bridge Priority + MAC address,选择最小的Bridge ID。
    有两种类型的BPDU:Config BPDU和TCN BPDU。

    根桥的选举配置:配置交换机成为根桥,宏命令 ------衍生出来具体配置。
    Switch(config)#spanning-tree vlan 1 root primary
    配置交换机成为备份根桥
    Switch(config)#spanning-tree vlan 1 root secondary
    配置交换机的优先级
    Switch(config)#spanning-tree vlan 1 priority priority
    配置交换机的端口优先级(0-255,默认为128)
    Switch(config-if)#spanning-tree vlan 2 port-priority 1
    <2>选择所有非根桥的根端口,即离根最近的接口,考虑:1)到达根桥开销最低的接口,2)BID最小的端口,3)Port ID最小的端口。

    <3>选择各个网段的指定端口,在所有链路上选举一个离根最近的接口,考虑:1)到达根桥开销最低的接口,2)BID最小的端口,3)Port ID最小的端口。
    <4>未指定的端口为非指定端口。


    (4)802.1D STP Topology Change使用TCN BPDU,有3种情况会发送TCN BPDU
    <1>从Forwarding或Listening的端口过渡到Blocking;
    <2>端口进入到Forwarding,并且网桥已经有DP端口;
    <3>非根网桥在他的DP端口接收到TCN。


    9、快速生成树协议(802.1W RSTP)
    (1)802.1D STP能够在大约1分钟之内恢复连接,而802.1W STP能够快速的收敛。
    原理:RSTP会选择一台交换机作为连接到活动拓扑的生成树的根,并为交换机上的不同端口分配端口角色,在出现故障之后,交换机之间实施明确的握手协议,完成快速的收敛。


    (2)配置边缘端口使用spanning-tree portfast命令。
    (3)RSTP拓扑变更机制原理
    <1>根网桥知道网络拓扑发生变更时,设置BPDU的TC标志;
    <2>此BPDU传输给网络中的所有网桥;
    <3>网桥接收到TC置位的BPDU后,将桥接表的老化时间 300s降低到转发延迟的秒数15s。
    只有当非边缘端口从阻塞状态到转发状态的时候才会导致拓扑变更.与802.1D不同,连接丢失并不会产生拓扑的变更。 换句话说, 如果某个状态进入阻塞状态将不会导致相应的网桥产生TC BPDU。
    (4)Cisco Catalyst交换机支持下列3类生成树:PVST+,RPVST+,MST,默认交换机为PVST+。
    RPVST+为每个VLAN运行一个独立的生成树实例,需要通过BID字段来承载VLAN ID信息,使用扩展系统ID。
    (5)RPVST+生成树的配置和验证
    <1>配置模式:
    Switch(config)# spanning-tree mode rapid-pvst
    指定root / secondary root
    Switch(config)#spanning-tree vlan 1 root primary
    Switch(config)#spanning-tree vlan 1 root secondary
    指定交换机的优先级:
    Switch(config)#spanning-tree vlan 1 priority priority
    查看:
    show spanning-tree vlan vlan-id
    10、多生成树

    MST区域
    MST区域是指一组相互连接,并且具有相同MST配置的网桥,VLAN到MST的分组必须在同一个MST区域的所有网桥中保持一致。拥有不同MST配置的网桥或运行802.1D协议的传统网桥则可以看做位于不同的MST区域中。
    MST的配置中包括如下属性
    <1>包含数字和字母的配置名称;<2>配置修订号;<3>VLAN映射表。

    MST的配置
    <1>指定模式:Switch(config)#spanning-tree mode mst
    <2>配置参数:
    Switch(config)#spanning-tree mst configuration Switch(config-mst)#name name Switch(config-mst)#revision rev_num Switch(config-mst)#instance inst vlan range
    <3>配置MST的primary 和 secondary roots:
    Switch(config)#spanning-tree mst instance_number root primary|secondary
    <4>MST验证:
    show spanning-tree mst instance_number detail show spanning-tree mst configuration
    11、生成树特性
    (1)PortFast

    配置:
    Switch(config-if)#spanning-tree portfast
    全局启用:
    Switch(config)#spanning-tree portfast default
    接口禁用:
    Switch(config-if)#no spanning-tree portfast
    (2)UplinkFast
    用于检测直连故障,使接口状态从Blocking到Forwarding<=5S,激活UplinkFast的条件:<1>交换机启用UplinkFast 功能;<2>交换机上至少有一个端口处于Blocking状态(即有冗余链路);<3>链路失效发生在根端口上。
    启用了UplinkFast的交换机:
    <1>默认priority由32768改变到49152;<2>默认cost增加3000;<3>非默认的priority与cost不变。
    配置:Switch(config)#spanning-tree uplinkfast
    (3)BackboneFast

    (4)BPDU Guard
    能够限制在启用PortFast端口接收BPDU。防止交换机连接到PortFast端口。
    特征:一旦收到BPDU,接口进入到err-disabled状态, err-disabled状态的接口必须手动启用。
    全局配置:Switch(config)#spanning-tree portfast bpduguard default
    或接口配置:Switch(config-if)#spanning-tree bpduguard enable
    全局下配置,只影响portfast特性开启的接口。
    (5)BPDU Filter
    能够限制在启用PortFast端口发送和接收BPDU。
    全局启用:当端口接收到BPDU时,不再处于PortFast状态,过滤特性也会被禁用。
    Switch(config)#spanning-tree portfast bpdufilter default
    接口启用:不发送也不接收任何BPDU数据包,收到BPDU则丢弃。
    Switch(config-if)#spanning-tree bpdufilter enable
    BPDU Filter优先级>BPDU Guard优先级,若同时启用两者,则BPDU Filter生效
    查看:
    show spanning-tree summary show spanning-tree interface interface-id detail
    (6)Root Guard
    启用根防护的端口不能成为根端口,将成为指定端口,当该端口接收到更好的BPDU时,根防护特性就会使接口进入root-inconsistent的阻塞状态。
    root-inconsistent状态等效于监听状态。当root-inconsistent端口不在接收到更优
    的BPDU时,它会自动恢复。
    配置
    Switch(config-if)#spanning-tree guard root
    查看
    show running-config interface interfac-id show spanning-tree inconsistentports
    (7)LOOP Guard

    loop-inconsistent状态的端口重新接收到了BPDU,根据接收到的BPDU过渡到STP状态,为自动恢复过程。
    配置:
    Switch(config-if)#spanning-tree guard loop Switch(config)#spanning-tree loopguard default
    查看:
    show spanning-tree interface interface-id detail
    (8) UDLD
    UDLD能够检测并禁用单向链路,是一个二层协议,与一层机制协同工作,启用UDLD后,交换机会定期向邻居发送UDLD协议包,并要求定期收到回应,否则判断为单向链路,并且关闭该端口,数据包中包含设备ID,端口ID,邻居设备ID和端口ID信息。模式分为:Normal mode和Aggressive mode。
    <1>Normal mode: 只能检测光口,未接收到UDLD消息时,端口状态为
    undetermined状态产生系统日志,但并不影响流量转发。
    Switch(config)# udld enable Switch(config-if)# udld port
    <2>Aggressive mode: 检测光口和电口,未接收到UDLD消息时,就会与邻居重新建立连接关系,连续尝试了8次都失败后,端口就会成为err-disable状态。
    Switch(config)# udld aggressive Switch(config-if)# udld port aggressive
    (9)Flex
    Flex链路是一种二层的可用性特性,是STP的一种替代解决方案。在关闭了STP的情况下,仍然可以实现基本的链路冗余。可让收敛时间降低到50毫秒以下。

    Flex链路定义了一对主用/备用链路,Flex链路是一对接口,可以是switchport接口、 port-channel接口。主用链路和备用链路的类型(fast ethernet/gigabit ethernet/ portchannel)不强求一致。Flex链路端口上禁用STP,所以STP没有启用时,要确保配置拓扑中没有环路,接口只属于一个Flex链路。
    配置:
    Switch(config-if)# switchport backup interface interface-id
    配置一例:
    Switch(config)# interface f0/1 Switch(config-if)# switchport backup interface f0/2
    查看
    show interface switchport backup
    12、高可用性
    (1)EtherChannel
    为了适应园区网业务的发展、速率的提高,我们可以采用多种方式提高园区网络中的数据传输速度。
    <1>使用端口速率更快的端口,如1Gbit/s或10Gbit/s。
    <2>增加两边交换机上物理链路的数量。
    <3>EtherChannel:EtherChannel是将多个快速以太网端口或吉比特以太网端口分组到一个逻辑通道中。
    PAgP:思科私有协议。


    LACP:IEEE 802.3ad标准协议。


    注意事项:
    可以最多将8条物理链路捆绑为一条逻辑的EtherChannel链路,同一条EtherChannel链路不能向不同的交换机发送流量,一条EtherChannel连接的两台设备配置必须相同,管理员配置EtherChannel接口时,同时影响所有分配了该接口的端口,同一个EtherChannel的所有接口要配置相同的速率和双工模式,EtherChannel的接口配置允许相同的VLAN,EtherChannel不能作为SPAN中的目的端口,IP地址配置在port-channel端口上。
    二层EtherChannel配置:
    Switch(config)#interface range interface slot/port - port Switch(config-if-range)#channel-protocol {pagp | lacp} Switch(config-if-range)#channel-group number mode {active | passive | on | desirable | auto}
    三层EtherChannel配置:
    Switch(config)# interface range interface slot/port - port Switch(config-if)#no switchport Switch(config-if)# channel-group number mode {active | passive | on | desirable | auto} Switch(config)#interface port-channel port-channel-number Switch(config-if)#no switchport Switch(config-if)#ip address address mask
    查看
    show running-config interface port-channel num Switch#show running-config interface interface x/y
    负载分担:
    Switch# show etherchannel load-balance Switch(config)#port-channel load-balance type
    负载分担类型:
    • src-mac • dst-mac • src-dst-mac • src-ip • dst-ip • src-dst-ip • src-port • dst-port
    (2)设备冗余——Supervisor Engine
    Supervisor Engine:提供多层交换数据的处理转发
    Catalyst 4500只能在4057R-E和4510R-E机箱中部署
    Catalyst 6500系列交换机可以在所有型号的机箱中部署

    Supervisor Engine支持下列冗余特性
    <1>RPR(路由处理器冗余性)和RPR+(仅用于Catalyst6500)
    <2>SSO(状态化故障倒换)
    <3>NSF(不间断转发)结合SSO
    (3)设备冗余——Power Supplies
    Power Supplies两种模式:主备供电和同时供电。
    Power Supplies配置:Switch(config)#power redundancy-mode combined | redundant
    查看:show power
    Switch(config)# No power enable module 5 -> 模块关电 Switch(config)# Power cycle module 5 -> 模块加电
    (4)设备冗余——Fans&Hot-swappable
    (5)设备冗余——StackWise Switches
    Catalyst 3750支持堆叠,最高支持9个3750,独立的堆叠端口,专用互连电缆,自动配置和IOS版本检测,采用背板堆叠方式,优点:高密度端口,便于管理。
    堆叠要求:相同的IOS版本(推荐加密版本),最多9台交换机做堆叠,通过1个地址管理堆叠。
    物理连接:物理连接好堆叠线缆,连接方法为Master的Stack1连接到Slave的Stack2上面。先开Master,等完全启动后再开Slave。不作任何的配置。
    以三个交换机堆叠为例:
    交换机1: ws-c3750g-12s,交换机2: ws-c3750g-24ts,交换机3: ws-c3750g-48ts。
    交换机1做为主交换,配置如下:
    Switch(config)# switch 1 provision ws-c3750g-12s Switch(config)# switch 1 priority 15 Switch(config)# switch 2 provision ws-c3750g-24ts Switch(config)# switch 2 priority 14 Switch(config)# switch 3 provision ws-c3750g-48ts Switch(config)# switch 3 priority 13 Switch(config)# sdm prefer desktop Switch(config)# copy running-config startup-config
    (6)虚拟交换系统——Virtual Switching System
    虚拟交换系统将两台交换机虚拟组合成单一交换机,中间采用虚拟交换链路( VSL) 互连,对外来看只有一台交换机,管理冗余链路如同管理一个单一接口。互连交换机通过链路聚合链接到VSS的两台交换机。VSS利用MEC技术在捆绑的逻辑端口上实现冗余和负载均衡。使得下游交换机好像与一台交换机进行互联。VSS和下联交换机之间形成了一个无环的二层网络结构,不再需要生成树协议,也减少了3层路由邻居,简化了网络的配置和操作。

    开启VSS时,两台VSS成员设备通过相互协商,一个成为Active状态,另一个成为Standby状态。Active状态设备用于控制整个VSS, Standby状态设备将控制流量通过VSL交由Active统一处理。两台设备同时转发数据层面流量。VSL是一条特殊的链路,用于VSS系统中的两台设备间传输控制流量和数据流量。VSL最多支持八条10GE捆绑,利用Etherchannel技术实现负载和冗余。其中的控制流量优先级高于数据流量。Standby设备使用VSL监控Active设备,检测到Active故障时, Standby设备将把自己转换成Active状态。
    配置:
    Switch1: Switch1(config)# switch virtual domain 100 // 指定交换机1为VSS100区域内的设备 Switch1(config-vs-domain)# switch 1 // 指定VSS区域内该交换机的ID Switch2: Switch2(config)# switch virtual domain 100 // 指定交换机2为VSS100区域内的设备 Switch2(config-vs-domain)# switch 2 // 指定VSS区域内该交换机的ID Switch1/2: Switch(config)# interface port-channel 10 // 启动逻辑接口 Switch(config-if)# switch virtual link 1 // 配置交换ID1使用该逻辑接口 Switch(config)# interface range tenGigabitEthernet 1/1-2 // 进入需要加入逻辑接口的物理接口 Switch(config-if)# channel-group 10 mode on // 物理接口绑定逻辑接口 Switch# platform hardware vsl pfc mode pfc3c // 将PFC模式转换成PFC3C(可选) Switch# switch convert mode virtual // 转换交换模式为虚拟交换
    13、FHRP首跳冗余性协议
    链路冗余技术有:EtherChannel、STP、FHRP(首跳冗余性协议):HSRP/VRRP/GLBP
    (1)FHRP首跳冗余协议,提供了默认网关的冗余性,主要方法是让一台路由器充当活跃的网关路由器,而另一台或多台其他路由器则处于备用模式。FHRP包括 HSRP/VRRP/GLBP,网关的识别要达成一致。虚拟的IP地址。
    (2)HSRP(Host Standby Route Protocol)
    HSRP是Cisco私有,该协议定义了一组路由器,这组路由器共享IP地址和MAC地址,模拟出一台虚拟的路由器。

    HSRP组路由器角色:一台active路由器,一台standby路由器,一台virtual路由器和其他路由器。active和standby向组播地址224.0.0.2 UDP 1985端口发送Hello消息。
    <1> active路由器:转发所有发送到虚拟路由器MAC地址的数据包,使用以虚拟路由器MAC地址回应ARP请求。
    <2>standby路由器:监听周期性Hello消息,当active路由器发生故障后,取代active路由器的角色。不响应ARP请求。Hello时间=3s,Hold时间=10s。
    HSRP状态:
    <1>Initial:路由器还未运行HSRP,路由器配置发生变化或接口刚进入UP状态。
    <2>Listen:该路由器知道虚拟IP地址,当不是active和standby路由器,监听那些路由器发出的Hello消息。
    <3>Speak:该路由器周期性发送Hello消息,并且积极参与到活跃路由器或备用路由器的选举中,知道虚拟IP地址。
    <4>Standby:该路由器为下一个活跃路由器的候选者,周期性发送Hello消息,只有一台处于standby状态。
    <5>Active:该路由器负责转发所有发送到组虚拟MAC地址的数据包,周期性发送Hello消息,只有一台处于active状态。

    HSRP配置:
    启用HSRP,并指定虚拟IP:
    Switch(config-if)#standby group-number ip ip-address
    禁用HSRP:
    Switch(config-if)#no standby group-number ip ip-address
    HSRP理论最多支持255个组,实际只支持16个。
    配置优先级和抢占:
    Switch(config-if)#standby group-number priority priority-value Switch(config-if)#standby group-number preempt {delay}[minimum]
    优先级范围0~255,默认值为100,优先级高的路由器成为active路由器,优先级相同时, IP地址大的路由器成为active路由器。
    配置HSRP认证:
    Switch(config-if)#standby group-number authentication password
    配置HSRP接口追踪:
    接口追踪能够使备用组路由器根据某个路由器接口的可用性状态,来自动调节优先级。
    Switch(config-if)#standby group-number track interface-type interface-number [interface-priority]
    interface-priority 当接口失效后,优先级减少量,当接口恢复后,优先级增加量,默认值为10。
    配置HSRP对象追踪:
    Switch(config-if)#standby group-number track track-group decrement priority Switch(config)#track track-group ? interface ip list rtr
    简单配置:
    Standby 1 ip 192.168.1.1(配置虚拟IP) Standby 1 priority 150(越高越好,默认为100) Standby 1 preemt(抢占,默认没有) Standby 1 track f0/1 60(跟踪上行端口,优先级减少60)
    查看验证:
    show standby show standby brief debug standby [errors] [events] [packets]

    (3)VRRP
    利用VRRP(虚拟路由器冗余协议)一组路由器协同工作,但只有一个处于激活
    状态。在一个VRRP组内的多个路由器共用一个虚拟的IP地址,该地址被作为局域网内所有主机的缺省网关地址。 VRRP协议决定哪个路由器被激活,该被激活的路由器负责接收发过来的数据包并进行路由。
    VRRP名词
    <1>VRRP路由器
    运行VRRP协议的路由器,一台VRRP路由器可以同时参与到多个VRRP组中,在不同的组中,一台VRRP路由器可以充当不同的角色。
    <2>VRRP组(VRID)
    由多个VRRP路由器组成,属于同一VRRP组的VRRP路由器互相交换信息,每一组由一个VRID标识。
    <3>虚拟路由器
    对于每一个VRRP组,抽象出来的一个逻辑路由器,该路由器充当网络用户的网关。
    <4>虚拟IP地址、 MAC地址
    用于标示虚拟的路由器,该地址实际上就是用户的默认网关,MAC地址为虚拟的。
    <5>MASTER、 BACKUP 路由器
    MASTER 路由器:就是在 VRRP 组实际转发数据包的路由器,在每一个VRRP组中,仅有MASTER响应对虚拟IP地址的ARP请求。
    BACKUP 路由器:就是在 VRRP 组中处于监听状态的路由器,一旦MASTER 路由器出现故障, BACKUP 路由器就开始接替工作。
    只有处于活动状态的设备才可以转发那些发送到虚拟IP地址的报文。
    VRRP的三个状态
    <1>初始状态(Initialize):路由器刚刚启动时进入此状态,通过VRRP报文交换数据后进入其他状态。
    <2>活动状态(Master): VRRP组中的路由器通过VRRP报文交换后确定的当前转发数据包的一种状态。
    <3>备份状态(Backup): VRRP组中的路由器通过VRRP报文交换后确定的处于监听的一种状态。
    VRRP报文
    VRRP路由器之间使用组播进行消息传输,VRRP报文使用的IP组播地址是224.0.0.18。VRRP报文承载在IP报文之上,使用协议号112 。
    定时器Timers:
    <1>Advertisement Interval:
    由主路由器按照Advertisement Interval定义的时间间隔来发送 VRRP 通告报文,默认为1s。在备份路由器上可以手动配置,但必须与主路由器相同,也可以从主路由器学习到这个时间间隔。
    <2>Master_Down Timer:
    Backup 路由器认为Master路由器down机的时间间隔。默认情况下等于:3*hello+skew time,(skew time=((256-pri)/256) ms)这个时间是确保优先级更好的备份路由器成为新的master路由器。

    Preempt 抢占模式:
    抢占模式主要应用于保证高优先级的路由器在接入网络时成为活动路由器。如果抢占模式关闭,高优先级的备份路由器不会主动成为活动路由器,即使活动路由器优先级较低,只有当活动路由器失效时,备份路由器才会成为主路由器。默认情况下,VRRP抢占模式都是开启的。(HSRP默认不开启抢占)
    Track:
    监视某个接口,并根据所监视接口的状态动态地调整本路由器的优先级。
    VRRP配置:
    配置R1:
    R1(config)#interface F1/0 R1(config-if)#ip address 192.168.1.253 255.255.255.0 R1(config-if)#vrrp 1 ip 192.168.1.254 R1(config-if)#vrrp 1 priority 105 //默认时的PRIORITY为100, 1-254 R1(config-if)#vrrp 1 preempt R1(config-if)#vrrp 1 track fa1/0
    配置R2:
    R2(config)#interface F1/0 R2(config-if)#ip address 192.168.1.252 255.255.255.0 R2(config-if)#vrrp 1 ip 192.168.1.254 R2(config-if)#vrrp 1 preempt R2(config-if)#vrrp 1 track fa1/0

    (4)GLBP
    HSRP和VRRP能够实现网关的快速复原,但对于冗余性组中的备用成员来说,处于备用模式时,是无法使用上行链路带宽的。
    GLBP是Cisco私有的解决方案,可在多台网关之间进行自动故障倒换,可同时使用多台可用网关。
    GLBP功能:
    <1>GLBP AVG(活跃虚拟网关):一个GLBP组中只有一台为AVG,其他的为AVG的备用网关, AVG的作用是为GLBP组中的每个成员分配一个虚拟MAC地址。
    <2>GLBP AVF(活跃虚拟转发者):一个GLBP组中的所有路由器都为AVF,负责转发到该虚拟MAC地址的数据包。
    <3>GLBP 通信: GLBP每3s向组播地址224.0.0.102 UDP 3222端口发送Hello数据包。
    GLBP特性:负载分担、多虚拟路由器、抢占、有效的资源利用。
    GLBP配置:


    14、高级特性
    (1)DHCP
    DHCP流程:

    DHCP配置:
    Router(config)#ip dhcp pool [pool name]
    • Enables a DHCP pool for use by hosts
    Router(config-dhcp)#default-router [host address]
    • Specifies the default router for the pool to use 默认网关
    Router(config-dhcp)#network [network address][subnet mask]
    • Specifies the network and subnet mask of the pool
    Router(config-dhcp)#dns-server [DNS address]
    • Specifies the DNS Server for the pool to use
    Router #show ip dhcp binding Router (config-if)# ip address dhcp
    Enables a Cisco IOS device to obtain an IP address dynamically from a DHCP server
    IP Helper:
    Router(config-if)# ip helper-address address
    Changes destination address from broadcast to unicast or directed broadcast address
    Router(config)# ip forward-protocol { udp [ port ] }

    DHCP验证:
    router# show ip dhcp database
    • Displays recent activity on the DHCP database
    router# show ip dhcp server statistics
    • Shows count information about statistics and messages sent and received
    router# debug ip dhcp server {events | packets | linkage}
    • Enables debugging on the DHCP server
    (2)Syslog
    思科设备会产生系统日志或系统记录消息,这些消息能够输出到设备控制台, VTY连接,系统缓冲区,远程日志服务器。如果发送到syslog服务器,消息被发送在UDP端口514。
    你可能熟悉syslog消息:
    %SYS-5-CONFIG_I: Configured from console by console;
    系统日志格式:
    %FACILTY-SUBFACILITY-SEVERITY-MNEMONIC: message text %SYS-5-CONFIG_I: Configured from console by console;
    说明:

    • FACILITY-SUBFACILITY:
      描述哪个协议、模块或者进程产生的信息, 如SYS—系统进程
    • SEVERITY: 设备上的事件级别分为0到7总共8个级别
      0 Emergency 紧急 、 1 Alert: 警报 、 2 Critical: 批判 、 3 Error: 错误、
      4 Warning: 警告、 5 notifications:通知、 6 Informational:信息 、
      7 Debugging:调试
    • MNEMONIC: A code that identifies the action reported;
    • A plain-text: 描述产生日志信息的事件内容

    (3)SNMP 简单网络管理协议
    SNMP Simple Network Management Protocol:简单网络管理协议。
    应用于管理软件与设备之间交流的协议。由一组网络管理的标准组成,该协议能够支持网络管理系统,用以监测连接到网络上的设备是否有任何引起管理上关注的情况。
    SNMP定义为应用层协议,因而它依赖于UDP数据报服务。
    SNMP管理的网络由下列三个关键组件组成:
    <1>网络管理系统(NMS, Network-management systems):安装了管理软件的主机。
    <2>被管理的设备(managed device)
    <3>代理者(agent):在配置SNMP时,配置了SNMP的网络设备。
    SNMP代理将自己的状态信息发送给SNMP管理,SNMP将其整理后,通过图形界面汇报给用户,并且SNMP管理上的相关软件被称为NMS(网络管理系统)。
    在SNMP代理与SNMP管理之间,SNMP代理使用UDP 162(Trap报文),SNMP管理使用UDP 161。
    网络管理系统从代理收集网络设备信息的方式: 定期轮询、 Trap报文。

    MIB: Management Information Base:管理信息库,存储在本地设备的信息,SNMP代理的所有硬件信息和软件信息,就全部存储在MIB里面。
    Cisco设备MIB库下载地址:
    http://tools.cisco.com/ITDIT/MIBS/MainServlet
    SNMP版本分为: V1、 V2、 V3
    SNMPv1在SNMP代理与SNMP管理之间提供的安全机制是使用密码的方式,只有拥有相应密码的NMS,才能够对SNMP代理进行操作。这种密码也分了级别,可以分别定义相应密码是否具有读权限或者是否同时具有读和写的权限。这样的密码被称为community。版本1不仅提供密码认证的方式。利用ACL的方式来限制只有某些主机能够对其进行访问。
    V1和V2版本以明文的形式发送共同体认证,不能验证消息的来源或加密消息,因此只能用于只读访问。SNMPv3增加了三个安全级别: noAuthNoPriv:不验证也不加密,authNoPriv:验证发送方但不加密消息, authPriv:验证发送方和加密消息。
    为保证网络管理信息的安全,代理必须对多个管理站进行本地MIB的访问控制。SNMP用 Community 来定义一个Agent和一组Manager间的认证、访问控制和代管关系,提供初步的安全能力。

    SNMPv1局限性:
    1)基本的SNMPv1标准只提供简单的团体名认证机制。因此大多数厂商仅仅提供有限的或者索性不支持Set操作。基本的SNMPv1更适合于对网络进行监视而不是控制。
    2)SNMPv1的Trap报文是没有没有应答的,管理站是否收到陷入报文,代理不得而知。这样可能丢掉重要的管理信息。
    3)SNMP不适合检索大量数据,例如检索整个表中的数据。
    4)SNMP的管理信息库MIB-2支持的管理对象是很有限的,不足以完成复杂的管理功能。
    5)SNMP不支持管理站之间的通信。对于大型网络管理,SNMPv1的查询机制可能导致大量的管理信息,占用过多的网络资源。

    SNMPv2:
    SNMPv2既可以支持完全集中的网络管理,又可以支持分布式网络管理。
    在分布式情况下,有些系统既是管理站又是代理。
    作为代理系统,它可以接受上级管理系统的查询命令,提供本地存储的管理信息;
    作为管理站它也可以要求下级代理系统提供有关被管理设备的汇总信息。
    此外,中间管理系统可以向它的上级系统发出陷入报告。
    SNMPv2的增强主要在以下3方面:
    管理信息结构的扩充。
    管理站和管理站之间的通讯能力。
    新的协议操作。
    SNMPv1的响应是原子性的,即只要有一个变量的值检索不到,就不返回任何值。而SNMPv2的响应不是原子性的,允许部分响应。
    SNMPv2c:
    SNMPv2c的认证方式和SNMPv1是一样的。
    SNMPv2c没有达到商业级别的要求:
    1)提供数据源标识
    2)报文完整性认证
    3)防止重放
    4)报文机密性
    5)授权和访问控制

    Inform:管理站发送给管理站的消息。
    SNMPv3:
    SNMPv3针对SNMPv2的最大改进主要在安全性和管理能力两个方面。
    SNMPv3提供的认证方式是使用用户名和密码的方式,并且密码可以是MD5加密的。
    SNMP报文将使用DES加密来避免信息泄漏。
    SNMP管理端与SNMP Agent通讯时必须要通过认证来保证身份的正确性、信息的完整性。
    SNMPv3增加了三个安全级别:
    1)noAuthNoPriv:不验证也不加密
    2)authNoPriv:验证发送方但不加密消息
    3)authPriv:验证发送方和加密消息
    Trap:
    当设备上发生了各种事件之后,产生的MIB信息由SNMP代理主动向NMS发送。
    NMS即使收到了,也不需要向SNMP代理发送确认消息 。而Trap自己发送完毕之后,这些MIB信息会马上删除,不会驻留在内存里面。
    Informs:
    当设备发生事件后,这些信息并不会主动向NMS通告,除非NMS发送request来查询,然后才会发出去,已经发出去的informs在发送之后是会保留在内存里面的。
    当NMS收到informs之后必须向SNMP代理发送确认消息,如果不发送确认消息,SNMP代理会重复多次发送informs。从上可以看出informs具有可靠性。
    轮询:
    SNMP 管理定期轮询SNMP代理的MIB数据库。
    Get:查询设备信息,发送的数据包被称为get。
    Set:更改设备的配置,被称为set。
    SNMP 配置:
    //Set SNMP administrator contact
    snmp-server contact snmp@spoto.net
    //Read-only access with this community string
    snmp-server community SPOTO RO
    //Read-write access with this community string
    snmp-server community SPOTO RW
    //Use IETF standard for SNMP traps
    snmp-server trap link ietf
    //Set SNMP Trap Server IP and community string
    snmp-server host IP SPOTO snmp-server enable traps

    ip access-list standard NMS
      permit 30.30.55.240
    snmp-server community CiscoWorks RW NMS   使用共同体认证到NMS
    snmp-server enable traps bgp              开启bgp的trab报文
    snmp-server host 30.30.55.240 CiscoWorks bgp  
    
    snmp-server location San Jose,US
    snmp-server contact ccie@cisco.com
    snmp-server view adminview iso included               
    snmp-server view adminwrite system included         
    snmp-server user ccie admin v3 auth md5 cisco
    access-list 17 permit YY.YY.17.0 0.0.0.255
    snmp-server group admin v3 priv read adminview write adminwrite access 17 
    access-list 67 permit YY.YY.67.0 0.0.0.255
    snmp-server community nms  67
    no snmp-server group nms v1      
    snmp-server trap-source Loopback0
    

    SNMP 协议的优缺点:
    优点:
    简单、容易实现;
    基于SGMP协议,已有相当多的操作经验。
    缺点:
    没有实质性的安全设施;
    无数据源的认证功能,不能防止偷听。
    SNMP协议轮询的方式在一个大型网络中可能会导致网络通信拥塞情况的发生,并且SNMP协议把采集数据的负担完全压在了管理端之上。
    SNMP Agent无法提供某个数据的历史记录。
    SNMP协议不能以一种统一通用的数据描述格式保存所有被管理设备的标识、状态和配置等信息。
    (4)SPAN
    SPAN(交换机端口分析器)技术主要是用来监控交换机上的数据流,利用SPAN技术我们可以把交换机上某些想要被监控端口(受控端口)的数据流COPY或MIRROR一份,发送给连接在监控端口上的流量分析仪,比如CISCO的IDS或是装了Sniffer工具的PC。
    SPAN配置
    <1>配置本地SPAN:
    Switch(config)# monitor session 1 source interface f0/10
    //设定SPAN的受控端口
    Switch(config)# monitor session 1 destination interface f0/20
    //设定SPAN的监控端口
    <2>监测命令:
    Switch#show monitor session 1
    (5)报文分析


    15、交换安全
    (1)二层攻击分类:MAC层攻击、VLAN攻击、欺骗攻击和交换机设备上的攻击。
    <1>MAC层攻击

    MAC层攻击防御措施:端口安全
    基于端口建立接入规则,接入规则有:
    端口MAC最大个数、端口+MAC、端口+MAC+VLAN、端口+IP、端口+IP+MAC+VLAN
    安全违例产生于以下情况:
    • 如果一个端口被配置为一个安全端口,当其安全地址的数目已经达到允许的最大个数。
    • 如果该端口收到一个源地址不属于端口上的安全地址的包。
    当安全违例产生时,你可以选择多种方式来处理违例:
    • Protect: 当安全地址个数满后,安全端口将丢弃违规地址的包, 不发SNMP Trap信息。
    • Restrict: 当违例产生时,安全端口将丢弃未知名地址,同时发送一个SNMP Trap通知。
    • Shutdown: 当违例产生时,将关闭端口,并发送一个SNMP Trap通知。
    端口安全配置:
    打开端口安全功能
    switch(config-if)#switchport port-security
    配置最大MAC地址数
    switch(config-if)#switchport port-security maximum 3
    配置MAC地址静态绑定
    switch(config-if)#switchport port-security mac-address 001a.a900.0001
    配置MAC地址粘滞,状态接口上所有通过动态学习到的MAC,将被转成sticky mac address,形成安全地址。命令配置后新学习到的MAC地址,也属于sticky。
    switch(config-if)# switchport port-security mac-address sticky
    配置违例处理方式
    Switch(config-if)#switchport port-security violation {protect | restrict | shutdown}
    查看端口安全:
    show port-securtity show port-securtity interface f0/1 show port-securtity address
    <2>VLAN攻击


    VLAN攻击防御措施:缓解VLAN跳转攻击
    将所有未使用的端口设置为Access端口,使其无法协商链路聚集协议。将所有未使用的端口设置为Shutdown状态,并放入同一个VLAN中。在建立Trunk链路时,将链路聚集协议设置成Nonegotiate。在Trunk链路上配置所需要承载的具体VLAN。Native VLAN与任何数据VLAN都不相同。
    配置:
    switch(config)# mac access-list extended BACKUP-SERVER switch(config-ext-mac)# permit any host 0000.1111.4444 switch(config)# access-list 100 permit ip 10.1.9.0 0.0.0.255 any switch(config)# vlan access-map XYZ 10 switch(config-map)# mactch ip address 100 switch(config-map)# action drop switch(config-map)# vlan access-map XYZ 20 switch(config-map)# match mac address BACKUP-SERVER switch(config-map)# action drop switch(config-map)# vlan access-map XYZ 30 switch(config-map)# action forward switch(config)# vlan filter XYZ vlan-list 10,20
    VLAN攻击防御措施:PVLAN
    Private VLAN(私有VLAN, PVLAN) 是能够为相同VLAN内不同端口提供隔离的VLAN。PVLAN可以将一个VLAN的二层广播域划分成多个子域,每个子域都由一对VLAN组成: Primary VLAN(主VLAN)和Secondary VLAN(辅助VLAN组成)。

    主VLAN: 主VLAN是PVLAN的高级VLAN,每个PVLAN中只有一个主VLAN。
    辅助VLAN: 辅助VLAN是PVLAN中的子VLAN,并且映射到一个主VLAN。每台接入设备都连接到辅助VLAN。
    <1>隔离VLAN(Isolated VLAN):同一个隔离VLAN中的端口互相不能进行二层通信,一个私有VLAN域中只有一个隔离VLAN。
    <2>团体VLAN(Community VLAN):同一个团体VLAN中的端口可以进行二层通信,但是不能与其他团体VLAN中的端口进行二层通信,一个私有VLAN中可以有多个团体VLAN。
    PVLAN的端口类型:
    <1>混杂端口(Promiscuous):混杂端口为主VLAN中的端口,可以与任意端口通信,包括同一个PVLAN中的隔离端口和团体端口。
    <2>孤立端口(Isolated):隔离端口为隔离VLAN中的端口,隔离端口只能与混杂
    端口进行通信。
    <3>团体端口(Community):团体端口为团体VLAN中的端口,同一个团体VLAN中的团体端口之间可以互相通信,并且团体端口可以与混杂端口通信,但是不能与其他团体VLAN的端口进行通信。
    配置PVLAN:
    <1>将VTP模式设置为透明模式。
    <2>创建辅助VLAN。
    <3>创建主VLAN。
    <4>将辅助VLAN和主VLAN进行关联,其中,主VLAN中只能关联一个孤立VLAN,但是可以关联多个团体VLAN。
    <5>将一个接口配置为孤立端口或团体端口。
    <6>将这个孤立端口或团体端口关联给主-辅助PVLAN对。
    <7>将一个接口配置为杂合端口。
    <8>将这个杂合端口映射到主–辅助PVLAN对。

    PVLAN示例:
    <1>创建Primary VLAN及Secondary VLAN
    SW(config)#vlan 100 SW(config-vlan)#private-vlan primary SW(config-vlan)#vlan 201 SW(config-vlan)#private-vlan community SW(config-vlan)#vlan 202 SW(config-vlan)#private-vlan isolated
    <2>关联Primary VLAN及Secondary VLAN
    SW(config)#vlan 100 SW(config-vlan)#private-vlan association 201-202
    <3>将端口f0/5设置为Promiscuous Port并映射Secondary VLAN:
    SW(config)#int f0/5 SW(config-if)#switchport mode private-vlan promiscuous //设置端口为混杂模式 SW(config-if)#switchport private-vlan mapping 100 201-202 //使用mapping关联主VLAN和能够访问的私有VLAN
    <4>将端口f0/1-2设置为Host Port并映射community VLAN:
    SW(config)#int range f0/1-2 SW(config-if)#switchport mode private-vlan host //设置端口为host模式 SW(config-if)#switchport private-vlan host-association 100 201 //使用host-association关联主VLAN和所属的私有VLAN
    <5>将端口f0/3-4设置为Host Port并映射isolated VLAN:
    SW(config)#int range f0/3-4 SW(config-if)#switchport mode private-vlan host //设置端口为host模式 SW(config-if)#switchport private-vlan host-association 100 202 //使用host-association关联主VLAN和所属的私有VLAN
    (3)欺骗攻击

    DHCP侦听防御措施:DHCP snooping
    switch(config) # ip dhcp snooping switch(config) # ip dhcp snooping vlan 10 switch(config-if) # ip dhcp snooping limit rate 10 // dhcp包的转发速率,超过就接口就shutdown,默认不限制 switch(config-if) # ip dhcp snooping trust // 将端口变成信任端口,信任端口可以正常接收并转发DHCP Offer报文,默认交换机的端口都是非信任端口, // 只能够发送DHCP请求 switch# show ip dhcp snooping // 显示DHCP探测状态
    ARP欺骗

    ARP协议原理
    ARP协议是“Address Resolution Protocol”(地址解析协议)的缩写。根据TCP/IP层次模型,在以太网中,一个主机要和另一个主机进行直接通信,必须知道目标主机的MAC地址。在现实环境中,一般采用IP地址标示通信的对象,而ARP的功能就是将IP翻译成对应的MAC地址。
    该协议是基于广播的,不可靠,ARP响应报文无需请求即可直接发送,这给攻击者留下巨大漏洞。
    ARP欺骗防御措施:
    如何判断是否存在ARP欺骗?网络突然不稳定,时断时续或网速突然很慢,使用arp –a,发现网关的MAC地址在变化。利用抓包进行报文分析,可以很快的定位ARP攻击源头。
    解决办法:
    <1>手工绑定IP、 MAC。
    PC上:arp –s ip地址 mac地址
    网络设备上:arp ip地址 mac地址 arpa
    <2>DAI(Dynamic ARP inspection)
    通过DHCP Snooping功能将用户正确的IP与MAC写入交换机的DHCP Snooping表,使用DAI功能校验ARP报文的正确性。
    应用场景:用户使用动态IP地址
    缺点:DAI功能需通过CPU处理,大量的ARP报文可能导致CPU过高。
    DAI 的配置:
    ip dhcp snooping vlan 10 Ip dhcp snooping ip arp inspection vlan 10 Interface f0/24 ip dhcp snooping trust ip arp inspection trust
    IP防欺骗和IP源防护
    攻击防御配置:
    switch(config)# ip dhcp snooping switch(config)# Ip dhcp snooping vlan 1,10 switch(config)# Ip dhcp snooping verify mac-address switch(config)# Ip source binding 0000.000a.000b vlan 10 10.1.10.11 interface fa2/18 switch(config)# interface range fastethernet 2/1 ,2/18 switch(config-if)# switchport switch(config-if)# switchport mode access switch(config-if)# switchport port-security switch(config-if)#ip verify source vlan dhcp-snooping port-security
    (4)交换机设备攻击

    DNP邻居发现协议
    CDP 默认启用的二层协议, cisco私有
    LLDP 默认禁用状态,与厂商无关的二层协议
    switch(config)# no cdp run

    switch(config-if)# no cdp enable switch#show cdp neighbor switch(config)# lldp run

    switch(config-if)# lldp enable switch# show lldp neighbor
    交换机设备攻击防御措施:
    SSH
    switch(config)# enable secret cisco //配置enable密码 switch(config)# username spoto password spoto //配置用户名和密码 switch(config)#ip domain-name spoto.net //配置主机名和域名 switch(config)#crypto key generate rsa general-keys //生成RSA密钥 switch(config)#line vty 0 15 switch(config-line)#login local switch(config-line)# transport input ssh //在线路上启用SSH传输

    展开全文
  • 程控交换之TST交换网络研究

    千次阅读 2010-07-06 09:06:00
    TST交换网络;程控核心交换网络模型。

    尊重原创,谢谢!

          TST    交换网络研究

    TST网络为三级网络:

    大型的数字交换网络普遍采用TST(时分-空分-时分)三级结构,它由两个T级和一个S级组成,如上图所示;因为采用两个T级,可充分利用时分接线器成本低和无阻塞的特点,并利用S级扩大容量,使他具有成本低,阻塞率小和路由寻找简单等特点。

     这种数字交换网引入了空分级S,改善了话务的疏散功能,并通过扩大S级的输入母线和输出母线,将多个时分接线器连接起来,大幅度提高了交换网的容量。图中S级之前的称为前T级,S级之后的称为后T级。这里S级的容量为8X8,即有8组输入母线和8组输出母线,分别可接8个前T级和8个后T级。

    这个TST网络的容量为:时分交换器芯片MT8980的容量为8X32=256个时隙。可接入8PCM一次群,由于8个前T8个后T,因而总交换的容量为8X256=2048时隙(话路),可接入8X8=64PCM一次群,又因为每端PCM可占用的时隙数为30,且数字交换网为单向传输,每一对通话占用两个时隙,故可同时接通的通话数为:64*30/2=960,即最多可接通1920路用户通话。

    T级采用控制写入,顺序读出,后T级采用顺序写入,控制读出,S级采用输出端控制,对入线进行选择。如下图所示:

     

    在实际应用中,用户A所在的同一组T级网络中前T级和后T级使用同一个控制存储器来控制,但两者最高位是倒相关系,同样的方法,用户B所属的T级网络也是采用的同一个控制存储器来控制,只需要将最高位反相后送给后T级。这样在电路上大大的简化了控制电路的复杂程度。

    介于TST网络的三级结构,整个系统的电路中必须包含三级交换电路,T级采用时分交换芯片MT8980来实现,S级采用空分交换芯片MT8816来实现。

    下面介绍芯片MT8980内部结构如下:

     

     

    输入端口:PCM0-PCM7

    输出端口:PCM0-PCM7

    处理机控制接口:A0~A5,D0~D7,-CS,R/W,DTA

    D0-D78位双向数据总线,处理机与芯片互通信息使用;

    A0~A56位地址总线,用于处理机对芯片内各部件寻址,传送寻址用的地址码。

    控制寄存器是一个8位的寄存器。其内容是由处理机写入,用以指定工作模式、操作对象和输入/输出的PCM总线号码。

    MT8980有两种工作模式:交换模式和消息模式。靠软件设置确定使用两种工作模式中的哪一种。在交换模式下,MY8980实际上就是一个完整的单级T接线器;在消息模式下接续存储器低8位的内容可作为数据直接输出到该存储单元对应的输出母线上的对应时隙中去。

    微处理器可通过控制接口寄存器读取数据存储器、控制寄存器和接续存储器的内容,并可向控制寄存器和接续存储器写入数据。所有上诉操作都是由微处理器发出的命令确定的。芯片工作于何种模式,也是由微处理器发出的命令控制,命令传送使用的信号线以及有关命令的格式介绍如下:

    地址线(A0~A5)用于确定操作对象。当A5=0时,所有的操作均针对控制寄存器;当A5=1时,则由A4~A0来确定时隙号,以便对各时隙进行控制。控制寄存器的格式如下:

     

    B7b6为模式控制位,其中b7为分离方式选择位。当b7=1时,不论b4,b3处于什么状态,对芯片的所有读操作均从数据存储器读出;所有的写操作均写入接续存储器的低8位。当b7=0时,由存储器选择位b4,b3指定对哪一个存储器进行读写操作。B6为输出方式选择位。当b6=1时,如ODE=1,位消息模式,接续存储器个存储单元的低8位将按顺序输出至对应输出母线上的对应时隙。当b6=0时,为交换模式,有接续存储器的内容控制数据存储器的读出。,

    MT8816内部结构如下图:

     

    COL0~COL7 :列输入/输出,开关阵列8路列输入或输出。

    ROW0~ROW15 :行输入/输出,开关阵列16路行输入或输出。

    ACOL0~ACOL2 :列地址码输入,对开关阵列进行列寻址。

    AROW0~AROW3 :行地址码输入,对开关阵行进行行寻址。

    ST :选通脉冲输入,高电平有效,使地址码与数据得以控制相应开关的通、断。在ST上升沿前,地址必须进入稳定状态,在ST下降沿处,数据也应该是稳定的。

    DI:通断控制输入,若DI为高电平,将所选择的开关导通;若DI为低电平,将所选择的开关断开。

    RESET:复位信号输入,若为高电平,不管CS处于什么电平,均将全部开关置于截止状态。

        CS :片选信号输入,高电平有效。

    MT8816的工作原理如下:

     

      图中有8COL线(COL0-COL7)和16ROW线(ROW0~ROW15),形成一个模拟交换矩阵。它们可以通过任意一个交叉点接通。芯片有保持功能,因此可以保持任一交叉点处于接通状态,直至有断开控制信号或复位信号为止。CPU可以通过地址线ACOL2~ACOL0和数据线AROW3~AROW0控制和选择需要接通的交叉点号。ACOL2~ACOL0COL7 ~COL0中的一条线。ACOL7~ACOL0编成二进制码,经过译码以后就可以接通交叉点相应的COLi;数据线AROW3~AROW0ROW15~ROW0中的一条。AROW3~AROW0也是编码的,经过译码以后就可以接通交叉点相应的ROWi;控制相应ROWi的以接通有关的交叉点。例如要接通COL1ROW8之间的交叉点。这时一方面向ACOL2~ACOL0。送“001”,另一方面向AROW3 ~AROW3送 “1000”。并使DI为高电平,当送出地址启动门ST时,就可以将相应交叉点接通了,图中还有一个端子叫“RESET”复位端。当RESET为“1”时,全部交叉点就断开了。

    电子接线器速度快,驱动要求低,并能自己保持。因此使用起来十分方便。

    其它型号的芯片的基本原理也大致相同。区别只是容量不一样。

    电子接线器的优点是体积小,价格便宜,它的缺点是导通电阻较机械接点大(一般几十欧姆到一百欧姆),并且串音衰耗也较机电的接线器小,因此电子接线器组成的交换网络和由机械接点组成的交换网络也有所区别。

    系统框架:

    通过对时分和空分电路分析,得出在时分电路中采用单片机进行控制,在单独T级电路中,采用一片单片机来控制,对输入的用户的摘机信号和DTMF信号进行分析,选择哪一路用户被呼叫,同时通过8位数据总线对数据存储器进行控制,选择该路用户,将数据存储起来并通过6位地址线进行寻址,对控制存储器进行控制。选择对应的时隙进行数据的交换。时分电路的数据为2MHZ,在内部的32个时隙中,可用的时隙为30,在对我司的程控实验箱的原理图进行分析发现电路中4路用户接口电路经过PCM编码芯片3067后的语音信号接在了同一个端口,即分析可知在该系统采用了时分复用的交换技术,对每一路用户默认规定了一个时隙,同时加入了信号音等时隙。

    对空分电路分析可知,在实际应用中,芯片由输入的行地址和列地址来选择电导通的点,从而实现空间上的电路交换。芯片的控制可以由单片实现,分析发现在这里若改为FPGA实现,在电路上可以得到简化,同时外围的一些时序电路均可以由FPGA来实现。这样整个交换网络的核心交换部分改为FPGA来实现,但是处理器还是由单片机控制。这样采用的空分 交换芯片为MT8816,该芯片交换矩阵为8X16,可实现24路用户的空间交换。

    整个系统的框架如下图:

     

    以上只是一个初步的方案,还有许多需要完善的地方,下面就该方案作一个简单的说明,在该TST网络中充分的利用了MCU在控制上的优势,FPGA在时序上的优点,以及DSP在数字信号处理上的高速性,将三大主控制器件结合起来,在整个交换网络中得到了很强的扩展性。在这里将4路用户分为了两路PCM群,每一组接在8980的一条母线上,经对我司程控D2产品分析发现可以将信号音(包括呼叫信号、忙音信号、摘机信号)与语音信号通过分时复用接在一根母线上。如果采用该方案,则空分交换没有体现交换的概念,故可以将两路用户分为两组,接两条母线,再经过时分交换,这样就完全符合实际工业上TST交换网络的概念。对8980的控制还是由单片机来实现,整个控制还是由单片机产生,但是由于单片机IO口有限,加入FPGA后可以实现时序电路的优化,同时可以由FPGA来对8816控制。

    整个系统的大致工作流程如下:

    在原理图的设计中,先由单片机接收用户电路产生的DTMF和拨号、忙音、回铃音等信号,由单片机分析选择被呼叫的用户,分时产生地址寻址信号和数据存储器命令来对8980芯片进行控制,选择用户时隙进行交换。单片机的IO口通过双向扩展芯片8255与用户电路相连,通过扫描的方式来判断用户呼叫信号。

    由单片机控制产生的时序信号以及8位数据总线接到FPGA模块,FPGA根据接收到的数据信号产生整个TST网络的时序控制信号,同时产生8816芯片空间电气接触的地址信号。这样同一时隙下就实现了一条话路的导通,当有多个用户同时呼叫时,则在整个原理上可以得到简化,因为在这里可以由软件的方式选择将四路用户分两组接在前T级的8980芯片的;两组母线上,而实际上前T级跟后T级进行通话时必须建立两条通路,在实际中,将所有的时隙划分成两部分,一旦一路接口的发送占用了第i个内时隙时,它的接收将占用第j=i+ni/2时隙。其中ni为内时隙个数;这种方法称为反相内时隙法。也就是说前T级和后T级可由同一个MCU来进行控制,考虑到IO口的限制,这样经过FPGA进行内部转换,所有的TST网络的控制端口可全部接在FPGA上。这样就不会出现话路阻塞现象,

    总结:

    TST网络完全实现了在实际的TST网络交换的电路原理和结构,并且可以通过外围的接口实现中继通信。在可扩展性上也突出了优势。在方案的论证上可以将该系统的控制部分作为核心板,将外围接口开放出来,搭建电路,验证方案的可行性。

    分析了国内知名的厂家的程控实验箱的产品,基本上都没有搭建TST三级网络,而在实际商用交换机均采用TST网络,在国外也是以TST网络居多。

    以上是整个系统的架构,分析核心控制电路,主要还是由DSP来进行7号信令的分析,MCU来进行整个交换网络的控制,FPGA来实现所有的电路接口和时序网络。

     

    将用户电路PCM语音信号经过FPGA写入到数据存储器,然后由DSP来对PCM信号进行7号信令运算,达盛科技公司的程控产品是采用的DSP架构,同时也是MCU进行控制,该设计是将FPGA融合到了整个交换网络中,在应用中能提高电路的运行速度,减少硬件电路的延时,同时利用了大容量的存储器将用户信息存储运算,可直接过渡到下一代交换技术,融合分组交换等现代交换技术。

    这篇文章是在我实习期间完成的,也算是对我实习工作的一个回报,本身自己不是电信专业的,在实习的时候自己负责了程控核心交换网络的设计工作,而其中所有的交换网络的时序都是在FPGA内部实现,(终于发现了自己的用武之地,在FPGA这张白纸上可以尽情的发挥),后来由于时间的原因我把前期的准备工作完成后就移交给其他牛人去做了。。。惭愧!!

    展开全文
  • 一段可以将由大于等于一个单词组成的字符串中的每个单词的首字母置为大写状态的源代码?诸位的想法是什么可以在下面留言看看
  • 社会交换理论

    千次阅读 2015-08-19 14:39:40
    二、五种社会交换理论      虽然“社会交换理论”意指关于社会交换的单一理论,实际上对社会交换存在着五种不同的观点:霍曼斯的操作心理学观点、布劳的经济学观点、蒂博特和凯利的相互依赖说、 E ·...

    二、五种社会交换理论

     

      

      虽然“社会交换理论”意指关于社会交换的单一理论,实际上对社会交换存在着五种不同的观点:霍曼斯的操作心理学观点、布劳的经济学观点、蒂博特和凯利的相互依赖说、 E ·福阿和 U ·福阿的资源说以及 E ·沃尔斯特等人的公平说。本章将考察构成以上各种观点基础的种种假设,并描述它们是怎样看待决策和各种交换模式的。再没有什么比一项好的理论更为实际的了。

                                   ——库尔特·卢因

      

      对上面的这句话,大多数社会科学家都会由衷地赞同。理论赋予我们解释过去、预测未来的能力,以及控制环境的力量;人们也希望理论使我们能改善自己的际遇。然而,又是什么构成了理论呢 ? 对此则众说纷纭。有些学者把未经检验的假设、含糊的概念或规定都说成是理论;也有的学者主张理论应是 _ 一整套使概念彼此关联的命题,人们可以据此来合乎逻辑( p · 27 )地推导出各种假设,并用经验的方法来检验假设。

      由于学术界给理论所下的定义各不相同,并非每一种社会交换理论都能符合对理论的要求。例如,霍曼斯提出了一种试图符合演绎要求的形式化了的理论,而布劳并没有进一步发展构成他理论的命题。我们确实应该给理论下一个广义的定义,这样才能包容所有的观点。本书给理论所下的定义是:一组表明某些现象特征的、并可能由此引出假设的陈述。

      本章将介绍的观点尽管形式各异,但都提到三个方面。第一,它们都说明了各自的基本假想或出发点。有的把心理学理论作为自己的理论基础 ( 如:霍曼斯, 1961 年、 1974 年;蒂博特和凯利, 1959 年; E ·福阿和 U ·福阿, 1974 年 ) ,也有的主要来源于经济学 ( 布劳, 1964 年 ) 或其他社会交换观点 ( 沃尔斯特等, 1976 年 ) 。第二,它们都描述了社会交换对人类行为的影响,大致来说,各种观点都描述了导致人类行为的决策过程。第三,它们都对人际关系中的交换模式提出了各自的解释。这些模式体现了关系双方对自我利益的调节。

      因此,对每一理论的描述都分为三个部分:理论基础、决策、交换模式。

    霍曼斯的操作心理学观点

    在本章介绍的五种理论中,霍曼斯的理论大概最为著名。他在早期发表的学术文章 (1958 年 ) 以及专著《社会行为的基本形式》 (1961 年和 1974 年版 ) 为我们提供了研究他理论的主要根据。在五种理论中,他的理论最为人熟知,但引起的争议也最多。不少人撰文对他的理论在社会学现象中的应用持批评态度。爱默森曾试图运用形式逻辑的规则将霍曼斯的分析形式化并加以引伸。

    理论基础

      如前所述,霍曼斯的观点在社会学领域引起许多争论。争论又主要源自他的理论基础。霍曼斯虽身为社会学家,但他主要依赖于行为心理学建立起了自己的交换理论。① B . F 。斯金纳的论著对霍曼斯的思路尤多启发。

      简要地解释一下斯金纳的观点,能使我们对霍曼斯所受到的批评有深入的了解。斯金纳提出了四点关于人类行为的假设。第一,人是与其他生物体一起居住在地球上的生物体;人类在解剖和生理上具有独特的特征,这是其祖先为适应环境而进化的结果。其中有利于生存的得到发展,妨碍生存的得不到发展,这些特征构成了遗传的能力。第二,当一个新生儿学会以他人强加于其身的方式动作时,他 ( 她 ) 便成为一个“人”。第三,人类行为受到环境中刺激物的制约。最后一点,人类习得行为的能力是遗传能力的一部分。

      由于斯金纳断言环境刺激造成人类行为,人们或许会认为认知过程 ( 如思维、态度 ) 在他的理论中无足轻重,或许会把人看作受环境冲击的相对被动、相对无知的个体。行为主义的某些流派固然忽视认知过程的重要性,斯金纳还是承认认知过程的存在,并对认知过程和行为之间的关系作了描述。 ①应该指出,霍曼斯也谈到过经济学和博弈原理对他理论的意义,但他理论的基础主要还是操作心理学。 (p · 29)

      在斯金纳看来,思维是一种隐蔽的行为;思维过程还可能包括调节感情及监控未来的行动。例如,在一次约会前,可能会预先计划一下说些什么话,到什么地方去,做些什么事,在这种情况下,斯金纳认为思维不过是赴约这一较大规模的行为系列中的一个环节,即对行为后果的预想。在约会当中,约会者或许会思考:“我现在过得愉快吗 ? 按下去我该说什么话呢 ? ”在约会之前和约会进行之中,思维都是由环境刺激引起的。在赴约之前,这方对与他方所作的约定作出反应,他方则将思维过程引向今后的交往;在约会之中,这方对他方或环境所激起的内在情感作出反应。不论在何种情况下,思维是作为外界刺激的效应而发生的,它虽有助于控制行为,但终究没有产生行为。正如公开的行为 ( 如谈话、舞蹈 ) 是对外界刺激的明显可见的反应一样,思维是对这种刺激的隐蔽的行为反应。

      斯金纳并未忽略认知过程,他只是认为认知过程并不产生行为,而仅仅是对外界刺激的一种行为反应。然而,如果考虑到认知过程在大多数推理中所起的主要作用,那么,即使只是稍加贬低这一作用,也会引起人们的争议,并导致一种夸张了的感觉——斯金纳所描述的不是像他自己一样的人,而是一台机器人。

      另一些批评与斯金纳的理论本身无关,而是产生于与他的理论有关的研究方法。人们总是把行为主义理论和“斯氏盒”以及自鼠联系在一起。可以理解,大多数人不想承认自己和啮齿动物有共通之处,包括在行为规律上有什么相同点。斯金纳为自己辩解道:“在心理学实验室里由白鼠主宰一切的时代至少在四分之一世纪以前已经告终。”然而,对他的观点持 (p·30·) 批评态度的人仍然断言,他的研究结果仅仅适用于实验室的动物。

      对斯金纳的观点提出的指责是形形色色的,但本节内所述的几点就足以给斯金纳制造难题了。斯金纳自己固然可能觉得运用行为心理学作为理论基础是极为可靠的,但批评者或许会把这一基础看作是一堆流沙,而不是钢筋混凝土。

    决策

      霍曼斯对人类行为的分析是基于操作条件原理的,即:人们重复那种受到回报的行为,而不重复那种受到惩罚的行为。为了阐明这一观点,霍曼斯提出了五个命题。

      第一个命题称为成功命题,即:“就人们的所有行动而言,某人的某一行动越是经常得到回报,此人越是可能采取该行动。”这一命题的意思就是人们倾向于重复能获回报的行动。霍曼斯确实也注意到这一命题的局限性。研究表明,如果某一行为所得回报是无规律的 ( 可变周期鼓励 ) ,而不是有规律的 ( 固定周期鼓励 ) ,那么任何生物体 ( 包括人 ) 重复该行为的频率就越高。尽管如此,霍曼斯仍断言成功命题一般来说是正确的。

      第二个命题是刺激命题,即:“如果过去某一刺激、或一系列刺激发生时,某人的某一行动得到了回报,那么目前的刺激和过去的刺激越是相似,此人目前就越有可能采取该一行动,或相似的行动。”这一命题描述的是刺激的普遍性。夫妻中的一方可能会采用在过去相似境况中获得成功的劝服策略;何谓“相似境况”,又是由话题、时间、夫妻中的一方、或在前后两次情况中突出的环境刺激决定的。 (p31)

      第三命题是价值命题,即:“某人某一行动的后果对他越具价值,他越有可能采取这一行动。”所谓价值,是指某一资源使人得益的大小。霍曼斯认为,各种资源具有大小不同的价值,正如拒绝给予资源造成大小不同的惩罚一样。他虽然未能对各种资源所具价值的大小作出精确的说明,但还是提出价值可能来源于两个方面:有些资源具有固有的价值,我们生来就须臾不可缺少它们,例如食物和住房对我们具有价值,因为它们对我们的生存至关重要;另一些资源之所以具有价值,是因为通过它们能获取其他的回报,例如金钱的价值来自它能换取食物、住房之类具有固有价值的资源。霍曼斯甚至提出,有些资源——如金钱和社会赞同——对获取我们需求的东西是如此之必要,以至于它们的价值对社会各阶层人均具有普遍意义。 .

      第四命题是贬值一饱和命题,即:“某人在近期内越是经常地接受了某一回报,该回报在未来对他的价值就越小。”这一命题对成功命题加以限制。人们到了一定程度就不再需要某一回报了;这时候,该回报对行为的重复就不再有多大的效应。

      第五命题是寻衅/赞同命题,并由两个部分组成:“ (1) 如果某人的行动未能获得预期的回报,或者招致始料未及的惩罚,此人就会愤怒;他更可能采取寻衅行为,而这类行为的后果对他来说更有价值”。 (2) “如果某人的行动获得了预期的回报,尤其是获得了超出预期的回报,或者未招致预期的惩罚,此人就会高兴;他更可能采取受赞同的行为,而这类行动的后果对他来说也更有价值”。霍曼斯的意思是,人们在经过一个时期以后能够预测某一行为会引出某种回报或惩罚,如未能 (p ·32') 获得预测的回报则会变得沮丧,这种沮丧情绪自然地导致寻衅行为;而如果寻衅行为果然获取了预测的回报,那么在未来 相似的情况下此人更有可能采取寻衅行为。每一次带孩子上 商店都给孩子买一根棒糖,孩子就会把上商店和获取棒糖这 一回报联系起来,万一父母忘了给孩子买棒糖,他就会不高 兴,就要“发脾气”。“发脾气”的结果是孩子得到了棒糖,寻衅行为就被强化了,在未来类似境况下就会反复出现。

      另一方面,霍曼斯也认为,如果我们在某一情况下一而 再、再而三地受到惩罚,那么在相似条件下也会预测受到惩 罚·这种预测如未实现,其结果就不是寻衅行为,而是宽慰或满意的心情。上段提到的孩子跟母亲上商店时如果出乎意料 地得到了一块冰淇淋,而不是一根棒糖,就可能变得更听话、更快乐 ( 至少在吃冰淇淋时是这样 ) 。以后上商店时他也就会 预期能吃冰淇淋了。

      上述五个命题构成了霍曼斯理论的基础,在《社会行为》 一书的初版本和再版本中均有阐述,虽然略有改动。其中心思想是人的行为可以根据过去行为产生的后果来预测。被过 去的经历强化了的事例对人有某种程度的制约力,在过去类似情况下被强化了的事例可能是眼下行为的主要决定因素。一旦在目前的环境中察觉到与以前的环境中相类似的刺激,就会自然而然地采取被过去的经历所强化的行为。

      在《社会行为》再版本中,霍曼斯将第一、第二、第三龠题总结为第六命题——合理命题:“人们面临行动抉择时,总是选择后果价值 (V) 乘以获取该后果的概率 (P) 所得的积较托的行动”。人类选择不同行为时,最可能采用在类似情况下一贯产生最大价值资源的行为。这一命题虽然似乎意指行为选 (p · 33·) 择是由某种心智过程决定的,但霍曼斯并无此意。行为的抉择不是由个人决定的,而是由先前的强化事例决定的。事实上,假若我们完全明了某人在过去类似情况中的强化事例,我们就能够与此人一样预测眼下的行为。由于行为主义并不认为人们总是有意识地估算某一行为的回报与代价,因此一位对某人的历史了若指掌的局外观察者能比此人本身更好地预测他的行为。

      霍曼斯提出了一套来源于行为心理学的、相互关联的命题。霍曼斯信奉简化论。他相信任何形式的行为,不论具有多大的复杂性,均可简化为上述六项命题——它们能够解释人际行为。

    交换模式

      霍曼斯描绘了一个从现有环境寻求积极刺激的人:即一个愿意做任何“在过去成功过”的事的人,一个追求利益的人。在与无生命的物体打交道时.追求利益就是为了获取某一有价值的资源而放弃某物。正在准备晚饭的人或许会判断,准备饭菜所花的时间、气力和金钱是否和吃这顿饭所得到的满足价值相当。从一定意义上说,这种交换是比较容易进行的,因为准备晚饭者是主动的,食物相对而言是被动的。只要烹调技术精良,烹调器具和调料徭当,准备晚饭的结果应该是相对地固定而且令人满意的。

      然而,当两个人处在一个交换关系时,就出现了复杂的情况。作为环境刺激的对方是有主动性的人,也是基于过去经历中的强化事例来作选择的。由于这些强化事例不清楚,交换中就碰到了问题。对方可能不象我们希望的那样作出反应, (p·34) 除非我们提供足够的回报,但我们有时并不清楚应当提供怎样的回报。

      霍曼斯在写下面这段话时认识到交换关系中对方的重要性:“人类交换的公开秘密是:给予对方的行为对对方的价值超过自己付出的代价;从对方获取的行为对我的价值超过他付出的代价。”就这样,一个人给予另一人某些值得的东西,来换回另~些值得的东西。但是,又怎样来决定这样的交换是否公平呢 ?

      霍曼斯根据亚里士多德的著作,主张公平与否得由分配公正律决定。分配公正律是:“交换关系中的一方将期待彼此所获的回报与各自所付的代价成正比例——回报越大,代价也越大;他也将期待彼此的纯回报 ( 或称得益 ) 与各自所下的投资成正比例——投资越多,得益也越多”。“投资”一词是指在一项活动或一件工作中所花的时间和所作的努力。因此,一对投资相等的夫妻 ( 年龄、婚龄 ) 可能期望从对方芬取那些会带来相等利益的具有相等价值的资源。

      万一出现不公平交换,霍曼斯预言双方都会感到苦恼。他说:“越是因分配公平未能实现而使某人不利,此人越是可能显示出我们称之为愤怒的感情行为。”然而,当某人因违反分配公正律而得益时 ( 即比付出相同投资者多获回报 ) ,霍曼斯预言此人或许会有负疚感。这一预言固然动听,但他也指出人们会轻而易举地找出理由来为自己解脱负疚感。

      描述决策的各项命题对两个人之间的资源交换仍然是适用的,但有必要作一个不同的解释。他们可能会自然而然地根据过去的历史对眼下的刺激作出反应,但必须用适合对方过去的强化事例的资源来作反应。交换双方是根据他们交换 (p ·35') 资源的历史而结合在一起的,这一历史又是与各自的自我利益相符的。

    布劳的经济学观点

      布劳将霍曼斯的分析扩大和延伸,得出了他自己的交换观。他的《日常生活中的交换与权势》一书 (1964 年 ) 和两篇论文 (1964 年, 1968 年 ) 是研究他的观点的主要素材。布劳虽然不像霍曼斯弓 l 起那样多的争议,但他对社会学现象的研究方法还是受到了一些学者的批评。

    理论基础

      一般来说,学者们对布劳的批评少于对霍曼斯的批评。布劳的观点之所以被人接受,原因之一是他认识到发生特性是社会交换的控制因素,并且依靠经济学原理——而不是操作心理学——作为其理论基础。

      如前所述,霍曼斯信奉简化论;他相信任何复杂行为都能简化为他提出的几项命题。这一立场未能获得普遍赞同,继而发生了热烈的争论。

      布劳承认,在人际交换中,会出现一些无法用双方过去的强化事例来解释的特性,这样他就避免了争议。他并不否认操作心理学的有效性,但也指出:操作心理学无法解释人际交换中的所有现象——不能解释发生特性。

      按照布劳的观点,发生特性“实质上是一个结构之中各个成分之间的种种关系。这些关系虽然必定与诸成分共存,但并不寓于成分之内,它们限定了该结构。例如,人际社会交换 p·36 ‘ 中的发生特性就是交换双方之间的关系。从关系双方经历过的强化事例不一定可以看出双方取得的一致的性质何在。两人对对方采取某些人际行为,可能是因为在过去这样做曾一直使双方得益。除非双方都发现对方的反应有利可图,否则就可能无法继续对方所期望的行为。假定有一个人曾把做家务和受惩罚联系在一起,从这一过去的强化事例我们可能预料他将竭力逃避这类家务。但是,为了保持与别人的某一关系,他可能不得不分担家务。人们为了获取回报,有可能达成一些难以用过去的强化事例来解释的一致。这些一致甚至可能是出于对未来回报的期望,而不是基于对过去回报的记忆。

      布劳运用经济学作为其主要理论基础。霍曼斯也谈论经济学,但他首先是从操作心理学的角度来研究;相反地,布劳固然承认操作心理学的重要性,却偏向于主要依靠经济学。

      第一章中已指出,布劳看到了社会交换与经济交换之间的若干重要差异;这些差异主要来源于社会交换的非正式性和非特定性。尽管如此,布劳还是相信,描述经济原理的方法 ( 如无差异曲线、供求曲线 ) 能被用来引伸出关于社会交换的可检验的假设。他正是运用这些方法来预测在工作群体中可以怎样用劝告来换得服从。诺德也对群体中社会赞同和社会一致的交换作了类似的分析。

      大多数批评家对布劳运用经济学方法表示欢迎,但也没有忽略其中的一些问题。希思曾指出布劳对各种曲线的描述中的若干小错误;更重要的是,他还提出了质疑:我们在考察社会交换时能否符合经济模式中的数学假设。我们对社会回报的计算可能与经济模式的要求相抵触,某些社会回报的性 p ·37· 质可能与经济生活中商品的性质不同。所以说,布劳对经济学方法的运用提供了一个有用的类比,但无法作出经精确的预测。

    经济学的决策

      布劳对人们如何决定行为的分析是以人们的期望为基点的。他写道:“可以作出的唯一假设是,人类在选择潜在合伙人或行动步骤时,首先对与他人以往的经历或预期的交往作一估价,按条件优劣列序,然后选择最优者。”人们对于从一项活动或从某一个人那里获利的潜在可能作出估计,再与其他活动或其他人作一比较,挑选出可望给予最大利益的活动或人。

      布劳还描述了三种会影响人们抉择的期望:一般期望、特殊期望、比较期望。一般期望是人们认为能从生活各个方面得到的回报:与工作有关的收入和福利条件、从友人那里获得的感情支持和友情。布劳指出,一般期望从最低水平到最高水平不等,达到的期望低于最低水平就会引起不满,高于最高水平则是理想的量。人们普遍认为,一般期望的大小是由两方面决定的:关于某人应得多少回报的社会标准,以及此人过去所获回报的多少。

      特殊期望是从他人获得的回报,包括预期他人的行为将符合社会行动准则,以及这一行为将提供的回报与他人相比是多还是少。

      比较期望包括分析一下从一个关系所获回报中减去维持这一关系的代价,差额是多少;这个差额就是利益。布劳认为,某一关系带来的利益越多,就越有吸引力。 p ·38·

      这些期望影响着人们获取社会回报的愿望。布劳设想,人们获得了某一东准的回报,就想至少要使这一水准维持下去。换言之,令人满意的最低水准的回报就是现行水准的回报。而且,布劳还认为,人们获得符合期望的回报,比获得超出期望的回报更令人满意。这一观点在经济学中称为边际效用递减法则。霍曼斯在贬值一饱和命题中表述了同样的概念:某人在过去接受到某一资源越多,他目前就越是不需要这一资源。最后,布劳还提出,某一资源越是稀有或代价越高,就越受到珍视。

      布劳的分析在一个方面与霍曼斯的分析相似:人们首先考虑选择对象可能提供的种种结果,然后择其最有利者。然而,也应该看到他们之间的一个重要区别。霍曼斯认为,人们只会选择在过去种种类似情况中曾产生回报的对象,而眼下的情况又提供了促使人们从事可得到回报的行为的刺激。布劳虽然认为过去经历的强化事倒是重要的,但同时承认它们没有绝对的制约力。人际关系或社会准则所产生的期望对抉择的影响力可能与过去的强化事例一样大,或更加大。确实,一个人可能愿意在目前付出代价,而期望在将来获取回报 0 在霍曼斯的理论中是找不到对这种延迟满足的阐述的。

    变换模式

      布劳认识到发生特性对社会交换的重要性。在本部分,我们将讨论发生特性是如何在社会交换中得到反映的,并集中介绍布劳关于交换模式的两个普遍性观点。

      第一个观点是:社会交换受到人际关系性质的影响,人际关系又随同社会交换而发展。当某人首次向另一人提供回 p ·39· 报时,就标志着关系的开始。如果该回报被接受,接受者就已受惠于给予者。反过来说,给予者已承担了一个风险。接受者可能不愿意回报给予者的施惠,但他也可能希望关系延续下去而以某种方法回报。回报之后,第一个给予者或许得到鼓舞,因而提供更多的回报,关系就发展起来了。就这样,随着受惠一回报的进行,双方渐渐彼此信任,这又促使了进一步的交换。如果施惠而得不到回报,或者回报不被接受,可以预料,双方会互不信任,并避免进一步的交换。

      第二个观点是:社会环境会影响交换。举例来说,一个人的地位会影响他与别人交换的机会以及交换中的代价的大小。斯坎佐尼认为,传统的婚姻地位使男子有较多的机会给予女子回报。特别是,外出工作的丈夫比操持家务的妻子拥有更多的机会获取收入和建立人际关系。因此,妻子可能认为她与丈夫的关系代价是昂贵的;她因为呆在家里,既很少有机会结识他人,也很少可能获取收入,若要赢得机会就不得不付出更高的代价。一个人的地位以及由此决定的为赢得机会而付出的代价就这样地影响着我们在交换中获取利益的潜在能力。

      社会环境还包括指导交换行为的社会准则。人类群体在一般情况下都制订出指导交换的准则。在对此进行分析时有两个重要的概念。一个概念是:布劳认为,资源的供求情况对两项资源之间的“现行交换率”是有影响的。倘若某人极其需要爱和友情但交游圈子甚小,此人就会心甘情愿地用珍贵的资源与能够结交到的人作交换,以期满足对爱和友情的需要。现行率并不反映人们对资源之间应有关系的道德判断。另一个概念是:社会群体也形成各种准则,指出什么是“公平的交换 p ·40‘ 率”。公平交换准则通常与一个人为社团作有益贡献时的投资有关。假若我们的社会珍视家庭,一个在抚养家庭方面倾注大量时间的人理应比独身者享有更多的资源。然而,布劳也注意到,现行率和公平率并不总是一致的。尽管从长远的情况来看我们的社会需要家庭,但当家庭的数量超过目前的需要时,一个长期承担抚养家庭义务的人所得到的回报会少于家庭义务较轻的人。

      布劳还指出,公平交换的准则常常因为对违反准则者的制裁而得到强化。一个粗暴违反公平交换的人可能会遭到社会的谴责,即便现行交换率没有得到重视。

      人与人之间的权力差异也是影响交换的社会环境的一个组成部分。一个独占大量宝贵资源的人可以毫无顾忌地违反公平交换率;除非其他人能同他进行互惠的交换,或从各种途径获取这些资源,或用强力夺取这些资源,或不需要这些资源,否则就将被迫以低于公平率规定的水平与他进行交换。

      社会环境的最后一个影响来自于交换关系的相互关联性。有些交换只有通过考察它们对其他关系所产生的影响力才能为人理解。两人结为夫妻后会发现,不仅他们两人的关系得到了巩固,而且一些其他的关系也得到了巩固,例如姻亲关系。一个新婚的丈夫或妻子可能面对姻亲的冷漠或侮辱而显得十分容忍,他 ( 她 ) 似乎对得利并不关心,只是以越来越高的代价提供回报。但是,如果将他 ( 她 ) 的行为解释为不想疏远配偶,那么就能理解这种交换还是有利的。与姻亲吵架确实不失为脱离婚姻交换关系的极好方法。

      布劳的理论超出了操作心理学的范围,并包容了经济学 p · 41 ;的一些概念。他的观点固然认为人们的行为是基于对获利的期望,但也承认,由人际关系和周围的社会结构所规定的发生特性同样影响交换。

    蒂博特与凯利的相互依赖说①

      霍曼斯和布劳是社会学家,而蒂博特和凯利的理论起源予社会心理学。他们的理论曾得到更新发展,超越了原先的范围, ( 见蒂博特与凯利,《群体的社会心理学》, 1959 年;凯利与蒂博特,《人际关系》, 1978~, 凯利,《个人关系》, 1979 年 ) 。我们还可以找到对他们著作作进一步论述或批评的文章。

    理论基础

      蒂博特和凯和的理论建立在对两个概念的认识上:内驱力降低和博弈原理。他们和霍曼斯、布劳同样地认为人们总是寻求强化事例;事实上,他们将这一原则作为他们理论的首要假设:“最具有社会意义的行为只有得到强化或得到某种方式的回报,才会被重复。我们认为这是一个基本前提” ( 见蒂博特和凯利, 1959 年 ) 。所谓“得到回报”意思就是人经历了内驱力降低或需要得到了满足,这是与一套被称为“激动理论”的理论 ( 见贝科威茨, 1959 年 ) 相一致的。简言之,这一观点认为,某种内在的动力机制促成了行为。这种内驱力的降低使

      ①这里应该首先提到两点。第一点,凯利与蒂博特 097s~) 和凯利 (1979 年 ) 都明确表示他们认为自己的理论不仅仅是一种交换理论,同时也涉及协调之类的问题。我对他们理论的探讨只限于交换方面。第二点,一依赖说”取自他们新近的论著 - 我把他们先前发表的东西也归于“依赖说”之中。 p ·42· 人欢愉,与此有关的刺激也就能够引起欢愉,从而其本身就成了回报。因此,社会交换的过程就是双方彼此提供能降低内驱力或满足彼此需要的资源的过程。因为内驱力降低原理往往只描述个人的行为,蒂博特和凯利又提出了第二套原理来描述两个人之间的社会交换,即博弈原理。博弈论提出了两个人在某些前提条件下解决冲突的理想方法。这些前提条件包括: (1) 冲突双方都试图获得最大限度的个人利益,遭受最小限度的损失; (2) 冲突双方都了解自己的结局,也了解对方的结局; (3) 冲突双方之间没有任何形式的沟通,所以无法断定对方将采取什么行动; (4) 双方的结局不但依赖于自身的抉择,而且有赖于对方的行为。(5) 冲突的结局很容易测定,其价值是固定的。

    图 (1) 两人混合动机博弈矩阵

      确定双方的理想行动的方法涉及研究博弈中的种种选择。有各种各样的博弈可以应用到人际关系中来。其中被人们普遍接受的是“两人混合动机博弈”。图 (1) 以矩阵形式显 (p ·43)示了这一博弈的结局。 A 、 B 两人处于交换关系之中,双方均有两种行为可选择,矩阵中小区的数字分别表示双方所得回报的大小;假若双方均选中其中的一小矩阵,右上小区的数字即 A 所得回报,左下小区的数字则为 B 所得回报。例如,假若 A 选择 a1 , B 选择 b1 ,则双方均得 4 分;假若 A 选择 a1 ,而 B 选择 b1 ,则 A 得 5 分,而 B 得一 5 分,换言之,在这一矩阵中 A 赢 B 输。

      蒂博特和凯利虽然发现运用博弈矩阵来研究人际关系颇为有用,但也认为并非博弈理论的所有假设都能用来说明人际关系。实际上,他们认为,在一般情况下,真正的社会交换总有一些无法确定的因素——自身与对方的结局如何,双方关于对方将如何动作的沟通,以及因回报获取的多寡而引起的回报价值的变化 ( 边际效用递减法则 ) 。因此,蒂博特和凯利只是用博弈原理作类比来分析社会交换,而并不把它作为能够预测确切行为和结局的模式。

    决策

      由于蒂博特和凯利是在内驱力降低说的基础上构造理论模式的,所以他们的决策观的基础就是由于满足需要而造成的强化行为。他们指出,某人采取某一行为的概率是内部刺激 ( 感情 ) 与外部刺激 ( 环境力量 ) 的函数,这些刺激都与该行为以及以前采取该行为而得到的强化事例有关。因此,采取的行为应该是能取得最大限度结果的。

      然而,他们也注意到这一模式的局限性。如果某一行为完全是自动产生的,以至于几乎不受认识的控制,那末即使该行为不产生积极后果,也有可能被采取。他们发现,有些传播 p ·44· 行为已经被礼仪化了,以致人们几乎不假思索地采取这些行为。由于长期受到社会的影响,我们已经习惯用阳性人称代词“他”来指称“人”,也许并不是很有意识这样使用的。虽然这通常被接受,或至少不被注意,女权主义者大概不会强化这事例。即使如此,尽管不会被强化,要改动语言还是很难的,因为用“他”来指称“人”多年来已经被接受而社会化了。

      他们决策观的另一局限来自如何对待新情况。在初次交往中,什么才是最有可能获得回报的行为,我们缺乏判断的基础,因此我们的行为可能得不到回报。但是,蒂博特和凯利认为,人们能以强化方式学会对新情况作出反应,并迅速克服初交的局限。

      然而,蒂博特和凯利的理论中最有意思的部分倒不是对行为的预测,而是对人们如何评估人际关系的分析。对关系的评估涉及到将这一关系带来的后果与两项标准分别作比较。这两项标准是:比较水准与替代比较水准。比较水准指的是某人觉得从某一关系应该获取的回报大小及要付出的代价的高低;这一水准的确定,可能是依据从先前的关系中获取的回报水平,也可能是自己得 l 知关于他人从类似关系中获取的回报水平。将眼下的关系产生的后果与上述比较水准作一比较,就决定了眼下的关系是否有吸引力,或是否令人满意。替代比较水准指的则是某人愿意从某一关系中获取的最低水平的回报大小,这又涉及此人能从其他替代关系中获取的回报大小,或涉及如不发生任何关系后果如何。将眼下的关系产生的后果与替代比较水准相比,则可知道这一关系的稳定性有多大。 p ·45·

    图( 2) 关系后果、比较水准、替代比较水准与满意度、稳定性的关系

      通过对关系后果、比较水准和替代比较水准进行一番比较,就有可能预测某一关系的满意度和稳定性。图( 2) 列出了将上述三者作比较可能出现的六种情况。在关季 (1) 中 - 关系后果大予比较水准,此人获取的回报大于预期,因此他是满意的;比较水准又大于替代比较水准,使这一关系具有稳定性。从某种程度说,此人对该关系有很大的依赖性:此人从关系中的所得超出了预期,但万一关系中断 ( 如对方死亡 ) ,从替代关系中获得的回报则比预期的要少。

      关系 (2) 与关系 (1) 相仿。因为关系后果大于比较水准,所以此人感到满意;又因关系后果大于替代比较水准,所以关系相当稳定。但是,由于替代比较水准能够提供的回报大予比较水准所提供的回报,此人就不象在关系 (1) 的情况中那样依赖这一关系。假若这一关系中断,此人会接受替代关系。

      关系 (3) 表明关系处于困境。此人对这一关系所能提供回撮的期望 ( 比较水准 ) 高于眼下得到的回报,但也高于其他关系能提供的回报。此人对眼下的关系感到不满,却可能将关系持续下去,因为他认识到从眼下的关系获取的回报毕竟高于替代关系。此人处于令人不满的关系之中;这样的关系 p46· 称为非自愿关系。

      关系 (4) 中的人对眼下的关系并不满意,因为从这一关系中获取的回报小于预期的回报。但并没有处于困境,因为替代比较水准大于关系后果;由于替代关系能提供比眼下的令人不满意的关系更大的回报,所以此人可能去形成一种新的关系,或者不和任何人发生关系。不过新关系的后果如何,我不太乐观,这是因为他的期望太高,即使形成了新关系,他也可能感到不满意。此人可能永远难以满足。

      关系 (5) 与关系 (6) 的结果很可能是建立不起关系。在这两种关系中,替代关系的回报均大于眼下关系的回报,也大于比较水准。然而必须看到关系 (5) 和关系 (6) 之间有一重要区别,关系 (5) 中的人因为关系后果小于比较水准而感到不满意,在这种情况下他对眼下取得的回报感到不快,并能作较好的选择;关系 (6) 中的人却对眼下关系感到满意,因为它提供的回报大于预期,另一方面他可以从替代关系获取更大的回报,眼下的关系处于危险的不稳定的状态。

    交换模式

      蒂博特和凯利不仅对一个人的决策过程感兴趣,也对人们怎样调节行为以适应对方感兴趣。一般认为,当人们在交往时,会产生行为系列。所谓行为系列是指为达到某种目的而采取的一系列言语的或身体的动作,而行为定向则指此人达到该目标的意向。

      社会交换可以被看作是一种扩展了的博弈矩阵;与上文描述的双人矩阵不同,交换关系中的双方常常可以在两种以上的行为中进行选择。一对夫妻在晚上可以看电视,看电影, p · 47· 上餐馆,上床睡觉,或者玩十五子游戏。在这种情况下,就和双人矩阵一样,一方选择某一行为的后果会受到另一方行为的影响。如果一方说:“我要玩十五子游戏“,另一方说:“我要看电视”,那末,各方行为的后果就不同于双方共同选择同一行为的后果,这可以是意料中的事。由于玩十五子游戏和看电视不一样,一般需要两个人一起玩,假若一方不选择玩十五子游戏,就会造成要玩十五子游戏这一方的损失。所以,选择某一行为带来的回报大小,部分是由内在因素 ( 如夫妻双方玩十五子游戏的技艺高低 ) 决定的,部分是由外在因素 ( 如另一方是否愿意玩十五子游戏而不看电视 ) 决定的。

      既然一方行为的后果部分地依赖于另一方的行为,关系各方就会关心自己影响对方行为或在对方身上施展权势的能力。根据蒂博特和凯利的理论,权势的基础是一方为获取回报而对另一方的依赖性。 A 为了获取回报而越是依赖于 B , B 就对 A 拥有越多的权势。在蒂博特和凯利的模式中,权势表现为两种形式:结局控制和行为控制。结局控制指影响某人行为后果的能力,而不管某人干什么;例如,假若某人为获取象爱情这样的资源而极为依赖另一人,那么后者可以不顾此人如何行事,只要拒绝不爱他,就能影响他的行为后果。此人由于无法从对方得到爱而处于被控制的境地。行为控制指的是通过改变自己的行为从而造成另一方行为变化的能力。结局控制提出的假设是人们可以通过采取或不采取某一行为来赢得权势;行为控制使我们明白的是,人们可以在对方选择某一特定行为的条件下,才选择使对方能获得回报的行为,从而对对方施加影响。假若双方关系中的一方决定要看书,这就使另一方更可能采取可以单独从事的行为。既然看 p ·48· 书只要一个人就行了,对方就会觉得采取需要两个人从事的行动就不会有多大回报了。

      由于单方面拥有权势会导致利用权势,所以人们关心如何使自己免受滥用权势之苦。为此,人们提出了对付权势的策略来处理不平等现象。拥有较小权势的人可以运用一系列策略达到增加自己权势的目的:从其他来源寻求回报,减少对方获取回报的其他来源,提高自身给予回报的能力,降低对方给予回报的能力,劝使对方认识自身拥有的资源的价值,贬低对方拥有的资源的价值,等等。

      因为运用权势常常要付出高昂的代价,所以出现了行为准则 ( 行为规则 ) 。这些规则规定人们怎样交换资源,怎样协调行为反应,以及怎样消除代价高昂的反应。这些规则或者是在双方交换关系中有意识地形成的,或者是经过摸索而在无形之中产生的,或者是由更大的社会群体强加的。它们的价值在于使交换双方无需经过代价高昂的谈判就能明确关系后果,并对之进行预测。

      凯利和蒂博特 1978 年出版的著作以及随后凯利在 1979 年出版的著作,都雄心勃勃地试图描述交换中出现的模式。和他们的早期著作一样,他们在这两本书中也认为可以把社会交换看作是一种矩阵,其中含有与回报联系在一起的可供选择的不同行为。但与此同时他们也指出,在社会交换中存在着三类矩阵。第一类是现存矩阵,它代表因环境、制度因素及内在因素 ( 如技能 ) 而决定的行为选择与行为后果。双方进行交换时,他们所处的环境可能使某些行为选择变得异常困难,从而限制了他们的行为选择。例如,资金匮乏就限制了不少选择。同时,双方也可能无法胜任某些行为,因而极不 p ·49‘ 可能成功地完成这些行为。实际上,要改变现存矩阵是很不容易的,因为这涉及要改变人或环境。

      然而,环境限制并不能完全控制人们的交流;人们有能力以某些方式改变现存的后果和可供选择的行为。假若交换双方发现彼此均无力采取能产生良好效果的行动,或对行为选择均无把握,他们可能将现存的行为后果及可供选择的行为转变为“实效矩阵”。这第二类矩阵代表可供选择的行为以及 ( 或者 ) 行为后果的扩展,它最终将决定社会交换中的行为选择。现存矩阵之改变,是由于把某人自己的行为后果与对方的行为后果同时进行了考虑的结果,其形式可以是假设现存行为后果与实际情况不同。例如,善于体贴的丈夫会自己承担妻子的各种家务,在这种情况下,他就把妻子的行为后果看作是自己的行为后果了。改变现存矩阵的另一种方法或许是变换交往中采取首次行动的人。在某些情况下,首次提供资源者可能在交往中占有有利的地位,因此对此作出的反应就比现存矩阵所表明的更具价值。最后一点,交换双方或许会考虑以往的交换情况,制订出以后如何与彼此的交换相适合的方针,从而改变现存矩阵。无论用何种方式,改变现存矩阵都是确定某一规则,双方据此改变对在交往中可供选择的行为及其后果的认识。这是指导人们进行交换时的行为的一种策略。

      第三类矩阵称为意向矩阵,代表了双方关于交换回报的方针;这种方针在一定程度上指导了产生实效矩阵的种种改变方式。例如,有些人对交换采取马基雅维里式的态度。这种人的价值观念极其重视取胜,因而倾向于将交换看作是竞争。我们可以预料,这种人面临现存的可供选择的行为和后 p ·50· 果时会想方设法加以改变,以获取最大的回报,这是相对于交换对方而言的。因此,我们只要了解某人对交换的意向,就不难预料他在与我们交往中可能使用的策略,从而采取恰当的对策来避免受其利用。

      意向矩阵不是决定改变现存矩阵的唯一因素;现存矩阵本身的情况也可能影响这一改变。有些情况中交换双方所处的地位极不平等,即使一个马基雅维里式的人物也无需改变它们。另外,意向矩阵也会受到现存矩阵产生的实际后果的影响。一个马基雅维里式的人物即使获取了比他人大的回报,这些回报还是不能满足他的需求,他甚至仍会心存不满。

      总之,蒂博特和凯利向我们提供了关于交换模式的最完整、最复杂的理论;他们使用的术语是新颖的,对博弈原理的应用是广泛的。

    E ·福阿与 U ·福阿的资源说

      E .福阿和 u ·福阿是社会心理学家,他们写了许多论 文 (U ·福阿, 1971 年; E ·福阿与 U ·福阿, 1972 年, 19'76 年 ) 和一部专著《心的社会结构》 (E ·福阿与 u ·福阿, 1974 年 ) 。

    理论基础

      资源说与我们前面考察过的社会交换理论的一个不同之处是:它的理论基础不是单一的。他们两位试图把心理学的种种理论综合起来。他们的观点在于谋求强化事例的效应和 p ·51· 影响行为的认知结构之间得到调和统一。为了达到这一崇高目标,他们把注意力集中在组织事例和刺激的认知结构或概念范畴上。认知结构是从分化与综合的过程中形成的。分化是将事物看作有区别的个体,综合是在个体之中认识其共同特性。

      很重要的一点是,在 E ·福阿和 u ·福阿看来,认知过程是随着时间发展的;认知范畴既不生来就有,其形成也有先后之分。他们对认知发展过程的分析是很有趣的。他们认为,对新生儿来说,周围环境是一片混沌,他从父母那里得到爱和服务,却不能区分这两种资源。当小孩学会穿衣吃饭这类事以后,才能认清爱和帮忙之间的区别。几乎与此同时,他开始认识自我和他人之间的区别;在行为上他也知晓了给予资源和接受 ( 或拒绝 ) 资源之间的不同。

      此后,这名儿童就学习区分真实行为和理想行为。他希望参与某项活动却不被允许,他便在行为方面渐渐知道作为一个行为对象和行为执行者的区别。与此同时他学会了区分地位和爱,区分货物和服务。他发现因某一行为受到赞扬或遭到斥责并不一定和被抚爱有关。他还可能看到有些货物 ( 如食品 ) 是会消失的,而一些服务性劳动 ( 如炊事 ) 则不断地重复出现。

      最后,这名儿童知道了当事人和旁观者对事物的看法常常不同。儿童们往往想吞食脏东西,而父母对此惊骇不已,这使儿童们不久就明白他们对事物的看法与父母不同。在这一阶段,儿童学会区分信息与地位,也学会区分金钱和货物。他懂得了解或牢记某些事实会受到赞扬,所以该行为经常得到强化。这样,信息就是常常与获得地位有关的商品;同样地, p · 52 .他也知道了金钱的用途——通常必须有钱才能交换到糖果或玩具之类的货物。

      这样,当儿童长大成人,他就具有了关于人际交换的各种认知结构,从而能够认知交换中各种事物的含义。他懂得自我与他人,给予与获取,以及各类资源之间的区别。 E .福阿和 u 。福阿的资源论,顾名思义,是把着眼点放在资源上。他们研究了六类资源:爱、服务、地位、信息、货物和金钱;它们之间的区别在于有不同的特殊性或普遍性,不同的具体性或抽象性。而后,资源论对指导上述各类资源交换的可变因素进行了讨论。

    决策

      行为是受动机状态支配的;一旦资源量低于或超出最佳度,人们就有了采取某种行为的动机。资源量的最佳度有上限和下限,上限度是指人们对某一资源感到饱和从而激发将该资源与其他资源作交换的动机,下限度则是指人们对某一资源感到需要或不足因而激发了获取该资源的动机。各类资源的最佳度各不相同。一般认为,爱的最佳度跨度很小;服务和地位的最佳度跨度大于爱,但小于货物和信息;金钱的最佳度跨度最大,其上限接近无限。

      当某人的资源高出最佳度,此人就有可能进入交换,以谋取其他资源。因为他拥有剩余的资源,所以他具有潜在的权势。但是潜在的权势转变为真实的权势,其前提是他人需要这一资源,例如,尽管某人有能力提供某项服务,却无人需要,他在交换中也就无权势可言。 因此,刺激行为选择的基本机制就是关于获取或放弃某 p53·

    一资源的需求

    交换模式

      E .福阿和 U ·福阿对规定指导资源交换的规则感兴趣。他们提出了两个命题:“ (1) 每一人际行为都含有一项或多项资源的给予以及 ( 或者 ) 拿取; (2) 涉及类似资源的交换行为比涉及不太相似的资源的交换行为更经常地发生”。

      上述两个命题中,第二个命题对预测资源交换更为重要。这一命题的假设是:人们通常把某一资源看作与其他资源比较类似,或者不那么类似。爱与地位、服务相类似。与货物、信息不那么类似,与金钱最不类似。实际上,爱、地位与服务十分类似,可以在同一行为中同时交换。

      有关的调查研究 ( 见 E ·福阿与 U ·福阿, 1974 年, 1976 年 ) 在很大程度上证明了他们的论点。对调查的回答表明,人们倾向于进行同类资源的交换,即以爱换爱、以金钱换金钱。这种倾向在特殊性的资源 ( 如爱、地位、服务 ) 交换中最为突出,在普遍性的资源 ( 如货物、金钱 ) 交换中不甚突出。信息虽然具有普遍性,但也往往是同类交换。关于类似资源之闻比较易于交换的预测也是正确的;假若某人没有得到同类的资源作为回报,他也比较喜欢得到类似的资源,例如用货物交换金钱,用地位交换爱。调查的回答还表明,交换关系的形式对资源的交换有影响。例如,友谊关系最有可能发生爱的交换、地位的交换、信息的交换以及服务的交换,而不大可能发生货物的交换或者金钱的交换。若考察一下那些性质不明的关系,就会发现金钱的交换以及货物的交换占有极大的比例。 p · 54·

      对实际的交换关系的研究也证实了这一理论。在.一次实验中,实验对象给予他人一种资源,但得到的回报均是金钱,或爱的表示。正如这一理论所预测的,如果交换的回报不相类似,人们对交换的满意度就较低。

      E·福阿和 U·福阿也研究了拒绝接受或拒绝给予资源的现象。人们总是试图拒绝给予类似于当初曾被夺走的资源,这一点是可以预料的,也是得到证实的。虽然拒绝给予爱被普遍地作为报复的武器,但人们一般倾向于用同样的方法来进行报复。对实际的交换进行研究表明,人们拒绝给予曾被夺走的类似的资源。有趣的是,当某人被迫用极不类似的资源进行报复时 ( 如用金钱作为对爱情的报复 ) ,此人往往会增加否定对方的强度。这一结果似可显示,只有增加不类似的资源的数量,才能对这种损失作充分的补偿。因此一个遭到抛弃的情人可能连“朋友”之情都不给对方,从而达到心境的平静。假若这/ 1 情人对对方一往情深以至于对方不可能不报之以情,他 ( 她 ) 也就不会用不类似的资源来报复。不过,我有一个学生曾提出过一个有趣的变异情况。他认为报复负心人的最好办法是去对他 ( 她 ) 说:“瞧,咱们就这么匆匆忙忙地分手了,我心里真不好过,我还没机会偿还你给我的全部爱情和欢愉呢,所以我现在给你二毛五分钱 ! ”

      由此可见,有人在使用不类似的资源报复他人时,可能通过增加其拒绝的强度来获得补偿。不过,研究结果表明,此人即使增加了强度,仍然感到灰心丧气。

      E ·福阿和 U ·福阿为我们阐明了交换的各类资源,也描述了它们是如何交换的。他们所作的调查研究看来证实了他们的理论。 p · 55·

    E ·沃尔斯特、贝尔谢德和 G ·沃尔斯特的公平说

      公平说曾经引起大量实验式的研究,沃尔斯特等人曾记载了各种不同学科对其理论所作的研究,计四百多项。他们对公平说的阐述主要集中在一篇论著 (1976 年 ) 和一部专著 (1978 年 ) 即《公平;理论与研究》中。

    理论基础

      公平说并不是被作为单一的社会交换理论提出来的;沃尔斯特等三人和 E ·福阿与 u ·福阿一样,希望能建立一门综合各种心理学理论的学说,他们不想陷入单一理论的陷阱.力图创建一个社会交往的总体理论。

      公平说的基本观点来自其他社会交换理论家。如前所述,霍曼斯和布劳都探讨过公正分配的概念。概括地说,公正分配所描述的,就是与他人投资相同而后果较差时所作出的反应。

      亚当斯首先将公正分配观点发展成早期的公平论,它认为,公平是指某人从某一关系中获取的后果与输入之比 ( 大致来说即回报与代价之比 ) 与关系对方获取的后果与输入之比相等,与同关系对方发生交换关系的他人获取的后果与输入之比相等,也与处于类似关系中的其他人获取的后果与输入相等;如不相等,此人就感到不快。在交换关系中处在不公平地位的人可能变更输入和后果,或在认知上曲解输入和输出,或中止交换,或改变对对方输入输出的看法,或寻求新的交换对象,以建立公平关系。亚当斯提出的理论体系引起了众多的研究,也启发了沃尔斯特等人. p ·56‘ 决策

      沃尔斯特等人提出了一些具体的命题。他们的理论核心是:人是自私的,都按私利行事。这一观念反映在命题 (J) 中:“人们总是试图最大限度地取得后果 ( 即回报减去代价 ) ”。因此,人们寻求最大限度的利益,这是和其他社会交换理论不谋而合的。

      不过,他们的推沦又加上了一个多少不同的意外转折:“人们只要认为可以通过公平的行为来得到最大限度的后果,就会采取公平的行为;人们如果认为可以通过不公平的行为来得到最大限度的后果,也就会采取不公平的行为”。人们只是根据能否得到最大限度的后果来调节行为,而不考虑行为对他人的影响。如果为了取得利益要求公平行事,他们会照着做的;但如果为取得成功而需要搞款骗利用一套,他们也会干的。

      讲到这里,有必要研究一下他们给公平所下的定义。所谓公平的关系,是指关系的一方或局外人认为关系双方从该交换关系中获得的相对利益是等值的。这里的相对利益,意即对于表示双方所获净利的比率所作的一种比较;这一比率是:关系后果与输入之差除以输入的绝对值所得的结果。若将关系双方的这一比率作一比较,就可能了解该关系中的利益分配是否公平;至少是通过该关系的旁观者的仔细检查,来看利益分配是否公平。

    交换模式

      关于交换模式,公平说认为最佳利益的获取具有一定的 p·57· 灵活性,但是公平说又认为,获取最佳利益的途径经常是受他人影响的,公平说的命题接着又描述了人们是如何决策的。

      人们在交换关系中作出的决定是否公平,起作用的因素之一是社会。沃尔斯特等人提出的第二个命题 (A) 是:“社会群体可以在其成员之间逐渐建立一些公认的公平分配资源的体系,从而为自己获取最大限度的回报,因此,社会群体将逐渐形成这样的公平体系,并会促使其成员接受和遵守这样的体系”。第二个命题 (B) 是:“一般来说,社会群体会惩罚 ( 即加重代价 ) 不公平对待他人的成员”。人们懂得,如果社会成员之间能相互提供利益,而不是单方面地达到自我目的,那么社会将是比较稳定的。因此,社会制订了规则和正式的法律以保证在交换关系中确立某种公平的交换。无疑离婚法就可以看作是确保婚姻关系中财产与货物公平分配的一种尝试。

      由于存在着社会惩罚和关系一方报复的潜在可能,所以当出现不公平现象时人们的反应是苦恼,因而谋求恢复公平的关系。第三个命题指出:“当人们发现自己处在不公平关系之中时,会感到苦恼;这一关系越是不公平,人们越感到苦恼”。第四个命题描述了苦恼之后的反应:“发现处于不公平关系的人试图恢复公平关系,以求消除苦恼。不公平现象越是严重,人们越是苦恼,越是努力试图恢复公平关系”。

      公平说预言,尽管在某些关系中会出现不公平和为私利而利用他人的现象,但这种现象不会持久。社会和关系中的对方会因此而采取措施来恢复公平关系。我们将在第四章探讨恢复公平关系的愿望和人际冲突之间的关系,现在只要知道人们是会采取某种措施来恢复公平关系的。

      综上所述,我们己经探讨了五种社会交换理论的基础,关 p ·58· 于决策的论述,以及交换模式。霍曼斯从操作心理学原理出发,提出了解释人际社会交换的命题;布劳着眼于交换的发生特性,并应用了经济学的原理;蒂博特和凯利考察了人们是如何评估关系后果,以及关系后果如何产生于关系双方的相互依赖。他们指出人们能够将他们的行为选择和结果转变为符合他们意向的一种策略。 E ·福阿和 u ·福阿描述了导致交换的发展过程,以及指导资源交换的规则;最后,沃尔斯特等人着重研究了关系之中的回报分配。人们既有谋取利益的动机,又由于社会准则及关系对方的关注而注意关系中利益的公平分配。 p · 59·

     

     



             

    展开全文
  • Flink中task之间的数据交换机制

    万次阅读 2016-04-24 20:31:08
    Flink中的数据交换构建在如下两条设计原则之上: 数据交换的控制流(例如,为实例化交换而进行的消息传输)是接收端初始化的,这非常像最初的MapReduce。 数据交换的数据流(例如,在网络上最终传输的数据)被抽象成...
  • 以太网交换原理

    千次阅读 2014-02-17 20:12:40
    以太网交换原理 本文力求阐明以太网交换原理,并对相关知识作以介绍。 1 以太网交换机相关概念 1.1 传统的电话交换技术 交换概念始于电话交换。传统电话网由传输电路与电话交换机组成,处于网络节点的交换机...
  • 视觉SLAM笔记(49) 后端状态估计

    万次阅读 2019-11-12 08:36:51
    误差累积、状态估计的概率解释、所关心的问题、最大似然估计
  • 安全隔离与信息交换读书笔记

    千次阅读 2016-06-24 15:45:43
    本着吸收理解而不是随学随忘的精神,了本篇读书笔记,如有侵权,请联系我。 本文其实主要就两个部分,第三章是各种交换平台实现原理的框架图或结构图,而第五章就是一些对未来做项目有帮助的典型部署。 2. 概述...
  • TCP连接的状态详解以及故障排查

    万次阅读 多人点赞 2014-08-20 07:06:38
    我们通过了解TCP各个状态,可以排除和定位网络或系统故障时大有帮助。(总结网络上的内容) 1、TCP状态 了解TCP之前,先了解几个命令: linux查看tcp的状态命令: 1)、netstat -nat 查看TCP各个状态的数量 2)...
  • Broadcom以太网交换芯片培训

    万次阅读 热门讨论 2011-06-15 14:58:00
    Broadcom以太网交换芯片培训---- 目录1、 交换芯片架构 2、 L2转发流程 2.1 L2转发原理 2.2 L2转发相关的项 2.2.1 port 2.2.2 egress port 2.2.3 L2地址 2.2.3 VLAN 3、 L3转发流程 4、 L2组播转发流程 5...
  • BGP状态机及其总结

    千次阅读 多人点赞 2020-06-18 13:03:56
    成功是留给有准备的人。 文章目录 一、拓扑 二、基础配置 三、BGP状态停留测试 四、总结 4.1 BGP5种报文类型 4.2 BGP状态机 4.3 BGP邻居的建立 4.4 BGP邻居关系建立 4.5 BGP路由属性及所属类型
  • Marvell交换芯片88E6390驱动开发

    千次阅读 2020-02-22 11:28:17
    参考 Marvell交换芯片88E6321/88E6320驱动总结-...Marvell 交换芯片DSA(分布式交换架构)功能介绍 以太网交换芯片及PHY处理相关 二层交换机和三层交换机的区别 介绍 Marvell 88E6390是一款11端口全千兆以太网二层交...
  • 程序: mov ax,1000H mov ss,ax mov sp,0010H ;设置AX和BX的值 mov ax,001AH mov bx,001BH ...在8086中,段寄存器不能直接传值,要通过一般...此时bx的值在上面,ax的值在下面,所以要交换值,只需先 pop ax就行
  • CDH大数据平台内存交换,警告问题

    千次阅读 2020-07-30 18:21:56
    CDH长时间运行,Cloudera Manager管理页面在运行Spark任务时候经常会出现内存交换警告,前期博主直接忽略,毕竟不是什么大问题,后期发现如果长时间黄色警告不处理,会误导页面查看集群状态,并且交换空间所占用磁盘...
  • 交换两个整型变量(不借助临时变量)这是多年前我做Java时面试碰到的题目,其实不难。特意下这篇博客,是因为我发现有不止一种方法可以实现,原谅我无聊的双手。图1先简单说说普通的方法吧,如上图:int i = 5;int p...
  • Linux--缺页中断和交换技术

    千次阅读 2013-06-25 11:11:43
    1.请求调页中断:进程线性地址空间里的页面不必常驻内存,例如进程的分配请求被理解满足,空间仅仅保留vm_area_struct的空间,页面可能被交换到后援存储器,或者一个只读页面(COW)。Linux采用请求调页技术来解决...
  • 1.1.1 数据交换工具Wormhole设计与实现 1.1.1.1 Wormhole整体设计 Wormhole是框架加插件的设计,各模块的设计思路: 1) 框架分为读管理器、双端缓冲队列和管理器。读写管理器分别持有读写线程池,双端缓冲队列...
  • 读取“线圈状态

    千次阅读 2018-07-27 17:19:49
    ModBus是通过功能码来实现数据的交换通信的。读取“线圈状态”就是读出数字量输出的位是true还是false。Modbus可以读写四种类型的数据。分别是 读取数量量输入位 读写数字量输出位 读取输入寄存器 读写输出寄存器...
  • VMWARE 中 LINUX 于WINDOWS 交换文件的五种方法 第一种 采用NETBIOS协议。在linux安装了samba 。 smbmount //IP/sharename / mount point  NETBIOS 毕竟稳定性不够。有时候会挂载不上。还需要特别注意打开...
  • 通信工程交换传输实习报告

    千次阅读 2017-10-07 15:17:43
    序言  本学期的3-5周,我们进行了为期3周的专业实习,本次实习的内容是程控交换和光纤传输,实习地点是云塘校区理科楼B304程控交换实验室。   实习的形式是老师讲述理论知识,然后同学分组参观设备,将老师所讲...
  • Java 如何用方法交换两个变量的值

    千次阅读 2018-01-16 09:19:06
    在学习C++的时候,我们需要学习如何用指针和方法来交换两个变量的值,比如swap(int*, int*)。而当我学习Java的时候,因为没有指针,所以我们需要另求他法。这引起了我下面的思考: (1)方法不能修改基本类型的...
  • SWAP交换分区的建立及删除

    千次阅读 2017-04-24 20:53:03
    SWAP交换分区的建立及删除
  • Linux 操作系统状态查看及调优

    万次阅读 2021-07-17 07:34:41
    -u:CPU 利用率 -v:进程、I 节点、文件和锁表状态。 -d:硬盘使用报告。 -r:没有使用的内存页面和硬盘块。 -g:串口 I/O 的情况。 -b:缓冲区使用情况。 -a:文件读写情况。 -c:系统调用情况。 -R:进程的活动...
  • Linux系统增加交换空间的方法

    千次阅读 2017-02-05 17:54:26
    增加交换空间有两种方法: 严格的说,在系统安装完后只有一种方法可以增加swap,那就是本文的第二种方法, 至于第一种方法应该是安装系统时设置交换区。 1、使用分区:  在安装OS时划分出专门的交换分区...
  • 传输与交换

    千次阅读 2005-12-01 15:37:00
    工作原理:要将入线的TS5(时隙为5)经过T交换到出线的TS20上,在控制存储器的第20号单元写入5,然后按控制存储器内单元的数值去到话音存储器的相应时隙位置去读语音信息,到出线上。这叫控制存储器控制写入、顺序...
  • Linux SWAP 交换分区配置说明

    万次阅读 2013-03-31 05:10:48
    一.SWAP 说明 1.1 SWAP 概述当系统的物理内存不够用的时候,就需要将物理内存中的一部分空间释放出来,以供当前...这样,系统总是在物理内存不够时,才进行Swap交换。 这个是SWAP 交换分区的作用。 实际上,我们更关
  • 并且,交换技术大多是索引定位技术,而不是搜索技术,因为搜索算法依赖很多中间状态,而在硬件上,很难维护有状态的系统或者说需要大量的空间维护状态信息。我们可以通过CPU Cache来理解交换机制,交换表可以看作是...
  • BCM56330系列交换芯片学习心得

    万次阅读 2017-07-17 17:34:41
    因为所里面的任务的要求,所以要学习学习BCM交换芯片,导师也说过,学习BCM芯片的Datasheet或者Programmer guider是对以后是很有好处的,所以我就奔着学习英语的心态开始学习BCM56330交换芯片。我学习的是BCM56330 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 242,197
精华内容 96,878
关键字:

交换表的状态怎么写