精华内容
下载资源
问答
  • 交换机查看端口镜像
    2021-04-02 12:20:43

    应用场景
    端口镜像是指:将经过指定端口的报文复制一份到另一个指定端口。
    在网络运营和维护中,为了便于业务监测和故障定位,网络管理员需要获取设备上的业务报文进行分析。

    镜像可以在不影响设备对报文进行正常处理的情况下,将镜像端口的报文复制一份到观察端口,网络管理员可以通过监控设备分析观察端口的报文,判断网络中的业务是否正常

    配置思路

    1. 将交换机连接监控设备的端口配置成观察端口
      observer-port 1 interface g0/0/10
    2. 将报文流经的端口配置成镜像端口,将接受或发送报文的方向绑定到观察端口
      int g0/0/7
      port-mirroring to observer-port 1 inbound
      (监测入方向流量是inbound,双向监测是both)
    3. 在监控设备上启用监控软件,获取镜像报文
      例如用wireshark抓包(选择对应的网卡)
    更多相关内容
  • 2 S3X00V2_S3110系列交换机本地端口镜像配置方法(命令行版) 3 S3X00V3系列交换机本地端口镜像配置方法(WEB版) 4 S3X00V3系列交换机本地端口镜像配置方法(命令行版) 5 S6X00系列交换机本地端口镜像配置方法...
  • 当需要现场对设备进行流量抓包分析时,就可以采用端口镜像技术对流量做端口镜像
  • SPAN:本地设备端口监控,当所有被监听的源端口与目的端口同处于一台交换机上,SPAN会话被称为本地SPAN。 Switch(config)#monitor session 1 source interface fastEthernet 0/0 tx //后面参数tx意思是监控0/0接口...

    SPAN:本地设备端口监控,当所有被监听的源端口与目的端口同处于一台交换机上,SPAN会话被称为本地SPAN。

    Switch(config)#monitor session 1 source interface fastEthernet 0/0 tx   //后面参数tx意思是监控0/0接口发送的流量,默认为both,即监控收发的流量

    Switch(config)#monitor session 1 destination interface fastEthernet 0/1   //把session 1里面接口(fastEthernet 0/0)的流量复制一份发送到fastEthernet 0/1,destination fa0/1接口不能正常收发流量,只能接收镜像过来的流量

     

    RSPAN:远端的设备端口口监控;源端口和目的端口不在同一台交换机上。

     

    在源端口交换机上配置:

    Switch1(config)#vlan100   //vlan号必须独立于现网使用的vlan,不能和业务vlan相同,

    Switch1(config-vlan)#name SPAN-VLAN   //为vlan 100名字配置为SPAN-VLAN

    Switch1(config-vlan)#remote-span   //模式改成RSPAN,特殊vlan用来做端口镜像

    Switch1(config)#monitor session 2 source interface Gig 0/1   //配置要抓取原端口的流量

    Switch1(config)#monitor session 2 destination remote vlan 100   //目的端口配置为SPAN的vlan

     

    在目的端口交换机上配置:

    Switch2(config)#vlan100   //vlan要和被抓取流量端口的交换机vlan要一致

    Switch2(config-vlan)#name SPAN-VLAN   //为vlan 100名字配置为SPAN-VLAN

    Switch2(config-vlan)#remote-span   //模式改成RSPAN,特殊vlan用来做端口镜像

    Switch2(config)#monitor session 3 destination interface Gig 0/2   //配置要抓取原端口的流量,这里的session 号不需要和Switch1的一致

    Switch1(config)#monitor session 3 source remote vlan 100   //目的端口配置为SPAN的vlan号

     

    Switch#show monitor   //查看端口镜像配置

     

    参考思科官网:https://www.cisco.com/c/zh_cn/support/docs/switches/catalyst-6500-series-switches/10570-41.html

    展开全文
  • 华为交换机端口镜像功能,想要配置端口镜像或者删除端口镜像,该怎么实现呢》下面我们就来看看详细的教程,很简单,需要的朋友可以参考下
  • cisco交换机端口镜像的配置.pdf
  • 华为各种型号交换机端口镜像配置方法总结
  • H3C交换机端口镜像方法汇总

    千次阅读 2020-12-20 19:25:14
    一、端口镜像概念:Port Mirror(端口镜像)是用于进行网络性能监测。可以这样理解:在端口A 和端口B 之间建立镜像关系,这样,通过端口A 传输的数据将同时复制到端口B ,以便于在端口B 上连接的分析仪或者分析软件...

    一、端口镜像概念:

    Port Mirror(端口镜像)是用于进行网络性能监测。可以这样理解:在端口A 和端口B 之间建立镜像关系,这样,通过端口A 传输的数据将同时复制到端口B ,以便于在端口B 上连接的分析仪或者分析软件进行性能分析或故障判断。

    二、端口镜像配置

    『环境配置参数』

    1. PC1接在交换机E0/1端口,IP地址1.1.1.1/24

    2. PC2接在交换机E0/2端口,IP地址2.2.2.2/24

    3. E0/24为交换机上行端口

    4. Server接在交换机E0/8端口,该端口作为镜像端口

    『组网需求』

    1. 通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。

    2. 按照镜像的不同方式进行配置:

    1) 基于端口的镜像

    2) 基于流的镜像

    2 数据配置步骤

    『端口镜像的数据流程』

    基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。

    【3026等交换机镜像】

    S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像,有两种方法:

    方法一

    1. 配置镜像(观测)端口

    [SwitchA]monitor-port e0/8

    2. 配置被镜像端口

    [SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2

    方法二

    1. 可以一次性定义镜像和被镜像端口

    [SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2 observing-port Ethernet 0/8

    【8016交换机端口镜像配置】

    1. 假设8016交换机镜像端口为E1/0/15,被镜像端口为E1/0/0,设置端口1/0/15为端口镜像的观测端口。

    [SwitchA] port monitor ethernet 1/0/15

    2. 设置端口1/0/0为被镜像端口,对其输入输出数据都进行镜像。

    [SwitchA] port mirroring ethernet 1/0/0 both ethernet 1/0/15

    也可以通过两个不同的端口,对输入和输出的数据分别镜像

    1. 设置E1/0/15和E2/0/0为镜像(观测)端口

    [SwitchA] port monitor ethernet 1/0/15

    2. 设置端口1/0/0为被镜像端口,分别使用E1/0/15和E2/0/0对输入和输出数据进行镜像。

    [SwitchA] port mirroring gigabitethernet 1/0/0 ingress ethernet 1/0/15

    [SwitchA] port mirroring gigabitethernet 1/0/0 egress ethernet 2/0/0

    『基于流镜像的数据流程』

    基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。

    【3500/3026E/3026F/3050】

    〖基于三层流的镜像〗

    1. 定义一条扩展访问控制列表

    [SwitchA]acl num 100

    2. 定义一条规则报文源地址为1.1.1.1/32去往所有目的地址

    [SwitchA-acl-adv-101]rule 0 permit ip source 1.1.1.1 0 destination any

    3. 定义一条规则报文源地址为所有源地址目的地址为1.1.1.1/32

    [SwitchA-acl-adv-101]rule 1 permit ip source any destination 1.1.1.1 0

    4. 将符合上述ACL规则的报文镜像到E0/8端口

    [SwitchA]mirrored-to ip-group 100 interface e0/8

    〖基于二层流的镜像〗

    1. 定义一个ACL

    [SwitchA]acl num 200

    2. 定义一个规则从E0/1发送至其它所有端口的数据包

    [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2

    3. 定义一个规则从其它所有端口到E0/1端口的数据包

    [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1

    4. 将符合上述ACL的数据包镜像到E0/8

    [SwitchA]mirrored-to link-group 200 interface e0/8

    【5516/6506/6503/6506R】

    目前该三款产品支持对入端口流量进行镜像

    1. 定义镜像端口

    [SwitchA]monitor-port Ethernet 3/0/2

    2. 定义被镜像端口

    [SwitchA]mirroring-port Ethernet 3/0/1 inbound

    【补充说明】

    1. 镜像一般都可以实现高速率端口镜像低速率端口,例如1000M端口可以镜像100M端口,反之则无法实现

    2. 8016支持跨单板端口镜像端口镜像配置

    『环境配置参数』

    1. PC1接在交换机E0/1端口,IP地址1.1.1.1/24

    2. PC2接在交换机E0/2端口,IP地址2.2.2.2/24

    3. E0/24为交换机上行端口

    4. Server接在交换机E0/8端口,该端口作为镜像端口

    『组网需求』

    1. 通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。

    2. 按照镜像的不同方式进行配置:

    1) 基于端口的镜像

    2) 基于流的镜像

    2 数据配置步骤

    『端口镜像的数据流程』

    基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。

    【3026等交换机镜像】

    S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像,有两种方法:

    方法一

    1. 配置镜像(观测)端口

    [SwitchA]monitor-port e0/8

    2. 配置被镜像端口

    [SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2

    方法二

    1. 可以一次性定义镜像和被镜像端口

    [SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2 observing-port Ethernet 0/8

    【8016交换机端口镜像配置】

    1. 假设8016交换机镜像端口为E1/0/15,被镜像端口为E1/0/0,设置端口1/0/15为端口镜像的观测端口。

    [SwitchA] port monitor ethernet 1/0/15

    2. 设置端口1/0/0为被镜像端口,对其输入输出数据都进行镜像。

    [SwitchA] port mirroring ethernet 1/0/0 both ethernet 1/0/15

    也可以通过两个不同的端口,对输入和输出的数据分别镜像

    1. 设置E1/0/15和E2/0/0为镜像(观测)端口

    [SwitchA] port monitor ethernet 1/0/15

    2. 设置端口1/0/0为被镜像端口,分别使用E1/0/15和E2/0/0对输入和输出数据进行镜像。

    [SwitchA] port mirroring gigabitethernet 1/0/0 ingress ethernet 1/0/15

    [SwitchA] port mirroring gigabitethernet 1/0/0 egress ethernet 2/0/0

    『基于流镜像的数据流程』

    基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。

    【3500/3026E/3026F/3050】

    〖基于三层流的镜像〗

    1. 定义一条扩展访问控制列表

    [SwitchA]acl num 100

    2. 定义一条规则报文源地址为1.1.1.1/32去往所有目的地址

    [SwitchA-acl-adv-101]rule 0 permit ip source 1.1.1.1 0 destination any

    3. 定义一条规则报文源地址为所有源地址目的地址为1.1.1.1/32

    [SwitchA-acl-adv-101]rule 1 permit ip source any destination 1.1.1.1 0

    4. 将符合上述ACL规则的报文镜像到E0/8端口

    [SwitchA]mirrored-to ip-group 100 interface e0/8

    〖基于二层流的镜像〗

    1. 定义一个ACL

    [SwitchA]acl num 200

    2. 定义一个规则从E0/1发送至其它所有端口的数据包

    [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2

    3. 定义一个规则从其它所有端口到E0/1端口的数据包

    [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1

    4. 将符合上述ACL的数据包镜像到E0/8

    [SwitchA]mirrored-to link-group 200 interface e0/8

    【5516/6506/6503/6506R】

    目前该三款产品支持对入端口流量进行镜像

    1. 定义镜像端口

    [SwitchA]monitor-port Ethernet 3/0/2

    2. 定义被镜像端口

    [SwitchA]mirroring-port Ethernet 3/0/1 inbound

    展开全文
  • 如何在华三交换机配置本地端口镜像和远程端口镜像 在平时的工作中,经常需要通过日志审计设备/行为管理设备/流量分析系统设备,对网络设备上的报文流量进行分析,以了解整个网络的运行情况,这时就需要通过端口镜像...

    如何在华三交换机配置本地端口镜像和远程端口镜像

    在平时的工作中,经常需要通过日志审计设备/行为管理设备/流量分析系统设备,对网络设备上的报文流量进行分析,以了解整个网络的运行情况,这时就需要通过端口镜像的技术通过把源端口的流量复制一份到目的观察端口。管理员就可以对这些镜像报文进行监控和分析。
    一般一个镜像组内可以配置多个源端口。但一个端口通常只能被一个镜像组使用。

    可分为本地端口镜像和远程端口镜像(可适用一个源端口镜像给多目的端口时)

    一,本地端口镜像—源端口方式
    在这里插入图片描述

    如图所示,交换机GE1/0/2和GE1/0/3口为被镜像的源端口,流量被镜像到目的端口GE1/0/4,4口下联流量分析设备。

    配置步骤:

    1.创建本地镜像组
    [SW]mirroring-group 1 local

    2.配置本地镜像组1的源端口为GE1/0/2和GE1/0/3,并镜像两端口的双向流量。
    [SW]mirroring-group 1 mirroring-port GigabitEthernet 1/0/2 to GigabitEthernet 1/0/3 both

    3.配置本地镜像目的观察端口为GE1/0/4。
    [SW]mirroring-group 1 monitor-port GigabitEthernet 1/0/4

    4.在目的端口GE1/0/4上关闭生成树协议,以免影响镜像功能的正常使用。
    [SW]interface GigabitEthernet 1/0/4
    [SW-GigabitEthernet1/0/4]undo stp enable

    5.使用display mirroring-group all查看镜像组的配置信息。

    在这里插入图片描述

    =============================================================================

    二,配置远程端口镜像(可适用一个源端口镜像给多目的端口时)
    在配置镜像时,经常会遇到一个端口需要镜像流量给几个不同的审计和流量分析设备,但有的交换机却不支持一个源端口镜像给多目的端口,此时即可用远程端口镜像,把源交换机端口的流量镜像到远端的目的交换机,多个审计分析设备连接到目的交换机上即可获取到源交换机端口的镜像流量。
    在这里插入图片描述

    如图,SWA为源设备,GE1/0/3为被镜像的源端口,GE1/0/2为出口,GE1/0/6为反射端口。SWB为中间设备,SWC为目的设备,GE1/0/2为目的端口,下联流量分析设备。

    1.配置SWA源设备

    创建远程源镜像组
    [SWA]mirroring-group 1 remote-source

    创建vlan30,并关闭mac地址学习功能
    [SWA]vlan 30
    [SWA-vlan30]undo mac-address mac-learning enable

    配置远程源镜像组的远程镜像vlan为vlan30,并配置源端口GE1/0/3和反射端口GE1/0/6
    [SWA]mirroring-group 1 remote-probe vlan 30
    ^
    [SWA]mirroring-group 1 mirroring-port GigabitEthernet 1/0/3 both //配置镜像源端口双向流量
    [SWA]mirroring-group 1 reflector-port GigabitEthernet 1/0/6 //配置反射端口

    配置出端口并放通相应vlan

    [SWA]interface GigabitEthernet 1/0/2
    [SWA-GigabitEthernet1/0/2]port link-type trunk
    [SWA-GigabitEthernet1/0/2]port trunk permit vlan 30


    2.配置SWB中间设备

    创建远程镜像vlan,并关闭mac地址学习功能
    [SWB]vlan 30
    [SWB-vlan30]undo mac-address mac-learning enable

    配置GE1/0/1类型为trunk,并放通vlan30报文通过
    [SWB]interface GigabitEthernet 1/0/1
    [SWB-GigabitEthernet1/0/1]port link-type trunk
    [SWB-GigabitEthernet1/0/1]port trunk permit vlan 30

    配置GE1/0/2类型为trunk,并放通vlan30报文通过
    [SWB]interface GigabitEthernet 1/0/2
    [SWB-GigabitEthernet1/0/2]port link-type trunk
    [SWB-GigabitEthernet1/0/2]port trunk permit vlan 30

    3.配置SWC为目的设备

    创建远程目的镜像组
    [SWC]mirroring-group 1 remote-destination

    创建远程镜像vlan,并关闭mac地址学习功能
    [SWC]vlan 30
    [SWC-vlan30]undo mac-address mac-learning enable

    创建远程镜像组的远程镜像vlan为vlan30,并配置目的端口GE1/0/2
    [SWC]mirroring-group 1 remote-probe vlan 30

    配置目的端口
    [SWC]interface GigabitEthernet 1/0/2
    [SWC-GigabitEthernet1/0/2]mirroring-group 1 monitor-port //配置为目的端口
    [SWC-GigabitEthernet1/0/2]undo stp enable //接口下关闭stp
    [SWC-GigabitEthernet1/0/2]port access vlan 30 //把端口加入vlan

    配置入端口GE1/0/1类型为trunk,并放通vlan30通过
    [SWC]interface GigabitEthernet 1/0/1
    [SWC-GigabitEthernet1/0/1]port link-type trunk
    [SWC-GigabitEthernet1/0/1]port trunk permit vlan 30

    4.查看配置
    使用命令display mirroring-group all分别在SWA和SWC上查看配置信息
    SWA
    在这里插入图片描述

    SWC
    在这里插入图片描述

    展开全文
  • 华为交换机设置端口镜像捕获数据包 1.登录交换机 在MobaXterm中选择telnet会话,采用telnet协议登录交换机。 2.添加镜像组 输入sys命令进入编辑模式。 添加镜像组,2为镜像组的标号 mirroring-group 2 local 3....
  • 什么是端口镜像 简而言之就是将一个端口的配置,参数,数据等 复制到一定指定的目的端口上面,通过镜像的原理可以在当前端口上进行在线的监控被复制端口上的一切数据 以及异常啥的。以便于能够快速的进行错误诊断。 ...
  • 镜像可以在不影响设备对报文进行正常处理的情况下,将镜像端口的报文复制一份到观察端口。网络管理员通过网络监控设备就可以分析从观察端口复制过来的报文,判断网络中运行的业务是否正常。......
  • 交换机端口镜像技术

    千次阅读 2022-01-02 23:34:54
    交换机端口镜像技术 参考资料:https://blog.csdn.net/qq_38265137/article/details/80404306 在某些场景中,我们可能需要监控交换机特定端口的入站或出站报文。 镜像简介 镜像是指将经过指定端口(源端口或者...
  • 查看交换机配置信息:display current-configuration 删除VLAN:undo vlan 5 创建vlan:vlan 5 将端口加入到vlan中:port GigabitEthernet 1/0/20 to GigabitEthernet 1/0/23 进入vlan管理:interface vlan-...
  • 分布式交换机端口镜像

    千次阅读 2019-12-12 00:16:45
    而没有将流量转发到上行链路(连物理交换机的端口),我的思路是这样的,先将虚拟机的端口直接镜像给一个上行链路,然后再在交换机上将这个上行链路再做一个端口镜像到另外的交换机端口(用于流量分析)。...
  • 锐捷S12010交换机配置端口镜像

    千次阅读 2020-05-20 12:11:33
    端口镜像需在全局配置模式下进行配置镜像目标接口,此接口用于镜像报文出口monitor session 1 destination interface GigabitEthernet 1/10配置被镜像口,both是方向出入都镜像,如果有多个口要被镜像可配置多次...
  • 华为交换机:交换机端口镜像技术

    千次阅读 2020-11-14 16:20:03
    交换机端口镜像技术 参考资料:https://blog.csdn.net/qq_38265137/article/details/80404306 在某些场景中,我们可能需要监控交换机特定端口的入站或出站报文。 镜像简介 镜像是指将经过指定端口(源端口或者...
  • 交换机镜像端口

    千次阅读 2022-03-24 12:04:42
    交换机镜像端口 示例: 交换机1口作为观察口,连接pc 使用wireshark抓包 3~13口是要抓包的口 华三交换机 [H3C]mirroring-group 1 local //创建本地镜像端口组1 [H3C]mirroring-group 1 mirroring-port ...
  • 交换机B将镜像端口g0/0/1的流量发送到观察端口g0/0/2;
  • CISCO交换机端口镜像配置

    千次阅读 2021-11-05 16:29:16
    在思科交换机上做镜像端口 1、镜像配置 配置镜像端口 >enable #conf t (config)#monitor session 1 source interface fastethernet 5/48 最后可接参数 both 双向监控 rx 接收 tx 发送 配置目的端口 ...
  • 交换机端口镜像配置(华为、华三)端口镜像应用场景设定华三交换机配置端口镜像华为交换机配置端口镜像 端口镜像应用场景设定 某企业近期为了加强网络安全防护,新购置了一台IDS网络安全检测设备,IDS检测设备的配置...
  • 1.1配置镜像(SPAN)端口 Switch(config)# monitor session 1 source interface fastethernet 4/10 Switch(config)# monitor session 1 filter vlan 57 Switch(config)# monitor session 1 destination interface ...
  • H3C交换机端口镜像配置命令汇总

    千次阅读 2020-12-21 15:40:19
    H3C交换机端口镜像配置命令汇总一、端口镜像概念:Port Mirror(端口镜像)是用于进行网络性能监测。可以这样理解:在端口A 和端口B 之间建立镜像关系,这样,通过端口A 传输的数据将同时复制到端口B ,以便于在端口B ...
  • H3C交换机配置端口镜像

    千次阅读 2020-07-11 21:16:33
    本文描述在H3C交换机中如何配置端口镜像
  • 本文介绍的是多个网口镜像到1个网口的现场操作 首先准备好连接线,网口转RS232线,USB转RS232线,有了这两根线,你可以从笔记本的USB口转到交换机console口 确保连接可靠,打开securecrt软件,进行和下图...
  • 交换机端口镜像RSPAN

    千次阅读 2019-04-09 17:18:01
    用户因为业务需求,要在两台交换机之间做端口镜像。我在本地搭了一个环境如下: 具体步骤如下:SW1:1、设置用于远程镜像的VLAN 2、将交换机的互联接口起TRUNK 3、配置monitor session SW2:1、设置用于远程镜像的...
  • cisco交换机端口镜像对网络其他交换机的端口进行镜像PPT学习教案.pptx
  • H3C交换机端口镜像

    千次阅读 2021-10-29 15:45:09
    需要将G0/0/1口的全部流量镜像到G0/0/2口,即G0/0/1为源端口,G0/0/2为目的端口。 配置步骤 1、进入配置模式:system-view; 2、创建本地镜像组:mirroring-group 1 local 3、为镜像组配置源端口:mirroring-...
  • 如何配置交换机端口镜像

    万次阅读 2018-08-07 20:38:15
    1先将交换机接通电源,console口与主机相连 2打开超级终端(windows7自带) 3弹出的填写位置信息界面点击取消 4. . 名称任意,图标选第一个,确定 5. . 选com1口 下一个界面选择还原为默认值,确定,这时...
  • 华为S5700交换机配置怎么端口镜像?今天我们通过电脑的com接口连接华为交换机为例,来显示交换机配置端口镜像的图文教程,过程很简单,需要的朋友可以参考下

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 15,329
精华内容 6,131
热门标签
关键字:

交换机查看端口镜像