精华内容
下载资源
问答
  • 交换机热备份
    2022-07-30 16:16:39

    目录

    一、热备份路由选择协议(HSRP)

    1.1 目标

    1.2 热备份路由协议概念

    1.3 HSRP组中成员

    1.3 虚拟MAC地址

    1.4 HSRP的消息

    1.5 工作原理

    1.6 HSRP状态与计时器

    1.7 配置的思路

    1.8 配置实例


    一、热备份路由选择协议(HSRP)

    热(两台设备都是开着的)

    1.1 目标

    1. 了解HSRP的相关概念
    2. 理解HSRP的工作原理
    3. 掌握HSRP的配置
    4. HSRP是思科私有协议,与之对应的是标准协议VRRP(虚拟路由器冗余协议)

    HSRP和VRRP主要作用:对路由器网关的备份

    冗余:备份

    负载:分摊工作

    1.2 热备份路由协议概念

    热备份路由选择协议(HSRP,Hot standby routing protocol):cisco私有协议,确保了当网络边缘设备或接入链路出现故障时,用户通信能迅速并透明地恢复,以此为IP网络提供冗余性(冗余就是备份的作用)。通过使用同一个虚拟IP地址和虚拟MAC地址,LAN网段上的两台或者多台路由器可以作为一台虚拟路由器对外提供服务。HSRP使组内的cisco路由器能互相监视对方的运行状态(router2要一直监视route1,router1一旦出现故障就自动把网关切到router2,但客户端的网关地址没有变,始终指向虚拟网关地址)。

    1.3 HSRP组中成员

    活跃路由器:转发发送到虚拟路由器的数据包,不断向组中发送Hello报文,表示活跃状态。

    备份路由器:监视 HSRP组的运行状态,并且当活跃路由器不能运行时(在规定时间内没有收到活跃路由器的Hello消息,判断为活跃路由器挂掉了),迅速承担起转发数据包的责任。

    备份路由器也传输Hello消息,告知组中所有路由器备份路由器的角色和状态变化

    虚拟路由器:向最终用户提供台可以连续工作的路由器。虚拟路由器配有它自己的IP地址和 MAC 地址,但并不实际转发数据包

    其他路由器:这些路由器监视 Hello消息,但不做应答。这些路由器转发任何经由它们的数据包但并不转发经由虚拟路由器的数据包

    设备需要跨网段通信时,首先是发送报文请求网关的MAC地址,再将报文发送给网关

    1.3 虚拟MAC地址

    48位二进制组成,前面24位是厂商编码,后面24位是序列号

    后24位:虚拟MAC地址的固定值(07AC)加上HSRP的组号(十六进制的两位表示

             例如组号位50 那么将16转化为16进制,为32 后24位就确定位07AC32

    虚拟MAC地址不需要设置,当设置完HSRP组号后。会自动生成虚拟MAC,所以自需要配置虚拟路由器的IP地址即可

    1.4 HSRP的消息

    采用UDP的协议,UDP效率高,能以最快的速度选出活备份、端口号是1985、采用组播方式发送,组播地址是224.0.0.2

    组播:表示网络中的一组设备  一对一组

    生命周期:TTL值=1,遇到路由器就停止发送

    1.5 工作原理

    HSRP组内的每个路由器都有指定的优先级(Priority),用于衡量路由器在活跃路由器选择中的优先程度。默认的优先级是100,它是用户配置中的可先项可以是0-255内的任何值。组中优先级最高的路由器将成为活跃路由器。

    活跃路由器替代虚拟路由器对数据流进行响应。如果末端主机发送了一个数据包到虚拟路由器的MAC地址,那么,活跃路由器将接收并且处理这个数据包。如果末端主机对虚拟路由器的IP地址发送 ARP解析请求,那么,活跃路由器将使用虚拟路由器的MAC地址进行应答。

    运行 HSRP的设备会发送和接收基于UDP (User Datagram Protocol,用数据报协议)的组播 Hello包,以检测路由器故障,并确定活跃路由器和备份路由器。一个组内的HSRP 路由器会从活跃路由器那里学到 Hello间隔、保持时间(Hold Time)和虚拟IP地址,就好像这些参数在每个路由器上进行了显示配置一样。

    如果活跃路由器由于预定的维修、电源故障或其他原因变得不可达,则备份路由器会在数秒内接替其功能。这种功能的接替在保持时间超时后发生

    1.6 HSRP状态与计时器

    六种状态

    1.初始状态
    2.学习状态
    3.监听0状态
    4.发言状态
    5.备份状态
    6.活跃状态

    提示:不是所有的HSRP路由都会经历所有状态,例如非备份路由就不会经历备份状态,非活跃路由就不会经历活跃状态

    初始状态

    最开始路由器都是初始状态,刚给端口配置IP,端口开启时,进入初始状态

    学习状态:

    该组员未设定虚拟IP地址,并等待从本组活动路由器发出的认证的 Hello 报文中学习得到自己的虚拟IP地址

    监听状态:

    该组员已得知或设置了虚拟IP地址,通过监听Hello 报文监视活跃/备份路由器,一旦发现活跃/备份路由器长时间未发送Hello报文,则进入发言(speak)状态,开始竞选

    发言状态:

    参加竞选活跃/备份路由器的组员所处的状态,通过发送Hello报文使竞选者间相互比较、竞争

    备份状态:

    组内备份路由器所处的状态,备份组员监视活跃路由器,准备随时在活跃路由器坏掉时接替活跃路由器。备份路由器也周期性发送 Hello报文告诉其他组员自己没有坏掉

    活跃状态:

    组内活跃路由器即负责虚拟路由器实际路由工作的组员所处的状态。活跃路由器周期性发送Hello报文告诉其他组员自己没有坏掉

    计时器

    Hello报文的间隔时间(默认是3 S)

    保持时间(10 S 对端路由器多久没有收到Hello报文,判断活跃路由坏掉)

    1.7 配置的思路

    设置组号(决定虚拟路由器MAC地址)

    优先级(确定活跃路由器,优先级最高的为活跃路由器)

    占先(网络中已经存在活跃路由器,当优先级比较高的路由器想要成为活跃路由器,就需要配置占先,占先一般是配置在优先级比较高的路由器上)

    端口追踪(线路坏掉;但是活跃路由器是好的,如果活跃路由器端口关闭,也需要切换活跃路由,启用备份路由)

    查看命令

    1.8 配置实例(单VLAN)

    注意:三层交换机如果想让它作为PC的网关,配置IP和子网掩码,一定不是通过转它的物理接口为非交换接口,而是引入虚接口vlan 1 在Vlan 1上配置IP地址和子网掩码,建立虚路由器

     首先确认有几个网段,两个三层交换机和二层交换机相连是一个网段

    配置三层交换机的vlan 1 虚接口IP地址,两个三层交换机均需要配置

    Switch#

    Switch#conf t

    Switch(config)#

    Switch(config)#ip routing

    Switch(config)#

    Switch(config)#int vlan 1

    Switch(config-if)#ip address 192.168.10.254 255.255.255.0

    Switch(config-if)#no shutdown

    进入虚接口VLAN 1 、指定HSRP组号、配置虚拟路由器的IP地址

    组号和虚拟路由器的ip地址、必须和另一台路由设置的一样

    占先,一般是组中已经存在活跃路由,那么这时就算设置优先级高于活跃路由也不会切换为活跃路由,需要在该路由设置占先。该HSRP组会重新选举出新的活跃路由和备份路由

    设置组号和虚拟路由器的IP地址

    先进对应接口

    Switch(config-if)#standby 50 ip 192.168.10.250   //50是组号,ip是虚拟路由的IP

    设置优先级

    先进对应接口

    Switch(config-if)#standby 50 priority 100         //50是组号,priority 是优先级

    Switch>en

    Switch#conf t

    Switch(config)#int vlan 1

    Switch(config-if)#standby 50 ip 192.168.10.250

    %HSRP-6-STATECHANGE: Vlan1 Grp 50 state Speak

    Switch(config-if)#standby 50 priority 100

    Switch(config-if)#standby 50 priority 210

    Switch(config-if)#standby 50 preemt

    更多相关内容
  • 一、三层交换网络规划>二、三层交换机综合实验

    一、三层交换网络规划

    1.三层交换机网络+HSRP

    • 上一章学习的公司网络是很简单的,但是现实中公司中会有多台二层交换机,二层交换机再连接到三层交换机,利用三层交换机实现公司中划分vlan后,不同vlan之间也可以相互通信,而且再添加一个路由器连接到三层交换机,则公司员工就可以通过三层交换机再到路由器实现与外网通信(上网)。所以在公司网络中,三层交换机的地位是很高的,那么就需要额外买一台三层交换机,作为备份使用,如下图

      image-20211108125414969
    • 三层交换机需要起虚接口并配置对应vlan网关的IP,假如图中有4个vlan,那么就需要在每个三层交换机上都起四个虚接口,分别作为这4个vlan的网关,但是一个网络中不能同时出现两个相同IP的网关,会冲突。比如在r1-gate三层交换机上vlan10–10.1.1.252,vlan20–20.1.1.252,vlan30–30.1.1.252等;在r2-gate三层交换机上vlan10–10.1.1.253,vlan20–20.1.1.253,vlan30–30.1.1.253等。那么此时员工PC网关该如何指呢?就需要用到HSRP协议热备份网关

      image-20211108150025153
    • 现在需要创建HSRP组并设置虚拟路由器网关的虚拟IP,由于有4个vlan,则有4个网段的网关,就需要设置4个HSRP组,一个组中有两个同一vlan的真实网关和此vlan的虚拟网关,所以也要设置4个虚拟IP。比如第一个HSRP组号为10,组中活跃路由器网关IP为10.1.1.252,备份路由器网关IP为10.1.1.253,虚拟IP为10.1.1.254;第二个HSRP组号为20,组中活跃路由器网关IP为20.1.1.252,备份路由器网关IP为20.1.1.253,虚拟IP为20.1.1.254…以此类推一共有4组。那么现在只需要让PC网关指向对应vlan的虚拟IP,就可以实现正常上网且当一个网关故障时另一个网关抢占活跃名分,实现快速切换,让员工感觉不到切换。比如PC1接入vlan10接口,那么PC1网关指向10.1.1.254;PC3接入vlan30接口,那么PC3网关指向30.1.1.254即可。

    2.多个三层交换机网络中环路问题

    • 在此网络中,会发现有两条环路,这种环路可以理解为是三个交换机之间构成的环路,与路由器形成的环路不同

    • 交换机构成的环路会造成:广播风暴!使交换机报黄灯,即交换机工作量巨大已经快无法承受

    • 原因:当一个PC发送广播,经过二层交换机,二层交换机将广播转发,又因为二层交换机与三层交换机之间的线路都配置成了trunk链路,表示允许任何vlan通过,则此PC发送的广播可以在trunk链路中传播,那么另一台交换机收到广播后,一看帧头中的目标MAC为广播MAC,则会继续向trunk链路转发广播,第三台再收到又会广播,那么广播就会周而复始的在交换机构成的网络中循环传播下去,就会造成广播风暴!

    • 如何解决:目前厂家在生产企业级管理型交换机时就已经内置了一个生成树协议–STP协议,利用此协议,三台交换机会相互通信交流谁当老大,如果协商出来一台交换机当老大,假设在下图中,左边的三层交换机是老大,那么在环路中与老大交换机相连的线路正常,另外两个交换机的f0/2或者f0/3接口会设置禁止通行,相当于f0/1和f0/1trunk端口之间的线路数据无法通过,则不会形成环路。所以如果网络中的交换机内置了STP协议,只要交换机之间形成环路,就立即通过此协议协商出逻辑down掉哪条线路的接口,避免形成环路(如下图中逻辑down掉这两个端口)

      屏幕截图 2021-11-08 131017
    • 如果有多台三层交换机做热备份使用的网路中,一般是HSRP协议和STP协议共同协作

    3.理解三层交换机在网络中的连接

    • 因为我们说过三层交换机内部可以理解为由一个纯的二层交换机和一个纯的路由器组成,所以连接方式如下图

      image-20211108153019395
    • 理解STP协议会逻辑down掉环路的某端口:红色圈起来的为逻辑down掉的端口;那么二层交换机与三层交换机之间有很多线路,但此时只有绿色对钩的线路可以走,就避免交换机之间形成环路

      屏幕截图 2021-11-08 153324
    • HSRP如何起作用详见本章三层交换机综合实验—3.验证—当中的第二点

    二、三层交换机综合实验

    1.实验要求

    • 如图所示

      image-20211108134650668
    1. 要求公司中划分vlan隔离广播,减小广播危害
    2. 配置三层交换机,实现不同vlan间PC可以相互通信
    3. 配置HSRP热备份三层交换机的各vlan网关,实现一个网关故障,可以切换另一个网关实现快速切换
    4. 配置所有路由器和三层交换机,实现内外网互通

    2.实验步骤

    1)配置交换部分

    1. 配置二层交换机的trunk和三层交换机的trunk

      注意由于已经给二层交换机端口配置trunk,那么相连的三层交换机端口已经自动配置成trunk,只需要再手动打开两台三层交换机的任意一台设置互连的端口为trunk即可。但是直接配置trunk会报错,先给端口设置标签协议:switchport trunk encapsulation dot1q,再配置trunk

      • 二层交换机配置trunk

        image-20211111182514338 image-20211111182628211

      • 三层交换机配置trunk

        image-20211111183113980
    2. 使用VTP技术在任意一台三层交换机上创建vlan并下发到二层交换机和另一台三层交换机

      image-20211111183313527
    3. 将二层交换机端口加入对应vlan

      • 检查一下是否下发成功

        image-20211111183440266
      • 再加入vlan

        image-20211111183547678 image-20211111183634598

    4. 在r1-gate三层交换机上根据vlan起虚端口,配IP:x.x.x.252(注意一定要先开启三层路由功能

      image-20211111183901818
    5. 在r2-gate三层交换机上根据vlan起虚接口,配IP:x.x.x.253

      image-20211111184103247

      目前为止,内网的不同vlan的电脑如果都指向同一个三层交换机上的虚接口网关,那么是可以通信的,比如PC1IP设置为10.1.1.1/24,网关指向10.1.1.252;PC2IP设置为20.1.1.1/24,网关指向20.1.1.252。则PC1和PC2是可以通信的。但是如果PC1不变,PC2网关指向20.1.1.253。那么此时PC1和PC2是无法通信的。所以每一个员工此时有两个网关的选择,为了避免这种情况的出现,则接着进行热备份,虚拟IP设为254,那么不同vlan的员工指向自己对应网段的网关IP接口,如10.1.1.254、20.1.1.254等

    6. 给三层交换机上的网关做热备份

      • 因为活跃路由器的优先级设置为200,且追踪自降优先级默认为10,所以在配置备份路由器优先级范围为[191,199],保证不超过活跃路由器优先级且活跃路由器连接外网端口故障自降优先级后比备份路由器低。实现热切换

      • 如何规划谁作为活跃谁作为备份:如果让一个三层交换机作为公司所有vlan的活跃路由器,那么工作压力会很大,所以一般有两个三层交换机的话,一个作为vlan10,vlan20的活跃路由器;另一个作为vlan30和vlan40的活跃路由器,各一半,平均分配压力到三层交换机。

      image-20211111185038059 image-20211111185254426

    7. 查看热备份信息

      现在可能会有些问题,因为活跃路由器设置过track跟踪连接外网的端口,而此时还没有开启端口,所以会先自降优先级,活跃成备份,备份成活跃,但不影响内网通信。等配置路由部分开启端口就恢复正常了

      image-20211111190410666 image-20211111185438811

    2)配置路由部分

    1. 开启所有路由器和三层交换机连接路由器的端口并配IP

      给三层交换机的端口配置IP时一定要先将二层端口升级为三层端口,才可以给三层交换机的端口配置IP

      • 开启三层交换机端口并配置IP

        image-20211111190616189image-20211111190720693

      • 开启r-in路由器并配置IP

        image-20211111191036093
      • 开启外网中的路由器并配置IP

        image-20211111191243469image-20211111191508753

    2. 给所有路由器和三层交换机路由引擎配置路由表

      • 注意在配置r-in时,现实中在配置外网网段的路由条目时,需要配置默认条目,因为互联网有很多网段,不可能每个网段都配置静态路由。但是这里实验为了方便,保证相邻路由器不互指默认路由的前提下,r-in路由器对外网方向上的网段配置成静态路由,因为可以数得过来。其他的外网的交换机也遵守上面的前提配置方便实验的路由表。
      • 在配置r-in路由器的路由表时一定要注意路由到内网网段的路由条目的下一跳IP,可以选择从连接r1-gate的线路路由到公司内网的网段;也可以把路由到10、20网段的消息设置浮动路由:优先指向r1-gate,备份指向r2-gate;把路由到30、40网段的消息设置浮动路由:优先指向r2-gate,备份指向r1-gate。这样分担线路的压力,而且保证有故障时也可以正常将消息路由
      • 给r1-gate配置路由表并查看

        image-20211111192115506
      • 给r2-gate配置路由表并查看

        image-20211111192253929
      • 给r-in配置路由表并查看

        image-20211111193546664 image-20211111193421231

      • 给r1-out配置路由表并查看

        image-20211111193750871 image-20211111193831667

      • 给r2-out配置路由表并查看

        image-20211111193925514

    3.验证

    1. 手动给所有PC配置IP,尝试内网与内网、内网与外网的通信

      image-20211111194357944 image-20211111194415531

    2. 故障的几种特殊情况举例:理解整个网络有线路故障,但在HSRP协议和STP协议相互配合下为什么能够正常通信?

      image-20211111195712617 image-20211111194948986

      1. 当网络正常时,我们用PC1(属于vlan10)去pingPC5。由于我们在设置HSRP热备份时,r1-gate作为vlan10和vlan20的活跃路由器、vlan30和vlan40的备份路由器。所以当没有故障时,PC1与外网通信会去请求虚拟路由器(10.1.1.254),虚拟路由器只认活跃路由器,所以会将帧发送到r1-gate路由器中的虚拟网关,然后再根据路由表将帧路由出去,但是由于交换设备的STP协议将r1-gate的f0/2端口逻辑down掉,所以④号线走不通,只能经过交换机再走⑥号线,所以会先经过r2-gate再经过③号线到达r1-gate;当PC5回包时经过r-in,由于设置的r-in的路由表时,发给10网段的应从①号线走、②号线作为备份(浮动路由),所以会到达r1-gate,根据路由表转发。④号线走不通,所以发到r2-gate再到sw1,最终到达PC1

        image-20211111201551949
      2. 当①号线路故障:可能是r1-gate的f0/4端口故障,或者是这根网线故障,或者r-in的f0/0端口故障(后面都是如此,不再赘述)

        image-20211111200409643 image-20211111195049111

      3. 当⑥号线路故障:一旦检测到⑥号线故障,STP协议会立刻逻辑开启r1-gate的端口,是④号线可以通行

        image-20211111201932571
      4. 当③号线路故障:由于③号线路故障,r1-gate的f0/2端口会被逻辑开启,那么帧直接经过sw1到达r1-gate

        image-20211111202503038 image-20211111202330126

    展开全文
  • #资源达人分享计划#
  • 核心交换机配置热备份详解及实验演示1 网络规划1.1 核心交换机的重要性及作用1.2 对核心交换机热备份2 拓扑图分析2.1 网络环路问题及解决方案2.1.1 网络环路问题2.1.2 二层环路解决方案2.2 核心交换机中配置热备份...

    1 网络规划

    1.1 核心交换机的重要性及作用

    在这里插入图片描述
    (1)重要性:核心交换机作为公司信息通信的交通枢纽,对外连接路由器,对内连接各二层交换机,是公司网络结构的轴承,起到承上启下的作用。
    (2)作用

    • 1) 核心交换机各二层接口连接各二层交换机,保证着各二层交换机之间的通信;
    • 2)在核心交换机内,为每个VLAN设置了虚拟网关,保证不同VLAN之间的通信;
    • 3)连接外网,是内外网数据的唯一通道。

    1.2 对核心交换机做热备份

    (1)核心交换机发生故障的后果:可能使不同交换机之间无法通信,不同VLAN之间无法通信,内外网无法通信。
    (2)对核心交换机做热备份:由于核心交换机地位高,一旦发生故障影响范围较广,为了提高整个网络结构的容错率,应设置两个及以上的核心交换机相互配合,即便有一个down掉,还有替补。如采用以下拓补图。
    在这里插入图片描述

    2 拓扑图分析

    2.1 网络环路问题及解决方案

    2.1.1 网络环路问题

    (1)在上述网络拓补图中,二层交换机与核心交换机之间形成了环路,形成了二层环路。环路一定程度上提高了网络结构的容错率,因为即便断了一根线,仍能保证有其他路线能够通信,但是环路也带来不可忽视的隐患。
    (2)对于三层环路(网络层环路),在数据帧中IP包头中,为数据帧设置了生命周期TTL,保证数据帧每跳一下均减少一次生命,在环路中数据帧很快会因为TTL降为0而被丢弃。
    (3)二层环路:如下图,当SW1发送广播数据帧时,将从f0/1、f0/2同时发出,将产生两个永不休止的广播在环路中广播,最终导致网络瘫痪。该现象称为广播风暴。即使引入vlan也是不行,因为交换机之间的链路一般配置成trunk链路,在这个三个交换机之间仍然会形成环路。
    在这里插入图片描述
    在这里插入图片描述

    2.1.2 二层环路解决方案

    (1)对于广播风暴,目前管理型交换机中内置了协议可以自动解决二层环路问题,而傻瓜型若形成了环路,可能很快就出现问题。
    (2)广播风暴的解决方案(简单理解即可):

    • 1)思路:逻辑上down掉冗余链路。
    • 2)STP(Spanning Tree Protocol)生成树协议。①STP的基本原理是,通过在交换机之间传递一种特殊的协议报文,网桥协议数据单元(Bridge Protocol Data Unit,简称BPDU),可以逻辑down掉(类似于打封条)某个接口,避免了环路的产生。但若当正常运行的链路出现问题时,被逻辑down掉的接口会立马开启,起到了备份了线路的作用,提高了网络故障容错率。②STP生成树协议主要作用是防止网桥网络中的冗余链路形成环路工作。
    • 3)PVST(per vlan Spanning Tree):是STP协议的升级,是思科私有的协议,公有协议叫做MST。可以在同一环路中,分别为各个VLAN逻辑down掉不同的冗余链路。优点是对流量进行了分担,而不至于所有流量都由某条链路承担。

    2.2 核心交换机中配置热备份HSRP

    (1)HSRP协议核心原理:配置多台路由器用于连接内外网,那么一个网段就有多个网关,将一个网段的多个网关加入同一个HSRP组中。正常情况下,内外网的通信,数据流量只从一个路由器的网关通过,该路由器称为活跃路由器。当活跃路由器失效后,备份路由器将自动成为新的活跃路由器,承担转发用户流量的职责。
    (2)核心交换机与热备份

    • 1)理解:从HSRP协议核心原理可知,做热备份是对网关做备份,有几个网段就有多少个热备份组。对于配置了核心交换机的网络,公司所有vlan的网关都在三层交换机的虚接口,且有几个vlan就有几个虚接口,有几个vlan就有几个网段。因此若对核心交换机配置热备份,那么就几个vlan就有几个热备份组,将同一VLAN的所有网关加入到一个HSRP组中,与真实网关一样设置虚拟IP、优先级等参数。这样网络结构上就保证了某VLAN能有多个路径与其他VLAN及外网相连,HSRP协调了各个路径的选择顺序。
    • 2)例子:假设公司有5个vlan,分别为vlan10~vlan50,有两台核心交换机,那么配置热备份时,需要设置5个热备份组,且命令配置需要做5*2=10套。首先将vlan10的两个网关加入一个热备份组,并设置虚拟IP、优先级等参数,之后依次对vlan20-vlan50设置。注意,这些备份要进入“vlan x ”里面配置。

    3 实验步骤及配置命令

    3.1 实验思路

    在这里插入图片描述
    首先规划网络(如vlan及网段),然后理清实验思路,实验思路整体可以以核心交换机为界,划分为二层交换部分与三层路由部分。
    (1)二层交换部分:

    • 第1步:配置trunk接口模式
    • 第2步:配置VTP域及创建虚拟局域网—VLAN
    • 第3步:去二层交换机上划分接口到对应VLAN

    (2)三层路由部分:

    • 第1步:核心交换机开启三层路由并创建虚拟接口,然后给网关配置IP并开启
    • 第2步:核心交换机与路由器相连的接口升级为三级接口并配置IP
    • 第3步:路由器接口配置IP
    • 第4步:配置路由表
    • 第5步:给三层交换机配置热备份,其中SW1为活跃路由器,SW2为备份路由器

    (3)给PC手动配置IP。

    3.2 实验部署及命令

    '''二层交换部分配置'''
    '''第1步:配置trunk接口模式'''
    #给SW1配置trunk接口模式
    en
    conf t
    ho SW1
    int range f0/2 - 5
    sw m t
    exit
    do show vlan b
    do wr
    #给SW2配置trunk接口模式
    en
    conf t
    ho SW2
    int f0/2
    sw m t
    exit
    int range f0/6 - 8
    sw m t
    exit
    do show vlan b
    do wr
    #给SW3配置trunk接口模式
    en
    conf t
    ho SW3
    int f0/3
    sw m t
    exit
    int f0/6
    sw m t
    exit
    do show vlan b
    do wr
    #给SW4配置trunk接口模式
    en
    conf t
    ho SW4
    int f0/4
    sw m t
    exit
    int f0/7
    sw m t
    exit
    do show vlan b
    do wr
    #给SW5配置trunk接口模式
    en
    conf t
    ho SW5
    int f0/5
    sw m t
    exit
    int f0/8
    sw m t
    exit
    do show vlan b
    do wr
    
    '''第2步:配置VTP域及创建虚拟局域网—VLAN'''
    # 在SW1上配置VTP域及创建虚拟局域网—VLAN
    conf t
    vtp domain zz
    vlan 10
    exit
    vlan 20
    exit
    vlan 30
    exit
    vlan 40
    exit
    do show vlan b
    do wr
    
    '''第3步:划分接口到对应VLAN'''
    # 给SW3划分接口至相应VLAN
    en
    conf t
    int f0/1
    sw ac vlan 10
    exit
    int f0/2
    sw ac vlan 20
    exit
    do show vlan b
    do wr
    # 给SW4划分接口至相应VLAN
    en
    conf t
    int f0/1
    sw ac vlan 10
    exit
    int f0/2
    sw ac vlan 30
    exit
    do show vlan b
    do wr
    # 给SW5划分接口至相应VLAN
    en
    conf t
    int f0/1
    sw ac vlan 20
    exit
    int f0/2
    sw ac vlan 40
    exit
    do show vlan b
    do wr
    
    
    '''三层路由部分'''
    '''第1步:核心交换机开启三层路由并创建虚拟接口,然后给网关配置IP并开启'''
    #给SW1配置
    conf t
    ip routing
    int vlan 10
    ip add 10.1.1.252 255.255.255.0
    no shut
    exit
    int vlan 20
    ip add 20.1.1.252 255.255.255.0
    no shut
    exit
    int vlan 30
    ip add 30.1.1.252 255.255.255.0
    no shut
    exit
    int vlan 40
    ip add 40.1.1.252 255.255.255.0
    no shut
    exit
    do show run
    do wr
    ##给SW2配置
    conf t
    ip routing
    int vlan 10
    ip add 10.1.1.253 255.255.255.0
    no shut
    exit
    int vlan 20
    ip add 20.1.1.253 255.255.255.0
    no shut
    exit
    int vlan 30
    ip add 30.1.1.253 255.255.255.0
    no shut
    exit
    int vlan 40
    ip add 40.1.1.253 255.255.255.0
    no shut
    exit
    do show run
    do wr
    
    '''第2步:核心交换机与路由器相连的接口升级为三级接口并配置IP'''
    #给SW1配置
    conf t
    int f0/1
    no switchport
    ip add 50.1.1.1 255.255.255.0
    no shut
    exit
    do show ip int b
    do wr
    #给SW2配置
    conf t
    int f0/1
    no switchport
    ip add 60.1.1.1 255.255.255.0
    no shut
    exit
    do show ip int b
    do wr
    
    '''第3步:路由器接口配置IP'''
    #给R1配置
    en
    conf t
    ho R1
    int f0/0
    ip add 50.1.1.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip add 60.1.1.2 255.255.255.0
    no shut
    exit
    int f1/0
    ip add 70.1.1.1 255.255.255.0
    no shut
    exit
    do show ip int b
    do wr
    #给R2配置
    en
    conf t
    ho R2
    int f0/0
    ip add 70.1.1.2 255.255.255.0
    no shut
    exit
    int f0/1
    ip add 80.1.1.1 255.255.255.0
    no shut
    exit
    do show ip int b
    do wr
    #给R3配置
    en
    conf t
    ho R3
    int f0/0
    ip add 90.1.1.254 255.255.255.0
    no shut
    exit
    int f0/1
    ip add 80.1.1.2 255.255.255.0
    no shut
    exit
    do show ip int b
    do wr
    
    '''第4步:配置路由表'''
    #给SW1配置
    conf t
    ip route 0.0.0.0 0.0.0.0 50.1.1.2
    do show ip route
    do wr
    #给SW2配置
    conf t
    ip route 0.0.0.0 0.0.0.0 60.1.1.2
    do show ip route
    do wr
    #给R1配置
    conf t
    ip route 10.1.1.0 255.255.255.0 60.1.1.1
    ip route 20.1.1.0 255.255.255.0 60.1.1.1
    ip route 30.1.1.0 255.255.255.0 60.1.1.1
    ip route 40.1.1.0 255.255.255.0 60.1.1.1
    ip route 80.1.1.0 255.255.255.0 70.1.1.2
    ip route 90.1.1.0 255.255.255.0 70.1.1.2
    do show ip route
    do wr
    #给R2配置
    conf t
    ip route 0.0.0.0 0.0.0.0 70.1.1.1
    ip route 90.1.1.0 255.255.255.0 80.1.1.2
    do show ip route
    do wr
    #给R3配置
    conf t
    ip route 0.0.0.0 0.0.0.0 80.1.1.1
    do show ip route
    do wr
    '''第5步:给三层交换机配置热备份'''
    #给SW1配置
    conf t
    int vlan 10
    standby 1 ip 10.1.1.254
    standby 1 priority 195
    standby 1 preempt
    standby 1 track f0/1
    exit
    int vlan 20
    standby 2 ip 20.1.1.254
    standby 2 priority 195
    standby 2 preempt
    standby 2 track f0/1
    exit
    int vlan 30
    standby 3 ip 30.1.1.254
    standby 3 priority 195
    standby 3 preempt
    standby 3 track f0/1
    exit
    int vlan 40
    standby 4 ip 40.1.1.254
    standby 4 priority 195
    standby 4 preempt
    standby 4 track f0/1
    exit
    do show standby b
    do wr
    #给SW2配置
    conf t
    int vlan 10
    standby 1 ip 10.1.1.254
    standby 1 priority 190
    standby 1 preempt
    standby 1 track f0/1
    exit
    int vlan 20
    standby 2 ip 20.1.1.254
    standby 2 priority 190
    standby 2 preempt
    standby 2 track f0/1
    exit
    int vlan 30
    standby 3 ip 30.1.1.254
    standby 3 priority 190
    standby 3 preempt
    standby 3 track f0/1
    exit
    int vlan 40
    standby 4 ip 40.1.1.254
    standby 4 priority 190
    standby 4 preempt
    standby 4 track f0/1
    exit
    do show standby b
    do wr
    

    3.3 实验结果

    (1)正常状态下,全网可以互相通信。分别查看SW1和SW2的热备份状态。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    (2)down掉SW1的f0/1端口,查看是否仍可以全网互通,并查看SW2的热备份状态。仍然可以ping通全网。且SW2的vlan10`vlan40的状态均变为了活跃。
    在这里插入图片描述
    在这里插入图片描述

    3.4 拓展

    (1)若需要在三层交换机上配置DHCP服务器,注意只能在其中一台上配置,不能两个都配置。若需要提高自动获取IP功能,那么可以配一台服务器,用做DHCP服务器。
    (2)上述实验中,vlan10~vlan40的活跃路由器都是SW1。在现实中,建议一半vlan的活跃路由器选择SW1,一半选中SW2,主要是为了连接外网时分摊流量。
    (3)本实验中,配置R1的路由条目时,10.1.1.0~40.1.1.0网段都是指向的60.1.1.1。注意,在此拓扑图中,建议其中两个网段指向50.1.1.1,且另外配置指向60.1.1.1的备份路由;另外两个网段与此相反。这样能更好得分担流量,且提高网络故障容错率。

    4 归纳

    (1)理解核心交换机的作用。
    (2)理解如何给核心交换机配置热备份,HSRP协议如何发挥作用。
    (3)简单理解出现二层环路时,STP、PVST如何发挥作用。
    (4)掌握给核心交换机配置热备份实验的原理及步骤,并熟悉相关命令。

    参考文章

    [1]《STP (生成树协议)》
    [2] 《应用HSRP协议布署双核心交换机网络——提高网络故障容错率》
    [3] 视频传送门

    展开全文
  • 华为设备配置CR-LSP热备份

    在这里插入图片描述

    1. 配置IP地址
      [LSR1-GigabitEthernet0/0/0]ip add 20.1.1.1 24
      [LSR1-GigabitEthernet0/0/2]ip add 20.4.1.1 24
      [LSR1-LoopBack0]ip add 1.1.1.1 32
      [LSR2-GigabitEthernet0/0/0]ip add 20.1.1.2 24
      [LSR2-GigabitEthernet0/0/1]ip add 20.2.1.2 24
      [LSR2-GigabitEthernet0/0/2]ip add 20.7.1.2 24
      [LSR2-LoopBack0]ip add 2.2.2.2 32
      [LSR3-GigabitEthernet0/0/0]ip add 20.2.1.3 24
      [LSR3-GigabitEthernet0/0/2]ip add 20.6.1.3 24
      [LSR3-LoopBack0]ip add 3.3.3.3 32
      [LSR4-GigabitEthernet0/0/0]ip add 20.4.1.4 24
      [LSR4-GigabitEthernet0/0/1]ip add 20.6.1.4 24
      [LSR4-GigabitEthernet0/0/2]ip add 20.7.1.4 24
      [LSR4-LoopBack0]ip add 4.4.4.4 32

    2. 配置OSPF
      [LSR1]ospf 1
      [LSR1-ospf-1]area 0
      [LSR1-ospf-1-area-0.0.0.0]network 20.1.1.0 0.0.0.255
      [LSR1-ospf-1-area-0.0.0.0]network 20.4.1.0 0.0.0.255
      [LSR1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0
      [LSR2]ospf 1
      [LSR2-ospf-1]area 0
      [LSR2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
      [LSR2-ospf-1-area-0.0.0.0]network 20.1.1.0 0.0.0.255
      [LSR2-ospf-1-area-0.0.0.0]network 20.2.1.0 0.0.0.255
      [LSR2-ospf-1-area-0.0.0.0]network 20.7.1.0 0.0.0.255
      [LSR3]ospf 1
      [LSR3-ospf-1]area 0
      [LSR3-ospf-1-area-0.0.0.0]network 20.2.1.0 0.0.0.255
      [LSR3-ospf-1-area-0.0.0.0]network 20.6.1.0 0.0.0.255
      [LSR3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
      [LSR4]ospf 1
      [LSR4-ospf-1]area 0
      [LSR4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
      [LSR4-ospf-1-area-0.0.0.0]network 20.4.1.0 0.0.0.255
      [LSR4-ospf-1-area-0.0.0.0]network 20.6.1.0 0.0.0.255
      [LSR4-ospf-1-area-0.0.0.0]network 20.7.1.0 0.0.0.255

    3. 配置MPLS基本能力,使能MPLS TE、RSVP-TE,在主隧道的入节点上使能CSPF
      [LSR1]mpls lsr-id 1.1.1.1
      [LSR1]mpls
      [LSR1-mpls]mpls te
      [LSR1-mpls]mpls rsvp-te
      [LSR1-mpls]mpls te cspf
      [LSR1-GigabitEthernet0/0/0]mpls
      [LSR1-GigabitEthernet0/0/0]mpls te
      [LSR1-GigabitEthernet0/0/0]mpls rsvp-te
      [LSR1-GigabitEthernet0/0/2]mpls
      [LSR1-GigabitEthernet0/0/2]mpls te
      [LSR1-GigabitEthernet0/0/2]mpls rsvp-te
      [LSR2]mpls lsr-id 2.2.2.2
      [LSR2]mpls
      [LSR2-mpls]mpls te
      [LSR2-mpls]mpls rsvp-te
      [LSR2-GigabitEthernet0/0/0]mpls
      [LSR2-GigabitEthernet0/0/0]mpls te
      [LSR2-GigabitEthernet0/0/0]mpls rsvp-te
      [LSR2-GigabitEthernet0/0/1]mpls
      [LSR2-GigabitEthernet0/0/1]mpls te
      [LSR2-GigabitEthernet0/0/1]mpls rsvp-te
      [LSR2-GigabitEthernet0/0/2]mpls
      [LSR2-GigabitEthernet0/0/2]mpls te
      [LSR2-GigabitEthernet0/0/2]mpls rsvp-te
      [LSR3]mpls lsr-id 3.3.3.3
      [LSR3]mpls
      [LSR3-mpls]mpls te
      [LSR3-mpls]mpls rsvp-te
      [LSR3-GigabitEthernet0/0/0]mpls
      [LSR3-GigabitEthernet0/0/0]mpls te
      [LSR3-GigabitEthernet0/0/0]mpls rsvp-te
      [LSR3-GigabitEthernet0/0/2]mpls
      [LSR3-GigabitEthernet0/0/2]mpls te
      [LSR3-GigabitEthernet0/0/2]mpls rsvp-te
      [LSR4]mpls lsr-id 4.4.4.4
      [LSR4]mpls
      [LSR4-mpls]mpls te
      [LSR4-mpls]mpls rsvp-te
      [LSR4-GigabitEthernet0/0/0]mpls
      [LSR4-GigabitEthernet0/0/0]mpls te
      [LSR4-GigabitEthernet0/0/0]mpls rsvp-te
      [LSR4-GigabitEthernet0/0/1]mpls
      [LSR4-GigabitEthernet0/0/1]mpls te
      [LSR4-GigabitEthernet0/0/1]mpls rsvp-te
      [LSR4-GigabitEthernet0/0/2]mpls
      [LSR4-GigabitEthernet0/0/2]mpls te
      [LSR4-GigabitEthernet0/0/2]mpls rsvp-te

    4. 配置OSPF TE
      [LSR1]ospf 1
      [LSR1-ospf-1]opaque-capability enable
      [LSR1-ospf-1]area 0
      [LSR1-ospf-1-area-0.0.0.0]mpls-te enable
      [LSR2]ospf 1
      [LSR2-ospf-1]opaque-capability enable
      [LSR2-ospf-1]area 0
      [LSR2-ospf-1-area-0.0.0.0]mpls-te enable
      [LSR3]ospf 1
      [LSR3-ospf-1]opaque-capability enable
      [LSR3-ospf-1]area 0
      [LSR3-ospf-1-area-0.0.0.0]mpls-te enable
      [LSR4]ospf 1
      [LSR4-ospf-1]opaque-capability enable
      [LSR4-ospf-1]area 0
      [LSR4-ospf-1-area-0.0.0.0]mpls-te enable

    5. 配置主、备CR-LSP使用的显式路径
      [LSR1]explicit-path pp1 //配置主CR-LSP使用的显式路径
      [LSR1-explicit-path-pp1]next hop 20.1.1.2
      [LSR1-explicit-path-pp1]next hop 20.2.1.3
      [LSR1-explicit-path-pp1]next hop 3.3.3.3
      [LSR1]explicit-path bp1 //配置备份CR-LSP使用的显式路径
      [LSR1-explicit-path-bp1]next hop 20.4.1.4
      [LSR1-explicit-path-bp1]next hop 20.6.1.3
      [LSR1-explicit-path-bp1]next hop 3.3.3.3
      在这里插入图片描述

    6. 配置隧道接口
      [LSR1]int Tunnel 0/0/1
      [LSR1-Tunnel0/0/1]ip address unnumbered interface LoopBack 0
      [LSR1-Tunnel0/0/1]tunnel-protocol mpls te
      [LSR1-Tunnel0/0/1]destination 3.3.3.3
      [LSR1-Tunnel0/0/1]mpls te tunnel-id 100
      [LSR1-Tunnel0/0/1]mpls te record-route
      [LSR1-Tunnel0/0/1]mpls te path explicit-path pp1 //指定显式路径
      [LSR1-Tunnel0/0/1]mpls te backup hot-standby wtr 15 //配置CR-LSP热备份,回切时间为15秒
      [LSR1-Tunnel0/0/1]mpls te path explicit-path bp1 secondary //指定备份显式路径
      [LSR1-Tunnel0/0/1]mpls te backup ordinary best-effort //配置逃生路径
      [LSR1-Tunnel0/0/1]mpls te commit
      在这里插入图片描述

    发现主CR-LSP、备份CR-LSP建立成功
    在这里插入图片描述
    在这里插入图片描述

    在这里插入图片描述

    1. 检查配置
      [LSR1-GigabitEthernet0/0/0]shutdown //模拟线缆拔出
      在这里插入图片描述

    发现流量被切换到备份CR-LSP上
    [LSR3-GigabitEthernet0/0/2]shutdown
    在这里插入图片描述

    发现隧道接口Up,逃生路径建立成功

    在这里插入图片描述

    展开全文
  • 构建实验拓扑 实验思路:华为与思科热备路由大同小异,区别在于,思科是写在路由器上的,而华为是基于端口的,而本实验采用三层交换机,故不同IP需要写在vlan虚接口上。STP只需要创建一个区域,两个生成树即可,互相...
  • 华为三层二层交换机双机热备份配置举例[参考].pdf
  • 华为三层 二层交换机双机热备份配置举例.doc
  • 华为三层二层交换机双机热备份配置举例.doc
  • 在仿真和实验中将添加了热备份路由协议的双交换机网状拓扑与传统单交换机星形网络拓扑结构进行对比,结果表明,采用双中心交换机热备份后,过程层网络中心交换机压力明显减小,并可以在链路发生故障时由备份交换机...
  • 双机热备份交换机

    千次阅读 2018-07-24 13:19:13
    双机热备份交换机
  • 步骤1:路由ip配置 路由r1配置 ...测试pc10.1.1.1是否ping通pc40.1.1.1 注:实验过程初步ping测试中时常会丢包,一般第一次4个包不通,可以选择再ping一次 此时拿走一根线路,让HSRP热备份协议生效,ping测试依旧成功
  • 目录 一、基础知识 二、实验过程 1)配IP 2)配置路由 3)热备份 ...上图中下面的一台交换机下的俩PC是公司内网,上面那俩...于是有了HSRP(Hot Standby Routing Protocol)热备份路由协议(用来备份网关的),这...
  • 二、三层交换配置HSRP(热备份

    千次阅读 2019-05-09 19:28:01
    目标: 以三层交换机代替路由器作为网关设备。 方案: 以三层交换机代替路由器作为网关设备,以vlan1作为网关接口 网络拓扑如下图所示: 步骤: 步骤一:分别为三层交换机和路由器配置IP并开启三层交换机路由功能...
  • 发现不是同一网络,会将数据交给自己的网关,在这里,主机配置的网关为HSRP组中的虚拟路由器,虚拟路由器收到了数据后,根据HSRP组中的机制(组中路由器的优先级来决定谁是活跃路由器,谁是备份路由器),将数据交给...
  • 华为交换机VRRP配置教程(一)

    千次阅读 2020-12-19 18:42:46
    VRRP是一种网关备份和负载均衡技术,以实现用户网络的多网关备份和负载均衡,主要用于WAN接入线路的备份和负载均衡接口和双机热备也可以实现主备切换和负载均衡,不同之处在于:接口备份是针对同一路由器上多个WAN...
  • 什么是核心交换机的链路聚合、冗余、堆叠、热备份,今天我们一起来了解这些专业术语!一、链路聚合是将两个或更多数据信道结合成一个单个的信道,该信道以一个单个的更高带宽的逻辑链路出现。链路聚合一般用来连接一...
  • 配置的方式有三种针对的备份内容也不同,第一种是自动备份,这个是默认开启的,当我们在防火墙上配置了可以备份的配置那么将立刻在另一台防火墙上输入,但是状态信息则是在一段周期后进行同步,这种自动备份会在设备...
  • 链路聚合、冗余、堆叠、热备份等这些功能,这些功能非常重要,决定了核心交换机在实际应用中的性能、效率、稳定性等,我们一起来了解下。一、链路聚合是将两个或更多数据信道结合成一...
  • 思科 HSRP热备份

    2012-12-02 21:50:55
    思科上实现hsrp热备份实现高可用性 1.所有路由器和交换机上要做的基本配置: Router>en Router# Router#conf Configuringfromterminal,memory,ornetwork[terminal]? Enterconfigurationcommands,...
  • 所以我们在选择核心交换机时,经常会看到有的核心交换机具有堆叠或热备份等功能。 对核心交换机采用热备份是提高网络可靠性的必然选择。在一个核心交换机完全不能工作的情况下,它的全部功能便被系统中的另一个...
  • 核心交换机是整个网络的核心和心脏,如果核心交换机发生...为了保持网络的稳定性,在多台交换机组成的网络环境中,通常都使用一些备份连接,以提高网络的效率、稳定性,这里的备份连接也称为备份链路或者冗余链路。...
  • 目录 基础配置 配置VGMP ...(上下行交换机可以是傻瓜交换机,不做任何配置) 按照图配置相关接口IP地址和安全区域 HRP、VGMP报文不需要配置相应的安全策略,策略只需要配置关于数据的策略 配置.....
  • 交换机堆叠,双上下链路连接。 monitor技术作用: (类似track监测为物理链路,只不过是上下联为一组监测) 1、上下联链路为一组,两组互为备份; 2、一组链路中上下联链路其中一条DOWN则整体切换另一组链路,...
  • 两核心交换机,业务流量优先从主核心交换机上传递,当核心宕机或者出现故障,业务流量会从备交换机上传递,(备交换机承接主交换机的任务)10-15s 当备设备过了三个周期后还没有收到主设备的hello包,就认为主设备...
  • 实现内网和外网的互通,在内网出口的三层交换机配置热备份路由,内网划分vlan,实现访问外网,并且考虑路由分担
  • 热备份路由选择协议(HSRP)

    千次阅读 2022-02-14 15:54:15
    文章目录前言1. HSRP1.1 HSRP 的原理1.1.1HSRP的相关概念1.1.2 HSRP 的状态1.1.3 HSRP 的计时器1.1.4 HSRP 与VRRP的区别2....两台三层交换机配置HSRP协议,可实现网关的冗余备份。主机只需要配置一个固定网关,

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,525
精华内容 2,610
关键字:

交换机热备份