精华内容
下载资源
问答
  • 交换机堆叠和热备的区别

    万次阅读 2018-04-28 16:39:59
    图解Cisco交换机堆叠与HSRP之间的区别随着Internet的日益普及,人们对网络的依赖性也越来越强。这同时对网络的稳定性提出了更高的要求,人们自然想到了基于...而目前对于业界的所有三层交换机均采用热备份路由协议(...

    图解Cisco交换机堆叠与HSRP之间的区别

    随着Internet的日益普及,人们对网络的依赖性也越来越强。这同时对网络的稳定性提出了更高的要求,人们自然想到了基于设备的备份结构,就像在服务器中为提高数据的安全性而采用双硬盘结构一样。核心交换机是整个网络的核心和心脏,如果核心交换机发生致命性的故障,将导致本地网络的瘫痪,所造成的损失也是难以估计的。

    而目前对于业界的所有三层交换机均采用热备份路由协议(VRRP),而Cisco一般采用自己的私有协议热备份路由协议(HSRP),但是对于Cisco Catalyst 3750系列交换机一般采用堆叠的方式,通过自带的堆叠线将多台交换机堆叠在一起形成一个逻辑交换机。

    那么下面先来看看堆叠与HSRP(热备份路由协议)的介绍。

    堆叠

    目前Cisco越来越多的产品支持堆叠了,目前支持堆叠型号有Cisco Catalyst 3750系列,而现在2960S以及3560X与3750X都支持,但是对于这些新型号要使用堆叠功能就必须使用专用的堆叠模块,而Cisco Catalyst 3750系列在包装箱中默认送了一根0.5的堆叠线,3750交换机相互之间通过思科专有的堆叠电缆连接起来,可将多达9台交换机堆叠成一台逻辑交换机。该逻辑交换机中的所有交换机共享相同的配置信息和路由信息。当向逻辑交换机增加和减少单体交换机时不会影响其性能。

    叠加的交换机之间通过两条环路连接起来。交换机的硬件负责将数据包在双环路上做负载均衡。环路在这里充当了这个大的逻辑交换机的背板的角色,在双环路都正常工作时,数据包在这台逻辑交换机上的传输率为32Gbps。

    当一个数据帧需要传输时,交换机的软件会进行计算看哪条环路更可用,然后数据帧会被送到该环路上。如果一条堆叠电缆出故障,故障两端的交换机都会侦测到该故 障,并将受影响的环路断开,而逻辑交换机仍然可以以单环的状态工作,此时的数据包通过率为16Gbps。交换机的堆叠采用菊花链方式,连接的方式参考下图。

    clip_image002[4]

    当若干台交换机堆叠后,会有一台交换机负责管理功能,称其为主交换机(master switch),主交换机会向其它交换机自动更新配置文件,路由信息,堆叠信息。而主交换机采用的是1:N的冗余备份方式,堆叠中的所有交换机在主交换机 出问题时都可以成为主交换机并取而代之。

    主交换机负责下载CAM转发表到各个交换机,3层交换机的路由信息也由主交换机负责维护与分发。其它一些QoS特性或访问控制列表的操作也是由主交换机告 诉其它交换机如何控制。当有新的交换机加入或现有的交换机移走,主交换机会送出一个通知,其它交换机会随之更新自己的堆叠信息。

    环上的每台交换机都会有一个MAC地址表保存自己本地的MAC地址信息,还会有一个MAC表维护其它交换机的MAC地址信息。MAC地址表是由主交换机负责更新的。

    另外,堆叠交换机处理数据包的方式非常有效,每个数据包有一个24字节的头信息,其中包括包的目的地信息(该信息是在堆叠交换机中使用的,是由主交换机给出的)和QoS指示器。

    HSRP

    对核心交换机采用热备份是提高网络可靠性的必然选择。在一个核心交换机完全不能工作的情况下,它的全部功能便被系统中的另一个备份路由器完全接管,直至出现问题的路由器恢复正常,这就是热备份路由协议(HotStandbyRouterProtocol)。

    实现HSRP的条件是系统中有多台核心交换机,它们组成一个“热备份组”,这个组形成一个虚拟路由器。在任意时刻,一个组内只有一个路由器是活动的,并由它来转发数据包,如果活动路由器发生了故障,将选择一个备份路由器来替代活动路由器,但是在本网络内的主机看来,虚拟路由器没有改变。所以主机仍然保持连接,没有受到故障的影响,这样就较好地解决了核心交换机切换的问题。

    为了减少网络的数据流量,在设置完活动核心交换机和备份核心交换机之后,只有活动核心交换机和备份核心交换机定时发送HSRP报文。如果活动核心交换机失效,备份核心交换机将接管成为活动核心交换机。如果备份核心交换机失效或者变成了活跃核心交换机,将由另外的核心交换机被选为备份核心交换机。

    在上面已经了解了各自的区别了,下面图解HSRP与堆叠故障切换与数据流的走向。

    热备份路由协议(HSRP)故障切换与数据流走向

    HSRP正常情况下,数据流量走向

    clip_image004

    (通过上图可以得知)正常情况下,终端1去访问应用服务器时,首先经过接入层交换机1再到过核心交换机A,通过核心交换机A到过应用服务器,而完成数据的交换。

    当某台接入层交换机到主核心交换机的线路出现故障,切换至备机,数据流走向

    clip_image006

    当接入层交换机1上联至核心交换机A的数据链路出现故障,导致接入层交换机1的数据链路切换至核心交换机B,但在切换期间接入层交换机1分丢6个数据包,如上图所示。

    服务器链路出现故障

    clip_image008

    当服务器与核心交换机A之间主链路出现故障(如线路、网卡等),服务器主网卡切换至备用网卡上时,会丢6个数据包,但当主链路恢复以后,服务器会自动从备用网卡切换至主网卡,而这次切换时数据包不会丢失。具体终端访问服务器的数据流走向如上图。

    主交换机出现故障

    clip_image010

    当核心交换机A出现故障以后,接入层交换机、服务器等均会从主链路切换至备用链路,但是在切换期间都会丢6个数据包。

    以上则是热备份路由协议(HSRP)在链路或者设备出现故障以后,在切换期间的一些表现。

    堆叠故障切换与数据流走向

    堆叠要求:

    IOS版本要一致、专用的堆叠模块和堆叠线缆、最大堆叠个数9台

    堆叠的好处:

    高密度端口、便于管理(配置时显示的是一台交换机,而其他交换机的端口则以slot号显示)

    避免STP(生成树协议)

    注意:

    1、堆叠最好成环,否则只有一半的带宽(16G)。

    2、最好把你想作为master的交换机的Priority指为最高15,默认为1,最大为15,值越大越优先。

    堆叠后正常情况下,数据流量走向

    clip_image012

    在使用Cisco Catalyst 3750系列交换机做堆叠时,将两台或多台Cisco Catalyst 3750系列交换机堆叠以后,会形成一台逻辑交换机。该逻辑交换机中的所有交换机共享相同的配置信息和路由信息。当向逻辑交换机增加和减少单体交换机时不会影响其性能。

    在核心交换机与接入层交换机以及服务器之间,通过两条链路互联,在核心交换机与接入层交换机上将对应的端口做端口捆绑,而这样在链路上可以达到双倍的效果,还可以避免STP(生成树)带来的问题。

    接入层上行链路故障

    clip_image014

    当接入层以交换机1的某条上行链路出现故障,而对于该终端1访问应用服务器的数据不会终端,而只是在该链路的带宽下降一半而已。

    服务器链路出现故障

    clip_image016

    当服务器与核心交换机之间某条链路出现故障,也不会导致服务器丢包情况出现。

    单台核心交换机出现故障

    clip_image018

    由于接入层交换机与应用服务器均采用双链路方式与核心交换机互联,所以当其中一台核心交换机出现故障,也不会对整个网络造成丢包情况。

    相信通过上面几张图大家应该理解了两种应用的各自区别了吧!

    出处:http://www.jb51.net/network/65931.html

    展开全文
  • 实验拓扑:实验需求:假设R3路由器为外网路由器,上面有一条虚拟网段3.3.3.0,模拟外网。C1为vlan10 ,C2为vlan 20。...实验步骤:配置C1,C2的IP地址,配置交换机R4R4#conf tEnter configuration...

    实验拓扑:

    wKiom1P4gcKRSpTrAAEHx2_Vih4132.jpg


    实验需求:

    1. 假设R3路由器为外网路由器,上面有一条虚拟网段3.3.3.0,模拟外网。

    2. C1为vlan10 ,C2为vlan 20。

    3. R1作为vlan10的主路由器,vlan20的备用路由器。R2作为vlan10的备用路由器,vlan10的主路由器。

    4. 测试热备路由的效果。


    实验步骤:

    1. 配置C1,C2的IP地址,配置交换机R4


    R4#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    R4(config)#no ip routing

    R4(config)#vlan 10,20

    R4(config-vlan)#ex

    R4(config)#int f1/1

    R4(config-if)#switchport access vlan 10

    R4(config-if)#int f1/2                 

    R4(config-if)#switchport access vlan 20

    R4(config-if)#int f1/3                 

    R4(config-if)#int range f1/3 -4

    R4(config-if-range)#switchport mode trunk 

    R4(config-if-range)#

    *Mar  1 00:04:35.099: %DTP-5-TRUNKPORTON: Port Fa1/3-4 has become dot1q trunk


    2.配置R1

    R1#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    R1(config)#ip routing                   //开启路由

    R1(config)#int f1/4

    R1(config-if)#no sh

    R1(config-if)#switchport mode trunk 

    R1(config-if)#

    *Mar  1 00:05:45.635: %DTP-5-TRUNKPORTON: Port Fa1/4 has become dot1q trunk

    R1(config)#track 1 int f1/3 line-protocol                  

    R1(config-track)#track 2 int f1/4 line-protocol            //创建监听端口

    R1(config)#vlan 10

    R1(config-vlan)#vlan 20    

    R1(config-vlan)#ex


    (1)配置vlan 10

    R1(config)#int vlan 10

    R1(config-if)#ip add 192.168.10.10 255.255.255.0

    R1(config-if)#no sh

    R1(config-if)#ex  

    *Mar  1 00:07:54.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

    R1(config-vlan)#ex

    R1(config)#int vlan 10

    R1(config-if)#vrrp 1 ?

      authentication  Authentication

      description     Group specific description

      ip              Enable Virtual Router Redundancy Protocol (VRRP) for IP

      preempt         Enable preemption of lower priority Master

      priority        Priority of this VRRP group

      shutdown        Disable VRRP Configuration

      timers          Set the VRRP timers

      track           Event Tracking


    R1(config-if)#vrrp 1 ip 192.168.10.1         //虚拟网关IP

    *Mar  1 00:09:20.763: %VRRP-6-STATECHANGE: Vl10 Grp 1 state Init -> Backup        

    *Mar  1 00:09:24.375: %VRRP-6-STATECHANGE: Vl10 Grp 1 state Backup -> Master

    R1(config-if)#vrrp 1 preempt                  //设置抢占

    R1(config-if)#vrrp 1 priority 100             //设置优先级,主要高于备用优先级

    R1(config-if)#vrrp 1 track 1                  //设置监听端口

    R1(config-if)#vrrp 1 track 2


    (2)配置vlan 20

    R1(config)#int vlan 20  

    *Mar  1 00:10:39.051: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

    R1(config-if)#ip add 192.168.20.10 255.255.255.0

    R1(config-if)#no sh

    R1(config-if)#vrrp 2 ip 192.168.20.1              

    *Mar  1 00:11:02.399: %VRRP-6-STATECHANGE: Vl20 Grp 2 state Init -> Backup     

    R1(config-if)#vrrp 2 preempt 

    *Mar  1 00:11:06.007: %VRRP-6-STATECHANGE: Vl20 Grp 2 state Backup -> Master  

    R1(config-if)#vrrp 2 priority 95              //要低于主路由器的优先级

    *Mar  1 00:12:58.911: %VRRP-6-STATECHANGE: Vl10 Grp 1 state Master -> Backup

    *Mar  1 00:13:09.515: %VRRP-6-STATECHANGE: Vl10 Grp 1 state Backup -> Master

    *Mar  1 00:13:47.295: %VRRP-6-STATECHANGE: Vl20 Grp 2 state Master -> Backup


    3.配置R2

    R2#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    R2(config)#ip routing

    R2(config)#int f1/4

    R2(config-if)#no sh

    R2(config-if)#switchport mode trunk 

    R2(config-if)#

    *Mar  1 00:10:09.595: %DTP-5-TRUNKPORTON: Port Fa1/4 has become dot1q trunk

    R2(config-if)#ex

    R1(config)#track 1 int f1/3 line-protocol 

    R1(config-track)#track 2 int f1/4 line-protocol

    R2(config)#vlan 10

    R2(config-vlan)#vlan 20


    (1)配置vlan 10

    R2(config-vlan)#int vlan 10

    *Mar  1 00:10:20.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

    R2(config-if)#ip add 192.168.10.20 255.255.255.0

    R2(config-if)#no sh

    R2(config-if)#vrrp 1 ip 192.168.10.1     

    *Mar  1 00:12:54.007: %VRRP-6-STATECHANGE: Vl10 Grp 1 state Init -> Backup

    R2(config-if)#vrrp 1 preempt 

    *Mar  1 00:12:57.619: %VRRP-6-STATECHANGE: Vl10 Grp 1 state Backup -> Master    

    R2(config-if)#vrrp 1 priority 95

    R2(config-if)#ex

    R2(config)#


    (2)配置vlan 20

    R2(config)#int vlan 20

    *Mar  1 00:13:14.543: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

    R2(config-if)#ip add 192.168.20.20 255.255.255.0

    R2(config-if)#no sh

    R2(config-if)#vrrp 2 ip 192.168.20.1         

    *Mar  1 00:13:42.375: %VRRP-6-STATECHANGE: Vl20 Grp 2 state Init -> Backup

    R2(config-if)#vrrp 2 preempt 

    *Mar  1 00:13:45.983: %VRRP-6-STATECHANGE: Vl20 Grp 2 state Backup -> Master    

    R2(config-if)#vrrp 2 priority 100

    R2(config-if)#vrrp 2 track 1

    R2(config-if)#vrrp 2 track 2

    R2(config-if)#ex


    4.分别在R1,R2上检查一下vrrp的配置是否正确

    R1#show vrrp b

    Interface          Grp Pri Time  Own Pre State   Master addr     Group addr

    Vl10               1   100 3609       Y  Master  192.168.10.10   192.168.10.1   

    Vl20               2   95  3628       Y  Backup  192.168.20.20   192.168.20.1 


    R2#show vrrp b

    Interface          Grp Pri Time  Own Pre State   Master addr     Group addr

    Vl10               1   95  3628       Y  Backup  192.168.10.10   192.168.10.1   

    Vl20               2   100 3609       Y  Master  192.168.20.20   192.168.20.1


    无误,分别配置上行口IP

    R1(config)#int f1/3

    R1(config-if)#no switchport                              将二层口变为三层口

    R1(config-if)#ip add 13.0.0.1 255.255.255.0

    R1(config-if)#no sh

    R1(config-if)#

    *Mar  1 00:14:36.199: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

    R1(config-if)#ex


    R2(config)#int f1/3

    R2(config-if)#no switchport  

    *Mar  1 00:14:50.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

    R2(config-if)#ip add 23.0.0.2 255.255.255.0

    R2(config-if)#no sh

    R2(config-if)#ex


    配置外网路由器R3

    R3#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    R3(config)#int f0/0

    R3(config-if)#ip add 13.0.0.3 255.255.255.0

    R3(config-if)#no sh

    R3(config-if)#int f0/1                     

    *Mar  1 00:15:18.651: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

    *Mar  1 00:15:19.651: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

    R3(config-if)#ip add 23.0.0.3 255.255.255.0

    R3(config-if)#no sh

    *Mar  1 00:15:32.571: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up

    *Mar  1 00:15:33.571: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

    R3(config)#int l0                           //建立虚拟接口

    *Mar  1 00:15:36.259: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up.

    R3(config-if)#ip add 3.3.3.3 255.255.255.0

    R3(config-if)#no sh

    R3(config-if)#ex


    5.使用动态协议RIP互相告知网段

    R3(config)#router rip                          //启动RIP协议

    R3(config-router)#network 3.3.3.0              //告知与自己直连网段,以便相邻路由器学习

    R3(config-router)#network 13.0.0.0

    R3(config-router)#network 23.0.0.0



    R1(config)#router rip 

    R1(config-router)#network 13.0.0.0

    R1(config-router)#network 192.168.10.0

    R1(config-router)#network 192.168.20.0



    R2(config)#router rip

    R2(config-router)#network 23.0.0.0

    R2(config-router)#network 192.168.10.0

    R2(config-router)#network 192.168.20.0


    6.可以连通测试了

    wKiom1P4jX2zX-caAAEEDhfmCbg291.jpg

    可以发现,C1走的路线是R1,C2走的路线是R2。这是刚才配置的vrrp优先级决定的。

    将R1的上行口f1/3 和 R3的f0/0口 shutdown,观察tracert的变化

    wKioL1P4j0OyCnJkAAB8aqT2Nis240.jpg

    此时R1已经的不同,电脑C1的路线已经由R1切换到了R2。

    再将R1的f1/3口和R3的f0/0口 no shutdown,观察变化

    wKiom1P4jqXzeYbgAABq6XFYVxs911.jpg

    可以发现R1又将C1的路线抢占过来了。这样,热备路由的目的已经实现。

    C2同理。

    转载于:https://blog.51cto.com/332162926/1543867

    展开全文
  • 防火墙双机热备与路由/交换机相比较的话,最主要的是会话备份的功能,路由器/交换机主备切换路由能转发就OK,防火墙需要匹配会话。防火墙双机热备的三个协议VRRP:虚拟路由冗余协议,在防火墙双机热备种主要作用是...

    防火墙双机热备与路由/交换机相比较的话,最主要的是会话备份的功能,路由器/交换机主备切换路由能转发就OK,防火墙需要匹配会话。

     

    防火墙双机热备的三个协议

     

    VRRP:虚拟路由冗余协议,在防火墙双机热备种主要作用是检测主备是否正常

    VGMP:在防火墙双机热备中主备切换不在使用VRRP,而是将VRRP加入VGMP中由VGMP来管理主备切换。默认情况下主设备VGMP优先级为65001,备用设备优先级为65000。每当VGMP管理组中的一个VRRP出现故障那么VGMP的优先级减2

    HRP:指定心跳口,用来备份会话表,server-map,以及一些命令等。


    实验拓扑

    wKiom1cDcFiBOqN_AAB1QtTlNzk539.png


    环境描述

    FW1FW2G0/0/0属于untrust区域,G0/0/1作为心跳口属于DMZ区域,G0/0/2属于untrust区域。

    VRRP1的虚拟IP192.168.10.1/24

    VRRP2的虚拟IP192.168.20.1/24

     

    实验目标

    要求C1能够访问C2

    完成流量倒换测试

    观察VGMP优先级变化


    FW1配置

    --------------------------将接口加入对应的安全区域----------------------------------

    [FW1]firewall zone trust

    [FW1-zone-trust]add int g0/0/0

    [FW1-zone-trust]quit

    [FW1]firewall zone dmz

    [FW1-zone-dmz]add intg0/0/1

    [FW1-zone-dmz]quit

    [FW1]firewall zone untrust

    [FW1-zone-untrust]add int g0/0/2

    [FW1-zone-untrust]quit

     

    ---------------------------------配置接口IP地址--------------------------------------------------

    [FW1]int g0/0/0

    [FW1-GigabitEthernet0/0/0]ip add 192.168.10.254 24

    [FW1-GigabitEthernet0/0/0]int g0/0/1

    [FW1-GigabitEthernet0/0/1]ip add 10.10.10.1 24

    [FW1-GigabitEthernet0/0/1]int g0/0/2

    [FW1-GigabitEthernet0/0/2]ip add 192.168.20.254 24

    [FW1-GigabitEthernet0/0/2]quit

     

    ------------------VRRP配置--------------------------------------------------------------------

    [FW1]int g0/0/0

    [FW1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.1 master

    //将接口加入VRRP 1中虚拟IP地址为192.168.10.1状态为主

    [FW1-GigabitEthernet0/0/0]vrrp virtual-mac enable

    //开启虚拟MAC地址功能,必须开启

    [FW1]int g0/0/2

    [FW1-GigabitEthernet0/0/2]vrrp vrid 2 virtual-ip 192.168.20.1 master

    [FW1-GigabitEthernet0/0/2]vrrp virtual-mac enable

     

    [FW1]hrp enable            //开启hrp

    [FW1]hrp auto-sync                //启用命令与状态信息的自动备份

    [FW1]hrp mirror session enable    //启动会话快速备份

    [FW1]hrp int g0/0/1              //指定心跳接口

     

     

    FW2配置

     

    [FW2]firewall zone trust

    [FW2-zone-trust]add int g0/0/0

    [FW2-zone-trust]quit

    [FW2]firewall zone dmz

    [FW2-zone-dmz]add int g0/0/1

    [FW2-zone-dmz]quit

    [FW2]firewall zone untrust

    [FW2-zone-untrust]add int g0/0/2

    [FW2-zone-untrust]quit

     

    [FW2]int g0/0/0

    [FW2-GigabitEthernet0/0/0]ip add 192.168.10.253 24

    [FW2-GigabitEthernet0/0/0]int g0/0/1

    [FW2-GigabitEthernet0/0/1]ip add 10.10.10.2 24

    [FW2-GigabitEthernet0/0/1]int g0/0/2

    [FW2-GigabitEthernet0/0/2]ip add 192.168.20.253 24

    [FW2]int g0/0/0

    [FW2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.1 slave

    [FW2-GigabitEthernet0/0/0]vrrp virtual-mac enable

    [FW2]int g0/0/2

    [FW2-GigabitEthernet0/0/2]vrrp vrid 2 virtual-ip 192.168.20.1 slave

    [FW2-GigabitEthernet0/0/2]vrrp virtual-mac enable

    [FW2-GigabitEthernet0/0/2]quit

    [FW2]hrp enable

    [FW2]hrp auto-sync

    [FW2]hrp mirror session enable

    [FW2]hrp int g0/0/1

     

    这样双机热备就配置完成了,如果想要通信还需配置区域间的安全策略,在主设备上配置安全策略会自动同步到备用设备,在备用设备上是无法配置的

     

    HRP_M[FW1]policyinterzone local untrust inbound

    HRP_M[FW1-policy-interzone-local-untrust-inbound]policy 1

    HRP_M[FW1-policy-interzone-local-untrust-inbound-1]policy source 192.168.20.0 0.0.0.255

    HRP_M[FW1-policy-interzone-local-untrust-inbound-1]action permit

    HRP_M[FW1-policy-interzone-local-untrust-inbound-1]quit

    HRP_M[FW1-policy-interzone-local-untrust-inbound]quit

    HRP_M[FW1]policyinterzone trust untrust outbound

    HRP_M[FW1-policy-interzone-trust-untrust-outbound]policy 1

    HRP_M[FW1-policy-interzone-trust-untrust-outbound-1]action permit



    测试连通性

    wKioL1cDck3wvE3rAABgNh8bIe8470.png


    使用display hrp group 命令查看VGMP的优先级

    wKiom1cDccagDNXQAABQYK6VVgQ221.png

    如图可以看出主设备的优先级为65001

    wKioL1cDcqjTOKeVAABO_wE7rEM964.png

    如图可以看出备用设备的VGPM优先级65000

     

    可以使用display hrp state查看当前hrp的状态

    FW1

    wKiom1cDciKAdLBeAAAl7GwWGac767.png

    FW2

    wKiom1cDckDRpl3MAAAi9dx8iJQ845.png


    使用display vrrp可以查看vrrp组信息

     

    FW1

     

    HRP_M[FW1]dis vrrp

    11:07:10  2016/04/05

      GigabitEthernet0/0/2 | Virtual Router 2

        VRRP Group : Master

        state : Master

        Virtual IP : 192.168.20.1

        Virtual MAC : 0000-5e00-0102

        Primary IP : 192.168.20.254

        PriorityRun : 120

        PriorityConfig : 100

        MasterPriority : 120

        Preempt : YES   Delay Time : 0

        Advertisement Timer : 1

        Auth Type : NONE

        Check TTL : YES


      GigabitEthernet0/0/0 | Virtual Router 1

        VRRP Group : Master

        state : Master

        Virtual IP : 192.168.10.1

        Virtual MAC : 0000-5e00-0101

        Primary IP : 192.168.10.254

        PriorityRun : 120

        PriorityConfig : 100

        MasterPriority : 120

        Preempt : YES   Delay Time : 0

        Advertisement Timer : 1

        Auth Type : NONE

    Check TTL : YES



    FW 2 

    HRP_S[FW2]dis vrrp

    11:09:00  2016/04/05

      GigabitEthernet0/0/2 | Virtual Router 2

        VRRP Group : Slave

        state : Backup

        Virtual IP : 192.168.20.1

        Virtual MAC : 0000-5e00-0102

        Primary IP : 192.168.20.253

        PriorityRun : 120

        PriorityConfig : 100

        MasterPriority : 120

        Preempt : YES   Delay Time : 0

        Advertisement Timer : 1

        Auth Type : NONE

        Check TTL : YES

     

     

      GigabitEthernet0/0/0 | Virtual Router 1

        VRRP Group : Slave

        state : Backup

        Virtual IP : 192.168.10.1

        Virtual MAC : 0000-5e00-0101

        Primary IP : 192.168.10.253

        PriorityRun : 120

        PriorityConfig : 100

        MasterPriority : 120

        Preempt : YES   Delay Time : 0

        Advertisement Timer : 1

        Auth Type : NONE

        Check TTL : YES


    流量倒换测试

     

    C1上一直ping C2 FW1G0/0/2接口down

    wKiom1cDcnDja0hTAACEBjiHU8A960.png


    wKioL1cDczPQIMEvAAASlvAZhsA919.png


    wKioL1cDc0_CupC4AAFlW8BQepY025.png

    由上图可以看出丢了2个包后数据正常转发


    再次查看FW1FW2VGMP优先级


    FW1

    wKiom1cDczyBmeoBAABMvU0lsgc786.png


    FW2

    wKiom1cDc1eiWINvAABGuz8waJw198.png

    由上图可以看出由于VRRPdown了一个所以优先级减2,原本的FW165001变成了64999,由于优先级小于FW2优先级所以状态转换成Backup


    转载于:https://blog.51cto.com/sunjie123/1760487

    展开全文
  • HSRP 双机热备

    2018-06-11 18:00:39
    热备路由选择协议[HSRP] 俗称双机热备。首先我们需要知道HSRP的工作原理和它的用途。其次我们需要掌握HSRP的术语参数和配置。在实际工作中,当一台交换机出现了故障时,主机没有办法自动切换网关,无法保障网络的...

    实验项目:
    1>热备路由选择协议[HSRP] 俗称双机热备。首先我们需要知道HSRP的工作原理和它的用途。其次我们需要掌握HSRP的术语参数和配置。
    在实际工作中,当一台交换机出现了故障时,主机没有办法自动切换网关,无法保障网络的正常,所以诞生了双机备份HSRP协议,它可以实 现网关备份,当其中的机器出现故障就会自动切换到备份状态的机器。HSRP就是可以实现自动切换实现备份。
    2>HSRP是通过使用同一个虚拟IP地址和虚拟MAC地址进行备份通讯。
    3>HSRP备份是由一台活跃路由,一套备份路由,一台虚拟路由和其他路由组成。每一台路由都有优先级,优先级高的将自动切换为活跃路由,优先级低的作为备份路由。虚拟路由是活跃路由和备份路由共同商量的一个结果。

    实验经过:1. 我们首先搭建好拓扑图,如下图:
    HSRP 双机热备

    1. 下面我们先来分析这个拓扑图。我们的最终目的是当活跃路由瘫痪了,备份路由是否能自动切换成活跃路由,一旦切换成功就是还能继续通讯。我们把R2做成活跃路由,所以优先级必须大于R3。接下来我们来进行配置,先重简单的开始。先配置交换机SW,这里面我们只需要把3个端口配置好速率和全双工。如下图:
      HSRP 双机热备
      3.当sw的配置完成我们接下来配置R1.这个上面我们注意的是R1需要做静态路由,需要跳两个相同的网段。如下图:
      HSRP 双机热备
      4.接下来我们可以重点关注R2的配置。这里需要注意R2需要做那些配置呢:开始我们先把端口的IP,速率,全双工做好。然后开启端口,还需要做静态路由。最后再来做HSRP。如下图
      HSRP 双机热备
      5.下面是HSRP的配置,这里需要注意的是两个路由器的组号必须相同,还有优先级,和跟踪端口的优先级。如下图:
      HSRP 双机热备
      6.最后R3的配置和上一步一样,稍许有所不同,我们来看看,如下图:
      HSRP 双机热备
      7.配置都完成了,我们来用命令:show standby brief 查看信息会得到什么.如下图:
      HSRP 双机热备
      8:我们也可以用同样命令来查另一台机器。这里就跳过,接下来我们可以来验证是否通讯,如下图
      HSRP 双机热备
      9:接下来我们来模拟一个活跃路由的故障,看看是否备份路由是否抢占,是否还能继续通讯。我们来关掉一个R2上面的端口就当是故障。如下图:
      HSRP 双机热备
      10:实验成功,有兴趣的朋友可以用抓包工具,看看数据的走向,在模拟故障后是哪台机器在工作。

    总结: 1. 使用HSRP将一组设备组合在一起,从主机来看他们就像一台虚 拟的设备

    1. 要想原来的活跃路由器能够从优先级较低的新活跃路由器那里重 新取回转发权,需要为其配置占先权
    2. 利用HSRP端口跟踪功能,可以指定HSRP监控路由上的另一个 端口。如果倍跟踪的端口down掉,其他路由就接替它王城活跃 路由
    3. 需要学会排查HSRP的故障。

    转载于:https://blog.51cto.com/13746824/2128178

    展开全文
  • 双机热备 双击热备份技术产生的原因: 理论基础 当主设备宕机,备设备会发送一个免费的arp给交换机,来冲刷交换机的mac地址...双击热备协议架构 VRRP:负责单个接口的故障检测和流量引导,每个VRRP备份组拥有一个
  • 实验目的:理解HSRP协议原理和配置;DHCP配置和应用;VLAN间路由回顾,重点理解配置思路和路由思路实验环境:三台交换机,三台路由器,...针对VLAN100配置HSRP双机热备协议,SW1作为VLAN100的HSRP为主,SW2作为VLA...
  • 首先了解生成树协议和MSTP协议,生成树协议(Spanning Tree Protocol,STP)是工作在OSI参考模型数据链路层的通信协议,基本应用是防止交换机冗余链路产生环路,从而避免广播风暴大量占用交换机资源。这种避免环路的...
  • WORD格式 整理分享范文范例 参考指导一、标识交换机二、设置口令及用户三、配置VTP(Vlan中继协议)四、配置中继线(Trunk)五、创建、描述Vlan及设置Vlan IP六、划分、描述及设置Vlan端口七、配置STP(生成树协议)八、...
  • 熟悉路由器和交换机的小伙伴们一提到网络可靠性,首先想到的肯定是VRRP协议,其实防火墙的双机热备功能也是在VRRP协议的基础上扩展而来的。所以本节我们会首先介绍VRRP的基本概念和实现原理,之后我们会...
  • keepalived 免费开源,具备第3、4、7层交换机的功能 主要提供 loadbalancing(负载均衡)和 high-availability(高可用)功能 负载均衡实现需要依赖Linux的虚拟服务内核模块(ipvs) 高可用是通过VRRP协议...
  • 热备路由协议(Hot Standby Router Protocol)   ---------------------------------------------------------------                     &...
  • 西门子交换机SCALANCE X VRRP快速入门pdf,西门子交换机SCALANCE X VRRP快速入门: 工业以太网应用在大量的工业现场,为了满足工业控制的稳定,通过SCALANCE X进行高速环网冗余(HSR)或者使用环与环之间的热备...
  • HSRP:1.启用HSRP功能,并设置虚拟地址IP, 1为standby的组号。2.相同组号的路由器属于同一个HSRP组,所有...由于局域网内大多使用三层交换机,此时HSRP是在交换机的SVI接口上配置的。1.网关冗余热备份协议HSRP(CIS...
  • Keepalived是一个基于VRRP虚拟路由冗余协议来实现的WEB 服务高可用方案,虚拟路由冗余协议 (Virtual Router Redundancy Protocol,简称VRRP),类似于工作在3,4,5层的交换机软件。利用其来避免单点故障。 ...
  • 1、处在同一或不同机箱上的路由处理器可通过使用热备路由协议共享VLAN上的冗余网关地址。 2、使用共有HSRP IP地址的路由处理器必须以属于相同HSRP组,即带有相同的组号,在一个HSRP组内的多个路由器共用一个虚拟的...
  • STP是一个需要众力协作的协议

    千次阅读 2012-03-21 19:07:49
    STP可以切掉交换以太网的环路,然而如果你真的不能容忍任何环路,必须使能所有交换机的STP协议,目前很多的本地以太网都是任意组建的,宗旨在于能用即可,而且很多低端的交换机并不支持STP协议...除了环路问题之外,...
  • 三层交换机1,2,3,4分别是vlan10,20,30,40的网关(网关IP-192.168.X.254/24) 对vlan10做HSRP热备 SW1做主网关,SW2做备份网关 Vlan10192.168.1.0/24 Vlan20192.168.2.0/24 Vlan30192.168.3.0/24...
  • HSRP的工作原理

    2010-03-18 14:34:00
    两台交换机通过Cisco的热备路由器协议(HSRP)可以实现路由设备之间的冗余,即三层交换的冗余。HSRP协议是针对于IP协议,参与HSRP协议的路由设备为IP终端提供一个虚拟IP地址,且IPX等其它网络协议与HSRP兼容。
  • HSRP的工作原理 

    2008-09-08 02:42:21
    两台交换机通过Cisco的热备路由器协议(HSRP)可以实现路由设备之间的冗余,即三层交换的冗余。HSRP协议是针对于IP协议,参与HSRP协议的路由设备为IP终端提供一个虚拟IP地址,且IPX等其它网络...
  • 配置多层交换机:HSRP(热备路由协议协议 配置多层交换机:VLAN连接互联网 配置多层交换机:配置PAT功能 配置多层交换机:指定端口变成路由器的物理接口 配置多层交换机:端口跟踪   # 综合案例设计_...
  • 一、标识交换机二、设置口令及用户三、配置VTP(Vlan中继协议)四、配置中继线(Trunk)五、创建、描述Vlan及设置Vlan IP六、划分、描述及设置Vlan端口七、配置STP(生成树协议)八、启用Vlan间 Router九、配置ACL十...
  • 华为防火墙二层HRP主备注意事项 华为防火墙没有STP协议并且透传BPDU报文以至于不能阻断端口,造成防火墙与交换机形成广播风暴,可以参考此种模式解决防火墙热备形成环路问题 !
  • 而Keepalived的核心VRRP协议,VRRP协议主要实现了在路由器或三层交换机处的冗 余;Keepalived就是使用VRRP协议来实现高可用的;下面一起来看一下Keepalived的原理图:Keepalived启动后会有三个进程:父进程:内存...
  • 大恒存储为北京工业大学视频图象研究中心提供的IP SAN存储网络...在对存储空间的管理上实现简化透明,所有设备(磁盘阵列、存储交换机、网络交换机等)都支持SNMP协议可以通过相应的图形化网管软件对设备进行集中管理。

空空如也

空空如也

1 2
收藏数 32
精华内容 12
关键字:

交换机热备协议