精华内容
下载资源
问答
  • 交换机的trunk是什么意思
    2022-06-01 07:52:36

    access端口类型:(接入链路,只能承载单一vlan数据)

    1、接收数据:

    查看数据是否携带vlan tag?

    如果携带:查看vlan tag和接口pvid是否相同,相同则接收,不同则丢弃。

    如果未携带:给数据打一个vlan tag,vlan id和接口pvid相同

    2、发送数据:

    对比数据帧携带的vlan id和出接口的pvid是否相同?

    如果相同,则剥离tag,发送原始帧出去。

    如果不同,则丢弃。

    trunk:干道链路,可以承载多vlan数据

    1、接收数据:

    要查看是否携带TAG?

    如果携带:查看放行列表是否允许,如果允许,直接收到交换机内部;如果不允许,则丢弃

    如果未携带(原始帧):打上一个TAG,vlan id和接口pvid(默认取值1)取值相同,在查看放行列表,允许则通过,不允许则丢弃

    2、发送数据:

    查看放行列表:

    如果允许放行,还要查看vlanid是否和接口的pvid相同:

    如果相同:则剥离tag,发送原始帧出去

    如果不同:则直接发出去

    如果不允许放行,则直接丢弃

    特别注意:trunk接口如果放行所有,这里所有是指本地交换机创建的所有vlan

    hybrid:混杂模式,既可以连接终端,又可以连接交换机

    1、当hybrid面对终端时:

    port link-type hybrid //将接口配置为hybrid模式,默认就是这个

    port hybrid pvid vlan 10 //相当于access的default vlan 10

    port hybrid untagged vlan 10 //相当于access接口发送数据时剥离tag;具有放行列表的作用,放行为VLAN10。

    2、当hybrid面对交换机时:

    port hybrid tagged vlan 10 //相当于trunk的放行列表

    port hybrid pvid vlan 10 //相当于trunk的pvid

    更多相关内容
  • 华为交换机怎么配置Trunk接口实现通信?交换机不配置置Trunk接口VLAN之间的数据是不能互通的,Trunk接口能收到所有VLAN的广播包信息,但是怎么配置Trunk接口?请看下文详细介绍
  • 交换机Trunk详解

    万次阅读 2019-10-10 13:21:26
    文章目录一、Trunk概述二、封装协议三...Trunk两端的交换机需要采用相同的干道协议 一般见于交换机之间或交换机与路由器、服务器之间 二、封装协议 ISL 801.1Q Cisco私有 共有标准 采用封装的方式 采用ta...

    一、Trunk概述

    在这里插入图片描述

    • 当一条链路,需要承载多VLAN信息的时候,需要使用trunk来实现
    • Trunk两端的交换机需要采用相同的干道协议
    • 一般见于交换机之间或交换机与路由器、服务器之间

    二、封装协议

    ISL801.1Q
    Cisco私有共有标准
    采用封装的方式采用tag的方式
    在原始帧的基础上封装上新帧头及新的FCS在原始的帧头中插入tag字段,去掉原有FCS,重新计算FCS
    1. baby giant frame 大于标准的MTU1500字节,但是小于2000字节
      对于采用ISL封装的,MTU=1548(下文有解释)
      对于Dot1Q,MTU=1522
    2. Vlan范围和映射
      ISL支持的vlan编号是1~1005(默认允许正常的)
      802.1q支持的vlan编号是1~4094(默认允许所有正常和扩展的)
      所以当穿过802.1q和ISL的干道的时候就需要映射。
      (1)单台交换机上最多允许8个802.1q到ISL vlan的映射
      (2)只能映射到Ethernet的vlan
      (3)该被映射的Ethernet vlan将被阻塞
      (4)映射仅在本地有效
    3. 链路聚集模式
      trunk 永久链路聚集模式,强制trunk,发送DTP帧
      Nonegotiate 永久链路聚集模式,必须手动将邻居配为干道口,不发送DTP帧。一般用于对端设备不支持DTP的情况。
      Desirable主动尝试将链路成为干道(默认模式),发送DTP帧,如果邻接接口为trunk、desirable、auto,那么此接口成为trunk。
      Auto接口愿意成为trunk,如果邻接接口被设置为trunk或desirable,那么接口就成为trunk
      Access永久的nontrunking模式,并且与对端接口协商,使其成为nontrunking链路
    Dynamic AutoDynamic DesirableTrunkAccess
    Dynamic AutoAccessTrunkTrunkAccess
    Dynamic DesirableTrunkTrunkTrunkAccess
    TrunkTrunkTrunkTrunk不建议
    AccessAccessAccess不建议Access

    三、ISL

    在这里插入图片描述

    • Cisco私有协议
    • 支持PVST
    • 在原始的数据帧基础上封装上ISL头及新的FCS
    • 没有修改原始的数据帧,因此处理效率比802.1Q高
    • VLAN字段,15个比特目前用了10个,那么最多支持210=1024个VLAN
    • “原始以太帧”最大是1518个字节,1500的ip MTU,加上源目的MAC地址共12,类型字段2个,CRC4个,再加上3字节的ISL封装,就是1548字节了
    • 上图中几个字段(ISL)的描述如下
      DA 40bit的组播地址用于标示这个FRAME是ISL的
      TYPE 标示这个帧是什么类型的,如以太、令牌环等
      SA 发送帧的原交换机MAC
      AAAA03 SNAP(固定值)
      VLAN 15个比特目前用了10个,那么最多支持210=1024 VLAN
      INDEX 这个帧的对端交换机来源端口

    所以ISL帧最大1548bytes(1518+26+4)

    四、Dot1Q

    1. 帧格式
      在这里插入图片描述
      802.1Q Tag包含4个字段,其含义如下:
    • Type长度为2字节,表示帧类型。取值为0x8100时表示802.1Q Tag帧。如果不支持802.1Q的设备收到这样的帧,会将其丢弃。
    • PRI Priority,长度为3比特,表示帧的优先级,取值范围为0~7,值越大优先级越高。用于当交换机阻塞时,优先发送优先级高的数据包。
    • CFI Canonical Format Indicator,长度为1比特,表示MAC地址是否是经典格式。CFI为0说明是经典格式,CFI为1表示为非经典格式。用于区分以太网帧、FDDI(Fiber Distributed Digital Interface)帧和令牌环网帧。在以太网中,CFI的值为0.
    • VID VLAN ID ,长度为12比特,表示该帧所属的VLAN。在VRP中,可配置的VLAN ID取值范围是1~4094。
    1. 优缺点
    • 缺点是破环了原始以太网帧以及重新计算FCS,ISL是直接封装头和尾。
    • Dot1Q公用,ISL私有
    • 802.1Q支持4096个VLAN 最大帧:1518+4=1522
    1. Native Vlan
    • 在802.1q的native vlan是不打标签的,使用Dot1q的交换机把所有未标记的frame转发到native vlan中,而ISL会对所有的数据帧,包括native vlan进行封装,因此如果没有封装的数据帧它会丢弃(ISL没有native vlan的概念)
    • Native vlan所属的帧在经过trunk时不打标签
    • Native vlan在Trunk两端必须匹配,否则会出现vlan流量互串
    • 默认的native vlan时vlan 1
    • 建议将一个生僻的vlan配置为native vlan

    在这里插入图片描述
    我们看上面这个图,两台交换机trunk两端native vlan不一样,会有什么问题?首先两端的vlan2通信肯定是没有问题的,但是vlan3和vlan4通信就有问题了,左边vlan3的用户发出来的数据帧从左交换机出去上trunk,是不打标签的,但是这些数据帧到了右交换机,它会认为这些数据帧是属于vlan4的,这就出现了问题。

    • 相关配置:
      Switch(config-if)# switchport trunk native vlan ?
      在trunk上设置native vlan
      Switch(config)# vlan dot1q tag native
      上述命令将对native vlan也打标签
    1. Vlan范围
    VLAN的范围作用
    0,4095保留,系统使用
    1Cisco默认vlan
    2~1001For Ethernet VLANS
    1002~1005Cisco默认为FDDI及TokenRIng定义
    1006~4094只能为Ethernet使用,在一些特殊平台被保留使用

    五、DTP

    • Trunk可以手工静态配置或者通过DTP进行协商
    • DTP使得交换机之间能够进行Trunk协商
    Trunk永久链路聚集模式,强制trunk,发送DTP帧
    Nonegotiate不发送DTP帧。一般用于对端设备不支持DTP的情况;需要搭配手工指定的trunk或access 模式命令
    Desirable主动尝试将链路成为干道(默认模式)。发送DTP帧,如果邻接接口为trunk、desirable、Auto,那么此接口成为Trunk
    Auto接口有意愿成为trunk,但是不会主动发送DTP/如果邻接接口被设置为trunk或desirable,那么接口就成为trunk,会被动响应DTP协商数据帧
    Access永久的nontrunking模式,并且与对端接口协商,使其成为nontrunking链路
    Dynamic AutoDynamic DesirableTrunkAccess
    Dynamic AutoAccessTrunkTrunkAccess
    Dynamic DesirableTrunkTrunkTrunkAccess
    TrunkTrunkTrunkTrunk不建议
    AccessAccessAccess不建议Access

    六、Trunk配置

    Switch(config-if)# switchport mode access
    将接口设置为access模式
    Switch(config-if)# switchport mode encapsulation {dot1q | ISL}
    如果接口为trunk,设置干道协议类型
    Switch(config-if)# switchport mode dynamic {auto | desirable}
    将接口设置为DTP动态协商,可选auto或desirable
    Switch(config-if)# switchport nonegotiate
    将接口设置为nonegotiate,不发送DTP帧,如果配置为非协商,那么就必须手工
    配置接口模式,为access或trunk

    在这里插入图片描述

    SW1(config)# interface fast0/23
    SW1(config-if)# switchport trunk encapsulation dot1q
    SW1(config-if)# switchport mode trunk
    SW1(config-if)# switchport native vlan 1
    SW1(config-if)# switchport nonegotiate
    SW1(config-if)# switchport trunk allowed vlan ?
      WORD   VLAN IDs of the allowed VLANs when this port is in trunking mode
      add     add VLANs to the current list
      all     all VLANs
      except   all VLANs except the following
      none     no VLANs
      remove   remove VLANs from the current list
    

    上图中,两端PC都属于vlan10的话,如果SW1的Fa0/23口将vlan10 remove掉,那么PC肯定就无法通信了。

    七、MTU问题

    MTU就是最大传输单元,不同的系统对于MTU的设定和理解使不同的。Cisoc IOS善,interface x接口模式下:

    • MTU指的使二层的MTU,这是接口MTU,值得是不包含二层帧头的、payload的MTU,这个MTU值一般是不能手工修改的,默认是1500字节。如此一来Cisco路由器支持的二层数据帧最大值就是1500的payload加上二层帧头及二层FCS:目的MAC 6字节+源MAC 6字节+类型字段2字节+FCS 4字节,所以总的就是1518字节。
    • IP MTU值得是三层的MTU,这个值可以手工修改,但是最大值必须小于接口的二层MTU值也就是1500.这个MTU指的是三层IP包的总大小,如果接口发出的包大于这个接口的IP MTU,那么这个ip包将被分片
      在这里插入图片描述
      做个测试:上图中,R1的fa0/0口 ip mtu为1500,
      我们去ping 1.1.1.2 repeat 1 size 1500,我们会发现R1直接将一个ICMP包发出去了,没有分片。
      从报文中我们可以得出,这个IP包的大小为1500字节。
      其中ip报头20字节,ICMP报头8字节,ICMP data荷载1472字节,刚好1500字节。
      因此在CISCO IOS设备上,ping后面跟着的size指的就是发出去的IP包整个的大小。而在windows PC 的cmd下,ping后跟的包大小就是ICMP data大小,ping –l 1472,产生的包就是1500字节
      还是上面的例子,如果我们在R1上,ping 1.1.1.2 repeat 1 size 1501,这个时候,R1由于产生的这个IP包大于mtu 1500,因此会被分片,然后在R2上,这两个分片被重组。

    转载:鸿鹄论坛

    展开全文
  • Cisco交换机Trunk配置命令是什么

    千次阅读 2020-12-28 20:22:40
    展开全部TRUNK(端口636f707962616964757a686964616f31333431356633汇聚)是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于...

    展开全部

    TRUNK(端口636f707962616964757a686964616f31333431356633汇聚)是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立端口的独享的高带宽。

    Trunk是一种封装技术,它是一条点到点的链路,链路的两端可以都是交换机,也可以是交换机和路由器,还可以是主机和交换机或路由器。

    基于端口汇聚(Trunk)功能,允许交换机与交换机、交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行连接同时传输以提供更高带宽、更大吞吐量,大幅度提供整个网络能力。

    在语音级应用的线路中,trunk一般指“主干网络、电话干线”,即两个交换局或交换机之间的连接电路或信道,它为两端设备之间进行转接,作为信令和终端设备数据的传输链路。

    扩展资料

    TRUNK功能具体应用

    1、TRUNK功能用于与服务器相联,给服务器提供独享的高带宽。

    2、TRUNK功能用于交换机之间的级联,通过牺牲端口数来给交换机之间的数据交换提供捆绑的高带宽,提高网络速度,突破网络瓶颈,进而大幅提高网络性能。

    3、Trunk可以提供负载均衡能力以及系统容错。由于Trunk实时平衡各个交换机端口和服务器接口的流量,一旦某个端口出现故障,它会自动把故障端口从Trunk组中撤消,进而重新分配各个Trunk端口的流量,从而实现系统容错。

    展开全文
  • 在技术领域中把TRUNK翻译为中文是“主干、干线、中继线、长途线” ,不过一般不翻译,直接用原文。... 在电信网络的语音级的线路中,Trunk指“主干网络、电话干线”,即两个交换局或交换机之间的连接电路或信道,它能
  • 还有在具体的交换机产品中怎样来交换机TRUNK配置,下面我们来了解一下这些方面的知识。在二层交换机的性能参数中。  常常提到一个重要的指标:TRUNK,许多的二层交换机产品在介绍其性能时,都会提到能够支持TRUNK...
  • 在二层交换机的性能参数中,常常提到一个重要的指标:TRUNK...那到底什么TRUNK呢?使用TRUNK功能到底能给我们带来哪些应用方面的优势?还有在具体的交换机产品中怎样来配置TRUNK。本文我们来了解一下这些方面的知识。
  • 华为交换机Trunk配置

    千次阅读 2021-03-12 15:11:15
    华为交换机Trunk配置 Trunk 采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继...

    华为交换机Trunk配置

    Trunk
    采用Trunk中继链路技术可以实现不同交换机同网段的Vlan间通信。Trunk中继技术可以实现在一条物理线路中可以传递多个Vlan间的信息,如:交换机从属于Vlan2的端口接收到数据,在Trunk中继链路上进行传输前,会先打上一个标记,表明该数据包是Vlan2的,到达对方交换机时,交换机会将该标记去掉,只发送到属于Vlan2的端口上。

    例:以下拓扑图中,子网掩码都为255.255.255.0
    Vlan1:
    左:192.168.1.1 192.168.1.2
    右:192.168.1.3 192.168.1.4
    Vlan2:
    左:192.168.:2.1 192.168.2.2
    右:192.168.2.3 192.168.2.4
    Vlan3:
    左:192.168.3.1 192.168.3.2
    右:192.168.3.3 192.168.3.4
    在这里插入图片描述
    S3700-LSW1

    <Huawei>system-view
    [Huawei]interface Eth0/0/7
    [Huawei-Ethernet0/0/7]port link-type trunk
    [Huawei-Ethernet0/0/7]port trunk allow-pass vlan all
    [Huawei]display current-configuration
    #
    interface Ethernet0/0/1
     port link-type access
    #
    interface Ethernet0/0/2
     port link-type access
    #
    interface Ethernet0/0/3
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/4
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/5
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/6
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/7
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    

    S3700-LSW2

    <Huawei>system-view
    [Huawei]interface Eth0/0/3
    [Huawei-Ethernet0/0/3]port link-type trunk
    [Huawei-Ethernet0/0/3]port trunk allow-pass vlan all
    [Huawei]display current-configuration
    #
    interface Ethernet0/0/1
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/2
     port link-type access
     port default vlan 2
    #
    interface Ethernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface Ethernet0/0/4
     port link-type access
    #
    interface Ethernet0/0/5
     port link-type access
    #
    interface Ethernet0/0/6
     port link-type access
     port default vlan 3
    #
    interface Ethernet0/0/7
     port link-type access
     port default vlan 3
    

    测试
    在这里插入图片描述
    不同交换机同网段Vlan之间能够互相ping通,说明两个交换机接口配置的Trunk中继链路技术实现成功。

    https://mp.weixin.qq.com/s/d9oJ121SubyTyf7d-F3LeQ

    展开全文
  • 1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访; 2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口10的IP地址为10.1.1.254/24,VLAN接口20的IP地址为...
  • 交换机trunk接口

    千次阅读 2020-05-08 11:49:28
    以太网通常由多台交换机组成,为了使VLAN的数据帧跨越多台交换机传递,交换机之间互连的链路需要配置为干道链路(Trunk Link)。 干道链路是用在不同的设备之间(如交换机和路由器之间、交换机交换机之间)承载多个...
  • 交换机TRUNK配置问题

    2020-10-23 14:26:24
    TRUNK作为一个重要的指标,常常在二层交换机的性能参数中被提到,许多的二层交换机产品在介绍其性能时,都会提到能够支持TRUNK功能,从而可以为互连的交换机之间提供更好的传输性能。一下就是TRUNK的介绍
  • 交换机Trunk端口配置,功能需求及组网说明,配置环境参数,数据配置步骤,配置命令代码,利用将端口配置为Trunk端口来完成在不同交换机之间透传VLAN,达到属于相同VLAN的PC机,跨交换机进行二层访问;或者不同VLAN的...
  • 核心交换机TRUNK配置功能非常重要,同时对TRUNK进行合理的配置,可以为互连的交换机之间提供更好的传输性能。到底什么TRUNK呢?使用TRUNK功能到底能给我们带来哪些应用方面的优势?还有在具体的核心交换机产品中...
  • 交换机trunk配置

    千次阅读 2019-05-15 13:49:30
    在路由器上配置DHCP服务为客户端自动分配IP地址如图 1,VLAN 1:192.168.1.0/24 2,网关192.168.1.244 3,首选DNS为202.106.0.20 4,预留IP地址打印服务器:192.168.1.1 5,预留IP地址文件服务器:192.168.1.10 ...
  • 大部分的公司选用的交换机同时有cisco、h3c,如果在cisco接口上启用的协议不当,cisco的交换机和h3c的交换机在作trunk后就会不通。本文通过实例,分析了该现象产生的原因和解决办法。
  • H3C交换机与CISCO交换机trunk设置注意事项收集.pdf
  • H3C交换机与CISCO交换机trunk设置注意事项[参照].pdf
  • Trunk概念

    千次阅读 2021-04-03 20:38:13
    一、为什么需要trunk? 1、当一条链路,需要承载多VLAN信息的时候,需要使用trunk来实现。 2、trunk两端的交换机需要采用相同的干道协议。 3、一般见于交换机之间或交换机与路由器、服务器之间。 二、trunk实现原理 ...
  • 华为交换机配置VLAN-TRUNK
  • 交换机TRUNK配置的问题.docx
  • 实验四 交换机TRUNK口和单臂路由实验 一、实验目的 1、理解交换机VLAN口的工作原理; 2、理解交换机TRUNK口的工作原理; 3、掌握单臂路由的配置方法; 二、实验的网络拓扑结构图 1.交换机VLAN配置实验 ...
  • 一: 连接 ...三:利用主机2进行配置,划分端口到VLAN10,并设置交换机和路由器的一号端口为 trunk模式 1.en 2.conf 3.vlan 10 4.name vlan10 5.exit 6.interface f0/2 7.switchport access vlan 10 8..
  • 交换机trunk模式工作原理

    万次阅读 2017-03-02 10:20:46
    TRUNK是端口汇聚的意思,允许交换机交换机交换机与路由器、主机与交换机或路由器之间通过两个或多个端口并行连接同时传输以提供更高带宽、更大吞吐量, 大幅度提供整个网络能力。VLAN TRUNK一般是你设置了多个...
  • 这让我不解,因为SW6上所有的接口我都设置为trunk口,而且开发所有的vlan都通过,但是为什么STA6的dhcp广播包发送不出去呢? 原来我在SW6上没有创建对应的vlan,因为STA发出的DHCP报文时带有vlan101标签的,但是我...
  • 做这个首先要明白什么trunktrunk 是实现不同网络设备的不同Vlan之间的通信 注意: 网卡也属于网络设备,设置vlan后也可以通信 先说下我的环境 网络工程师在两台交换机上做了两个trunk模式的vlan 两个口分别连接...
  • 思科交换机配置trunk模式及vtp

    千次阅读 2022-03-21 09:12:25
    如果交换机交换机之间存在多条链路,交换机每增加一个vlan,交换机交换机就会增加一条链路。这样会存在链路浪费,就产生了 DTP ( dynamic trunk protocols)采用trunk后,所有的vlan都走一条线。 二、 TRUNK ...
  • S系列交换机 Eth-Trunk特性指导
  • 思科交换机如何配置Trunk

    千次阅读 2021-02-25 14:30:58
    1、理解Trunk的运行原理 2、掌握Trunk的配置方法 实验拓扑 实验需求 1、根据实验拓扑图,完成设备的基本配置; 2、分别在SW1和SW2创建VLAN10和VLAN20,名字为IT和HR; 3、分别在SW1和SW2上把相应...
  • 华为交换机VLAN配置(TRUNK

    千次阅读 2022-01-17 16:29:55
    Lsw1配置(Lsw2同样): <Huawei>u t m Info: Current terminal monitor is off. <Huawei>...[Huawei]sysname lsw1 //更改交换机名称lsw1 [lsw1]vlan batch 10 20 30 40 //创建vlan...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 26,024
精华内容 10,409
热门标签
关键字:

交换机的trunk是什么意思