精华内容
下载资源
问答
  • 文章目录交换机详细工作原理交换机基本配置实验交换机的工作原理1.初始状态2.学习源MAC地址3.广播未知数据帧4.接收方回应5.交换机实现单播通信交换机基本配置实验●实验目的:●实验环境:●实验步骤:●实验...

    交换机详细工作原理及交换机的基本配置实验

    交换机的工作原理

    核心:

    学习源MAC地址,转发目标MAC地址,没有MAC地址广播泛洪。

    学习MAC地址的同时会记录对应的端口。

    泛洪:指交换机在MAC表中无法找到与数据帧目标地址一致的条目,就将数据帧从所有端口发送出去(除了接收该数据帧的端口),以期找到目标主机来接收数据帧。

    1.初始状态

    一台初始化交换机,三台初始化PC机。

    在这里插入图片描述

    2.学习源MAC地址

    A主机要把数据帧发给B主机,因为现在交换机处于初始状态,它的MAC地址表是空的,A主机的数据帧通过1端口进入交换机,此时交换机会学习到源MAC地址即A主机的MAC地址并和1端口对应起来。
    在这里插入图片描述

    3.广播未知数据帧

    交换机现在已经学习到了源MAC地址(A主机),但是它的MAC地址表里没有目的主机的MAC地址,所以它会向除了1端口外的其他所有端口进行广播,此时B和C都会接收到转发来的数据帧。

    在这里插入图片描述

    4.接收方回应

    B和C接收到数据帧以后,C拆开数据帧发现对方的目的MAC地址不是自己,所以不作回应,丢包。B主机拆开后发现对方的目的MAC地址正是自己,所以要作出回应,它向交换机发出一个数据帧,包含源MAC地址(B)和目的MAC地址(A),数据帧通过2端口进入交换机,这时交换机会把这个数据帧的源MAC地址和端口对应起来,添加到MAC地址表中。
    在这里插入图片描述

    5.交换机实现单播通信

    此时,在交换机的MAC地址表中存有A和B电脑的MAC地址和端口,两台电脑若再有通信需求交换机就不会再向其他电脑进行广播了。但是在交换机中有MAC地址老化机制,即300s内两台电脑没有通信则交换机会将两台电脑的MAC地址进行删除,此后通信则需要交换机再次进行广播。这是交换机的动态学习过程。

    交换机的基本配置实验

    ●实验目的:

    1.通过实验更好的了解交换机的工作原理。

    2.通过命令查看MAC地址表,观察各个接口对应哪些MAC地址。

    3.配置交换机互连接口的双工以及速率。

    ●实验环境:

    华为ensp模拟器,两台初始化交换机,四台初始化PC机。

    ●实验步骤:

    1.打开ensp软件,新建如下图所示的拓扑图。

    在这里插入图片描述

    2.打开所有设备,给四台PC配相同网段的IP地址。这里配的是(192.168.10.0/24)网段的。
    在这里插入图片描述

    3.双击PC2,在命令行里输入ping 192.168.10.10 -t命令,使其长pingPC1的IP地址,让PC2的数据帧能够发送出去。
    在这里插入图片描述

    4.右击GE0/0/2端口,点击开始抓包。
    在这里插入图片描述

    5.抓包软件Wireshark自动开始抓包。
    在这里插入图片描述

    6.双击SW1交换机,输入dis mac-address的命令,回车。我们会发现此时SW1交换机已经学习到PC1和PC2的MAC地址信息了,并和它们连接的交换机端口是相对应的。
    在这里插入图片描述

    7.同理,我们将PC3和PC4分别长pingPC1,让它们的数据帧也发送给PC1。再查看SW1交换机的MAC地址表时,我们发现PC3和PC4的MAC信息也已经被学习到了。
    在这里插入图片描述

    8.此时我们查看一下SW2交换机的MAC地址表,发现PC1、PC3、PC4的MAC地址已经存在,这是因为刚才PC3和PC4刚才传数据帧给PC1的时候,SW2交换机也已经学习到了PC1、PC3、PC4的MAC地址。
    在这里插入图片描述

    9.但是SW2交换机并没有学习到PC2的MAC地址,只需要PC3或者PC4长ping一下PC2的IP地址(发送数据帧给PC2),SW2交换机就也能学习到PC2的MAC地址了。

    在这里插入图片描述
    10.为了调整g0/0/1接口的速率,我们先要进入g0/0/1接口,关闭自动协商功能。

    在这里插入图片描述

    11.调整g0/0/1接口的速率为100M,输入dis this命令,我们可以查到刚才输入关闭自动协商和调整速率的命令。

    在这里插入图片描述
    12.如需调整全双工,输入duplex full命令,半双工为duplex haif命令。
    在这里插入图片描述
    在这里插入图片描述

    ●实验总结:

    1.通过实验能够更好的了解交换机的转发原理:学习源MAC地址,转发目标MAC地址,没有MAC的广播泛洪。

    2.通过查看交换机的MAC地址表,我们发现每个端口都与其各自连接的PC主机的MAC地址相对应,如果一个端口连接了另外一台交换机,则这个端口对应了与另外一台交换机相连的所有的PC主机。(例如本实验中SW1交换机的GE0/0/3接口对应了与SW2交换机相连的所有PC主机的MAC地址。)
    在这里插入图片描述

    实验过程中遇到的一个小问题:

    在PC2中长pingPC1的IP地址后,我们需要进行抓包,此时不能CTRL+C停止PC2的长ping,停止后会发现抓包软件无法抓取到数据包(因为PC2不再发送数据帧了)。

    展开全文
  • 网络原理实验1 交换机基本配置

    千次阅读 2019-10-11 00:43:48
    实验原理交换机是一种用于电、光信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。 交换机配置需要使用交换机IOS提供的命令进行。与路由器类似,交换机配置命令有...

    赞赏码 & 联系方式 & 个人闲话

    【实验名称】交换机的基本配置

     

    【实验目的】

    1、了解交换机的基本结构

    2、掌握交换机的管理特征

    3、学会交换机的基本配置。

     

    【实验原理】

    交换机是一种用于电、光信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。

    交换机的配置需要使用交换机IOS提供的命令进行。与路由器类似,交换机的配置命令有多种模式,不同模式配置的参数不同,执行的命令不同。交换机的4种主要命令模式:用户模式(user mode)、特权模式(privileged mode)、全局配置模式(configuration mode)、接口配置模式(interface configuration)。

     

    【实验内容】

    项目1:超级终端协议的设置及交换器的启动

    1、首先按实验要求接线,建立一个新连接,设置参数,并启动交换机。

    2、查看交换机版本信息和硬件信息

    首先使用enable命令,输入密码star,进入特权模式。

    再输入show version命令,查看交换机版本信息和硬件信息。

    3、显示交换机当前的配置

    使用show running-config命令查看交换机当前的配置

    4、特权模式下,查看交换机NVRAM中备份的配置文件内容

    在前几题中已经进入特权模式,直接使用show config查看交换机NVRAM中备份的配置文件内容。

    5、全局配置模式

    在特权模式下输入config terminal命令进入全局配置模式。

    可以看到提示符变为:Switch(config)#,在全局配置模式下,可以设置交换机的名字、用户口令等一些基本参数。若想退出全局配置模式,输入end命令即可退回特权模式。

    6、接口配置模式

    在全局配置模式下输入命令: interface <端口类型> <端口号>即进入接口配置模式,提示符变为Switch(config-if)#

    在端口配置模式下,可以对端口采用封装协议、IP地址和工作模式等参数进行配置。

     

    项目2 交换机的基本配置

    1、设置交换机的名字

    在全局配置模式下,设置交换机的名字:Switch (config)# hostname LXJ

    2、设置密码

    使用enable secret level 15 0 star命令设置密码,其中star可以替换成自己想要设置的密码。该密码在显示交换机配置文件中时是一串加密的字符串。从用户模式到特权模式时需要用该密码进行验证,验证通过后才能进入特权模式。

    3、复位交换机

    在特权模式执行reload命令即可复位交换机。在复位的时候,交换机会给出确认是不是真的要复位,还会提示保存当前配置的信息。

    System configuration has been modified. Save?[yes/no]:n

    Proceed with reload?[confirm]

    4、保存当前的配置信息

    在完成交换机修改配置后,需要保存当前配置,否则在交换机复位时,已做的配置和修改都会丢失。

    在特权模式下执行的,其命令如下Switch #write memory

    5、清除NVRAM中保存的配置文件

    使用delete flash:config.text清除NVRAM中保存的配置文件,在重启交换机。中间过程需要输入一些配置信息,因为原配置信息已经被删除。

     

    项目3 交换机的密码清除

    步骤1  打开PC上的超级终端--还原默认值--波特率设置为每秒57600

    步骤2  交换机断电--交换机加电

    步骤3  交换机加电3秒内点击确定、然后快速按键盘上“ESC”一直按到出现对话提示为止,此时进入交换机ctrl层。

    步骤4  Continue with configuration dialog ?[y/n] y 回车

    显示如下界面:

    选择菜单中“4”输入“config.text”,删除保存密码信息的文件。。

    再选择 6运行主程序即可,此时配置丢失,不用输入密码就可以进入特权模式了。

    随后我们就可以进行设置新密码等一系列操作了。

     

    【小结或讨论】

    实验中中我遇到了命令理解的困难,比如enable secret level 15 0 star命令中,我不太理解15和0的含义,书上也没有具体说明。再询问老师后我才知道15代表了权限等级,0则是函数的输入参数。在做最后一个项目是,需要断电后快速敲击ESC键进入交换机ctrl层来删除配置文件,让我觉得十分有趣。

     

    展开全文
  • 这里写目录标题一、交换机的工作原理二、交换机以太网接口的工作模式一级目录一级目录一级目录 一、交换机的工作原理 基于源MAC地址学习。 基于目标MAC地址转发。 对于没有目标MAC地址表项的帧,向本VLAN的其他所有...

    一、交换机的工作原理

    • 基于源MAC地址学习。
    • 基于目标MAC地址转发。
    • 对于没有目标MAC地址表项的帧,向本VLAN的其他所有接口转发。
    • 收到广/组播帧后,向本VLAN的其他所有接口转发。
    • 同一个MAC地址可以被多个接口学习到,选择后学习到的接口。
    • 同一个接口可以学习到多个MAC地址。

    二、

    1.初始状态
    2.MAC地址学习
    3.广播未知数据帧
    4.接收方回应
    5.交换机实现单播通信
    【先学习(源地址)再转发(目标地址)】

    三、交换机以太网接口的工作模式

    • 单工:两个数据站之间只能沿单一方向传输数据。
    • 半双工:两个数据站之间可以双向数据传输,但不能同时进行。
    • 全双工:两个数据站之间可双向且同时进行数据传输。
    • 交换机以太网接口速率:1.接口连接时进行协商;2.协商失败则无法正常通信。(类似木桶原则)

    四、交换机的基本配置实验

    • 实验目的:
      1.通过实验更好的了解交换机的工作原理。
      2.通过命令查看MAC地址表,观察各个接口对应哪些MAC地址。
      3.配置交换机互连接口的双工以及速率。
    • 实验环境:
      华为ensp模拟器,两台初始化交换机,四台初始化PC机。
    • 实验步骤:
      1.打开ensp软件,新建如下图所示的拓扑图。
      在这里插入图片描述
      2.开启所有设备,给四台PC配相同网段的IP地址。这里配的是(192.168.1.0/24)网段的。
      在这里插入图片描述
      在这里插入图片描述
      在这里插入图片描述
      在这里插入图片描述
      3.双击其中一台PC,在命令行里输入ping其他PC机地址命令,使其长ping其他PC的IP地址,让PC2的数据帧能够发送出去就行了。
      在这里插入图片描述

    一级目录

    一级目录

    展开全文
  • 交换机基本配置实验报告,1,了解交换机的工作原理。2,掌握交换机配置模式。3,掌握交换机基本配置。4,掌握交换机的安全配置
  • 交换机配置实验报告,和号很实用,是思科的配置
  • 以太网格式三、交换机的工作原理1.交换机以太网接口的工作模式:四、交换机的命令行配置1.配置前的准备2.SecureCRT软件的配置3.管理设别的方式4.Vlan概述1.常用的端口类型2.相同Vlan通信与不同Vlan通信单臂路由实验 ...

    前言

    一、数据链路层功能

    在这里插入图片描述数据链路层位于网络层与物理层之间

    数据链路层的功能:
    1.数据链路的建立、维护与拆除
    2.帧包装、帧传输、帧同步
    3.帧的差错恢复
    4.流量控制

    二、以太网

    在这里插入图片描述
    以太网工作在数据链路层

    以太网MAC地址: 用来识别一个以太网上的某个单独的设备或一组设备
    在这里插入图片描述
    注:MAC地址是全球唯一的

    1.以太网格式

    在这里插入图片描述
    以太网帧格式:Ethernet ||帧格式

    三、交换机的工作原理

    交换机工作原理:
    1.基于源MAC地址学习
    2.基于目标MAC地址转发
    3.对于没有目标MAC地址表项的帧,向本Vlan的其他所有接口转发
    4.收到广/组播帧,向本Vlan的其他所有接口转发
    5.同一MAC地址被多个接口学习到,选择后学习到的接口
    6.同一接口可以学习到多个MAC地址

    1.交换机以太网接口的工作模式

    单工:两个数据站之间只能沿单一方向传输数据
    在这里插入图片描述

    半双工:两个数据站之间可以双向数据传输,但不能同时进行
    在这里插入图片描述

    全双工:两个数据站之间可双向且同时进行数据传输
    在这里插入图片描述

    交换机以太网接口速效率
    1.接口连接时要进行协商
    2.协商失败则无法正常通信
    注:百兆交换机和千兆交换机要协商好,要不然数据通信不了

    四、交换机的命令行配置

    1.配置前的准备

    Console电缆

    物理连接:1.计算机COM口 2.交换机/路由器Console口

    软件连接:1.超级终端 2.其他软件

    2.SecureCRT软件的配置

    在这里插入图片描述
    协议:Protocol
    端口号:Port
    波特率:Baud rate
    数据位:Data bits
    奇偶校验位:Parity
    停止位:Stop bits
    流控(下面的选项一般都不选):Flow Control
    注:只有端口号Port要选择变,其他都是一个定值

    3.管理设别的方式

    带内管理:指的是网络管理控制信息于用户承载业务的网络是同一个逻辑通道。即使用到带宽的管理方式。
    带内管理的方式:WEB、Telnet(telnet时用的外网的IP)

    带外管理:指的是网络管理控制信息与用户承载业务的网络不是同一个逻辑通道,即使用内网的管理方式,不占用带宽。
    带外管理的方式:Console、Telnet(telnet时用的是内网的IP)

    在这里插入图片描述

    4.Vlan概述

    Vlan(虚拟局域网)
    pc到pc之间是在物理局域网中,可以正常通信,但是设置完Vlan时就是给每个pc设置了一个虚拟局域网,每个PC都是一个单独的个体不能通信(因为它们不在同一个虚拟局域网中是不能通信的)

    华为支持Vlan数量是1-4094
    一个Vlan=一个广播域=逻辑网络(子网)
    Vlan作用:分段 灵活性 安全性

    Vlan的运作
    1.每个逻辑的Vlan就像一个独立的物理桥
    2.交换机上的每一个端口都可以分配给不同的Vlan(交换机每个接口只能属于一个Vlan)
    3.默认的情况下,所有端口都属于Vlan1

    1.常用的端口类型

    常用的端口类型是:access、trunk、hybrid
    access:接口类型,一个接口属于一个Vlan。连接对象是PC机

    int e0/0/1    #接口1设置为10兆接口
    port link-type access   #接口类型设置位access
    port default vlan 2     #把这接口划分到Vlan中
    

    trunk:单条链路承载多Vlan的数据流量。连接对象是交换机

    port trunk allow-pass vlan 10 20 30    #允许Vlan10 20 30的流量通过
    undo port trunk allow-pass vlan 1      #去除Vlan 1的流量
    

    hybrid:混合接口,可以选择以access还是trunk接口属性工作。

    port hybrid pvid vlan 2       #把这个hybrid分到Vlan2中
    port hybrid untagged vlan 2   #脱标签,(PC机不能收到带有标签的命令)
    
    
    //设置接口类型,vlan流量命令
    Port  link-type  ? #选择接口类型
    
    access:int  e0/0/0         #设置选择10兆接口
    port  link-type  access    #连接对象是access设置接口类型 
     port  default  vlan 2     #把这个接口划分到Vlan2中
    
    port  trunk  allow-pass  vlan  10 20 30    #设置允许特定流量通过   all(放行所有)
    undo  port  trunk  allow-pass  vlan  10    #去除特定流量
    
    hybrid:port  hybrid  pvid  vlan 2           #把这hybrid分到vlan2中
    port  hybrid  untagged  vlan  2             #PC机不收有标签的命令,脱标签
    clear  configuration   interface  e0/0/3    #消除接口下的所有命令
     
    untagged:出交换机会指定标签解除一张列表
    tagged:当某些指定Vlan(有相应标签)经过交换机时,无条件放行的一张列表
    **注:同一个Vlan只能存在于untagged和tagged表中其中一个**
    

    2.相同Vlan通信与不同Vlan通信

    相同Vlan通信:
    ·情况一:同一台交换机相同Vlan通信,查看MAC地址表,将打了相同Pvid标签数据包转发到对应的端口上起
    ·情况二:跨交换机,通过trunk技术实现多Vlan数据通信,可以帮助我们实现相同的Vlan通信。

    不同Vlan通信(不同网段):
    ·单臂路由
    组成:一台二层交换机和一台路由

    ·三层交换
    组成:三层交换机

    ·Vlan封装的方式:802.1q

    5.STP生成树

    1.环路引起的问题

    1.环路引起的问题一:广播风暴
    在这里插入图片描述
    环路引起的问题二:MAC地址表不稳定
    在这里插入图片描述

    2.STP生成树协议

    生成树协议的作用:
    因为当有环路存在时,广播的发送会引起全网的广播风暴,因此需要打破环路生成的条件,而生成树协议就是解决二层广播风暴的重要手段,另外我们会阻塞一些端口,打破环路生成条件,当链路出现问题时,这些被阻塞的端口可以过渡到转发状态,实现链路的备份作用。

    在这里插入图片描述

    3.BPDU网桥协议

    1.BPDU(Bridge Protocol Data Unit)网桥协议数据单元
    对于参与STP的所有SW,他们都通过数据消息的交换来获取网络中其他SW的信息,这种消息就被称为BRDU。
    BPDU是直接封装在二层的协议

    2.BPDU的功能:
    1.选举根网桥
    2.确定冗余路径的位置
    3.通过阻塞特定端口来避免环路
    4.通告网络的拓扑变更
    5.监控生成树的状态

    3.BPDU的两种类型:
    1.配置BPDU–通常由根网桥以周期性间隔发出,包括STP参数,用于进行各种选举。
    2.TCNBPDU–这种BPDU是交换机检测到拓扑发送变更时所产生的。

    4.选举根交换机的规则
    lowest BID=网桥优先级(32768)+MAC地址(越小越优)
    交换机默认网桥优先级是32768

    5.设置成根网桥的两种方法

    //1.修改网桥优先级命令
    [SW1]stp Priority  0(数值需要设定为4096的倍数)
    
    //2.设置此网桥为根网桥
    [SW1]stp  root  primary(优先级将变为0)
    
    display  stp   #查看根网桥命令
    CLST Root/ERPC #表示根网桥
    

    6.端口角色:
    RP:根网桥。每个非根网桥上有且只有一个,选举到达根网桥上路径开销值最小的成为根网桥
    DP:指定端口。根网桥上每个端口都是指定端口,非根网桥上需要转发数据的端口也是指定端口
    AP:预备端口。该接口状体为blocking状态,只收BPDU,不发BPDU

    端口状态描述:
    Disabled(禁用状态): 不转发数据帧,不学习MAC地址表,不参与生成树计算
    Discarding(阻塞状态): 不转发数据帧,不学习MAC地址表,接收并处理BPDU,不发送BPDU
    Listening(侦听状态): 不转发数据帧,不学习MAC地址表,参与生成树计算,接收并发送BPDU
    Learning(学习状态):不转发数据帧,学习MAC地址表,参与生成树计算,接收并发送BPDU
    Forwarding(转发状态):转发数据帧,学习MAC地址表,参与生成树计算,接收斌发送BPDU

    端口由Blocking过渡到Forwarding有50s延时,
    Blocking到Listening有20s老化时间,
    Listening到Learning有15s过渡时间,
    Learning到Forwarding有15s过渡时间。

    7.选举根端口、指定端口的规则

    1.Lowest  path  cost  to root bridge(到达根最小路径开始)
    2.Lowest  sender BID(最小的发送方BID)
    3.Lowest  sender port ID(最小的发送发PID)
    端口优先级(默认128+发送方端口号
    
    [SW1-Ethernet0/0/2]stp  port  priority 0(16的倍数)     #修改网桥接口优先级命令
    display  stp  brief                                   #查看端口状态命令
    
    

    1.单臂路由项目

    要求:
    用单臂路由实现Vlan通信
    拓扑图:
    在这里插入图片描述
    1.PC1、PC2基本配置
    在这里插入图片描述
    在这里插入图片描述
    2.LSW1交换机配置

    #
    sysname SW1
    #
    vlan batch 101 to 102
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #
    interface Ethernet0/0/2
     port hybrid pvid vlan 102
     port hybrid untagged vlan 102
    #
    interface Ethernet0/0/3
    #
    interface Ethernet0/0/4
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101 to 102
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
     idle-timeout 0 0
    user-interface vty 0 4
    #
    return
    

    3.R1路由器配置

    #
    sysname R1
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password cipher P`;s###JuDbL^B&WSBiQ[:[#
     local-user admin service-type http
    #
    firewall zone Local
     priority 16
    #
    interface Ethernet0/0/0
    #
    interface Ethernet0/0/1
    #
    interface Serial0/0/0
     link-protocol ppp
    #
    interface Serial0/0/1
     link-protocol ppp
    #
    interface Serial0/0/2
     link-protocol ppp
    #
    interface Serial0/0/3
     link-protocol ppp
    #
    interface GigabitEthernet0/0/0
    #
    interface GigabitEthernet0/0/0.1
     vlan-type dot1q 101
     ip address 192.168.101.1 255.255.255.0
    #
    interface GigabitEthernet0/0/0.2
     vlan-type dot1q 102
     ip address 192.168.102.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/2
    #
    interface GigabitEthernet0/0/3
    #
    wlan
    #
    interface NULL0
    #
    user-interface con 0
     idle-timeout 0 0
    user-interface vty 0 4
    user-interface vty 16 20
    #
    return
    
    

    4.测试 PC1到PC2网关
    在这里插入图片描述
    PC1到PC2 IP地址
    在这里插入图片描述

    2.hybrid项目

    要求:
    1.相同Vlan之间相互通信;
    2.所有pc机都可以访问ftp服务器。

    拓扑图:
    在这里插入图片描述
    1.LSW2交换机配置

    #
    sysname SW2
    #
    vlan batch 1101 to 1102 1105
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port hybrid pvid vlan 1101
     port hybrid untagged vlan 1101 1105
    #
    interface Ethernet0/0/2
     port hybrid pvid vlan 1102
     port hybrid untagged vlan 1102 1105
    #
    interface Ethernet0/0/3
    #
    interface Ethernet0/0/4
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
     idle-timeout 0 0
    user-interface vty 0 4
    #
    port-group q
    #
    return
    

    2.LSW3交换机配置

    #
    sysname SW3
    #
    vlan batch 1101 to 1102 1105
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port hybrid pvid vlan 1101
     port hybrid untagged vlan 1101 1105
    #
    interface Ethernet0/0/2
     port hybrid pvid vlan 1102
     port hybrid untagged vlan 1102 1105
    #
    interface Ethernet0/0/3
     port hybrid pvid vlan 1105
     port hybrid untagged vlan 1101 to 1102 1105
    #
    interface Ethernet0/0/4
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
     idle-timeout 0 0
    user-interface vty 0 4
    #
    port-group hybr
    #
    return2
    

    3.Server1 FTP
    在这里插入图片描述
    3.1 选择文件根目录——启动监听端口号
    3.2 客户端信息——FtpClient——输入FTP服务器地址:192.168.101.254——登录——实现本地文件传输到服务器文件列表在这里插入图片描述
    4.不同Vlan间,IP地址是不能通信的
    在这里插入图片描述
    5.相同Vlan,IP地址可以通信
    在这里插入图片描述
    6.pc机地址测试FTP服务器IP地址都可以通
    在这里插入图片描述

    3.Trunk项目

    在这里插入图片描述
    1.LSW4交换机配置
    要求:
    1.交换机与交换机之间用trunk
    2.相同Vlan间通信

    #
    sysname SW4
    #
    vlan batch 101 to 102
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #
    interface Ethernet0/0/2
     port hybrid pvid vlan 102
     port hybrid untagged vlan 102
    #
    interface Ethernet0/0/3
    #
    interface Ethernet0/0/4
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
     idle-timeout 0 0
    user-interface vty 0 4
    #
    return
    

    2.LSW5交换机配置

    #
    sysname SW5
    #
    vlan batch 101 to 102
    #
    cluster enable
    ntdp enable
    ndp enable
    #
    drop illegal-mac alarm
    #
    diffserv domain default
    #
    drop-profile default
    #
    aaa
     authentication-scheme default
     authorization-scheme default
     accounting-scheme default
     domain default
     domain default_admin
     local-user admin password simple admin
     local-user admin service-type http
    #
    interface Vlanif1
    #
    interface MEth0/0/1
    #
    interface Ethernet0/0/1
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #
    interface Ethernet0/0/2
     port hybrid pvid vlan 102
     port hybrid untagged vlan 102
    #
    interface Ethernet0/0/3
    #
    interface Ethernet0/0/4
    #
    interface Ethernet0/0/5
    #
    interface Ethernet0/0/6
    #
    interface Ethernet0/0/7
    #
    interface Ethernet0/0/8
    #
    interface Ethernet0/0/9
    #
    interface Ethernet0/0/10
    #
    interface Ethernet0/0/11
    #
    interface Ethernet0/0/12
    #
    interface Ethernet0/0/13
    #
    interface Ethernet0/0/14
    #
    interface Ethernet0/0/15
    #
    interface Ethernet0/0/16
    #
    interface Ethernet0/0/17
    #
    interface Ethernet0/0/18
    #
    interface Ethernet0/0/19
    #
    interface Ethernet0/0/20
    #
    interface Ethernet0/0/21
    #
    interface Ethernet0/0/22
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet0/0/2
    #
    interface NULL0
    #
    user-interface con 0
     idle-timeout 0 0
    user-interface vty 0 4
    #
    return
    

    3.测试 PC3 192.168.1.10——PC4 192.168.1.20 不同Vlan
    在这里插入图片描述
    4.PC3 192.168.1.10 —— PC6 192.168.1.30 相同Vlan
    在这里插入图片描述

    展开全文
  •  交换机接口的双工模式 主要分为单工,双工,半双工 三、交换机基本配置 这里以华为交换机为例,来说说其常见的基本命令: #######sys-------------------------------------------转为全局模式 #######sysname——...
  • 交换机的管理方式基本分为两种:带内管理和带外管理。 通过交换机的Console端口管理交换机属于带外管理;这种管理方式不占用交换机的网络端口,第一次配置交换机必须利用Console端口进行配置交换机的命令行操作...
  • 文章目录 交换机基本原理配置 一、基本原理 二、以太网MAC地址组成(全球唯一性): 交换机以太网接口的工作模式 三、Secure CRT软件配置 四、管理设备的方式 带内管理: 带外管理: 交换机基本原理配置 一、...
  • 六 三层交换机基本配置 实验目标 理解三层交换机基本原理; 掌握三层交换机物理端口开启路由功能的配置方法; 实验背景 公司现有1台三层交换机,要求你进行测试,该交换机的三层功能是否工作正常。 技术...
  • 实验交换机基本配置 实验目的 掌握交换机命令行各操作模式的区别,以及模式之间的切换。 实验拓扑 实验步骤 1.交换机配置方式 交换机自身没有输入/输出设备,需要通过其它计算机登录到交换机后才能配置...
  • 1 实验目的 了解锐捷系列交换机的几种配置...3 实验原理 3.1 CLI的五种模式 模式 特征 用户模式 Red-Giant> 特权模式 Red-Giant# 全局配置模式 Red-Giant (config)# 接口配置模式 Red-Giant (config-if)# vlan
  • 计算机网络原理实验实验六:交换机划分Vlan配置 一、实验名称 交换机划分Vlan配置 二、实验目的: 三、实验内容和要求  理解虚拟LAN(VLAN)基本配置;  掌握一般交换机按端口划分VLAN的配置方法;  掌握Tag ...
  • 三、实验原理与步骤 1、打开Cisco Packet Tracer 2、建立连接 注意:交换机使用2960 终端设备使用Generic 线缆使用配置线(无信号灯) 3、使用配置线缆连接 计算机端选择“RS 232” 交换机端选择“Cons
  • 前导知识:了解vlan、了解基本的路由原理、了解客户端设置网关的作用实验环境:Cisco Packet Tracer 模拟器三层交换机SVI接口:跨vlan数据通讯实验步骤1、二层交换机配置(划分vlan:交换机1-10口划到vlan10,11-20口...
  • 交换机原理及VLAN的配置 ** ** 1.交换机工作原理 ** 1)首先,交换机mac地址表为空处于学习状态, 2)收到某个接口发来的以太网帧后,读出发信人的mac地址和这个接口建立起对应关系。 3)由于暂时还没有收信人的接口...
  • 实验交换机基本配置和VLAN配置 实验目的 掌握交换机和vlan的工作原理 学习配置交换机基本配置命令和步骤 学习配置vlan命令和步骤 实验要求 拓扑与地址规划 交换机基本配置和vlan配置 验证配置并给出配置清单 实验...
  • 交换机——VLAN原理基本配置

    千次阅读 2020-08-12 20:59:14
    VLAN原理配置 VLAN的三种端口类型 Access:接入链路类型(一般使用:交换机与PC) Trunk:干道链路类型(一般使用:交换机交换机) Hybrid 在这里,我们只使用和讲解Access和Trunk VLAN原理 为什么使用VLAN 随着...
  • 交换机的基础配置实验,有拓扑图和步骤。其中有密码的配置,和telnet的配置。
  • 三层交换技术的前身是单臂路由,三层交换机就是具有部分路由器功能的交换机,工作在OSI网络标准模型的第三层:网络层。三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的...
  • 交换机基本配置实验目的】 掌握交换机命令行各种操作模式的区别,能够使用各种帮助信息,以及用命令进行基本配置。 【背景描述】 你是某公司新进的网管,公司要求你熟悉网络产品,公司采用全系列锐捷网络产品...
  • 数据链路层的功能:数据链路的建立维护拆除,包括帧包装,帧同步, 帧传输,帧效验恢复,数据效验,流量控制 ...交换机的工作原理 交换机在初始状态里面什么都没有,当PC1给PC2发送数据时,交换机会学习PC1的MAC...
  • 实验一 交换机基本配置 一 实验目的 掌握桌面网络组建方法 掌握 Quidway S 系列中低端交换机...三 实验原理方法和手段 交换机配置方式 交换机通常的配置方式有 Console 方式,telnet 方式 ,web 方式和 modem 拨号方式 命
  • 掌握以太网交换机基本概念 完成交换机的简单配置 图文解释 可实现 (1)查看当前生效的配置参数。 (2)查看以太网交换机的启动配置。 (3)将以太网交换机重启。 (4)显示系统版本信息。 (5)对端口的工作模式...
  • 一.实验目的 掌握交换机命令行各种操作模式的区别,能够使用各种帮助信息,以及用命令进行各种配置。 二....实验原理 交换机的管理方式基本分为带内管理,带外管理。通过交换机的concole口...
  • 交换机基本原理配置 数据链路层 位于网络层和物理层之间 以太网:工作在数据链路层 以太网的发展 X-Wire:2.94兆实验性以太网 DIX:10兆以太网应用 IEEE802.3:10兆以太网标准 千兆以太网:100/1000兆以太网 ...
  • 交换机VLAN的配置实验

    千次阅读 2019-11-18 15:16:36
    实验任务】 按图连接网络,pc0 分配地址为:192.168.100.1 ,pc1 分配的地址为 :192.168.100.2 。pc2 分配的地址为 :192.168.100.3。我们在Switch1 中添加两个VLAN, VLAN10和VLAN20 , 并且在交换机0中将端口1...
  • 交换机基本原理配置放一、以太网1.以太网的发展2.以太网的MAC地址.什么是MAC地址?②.MAC地址如何表示?3.Ethernet II帧格式①.什么是帧格式?②.什么是Ethernet II帧格式?二、交换机基本概念1.什么是交换机?2...
  • 教学过程-任务完成 2远程登录准备 配置进入特权模式的密码 Switch>enable //进入特权模式 Switch#configure terminal //进入全局配置模式 enable password 123456 //配置交换机进入特权模式的密码为123456 配置远程...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 9,544
精华内容 3,817
关键字:

交换机的基本配置的实验原理