精华内容
下载资源
问答
  • 华为交换机配置SSH登录首先说一下配置的基本步骤1、虚拟终端VTY设置2、SSH用户设置3、SSH服务器设置下面具体说一下1、虚拟终端VTY设置[huawei]user-interfacevty4[huawei-ui-vty4]authentication-modeaaa#用户认证...

    华为交换机配置

    SSH

    登录

    首先说一下配置的基本步骤

    1

    、虚拟终端

    VTY

    设置

    2

    SSH

    用户设置

    3

    SSH

    服务器设置

    下面具体说一下

    1

    虚拟终端

    VTY

    设置

    [huawei]user-interface vty 4

    [huawei-ui-vty4]authentication-mode aaa

    #

    用户认证方式为

    AAA

    [huawei-ui-vty4]protocol inbound ssh

    #

    设置

    VTY

    只支持

    SSH

    协议,自动禁止

    telnet

    功能。

    Inbound

    后面一共有三个参

    all

    允许所有协议,

    ssh

    只允许

    ssh

    协议

    telnet

    只允许

    telnet

    协议

    根据情况自己选择。

    2

    SSH

    用户设置

    [huawei]ssh usersshuser authentication-type  password

    #

    创建

    SSH

    用户并配置

    SSH

    用户的认证方式为

    password

    当用户使用

    Password

    认证方式时,需要在

    AAA

    视图下配置与

    SSH

    用户同名的本

    地用户。

    [huawei]aaa

    #

    进入

    AAA

    配置模式

    [Huawei-aaa]

    local-user

    sshuser

    password

    simple

    12345

    privilege

    level

    15

    #

    创建本的用户

    sshuser

    并设置密码方式为

    simple

    密码为

    12345

    等级为

    15

    #password

    的参数有

    simple

    cipher

    一个是明文,一个是密文

    [Huawei-aaa]local-user sshuser  service-type ssh

    #

    配置本地用户的服务方式为

    ssh

    [huawei]ssh user sshuser service-type stelnet

    #

    配置

    SSH

    用户的服务方式为

    stelnet

    3

    SSH

    服务器设置

    [Huawei]stelnet server enable

    #

    使能

    stelnet

    服务

    [Huawei]rsa local-key-pair create

    #

    生成本地

    RSA

    DSA

    密钥对

    展开全文
  • 一、配置思路配置ssh远程登陆,一般是有四个步骤:1、首先选择Console方式登陆交换机2、开启交换机的SSH服务功能并配置IP3、生成加密密钥4、配置SSH管理的登入口令二、配置步骤(以锐捷交换机的配置为例)1、首先选择...

    如何配置交换机SSH远程登录,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。

    如何配置锐捷SSH远程登陆?

    一、配置思路

    配置ssh远程登陆,一般是有四个步骤:

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    3、生成加密密钥

    4、配置SSH管理的登入口令

    二、配置步骤(以锐捷交换机的配置为例)

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    switch>enable //进入特权模式

    switch#configure terminal //进入全局配置模式

    switch(config)#enable service ssh-server //开启ssh-server

    switch(config)#interface vlan 1 //进入vlan 1接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 //为vlan 1接口上设置管理ip 192.168.1.1

    switch(config-if)#exit //退回到全局配置模式

    3、生成加密密钥

    switch(config)#crypto key generate dsa //加密方式有两种:DSA和RSA,可以随意选择

    然后等待密钥生成,然后直接敲回车就好

    4、配置SSH管理的登入口令

    switch(config)#line vty 0 4 //进入SSH密码配置模式,0 4表示允许共5个用户同时SSH登入到交换机

    switch(config-line)#login local //启用SSH时使用本地用户和密码功能

    switch(config-line)#transport input ssh //设置传输模式是SSH,设置远程登入只允许使用SSH登入,不能使用telnet登入

    switch(config-line)#exit //回到全局配置模式

    switch(config)#username Ruijie password 123456 //配置远程登入的用户名为Ruijie,密码为123456

    switch(config)#end //退出到特权模式

    switch#write //确认配置正确,保存配置

    5、验证命令(查看SSH的参数信息(版本信息,重认证次数等参数)

    switch#show ip ssh //显示配置信息

    然后就配置完了,从配置中可以看出,ssh远程登陆方式确实比telnet要安全一些,适用于企业中。

    三、远程登陆进入

    配置后了ssh远程登陆后,可以使用PUTTY或者SecureCRT远程登陆就行。

    用刚刚配置的ip地址,及用户名和密码进行登陆,我们就是SecureCRT登陆为例。

    那么,这个就ssh远程登陆成功了。

    最后补充下:

    配置需要开启SSH功能,且PC与交换机在同一个网段,如果不在的话,可以设置下网关。

    可以用show service命令确认SSH服务功能是否开启。

    精品学习资料,有弱电、室分工程学习资料。入行必备,培训必备!

    展开全文
  • 一、配置思路配置ssh远程登陆,一般是有四个步骤:1、首先选择Console方式登陆交换机2、开启交换机的SSH服务功能并配置IP3、生成加密密钥4、配置SSH管理的登入口令二、配置步骤(以锐捷交换机的配置为例)1、首先选择...

    本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。

    如何配置锐捷SSH远程登陆?

    一、配置思路

    配置ssh远程登陆,一般是有四个步骤:

    1、首先选择Console方式登陆交换机

    2、开启交换机的SSH服务功能并配置IP

    3、生成加密密钥

    4、配置SSH管理的登入口令

    二、配置步骤(以锐捷交换机的配置为例)

    1、首先选择Console方式登陆交换机

    ddd2bd71faac4f466d7836364bdfa7f2.png

    2、开启交换机的SSH服务功能并配置IP

    switch>enable //进入特权模式

    switch#configure terminal //进入全局配置模式

    switch(config)#enable service ssh-server //开启ssh-server

    switch(config)#interface vlan 1 //进入vlan 1接口

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 //为vlan 1接口上设置管理ip 192.168.1.1

    switch(config-if)#exit //退回到全局配置模式

    3、生成加密密钥

    switch(config)#crypto key generate dsa //加密方式有两种:DSA和RSA,可以随意选择

    然后等待密钥生成,然后直接敲回车就好

    4、配置SSH管理的登入口令

    switch(config)#line vty 0 4 //进入SSH密码配置模式,0 4表示允许共5个用户同时SSH登入到交换机

    switch(config-line)#login local //启用SSH时使用本地用户和密码功能

    switch(config-line)#transport input ssh //设置传输模式是SSH,设置远程登入只允许使用SSH登入,不能使用telnet登入

    switch(config-line)#exit //回到全局配置模式

    switch(config)#username Ruijie password 123456 //配置远程登入的用户名为Ruijie,密码为123456

    switch(config)#end //退出到特权模式

    switch#write //确认配置正确,保存配置

    5、验证命令(查看SSH的参数信息(版本信息,重认证次数等参数)

    switch#show ip ssh //显示配置信息

    9ac63ff895f14cb7aa45cce5c7247b83.png

    然后就配置完了,从配置中可以看出,ssh远程登陆方式确实比telnet要安全一些,适用于企业中。

    三、远程登陆进入

    配置后了ssh远程登陆后,可以使用PUTTY或者SecureCRT远程登陆就行。

    用刚刚配置的ip地址,及用户名和密码进行登陆,我们就是SecureCRT登陆为例。

    ed9fe3ca4647f622cc7c4dfedfbe86c3.png
    f75d32fff4f11b86d61c388074f3db8e.png
    3aae8c8f4f5f3aafbb65fd7aa2c53dde.png

    那么,这个就ssh远程登陆成功了。

    最后补充下:

    配置需要开启SSH功能,且PC与交换机在同一个网段,如果不在的话,可以设置下网关。

    可以用show service命令确认SSH服务功能是否开启。

    1e770a9444624a358a84949a271cfd8e.png
    展开全文
  • 一、如何配置锐捷SSH远程登陆1、配置思路配置SSH远程登陆,一般是有四个步骤:(1)首先选择Console方式登陆交换机(2)开启交换机的SSH服务功能并配置IP(3)生成加密密钥(4)配置SSH管理的登入口令二、配置步骤(1)首先...

    1351ef0bb80b6cb87d3753be138058a5.gif

    上次我们提到了关于华为交换机配置Telnet远程登陆,现在我们讲一下SSH远程登录的方式,以下为锐捷交换机为例。

    6917c228dad4eeb5bb026c42d58ff188.png

    一、如何配置锐捷SSH远程登陆

    1、配置思路

    配置SSH远程登陆,一般是有四个步骤:

    (1)首先选择Console方式登陆交换机

    (2)开启交换机的SSH服务功能并配置IP

    (3)生成加密密钥

    (4)配置SSH管理的登入口令

    二、配置步骤

    (1)首先选择Console方式登陆交换机

    a8c8d2a3dafed862871a415848075226.png

    (2)开启交换机的SSH服务功能并配置IP

    switch>enable     //进入特权模式switch#configure terminal     //进入全局配置模式switch(config)#enable service ssh-server     //开启ssh-serverswitch(config)#interface vlan 1       //进入vlan 1接口switch(config-if)#ip address 192.168.1.1 255.255.255.0    //为vlan 1接口上设置管理ip 192.168.1.1switch(config-if)#exit //退回到全局配置模式

    3、生成加密密钥

    switch(config)#crypto key generate dsa    //加密方式有两种:DSA和RSA,可以随意选择

    然后等待密钥生成,然后直接敲回车即可。

    4、配置SSH管理的登入口令

    switch(config)#line vty 0 4     //进入SSH密码配置模式,0 4表示允许共5个用户同时SSH登入到交换机switch(config-line)#login local    //启用SSH时使用本地用户和密码功能switch(config-line)#transport input ssh    //设置传输模式是SSH,设置远程登入只允许使用SSH登入,不能使用Telnet登入
    switch(config-line)#exit     //回到全局配置模式switch(config)#username Ruijie password 123456 //配置远程登入的用户名为Ruijie,密码为123456switch(config)#end     //退出到特权模式switch#write       //确认配置正确,保存配置

    a4f981e55f7bf29d0de67748b2aec201.gif

    展开全文
  • 华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。一、如何配置锐捷SSH...
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...
  • 一、配置思路配置ssh远程登陆,一般是有四个步骤:1、首先选择Console方式登陆交换机2、开启交换机的SSH服务功能并配置IP3、生成加密密钥4、配置SSH管理的登入口令二、配置步骤(以锐捷交换机的配置为例)1、首先选择...
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...
  • 一实验目的 学习如何配置路由器的gatway、Console、vty、enable password 学习如何配置交换机的vlan1 gatway、Console、vty、enable password 学习如何安装telnet 学习如何远程登录交换机路由器二实验步骤路 由 配 ...
  • 华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet 的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。一、如何配置锐捷SSH...
  • 上次提到了关于华为交换机配置Telnet远程登陆,有很多朋友就问到了关于ssh远程登陆的方法,现在telnet的远程登录方式企业用的不多,ssh更加安全些,本期我们就来了解下ssh远程登陆的方式,以锐捷交换机为例。...
  • 华三交换机配置Telnet远程登录

    千次阅读 2019-03-24 16:36:43
    步骤11、Telnet协议 Telnet 协议是TCP/IP协议簇的一员,是Internet远程登录...步骤2、配置Telnet远程登录1、本地PC连到交换机配置口 第一次配置交换机时,只能能通过交换机的Console口进行本地配置,默认Console口...
  • 这里以三层交换机的配置为例子,说一说配置步骤。step1:配置管理地址每个交换机需要配置一个管理地址,方便后期的远程维护;网络中的所有交换机等网络设备,可以使用一个管理VLAN,比如VLAN100,设备的地址圈网...
  • 实验拓扑及描述在上图所示的拓扑中,Cloud1与交换机LSW1直连,我们将...实验需求完成交换机的配置,使得物理机能够通过SSH的方式登录到该交换机。实现步骤配置cloud的配置如下:SW1的配置如下:创建VLAN100:[...
  • 一、通过console口登陆新的交换机我们在拿到新的交换机后,想要配置远程登陆交换机,首先就需要通过Console口登录交换机。如何才能通过Console口登录交换机步骤1:连线用Console通信线缆DB9(孔)插头插入PC19芯...
  • h3c交换机配置telnet远程登录

    千次阅读 2019-09-18 07:38:54
    步骤11、Telnet协议Telnet 协议是TCP/IP协议簇的一员,是...步骤2、配置Telnet远程登录1、本地PC连到交换机配置口第一次配置交换机时,只能能通过交换机的Console口进行本地配置,默认Console口登录到命令行界面时...
  • 交换机分为普通交换机和可...下面为大家整理了一份华为交换机基本的配置步骤,经过这些步骤配置之后我们可以对交换机进行远程管理,经过测试Telnet登录管理都是没问题。我们一起来看看吧![Quidway]sysname TES...
  • 一、通过console口登陆新的交换机我们在拿到新的交换机后,想要配置远程登陆交换机,首先就需要通过Console口登录交换机。如何才能通过Console口登录交换机步骤1:连线用Console通信线缆DB9(孔)插头插入PC19芯...
  • 步骤:一,为各PC配置IP地址二,在交换机SW1配置管理IP地址三,在SW1上配置VTY密码路由器R1同上配置四,PC登录SW2需要配置网关,其他配置同SW1一样五,使用PC机远程登录交换机和路由器登录SW1:登录R1:登录SW2:六...
  • 一、通过console口登陆新的交换机我们在拿到新的交换机后,想要配置远程登陆交换机,首先就需要通过Console口登录交换机。如何才能通过Console口登录交换机呢?这个弱电行业网之前也提到过,我们再来做个简单回顾...
  • 一、通过console口登陆新的交换机我们在拿到新的交换机后,想要配置远程登陆交换机,首先就需要通过Console口登录交换机。如何才能通过Console口登录交换机呢?这个弱电行业网之前也提到过,我们再来做个简单回顾...
  • 今天给大家带来是如何在华为交换机配置Telnet和SSH的配置。实验拓扑如下 实验拓扑 实验需求 按照图示连接到真机,并配置IP地址(真机IP地址配置到VirtualBox Host-Only Ethernet Adapter网卡) 在SW1开启Telnet...
  • 配置远程登陆交换机方法

    千次阅读 2020-07-26 19:58:43
    我们在拿到新的交换机后,想要配置远程登陆交换机,首先就需要通过Console口登录交换机。如何才能通过Console口登录交换机呢?这个弱电行业网之前也提到过,我们再来做个简单回顾。 步骤1:连线 用Console通信...
  • 这里以三层交换机的配置为例子,说一说配置步骤。step1:配置管理地址每个交换机需要配置一个管理地址,方便后期的远程维护;网络中的所有交换机等网络设备,可以使用一个管理VLAN,比如VLAN100,设备的地址圈网...
  • 配置通过Console口首次登录设备后进行基本配置的示例组网需求通过Console口首次登录设备后,对设备进行基本配置配置通过Telnet远程登录的0~4号用户级别为15级,认证方式为AAA认证。PC2与设备之间路由可达。图1 ...
  • 一、组网需求通过ssh功能远程登录管理设备二、配置步骤:1)全局开启SSH服务,并制定SSH版本Ruijie>enableRuijie#configure terminalRuijie(config)#enable service ssh-server ------>开启SSH服务,默认关闭...
  • 以下是笔者视频课程中一节PPT课程内容,介绍是华为VRP系统用户界面主要配置方法,同时以一真实Telnet远程登录实验向大家验证了这些配置的正确性。本节课程视频链接如下(可免费观看):...

空空如也

空空如也

1 2 3 4
收藏数 80
精华内容 32
关键字:

交换机的远程登录配置步骤