精华内容
下载资源
问答
  • 基于交换机端口划分VLAN

    千次阅读 2019-07-16 17:23:35
    一、VLAN的分类 1)基于端口vlan ... 只有网卡才分配MAC地址,因此按照MAC地址划分VLAN实际上是将某些工作站和服务器划分给某个VLAN。实际上该VLAN是MAC地址的集合。当设备移动时,VLAN能自动识别...

    一、VLAN的分类

    1)基于端口的vlan

      基于端口的vlan,是划分虚拟局域网最简单有效的方法。实际上时某些交换端口的集合,网络管理员只需要管理和配置交换端口,而不管交换端口连接什么设备。

    2)基于MAC地址

      只有网卡才分配MAC地址,因此按照MAC地址划分VLAN实际上是将某些工作站和服务器划分给某个VLAN。实际上该VLAN是MAC地址的集合。当设备移动时,VLAN能自动识别。网络管理需要管理和配置MAC地址,当网络规模很大时会给管理带来很大难度。

    3)基于第三层的VLAN

      基于第三层的VLAN是采用在路由器中常用的方法:IP子网或者IPX网络号等。

    4)基于策略VLAN

      该方式的核心时采用什么策略,常用的策略有:按MAC地址、按IP地址、按以太网协议类型、按网络的应用等。

    二、实验配置和要求

      如下图所示,有4台PC机,ip分别为:172.25.10.1、172.25.10.2、172.25.10.3、172.25.10.4 他们的子网掩码都是255.255.255.0

    他们处在同一网段,同一vlan。他们之间是可以相互通信的。

    首先,我们用pc-1去ping其他三台PC机,发现是可以ping通的。

    我们要求是:将PC-1和PC-2划分到vlan10,将PC-3划分到vlan20,将PC-4划分到vlan30.然后再测试他们之间能否通信。

    三、实验

    首先创建VLAN1、2、3

    SW1(config)#vlan 10                                     ##创建编号为10的vlan
    SW1(config-vlan)#name vlan 10                   ##给编号为10的vlan命名为vlan 10
    SW1(config-vlan)#vlan 20
    SW1(config-vlan)#name vlan 20
    SW1(config-vlan)#vlan 30
    SW1(config-vlan)#name vlan 30
     

    将e0/0和e0/1端口分配给vlan10

    SW1(config)#int range e0/0-1            ##进入e0-e1端口
    SW1(config-if-range)#switchport mode access        ##将端口模式设置为access
    SW1(config-if-range)#switchport access vlan 30        ##为端口指派VLAN 10

    以同样的方式将e0/2和e0/3 分别分配给vlan20和vlan30

    可以通过show vlan命令查看vlan的配置

    四、验证

      用PC-1去ping其他三台主机,会发现只有能ping通,其他两台不通。


      因为我们把PC-1和PC-3、PC-4分别划分到了不同的vlan,所以他们不能通信(2层交换机不同vlan不通信,大部分catalyst交换型号的端口默认都是2层操作)。PC-1和PC-2都处于相同的vlan(vlan10),所以他们之间可以通信。

     

     

     

     

     

     

     

     

    展开全文
  • 根据交换机端口分配固定地址的解决方法: 技术原理:开启DHCP Snooping的option82策略分配。为交换机每一个端口做一个option82的类标记,DHCP服务器根据option82的类标记分配固定地址。 这里以H3C交换机为例,为...

    根据交换机的端口分配固定地址的解决方法:
    技术原理:开启DHCP Snooping的option82策略分配。为交换机每一个端口做一个option82的类标记,DHCP服务器根据option82的类标记分配固定地址。

    这里以H3C交换机为例,为VLAN 10中的终端分配地址:
    希望交换机端口1-24依次分配固定地址172.16.10.1-172.16.10.24/24的地址。

    1、创建DHCP服务器并做option82类标记:
    [H3C]dhcp enable
    [H3C]dhcp server ip-pool vlan10
    [H3C-dhcp-pool-vlan10]network 172.16.10.0 mask 255.255.255.0
    [H3C-dhcp-pool-vlan10]gateway-list 172.16.10.254
    [H3C-dhcp-pool-vlan10]dns-list 114.114.114.114
    [H3C-dhcp-pool-vlan10]expired day 0 hour 2
    [H3C-dhcp-pool-vlan10]class port1 range 172.16.10.1 172.16.10.1           #类port1标记地址172.16.10.1
    [H3C-dhcp-pool-vlan10]class port2 range 172.16.10.2 172.16.10.2
    [H3C-dhcp-pool-vlan10]class port3 range 172.16.10.3 172.16.10.3
    [H3C-dhcp-pool-vlan10]class port4 range 172.16.10.4 172.16.10.4
    [H3C-dhcp-pool-vlan10]quit

    [H3C]interface range Ethernet 1/0/1 to Ethernet 1/0/4
    [H3C-if-range]port link-type access
    [H3C-if-range]port access vlan 10
    [H3C-if-range]quit
    [H3C]interface Vlan-interface 10
    [H3C-Vlan-interface10]ip address 172.16.10.254 24
    [H3C-Vlan-interface10]dhcp select server        #开启dhcp服务

    2、配置option82的参数信息:
    [H3C]dhcp class port1
    [H3C-dhcp-class-port1]if-match rule 1 option 82 hex 706f727431 offset 2 length 5
    [H3C-dhcp-class-port1]quit
    #hex代表十六进制;"706f727431"是十六进制值,转换后字符就是“port1”,如下同理;"offset 2 length 5"指的是option允许偏移量2,十六进制字符串长度为5。
    在线转换网址:https://www.sojson.com/hexadecimal.html
    [H3C]dhcp class port2
    [H3C-dhcp-class-port2]if-match rule 1 option 82 hex 706f727432 offset 2 length 5
    [H3C-dhcp-class-port2]quit
    [H3C]dhcp class port3
    [H3C-dhcp-class-port3]if-match rule 1 option 82 hex 706f727433 offset 2 length 5
    [H3C-dhcp-class-port3]quit
    [H3C]dhcp class port4
    [H3C-dhcp-class-port4]if-match rule 1 option 82 hex 706f727434 offset 2 length 5
    [H3C-dhcp-class-port4]quit

    3、配置端口与类的关系:
    [H3C]dhcp snooping enable          #全局开启dhcp snooping功能
    [H3C]interface Ethernet 1/0/1        #端口启用dhcp snooping支持option82功能,并配置circuit-id为port1
    [H3C-Ethernet1/0/1]dhcp snooping information enable         #开启支持option82字段功能
    [H3C-Ethernet1/0/1]dhcp snooping information circuit-id string port1      #string后面是自定义字符
    [H3C-Ethernet1/0/1]quit
    [H3C]interface Ethernet 1/0/2
    [H3C-Ethernet1/0/2]dhcp snooping information enable
    [H3C-Ethernet1/0/2]dhcp snooping information circuit-id string port2
    [H3C-Ethernet1/0/2]quit
    [H3C]interface Ethernet 1/0/3
    [H3C-Ethernet1/0/3]dhcp snooping information enable
    [H3C-Ethernet1/0/3]dhcp snooping information circuit-id string port3
    [H3C-Ethernet1/0/3]quit
    [H3C]interface Ethernet 1/0/4
    [H3C-Ethernet1/0/4]dhcp snooping information enable
    [H3C-Ethernet1/0/4]dhcp snooping information circuit-id string port4
    [H3C-Ethernet1/0/4]quit
    ----------------------------------------------------------------------------------------
    4、插交换机4口测试如下:
    terminal debugging
    terminal monitor
    debugging dhcp snooping information
    *Oct 19 16:37:38:201 2019 H3C DHCPSP4/7/INFO: Received packet: Option 82 offset is 0, Option 82 handling strategy is Replace.
    *Oct 19 16:37:38:201 2019 H3C DHCPSP4/7/INFO: Fill circuit-id in padding format string: Length is 7.
    *Oct 19 16:37:38:201 2019 H3C DHCPSP4/7/INFO: Fill remote-id in padding format normal: Length is 10.
    *Oct 19 16:37:38:201 2019 H3C DHCPSP4/7/INFO: Recalculated IP and UDP checksum.
    *Oct 19 16:37:38:790 2019 H3C DHCPSP4/7/INFO: Stripping Option 82 succeeded: offset is 331, stripped length is 19.
    *Oct 19 16:37:38:790 2019 H3C DHCPSP4/7/INFO: Padded packet: padded length is 14.
    *Oct 19 16:37:38:790 2019 H3C DHCPSP4/7/INFO: Recalculated IP and UDP checksum.
    *Oct 19 16:37:38:792 2019 H3C DHCPSP4/7/INFO: Received packet: Option 82 offset is 0, Option 82 handling strategy is Replace.
    *Oct 19 16:37:38:792 2019 H3C DHCPSP4/7/INFO: Fill circuit-id in padding format string: Length is 7.
    *Oct 19 16:37:38:792 2019 H3C DHCPSP4/7/INFO: Fill remote-id in padding format normal: Length is 10.
    *Oct 19 16:37:38:792 2019 H3C DHCPSP4/7/INFO: Recalculated IP and UDP checksum.
    *Oct 19 16:37:38:795 2019 H3C DHCPSP4/7/INFO: Stripping Option 82 succeeded: offset is 331, stripped length is 19.
    *Oct 19 16:37:38:795 2019 H3C DHCPSP4/7/INFO: Padded packet: padded length is 14.
    *Oct 19 16:37:38:795 2019 H3C DHCPSP4/7/INFO: Recalculated IP and UDP checksum.

    display arp all
    Type: S-Static D-Dynamic O-Openflow R-Rule M-Multiport I-Invalid
    IP address MAC address VLAN/VSI Interface Aging Type
    172.16.10.4 b00c-d16b-c771 10 Eth1/0/4 1191 D

    -----------------------------------------------------------------------------------------------------------

    展开全文
  • 交换机上划分Vlan

    2013-06-02 09:20:00
    项目目标通过项目的完成,掌握以下技能:(1) 能够跨交换机实习VLAN划分(2) 能够掌握将交换机端口分配vlan中的操作技巧3.4.2项目任务网络拓扑环境如上图所示。在信息大楼、实验中心和办公楼采用Cisco 2960交换机,...

    项目目标

    通过项目的完成,掌握以下技能:
    (1) 能够跨交换机实习VLAN划分
    (2) 能够掌握将交换机端口分配到vlan中的操作技巧
    3.4.2项目任务

     


    网络拓扑环境如上图所示。在信息大楼、实验中心和办公楼采用Cisco 2960交换机,实现网管功能,机电大楼也采用Cisco 2960交换机,但作为傻瓜交换机使用,也可采用另外的傻瓜交换机。实验中心、办公楼和机电大楼的交换机与信息大楼的交换机采用双绞线直接连接起来。
    (1) 完成网络中各交换机、计算机等的名称、口令、IP地址、子网掩码、网关、VLAN号等的详细规划,交换机端口VLAN的划分。
    (2) 设置交换机的名称、口令、管理地址。
    (3) 划分各部门VLAN
    (4) 配置中继链路。
    (5) 分配各交换机端口VLAN成员。
    3.4.3设备清单

    1Cisco 2960交换机3

    2Cisco 2960交换机1台,作傻瓜交换机使用,不进行任何配置。

    3PC8台。

    4)双绞线若干根。

    5)反转电缆一根。
    3.4.4实施过程

    步骤1:规划与设计。
    (1) 规划计算机IP地址、子网掩码、网关。配置PC11.PC12PC21PC22PC31PC32PC41PC42IP地址如表2所示。
     
    (2) 规划各场所交换机名称,端口所属VLAN以及连接的计算机,如表3所示。各个交换机之间的连接关系如表4所示。
      
    步骤2:环境准备。
    (1) 在交换机和计算机断电的状态下,按图1、表3和表4所示连接硬件。交换机端口之间的连接采用交叉线。
    (2) 分别打开设备,给设备加电。
    步骤3:按照表2所列设置个计算机的IP地址、子网掩码、默认网关。
    步骤4:清除交换机配置。
    (1)Switch#erase startup-config
    (2)删除交换机vlan。交换机的vlan配置信息保存在闪存的vlan.dat文件中,要想删除vlan,必须删除闪存中的vlan.dat文件。
    Switch#show flash:
    Switch#del vlan.dat
    步骤5:测试连通性。
    步骤6:配置交换机jisjsw
    在设备断电的状态下,将交换机jisjswPC1通过反转电缆连接起来,打开PC1的超级终端,配置交换机jisjsw,配置如下。
    (1) 配置信息大楼的交换机的主机名为jisjsw
    Switch#conf t
    Switch(config)#hostname jisjsw
    Jisjsw(config)#exit
    Jisjsw#wr
    (2) 在交换机jisjsw创建Vlan10Vlan20Vlan30Vlan99.
    Vlan database
    Vlan 10 name jisj10
    Vlan 20 name jidx20
    Vlan 30 name caiwc30
    Vlan 99 name manage
    Exit
    Jisjsw(config)#int vlan 10
    Jisjsw(config-if)#ip add 192.168.10.1 255.255.255.0
    Jisjsw(config-if)#no shut
    Jisjsw(config-if)#exit
    Jisjsw(config)#int vlan 20
    Jisjsw(config-if)#ip add 192.168.20.1 255.255.255.0
    Jisjsw(config-if)#no shut
    Jisjsw(config-if)#exit
    Jisjsw(config)#int vlan 30
    Jisjsw(config-if)#ip add 192.168.30.1 255.255.255.0
    Jisjsw(config-if)#no shut
    Jisjsw(config-if)#exit
    Jisjsw(config)#int vlan 99
    Jisjsw(config-if)#ip add 192.168.100.1 255.255.255.0
    Jisjsw(config-if)#no shut
    Jisjsw(config-if)#exit
    Jisjsw(config)#exit
    Jisjsw#wr

    (3) 按照表3 分配交换机jisjsw端口VLAN
    Jisjsw(config)#int range f0/2 – 10
    Jisjsw(config-if-range)#switchport mode access
    Jisjsw(config-if-range)#switchport access vlan 10
    Jisjsw(config-if-range)#no shut
    Jisjsw(config-if-range)#exit
    Jisjsw(config)#int range f0/11 – 12
    Jisjsw(config-if-range)#switchport mode access
    Jisjsw(config-if-range)#switchport access vlan 30
    Jisjsw(config-if-range)#no shut
    Jisjsw(config-if-range)#exit
    Jisjsw(config)#int f0/13
    Jisjsw(config-if)#description link to jidxsw-f01
    Jisjsw(config-if)#switchport mode access
    Jisjsw(config-if)#switchport access vlan 20
    Jisjsw(config-if)#no shut
    Jisjsw(config-if)#exit
    Jisjsw(config)#int f0/15
    Jisjsw(config-if)#description manage
    Jisjsw(config-if)#switchport mode access
    Jisjsw(config-if)#switchport access vlan 99
    Jisjsw(config-if)#no shut
    Jisjsw(config-if)#end
    Jisjsw#wr

    (4)查看jisjsw VLAN配置。
    Jisjsw#show vlan 
    步骤7:配置办公楼的交换机。
    (1) 配置办公楼交换机的主机名为banglsw.
    Switch>en
    Switch#conf t
    Switch(conf t)#hostname banglsw
    Banglsw(config)#no ip domain lookup
    Banglsw(config)#


    (2)在交换机banglsw创建VLAN10VLAN20VLAN30VLAN99.



    Banglsw#vlan database



    Banglsw(vlan)#valn 10 name jisj10



    Banglsw(vlan)#valn 20 name jidx20



    Banglsw(vlan)#valn 30 name caiwc30


    Banglsw(vlan)#valn 99 name manage


    Banglsw(vlan)#exit


    Banglsw#conf t


    Banglsw(config)#int vlan 10


    Banglsw(config-if)#ip add 192.168.10.1 255.255.255.0


    Banglsw(config-if)#no shut


    Banglsw(config)#int vlan 20


    Banglsw(config-if)#ip add 192.168.20.1 255.255.255.0


    Banglsw(config-if)#no shut


    Banglsw(config)#int vlan 30


    Banglsw(config-if)#ip add 192.168.30.1 255.255.255.0


    Banglsw(config-if)#no shut


    Banglsw(config)#int vlan 99


    Banglsw(config-if)#ip add 192.168.100.1 255.255.255.0


    Banglsw(config-if)#no shut


    Banglsw(config-if)#end


    Banglsw#wr
    (4) 按照表3分配交换机banglsw端口vlan.
    Banglsw(config)#int range f0/2 – 10
    Banglsw(config-if-range)#switchport mode access
    Banglsw(config-if-range)#switchport access vlan 30
    Banglsw(config-if-range)#no shut
    Bangsw(config-if-range)#exit
    Banglsw(config)#int range f0/11 – 12
    Banglsw(config-if-range)#switchport mode access
    Banglsw(config-if-range)#switchport access vlan 10
    Banglsw(config-if-range)#no shut
    Bangsw(config-if-range)#exit
    Banglsw(config)#int range f0/13 
    Banglsw(config-if-range)#switchport mode access
    Banglsw(config-if-range)#switchport access vlan 20
    Banglsw(config-if-range)#no shut
    Bangsw(config-if-range)#exit
    Banglsw(config)#int range f0/15
    Banglsw(config-if-range)#switchport mode access
    Banglsw(config-if-range)#switchport access vlan 99
    Banglsw(config-if-range)#no shut
    Banglsw(config-if-range)#end
    Banglsw#wr
    (5) 查看banglswvlan配置。
    步骤8:配置实验中心的交换机
    (1) 配置实验中心交换机的主机名为shiysw.
    (2) 在交换机shiysw创建VLAN10VLAN30VLAN40VLAN99.
    (3) 按照表3分配交换机shiysw端口VLAN
    (4) 查看shiyswVLAN配置。
    步骤9:测试


    步骤10:配置jisjswbanglsw/shiysw之间的中继。
    (1) 将交换机jisjsw的端口(f1/0f0/1)定义为中继链路。
    Jisjsw(config)#int f1/0
    Jisjsw(config-if)#description link to banglsw-f1/0
    Jisjsw(config-if)#switchport mode trunk
    Jisjsw(config-if)#no shut
    Jisjsw(config-if)#exit
    Jisjsw(config)#int f0/1
    Jisjsw(config-if)#description link to shiysw-f0/1
    Jisjsw(config-if)#switchport mode trunk
    Jisjsw(config-if)#no shut
    Jisjsw(config-if)#end
    Jisjsw#end
    Jisjsw#show int trunk
    (2)将交换机shiyswf0/1)和交换机banglsw的端口(f1/0)定义为中继链路。
    Banglsw(config)#int f1/0
    Banglsw(config-if)#description link to jisjsw-f1/0
    Banglsw(config-if)#switchport mode trunk
    Banglsw(config-if)#no shut
    Banglsw(config-if)#end
    Banglsw#wr
    Banglsw(config)#int f0/1
    Banglsw(config-if)#description link to jisjsw-f0/1
    Banglsw(config-if)#switchport mode trunk
    Banglsw(config-if)#no shut
    Banglsw(config-if)#end
    Banglsw#wr
    步骤11:项目测试。
    (1) 测试这几台计算机之间的连通性。
    (2) 分别打卡交换机jisjsw和交换机Switch 2,查看交换机的配置信息。
    Jisjsw#show run
    Banglsw#show run
    Shiysw#show run


    步骤12:配置交换机口令。



    配置个交换机远程登录口令、超级口令和控制台等咯口令。


    步骤13:配置远程管理。
    (1) 将PC11接到交换机jisjsw的端口f0/15上,IP地址改为192.168.100.100/24,网关为192.168.100.1.
    (2) 配置交换机jisjsw管理地址,管理VLAN,端口f0/15所属VLAN
    Jisjsw(config)#int vlan 99
    Jisjsw(config-if)#ip add 192.168.100.201 2555.255.255.0
    Jisjsw(config-if)#ip default-gateway 192.168.100.1
    Jisjsw(config-if)#exit
    Jisjsw(config)#
    (3) 测试PC11合同交换机jisjsw的远程管理地址的连通性。
    Ping 192.168.100.201
    (4) 配置交换机shiyswbanglsw管理地址,端口f0/15所属VLAN
    Banglsw(config)#int vlan 99
    Banglsw(config-if)#iip add 192.168.100.202 255.255.255.0
    Banglsw(config-if)#exit
    Banglsw(config)#ip default-gateway 192.168.100.1


    步骤14:保存配置


    步骤15:清除交换机的所有配置。

    转载于:https://www.cnblogs.com/kscnchina/archive/2013/06/02/3113519.html

    展开全文
  • 给服务器单独规划一个网段和VLAN,给计算机PC1和PC3单独规划一个网段和VLAN,计算机PC2和PC4、Laptop单独规划一个网段和VLAN,并在S1、S2两个核心交换机上划分相应的VLAN分配相应的地址,并要求: 1:在两S1和S2...

    1:配置要求

           给服务器单独规划一个网段和VLAN,给计算机PC1和PC3单独规划一个网段和VLAN,计算机PC2和PC4、Laptop单独规划一个网段和VLAN,并在S1、S2两个核心交换机上划分相应的VLAN,分配相应的地址,并要求:

    1:在两S1和S2之间的F0/1、F0/2上作端口聚合PAgP,并把聚合口设置为TRUNK;

    2:把S1设置为VTP的server模式,S2设置为VTP的transparent模式,别的交换机都设置为client模式,域名domain为sspu,密码password为network;

    3:计算机PC4和Laptop所连接的交换机口使用端口安全配置,前者更换MAC就关掉端口,后者更换则不能使用并发消息和日志记录

    以上三个要求即分别对应以下三个技术:

    1. 交换机端口聚合技术
    2. 交换机VTP虚拟主干协议
    3. 交换机端口安全技术

    2:拓扑结构

    3:配置步骤和代码

    三层交换机s1:

    Switch>en

    Switch#Conf t

    Switch(config)#Host s1

    s1(config)#Vlan 2

    s1(config-vlan)#Exit

    s1(config)#Vlan 3

    s1(config-vlan)#Exit

    s1(config)#Vlan 4

    s1(config-vlan)#Exit

    s1(config)#Int vlan 2

    s1(config-if)#Ip address 192.168.1.254 255.255.255.0

    s1(config-if)#Exit

    s1(config)#Int vlan 3

    s1(config-if)#Ip address 192.168.2.254 255.255.255.0

    s1(config-if)#Exit

    s1(config)#Int vlan 4

    s1(config-if)#Ip address 192.168.3.254 255.255.255.0

    s1(config-if)#Exit

    s1(config)#Int f0/4

    s1(config-if)#Switchport mode access

    s1(config-if)#Switchport mode trunk

    s1(config-if)#Int range f0/1-2

    s1(config-if-range)#Switchport mode access

    s1(config-if-range)#Switchport mode trunk

    s1(config-if-range)#Int range f0/5-6

    s1(config-if-range)#Switchport access vlan 4

    s1(config-if-range)#Ip routing

    S1(config-if-range)#int range f0/1-2

    S1(config-if-range)#channel-group 2 mode desirable

    s1(config-if-range)#End

    s1#show etherchannel summary

    s1#conf t

    s1(config)#vtp domain sspu

    s1(config)#vtp password network

    s1(config)#vtp mode server

    s1(config)#int f0/3

    s1(config-if)#switchport mode access

    s1(config-if)#switchport mode trunk

     

    s1(config-if)#end

    s1#show vtp status

    s1#show vlan

    s1#conf t

    s1(config)#vlan 5

    s1(config-vlan)#exit

    s1(config)#vlan 6

    s1(config-vlan)#exit

    s1(config)#vlan 7

    s1(config-vlan)#exit

    s1(config)#exit

    s1#show vtp status

    s1#show vlan

     

    纯代码:

    en
    Conf t
    Host s1
    Vlan 2
    Exit
    Vlan 3
    Exit
    Vlan 4
    Exit
    Int vlan 2
    Ip address 192.168.1.254 255.255.255.0
    Exit
    Int vlan 3
    Ip address 192.168.2.254 255.255.255.0
    Exit
    Int vlan 4
    Ip address 192.168.3.254 255.255.255.0
    Exit
    Int f0/4
    Switchport mode access
    Switchport mode trunk
    Int range f0/1-2
    Switchport mode access
    Switchport mode trunk
    Int range f0/5-6
    Switchport access vlan 4
    Ip routing
    ------以上为第一阶段,在配置以下三个技术1:交换机端口聚合技术2:交换机VTP虚拟主干协议3:交换机端口安全技术
    之前就可以保证图中所有server和PC机均可以ping通,三层交换机s1与三层交换机s2之间的链路在这一个阶段就应该设置为trunk,因为这也是一种实现单臂路由的情况,可以把s1看作原单臂路由模型中的三层交换机,把s2当作原单臂路由模型中的二层交换机,因此就可以很清晰的分析出,第一阶段,要保证所有server和PC机均可以ping通,s1和s2之间的链路就必须为trunk
    int range f0/1-2
    channel-group 2 mode desirable
    End
    show etherchannel summary
    --------第二阶段,实现1:交换机端口聚合技术
    --------聚合之后要设置为trunk接口,因为第一阶段已经设置过,因此这一阶段就没有表示出来
    conf t
    vtp domain sspu
    vtp password network
    vtp mode server
    int f0/3
    switchport mode access
    switchport mode trunk
    end
    show vtp status
    show vlan
    conf t
    vlan 5
    exit
    vlan 6
    exit
    vlan 7
    exit
    ------------新加vtp5,6,7看变化
    -------疑问是否一端设为trunk后,另一端自动为trunk
    exit
    show vtp status
    show vlan
    --------第三阶段,实现2:交换机VTP虚拟主干协议;注意实现这个技术时,要把与这个交换机相连的参与VTP的其它交换机之间的链路设置为trunk
    --------(注意是否一条链路的一端设置为trunk后,另一端的交换机也自动变为trunk)

    三层交换机s2:

    Switch>en

    Switch#Conf t

    Switch(config)#Host s2

    s2(config)#Vlan 2

    s2(config-vlan)#Exit

    s2(config)#Vlan 3

    s2(config-vlan)#Exit

    s2(config)#Vlan 4

    s2(config-vlan)#Exit

    s2(config)#Int vlan 2

    s2(config-if)#Ip address 192.168.1.254 255.255.255.0

    s2(config-if)#Exit

    s2(config)#Int vlan 3

    s2(config-if)#Ip address 192.168.2.254 255.255.255.0

    s2(config-if)#Exit

    s2(config)#Int vlan 4

    s2(config-if)#Ip address 192.168.3.254 255.255.255.0

    s2(config-if)#Exit

    s2(config)#Int range f0/1-2

    s2(config-if-range)#Switchport mode access

    s2(config-if-range)#Switchport mode trunk

    s2(config-if-range)#Int f0/3

    s2(config-if)#Switchport access vlan 2

    s2(config-if)#Int f0/4

    s2(config-if)#Switchport access vlan 3

    s2(config-if)#Int range f0/5-6

    s2(config-if-range)#Switchport access vlan 4

    s2(config-if-range)#Ip routing

    s2(config-if-range)#int range f0/1-2

    s2(config-if-range)#channel-group 2 mode desirable

    s2(config-if-range)#End

    s2#show etherchannel summary

    s2#conf t

    s2(config)#vtp mode transparent

    s2(config)#int range f0/3-4

    s2(config-if-range)#switchport mode access

    s2(config-if-range)#switchport mode trunk

    s2(config-if-range)#End

    s2#show vtp status

    s2#show vlan

    s2#show vtp status

    s2#show vlan

     

    纯代码:

    en
    Conf t
    Host s2
    Vlan 2
    Exit
    Vlan 3
    Exit
    Vlan 4
    Exit
    Int vlan 2
    Ip address 192.168.1.254 255.255.255.0
    Exit
    Int vlan 3
    Ip address 192.168.2.254 255.255.255.0
    Exit
    Int vlan 4
    Ip address 192.168.3.254 255.255.255.0
    Exit
    Int range f0/1-2
    Switchport mode access
    Switchport mode trunk
    Int f0/3
    Switchport access vlan 2
    Int f0/4
    Switchport access vlan 3
    Int range f0/5-6
    Switchport access vlan 4
    Ip routing
    ---------以上为第一阶段,在配置以下三个技术1:交换机端口聚合技术2:交换机VTP虚拟主干协议3:交换机端口安全技术
    之前就可以保证图中所有server和PC机均可以ping通,三层交换机s1与三层交换机s2之间的链路在这一个阶段就应该设置为trunk
    
    --------特别注意第一阶段就可以使所有的server和PC机均可以ping通,除了s1的第3个接口,因为下边没有连server或者PC机,因此第一阶段不用设置以外,其它所有交换机的所有接口必须有设置,要么是trunk,要么是switchport access vlan 2或者3或者4
    int range f0/1-2
    channel-group 2 mode desirable
    End
    show etherchannel summary
    --------第二阶段,实现1:交换机端口聚合技术
    Conf t
    vtp domain sspu
    vtp password network
    ------这个交换机已经设置为 transparent,因此这两句可以省略,结果是一样的
    vtp mode transparent
    int range f0/3-4
    switchport mode access
    switchport mode trunk
    End
    show vtp status
    show vlan
    show vtp status
    show vlan
    --------第三阶段,实现2:交换机VTP虚拟主干协议;注意实现这个技术时,要把与这个交换机相连的参与VTP的其它交换机之间的链路设置为trunk
    --------(注意是否一条链路的一端设置为trunk后,另一端的交换机也自动变为trunk)

    二层交换机s3:

    Switch>en

    Switch#conf t

    Switch(config)#host s3

    s3(config)#exit

    s3#show vtp status

    s3#show vlan

    s3#conf t

    s3(config)#vtp domain sspu

    s3(config)#vtp password network

    s3(config)#vtp mode client

    s3(config)#exit

    s3#show vtp status

    s3#show vlan

    s3#show vtp status

    s3#show vlan

     

    纯代码:

    en
    conf t
    host s3
    exit
    show vtp status
    show vlan
    conf t
    vtp domain sspu
    vtp password network
    vtp mode client
    exit
    show vtp status
    show vlan
    show vtp status
    show vlan
    --------(注意是否一条链路的一端设置为trunk后,另一端的交换机也自动变为trunk,这里虽然自己没有设置f0/1接口是trunk,但是其自己已经变为了trunk)
    --------s3只参与了实现2:交换机VTP虚拟主干协议

     

    二层交换机s4:

    Switch>En

    Switch#Conf t

    Switch(config)#Host s4

    s4(config)#Vlan 2

    s4(config-vlan)#Exit

    s4(config)#Vlan 3

    s4(config-vlan)#Exit

    s4(config)#Int f0/2

    s4(config-if)#Switchport access vlan 2

    s4(config-if)#Int f0/3

    s4(config-if)#Switchport access vlan 3

    s4(config-if)#Int f0/1

    s4(config-if)#Switchport mode trunk

    s4(config-if)#exit

    s4(config)#vtp domain sspu

    s4(config)#vtp password network

    s4(config)#vtp mode client

    s4(config)#exit

    s4#show vtp status

    s4#show vlan

    s4#show vtp status

    s4#show vlan

     

    纯代码

    En
    Conf t
    Host s4
    Vlan 2
    Exit
    Vlan 3
    Exit
    Int f0/2
    Switchport access vlan 2
    Int f0/3
    Switchport access vlan 3
    Int f0/1
    Switchport mode trunk
    --------以上为第一阶段,在配置以下三个技术1:交换机端口聚合技术2:交换机VTP虚拟主干协议3:交换机端口安全技术
    之前就可以保证图中所有server和PC机均可以ping通
    exit
    vtp domain sspu
    vtp password network
    vtp mode client
    exit
    show vtp status
    show vlan
    show vtp status
    show vlan
    --------参与第三阶段,实现2:交换机VTP虚拟主干协议;

     

    二层交换机s5:

    Switch>En

    Switch#Conf t

    Switch(config)#Host s5

    s5(config)#Vlan 2

    s5(config-vlan)#Exit

    s5(config)#Int range f0/1-2

    s5(config-if-range)#Switchport access vlan 2

    s5(config-if-range)#exit

    s5(config)#vtp domain sspu

    s5(config)#vtp password network

    s5(config)#vtp mode client

    s5(config)#exit

    s5#show vtp status

    s5#show vlan

    s5#show vtp status

    s5#show vlan

     

    纯代码:

    En
    Conf t
    Host s5
    Vlan 2
    Exit
    Int range f0/1-2
    Switchport access vlan 2
    
    --------以上为第一阶段,在配置以下三个技术1:交换机端口聚合技术2:交换机VTP虚拟主干协议3:交换机端口安全技术
    之前就可以保证图中所有server和PC机均可以ping通
    exit
    vtp domain sspu
    vtp password network
    vtp mode client
    exit
    show vtp status
    show vlan
    show vtp status
    show vlan
    --------参与第三阶段,实现2:交换机VTP虚拟主干协议;

    二层交换机s6:

    Switch>En

    Switch#Conf t

    Switch(config)#Host s6

    s6(config)#Vlan 3

    s6(config-vlan)#Exit

    s6(config)#Int range f0/1-3

    s6(config-if-range)#Switchport access vlan 3

    s6(config-if-range)#exit

    s6(config)#vtp domain sspu

    s6(config)#vtp password network

    s6(config)#vtp mode client

    s6(config)#exit

    s6#show vtp status

    s6#show vlan

    s6#show vtp status

    s6#show vlan

    s6#conf t

    s6(config)#int f0/2

    s6(config-if)#switchport mode access

    s6(config-if)#switchport port-security

    s6(config-if)#switchport port-security maximum 1

    s6(config-if)#switchport port-security mac-address 00E0.A3A1.6635

    s6(config-if)#switchport port-security violation shutdown

    s6(config-if)#int f0/3

    s6(config-if)#switchport mode access

    s6(config-if)#switchport port-security

    s6(config-if)#switchport port-security maximum 1

    s6(config-if)#switchport port-security mac-address 0001.9721.1BD4

    s6(config-if)#switchport port-security violation restrict

    s6(config-if)#end

    s6#show port-security

     

    纯代码:

    En
    Conf t
    Host s6
    Vlan 3
    Exit
    Int range f0/1-3
    Switchport access vlan 3
    --------以上为第一阶段,在配置以下三个技术1:交换机端口聚合技术2:交换机VTP虚拟主干协议3:交换机端口安全技术
    之前就可以保证图中所有server和PC机均可以ping通
    exit
    vtp domain sspu
    vtp password network
    vtp mode client
    exit
    show vtp status
    show vlan
    show vtp status
    show vlan
    --------参与第三阶段,实现2:交换机VTP虚拟主干协议;
    conf t
    int f0/2
    switchport mode access
    switchport port-security
    switchport port-security maximum 1
    switchport port-security mac-address 00E0.A3A1.6635
    switchport port-security violation shutdown
    int f0/3
    switchport mode access
    switchport port-security
    switchport port-security maximum 1
    switchport port-security mac-address 0001.9721.1BD4
    switchport port-security violation restrict
    End
    show port-security
    --------参与第四阶段,即最后一个阶段,实现3:交换机端口安全技术

    4:疑问

    是否一端设为trunk后,另一端自动为trunk

    5:配置结果

    PC1:

    PC3:

    Server2:

    Server3:

     

    Laptop:

    1:交换机端口聚合技术

    S1:

    S2:

    2:交换机VTP虚拟主干协议

    S1:

    S2:

    S3:

     

    S5:

    S4,S6同理,同步S1,新增

     

    3:交换机端口安全技术

    展开全文
  • 您能配置端口和指定端口是否应该在访问或中继模式,并且分配特定端口VLAN。此条款提供说明关于怎样配置您的交换机的接口VLAN作为访问或中继端口通过Comman线路接口(CLI)。简介VLAN是由功能或...
  • 交换机端口属于一个或多个 VLANVLAN 交换机端口模式 配置 VLAN 时,必须为它分配一个数字 ID,也可根据需要为其指定一个名称。VLAN 实施过程中需要以灵活的方式将端口与特定的 VLAN ...
  • 众多中小企业内部网络结构都很简单,仅仅是用一台...通过划分VLAN可以让在同一台交换机不同端口的客户机不能互相访问,有效的隔离了网络。  通过VLAN划分网络固然可以解决安全和广播风暴的频繁出现,但是对于那...
  • 点击蓝字,关注我们VLAN基本概念●一个VLAN中所有设备都是在同一广播域...一个VLAN一般为一个逻辑子网,由被配置为此VLAN成员的设备组成●VLAN中成员多基于交换机端口分配,划分VLAN就是对交换机的接口划分●VLAN工...
  • 2.进入交换机1设置界面设置好vlan,然后把交换机1与电脑,交换机1与交换机2之间的端口分配vlan里.进入交换机2界面,重复以上步骤,端口分配至同一vlan里。3.进入电脑网络适配器,把两台电脑ip...
  • 三层交换机实现VLAN间通信(Cisco)

    千次阅读 2019-01-17 00:05:15
    分配交换机端口VLAN 添加、移动和更改端口 检验 VLAN 配置 对交换机间连接启用中继 检验中继配置 保存 VLAN 配置   实验环境  •思科2960交换机三台。 •计算机6台(已安装 Windows Server 2003...
  • 交换机vlan配置

    2021-01-16 17:38:28
    在默认下,六台计算机在同个vlan;因为没有划分vlan时,交换机所连接的计算机设置成同网段的ip地址是连通的(在同一个广播域中)。 现在给它们划分vlan,...分配vlan端口 上面操作即可 也可用show vlan命令查看 ...
  • 一、交换机VLAN的划分(实现交换机端口的广播隔离) 按交换机端口划分定义虚拟局域网(VLAN)(最常用的方式) 交换机是数据链路层的网络互联设备,交换机可以划分成多个VLAN,每个VLAN可以分配一个或多个端口,在同...
  • 问:我们使用Cisco Catalyst 5500交换机,该交换机的168个端口分配给了一个虚拟LAN。我将SPAN端口配置为监控VLAN,然后将一监测器接到了SPAN端口上。令我吃惊的是,当时吞吐量非常大,竟达到了100%的利用率。除了...
  • 思科交换机vlan配置

    2017-11-22 20:19:00
    vlan:虚拟局域网,是交换机端口的逻辑组合,vlan工作在osi的第二层,一个vlan就是一个广播域,vlan之间的通信是通过第3层的路由器来完成的.2. vlan优点: 1>控制网络的广播问题 2>简化网络管理 3>提高网络的...
  • 掌握交换机命令行各种操作模式的区别,能够使用各种帮助信息,以及用命令进行基本的配置。 掌握如何在交换机上划分基于...注:每台交换机上的每个VLAN,分别分配10个端口,即每台交换机的每个VLAN可以接入10台计算机。
  • 曾有博友问,“如何配置三层交换机创建VLAN ”这个问题,我参考了其他书籍和网络上面的一些资料简单的介绍下。 ...将端口分配VLAN的方式有两种,分别是静态的和动态的。 形成静态VLAN的过...
  • 三层交换机vlan路由

    2019-03-14 14:31:19
    拓扑图如下: 注:LSW1为华为S5700三层交换机。...#创建vlan10,并将0/0/1端口分配vlan10 [Huawei]vlan 10 [Huawei-vlan10]port GigabitEthernet 0/0/1 [Huawei-vlan10]quit #创建vlan20,并将0/0/2端口...
  • 我们使用Cisco Catalyst 5500交换机,该交换机的168个端口分配给了一个虚拟LAN。我将SPAN端口配置为监控VLAN,然后将一监测器接到了SPAN端口上。令我吃惊的是,当时吞吐量非常大,竟达到了100%的利用率。除了非常大...
  • CISCO三层交换机+二层交换机配置VLAN的实例  Cisco的VLAN实现通常是以端口为中心的。...将端口分配VLAN的方式有两种,分别是静态的和动态的.形成静态VLAN的过程是将端口强制性地分配给VLAN的过程。即我
  • 交换机VLAN内通信

    千次阅读 2019-05-10 14:20:38
    接入端口传输来自分配给该端口的特定 VLAN 的流量。TRUNK端口默认为所有 VLAN 的成员;因此,它传输所有 VLAN 的流量。本练习主要介绍创建 TRUNK 端口并将它们分配给本征 VLAN(而不是默认 VLAN)。 地址分配表 ...
  • 接入端口传输来自分配给该端口的特定 VLAN 的流量。TRUNK端口默认为所有 VLAN 的成员;因此,它传输所有 VLAN 的流量。本练习主要介绍创建 TRUNK 端口并将它们分配给本征 VLAN(而不是默认 VLAN)。 地址分配表: ...
  • CISCO Vlan 配置实例 如何配置三层交换机创建VLAN ...将端口分配VLAN的方式有两种,分别是静态的和动态的。 形成静态VLAN的过程是将端口强制性地分配给VLAN的过程。即我们先在VTP (VLAN Tr...
  • Cisco的VLAN实现通常是以端口为中心的。与节点相连的端口将确定它所驻留的...即我们先在VTP (VLAN Trunking Protocol)Server上建立VLAN,然后将每个端口分配给相应的VLAN的过程。这是我们创建VLAN最常用的方法。...
  • 划分vlan端口,将fa0/1-2分配vlan 10、fa0/3划分给vlan 203.配置交换机svi4.设置交换机三层接口+路由测试结果 实验目的 ·搭建如拓扑图所示的网络 • 删除交换机启动配置并将其重新加载到默认状态 • 执行交换机上...

空空如也

空空如也

1 2 3 4 5 ... 14
收藏数 262
精华内容 104
关键字:

交换机端口分配vlan