精华内容
下载资源
问答
  • 交换机设置局域网
    千次阅读
    2021-07-28 02:43:58

    交换机是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路,可以实现电脑的共同上网。如果多台电脑之间如何组建小型局域网呢?我们可以用交换机来组建局域网,下面一起看下win7系统使用交换机组建局域网的详细步骤。

    846c20a36fdb41a53e425814173675a8.png

    1、将宿舍6电脑交换机连接好;

    2、修改6台电脑的IP地址:分别是:pc1:192.168.1.1 ; pc2:192.168.1.2;

    pc3:192.168.1.3 ; pc4:192.168.1.4 ; pc5:192.168.1.5 ;pc6:192.168.1.6;

    修改ip的步骤:打开本地连接属性,双击TCP/IP协议,输入ip地址即可;

    3、6台电脑都必须是同一个工作组,右键我的电脑——属性——计算机名——更改——这里面设置;

    4、安装IPX协议,控制面板——网络连接——本地连接——属性——安装——协议——添加——NWLink

    IPX/SPX/NETBIOS;

    5、测试网络是否连通 打开运行,输入CMD,然后输入ping对方的IP,看是否能够连通;

    例如:ping

    192.168.1.1六台机器都连上交换机,设置好同一段ip,物理上就已经是局域网了。

    以上和大家分享内容就是win7系统使用交换机组建局域网的方法,简单设置之后,多台电脑之间可以一起玩游戏、共享文件了。

    更多相关内容
  • 交换机组建局域网

    千次阅读 2020-12-18 11:06:12
    说来惭愧,今天才搞明白用交换机组建局域网的原理,这里介绍方法: 平时使用的路由器有交换机的功能,单纯使用路由器还是第一次: 1、将所有电bai脑连到同一台交换机上,du即将各台电zhi脑的网线插入同一dao台交换机...

    说来惭愧,今天才搞明白用交换机组建局域网的原理,这里介绍方法:
    平时使用的路由器有交换机的功能,单纯使用交换机还是第一次:
    1、将所有电bai脑连到同一台交换机上,du即将各台电zhi脑的网线插入同一dao台交换机的poe接口。

    在这里插入图片描述

    2、设置其中某个电脑的IP地址及子网掩码,如下图所示,使用常用的局域网IP地址为例进行设置。

    在这里插入图片描述

    3、设置其余各个电脑的IP地址及子网掩码,并确保与第一台电脑处于同一子网。即IP地址设置为192.168.1.2~192.168.1.254中任一IP,子网掩码为255.255.255.0。如下图:

    在这里插入图片描述
    这样两台电脑就在一个局域网内,可以互相ping通,进行网络通信了,其中最常用的功能是打游戏和共享文件。

    展开全文
  • 交换机组建局域网的简单方法,局域网连接的简单步骤,适合初学者快速实践应用。
  • 它既有交换机的全部功能,又有路由器的部分功能,一台设备就实现局域网内的数据高速转发。接下来,我们就详细介绍下三层交换机。 1、什么是三层交换机? 三层交换机是在二层交换机的基础上,增加了路由选

    大家好,我是 Fox 。最近在追一部剧,封面就是女主角,剧中男主光环太强了,太多不符合常理的设定,都想弃剧了。可说来奇怪,这剧质量不咋的,但还是想继续追完,这就是爽剧的魅力吧。开始追剧的原因很简单,就是男主张若昀,喜欢看他演的《庆余年》,结果这部剧翻车了。但是二层交换机的升级产品:三层交换机,没翻车,一个顶俩,很给力。它既有交换机的全部功能,又有路由器的部分功能,一台设备就实现局域网内的数据高速转发。接下来,我们就详细介绍下三层交换机。

    1、什么是三层交换机?

    三层交换机是在二层交换机的基础上,增加了路由选择功能的网络设备,能够基于 ASIC 和 FPGA 实现网络功能和转发分组。

    二层交换机能够基于数据链路层的 MAC 地址,进行数据帧或 VLAN 的传输功能。三层交换机能够基于网络层的 IP 地址,实现路由选择以及分组过滤等功能。

    二层交换机通过使用 VLAN 分隔广播域,位于同一个 VLAN 下的终端才能进行数据帧交互。对于不同 VLAN 的终端有通信需求时,就必须使用路由功能,也就是需要额外添加路由器

    二层交换机和路由器组合使用,才能完成跨 VLAN 的通信,但使用三层交换机就不需要其它网络设备,能够直接完成不同 VLAN 之间的通信。

    现在,内部网络核心交换机都是使用三层交换机。三层交换机用于由以太网构成的 Intranet 内部转发分组,而路由器作为连接互联网和 Intranet 内网之间的网关来使用。

    2、三层交换机和路由器有什么不同?

    三层交换机一般只支持以太网的数据链路层协议和 IP 网络的网络层协议。

    路由器的物理层和数据链路层除了 IEEE 802 标准以外,还支持其它各种协议,包括 ATM、SDH、串口等。网络层和传输层也一样,支持 TCP/IP 协议簇以外的协议簇,比如 IPX 、AppleTalk 等。这些功能都是由运行在 CPU 上的软件来完成,对比三层交换机,速度会慢不少,但是也有很多功能必须由路由器 CPU 来处理,比如远程接入、安全功能等。

    3、三层交换机的架构是怎样的?

    三层交换机的构成要素有:控制平面、数据平面、背板和物理接口。高端路由器和防火墙也是同样的架构。三层交换机把硬件设备内部分成两个区域,即以路由选择、管理功能为主的控制平面和以数据转发功能为主的数据平面,从而实现高速转发分组的系统架构。

    当硬件内部结构分为控制平面和数据平面时,分组的传输需要使用 FIB(转发信息库)和邻接表的信息。这种利用 FIB 和邻接表信息的 IP 分组传输方式叫做特快转发

    路由器使用 CPU 完成分组转发,而三层交换机使用 ASCI 代替 CPU ,分组的转发更快。

    三层交换机将 FIB 和邻接表合并成一个表项,这个表项叫做 FDB(转发数据库),注册在内存中并通过硬件处理完成高速检索。

    4、什么是多层交换?

    除了二层交换机之外,三层以上功能的交换机统称为多层交换机

    拥有 IP 路由选择等网络功能、能够通过访问控制列表来对传输层的 TCP 端口编号进行访问控制的三层交换机,也叫做四层交换机

    能够支持到 TCP 层级访问控制的交换机叫做四层交换机。能够基于 HTTP 和 HTTPS 这里应用层参数进行负载均衡等操作,这类交换机叫做七层交换机

    有些厂家将处理到应用层的网络设备和路由器区分开来,作为不同类型的产品。但所谓的多层交换机,也就是基于 ASIC 和 FPGA 的硬件处理,高速进行各层业务处理的网络设备。

    5、什么是负载均衡设备?

    多个客户端同时连接一台服务器,可能导致服务器的处理能力超过负载。如果使用多台提供相同服务的服务器,通过使用负载均衡设备,就可以将客户端的请求分散到各个服务器进行处理。

    负载均衡设备可以是专用设备,也可以是在服务器上运行的应用程序。专用设备会有以太网接口,可以说是多层交换机的一种。也存在拥有负载均衡功能的路由器。

    负载均衡设备一般会分配虚拟 IP 地址,所有客户端的请求是通过虚拟 IP 地址完成的,通过负载均衡算法将客户端的请求转发到服务器的实际 IP 地址上。

    负载均衡设备作用

    使用负载均衡设备可以提高扩展性可靠性

    负载均衡设备不仅适用于服务器,防火墙代理服务器这种安全设备也可以使用负载均衡设备。

    负载均衡算法类型

    6、什么是 SSL 加速?

    SSL 加速是负载均衡专用设备的一项功能,执行这个功能的内部装置叫做 SSL 加速器

    在服务器进行 SSL 通信时,对传输的数据进行加密解密操作需要执行相当复杂的计算,这会导致服务器 CPU 的处理负载进一步加大。与不执行加密解密的 HTTP 通信对比,HTTPS 的处理负载是 HTTP 的 10 倍。

    这时,通过使用 SSL 加速器对客户端的 HTTPS 请求进行解密,并转换成 HTTP 请求后再转发到实际的服务器上,这样就可以降低服务器 CPU 的处理负载。

    这样一来,整个系统在提高服务器响应速度的同时,还能减少服务器的数量,在单位时间内能够转发更多 Web 服务内容。

    7、根据性能分类,三层交换机有几种类型?

    根据三层交换机的背板容量,可分为高端交换机中端交换机低端交换机

    高端三层交换机

    框式三层交换机由路由引擎、交换结构、线卡模块、风扇模块和电源模块组成,一般作为企业的核心交换机用在数据中心。

    为了提高交换机的可靠性,除了线卡模块之外,其余模块都提供了冗余结构。电源或风扇模块通常采用 1+N 或 N+N 冗余结构,路由引擎通常采用 1+1 的冗余结构。三层交换机一般通过多台设备堆叠构成三层冗余结构,来提高整个系统的可用性。

    中端三层交换机

    中端三层交换机一般是箱式交换机或最大插槽数为 4 的框式交换机,用于企业核心交换机和接入交换机进行汇聚交换。

    低端三层交换机

    低端三层交换机一般为箱式交换机或桌面式交换机,作为企业的接入交换机使用,设备通常有 24 端口或 48 端口。有些作为 IP 电话或无线 LAN 的访问接入点,还能直接使用以太网的电源供电( PoE )。

    8、三层交换机有哪些功能?

    尽管各个厂家的三层交换机提供的功能不同,但是这些功能大致有几个类别:认证类、管理类、路由选择协议、QoS 、IP 隧道、VLAN 、STP 等。

    在三层交换机中,对分组进行管理的功能是由 CPU(软件)直接处理的。用户直接的通信,是由 ASIC(硬件)处理实现分组的高速转发的。

    9、什么是 VLAN ?

    由一台或几台集线器组成的一个广播域可以称为是一个扁平网络。相互连接的终端会接收网络发来的所有广播帧。随着连接终端数量的增加,广播数量也会增加,网络状况也就越混杂。

    这种情况下,需要采用 VLAN( Virtual Lan )技术把整个扁平网络进行逻辑分段。一个 VLAN 对应一个广播域,不同 VLAN 的广播域互相隔离,因此能够控制广播域内的广播通信规模。

    交换机通过设置,可以轻易的修改物理端口的属性,让这个物理端口加入到某一个 VLAN 之中,而不需要改变对应的物理线路。

    VLAN 之间的通信需要使用路由选择,不借助路由器或三层交换机就无法与不同 VLAN 的终端进行通信,因此安全性也有了保障。

    10、什么是基于端口的 VLAN ?

    基于端口的 VLAN 是在交换机的端口上设置 VLAN ID ,拥有相同 VLAN ID 的多个端口构成一个 VLAN 。通常交换机在初始状态下,所有端口默认 VLAN ID = 1(即 VLAN 1 ),可以对任意一个端口的 VLAN ID 进行设置。比如把修改某一个端口配置为 VLAN ID = 2 ,那这个端口就属于 VLAN 2 。

    11、什么是标签 VLAN ?

    当 VLAN 需要跨越多个交换机时,会使用中继端口( trunk port )的标签 VLAN( tag VLAN )。tag VLAN 通过中继端口完成数据帧的接收和发送,其中数据帧需要添加 4 字节 IEEE 802.1Q 定义的头部信息(即 VLAN 标签信息)。为数据帧添加标签的过程叫做 tagging 。当 tagging 完成后,数据帧的最大长度从 1518 字节变成 1522 字节,其中有 12bit 的 VLAN ID 信息,也就是说,最多支持的 VLAN 数是 4096 个。

    在以太网中,数据帧中 TPID 的值是 0x8100 。如果源地址后面的值不是 0x8100 ,那么就不是 TPID 信息,而是识别成“长度/类型”。当“长度/类型”的值为 0x05DC 以下时,表示数据帧的长度;在0x0600 以上时,表示数据帧的类型。数据帧类型的值分别是:IPv4 是 0x0800 ,ARP 是 0x0806 、IPv6 是 0x86DD 等。

    不支持 IEEE 802.1Q 的交换机,由于无法识别 TPID ,会将 0x8100 视为数据帧类型,但是不存在 0x8100 类型的数据帧,交换机会作为错误帧直接丢弃。

    IEEE 802.1Q 还定义了一个字段:TCI ,TCI 可以分为 3 个类型:PCP 、CFI 和 VID 。

    12、什么是本征 VLAN ?

    本征 VLAN( native VLAN )用于中继端口( trunk port )。如果数据帧在进入 trunk port 前,是没有标记的,那么 trunk port 会给它打上 native VLAN 的标记,这个数据帧就以 native VLAN 的身份传输。如果数据帧在进入 trunk 前,已经打上标记了,且 trunk port 允许这个 VLAN ID 通过,这个数据帧就通过。trunk port 不允许通过的 VLAN 数据帧会直接丢弃。交换机默认使用 VLAN ID 为 1 的 VLAN 作为 native VLAN 。native VLAN 是可以自定义的,通常是使用 VLAN 1 以外的 VLAN 作为本征 native VLAN ,作为管理 VLAN 。

    13、什么是中继端口?

    使用标签 VLAN( tag VLAN )向其它交换机传递 VLAN ID 时,首先设置中继端口( trunk port )。trunk port 能够属于多个 VLAN ,与其它交换机进行多个 VLAN 的数据帧收发通信。两台交换机 trunk port 之间的链路叫做中继链路( trunk link )。

    与 trunk port 和 trunk link 对应的,是接入端口( access port )和接入链路( access link )这两个概念。access port 只属于一个 VLAN ,access link 也仅传输一个 VLAN 数据帧。

    14、什么是私有 VLAN ?

    私有 VLAN( Private VLAN )也叫做 PVLAN ,是指在 VLAN 内部再构建一层 VLAN 的功能,也叫做多层 VLAN 。

    PVLAN 能够进一步分割广播域,削减 VLAN 内部的广播流量并保障通信的安全性。酒店、公寓等场所使用这个功能,能够控制服务器或网关与终端的连接,让不同终端之间无法相互通信。

    PVLAN 由主 VLAN( Primary VLAN )和从 VLAN( Secondary VLAN )组成,从 VLAN 与 1 个主 VLAN 关联。

    15、静态 VLAN 和动态 VLAN 的区别是什么?

    通过输入交换机命令,将一个交换机端口固定分配给某个 VLAN ,这种 VLAN 划分方式叫做静态 VLAN

    相对的,根据连接端口的终端或用户信息自动分配某个 VLAN 的方式叫做动态 VLAN 。具体来说,就是交换机根据终端的 MAC 地址来分配,或者基于 802.1X 的认证来决定端口属于哪个 VLAN 。在动态 VLAN 中,无论终端与哪台交换机连接,都会获取固定的同一个 VLAN 。

    通过交换机内部的数据库,可以实现基于 MAC 地址的认证,但大部分情况下,动态 VLAN 的实现都是使用 RADIUS 服务器。

    16、VLAN 之间的是如何互通的?

    二层交换机

    二层交换机上设置多个 VLAN 后,单台交换机内,数据帧只能在相同 VLAN 内转发,不能在不同 VLAN 之间转发。

    当需要在多个 VLAN 之间转发数据时,一般会使用 trunk link 连接路由器,通过路由器进行 VLAN 之间的路由选择。

    三层交换机

    三层交换机能够在交换机内部直接完成 VLAN 之间的路由选择。

    结尾

    阿威十六式,打完收工。希望文章对你有用,喜欢的话,来个点赞、在看、分享和转发!谢谢!!!

    展开全文
  • 华为交换机、三层交换机局域网中的应用和简单配置,
  • VLAN是为解决以太网的广播问题和安全性而提出的,它在以太网帧的基础上增加了VLAN头,用VLAN ID把用户划分为更小的工作组,限制不同工作组间的用户二层互访,每个工作组就是一个虚拟局域网
  • 局域网交换机配置

    千次阅读 2019-08-16 19:12:02
    局域网规划设计拓扑图的时候:一般会把交换机分为三层结构。 接PC机的这一层交换机:接入层交换机(接PC机)。 中间这一层交换机:汇聚层交换机(将接入层交换机进行聚合) 最上面这一层交换机:核心层交换机...
    • 一、 局域网划分
      • 局域网规划设计拓扑图的时候:一般会把交换机分为三层结构。
      • 接PC机的这一层交换机:接入层交换机(接PC机)。
      • 中间这一层交换机:汇聚层交换机(将接入层交换机进行聚合)
      • 最上面这一层交换机:核心层交换机(交不同VLAN数据进行转发)。
    • 二、 思科局域网配置
      • 1. 接入交换机的配置 :
        • (1).   创建相应的vlan:vlan 10
        • (2).   将交换机连接PC机的端口加入到VLAN10:
          • interface f0/1
          • switchport access vlan 10
        • (3).   将交换机与交换机之间的端口配置成trunk
          • Switch(config)#interface f0/2
          • Switch(config-if)#switchport mode trunk
      • 2. 汇聚层交换机的配置 :
        • (1)、创建相应的vlan(本汇聚层交换机所有的vlan)
          • Switch(config)#vlan 10
          • Switch(config-vlan)#exit
          • Switch(config)#vlan 20
        • 2、将交换机与交换机相连的所有接口配置成trunk.
          • Switch(config)#interface range f0/1-3
          • Switch(config-if-range)#switchport mode trunk
      • 3. 核心层交换机配置 :
        • (1)、创建所有vlan
          • Switch(config)#vlan 10
          • Switch(config-vlan)#exit
          • Switch(config)#vlan 20
          • Switch(config-vlan)#exit
        • (2)、交换机与交换机之间相边的端口配置成trunk
          • Switch(config)#interface f0/1
          • Switch(config-if)#switchport trunk encapsulation dot1q
          • Switch(config-if)#switchport mode trunk
          • 注意:三层交换机打trunk的时候一定要打封装。二层交换机直接打trunk就可以了。
        • (3)、给所有计算机配置网关
          • Switch(config)#interface vlan 10
          • Switch(config-if)#ip address 192.168.10.1 255.255.255.0
          • Switch(config-if)#exit
          • Switch(config)#interface vlan 20
          • Switch(config-if)#ip address 192.168.20.1 255.255.255.0
        • (4)、打开路由表的功能(路由表就有路由转发功能)Ip routing
          • Switch#show ip route
    • 三、华为局域网配置
      • 2. 汇聚层交换机
        • (1) 创建VLAN
          • vlan 10
        • (2)将交换机与交换机相连接口配置成trunk
          • port link-type trunk
          • port trunk allow-pass vlan all
      • 1. 接入层交换机
        • (1)创建VLAN : VLAN 10
        • (2)将接计算机的端口加入VLAN
          • interface e0/0/2
          • port link-type access
          • port default vlan 10
        • (3).   将交换机与交换机之间的端口配置成trunk
          • interface g0/0/1
          • port link-type trunk
          • port trunk allow-pass vlan all
      • 3. 核心层交换机
        • (1)、创建所有vlan
          • Switch(config)#vlan 10
          • Switch(config-vlan)#exit
          • Switch(config)#vlan 20
          • Switch(config-vlan)#exit
        • (2)交换机与交换机配置trunk
          • interface g0/0/1
          • port link-type trunk
          • port trunk allow-pass vlan all
        • (3)配置计算机网关
          • interface vlan 10
          • ip address 192.168.10.254 255.255.255.0
        • (4)配置路由转发
          • 开启路由转发功能
          • 华为默认是开启了路由转发功能
    • 5.4 适合所有的厂商,324 模板
    • 5.5 注意
      • 华为与思科区别
      • 思科默认路由转发功能是关闭的,华为路由转发功能是默认开启的。
    展开全文
  • 局域网设置(实用于安装了交换机的局域网).pdf
  • 交换机组建局域网.pdf

    2022-07-04 10:39:54
    交换机组建局域⽹ 说来惭愧,今天才搞明⽩⽤交换机组建局域⽹的原理,这⾥介绍⽅法: 平时使⽤的路由器有交换机的功能,单纯使⽤交换机还是第⼀次: 1、将所有电bai脑连到同⼀台交换机上,du即将各台电zhi脑的⽹线插...
  • 交换机组建局域网.ppt

    2022-07-04 10:40:41
    交换机组建局域网.ppt该文档详细且完整,值得借鉴下载使用,欢迎下载使用,有问题可以第一时间联系作者~
  • 交换机工作在数据链路层 应用层 & 传输层 路由器工作原理: wan口: 连接广域网使用, 它一般都是接的外 网 LAN口: 用于局域网连接, 这里设置的是网关 路由器收到LAN口 的数据,它转发给 WAN口,然后根据 路由表来...
  • 实验一交换机基本配置及虚拟局域网VLAN.pdf
  • 交换机组建局域网实验.pdf
  • 实验7 多个交换机虚拟局域网

    千次阅读 2020-09-28 10:17:04
    1.2 掌握交换机虚拟局域网的划分方法 1.3 掌握trunk链路与access链路的区别 1.4 理解802.1Q协议 2 实验准备 2.1 安装操作系统电脑一台 2.2 思科模拟器 3 实验步骤 3.1 创建实验拓扑图(图需要根据自己的实际情况做...
  • 如何用交换机组建局域网.docx
  • 三层交换机局域网中的使用.pdf
  • 交换机组建局域网实验收集.pdf
  • 交换机组建局域网学习教案.ppt
  • 交换机组建局域网实验参考.pdf
  • 交换机组建局域网PPT课件.pptx
  • 交换机虚拟局域网实验课件 制作单位曲靖师范学院计算机科学与工程学院 制 作 人张顺吉 制作时间2012年5月25日 实验目的掌握复杂虚拟局域网的规划及交换机配置方法 实验重点理解虚拟局域网的功能 实验难点多层次多...
  • 华为交换机虚拟局域网(VLAN)的配置

    千次阅读 2019-03-26 00:18:52
    交换机端口和Vlan的设置。 测试 五、实验过程原始记录(数据、图标、计算等) 2.(2)-1、创建vlan10和20 2.(2)-2、配置与PC连接的端口链接类型为access 2.(2)-3、配置与交换机连接的端口链接类型为tru....
  • 交换机组建局域网PPT学习教案.pptx
  • 下面讲述下什么是局域网交换机?以及局域网交换机的工作原理和相关的操作技巧,与桥接器不同的是交换机转发延迟很小,操作接近单个局域网性能,远远超过了普通桥接互联网络之间的转发性能。
  • 用思科交换机杜绝局域网广播风暴.pdf
  • 交换机组建局域网实验[收集].pdf
  • 交换机虚拟局域网组网VLAN技术与配置.ppt
  • WIN7使用交换机建立局域网的方法资料.pdf

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 64,639
精华内容 25,855
关键字:

交换机设置局域网