精华内容
下载资源
问答
  • 交换机 路由器配置

    2020-06-26 22:00:21
    实验内容步骤: 一、地址绑定配置 影响网络安全的因素有很多,IP地址盗用或地址欺骗就是其中常见且危害极大的一个问题,防御措施一是在交换机接口上绑定计算机的MAC地址与IP地址,只有满足绑定条件的计算机,才能...

    计算机网络A
    实验指导书

    计算机科学与技术学院
    2019.2

    注意事项

    1. 实验报告纸请自行领取(无需封面)。
    2. 实验报告纸的各项内容务必填全,室温:常温,气压:常压。(成绩、教师签字不填写),包括右上角的页号、下方的实验室名称与日期。实验室名称:网络与信息安全实验室
    3. 一次实验一张报告纸(4次实验共4张)。
    4. 实验报告上的各栏目严格按本文档填写。
    5. 实验项目名称、项目编码、指导教师、实验目的、实验仪器、原理概述、实验内容步骤(仅蓝色字部分)、实验室名称按本文档照抄。
    6. “数据记录表及处理”与“实验结论及问题讨论”,按照本文档要求,自己组织编写,严禁抄袭。
    7. 实验地点 :不写。
    8. 实验时间:第一次实验:2020-4-13
      第二次实验:2020-4-20
      第三次实验:2020-5-11
      第四次实验:2020-6-3

    实验1
    项目名称:局域网组建(编码:E1219701)
    指导教师:赵金铃
    实验目的:
    熟悉以太网,掌握双绞线连接线的制作方法,掌握使用交换机组建以太网的方法,熟悉交换机的基本配置方法。
    实验仪器:以太网、交换机、PC机、卡线钳、双绞线、RJ45头。
    原理概述:
    局域网是计算机网络的重要组成部分,主要特点是地理覆盖范围较小。以太网是目前应用最广泛的一种局域网,一般采用星型或树型拓扑结构,交换机作为核心,双绞线或光纤作为传输介质。一般交换机均可使用命令行方式进行配置。
    实验内容步骤:
    一、熟悉以太网
    1.查看本实验室内的网络拓扑结构,重点是交换机。
    2.熟悉以太网的常用传输介质:双绞线及RJ-45头(俗称水晶头)。
    RJ-45头的线号:将RJ-45头有金属触脚的一面朝向自己,自上至下线号分别为1-8,如图1.1所示。

    图1.1 RJ45接头的线号
    制作RJ-45头时的接线顺序有两种标准,如表1-1所示。
    表1-1 RJ-45头的线序
    线号 1 2 3 4 5 6 7 8
    EIA-568A 绿白 绿 橙白 蓝 蓝白 橙 棕白 棕
    EIA-568B 橙白 橙 绿白 蓝 蓝白 绿 棕白 棕
    网卡的1、2两脚为信号发送端,3、6两脚为信号接收端。交换机和集线器则相反,3、6两脚为信号发送端,1、2两脚为信号接收端。所以两种接线情况如下:
    (1)计算机接至交换机,双绞线两端的线序应该一样,即都为EIA-568A或EIA-568B,通常为EIA-568B,这种线称为直连线(工程中常称为普通跳线、标准跳线、跳线)。
    (2)计算机间直接相连,双绞线两端的线序应该不一样,即一端为EIA-568A,另一端为EIA-568B。这种线称为交叉线。
    二、制作双绞线连接线
    1.剥线:用卡线钳的剪线刀口将双绞线端头剪齐,再划开双绞线的保护胶皮(注意不要划到里面的导线),从而剥下保护胶皮,如图1.2所示。

    图1.2 剥掉外层保护胶皮后
    2.理线:请按照标准EIA-568B(推荐)或EIA-568A的线序排列双绞线内的导线,如图1.3所示。

    图1.3(a) 理线前 图1.3(b) 理线后
    3.插线:一只手捏住水晶头,另一只手捏住双绞线,稍稍用力将排好的线平行插入水晶头内的线槽中,每根线顶端都应插到线槽顶端,如图1.4所示。

    图1.4 插线 图1.5 卡线钳
    4.压线:确认所有导线都到位后,将水晶头放入卡线钳(如图1.5所示)夹槽中,用力捏紧卡线钳,压紧线头即可。
    注意,为了结实牢固,制作完毕的连接线的双绞线塑料硬皮必须在水晶头内部,而且应该被牢固压住,否则为不合格。图1.6为不合格的双绞线连接线,图1.7为合格的双绞线连接线。

    图1.6 不合格的连接线 图1.7 合格的连接线
    5.检测:将双绞线两端分别插入测线仪的信号发射器和信号接受器,打开电源,如果是制作成功的直连线,则两端的指示灯会一起亮起来,依次从1号到8号,如图1.8所示。

    图1.8 测线仪
    三、熟悉交换机
    1.交换机上的接口
    以太网交换机通常具有若干以太网接口(8、16、24、48等)与一个Console口。以太网接口一般有10M/100M自适应接口、1000M接口等。Console口称为控制台口,通过该接口可以配置交换机。
    刚出厂的交换机没有IP地址,无法通过网络登录上去配置,这时只能通过Console口配置。交换机出厂自带一根专用电缆,进行配置时,电缆一端连接到Console口上,一端连接到计算机的COM口(串口)上,在计算机上通过超级终端等软件,交换机上不需要有IP地址,就可以登录到交换机上进行配置了。给交换机配置好IP地址后,以后就可以通过网络利用Telnet协议登录到交换机上,进行远程配置了。
    交换机上的接口都有名称,不同厂家的命名法可能不一样。
    2.交换机的工作模式
    交换机一般用命令行方式进行配置。交换机有4种工作模式:用户模式、特权模式、全局配置模式、接口配置模式。
    用户模式是登录交换机后的第一个模式,该模式下可以查看交换机的部分信息,并进行简单的测试。用户模式提示符为“>”。
    特权模式是由用户模式进入的下一级模式,该模式下可以查看交换机的详细信息,进行网络的测试和调试等。特权模式提示符为“#”。
    全局配置模式属于特权模式的下一级模式,该模式下可以配置交换机的全局性参数。全局模式提示符为“(config)#”。
    接口配置模式属于全局配置模式的下一级模式,该模式下可以对交换机的某个接口进行配置。接口配置模式提示符为“(config-if)#”。
    四、交换机的简单配置
    登录到交换机上,练习如下配置命令(绿色字为输入的命令,其中正体字为关键字,斜体字为参数,红色字为注释),注意命令前的提示符,这说明该命令应该在何种工作模式下使用。
    1.命令简写与自动补齐
    某个命令如果太长,或者没有记全,可以简写。或者输入前几个字母后,按TAB键,可以自动补齐这条命令。这时要求所简写的字母必须能够唯一区别该命令。例如,config可以代表configure,但co无法代表configure,因为co开头的命令有两个copy和configure,设备无法区别。
    2.四种工作模式切换
    S3760-1>enable 14
    注释:“S3760-1”是该交换机的名称,“>”是提示符。刚登录时是用户模式,输入命令“enable”进入特权模式,可简写为“en”。数字14是指14级权限。
    S3760-1>password 123456
    注释:口令为123456。
    S3760-1#configure terminal
    注释:进入全局配置模式,简写方式为“conf t”或者“config t”。
    S3760-1(config)#interface fastethernet 0/1
    注释:进入接口fastethernet 0/1的配置模式,简写为“int f 0/1”。
    S3760-1(config-if)#exit
    注释:退回到上一级模式。
    S3760-1(config)#exit
    注释:继续退回到上一级模式。
    S3760-1#
    进行工作模式切换时,注意提示符的变化。
    3.获取帮助
    S3760-1>?
    注释:直接输入“?“可显示当前模式下所有可执行的命令。
    S3760-1#co?
    注释:输入几个首字母后,输入“?”可显示所有以co开头的命令。
    S3760-1#config ?
    注释:输入一个命令后,输入空格再输入“?”可显示该命令后可选择的参数。
    4.更改交换机名称
    S3760-1(config)#hostname xxx
    注释:xxx是操作者给交换机新起的名称。
    5.启用和关闭交换机接口
    S3760-1(config-if)#no shutdown
    注释:在接口配置模式下,启用该接口。
    S3760-1(config)#shutdown
    注释:关闭该接口,不再转发数据。
    6.查看配置信息
    在用户模式和特权模式下,可以运行不同的查看命令,查看交换机的一些配置信息。
    S3760-1#show interface f 0/10
    注释:查看交换机f 0/10接口上的配置信息,可简写为“sh int f 0/10”。
    S3760-1#show running-config
    注释:查看交换机正在生效的全部配置信息,可简写为“sh run”。
    实验内容步骤(抄入实验报告部分):
    一、熟悉以太网
    查看本实验室内的网络拓扑结构。
    二、制作双绞线连接线
    熟悉双绞线连接RJ-45头的线序标准:EIA-568A、EIA-568B,并实际制作双绞线连接线。
    三、熟悉企业级交换机的外观、接口与工作模式。
    四、练习交换机的简单配置命令。
    实验室名称:网络与信息安全实验室
    数据记录表及处理:
    记录实验室的网络拓扑结构、双绞线连接RJ-45头的线序标准、交换机的工作模式、配置命令等内容的一部分即可。数量以基本填满实验报告纸的本栏目为宜。
    实验结论及问题讨论:

    1. 标准化:双绞线连接RJ-45头的线序标准,网络协议。
    2. 知识产权:思科命令。
    3. 管理:布线整齐、线上贴标签。

    实验2
    项目名称:交换机的配置(编码:E1219702)
    指导教师:赵金铃
    实验目的:
    掌握交换机的常用配置方法,包括交换机接口绑定MAC地址与IP地址的配置方法,以及交换机上VLAN的配置方法。
    实验仪器:以太网、交换机、PC机。
    原理概述:
    一般交换机均可使用命令行方式进行配置。MAC地址与IP地址绑定、划分VLAN是交换机上的常用技术。地址绑定可以提高安全性。VLAN是一种用于隔离广播域以及控制访问的技术。相同VLAN内的计算机可以互相直接访问,不同VLAN内的计算机不能互相直接访问。如果属于不同VLAN的计算机要互相访问,必须经路由器或三层交换机转发。
    实验内容步骤:
    一、地址绑定配置
    影响网络安全的因素有很多,IP地址盗用或地址欺骗就是其中常见且危害极大的一个问题,防御措施之一是在交换机接口上绑定计算机的MAC地址与IP地址,只有满足绑定条件的计算机,才能通过该接口收发数据。
    下面的操作将计算机A绑定在交换机的f 0/1接口上。
    1.使用ipconfig /all命令查看计算机A的MAC地址。假设计算机A的IP地址为10.1.1.1,MAC地址为 00-1b-b9-d9-b0-37。
    2.交换机上的配置如下(在输入命令时,请注意该命令前的提示符,提示符说明该命令应该在何种工作模式下输入):
    S3760-1# configure terminal
    注释:进入全局配置模式。
    S3760-1(config)# interface fastethernet 0/1
    注释:进入接口f 0/1的配置模式。
    S3760-1(config-if)# switchport mode access
    注释:把接口模式改为access类型,用于连接计算机的接口一般设为access类型。
    S3760-1(config-if)# switchport port-security
    注释:启用接口安全。
    S3760-1(config-if)# switchport port-security maximum 1
    注释:定义该接口最多能绑定1个MAC地址,参数范围为1~128。
    S3760-1(config-if)#switchport port-security mac-address 001b. b9d9.b037
    注释:该接口和MAC地址绑定。
    S3760-1(config-if)#switchport port-security mac-address 001b.b9d9.b037 ip-address 10.1.1.1
    注释:该接口与MAC地址和IP地址绑定。
    S3760-1(config-if)#exit
    S3760-1(config)#exit
    S3760-1#show running-config
    注释:查看交换机的所有配置信息。其中,与这条绑定有关的配置信息如图2.1所示。

    图2.1 绑定配置信息截图
    二、VLAN(虚拟局域网)的划分
    VLAN(Virtual Local Area Network)即虚拟局域网。此处的局域网应理解为子网(subnet)。它是在一个物理网段内进行逻辑地划分,划分成若干个虚拟局域网,每一个VLAN都包含一组有着相同需求的计算机,相当于物理上形成的局域网。在同一VLAN里的计算机能相互直接通信,而在不同VLAN里的计算机不能直接相互通信。如果属于不同的VLAN的计算机需要通信的话,必须经过路由器或三层交换机转发。
    一台计算机属于哪个VLAN的依据有多种,如该计算机的IP地址、MAC地址、它所连接交换机的物理接口等等。下面的配置是依据交换机物理接口的。实验结构如图2.2所示,3台计算机和两台交换机连接成1个局域网,其中计算机A、B划为VLAN10,计算机C划为VLAN20。

    图2.2 VLAN划分
    1.验证划分VLAN前各计算机能互相ping通
    将计算机A、B、C的本地连接禁用,启用测试连接,设置IP地址分别为10.1.1.1~10.1.1.3(都在1个子网内即可),子网掩码均为255.255.255.0,并接好测试线路,验证划分VLAN前,各计算机能互相ping通。
    2.交换机switch1上的配置(在输入命令时,请注意该命令前的提示符,提示符说明该命令应该在何种工作模式下输入)
    (1) 创建VLAN10,并将f0/1接口划分到VLAN10中。
    switch1(config)#vlan 10
    注释:建立标识符为10的vlan。
    switch1(config-vlan)#exit
    switch1(config)#interface fastethernet 0/1
    switch1(config-if)#switchport access vlan 10
    注释:将接口f0/1划归到vlan 10。
    switch1(config-if)#exit
    switch1(config)#exit
    switch1#show vlan id 10
    注释:查看vlan 10的信息。
    (2) 把与交换机switch2相连的接口f 0/24定义为trunk模式。
    switch1(config)#interface fastethernet 0/24
    switch1(config-if)#switchport mode trunk
    switch1(config-if)#exit
    switch1(config)#exit
    switch1#show vlan
    注释:查看当前交换机上全部的vlan配置。
    3.交换机switch2上的配置
    (1) 创建VLAN 10,并将f 0/1接口划分到VLAN10中。
    switch2(config)#vlan 10
    注释:建立标识符为10的vlan。
    switch2(config-vlan)# exit
    switch2(config)#interface fastethernet 0/1
    switch2(config-if)#switchport access vlan 10
    注释:将接口f 0/1划归到vlan 10。
    switch2(config-if)#exit
    switch2(config)#exit
    switch2#show vlan id 10
    注释:查看vlan10的信息。
    (2) 创建VLAN 20,并将f0/2接口划分到VLAN 20中。
    switch2(config)#vlan 20
    注释:建立标识符为20的vlan。
    switch2(config-vlan)# exit
    switch2(config)#interface fastethernet 0/2
    switch2(config-if)#switchport access vlan 20
    注释:将接口f 0/2划归到vlan 20。
    switch2(config-if)#exit
    switch2(config)#exit
    switch2#show vlan id 20
    注释:查看vlan20的信息。
    (3) 把与交换机switch1相连的接口f0/24定义为trunk模式。
    switch2(config)#interface fastethernet 0/24
    switch2(config-if)#switchport mode trunk
    switch2(config-if)#exit
    switch2(config)#exit
    switch2#show vlan
    注释:查看当前交换机上全部的vlan配置。
    4.验证
    划分完VLAN后,将计算机A、B、C的本地连接禁用,启用测试连接,设置IP地址分别为10.1.1.1~10.1.1.3(都在1个子网内即可),子网掩码均为255.255.255.0,并接好测试线路,计算机A、 B能互相ping通,但都ping不通C,证明了计算机A、B在同一个VLAN内,而计算机C自己属于另一个VLAN。
    三、VLAN(虚拟局域网)间的互通
    上一步骤划分的不同VLAN内的计算机不能互通,为使不同VLAN内的计算机能够互通,必须使用路由器或三层交换机。在图2.2中,如果两台交换机都为三层交换机,经过配置后三台计算机A、B、C就能互通。假设A的IP地址为10.1.1.1/24,B的IP地址为10.1.1.2/24,C的IP地址为10.1.2.1/24,配置步骤如下:
    1.交换机switch1上的配置
    不需配置。
    2.交换机switch2上的配置
    switch1(config)#interface vlan 10
    注释:进入vlan10。
    switch1(config-if)#ip address 10.1.1.100 255.255.255.0
    注释:为vlan10设置SVI(交换机虚拟接口)的IP地址。
    switch1(config-if)#no shutdown
    switch1(config-if)#exit
    switch1(config)#interface vlan 20
    注释:进入vlan20。
    switch1(config-if)#ip address 10.1.2.100 255.255.255.0
    注释:为vlan20设置SVI(交换机虚拟接口)的IP地址。
    switch1(config-if)#no shutdown
    3.验证
    将计算机A、B、C的本地连接禁用,启用测试连接,并接好测试线路。把计算机A与B的默认网关设为10.1.1.100,即VLAN10的SVI的IP地址,计算机C的默认网关设为10.1.2.100,即VLAN20的SVI的IP地址。此时A、B、C就可以相互ping通了。
    实验内容步骤(抄入实验报告部分):
    一、地址绑定配置
    配置交换机,在某个接口上绑定计算机的MAC地址与IP地址。
    二、配置交换机,按下图划分VLAN。

    三、配置交换机,实现上图中两个VLAN间的互通。
    实验室名称:网络与信息安全实验室
    数据记录表及处理:
    记录交换机部分重要配置命令,以及某些配置命令的输出。数量以基本填满实验报告纸的本栏目为宜。
    实验结论及问题讨论:
    自己实验中遇到的问题,必须与实验相关,如交换机计算机间的连线、交换机的配置命令,对某些配置命令输出的理解。

    实验3
    实验项目:路由器的配置(编码:E1219703)
    指导教师:赵金铃
    实验目的:熟悉路由器的使用和配置方法,巩固和加深理解网络互联原理,同时增强实际操作网络设备的能力。
    实验仪器:路由器、以太网、PC机。
    原理概述:
    互联网的核心协议是TCP和IP协议。计算机和网络设备都运行IP协议,才能互联在一起。网络互联的关键设备是路由器,路由器可以通过许多命令进行配置。路由器通过查询路由表转发分组。路由表可通过路由协议生成,也可人工输入。NAT与DHCP是路由器常用的两种服务。
    实验内容步骤:
    一、路由器的基本操作
    路由器的基本操作与交换机是相同的,详情请见实验1。
    二、给路由器接口配置IP地址
    R1762-1(config)#interface fastethernet 1/0
    注释:进入接口f 1/0。
    R1762-1(config-if)#no ip address
    注释:取消掉该接口上原来的IP地址。
    R1762-1(config-if)#ip address 1.1.1.100 255.255.255.0
    注释:给该接口配置了IP地址及子网掩码。
    R1762-1(config-if)#no shutdown
    注释:启用该端口(默认是关闭的)。
    三、配置静态路由
    网络拓扑结构如图3.1所示。3台计算机通过两台路由器连接在一起。

    图3.1 网络拓扑结构图
    1.配置路由器接口的IP地址
    设置两台路由器的f1/0、f1/1与s1/2接口的IP地址,注意不要忘记no shutdown命令。设置完毕后可用如下命令查看:
    R1762-1#show ip interface brief
    2.在路由器R1762-1上配置静态路由
    R1762-1(config)#ip route 2.2.2.0 255.255.255.0 4.4.4.5
    注释:4.4.4.5可用s 1/2代替。
    R1762-1(config)#ip route 3.3.3.0 255.255.255.0 4.4.4.5
    注释:4.4.4.5可用s 1/2代替。
    R1762-1(config)#exit
    R1762-1#show ip route
    注释:查看路由表。
    3.在路由器R1762-2上配置静态路由
    R1762-2(config)#ip route 1.1.1.0 255.255.255.0 4.4.4.4
    注释:4.4.4.4可用s 1/2代替。
    R1762-2(config)#exit
    R1762-2#show ip route
    注释:查看路由表。
    在路由器R1762-2中,子网2.2.2.0/24与子网3.3.3.0/24间不需设置静态路由,自动就会连通。
    4.测试网络的互通性
    将计算机A、B、C的本地连接禁用,启用测试连接,设置好IP属性,注意默认网关要设置为与其相连的路由器接口的IP地址,并接好测试线路,然后可以测试3台计算机均可相互通信。
    四、配置网络地址转换(NAT)
    在配置网络地址转换之前,首先必须明确内部接口和外部接口,以及在哪个外部接口上启用NAT。通常情况下,连接到用户内部网络的接口是NAT内部接口,而连接到外部网络(如Internet)的接口是NAT外部接口。
    NAT分静态转换与动态转换两种。静态转换是指内部网络的私有IP地址与端口号和外部公有IP地址和端口号是一对一的,是固定不变的。借助于静态转换,可以实现外部网络对内部网络中某些特定设备(如服务器)的访问。动态转换则相反,对应关系是随机的,不是固定不变的,适用于内部计算机访问外部网络。以下是配置动态转换的过程。
    1.配置NAT
    R1762(config)#ip nat pool net200 1.1.1.1 1.1.1.1 netmask 255.255.255.0
    注释:定义了一个NAT地址池,标识符为net200,含有的地址从1.1.1.1到1.1.1.1,实际只有一个地址,掩码是255.255.255.0。
    R1762(config)#access-list 12 permit any
    注释:定义了一个访问列表,12是其标识符,permit any的含义是允许全部计算机。实际可定义仅允许部分计算机。
    R1762(config)#ip nat inside source list 12 pool net200
    注释:说明NAT使用访问列表12与net200地址池。
    2.配置使用NAT的接口
    R1762(config)#interface fastethernet 1/0
    注释:进入接口f1/0的配置模式,简写为“int f 1/0”。
    R1762(config-if)ip address 10.1.1.1 255.255.255.0
    R1762(config-if)ip nat inside
    注释:设置接口f1/0的IP地址(内部使用的私有地址),并设置为使用NAT的内部接口。
    R1762(config-if)#exit
    R1762(config)#interface fastethernet 1/1
    R1762(config-if)#ip address 1.1.1.1 255.255.255.0
    R1762(config-if)#ip nat outside
    注释:设置接口f1/1的IP地址(net200地址池中的地址),并设置为使用NAT的外部接口。
    R1762(config-if)#exit
    五、配置DHCP
    1.配置DHCP
    R1762(config)#service dhcp
    注释:启用DHCP服务。
    R1762(config)#ip dhcp pool net172
    注释:建立地址池,其标识符为net172。下面的命令将对其设置。
    R1762(dhcp-config)#network 172.21.94.0 255.255.255.0
    注释:设置DHCP地址池net172的网络号和掩码。分配地址时从中选择一个未用地址分配。
    R1762(dhcp-config)#default-router 172.21.94.1
    注释:设置客户端的默认网关。
    R1762(dhcp-config)#dns-server 210.44.176.1
    注释:设置域名服务器
    R1762(dhcp-config)#lease 3
    注释:设置已分配地址的过期时间为3天。
    R1762(dhcp-config)#exit
    注释:退出net172地址池的设置状态。
    2.测试DHCP
    注意:测试连接所连的路由器接口必须设置IP地址,否则DHCP无法运行。例如,测试连接与路由器的fastethernet 1/1接口相连,则该接口必须设置IP地址。在这个例子中,fastethernet 1/1接口的IP地址应该设为172.21.94.1/24,实际上这就是计算机的默认网关。
    禁用计算机的本地连接,把测试连接设置为自动获得IP地址、自动获得DNS服务器地址,接好测试线路,启用测试连接,测试连接即可获得IP地址等属性。
    实验内容步骤(抄入实验报告部分):
    一、练习路由器的基本操作。
    二、给路由器的某个接口配置IP地址。
    三、按下图配置静态路由表。

    四、配置网络地址转换(选做)。
    五、配置DHCP(选做)。
    实验室名称:网络与信息安全实验室
    数据记录表及处理:
    记录路由器部分重要配置命令,以及某些配置命令的输出。数量以基本填满实验报告纸的本栏目为宜。
    实验结论及问题讨论:
    自己实验中遇到的问题,必须与实验相关,如路由器计算机间的连线、路由器的配置命令,对某些配置命令输出的理解。

    实验4
    实验项目:网络编程(编码:E1219704)
    指导教师:赵金铃
    实验目的:掌握套接字(socket)的基本原理,掌握socket编程的基本方法,加深对网络协议及客户-服务器模式的理解。
    实验仪器:局域网、PC机。
    原理概述:
    一台计算机的IP地址与此计算机中运行的一个进程的端口号组成套接字,一对套接字则标明了网络通信的双方。通信双方进行通信的规则的集合则称为协议。客户-服务器模式是应用最为广泛的网络应用模式。利用运输层协议TCP与UDP进行应用层编程称为套接字编程。
    实验内容步骤(抄入实验报告部分):
    利用套接字编程实现不同计算机间传输文件的简单功能,或其他应用性较强的网络通信功能。
    1.先设计一个最简单的协议,例如先实现最基本的文件传输功能。再分析其缺点,改进协议,完善协议功能,克服这些缺点。
    2.自选一种编程工具。
    3.利用该工具编写服务器端与客户端程序,至少实现最基本的文件传输功能,或者其他任何功能,最好能实现更完善一些的功能。
    实验室名称:网络与信息安全实验室
    数据记录表及处理:
    记录协议,包括请求与响应有哪些字段,各字段的长度、格式与含义,服务器与客户的操作。运输层使用TCP还是UDP,端口号问题。
    实验结论及问题讨论:
    由简单到复杂说明协议的设计思路:例如最简单的协议只能实现最基本的文件传输功能,有什么缺点,如何改进,改进后的协议应该增加什么功能。

    展开全文
  • 交换机路由器区别

    2013-07-13 21:50:13
    在主干网上,路由器的主要作用是路由选择。主干网上的路由器,必须知道到达所有下层网络的路径。这需要维护庞大的路由表,并对连接状态的变化作出尽可能迅速的反应。路由器的故障将会导致严重的信息传输问题。 在...

    在主干网上,路由器的主要作用是路由选择。主干网上的路由器,必须知道到达所有下层网络的路径。这需要维护庞大的路由表,并对连接状态的变化作出尽可能迅速的反应。路由器的故障将会导致严重的信息传输问题。

    在地区网中,路由器的主要作用是网络连接和路由选择,即连接下层各个基层网络单位--园区网,同时负责下层网络之间的数据转发。

    在园区网内部,路由器的主要作用是分隔子网。早期的互连网基层单位是局域网(LAN),其中所有主机处于同一逻辑网络中。随着网络规模的不断扩大,局域网演变成以高速主干和路由器连接的多个子网所组成的园区网。在其中,处个子网在逻辑上独立,而路由器就是唯一能够分隔它们的设备,它负责子网间的报文转发和广播隔离,在边界上的路由器则负责与上层网络的连接。

    第二层交换机和路由器的区别

    传统交换机从网桥发展而来,属于OSI第二层即数据链路层设备。它根据MAC地址寻址,通过站表选择路由,站表的建立和维护由交换机自动进行。路由器属于OSI第三层即网络层设备,它根据IP地址进行寻址,通过路由表路由协议产生。交换机最大的好处是快速,由于交换机只须识别帧中MAC地址,直接根据MAC地址产生选择转发端口算法简单,便于ASIC实现,因此转发速度极高。但交换机的工作机制也带来一些问题。

    1.回路:根据交换机地址学习和站表建立算法,交换机之间不允许存在回路。一旦存在回路,必须启动生成树算法,阻塞掉产生回路的端口。而路由器的路由协议没有这个问题,路由器之间可以有多条通路来平衡负载,提高可靠性。

    2.负载集中:交换机之间只能有一条通路,使得信息集中在一条通信链路上,不能进行动态分配,以平衡负载。而路由器的路由协议算法可以避免这一点,OSPF路由协议算法不但能产生多条路由,而且能为不同的网络应用选择各自不同的最佳路由。

    3.广播控制:交换机只能缩小冲突域,而不能缩小广播域。整个交换式网络就是一个大的广播域,广播报文散到整个交换式网络。而路由器可以隔离广播域,广播报文不能通过路由器继续进行广播。

    4.子网划分:交换机只能识别MAC地址。MAC地址是物理地址,而且采用平坦的地址结构,因此不能根据MAC地址来划分子网。而路由器识别IP地址,IP地址由网络管理员分配,是逻辑地址且IP地址具有层次结构,被划分成网络号和主机号,可以非常方便地用于划分子网,路由器的主要功能就是用于连接不同的网络。

    5.保密问题:虽说交换机也可以根据帧的源MAC地址、目的MAC地址和其他帧中内容对帧实施过滤,但路由器根据报文的源IP地址、目的IP地址、TCP端口地址等内容对报文实施过滤,更加直观方便。

    6.介质相关:交换机作为桥接设备也能完成不同链路层和物理层之间的转换,但这种转换过程比较复杂,不适合ASIC实现,势必降低交换机的转发速度。因此目前交换机主要完成相同或相似物理介质和链路协议的网络互连,而不会用来在物理介质和链路层协议相差甚元的网络之间进行互连。而路由器则不同,它主要用于不同网络之间互连,因此能连接不同物理介质、链路层协议和网络层协议的网络。路由器在功能上虽然占据了优势,但价格昂贵,报文转发速度低。 近几年,交换机为提高性能做了许多改进,其中最突出的改进是虚拟网络和三层交换。

    划分子网可以缩小广播域,减少广播风暴对网络的影响。路由器每一接口连接一个子网,广播报文不能经过路由器广播出去,连接在路由器不同接口的子网属于不同子网,子网范围由路由器物理划分。对交换机而言,每一个端口对应一个网段,由于子网由若干网段构成,通过对交换机端口的组合,可以逻辑划分子网。广播报文只能在子网内广播,不能扩散到别的子网内,通过合理划分逻辑子网,达到控制广播的目的。由于逻辑子网由交换机端口任意组合,没有物理上的相关性,因此称为虚拟子网,或叫虚拟网。虚拟网技术不用路由器就解决了广播报文的隔离问题,且虚拟网内网段与其物理位置无关,即相邻网段可以属于不同虚拟网,而相隔甚远的两个网段可能属于不同虚拟网,而相隔甚远的两个网段可能属于同一个虚拟网。不同虚拟网内的终端之间不能相互通信,增强了对网络内数据的访问控制。交换机和路由器是性能和功能的矛盾体,交换机交换速度快,但控制功能弱,路由器控制性能强,但报文转发速度慢。解决这个矛盾的最新技术是三层交换,既有交换机线速转发报文能力,又有路由器良好的控制功能。

    第三层交换机和路由器的区别

    在第三层交换技术出现之前,几乎没有必要将路由功能器件和路由器区别开来,他们完全是相同的:提供路由功能正在路由器的工作,然而,现在第三层交换机完全能够执行传统路由器的大多数功能。作为网络互连的设备,第三层交换机具有以下特征:

    1.转发基于第三层地址的业务流;
    2.完全交换功能;
    3.可以完成特殊服务,如报文过滤或认证;
    4.执行或不执行路由处理。

    第三层交换机与传统路由器相比有如下优点:

    1.子网间传输带宽可任意分配:传统路由器每个接口连接一个子网,子网通过路由器进行传输的速率被接口的带宽所限制。而三层交换机则不同,它可以把多个端口定义成一个虚拟网,把多个端口组成的虚拟网作为虚拟网接口,该虚拟网内信息可通过组成虚拟网的端口送给三层交换机,由于端口数可任意指定,子网间传输带宽没有限制。

    2.合理配置信息资源:由于访问子网内资源速率和访问全局网中资源速率没有区别,子网设置单独服务器的意义不大,通过在全局网中设置服务器群不仅节省费用,更可以合理配置信息资源。

    3.降低成本:通常的网络设计用交换机构成子网,用路由器进行子网间互连。目前采用三层交换机进行网络设计,既可以进行任意虚拟子网划分,又可以通过交换机三层路由功能完成子网间通信,为此节省了价格昂贵的路由器。

    4.交换机之间连接灵活:作为交换机,它们之间不允许存在回路,作为路由器,又可有多条通路来提高可靠性、平衡负载。三层交换机用生成树算法阻塞造成回路的端口,但进行路由选择时,依然把阻塞掉的通路作为可选路径参与路由选择。

    五、结论
    综上所述,交换机一般用于LAN-WAN的连接,交换机归于网桥,是数据链路层的设备,有些交换机也可实现第三层的交换。路由器用于WAN-WAN之间的连接,可以解决异性网络之间转发分组,作用于网络层。他们只是从一条线路上接受输入分组,然后向另一条线路转发。这两条线路可能分属于不同的网络,并采用不同协议。相比较而言,路由器的功能较交换机要强大,但速度相对也慢,价格昂贵,第三层交换机既有交换机线速转发报文能力,又有路由器良好的控制功能,因此得以广播应用。

    展开全文
  •  区别二 路由器在网络层,路由器根据IP地址寻址,路由器可以处理TCP/IP协议,交换机不可以。 交换机在中继层,交换机根据MAC地址寻址。 区别三 路由器可以把一个IP分配给很多个主机使用,这些主机对外只...
  • P x P交换性能是由与传统路由器相同的特征所确定的比如本题3项正确 A? 芯片速度 B? 内存大小 C? 缓冲能力 D? 接口类型多少 2? 下列设备属于单板的多层交换机的是 A? DCS-3926S B? DCRS-5526S C? DCRS-7504 D? DCRS-...
  • 华为交换机路由器安全加固

    千次阅读 2020-12-02 13:09:48
    system-view dhcp enable dhcp snooping enable ipv4 步骤二、使能用户侧接口的DHCP Snooping功能: #以GE0/0/1接口为例,GE0/0/2的配置相同,此处省略。 interface gigabitethernet 0/0/1 dhcp snooping enable ...
    我想我是一朵死去的花,不然怎么就盛开不了呢
                                               ---------涩
    

    现在的网络架构更注重也安全,无论从设备还是软件方面的能体现出来。只有安全的网络才能保证传输的可靠性,稳定性,安全性,以及隐私性。

    华为设备加固

    1,远程管理服务
    对于使用远程维护,telnet协议采用的是不加密传输,容易导致密码不泄露,设备应采用ssh加密协议,提高网络设备管理安全性。

    配置步骤
    1,生成密钥。

    [Huawei]rsa  local-key-pair  create 
    The key name will be: Huawei_Host
    The range of public key size is (512 ~ 2048). 
    NOTES: If the key modulus is greater than 512, 
           it will take a few minutes.
    Input the bits in the modulus[default = 512]:2048
    Generating keys...
    .....+++
    ........+++
    ......................................++++++++
    ...................++++++++
    

    2,配置VTY用户界面。

    [Huawei]user-interface  vty 0 4
    [Huawei-ui-vty0-4]authentication-mode  aaa
    [Huawei-ui-vty0-4]protocol  inbound  ssh 
    

    3,创建用户和密码。

    [Huawei]aaa
    [Huawei-aaa]local-user admin password  cipher  qaz123qaz123
    [Huawei-aaa]local-user  admin privilege  level  15
    [Huawei-aaa]local-user  ad service-type  ssh
    

    4,配置ssh用户的认证方式和服务方式。

    [Huawei]ssh user admin authentication-type password
    [Huawei]ssh user  admin service-type  stelnet 
    

    5,激活

    [Huawei]stelnet  server  enable 
    

    6,查看ssh。

    [Huawei]display  ssh  server status 
    

    2,限制可以登录远程的IP地址
    系统远程管理员telent,ssh,默认可以接受任何地址的连接,出于安全考虑,应该只允许特定地址访问。

    参考配置

    [Huawei]acl  2000
    [Huawei-acl-basic-2000]rule 5 permit source 192.168.1.1 0.0.0.255
    [Huawei-acl-basic-2000]quit
    [Huawei]user-interface  vty  0 4
    [Huawei-ui-vty0-4]acl  2000 inbound 
    [Huawei] display current-configuration configuration user-interface 查看配置
    

    3,账户登录空闲时间
    设置console和vty的登录超时时间5分钟,5分钟后重新输入密码

    参考配置

    <Huawei>system-view 
    [Huawei]user-interface  console  0
    [Huawei-ui-console0]idle-timeout  5 0
    
    <Huawei>system-view 
    [Huawei]user-interface  vty  0 4
    [Huawei-ui-vty0-4]idle-timeout  5 0
    

    4,服务优化
    关闭网络设备不需要的服务,比如ftp,telnet,等。

    参考配置

    [Huawei]undo ftp server
    Warning: The operation will stop the FTP server. Continue? [Y/N]:y
    
    [Huawei]undo telnet server enable 
    Warning: The operation will stop the Telnet server. Continue? [Y/N]:y
    

    5,关闭未使用的端口

    参考配置

    关闭端口
    [Huawei]interface  g0/0/2
    [Huawei-GigabitEthernet0/0/2]shutdown  
    
    激活端口
    [Huawei-GigabitEthernet0/0/2]undo shutdown 
    

    6,ip地址和mac地址绑定。
    防止办公人员随意更改IP地址,还可以防止arp欺骗攻击,出于安全考虑做静态arp绑定,动态IP地址会随意变动,导致无法上网

    参考配置

    [Huawei]arp static 192.168.1.1 5489-9891-09A3
    

    7,环路检测配置
    为防止交换机环路对网络造成影响,要求开启环路检测功能

    参考配置

    [Huawei]loopback-detect enable 
    [Huawei]interface  g0/0/1
    [Huawei-GigabitEthernet0/0/1]loopback-detect  enable 
    [Huawei-GigabitEthernet0/0/1]loopback-detect  action  block 
    
    动作说明
    1)block接口检测到环路时将接口堵塞;
    2)nolearn 接口检测到环路时禁止接口进行MAC地址学习;
    3)shutdown接口检测到环路时将接口关闭;
    4)trap接口检测到环路时只上报告警。
    

    8,局域网防病毒
    配置acl,禁止访问危险端口:135、137、138、139、445、3389。

    参考配置

    [Huawei]acl number  3000
    [Huawei-acl-adv-3000]rule 5 deny tcp destination-port eq 135
    [Huawei-acl-adv-3000]rule 10 deny tcp destination-port eq 137
    [Huawei-acl-adv-3000]rule 15 deny tcp destination-port eq 138
    [Huawei-acl-adv-3000]rule 20 deny tcp destination-port eq 139
    [Huawei-acl-adv-3000]rule 25 deny tcp destination-port eq 445
    [Huawei-GigabitEthernet0/0/1]traffic-filter inbound  acl 3000
    

    9,DHCP snooping配置
    网络中存非法用户的攻击导致合法用户不能造成获取ip地址,加固后能防止网络中针对DHCP的攻击,为DHCP用户提供更优质的服务

    参考配置

    步骤一、使能DHCP Snooping功能:
    #使能全局DHCP Snooping功能并配置设备仅处理DHCPv4报文。
    system-view
    dhcp enable
    dhcp snooping enable ipv4
    
    步骤二、使能用户侧接口的DHCP Snooping功能:
    #以GE0/0/1接口为例,GE0/0/2的配置相同,此处省略。
    interface gigabitethernet 0/0/1
    dhcp snooping enable
    quit
    
    步骤三:配置接口的信任状态:将连接DHCP Server的接口状态配置为“Trusted”:
    interface gigabitethernet 0/0/X
    dhcp snooping trusted
    quit
    
    展开全文
  • 交换机(SWITCH)类似于HUB,能连接两个局域网段。它工作在数据链路层,能起到过滤帧的作用。SWITCH检测帧的源地址及目的地址。如果在同一网络段则不转发。如果不在同一网段,就把帧转发到另一网段。  

    集线器(HUB)是中继器的一种形式。它工作在物理层,与中继器一样,常用于两个网络节点之间物理信号的双向转发。完成信号的复制,调整和放大功能。不同的是HUB能提供多端口服务。

     

    交换机(SWITCH)类似于HUB,能连接两个局域网段。它工作在数据链路层,能起到过滤帧的作用。SWITCH检测帧的源地址及目的地址。如果在同一网络段则不转发。如果不在同一网段,就把帧转发到另一网段。

     

    公司的几台或者几百台电脑组成一个局域网,可以用几个HUB连接起来。从价格角度上说。HUB具有价格便宜,即插即用的优点。但这种组建局域网的方法只是最简单的拓扑结构。这种对等网只能完成简单的数据共享。这对于一个需要进行高级的网络管理的公司来说远远不够。

     

    任何公司都在发展,公司局域网的应用将会更加丰富。局域网中的PC越来越多,分工更加明确,使得网络的拓扑结构日渐复杂。网络合理的构架,要充分考虑兼容性,可扩展性。另外还要考虑主干网与骨干网之间的带宽平衡以及不同的网络介质在不同的传输距离上的稳定性,使得主干网与骨干网的连接即能满足带宽的需要又能满足不同的传输距离。这样一个系统集成复杂,规划合理的网络,HUB已不能胜任。因此,SWITCH必将成为首选。

     

    比较说明HUB与SWITCH的区别

     

    1 在数据的传输过程中。因为阻塞,延时等原因。将会出现短帧,碎片等。从ISO物理体系上看出,HUB属于物理层的设备。物理层提供基本的机制,该机制对二进制数据(位)进行编码(发送到物理介质)和解码(从物理介质接收),物理层也定义与介质的物理连接机制,但不是介质本身。所以HUB只对数据进行单一的同步,放大,整形作用,而对数据过程中的短帧,碎片无法进行处理。

     

    SWITCH工作在数据链路层。该层提供了一个由信息位组成的帧(Frame),帧由一个包含起始标志的报头或报头位,寻址信息和(对于LAN)一个32位的循环冗余码(CRC)组成。CRC的作用是在信息位穿过物理介质时保证帧的完整性。数据链路层还提供链路的管理。对于以太网,在通道空闲时传送帧,在检测到冲突时停止。在令牌环网中。当接收到一个自由的令牌时进行帧的传送。所以交换机不但可以对数据进行同步,放大,整形,还能有效的过滤短帧、碎片。

     

    2 公司局域网上工作站的增多,数据通讯会更加繁忙。HUB工作时,不管有多少个端口在进行通讯,所有的端口都共用一个带宽。它采用的是分时处理的方式。

     

    对SWITCH而言,每个端口独占一个带宽,两个任意端口之间可以随时沟通,绝对不会影响其他端口的工作。这样使SWITCH工作时传输数据比HUB更流畅。当然,所有主流 的SWITCH 都支持10M/100M自适应,不但可以工作在半双工,也可以工作在全双工模式。

     

    3 HUB的一个端口发送数据时,不会主动的发给目的端口,而是向每一个端口都发出信息。试想一下,某个工作站向另一工作站传输数据。这个信息帧会通过HUB传遍整个网络。白白浪费带宽资源。使用SWITCH连接网段,如果源端口与目的端口在同一网段,信息将不会通过SWITCH进入另一网段。

     

    同样,还是上面那种情况,HUB是广播方式工作。如果一个端口接到信息,因为不是目的端口,所以将信息又向网络中的所有端口发出。这样重复下去,将会产生“广播风暴”。而全向SWITCH就能很好的杜绝这种情况的发生。因为SWITCH工作时,只有源端口和目的端口之间响应,不会影响其他的端口,因此SWITCH有效地抑制广播风暴。

     

    总的说来,HUB只有比SWITCH价格便宜的优势。但在性价比高的SWITCH面前,这一优势也不复存在。不同的SWITCH还具有不同的功能。比如能接光纤,具有VLAN功能,智能管理功能,路由功能等。所以,使用SWITCH是大势所趋

     

     

    1.什么是交换机 
      交换机也叫交换式集线器,它通过对信息进行重新生成,并经过内部处理后转发至指定端口,具备自动寻址能力和交换作用,由于交换机根据所传递信息包的目的地址,将每一信息包独立地从源端口送至目的端口,避免了和其他端口发生碰撞。广义的交换机就是一种在通信系统中完成信息交换功能的设备。 
    2.交换机的工作原理 
      在计算机网络系统中,交换机是针对共享工作模式的弱点而推出的。集线器是采用共享工作模式的代表,如果把集线器比作一个邮递员,那么这个邮递员是个不认识字的“傻瓜”--要他去送信,他不知道直接根据信件上的地址将信件送给收信人,只会拿着信分发给所有的人,然后让接收的人根据地址信息来判断是不是自己的!而交换机则是一个“聪明”的邮递员--交换机拥有一条高带宽的背部总线和内部交换矩阵。交换机的所有的端口都挂接在这条背部总线上,当控制电路收到数据包以后,处理端口会查找内存中的地址对照表以确定目的MAC(网卡的硬件地址)的NIC(网卡)挂接在哪个端口上,通过内部交换矩阵迅速将数据包传送到目的端口。目的MAC若不存在,交换机才广播到所有的端口,接收端口回应后交换机会“学习”新的地址,并把它添加入内部地址表中。 
      可见,交换机在收到某个网卡发过来的“信件”时,会根据上面的地址信息,以及自己掌握的“常住居民户口簿”快速将信件送到收信人的手中。万一收信人的地址不在“户口簿”上,交换机才会像集线器一样将信分发给所有的人,然后从中找到收信人。而找到收信人之后,交换机会立刻将这个人的信息登记到“户口簿”上,这样以后再为该客户服务时,就可以迅速将信件送达了。 
    3.交换机的性能特点 
    1)独享带宽 
      由于交换机能够智能化地根据地址信息将数据快速送到目的地,因此它不会像集线器那样在传输数据时“打扰”那些非收信人。这样一来,交换机在同一时刻可进行多个端口组之间的数据传输。并且每个端口都可视为是独立的网段,相互通信的双方独自享有全部的带宽,无须同其他设备竞争使用。比如说,当A主机向D主机发送数据时,B主机可同时向C主机发送数据,而且这两个传输都享有网络的全部带宽--假设此时它们使用的是10Mb的交换机,那么该交换机此时的总流通量就等于2×10Mb=20Mb。 
    2)全双工 
      当交换机上的两个端口在通信时,由于它们之间的通道是相对独立的,因此它们可以实现全双工通信。

    1.路由器的作用 
      通过集线器或交换机,我们可以将很多台电脑组成一个比较大的局域网(图3),但是当机器的数量达到一定数目时,问题也就来了:对于用集线器构成的局域网而言,由于采用“广播”工作模式,当网络规模较大时,信息在传输过程中出现碰撞、堵塞的情况越来越严重,即使是交换机,这种情况也同样存在。其次,这种局域网不安全,也不利于管理。 
      为了解决这些问题,人们便将一个较大的网络划分为一个个小的子网、网段,或者直接将它们划分为多个VLAN(即虚拟局域网),在一个VLAN内,一台主机发出的信息只能发送到具有相同VLAN号的其他主机,其他VLAN的成员收不到这些信息或广播帧。采用VLAN划分网络后,可有效地抑制网络上的广播风暴,增加网络的安全性,使管理控制集中(图4)。 
      既然是局域网,万一分别处于不同VLAN的主机需要互相通信时该怎么办呢?这时候就得通过路由器(Router,转发者)来帮忙了。路由器可以将处于不同子网、网段、VLAN的电脑连接起来,让它们自由通信。另外,我们都知道目前的网络有很多种结构类型,且不同网络所使用的协议、速度也不尽相同。当两个不同结构的网络需要互连时,也可以通过路由器来实现。路由器可以使两个相似或不同体系结构的局域网段连接到一起,以构成一个更大的局域网或一个广域网。 
      可见,路由器是一种连接多个网络或网段的网络设备,它能将不同网络、网段或VLAN之间的数据信息进行“翻译”,以使它们能够相互“读”懂对方的数据,从而构成一个更大的网络。 
    2.路由器的工作原理 
      所谓路由就是指通过相互连接的网络把信息从源地点移动到目标地点的活动。那么路由器具体是如何进行“翻译”工作的呢?我们平时在学习、翻译英语时,肯定会准备一本英汉字典,通过它来实现英文与中文之间的互现转换。而对于路由器而言,它也有这种用于翻译的字典--路径表。路径表(Routing Table)保存着各种传输路径的相关数据,如子网的标志信息、网上路由器的个数和下一个路由器的名字等内容。路径表可以是由系统管理员固定设置好的,也可以由系统动态修改,可以由路由器自动调整,也可以由主机控制。 
      通过路由器可以让不同子网、网段进行互连,因此路由器与集线器、交换机不同,它一般安装在网络的“骨干”部位,而不像集线器、交换机那样工作在基层。比如说一个较大规模的企业局域网,基于管理、安全、性能的考虑,一般都会将整个网络划分为多个VLAN,如此一来,当VLAN与VLAN之间进行通讯时,就必须使用路由器。 
      对于该企业网而言,肯定还需要与互联网相连,对于企业而言,一般都是通过租用电信的DDN专线或者利用ADSL、Cable、ISDN等方式将企业网接入互联网,而此时由于网络体系及所用协议的不同,也需要路由器来完成企业网与互联网的互连工作。 
      一般来说,在路由过程中,信息至少会经过一个或多个中间节点。通常,人们会把路由和交换进行对比,这主要是因为在普通用户看来两者所实现的功能是完全一样的。其实,路由和交换之间的主要区别就是交换发生在OSI参考模型的第二层(数据链路层),而路由发生在第三层,即网络层。这一区别决定了路由和交换在移动信息的过程中需要使用不同的控制信息,所以两者实现各自功能的方式是不同的。路由器通过路由决定数据的转发。转发策略称为路由选择,这也是路由器名称的由来。

    三剑客的外观比较 
      前面我们已经讲解了集线器、交换机、路由器的工作原理,但是对于很多初学者来说,有时也希望能够从外观上去区分它们。当然,集线器、交换机、路由器在外观上肯定有所区别,但这些往往只能作为参考信息,毕竟现在很多集线器、交换机与路由器产品在外观上看非常相似。而这里面最难区分的就是普通桌面型的集线器与交换机,而路由器相对比较容易识别。

    展开全文
  • 交换机(又名交换式集线器)作用与集线器大体相同。但是两者在性能上有区别:集线器采用的式共享带宽的工作方式,而交换机是独享带宽。这样在机器很多或数据量很大时,两者将会有比较明显的。而路由器与以上两者有...
  • 实验一:交换机的基本配置
  • 中继器 集线器 网桥 交换机 路由器 网关
  • 原理:某些交换机路由器等设备会开启161端口的SNMP服务,有些设备采用默认的只读社区字符串:public与读写社区字符串:private或是其他较弱的社区字符串,这就使得我们可以以此来查看设备的实时信息甚至下载它的...
  • 这里交换机 路由器 暂时统称为 网络设备 我们一般管理网络设备采用的几种方法   一般来说,可以用5种方式来设置路由器: 1. Console口接终端或运行终端仿真软件的微机(第一次配置要使用此方式)...
  • linux中使用minicom模拟windows上的超级终端配置交换机。安装minicom使用yum自动安装minicom,首先配置本地yum源或者网络yum源(略),命令yum -y install minicom。2.配置minicom安装好minicom后需要配置参数使适配...
  • 中继器 集线器 网桥 交换机 路由器 网关 分类: 数据存储 2009-12-05 16:14 333人阅读 评论(0) 收藏 举报 Source: http://blog.donews.com/littlechen/archive/2005/10/10/582975.aspx 不同...
  • 之前成哥写了一篇交换机的转发原理,有读者私信成哥,交换机路由器有什么区别,总是傻傻分不清楚。这里成哥就带着大家从概念、外观、部署位置、主要功能等方面剖析下这个问题。01 交换机路由器的概念交换机:是...
  • 路由器R1的Fa0/0接口首先进行ARP欺骗,欺骗交换机S1要找的地址就是自己,然后通过地址解析协议把A的mac解析成IP,最后通过路由器的路由表转发到另一个接口Fa0/1 路由器R1的另一个接口Fa0/1继续发送ARP给交换机...
  • 现如今很多家庭都基本上有两台电脑,因此为了都能上网,路由器交换机慢慢的走入了人们的视线,这两个机器看起来长得很像,不好区别,因此很多人并不知道交换机路由器的区别,又各自有什么特点,下面就来简单介绍...
  • 交换机 VS 路由器

    2019-06-18 20:11:43
    交换机和路由去的区别 交换机只是用来分配网络数据的; 路由器可以给局域网自动分配ip,虚拟拨号; 路由器在网络层,根据ip地址...路由器可以把一个ip分配给你多个主机使用,交换机可以把各有ip的主机连接起来。 ...
  • 转自:http://blog.csdn.net/lsk_30516/archive/2007/03/29/1545748.aspx最近看到很多人在询问交换机、集线器、路由器是什么,功能如何,有何...而 交换机 (又名交换式集线器)作用与集线器大体相同。但是两者在性能上
  • 号称网络硬件三剑客的集线器(Hub)、交换机(Switch)与路由器 (Router)一直都是网络界的活跃分子,但让很多初入网络门的菜鸟恼火的是,它们三者不仅外观相似,而且经常呆在一起,要想分清谁是谁,感觉...
  •  第三层交换机路由器的区别在第三层交换技术出现之前,几乎没有必要将路由功能器件和路由器区别开来,他们完全是相同的:提供路由功能正在路由器的工作,然而,现在第三层交换机完全能够执行传统...
  • 交换机(又名交换式集线器)作用与集线器大体相同。但是两者在性能上有区别:集线器采用的式共享带宽的工作方式,而交换机是独享带宽。 <br /> 这样在机器很多或数据量很大时,两者将会有比较明显的。而...
  • 交换机路由器的配置

    万次阅读 多人点赞 2019-05-30 11:02:14
    交换机路由器的配置 一、交换机的基本配置 配置enable口令、密码和主机名 Switch> (用户执行模式提示符) Switch>enable (进入特权模式) Switch# ...
  • eNSP基础实验交换机连接路由器(二层交换机和三层交换机)一、实验题目二、实验拓扑图三、实验内容(一)二层交换配置(二)三层交换机配置五、实验总结 一、实验题目 一台交换机,一台路由器,两台电脑。使得两台...
  • 交换机路由器

    2019-10-01 09:37:39
    交换机(又名交换式集线器)作用与集线器大体相同。但是两者在性能上有区别:集线器采用的式共享带宽的工作方式,而交换机是独享带宽。这样在机器很多或数据量很大时,两者将会有比较明显的。而路由器与以上两者有...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 38,238
精华内容 15,295
关键字:

交换机路由器的相同之处