精华内容
下载资源
问答
  • 交换机转发数据包的过程
    千次阅读
    2021-03-15 20:02:28

    1.

    当路由器接收到一个数据包时,工作过程如下
    首先提取数据包头的目的MAC信息,与自身MAC表比较:
    如果找到对应项,则按MAC表进行转发(与交换机一样);
    如果没找到则提取数据包头的目的IP信息,则与自身的路由表进行比较
    找到了对应的路由表,则按着路由表转发(与查到MAC表很像啊)。
    没找到对应路由表,则按着缺省路由转发,没有广播。
    路由器转发数据包是根据路由器内部的路由表进行转发,当数据包到达路由器时,查询路由表,获取下一站的地址,然后进行转发,与之对应的每个公交站点都有一个站牌,告诉你下一站是哪里。

    destination/mask:用于描述目标网段,当前往目标网段有多个路径时,选择掩码最长的一条路径转发。
    Protocol:表示路由运行的协议,路由表根据路由协议生成,包含三类路由
    直连路由:有链路层协议发现,开销小,表示与该路由器直连的路由,只能发现本接口所属网段的路由
    静态路由:由人工手动配置,
    动态路由:根据各种路由协议算法发现,无需人工维护,但是开销较大,这也是生成路由表的主要方式
    Preference:表示优先级,数值越小,优先级越高
    Metric(Cost):开销,到达目标网络的代价,值越小,越优先
    Interface:本端接口,表示数据包从本端那个接口转发出去
    Nexthop:下一跳地址,互联网对端路由器的端口
    当数据包到达路由器时,会进行下面几个操作

    读取目标地址的网络部分
    找到路由表中对应的地址的路由条目,将包转发到相应的路由器接口
    如果没有找到对应的路由条目,则将包转发到路由器对应的默认路由的接口,如果没有配置默认路由,将包丢弃,返回目标不可达信息
    到达下一个路由器时,在重复上述过程,直到到达目标地址对应的网段。
    整个包传输过程,目标地址,源地址和端口号不会改变,但是MAC地址会发生变化,每经过一个路由器转发,MAC地址会被重新封装一次,封装为下一跳的MAC地址。

    一般来说,静态路由的优先级最高,如果配置了静态路由,会优先使用静态路由转发。

    由于路由转发的数据量非常大,所以不可避免的会出现路由环回(数据包在一个闭环的环路中不停的转发,始终到不了目标地址)的情况,避免这种情况的方法就是在数据包中封装一个TTL字段,该字段的意义就是最大转发跳数,一旦超过这个限制,便会将该数据包丢弃。

    2.

    当交换机收到一个数据包时;工作过程如下
    交换机会将这个数据包包头的目的MAC信息提取出来,与自身的MAC地址表比较;
    如果找到对应项,则按MAC表进行转发;
    如果没找到对应项,则在除了接收到数据包以外的所有端口进行转发

    3.

    当以太网帧到达交换机后,交换机会自动并学习该数据帧的源mac地址,与进入的接口形成绑定关系,当该表项被转发时,会刷新老化时间
    当一台终端设备访问同一网段中其他ip地址时,将正常进行ip封装、封装过程中若没有该ip对应的mac地址时,将二层广播来获取对端的mac地址,过程中交换机将记录两个mac对应的接口目标终端也会记录请求的ip与mac地址对应关系

    **当一个数据帧进入交换机后,交换机先查看数据帧中的源mac地址没然后将该地址与进入的接口进行映射记录;再查看目标mac地址,查看本地mac表,若表中存在记录,将进行单播;若没有记录,将洪泛

    当终端访问的设备为其他网段,将在数据封装的过程中,目标mac为本广播域的网关地址(需提前知道,可通过arp获取)

    流量进入路由器后,路由器将先识别数据的二层报头,关注目标mac地址;之后判断是否解封装(目标mac为广播域或路由器接口);再基于数据包中的ip地址,查看本地路由表,若没有记录将丢弃;若存在将无条件按照记录转发;转发过程中需要重新封装二层,新二层源maac为路由器出接口mac地址,目标mac为下一跳或目标设备;获取mac的方式仍然是arp**

    更多相关内容
  • 交换机转发数据包过程[定义].pdf
  • 当R1接收到数据报文后,会进行接封装,解封至网络层,查看目的IP所在网段是否在自己路由表内,如果在就可以到达,转发到对应接口,重新进行二层封装,源MAC变为R1F1/0接口的MAC目的MAC变为R2的F1/0接口MAC。...

    路由器转发数据包的封装过程;此过程通过实例的方式,完成展示

    建立拓扑,配置相应的IP地址和子网掩码

    主机配置(PC1和2基本一致,除了配置的ip和网关不同)

    PC1#conf t
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    PC1(config)#int f0/0
    
    PC1(config-if)#ip address 192.168.10.1 255.255.255.0
    
    PC1(config-if)#no shutdown  //开启接口
    
    PC1(config-if)#exit
    
    PC1(config)#no ip routing       //路由器的ip routing是默认启用的,关闭ip routing是为了把路由器当做一台主机来用、所以此时要配上ip default-gateway ,就像在自己的pc上设置默认网关一样。
    
    PC1(config)#ip default-gateway 192.168.10.254   //配置默认网关
    
    PC1(config)#

    路由配置(R1和R2配置基本一致,除了各个接口IP不同和静态路由不同)

    R2#conf t
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    R2(config)#int f1/0
    
    R2(config-if)#ip address 192.168.50.2 255.255.255.0
    
    R2(config-if)#no shutdown
    
    R2(config-if)#ip route 192.168.10.0 255.255.255.0 f1/0   //在全局模式下配置静态路由,192.168.10.0是网段,不是IP地址, F1/0是转发接口,或者将f1/0换成下一个路由器的IP地址
    
    使用show interface f0/0查接口f0/0的接口信息

    以下为Wireshark三个抓包过程

    PC1-—》R1

    PC1发送访问PC2

    第一个报文:源IP:10.1 目的IP:100.1;源MAC:pc1 目的MAC:R1 F0/0接口MAC。

    R1->R2

    当R1接收到数据报文后,会进行接封装,解封至网络层,查看目的IP所在网段是否在自己路由表内,如果在就可以到达,转发到对应接口,重新进行二层封装,源MAC变为:R1 F1/0接口的MAC 目的MAC变为R2的F1/0接口MAC

    R2->PC2

    当R2接收到数据报文后,会进行接封装,解封至网络层,查看目的IP所在网段是否在自己路由表内,此时PC2和R2直连属于,同网段,肯定可到,数据交给对应接口,重新进行二层封装。源MAC变为:R2的F0/0接口MAC 目的MAC变为PC2的f0/0接口MAC

    总结:

    路由器在转发数据包的封装过程中

    源IP和目的IP是一直不变的

    源MAC和目的MAC一直变化的

    因为路由器会重新进行二层封装

    同网段传输是二层转发,二层转发不需要进行重新封装

    跨网段传输是三层转发,需要重新进行二层封装

    展开全文
  • 交换机的包转发操作

    2021-05-24 14:46:15
    交换机根据地址表进行转发 交换机:将网络包原样转发到目的地

    交换机根据地址表进行转发

    • 交换机:将网络包原样转发到目的地
    • 端口:网线接口和后面的电路部分
      交换机的一个端口就相当于计算机上的一块网卡
      但交换机的工作方式和网卡有一点不同。网卡本身具有MAC地址,并通过核对收到的包的接收方MAC地址判断是不是发给自己的,如果不是发给自己的则丢弃;相对地,交换机的端口不核对接收方MAC地址,而是直接接收所有的包并存放到缓冲区中
      将包存入缓冲区后,接下来需要查询一下这个包的接收方MAC地址是否已经在MAC地址表中有记录了
      在这里插入图片描述
      在这里插入图片描述
    当网络包到达发送端口时的操作
    • 端口中的MAC模块和PHY (MAU)模块会执行发送操作
    • 首先应该确认没有其他设备在发送信号,也就是确认信号收发模块中的接收线路没有信号进来。如果检测到其他设备在发送信号,则需要等待信号发送完毕;如果没有其他信号,或者其他信号已经发送完毕,这时就可以将包的数字信息转换为电信号发送出去
    • 在发送信号的过程中,还需要对接收信号进行监控,如果在发送过程中检测到其他设备发送信号,就意味着出现了信号碰撞,这时需要发送阻塞信号以停止网络中所有的发送操作,等待一段时间后再尝试重新发送,这一步和网卡也是一样的

    MAC地址表的维护

    • 第一种:将发送方MAC地址以及其输入端口的号码写入MAC地址表中
    • 第二种:为了防止终端设备移动产生问题,只需要将一段时间不使用的过时记录从地址表中删除就可以了
      过时记录从地址表中删除的时间一般为几分钟,因此在过时记录被删除之前,依然可能有发给该设备的包到达交换机。这时,交换机会将包转发到老的端口,通信就会发生错误。遇到这样的情况,只要重启一下交换机,地址表就会被清空并更新正确的信息,然后网络就又可以正常工作了。

    特殊操作

    在这里插入图片描述

    全双工模式可以同时进行发送和接收

    • 全双工模式是交换机特有的工作模式,可以同时进行发送和接收操作
    • 全双工模式比半双工模式速度要快。传送的数据量也更大,性能也就越高
    原因:
    • 使用集线器,如果多台计算机同时发送信号,信号就会在集线器内部混杂在一起,进而无法使用,这种现象称为碰撞,是以太网的一个重要特征。
    • 使用双绞线,发送和接收的信号线是各自独立的[插图],因此在双绞线中信号不会发生碰撞,发送和接收可以同时进行。
    • 修改以太网规则(全双工模式):以太网规范中规定了在网络中有信号时要等该信号结束后再发送信号,因此发送和接收还是无法同时进行。于是,人们对以太网规范进行了修订,增加了一个无论网络中有没有信号都可以发送信号的工作模式,同时规定在这一工作模式下停用碰撞检测

    自动协商:确定最优的传输速率

    • 自动切换工作模式:这一功能可以由相互连接的双方探测对方是否支持全双工模式,并自动切换成相应的工作模式。此外,除了能自动切换工作模式之外,还能探测对方的传输速率并进行自动切换。这种自动切换的功能称为自动协商

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    交换机可同时执行多个转发操作

    • 交换机只将包转发到具有特定MAC地址的设备连接的端口,其他端口都是空闲的
    • 当包从最上面的端口发送到最下面的端口时,其他端口都处于空闲状态,这些端口可以传输其他的包,因此交换机可以同时转发多个包
    • 相对地,集线器会将输入的信号广播到所有的端口,如果同时输入多个信号就会发生碰撞,无法同时传输多路信号,因此从设备整体的转发能力来看,交换机要高于集线器。
    展开全文
  • 2、回顾路由器相关知识 3、网络层IP数据包的格式 4、路由器的工作原理 4.1、路由 4.2、路由器的原理工作 4.3、静态路由 4.4、动态路由 三、路由器转发数据包的封装过程 一、通过远程管理方式连接交换机 1、teInet是...

    一、通过远程管理方式连接交换机

    1、teInet是应用层协议基于传输层TCP,默认端口号:23

    采用的是明文密码方式,不是很安全,—般用于内网管理,

    2、ssh是应用层协议基于传输层TCP默认端口号:22

    采用的是密文密码方式,相对来讲比较安全,经常用于跨越互联网管
    理,也常用于远程管理Linux操作系统

    没有绝对安全,绝对安全是扯断,所以说总是有漏洞。

    3、思路

    3.1、telnet

    • 既然是通过网络的方式进行管理设备,设备就必须配置IP地址,由于交换机上的接口都是交换接口,是不允许配置IP地址,直接为交换机的虚接口配置IP地址,默认情况下交换机的默认虚接口就是vlan1接口

    int vlan 1 //进入vlan 1
    ip adress 192.168.100.100 255.255.255.0 //配置,主机要是同一个网络的IP
    no shutdown //开启接口
    在这里插入图片描述

    • 配置设备的连接终端并直接设置密码,应用

    conf t
    line vty 0 4 //进入vty接口,默认从0开始
    password zixin //配置密码
    login //应用
    在这里插入图片描述

    • 创建连接用户名密码,配置设备的连接终端并应用

    法1:

    1、给主机设置一个IP
    在这里插入图片描述
    2、连接主机的IP,在这个样例中连接的是交换机的虚地址192.168.100.100
    在PC中设置。在设置前,先看第四点设置特权模式密码
    在这里插入图片描述
    在这里插入图片描述
    先输入远程连接的密码zixin进入switch,再输入特权模式的密码456
    在这里插入图片描述

    法2:

    1、创建连接用户密码
    conf t
    username zhangsan password zixin
    line vty 0 4
    login local //表示使用用户名密码登录
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    3.2、ssh

    • 开始同talnet。既然是通过网络的方式进行管理设备,设备就必须配置IP地址,由于交换机上的接口都是交换接口,是不允许配置IP地址,直接为交换机的虚接口配置IP地址,默认情况下交换机的默认虚接口就是vlan1接口

    int vlan 1 //进入vlan 1
    ip address 192.168.100.100 255.255.255.0 //配置,主机要是同一个网络的IP
    no shutdown //开启接口
    在这里插入图片描述

    • 查看是否支持ssh

    show ip ssh
    在这里插入图片描述

    • 交换机不能用默认的名字,先改名

    hostname 名字在这里插入图片描述

    • 设置域名

    ip domain-name zixin.com

    • 创建密钥对

    sw1(config)#crypto key generate rsa

    • 配置超时时间

    sw1(config)#ip ssh time-out 100

    • 配置认证失败次数

    sw1(config)#ip ssh authentication-retries 5

    在这里插入图片描述

    • 应用

    在这里插入图片描述
    1、创建用户名
    2、进入接口
    3、应用
    4、设置特权密码
    在这里插入图片描述

    • 连接

    1、配置PC的IP地址
    (就是这里没配置,结果出错了)在这里插入图片描述
    2、连接在这里插入图片描述
    在这里插入图片描述

    4、设置特权模式密码

    1.设置明文密码
    enable password 123

    2.设置密文密码。因为密文密码比明文密码安全级别高,所以密文密码会生效
    enable secret 456
    3、查看当前配置文件命令
    show running-config
    ps:设置要在全局模式下设置,查看要在特权模式下查看
    在这里插入图片描述

    二、路由器工作原理

    1、回顾交换机的工作原理

    • 交换机里面维护了—张MAC地址表,主要记录的是MAC地址和接口的对应关系
    • 交换机在初始状态下,MAC地址表是空的,当收到一个来自某接口(F0/1)的数据时,首先查看数据帧中的源MAC地址,对照自己的MAC地址表,如果不在表中,将发送方的MAC地址学习并记录到自己的MAC地址表中,并附上对应的接口(F0/1),再查看目的MAC地址,如果目的MAC地址也不在MAC地址表中,将进行从接收接口(F0/1)外的其他所有连接接口转发出去(广播方式),此时,目的主机将接收到,其他主机也会接收到,其他主机接收到后直接丢弃,
      目的主机接收到后进行回应,回应的过程中数据同样会交由给交换机进行转发,目的主机这时候就变成回应的发送主机,当交换接收到来自目的主机的回应报文时(F0/10),同样查看发送方的MAC地址,进行学习并记录,并附带对应接口(F0/10),再去查看目的MAC,由于之前已经有记录,所以直接从记录的接口(F0/1)进行转发(单播)
    • 总结:交换学习源MAC,广播数据帧,接收方回应,回应使用单播直接转发

    2、回顾路由器相关知识

    • 路由器是属于三层(网络层)设备
    • IP头部封装在网络层
    • 网络层功能
      (1)进行逻辑地址(IP地址)寻址,实现不同网络(网络地址不等或者说内网和外网分割,强调:内网的IP地址是无法在外网上进行路由)直接的路径选择
      (2)去查找目的是否可以到达,如果可以到达,选择一条最优的路径,如果不能到达,直接返回给发送方一个消息
    • 网络层所传输的PDU(传输数据单元)是数据包(IP数据包)

    3、网络层IP数据包的格式

    因为ipv6尚未大规模应用,这里仅涉及ipv4

    在这里插入图片描述

    • 版本:标识当前使用的P版本(IPv4,lPv6)
    • 首部长度:由于IP数据报文的首部有一个可选项,造成首部长度是可变,所以需要定义
    • 区分服务(服务质量/优先级和服务类型)︰为了保障更好的服务,主要是在P层做Qos.总长度:主要用来标识整个数据包的长度
    • 标识、标志、片位移∶上层来的数据到IP层会被分片,这几个字段用来对数据包进行标识,使数据到达目的端重组的时候不会乱序
    • 生存时间(TTL值)︰数据包在路由器转发消耗时间的如果小于1秒,TTL就会减1
    • 协议:标识上层数据是使用的何种协议(TCP是6或UDP是17)
    • 首部校验:校验数据报文的首部
    • 源地址:发送方的IP地址
    • 目的地址:接收方的IP地址

    4、路由器的工作原理

    4.1、路由

    • 从源主机到目标主机的转发过程(跨网络访问)
    • 包含两个内容:
      (1)确定最佳路径(手动指定方式,或者根据动态路由协商方式)
      (2)通过网络传输信息

    4.2、路由器的原理工作

    在这里插入图片描述

    • 路由表
      (1)直连路由:当路由器的接口配置好对应的lP地址并开启接口后自动生成。
      (2)非直连路由:需要手动配置静态路由或者使用动态路由协议学习到

    4.3、静态路由

    • 由管理员手动配置,不灵活,而且是单向
    • 特殊的静态路由:默认路由,当在路由器的中找不到目标网络的路由条目时再去查看默认路由
      使用场景:一般应用于末节(末梢)网络(网络的最末端)(路由器的一端只连接了一个网络)

    4.4、动态路由

    • 通过某种动态路由协议自动的去建立自己路由表
    • 常见的动态路由协议:RIP OSPF IS-IS BGP IGRP EIGRP
      RIP和OSPF最常用。

    三、路由器转发数据包的封装过程

    在这里插入图片描述

    因为在解封装时要去掉mac帧,再次封装时又添加mac帧,所以跨网段传输的源mac和目的mac一直在发生变化。

    展开全文
  • 以太网交换机转发原理简介

    千次阅读 2022-04-03 14:59:54
    对二层以太网交换机的总结,包括帧结构,帧分类,XCAP的使用,二层转发原理的简单介绍
  • 交换机转发过程: 当以太网帧到达交换机后,交换机会自动并学习该数据帧的源mac地址,与进入的接口形成绑定关系,当该表项被转发时,会刷新老化时间 当一台终端设备访问同一网段中其他ip地址时,将正常进行ip封装、...
  • 交换机收到一个数据包时;交换机会将这个数据包包头的目的MAC信息提取出来,与自身的MAC地址表比较;情况一:如果找到对应项,则按MAC表进行转发;情况二:如果没找到对应项,则在除了接收到数据包以外的所有端口...
  • 三层交换机转发原理

    千次阅读 2021-12-31 18:30:49
    三层交换机:高速三层转发设备,大多数三层交换机采用ASIC硬件芯片来完成转发的功能。 2、作用: 1.同一网段 源主机直接向目的主机发ARP请求,收到对方的回应后获得对方MAC地址,将数据报进行封装发送出去。 2.不同...
  • 路由器的转发过程: PC1在本网段广播一个数据帧(目标MAC地址为:全F)本网段直连路由器可以直接接受帧 由于PC2和PC1不在同一网段,路由器不转发广播帧。需要路由器来完成一...交换机转发过程:当交换机收到一个数
  • 交换机转发数据帧的3种方式

    千次阅读 2022-05-21 13:04:44
    直通转发(Cut-Through )交换机接收到目的地址即开始转发过程交换机不检测错误,直接转发数据帧。 优点:由于不需要存储,延迟非常小、交换非常快 缺点:因为数据包内容并没有被以太网交换机保存下来,所以无法检查...
  • 1、交换机根据地址表进行转发: 在研究交换机是如何将网络包转发到目的地之前,先来看一下交换机的内部结构: 大家可以认为交换机的每个网线接口后面都是一块网卡,网线接口和后面的电路部分加在一起称为一个...
  • 交换机转发过程及帧mac地址的变化

    千次阅读 2020-11-16 20:29:55
    二层交换机: 没有mac地址 交换时,不改变帧的源地址和目的地址 直接根据查找表的目的地址及端口将帧发送即可 ...在帧不断转发过程中,ip源目的地址不变,mac源目的地址根据所经过的路由器端口变化。 ...
  • 一、交换机转发原理交换机依靠ARP表单生成mac地址表,依靠mac地址转发数据,交换机处理数据时,有三个处理行为:泛洪:接收到的是广播帧,交换机会广播泛洪(arp request广播帧); 目的mac广播 转发:如果接收的是一个已知的...
  • 网络数据包转发过程详解

    千次阅读 2021-07-15 15:38:05
    本片文章详解了两台终端跨网段通信时数据包转发的过程,包含第一次转发数据包ARP工作的过程以及详细配置,下面是本次实验的拓扑图,在华为ENSP模拟器上实现。 简单介绍一下实验环境,在本次实验中包含两个区域...
  • 路由器转发数据包是根据路由器内部的路由表进行转发,当数据包到达路由器时,查询路由表,获取下一站的地址,然后进行转发,与之对应的每个公交站点都有一个站牌,告诉你下一站是哪里。 以华为路由器为例,说一下...
  • 工业交换机主要是应用于复杂的工业环境中的实时以太网数据传输,这就要求我们在选购工业交换机时必须对产品的性能有所了解,要求我们所选购的工业交换机产品能够符合当下的工业环境要求。那么,新手在选购工业交换机...
  • 交换机是一种工作在数据链路层对流量进行转发的网络设备。主要应用于延长传输距离,解决冲突域,实现单播等功能。 ** 工作过程: **当流量进入交换机后,根据数据帧中的源MAC,建立该地址与交换机端口的映射,并写入...
  • 二层交换机转发数据原理解析

    千次阅读 2019-10-18 18:55:27
    二层交换机转发数据原理解析 一、什么是二层交换机 二层交换机工作于OSI模型的第2层(数据链路层),故而称为二层交换机。二层交换技术的发展已经比较成熟,二层交换机属于数据链路层设备,可以识别数据帧中的MAC地址...
  • 交换机与二层转发原理

    千次阅读 2022-04-17 23:04:05
    本文详细介绍了以太网交换机的二层转发原理,以太网帧在网络中的运动轨迹
  • 交换机收到一个数据包时; 交换机会将这个数据包包头的目的MAC信息提取出来,与自身的MAC地址表比较; 情况一:如果找到对应项,则按MAC表进行转发; 情况二:如果没找到对应项,则在除了接收到数据包以外的所有...
  • 三层交换机

    2022-06-16 15:19:18
    在这个流中的多个数据包,其中只有一个数据包是由三层交换机的三层引擎来处理的,处理的方式是软件方式,与路由器相同,三层引擎获取了新的2层封装信息后,路由这个数据包。在第一个数据包转发完成后,在硬件中创建...
  • Wireshark TS | 交换机同 VLAN 转发异常
  • 交换机依靠什么进行数据转发

    千次阅读 2022-03-09 17:50:55
    网工小白必会知识点,​​交换机依靠什么进行数据转发
  • 摘要:SDN将传统网络的控制平面和数据平面解耦,通过控制平面的控制器灵活地对网络进行管理,目前应用最广泛的控制协议是OpenFlow。...研究机构从不同角度提出了针对SDN中交换机转发规则的TCAM存储优
  • 网络数据包如何在网络上游荡,长久以来也困扰了我很长时间,现在把这部分内容总结分享一下。  说起网络,大家不约而同会想起大学课本上那个臭名昭著的ISO七层模型,但是ISO模型只是提供了一个参考,并不是具体实现...
  • 网络数据包转发过程

    万次阅读 多人点赞 2014-09-30 11:33:40
    这篇文章讲述了上网时数据包转发的全过程,下面是电脑和网络设备连接简略图:   以PC1 ping PC3为例讲述数据包转发过程: 1、当PC1 ping PC3时,发现它们的IP不在同一网段,PC1就将数据包发送至网关(1.1.1.1/24)...
  • 数据包转发流程

    2020-12-21 11:59:37
    过程如下1.pc1将要与pc2通信,首先根据网卡的ip地址与掩码算出pc2是否与pc1是同网段,如果是同网段直接二层转发,如果不是将跨网段转发2.pc1算出pc2和自己不是同网段,所以要将数据包发送到网关由网关进行三层寻址...
  • 近期被一道有点奇怪的题目考住了,考点其实就是最基础的交换机转发原理。在此复习、整理一下。 在此,我们不讲这个题目提出的其他条件,单独讲述PC1能够ping通PC2的这一过程交换机SW1 eth0属于vlan10,交换机...
  • 交换机基于数据帧的MAC地址转发数据帧,路由器基于数据包的IP地址转发数据包 数据包在传输过程不变,过网络设备数据帧要用新的物理层地址重新封装 MAC地址决定了数据帧下一跳哪个设备接收,而IP地址决定了数据包的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 28,238
精华内容 11,295
热门标签
关键字:

交换机转发数据包的过程