精华内容
下载资源
问答
  • 交换机软件组成
    千次阅读
    2021-07-29 08:22:16

    测试平台:

    客户端:IBM T61普屏

    处理器:Intel 酷睿2双核 T7500 内存:3GB 硬盘:160G 5400转 光驱:DVD刻录光驱 显卡:Nvidia Quadro NVS 140M 千兆网卡。

    服务器端:IBM T60宽屏

    处理器:Intel Core2 T5500,内存:1GB,硬盘:120G 5400转,光驱:DVD-RW,显卡:ATI MOBILITY RADEON X1400,千兆网卡。

    测试软件:NetIQ Chariot v5.4;Endpoint6.0

    客户端:我们在客户端安装所测无线网卡的管理软件和Performance Endpoint,并固定千兆网卡的IP地址为:192.168.1.2。

    服务器:在服务器端安装Performance Endpoint和Chariot Console(控制台)。将交换机与服务器端通过网线连接,组成一个小型局域网,并固定服务端IP地址为:192.168.1.1。

    运行服务器端的Chariot Console控制台,依次建立点对点的测试项目,并选择Throughput脚本。我们只建立一个测试进程,测试时间设置为1分钟。为了保证测试数据的客观性,每项结果我们都反复进行了多次的测试,测试结果因各种因素不同会有所差异,以下数据仅供读者参考。

    1pair的测试:

    00c9a73fbf54b1841ceb35790b7785e6.gif

    测试截图

    平均数据传输率达到了525.454Mbps,峰值达到了800.008Mbps,这个数据相当的不错,基本达到了千兆交换机的水平。

    10/20 pair的测试:

    49bfc078ebd9a01431da4d713bd03bea.gif

    10个pair的测试截图

    8bf9abbd31fa0232a324f9798a8033f6.gif

    20个pair的测试截图

    同时传输10/20个pair的情况下,平均数据传输率达到了924.785Mbps/925.825Mbps,峰值都达到了400.004Mbps,平均值还是很高的。

    更多相关内容
  • (1)智能交换机,也称为网管交换机。具有独立的操作系统,可以进行配置和管理。随着网络规模的扩大,接入计算机数量...交换机和计算机一样,也由硬件和软件两部分组成,硬件主要包括CPU、端口和存储介质,软件主要是I...

    (1)智能交换机,也称为网管交换机。具有独立的操作系统,可以进行配置和管理。随着网络规模的扩大,接入计算机数量的增多,为了提高数据传输的效率,保障敏感部门数据的访问安全,对一些安全性要求较高,或较为复杂的网络环境,就应该采用网管交换机。

    20180509194018_e12056f8ac49254072a238e61c97fb58_1.jpeg

    (2)交换机相当于一台特殊的计算机,同样有CPU、存储介质和操作系统。交换机和计算机一样,也由硬件和软件两部分组成,硬件主要包括CPU、端口和存储介质,软件主要是IOS(互联网络操作系统)。表2-2列举了交换机的主要组件及其作用。

    表2-2交换机的主要组件及其作用

    20180509194018_e12056f8ac49254072a238e61c97fb58_2.jpeg

    (3)交换机间的互联方法。

    单个交换机的接口数量是有限的,在实际网络中,有时需要将若干个交换机互联起来以增加端口的数量。级联、堆叠是交换机互联的2种常用方法。

    20180509194018_e12056f8ac49254072a238e61c97fb58_3.jpeg

    ①级联。级联是交换机互联的标准技术和主流技术。即使用双绞线直接将两台交换机的某两个普通端口连接起来。它的早期目标就只是单纯地为了扩充端口数量。而在现代网络中,级联是构建结构化、层次化交换网络的必备技术,如图2-3所示。

    20180509194018_e12056f8ac49254072a238e61c97fb58_4.jpeg

    图2-3

    展开全文
  • 5、 一手握住缆线和绝缘护套,反转一小段绿色和蓝色组线,将其重组成 T568-B 接线顏色排列标准。依照颜色排列标准反转其余的线组。 6、 将这些缆线弄平、拉直、排列好,然后将裸露线缆处修剪约为 12mm。注意不要...

    实验一 网络连接线的制作

    首先,我们将学习如何制作直通线和交叉线,并用做线连通性测试仪测试线路是否可以正常工作。然后,再学习如何利用做好的缆线将两台工作站连接起来。

    工具 / 准备:

    (1) Cat5 无遮蔽式双绞缆线若干米;

    (2) RJ-45 接头(水晶头)若干个;

    (3) RJ-45 压线工具(以便将 RJ-45 接头接到缆线末端);

    (4) 测试仪(可以测试直通或交叉缆线是否能正常工作);

    (5) 剪线器。

    步骤 1- 做线说明

    根据本实验要求我们需要制作符合直通线和交叉线标准的两种缆线。下面介绍有关的做线信息。

    我们先来了解以下有关水晶头的信息(图 1):

    c0f89672b235ce2a6caa7b3d6360ed60.png

    网络连接插头

    图 1 水晶头带金属片的一面图

    如果用左手握住水晶头,将有弹片的一面朝下,带金属片的一面朝上,线头的插孔朝向右手一侧时,可以看到接头中的 8 个引脚。为了叙述方便,我们对引脚进行编号,如下图2 所示。

    5fbbd17cb838d98ce51f123fd81e5f99.png

    从工作站连接到集线器/交换器和从连接面板到集线器/交换器需要使用直通线,直通线的两端都符合 T568-B 或 T568-A标准,目前国内使用的直通线大多采用 T568-B 标准(图 3)。

    57d4f03c8b064d1eedab2d630b99e38c.png

    图 3 直通线做线示意图

    T568-A标准的线头排列顺序为绿白、绿、橙白、蓝、蓝白、橙、棕白、棕。T568-B 标 准的线头排列顺序为橙白、橙、绿白、蓝、蓝白、绿、棕白、棕。

    从工作站连接到工作站则需要使用交叉线,交叉线的一端符合T568-B 标准,另一端符

    合T568-A标准(图 4)。

    061ca9ce910bbec26d711970bb5a0e89.png

    图 4 交叉线做线示意图

    步骤 2- 建立 T568-B 直通连接缆线和建立 T568-A/T568-B 交叉连接缆线。

    按照图 3 与如下步骤制作符合 T568-B 标准的直通连接缆线(缆线两端应该以相同的方式接线,即都为T568-B标准)。

    T568-B 标准做线:

    1、根据设备间或设备与插头的距离,然后再加至少20 厘米的距离。此种缆线的最大长度为100米,本次实验所要求的标准长度为 2 米和 3米。

    2、 剪一段 2-3 米的 stranded Cat 5 无遮蔽式双绞线。

    3、 切除缆线一端约 3 厘米的绝缘护套。

    4、 紧紧握住四组(橙色组线、绿色组线、蓝色组线、棕色组线)。扭绞缆线去除绝缘护套的位置,然后按照 T568-B 接线标准重组缆线。小心处理扭绞处,因为它将提供消除杂讯功能。

    5、 一手握住缆线和绝缘护套,反转一小段绿色和蓝色组线,将其重组成 T568-B 接线顏色排列标准。依照颜色排列标准反转其余的线组。

    6、 将这些缆线弄平、拉直、排列好,然后将裸露线缆处修剪约为 12mm。注意不要松开已排列好之缆线!尽量减少未扭转缆线的长度,因为接头附近过长是电子杂讯的主要原因。

    7、 缆线一端放入一个 RJ-45 插头,岔线部分向下,橙色组线在接头最上面。

    8、 轻轻将插头穿过缆线,直到看见铜线尾端从插头另一方露出来。确定缆线绝缘护套尾端在插头內部而且缆线顺序正确。 如果缆线绝缘护套尾端不在插头內部,就无法良好的固定,而且会发生问题。如果一切正确的話,用力压下插头,让触点穿入电线的绝缘管,完成传导路径。

    9、重复步骤 3 到步骤 8,以同样的方法完成直通缆线的另一端。

    10、用测试仪测试完成的缆线,并请教师检查一遍。

    T568-A 标准做线:

    按照步骤 2提供的方法和图 4 制作出符合标准的交叉连通缆线。

    740a7dcd2b930dfa2a3f4af9e007410f.png

    实验二 认识Packet Tracer软件

    Packet Tracher介绍

    l Packet Tracer是Cisco公司针对CCNA认证开发的一个用来设计、配置和故障排除网络的模拟软件。

    l Packer Tracer模拟器软件比Boson功能强大,比Dynamips操作简单,非常适合网络设备初学者使用。

    实验任务

    1、安装Packer Tracer;

    2、利用一台型号为2960的交换机将2pc机互连组建一个小型局域网;

    3、分别设置pc机的ip地址;

    4、验证pc机间可以互通。

    实验设备

    Switch_2960 1台;PC 2台;直连线

    79a532f14575543298734d8a7a7a4548.png

    PC1

    IP: 192.168.1.2

    Submask: 255.255.255.0

    Gateway: 192.168.1.1

    PC2

    IP: 192.168.1.3

    Submask: 255.255.255.0

    Gateway: 192.168.1.1

    PC1 ping PC2 Reply

    PC2 ping PC1 Reply

    PC2 ping Gateway Timeout

    538ae2e8cd001ce37ab3b7a269c38e3f.png

    实验二 交换机的基本配置与管理

    实验目标

    l 掌握交换机基本信息的配置管理。

    实验背景

    l 某公司新进一批交换机,在投入网络以后要进行初始配置与管理,你作为网络管理员,对交换机进行基本的配置与管理。

    技术原理

    l 交换机的管理方式基本分为两种:带内管理和带外管理。

    l 通过交换机的Console端口管理交换机属于带外管理;这种管理方式不占用交换机的网络端口,第一次配置交换机必须利用Console端口进行配置。

    l 通过Telnet、拨号等方式属于带内管理。

    l 交换机的命令行操作模式主要包括:

    l 用户模式 Switch>

    l 特权模式 Switch#

    l 全局配置模式 Switch(config)#

    l 端口模式 Switch(config-if)#

    实验步骤:

    l 新建Packet Tracer拓扑图

    l 了解交换机命令行

    l 进入特权模式(en)

    l 进入全局配置模式(conf t)

    l 进入交换机端口视图模式(int f0/1)

    l 返回到上级模式(exit)

    l 从全局以下模式返回到特权模式(end)

    l 帮助信息(如? 、co?、copy?)

    l 命令简写(如 conf t)

    l 命令自动补全(Tab)

    l 快捷键(ctrl+c中断测试,ctrl+z退回到特权视图)

    l Reload重启。(在特权模式下)

    l 修改交换机名称(hostname X)

    l 配置交换机端口参数(speed,duplex)

    l 查看交换机版本信息(show version)

    l 查看当前生效的配置信息(show run)

    实验设备

    Switch_2960 1台;PC 1台;配置线;

    3530b4468042fcbc4c6f3ab69d568a30.png

    PC console端口

    enable

    conf t

    interface fa 0/1

    speed 100

    duplex full

    end

    show version

    show run

    实验三 交换机的Telnet远程登陆配置

    实验目标

    l 掌握采用Telnet方式配置交换机的方法。

    实验背景

    l 第一次在设备机房对交换机进行了初次配置后,你希望以后在办公室或出差时也可以对设备进行远程管理。现要在交换机上做适当配置。

    技术原理

    l 配置交换机的管理IP地址(计算机的IP地址与交换机管理IP地址在同一个网段):

    l 为telnet用户配置用户名和登录口令:

    l 交换机、路由器中有很多密码,设置对这些密码可以有效的提高设备的安全性。

    l switch(config)# enable password ****** 设置进入特权模式的密码

    l switch(config-line)可以设置通过console端口连接设备及Telnet远程登录时所需的密码;

    l switch(config)# line console 0

    l switch(config-line)# password 5ijsj

    l switch(config-line)# login

    l switch(config)# line vty 0 4

    l switch(config-line)# password 5ijsj

    l switch(config-line)# login

    实验步骤

    l 新建Packet Tracer拓扑图

    l 配置交换机管理ip地址

    l Switch(config)# int vlan 1

    l Switch(config-if)# ip address **IP**空格+子网掩码

    l 配置用户登录密码

    l Switch(config)# enable password ******* 设置进入特权模式的密码

    l Switch(config)# line vty 0 4

    l Switch(config-line)# password 5ijsj

    l Switch(config-line)# login

    实验设备

    Switch_2960 1台;PC 1台;直连线;配置线

    ff0965b224fb8633d93f6dac56dd43b5.png

    PC

    192.168.1.2

    255.255.255.0

    192.168.1.1

    PC终端

    en

    conf t

    inter vlan 1(默认交换机的所有端口都在VLAN1中)

    ip address 192.168.1.1 255.255.255.0

    no shutdown

    exit

    enable password 123456

    line vty 0 4

    password 5ijsj

    login

    end

    show run

    PC CMD

    ping 192.168.1.1

    telnet 192.168.1.1

    password:5ijsj 密码使用密文发送 输入时不会显示

    enable

    password:123456

    show running

    实验四 交换机划分Vlan配置

    实验目标

    l 理解虚拟LAN(VLAN)基本配置;

    l 掌握一般交换机按端口划分VLAN的配置方法;

    l 掌握Tag VLAN配置方法。

    实验背景

    l 某一公司内财务部、销售部的PC通过2台交换机实现通信;要求财务部和销售部的PC可以互通,但为了数据安全起见,销售部和财务部需要进行互相隔离,现要在交换机上做适当配置来实现这一目标。

    技术原理

    l VLAN是指在一个物理网段内。进行逻辑的划分,划分成若干个虚拟局域网,VLAN最大的特性是不受物理位置的限制,可以进行灵活的划分。VLAN具备了一个物理网段所具备的特性。相同VLAN内的主机可以相互直接通信,不同VLAN间的主机之间互相访问必须经路由设备进行转发,广播数据包只可以在本VLAN内进行广播,不能传输到其他VLAN中。

    l Port VLAN是实现VLAN的方式之一,它利用交换机的端口进行VALN的划分,一个端口只能属于一个VLAN。

    l Tag VLAN是基于交换机端口的另一种类型,主要用于是交换机的相同Vlan内的主机之间可以直接访问,同时对不同Vlan的主机进行隔离。Tag VLAN遵循IEEE802.1Q协议的标准,在使用配置了Tag VLAN的端口进行数据传输时,需要在数据帧内添加4个字节的8021.Q标签信息,用于标示该数据帧属于哪个VLAN,便于对端交换机接收到数据帧后进行准确的过滤。

    实验步骤

    l 新建Packet Tracer拓扑图;

    l 划分VLAN;

    l 将端口划分到相应VLAN中;

    l 设置Tag VLAN Trunk属性;

    l 测试

    实验设备

    Switch_2960 2台;PC 4台;直连线

    c989c248f78c4fc0839d8ba4dfee7e3e.png

    PC1

    IP: 192.168.1.2

    Submark: 255.255.255.0

    Gateway: 192.168.1.1

    PC2

    IP: 192.168.1.3

    Submark: 255.255.255.0

    Gateway: 192.168.1.1

    PC3

    IP: 192.168.1.4

    Submark: 255.255.255.0

    Gateway: 192.168.1.1

    PC4

    IP: 192.168.1.5

    Submark: 255.255.255.0

    Gateway: 192.168.1.1

    Switch1

    en

    conf t

    vlan 2

    exit

    vlan 3

    exit

    inter fa 0/1

    switch access vlan 2

    exit

    inter fa 0/2

    switch access vlan 3

    exit

    inter fa 0/24

    switch mode trunk

    end

    show vlan

    Switch2

    en

    conf t

    vlan 2

    exit

    vlan 3

    exit

    int fa 0/1

    switch access vlan 2

    exit

    int fa 0/2

    switch access vlan 3

    exit

    int fa 0/24

    switch mode trunk

    end

    show vlan

    PC1 ping PC2 timeout

    PC1 ping PC3 Reply

    实验五 利用三层交换机实现VLAN间路由

    实验目标

    l 掌握交换机Tag VLAN的配置

    l 掌握三层交换机基本配置方法;

    l 掌握三层交换机VLAN路由的配置方法;

    l 通过三层交换机实现VLAN间相互通信;

    实验背景

    l 某企业有两个主要部门,技术部和销售部,分处于不同的办公室,为了安全和便于管理对两个部门的主机进行了VLAN的划分,技术部和销售部分处于不同的VLAN,先由于业务的需求需要销售部和技术部的主机能够相互访问,获得相应的资源,两个部门的交换机通过一台三层交换机进行了连接。

    技术原理

    l 三层交换机具备网络层的功能,实现VLAN相互访问的原理是:利用三层交换机的路由功能,通过识别数据包的IP地址,查找路由表进行选路转发,三层交换机利用直连路由可以实现不同VLAN之间的相互访问。三层交换机给接口配置IP地址。采用SVI(交换虚拟接口)的方式实现VLAN间互连。SVI是指为交换机中的VLAN创建虚拟接口,并且配置IP地址。

    实验步骤

    l 新建packet tracer拓扑图

    l (1)在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划分给VLAN2、VLAN3。

    l (2)将二层交换机与三层交换机相连的端口fa 0/1都定义为tag Vlan模式。

    l (3)在三层交换机上配置VLAN2、VLAN3,此时验证二层交换机VLAN2、VLAN3下的主机之间不能相互通信。

    l (4)设置三层交换机VLAN间的通信,创建VLAN2,VLAN3的虚接口,并配置虚接口VLAN2、VLAN3的IP地址。

    l (5)查看三层交换机路由表。

    l (6)将二层交换机VLAN2、VLAN3下的主机默认网关分别设置为相应虚拟接口的IP地址。

    l (7)验证二层交换机VLAN2,VALN3下的主机之间可以相互通信。

    实验设备

    Switch_2960 1台;Swithc_3560 1台;PC 3台;直连线

    33b2763dcd0b6ea3d716cc34c16a1d82.png

    PC1

    IP: 192.168.1.2

    Submark: 255.255.255.0

    Gateway: 192.168.1.1

    PC2

    IP: 192.168.2.2

    Submark: 255.255.255.0

    Gateway: 192.168.2.1

    PC3

    IP: 192.168.1.3

    Submark: 255.255.255.0

    Gateway: 192.168.1.1

    S2960

    en

    conf t

    vlan 2

    exit

    vlan 3

    exit

    int fa 0/2

    switchport access vlan 2

    int fa 0/3

    switchport access vlan 3

    int fa 0/1

    switchport mode trunk

    exit

    show vlan

    S3560

    en

    conf t

    vlan 2

    exit

    vlan 3

    exit

    int fa 0/1

    switchport trunk encapsulation dot1q

    switchport mode trunk

    exit

    int fa 0/2

    switchport access vlan 2

    exit

    interface vlan 2

    ip address 192.168.1.1 255.255.255.0

    no shutdown

    exit

    interface vlan 3

    ip address 192.168.2.1 255.255.255.0

    no shutdown

    exit

    show ip route

    show vlan

    PC3 Ping PC1

    Ping 192.168.1.2

    PC3 Ping PC2

    Ping 192.168.1.3

    实验六 路由器的基本配置

    实验目标

    l 掌握路由器几种常用配置方法;

    l 掌握采用Console线缆配置路由器的方法;

    l 掌握采用Telnet方式配置路由器的方法;

    l 熟悉路由器不同的命令行操作模式以及各种模式之间的切换;

    l 掌握路由器的基本配置命令;

    实验背景

    l 你是某公司新进的网管,公司要求你熟悉网络产品,首先要求你登录路由器,了解、掌握路由器的命令行操作;

    l 作为网络管理员,你第一次在设备机房对路由器进行了初次配置后,希望以后在办公室或出差时也可以对设备进行远程管理,现要在路由器上做适当配置。

    技术原理

    l 路由器的管理方式基本分为两种:带内管理和带外管理。通过路由器的Console口管理路由器属于带外管理,不占用路由器的网络接口,其特点是需要使用配置线缆,近距离配置。第一次配置时必须利用Console端口进行配置。

    实验步骤

    l 新建packet tracer拓扑图

    l (1)用标准console线缆用于连接计算机的串口和路由器的console上。在计算机上启用超级终端,并配置超级终端的参数,使计算机与路由器通过console接口建立连接;

    l (2)配置路由器的管理的IP地址,并为Telnet用户配置用户名和登录口令。配置计算机的IP地址(与路由器管理IP地址在同一个网段),通过网线将计算机和路由器相连,通过计算机Telnet到路由器上对交换机进行查看;

    l (3)更改路由器的主机名;

    l (4)擦除配置信息。保存配置信息,显示配置信息;

    l (5)显示当前配置信息;

    l (6)显示历史命令。

    实验设备

    Router_2811 1台;PC 1台;交叉线;配置线

    说明: 交叉线:路由器与计算机相连 路由器与交换机相连

    直连线:计算机与交换机相连

    c338482849233b5aa89f9d07934a9fce.png

    PC

    IP: 192.168.1.2

    Submask: 255.255.255.0

    Gageway:192.168.1.1

    Router

    图形化:界面开启FastEthernet0/0端口

    命令行:rip 视图:router rip; osfp视图:router osfp 1

    PC 终端

    en

    conf t

    hostname R1

    enable secret 123456 //设置特权密码

    exit

    exit

    en

    password:此时输入密码,输入的密码不显示

    conf t

    line vty 0 4 //设置telnet密码

    password 5ijsj

    login

    exit

    interface fa 0/0

    ip address 192.168.1.1 255.255.255.0

    no shut

    end

    PC CMD

    ipconfig

    ping 192.168.1.1

    telnet 192.168.1.1

    password:5ijsi

    en

    password:123456

    show runing

    实验七 路由器静态路由配置

    实验目标

    l 掌握静态路由的配置方法和技巧;

    l 掌握通过静态路由方式实现网络的连通性;

    l 熟悉广域网线缆的链接方式;

    实验背景

    学校有新旧两个校区,每个校区是一个独立的局域网,为了使新旧校区能够正常相互通讯,共享资源。每个校区出口利用一台路由器进行连接,两台路由器间学校申请了一条2M的DDN专线进行相连,要求做适当配置实现两个校区的正常相互访问。

    技术原理

    l 路由器属于网络层设备,能够根据IP包头的信息,选择一条最佳路径,将数据包转发出去。实现不同网段的主机之间的互相访问。路由器是根据路由表进行选路和转发的。而路由表里就是由一条条路由信息组成。

    l 生成路由表主要有两种方法:手工配置和动态配置,即静态路由协议配置和动态路由协议配置。

    l 静态路由是指由网络管理员手工配置的路由信息。

    l 静态路由除了具有简单、高效、可靠的优点外,它的另一个好处是网络安全保密性高。

    l 缺省路由可以看做是静态路由的一种特殊情况。当数据在查找路由表时,没有找到和目标相匹配的路由表项时,为数据指定路由。

    实验步骤

    l 新建packet tracer拓扑图

    l (1)在路由器R1、R2上配置接口的IP地址和R1串口上的时钟频率;

    l (2)查看路由器生成的直连路由;

    l (3)在路由器R1、R2上配置静态路由;

    l (4)验证R1、R2上的静态路由配置;

    l (5)将PC1、PC2主机默认网关分别设置为路由器接口fa 1/0的IP地址;

    l (6)PC1、PC2主机之间可以相互通信;

    实验设备

    pc 2台;Router-PT可扩展路由 2台(Switch_2811无V.35线接口);Switch_2960 2台;DCE 串口线;直连线;交叉线

    481000bec2db41d4fc41ef61db458e76.png

    PC1

    IP: 192.168.1.2

    Submask: 255.255.255.0

    Gateway: 192.168.1.1

    PC2

    IP: 192.168.2.2

    Submask: 255.255.255.0

    Gateway: 192.168.2.1

    R1

    en

    conf t

    hostname R1

    int fa 1/0

    no shut

    ip address 192.168.1.1 255.255.255.0

    exit

    int serial 2/0

    no shut

    ip address 192.168.3.1 255.255.255.0

    clock rate 64000(必须配置时钟才可通信)

    end

    配置路由器1的 网管 及s口

    R2

    en

    conf t

    hostname R2

    int fa 1/0

    no shut

    ip address 192.168.2.1 255.255.255.0

    exit

    int serial 2/0

    ip address 192.168.3.2 255.255.255.0

    no shut

    end

    给路由器2配置网网关ip 两台Pc处于不同的网段 在非动态路由的情况下 两台pc是无法连通的,下面给R1 R2手动添加两条静态的路由

    R1 是从192.168.2.0 路由到192.168.3.2

    en

    conf t

    ip route 192.168.2.0 255.255.255.0 192.168.3.2

    end

    show ip route

    R2

    en

    conf t

    ip route 192.168.1.0 255.255.255.0 192.168.3.1

    end

    show ip route

    S 192.168.1.0/24 [1/0] via 192.168.3.1 1.0到 3.1网关 的路由

    C 192.168.2.0/24 is directly connected, FastEthernet1/0 通过快速以太网口1/0 直连的网段 2.0

    C 192.168.3.0/24 is directly connected, Serial2/0 同理

    实验八 路由器RIP动态路由配置

    实验目的

    l 掌握RIP协议的配置方法:

    l 掌握查看通过动态路由协议RIP学习产生的路由;

    l 熟悉广域网线缆的链接方式;

    实验背景

    假设校园网通过一台三层交换机连到校园网出口路由器上,路由器再和校园外的另一台路由器连接。现要做适当配置,实现校园网内部主机与校园网外部主机之间的相互通信。为了简化网管的管理维护工作,学校决定采用RIPV2协议实现互通。

    技术原理

    l RIP(Routing Information Protocols,路由信息协议)是应用较早、使用较普遍的IGP内部网管协议,使用于小型同类网络,是距离矢量协议;

    l RIP协议跳数作为衡量路径开销的,RIP协议里规定最大跳数为15;

    l RIP协议有两个版本:RIPv1RIPv2RIPv1属于有类路由协议,不支持VLSM,以广播形式进行路由信息的更新,更新周期为30秒;RIPv2属于无类路由协议,支持VLSM,以组播形式进行路由更细。

    实验步骤

    l 建立建立packet tracer拓扑图

    l (1)在本实验中的三层交换机上划分VLAN10和VLAN20,其中VLAN10用于连接校园网主机,VLAN20用于连接R1。

    l (2)路由器之间通过V.35电缆通过串口连接,DCE端连接在R1上,配置其时钟频率64000。

    l (3)主机和交换机通过直连线,主机与路由器通过交叉线连接。

    l (4)在S3560上配置RIPV2路由协议。

    l (5)在路由器R1、R2上配置RIPV2路由协议。

    l (6)将PC1、PC2主机默认网关设置为与直连网路设备接口IP地址。

    l (7)验证PC1、PC2主机之间可以互相同信;

    实验设备

    PC 2台;Switch_3560 1台;Router-PT 2台;直连线;交叉线;DCE 串口线

    b924a427c402705e12bfbac6c98273d5.png

    PC1

    IP: 192.168.1.2

    Submask: 255.255.255.0

    Gateway: 192.168.1.1

    PC2

    IP: 192.168.2.2

    Submask: 255.255.255.0

    Gateway: 192.168.2.1

    S3560

    en

    conf t

    hostname S3560

    vlan 10

    exit

    vlan 20

    exit

    interface fa 0/10

    switchport access vlan 10

    exit

    interface fa 0/20

    switchport access valn 20

    exit

    end

    show vlan

    下面为两个vlan 划分连个端口的ip 并且处于不同的网段分别是连接pc1的 1网段

    和 连接路路由器部分的3 网段

    conf t

    interface vlan 10

    ip address 192.168.1.1 255.255.255.0

    no shutdown

    exit

    interface vlan 20

    ip address 192.168.3.1 255.255.255.0

    no shutdown

    end

    show ip route 此处显示路由表的结果是 只有当前的设备直连的网段路由

    show runing

    为三层交换机 添加动态rip路由协议 分别将 vlan 10 和vlan 20 之间搭建一个路由路径

    conf t

    ip routing

    router rip

    network 192.168.1.0

    network 192.168.3.0

    version 2

    end

    show ip route

    仍然是只有直连网段

    R1

    en

    conf t

    hostname R1

    interface fa 0/0

    no shutdown

    ip address 192.168.3.2 255.255.255.0

    interface serial 2/0

    no shutdown

    ip address 192.168.4.1 255.255.255.0

    clock rate 64000

    end

    show ip route

    配置好 后依然是只有直连网段的路由表

    该路由器R1 直连3.0 网段和4.0网段 为路由器R1添加 两个网段之间的rip

    conf t

    router rip

    network 192.168.3.0

    network 192.168.4.0

    version 2

    exit

    R2

    en

    conf t

    hostname R2

    interface fa 0/0

    no shutdown

    ip address 192.168.2.1 255.255.255.0

    interface serial 2/0

    no shutdown

    ip address 192.168.4.2 255.255.255.0

    end

    show ip route

    conf t

    router rip

    network 192.168.2.0

    netword 192.168.4.0

    version 2

    end

    实验九 路由器OSPF动态路由配置

    实验目的

    l 掌握OSPF协议的配置方法:

    l 掌握查看通过动态路由协议OSPF学习产生的路由;

    l 熟悉广域网线缆的连接方式;

    实验背景

    假设校园网通过一台三层交换机连到校园网出口路由器上,路由器再和校园外的另一台路由器连接。现要做适当配置,实现校园网内部主机与校园网外部主机之间的相互通信。为了简化网管的管理维护工作,学校决定采用OSPF协议实现互通。

    技术原理

    l OSPF开放式最短路径优先协议,是目前网路中应用最广泛的路由协议之一。属于内部网管路由协议,能够适应各种规模的网络环境,是典型的链路状态协议。OSPF路由协议通过向全网扩散本设备的链路状态信息,使网络中每台设备最终同步一个具有全网链路状态的数据库,然后路由器采用SPF算法,以自己为根,计算到达其他网络的最短路径,最终形成全网路由信息。

    实验步骤

    l 新建packet tracer拓扑图

    l (1)在本实验中的三层交换机上划分VLAN10和VLAN20,其中VLAN10用于连接校园网主机,VLAN20用于连接R1。

    l (2)路由器之间通过V35电缆通过串口连接,DCE端连接在R1上,配置其时钟频率64000。

    l (3)主机和交换机通过直连线,主机与路由器通过交叉线连接。

    l (4)在S3560上配置OSPF路由协议。

    l (5)在路由器R1、R2上配置OSPF路由协议。

    l (6)将PC1、PC2主机默认网关设置为与直连网路设备接口IP地址。

    l (7)验证PC1、PC2主机之间可以互相通信;

    实验设备

    PC 2台;Switch_3560 1台;Router-PT 2台;直连线;交叉线;DCE串口线

    f0224179d75a359bf3f4f9e77ddd98ea.png

    PC1

    IP: 192.168.1.2

    Submask: 255.255.255.0

    Gateway: 192.168.1.1

    PC2

    IP: 192.168.2.2

    Submask: 255.255.255.0

    Gateway: 192.168.2.1

    S3560

    en

    conf t

    hostname S3569

    vlan 10

    exit

    vlan 20

    interface fa 0/10

    switchport access vlan 10

    exit

    int fa 0/20

    switchport access valn 20

    exit

    interface valn 10

    ip address 192.168.1.1 255.255.255.0

    no shutdown

    exit

    interface vlan 20

    ip address 192.168.3.1 255.255.255.0

    no shutdown

    end

    show ip route

    将10 和 20端口分别划分给vlan 10 vlan 20 并且为其分配ip

    conf t

    router ospf 1

    network 192.168.1.0 0.0.0.255 area 0

    network 192.168.3.0 0.0.0.255 area 0

    end

    show ip route

    R1

    en

    conf t

    hostname R1

    interface fa 0/0

    no shutdown

    ip address 192.168.3.2 255.255.255.0

    exit

    interface serial 2/0

    no shutdown

    clock rate 64000

    ip address 192.168.4.1 255.255.255.0

    end

    show ip route

    为路由器R1 配置ospf

    conf t

    router ospf 1

    network 192.168.3.0 0.0.0.255 area 0

    network 192.168.4.0 0.0.0.255 area 0

    end

    show ip route

    R2 同样R2配置路由及ip信息

    en

    conf t

    hostname R2

    interface fa 0/0

    no shutdown

    ip address 192.168.2.1 255.255.255.0

    exit

    interface serial 2/0

    no shutdown

    ip address 192.168.4.2 255.255.255.0

    end

    show ip route

    conf t

    router ospf 1

    network 192.168.2.0 0.0.0.255 area 0

    network 192.168.4.0 0.0.0.255 area 0

    end

    show ip route

    实验10 路由器综合路由配置

    实验目标

    掌握综合路由器的配置方法;

    掌握查看通过路由重分布学习产生的路由;

    熟悉广域网线缆的连接方式;

    实验背景

    假设某公司通过一台三层交换机连到公司出口路由器R1上,路由器R1再和公司外的另一台路由器R2连接。三层交换机与R1间运行RIPV2路由协议,R1与R2间运行OSPF路由协议。现要做适当配置,实现公司内部主机与公司外部主机之间的相互通信。

    技术原理

    为了支持本设备能够运行多个路由协议进程,系统软件提供了路由信息从一个路由进程重分布到另一个路由进程的功能。比如你可以将OSPF路由域的路由重新分布后通高RIP路由域中,也可以将RIP路由域的路由重新分布后通告到OSPF路由域中。路由的相互重分布可以在所有的IP路由协议之间进行。

    要把路由从一个路由域分布到另一个路由域,并且进行控制路由重分布,在路由进程配置模式中执行以下命令:

    redistribute protocol [metric metric][metric-type metric-type][match internal|external type|nssa-external type][tag tag][route-map route-map-name][subnets]

    实验步骤

    新建Packet Tracer拓扑图

    (1)PC与交换机间用直连线连接;PC与路由、路由与路由之间用交叉线连接。

    (2)在三层上划分2个Vlan,运行RIPV2协议;R2运行OSPF协议。

    (5)在路由器R1上左侧配置RIPV2路由协议;右侧配置OSPF协议。

    (6)在R1路由进程中引入外部路由,进行路由重分布。

    (7)将PC1、PC2主机默认网关分别设置为与直接网络设备接口IP地址。

    (8)验证PC1、PC2主机之间可以互相通信;

    实验设备

    Router_1841 2台;Switch_3560 1台;直通线;交叉线

    8df9eef883f913beb55c2e36b14aad14.png

    PC0

    IP: 192.168.1.2

    Submask: 255.255.255.0

    Gageway: 192.168.1.1

    PC1

    IP: 192.168.4.2

    Submask: 255.255.255.0

    Gageway: 192.168.4.1

    Switch0

    en

    conf t

    vlan 2

    exit

    int fa 0/10

    switchport access vlan 2

    exit

    int vlan 1

    ip address 192.168.1.1 255.255.255.0

    no shutdown

    exit

    int vlan 2

    ip address 192.168.2.1 225.255.255.0

    no shutdown

    end

    show int vlan 1

    conf t

    router rip

    network 192.168.1.0

    network 192.168.2.0

    version 2

    Router0

    en

    conf t

    host R1

    inf fa 0/0

    ip address 192.168.2.2 255.255.255.0

    no shutdown

    int fa 1/0

    ip address 192.168.3.1 255.255.255.0

    no shutdown

    exit

    router rip

    network 192.168.2.0

    version 2

    router ospf 1

    network 192.168.3.0 0.0.0.255 area 0

    Route1

    en

    conf t

    host R2

    int fa 0/1

    ip address 192.168.3.2 255.255.255.0

    no shutdown

    int fa 0/0

    ip address 192.168.4.1 255.255.255.0

    no shutdown

    exit

    router ospf 1

    network 192.168.3.0 0.0.0.255 area 0

    network 192.168.4.0 0.0.0.255 area 0

    end

    show ip route

    Router0

    end

    show ip route

    show run

    show ip route

    ping 192.168.1.2 (success)

    ping 192.168.4.2 (success)

    PC0

    ping 192.168.4.2 (Replay form 192.168.1.1: Destination host unreachable)

    Switch_3560

    show ip rout (只有两条直连路由)

    Router0

    conf t

    router rip

    redistribute ospf 1

    exit

    router ospf 1

    redistribute rip subnets

    end

    Router1

    show ip route

    PC0

    ping 192.168.4.2 (Replay form 192.168.4.2: byes=32 time=125ms TTL=125)

    展开全文
  • PISCES:可编程的,协议独立的软件交换机 摘要 虚拟机监视器使用软件交换机来引导数据包进出虚拟机(vm)。这些交换机经常需要升级和定制,以支持新的协议头或用于隧道和覆盖的封装,以改进测量和调试功能,甚至添加...

    PISCES:可编程的,协议独立的软件交换机

    摘要

    虚拟机监视器使用软件交换机来引导数据包进出虚拟机(vm)。这些交换机经常需要升级和定制,以支持新的协议头或用于隧道和覆盖的封装,以改进测量和调试功能,甚至添加类似于中间盒的函数。软件交换机通常基于大量的代码,包括内核代码,改变交换机是一项艰巨的任务,需要精通网络协议的设计和开发、测试,以及维护一个庞大而复杂的代码库。改变软件交换机转发数据包的方式不需要对其实现有深入的了解。相反,应该可以指定如何用高级领域特定语言(DSL)(如P4)处理和转发数据包,并将其编译为在软件交换机上运行。我们介绍了PISCES,它是一个软件交换机,派生于Open vSwitch (OVS),一个硬连接的hypervisor交换机,它的行为是使用P4定制的。PISCES不是硬连接到特定的协议;这种独立性使得添加新特性变得很容易。我们还将展示编译器如何分析高级规范以优化转发性能。我们的评估表明,PISCES的性能与OVS相当,PISCES程序的长度约为OVS源代码的1/40。

    简介

    软件交换机,如Open vSwitch (OVS),在现代数据中心中扮演着关键角色:除了少数例外,每个进出虚拟机(VM)的数据包都要经过软件交换机。此外,在这种环境中,服务器的数量大大超过物理交换机。因此,充满运行虚拟机监视器软件的服务器的数据中心所包含的软件交换机也远远多于硬件交换机。同样,由于每个虚拟机监视器托管多个虚拟机,这样的数据中心拥有比物理以太网端口更多的虚拟以太网端口。

    软件虚拟机监视器交换机的主要优点之一是,它比硬件交换机更容易升级。因此,虚拟机监视器交换机支持新的封装头、改进的故障排除和调试特性,以及类似于中间件的功能,如负载平衡、地址虚拟化和加密。未来,随着数据中心所有者自定义和优化他们的基础设施,他们将继续向虚拟机监视器交换机添加特性。

    每个新特性都需要自定义虚拟机监视器的切换,但是进行这些自定义比表面上看起来要困难得多。首先,大多数支持快速包转发的机制都位于内核中。编写内核代码需要大多数网络运营商缺乏的领域专业知识,因此为开发和部署新特性带来了很大的障碍。最近的技术可以加速用户空间中的包转发,但这些技术仍然需要大量的软件开发专业知识,并熟悉大量、复杂和复杂的代码库。此外,定制不仅需要将更改合并到开关代码中,还需要随着底层软件的发展而维护这些定制,这可能需要大量的资源。

    要改变软件交换机转发数据包的方式,不需要对交换机是如何实现的了如指掌。相反,应该可以用特定于领域的语言(DSL)(如P4)指定自定义网络协议,然后将其编译为用于虚拟机监视器切换的自定义代码。这样的DSL将支持自定义交换机的转发行为,而不需要更改底层交换机实现。将自定义协议实现与底层交换机代码解耦也使得维护这些自定义变得更容易,因为它们仍然独立于底层交换机实现。使用标准化的DSL,定制也可以移植到其他支持相同语言的硬件或软件交换机上。

    借用硬件交换机的类似趋势的一个关键观点是,底层交换机应该是一个基板,可以很好地处理高速数据包,但不绑定到特定的协议。在极端情况下,交换机被认为是协议独立的,这意味着在它接收到关于如何处理数据包的指令(通过DSL)之前,它不知道协议是什么。换句话说,协议由协议作者创建的DSL中编写的程序表示。

    我们将类似的理念应用于软件交换机。我们假设在DSL中编写的程序指定了要解析的包报头和匹配操作表的结构(例如,匹配哪个报头字段以及对匹配的报头执行哪些操作)。底层的软件基板是一个通用引擎,经过优化以程序指定的形式解析、匹配和处理数据包头。

    然而,在DSL中表达这些定制需要编译从DSL到在交换机中运行的代码。与手动实现固定协议的交换机相比,这种协议编译过程会降低底层实现的效率,从而降低性能。编译过程与硬件交换机不同,在硬件交换机中,给定有限的资源,目标是优化面积、延迟和功率等指标,同时满足资源约束。我们在本文中的目标是(1)量化在这样的DSL中表达自定义协议所产生的额外成本;(2)设计和评估领域特定的编译器优化,尽可能地减少性能开销。最后,我们证明,通过适当的编译器优化,独立于协议的软件交换机的性能——在高级DSL中支持自定义协议规范而不直接修改低级源代码的交换机——接近于本机虚拟机监视器软件交换机的性能。我们的结果很有希望,特别是考虑到我们的基础代码OVS并不是设计来支持协议独立性的。不过,我们的结果表明,在虚拟机监视器切换中,可编程性的成本可以忽略不计。我们希望我们的研究结果将启发设计新的协议无关的软件交换机,以更高的速度运行。

    我们的贡献如下:

    • PISCES的设计和实现,第一个允许在高级DSL中定制协议规范的软件交换机,不需要直接修改交换机源代码。
    • 一个在GitHub上公开的PISCES的开源实现。实现是一种独立于协议的软件交换机,它来自于OVS,由(称为P4的)高级DSL编程而成。
    • 特定于领域的优化和一个后端优化器,以减少使用P4定制OVS的性能开销。我们还在P4中引入了两个新的注释来帮助优化
    • 对PISCES程序的代码复杂性及其转发性能的评估。我们的评估表明,PISCES程序平均比等效的OVS源代码更改短约40倍,而转发性能(即吞吐量)开销仅为2%左右。

    我们首先通过描述来自运营网络的真实用例来引出对可定制的虚拟机监视器软件交换机的需求,并介绍P4和OVS的背景信息。

    协议无关交换机的需求

    我们说PISCES是一个独立于协议的软件交换机,因为它不知道协议是什么,也不知道如何代表协议处理包,直到程序员指定它。例如,如果我们想让PISCES处理IPv4数据包,那么我们需要描述在P4程序中如何处理IPv4数据包。在P4程序中(例如IPv4. P4),我们需要描述IPv4报头的格式和字段,包括IP地址、协议ID、TTL、校验和、标志等。我们还需要指定我们使用一个查找表来存储IPv4前缀,以及我们搜索最长的匹配前缀。我们还需要描述如何减少TTL,如何更新校验和,等等。P4程序捕获整个包处理管道,将其编译为OVS的源代码,OVS指定交换机的匹配、操作和解析能力。

    协议无关的交换机有很多好处:

    添加新的标准或私有协议头

    供应商一直在提出新的协议标头,特别是对于数据中心。私有的、专有的协议也被添加进来,以提供竞争优势,例如,通过在应用程序之间创建更好的隔离,或通过引入新的拥塞标记。在许多情况下,在部署新协议之前,必须升级所有的硬件和软件交换机,以识别报头并正确处理它们。对于硬件交换机,数据中心所有者必须向他们的芯片供应商提供需求,并等待三到四年的时间,如果供应商同意添加新特性的话。在软件切换的情况下,它们必须等待下一个主要的修订、测试和部署周期。即使修改开源软件交换机也不是万能的,因为一旦数据中心所有者直接修改开源软件交换机以添加他们自己的定制协议,这些修改仍然需要与主线代码库进行维护和同步,随着原始开源交换机的不断发展,引入了大量的代码维护开销。可以向P4程序添加新协议的数据中心所有者可以更快地编译和部署新协议

    删除标准协议头

    数据中心网络通常比传统的校园网和企业网运行更少的协议,部分原因是大多数流量是机器对机器的,许多传统的协议不需要(例如多播)。例如,亚马逊网络服务(AWS)据说只转发使用IPv4头的数据包。因此,完全删除未使用的协议有利于数据中心所有者,从而消除了与旧协议的休眠实现进行交互的任何顾虑。必须支持许多协议已经够糟糕的了;更糟糕的是,必须理解操作人员不打算使用的协议的交互和含义。因此,数据中心所有者经常希望从他们的交换机、网卡和操作系统中消除未使用的协议。从传统交换机中移除协议是困难的;对于硬件来说,这意味着等待新的芯片,而对于软件转换来说,这意味着要通过大量的代码库来提取特定的协议。在PISCES网络中,删除未使用的协议与删除协议规范中未使用的部分并重新编译开关源代码一样简单。

    添加更好的可见性

    随着数据中心的规模越来越大,应用越来越多,了解网络的行为和运行状况变得越来越重要。故障可能导致巨大的收入损失,随着网络变得更大、更复杂,长时间的调试时间会加剧这一损失。人们越来越感兴趣的是如何让人们更容易地看到网络在做什么。提高网络可见性可能需要支持新的统计数据,生成新的探测包,或添加新的协议和动作来收集交换机状态。用户将希望看到队列是如何演变的,延迟是如何变化的,隧道是否正确终止,以及链接是否仍然是正常的。通常,在紧急情况下,用户希望快速添加可见性特性。让它们随时可以部署,或者能够快速修改转发和监视逻辑,可以减少诊断和修复网络故障的时间。

    添加全新的功能

    如果用户和网络所有者可以修改转发行为,他们甚至可以添加全新的功能。例如,随着时间的推移,我们会承担更多的复杂的路由交换机,新的拥塞控制机制,跟踪路由,新的负载均衡算法,新方法来减轻DDoS,和新"虚拟-物理"网关功能。如果网络所有者能够升级基础设施以实现更大的利用率或更多的控制,那么他们将知道如何做。如果有了升级用DSL(如P4)编写的程序以向交换机添加新特性的方法,我们可以预期网络所有者将更快地改进他们的网络。

    背景

    PISCES是一个软件交换机,它的转发行为是使用特定领域的语言指定的。PISCES基于Open vSwitch (OVS)软件交换机,使用P4领域专用语言进行配置。我们在下面描述P4和OVS

    领域特定语言:P4

    P4是一种领域特定的语言,它表示网络转发元素的流水线应该如何使用下图所示的抽象转发模型处理数据包。在这个模型中,每个数据包首先经过一个可编程的解析器,解析器提取报头。P4程序指定了每个可能的头的结构,以及表示排序和依赖关系的解析图。然后,数据包通过一系列的匹配动作表(MATs)。P4程序指定了每个mat可能匹配的字段和它们之间的控制流,以及每个表允许的操作范围。在运行时(即,当交换机转发数据包时),控制器软件可以根据特定的匹配操作规则添加、删除和修改表项,这些规则符合P4程序的规范。最后,在将报头字段发送到适当的端口之前,发送者会将报头字段写回数据包。

    在这里插入图片描述

    P4抽象转发模型

    我们选择P4是因为它的抽象交换机模型类似于OVS内建语言OpenFlow的模型,它允许我们对带有和不带有P4前端的OVS进行简单的比较。我们考虑了其他备选基础,对于我们的目的,P4足以进行预期的比较。拥有一种通用的方法来表示跨网络中所有管道交换机的转发,并拥有可从一个交换机移植到另一个交换机的代码,这是有好处的。因此,使用相同的语言进行这些实验是有意义的。

    软件交换机: Open vSwitch

    Open vSwitch (OVS)广泛用于数据中心,作为运行在虚拟机监视器内部的软件交换机。在这种环境下,OVS可以在虚拟接口和物理接口之间交换报文。OVS实现了常见的以太网、GRE、IPv4等协议,以及数据中心中较新的协议。

    Open vSwitch虚拟交换机有两个重要的部分,称为慢路径和快路径(即数据路径),如下图所示。慢路径是一个用户空间程序;它提供了OVS的大部分智能。快速路径作为一个缓存层,只包含实现最大性能所需的代码。值得注意的是,快速路径必须将任何导致缓存丢失的包传递给慢路径,以获得进一步处理的指令。OVS包括针对不同环境的单个、可移植的慢路径和多个快路径实现:一个基于Linux内核模块,另一个基于Windows内核模块,另一个基于Intel DPDK用户空间转发。DPDK快速路径可以产生最高的性能,因此我们在工作中使用它;通过额外的努力,我们的工作可以扩展到其他快速路径。

    在这里插入图片描述

    OVS转发模型

    作为SDN交换机,OVS依赖于控制器的指令来确定其行为,具体使用的是OpenFlow协议。OpenFlow根据匹配操作表的集合指定行为,每个表包含许多称为流的条目。反过来,流由匹配(根据包头和元数据)、指示交换机在匹配结果为true时该做什么的动作和一个数字优先级组成。当一个包到达一个特定的匹配操作表时,交换机找到一个匹配的流并执行它的操作;如果有多个流匹配该报文,则优先级最高的流优先。

    完全实现上述行为的软件交换机无法实现高性能,因为OpenFlow数据包经常要经过几个匹配操作表,每个表都需要通用的数据包分类。因此,OVS依赖缓存来实现良好的转发性能。主要的OVS缓存是它的megflow巨流缓存,它的结构很像一个OpenFlow表。巨流缓存背后的思想是,从理论上讲,可以通过计算它们的交叉乘积,将包在遍历OpenFlow管道时访问的所有匹配操作表合并到单个表中。但这是不可行的,因为k个表与 n 1 . . . . n k n_{1}....n_{k} n1....nk规则的叉积可能包含 n 1 . . . . n k n_{1}....n_{k} n1....nk规则。巨流缓存的功能有点像延迟计算的跨积:当一个包到达时,如果它不匹配任何现有的巨流缓存条目,慢速路径会计算一个新的条目,对应于理论的跨积中的一行,并将其插入缓存中。OVS使用了许多技术来提高大流量缓存性能和命中率

    当一个数据包在超大流量缓存中命中时,交换机处理它的速度比缓存丢失所需要的从快路到慢路的往返速度要快得多。然而,作为一个通用的分组分类步骤,巨流缓存查找仍然有很大的成本。因此,Open vSwitch快速路径实现还包括一个微流缓存,一个从一个五元组数据包映射到一个超大流缓存条目的哈希表。微流缓存查找的结果只能是一个提示,因为巨流通常匹配更多的字段,而不仅仅是五元组,所以微流缓存条目在最好的情况下可以指向最可能的匹配。因此,快速路径必须验证巨流缓存条目确实与数据包匹配。如果匹配,则查找成本仅为单个哈希表的查找成本。这种查找成本通常比一般的包分类要低得多,因此对于具有相对较长的、稳定的数据包流的流量模式来说,它是一种重要的优化。如果不匹配,则数据包继续执行通常的兆流缓存查找过程,跳过它已经检查过的条目。

    PISCES 原型

    我们的PISCES原型是OVS的一个修改版本,解析、匹配和操作代码被我们的P4编译器生成的C代码替换。工作流程如下:首先,程序员创建一个P4程序,并使用P4编译器的PISCES版本为OVS生成新的解析、匹配和操作代码。其次,编译OVS(使用常规的C编译器)以创建一个依赖于协议的交换机,该交换机处理P4程序中描述的数据包。要修改协议,用户需要修改P4程序,该程序将编译成新的虚拟机监视器切换二进制文件。

    我们使用OVS作为PISCES 的基础,因为它被广泛使用,并且包含一些可编程交换机的基本脚手架,因此允许我们只关注交换机需要定制的部分(即解析、匹配和操作)。代码结构良好,便于修改,并且测试环境已经存在。它还允许比较:我们可以比较未修改的OVS和P4程序的代码行数,我们也可以比较它们的性能。

    PISCES 的P4-OVS编译器

    P4编译器有两个部分:前端将P4代码转换为与目标无关的中间表示(IR),后端将IR映射到目标。在本例中,后端通过操作IR来优化CPU时间、延迟或其他目标,然后生成C代码来替换OVS中的解析、匹配和操作代码,如下图所示。P4-OVS编译器输出C源代码,该源代码实现了编译相应的开关可执行文件所需的一切。编译过程还生成一个独立的类型检查程序,可执行程序使用该程序来确保来自控制器的任何运行时配置指令(例如,流规则的插入)符合P4程序中指定的协议。

    在这里插入图片描述

    PISCES 的P4-OVS编译器

    解析

    C代码由取代结构流替换原始OVS解析器,C结构OVS用来跟踪协议头字段,包括成员每个字段指定的P4程序,并生成代码从数据包中提取头字段到结构体流。

    匹配

    OVS使用一种通用的分类器数据结构,基于元空间搜索来实现匹配。要执行自定义匹配,我们不需要修改这个数据结构或管理它的代码。相反,控制平面可以在运行时简单地用新的包报头字段填充分类器,从而自动地使这些字段可用于包匹配。

    动作

    编译器的后端通过自动生成代码来支持定制操作,我们将这些代码静态地编译成OVS二进制文件。自定义动作可以在OVS慢路径或快路径中执行;编译器决定在哪里运行一个特定的操作,以确保开关有效地执行这些操作。某些动作可以在任意一个组件中执行。程序员可以向编译器提供一些提示,告诉它动作的慢路径实现还是快路径实现是最合适的。

    控制流

    在交换机中,信息包的控制流是信息包所遍历的匹配操作表序列。而在P4中,控制流必须在程序的编译时指定,而在OVS中,控制流是在运行时指定的,通过流条目,这使得它更加灵活。因此,我们的编译器后端可以在不改变OVS的情况下实现P4控制语义

    优化IR

    编译器后端包含一个优化器来检查和修改IR,以便生成高性能的C代码。例如,P4程序可能包含一个完整的IP校验和,但优化器可以将此操作转换为一个增量的IP校验和,以使其更快。编译器还对IR执行数据流分析,允许它合并和专门化C代码。优化器还决定数据包处理管道中的何时何地编辑数据包头。一些硬件交换机将编辑推迟到流水线的末尾,而软件交换机通常在流水线的每个阶段编辑头文件。如果需要,优化器会将IR转换为内嵌编辑。

    与其他P4编译器的情况一样,P4- OVS编译器也为匹配操作表生成API,并扩展了OVS命令行工具来处理新的字段。

    改进OVS

    我们需要对OVS进行三处修改,使其能够实现任何P4程序中描述的转发行为。

    任意封装和解封装。

    OVS不支持P4程序可能需要的任意封装和解封装。每个OVS快速路径都为各种固定形式的封装提供了自定义支持。Linux内核快速路径和DPDK快速路径分别实现了GRE、VXLAN、STT等封装。为隧道封装和解封装数据包所需的元数据是静态配置的。交换机使用数据包的入口端口将其映射到适当的隧道;在报文出接口时,根据此静态隧道配置将报文封装在相应的IP报头中。因此,我们在OVS中添加了两个新的原语,添加header()和删除header(),分别执行封装和解封装,并在快速路径中执行这些操作。

    基于报头字段比较的条件。

    OpenFlow只直接支持对报头字段的按位相等测试。相关测试,如<和比;将k位域与常数进行比较,可以表示为最多有k个使用位相等匹配的规则。两个k位域之间的关系测试,例如x <Y,需要k(k + 1)=2个这样的规则。为了同时测试两个单独使用n1和n2规则的条件,我们需要n1和n2规则。P4直接支持这类测试,但在OpenFlow中以这种方式实现它们的开销太大,所以我们在OVS中添加了对它们的直接支持,作为条件操作,一种用于OpenFlow操作的if语句。例如,我们的扩展允许P4编译器发出一个形式的动作,如果x <Y,转到表2,否则转到表3。

    一般的校验和验证/更新。

    IP路由器应该在入口验证校验和,然后在出口重新计算,大多数硬件交换机都是这样做的。软件路由器通常在进入时跳过校验和验证以减少CPU周期。相反,如果它改变了任何字段(例如TTL),它只是增量地更新校验和目前,OVS只支持增量校验和,但我们希望以程序员希望的方式支持校验和的其他用途。因此,我们添加了增量校验和优化。这种优化是否有效取决于P4交换机是作为给定数据包的转发元素还是终端主机(如果它是终端主机的话),然后它必须验证校验和,所以它需要P4程序员的注释。

    编译器的后端优化器

    软件交换机的最终影响转发性能两个方面:(1)快速路径处理的每个包的成本(增加100周期成本降低了开关s吞吐量约500 Mbps),和(2)发送的数据包数量缓慢的路径,以50 +倍周期的快速路径处理数据包。下表列出了我们已经实现的优化,以及优化是否减少了慢路径的行程、快路径的CPU周期,或者两者都减少了。本节的其余部分将详细介绍这些优化。

    在这里插入图片描述

    后端优化以及它们如何提高性能

    内联编辑vs.流水线后编辑

    OVS快速路径执行内联编辑,立即应用包修改(缓慢路径做一些简单的优化,以避免冗余或不必要的修改)。如果许多报头字段被修改,删除或插入,它可以成为昂贵的移动和调整数据包数据的动态。相反,延迟编辑直到头文件被处理后(就像硬件开关通常做的那样)会更有效。优化器分析IR,以确定在流水线中一个包可能需要修改多少次。如果值低于某个阈值,则优化器执行内联编辑;否则,它将执行流水线后编辑。我们允许程序员使用一个pragma指令来覆盖这个启发式。

    增量校验和。

    通过用高级程序描述(如P4)来表示校验和操作,程序员可以向编译器提供必要的上下文信息,以便更有效地实现校验和。例如,程序员可以通过注释通知编译器,每个包的校验和可以递增计算,然后,优化器可以执行数据流分析,以确定哪个包报头字段发生了变化,从而使校验和的重新计算更加有效。

    解析器专业化

    协议无关的软件交换机可以优化包解析器的实现,因为定制的包处理管道(在高级语言如P4中指定)提供了关于包中的哪些字段被修改或用作转发决策的基础的特定信息。例如,不根据其他层的信息做出转发决策的第二层交换机可以避免在那些层中解析包报头字段。在高级语言中指定转发行为可以为编译器提供可以用来优化解析器的信息。

    动作专业化

    OVS快速路径中的内联编辑操作将经常同时设置的相关字段组合在一起。例如,OVS实现了一个单一的快速路径动作,设置IPv4源、目的、服务类型和TTL值。当多个字段同时更新时,这种方法是有效的,如果只更新一个字段,边际成本很小。IPv4有许多其他字段,但快速路径不能设置其中任何一个。

    OVS这方面的设计需要领域专业知识:其设计者知道哪些领域对于能够快速改变非常重要。P4编译器不具备将哪些字段组合在一起的专家知识,这可能会导致将太少或太多的字段组合到单个操作中产生成本。幸运的是,匹配操作控制流的高级P4描述允许优化器使用诸如死代码消除之类的优化来识别和消除快速路径设置操作中的冗余检查。这样,优化器只检查将在匹配操作控制流中实际设置的set操作中的那些字段。

    动作合并

    通过分析P4程序中的控制流和匹配操作处理,编译器可以发现哪些字段实际上被修改了,并可以生成一个有效的、单一的操作来直接更新这些字段。因此,如果一个规则修改了两个字段,那么优化器在OVS中只安装一个操作。

    缓存字段修改

    网络协议数据平面很少需要对报头字段进行算术操作。TTL减量操作是最明显的反例;上面已经讨论过的校验和是另一个问题。因此,OVS快速路径不包括通用的算术运算。事实上,它们也不包括特殊用途的TTL减量操作。相反,要实现专用的OpenFlow动作来减少TTL,慢路径依赖于这样一个事实:来自给定源的大多数包都具有相同的TTL。因此,它会发出一个缓存条目,与它正在转发的包中观察到的TTL值匹配,并用一个比观察到的值小的值覆盖这个值,这种方法我们称为match-and-set。对于TTL的减少,这种解决方案是可以接受的,因为OVS设计者知道这种缓存方式在实践中会产生很高的命中率

    match-and-set并不总是合适的。考虑更新IPv4或IPv6的校验和给定的一些其他IP字段的变化。使用匹配和设置方法,缓存条目必须匹配每一个对校验和有贡献的字段,即每一个IP字段,这将使缓存条目的命中率几乎降低到零。对于P4支持的更简单的算术操作也是如此,比如增加或减少字段值,最后,PISCES无法知道在给定的情况下match-and-set是否合适。

    PISCES所采用的解决方案是,通过自动生成快速路径操作来实现P4程序所需的特定算术操作,在可能的情况下避免匹配和设置。例如,如果程序增加一个特定的字段,PISCES会生成一个快速路径操作来增加该字段。这在P4程序盲目执行算术操作时是有效的,否则不会匹配修改后的字段的值。如果程序确实匹配它,那么,按照通常的缓存规则,缓存条目必须匹配字段,因此需要匹配和设置方法。

    分阶段指派算法

    OVS实现分段查找,以减少到慢路径的次数。分段查找将字段划分为一个有序的组列表,称为阶段。每个阶段都是累积的,因此第一个阶段之后的每个阶段都包含前一个阶段的所有字段以及其他字段。最后一个阶段包含每个字段。OVS在其元组空间搜索分类器中将每个阶段实现为一个单独的哈希表。分类器查找将按顺序搜索每个阶段。如果任何搜索都没有得到匹配,整个搜索将终止,只有最后阶段包含的字段必须在缓存条目中匹配。

    OVS使用了四个阶段:第一个阶段是元数据字段(如报文的入端口),第二个阶段是元数据和二层字段,第三个阶段是添加三层字段,第四阶段是所有字段(即元数据、二层、三层、二层、二层).这种顺序是基于这样的原则:对于网络,当阶数对应于场观测值熵的增加阶数时,阶数最有效。例如,在通常情况下,只匹配元数据的缓存条目可能比只匹配第四层字段的缓存条目的命中率更高,因此元数据首先出现在更早的阶段(第一阶段),而不是第四层字段(最后阶段)。

    分段查找可推广到任意P4程序。这个顺序不能从P4程序中推断出来,所以PISCES需要帮助来选择合适的阶段。我们增强了P4语言,使用户能够用阶段编号注释每个头文件。阶段的数量与头文件的数量相同。

    展开全文
  • 与此同时在日常工作中,交换机故障的现象是多样的,故障的原因也是多样的,本文将交换机分为硬件和软件故障,并针对性地进行分析,逐类排除。一、交换机硬件故障:交换机故障一般可以分为硬件故障和软件故障两大类。...
  • 网络基础设施可以由各种交换机组成,这些交换机可能有不同的品牌和型号,这会使它们的管理和管理复杂化。 该软件允许管理网络上存在的不同交换机,并使用 C# 和 .NET Framework 进行编程。
  • 交换机结构原理

    千次阅读 2020-03-14 15:02:33
    1、硬件结构 2、软件结构
  • 交换机的基本架构是由带有多个RJ45接口,PHY,MAC等模块的网络接口控制器和管理由各个NIC分配的收发帧缓存,转发表的软件组成,通过参考转发表信息,在NIC之间进行数据帧交互 交换机的基本架构 ...
  • 使用开源交换机(Open vSwitch)软件

    千次阅读 2020-03-29 12:07:05
    文章目录Open vSwitch安装及部署Open vSwitch网桥管理网桥相关的基本概念常用的网桥命令,进行网桥和端口的添加、删除、查看等操作 ...  在网络中,交换机和桥概念类似,Open vSwitch是一个虚拟交换软件,也就是...
  • 现如今,交换机已经普及到了各办公场所,商场,学校,医院等等几乎所有的需求上网的地方,各大光纤交换机厂商也加大了研发速度,使得...光纤交换机故障一般可以分为硬件故障和软件故障两大类。 一. 交换机的硬件故障
  • 交换机和路由器基础

    2022-09-04 16:43:13
    交换机组成和启动过程
  •  ConneXview能够实现如下功能: 自动识别网络结构,网络上连接的设备以及ConneXium交换机组成的冗余环拓扑结构- 以图形界面的形式显示网络当前拓扑结构,并在线实时监视网络状态 利用不同的颜色来标识网络以及...
  • 交换机芯片笔记1.1

    2021-05-26 16:24:36
    一、基本的概念 出于安全原因并非所有的端口都支持...Note:寄存器分为端口、全局1、全局2和TCAM组成的组,还有一个用于访问PHY的组 1.1.3MAC 该设备有12个MAC:执行802.3协议中的所有的功能包括如下的退避等。 1.1
  • 但是二层交换机的升级产品:三层交换机,没翻车,一个顶俩,很给力。它既有交换机的全部功能,又有路由器的部分功能,一台设备就实现局域网内的数据高速转发。接下来,我们就详细介绍下三层交换机。 1、什么是三层...
  • 三层交换机(理论)

    千次阅读 2020-08-03 21:02:30
    目前的三层交换机一般是通过VLAN来划分二层网络并实现二层交换的,同时能够实现不同VLAN间的三层IP互访. (1)源主机在发起通信之前,将主机的IP与目的主机的IP进行比较,如果两者位于同一个网段(用网络掩码计算后...
  • 三,交换机的工作原理 交换机以太网接口的工作模式 交换机以太网接口速率 四,交换机基本命令 一,数据链路层 功能: 数据链路的建立,建立与拆除 帧包装,帧传输,帧同步 帧的差错恢复 流量控制 二,...
  • 主要由主机(也称呼为端系统)、通信链路(双绞线、光纤)、交换设备(路由器、交换机)和通信处理机(网卡)等组成 软件 各种实现资源共享的软件和方便用户使用的各种工具软件(你常用的软件基本都是) 协议 ...
  • 25 张图详解交换机:秒懂二层交换机的 16 个问题

    千次阅读 多人点赞 2021-11-19 10:45:50
    下面我们来看看最常见的网络设备——交换机。 1、什么是中继器? 中继器( repeater )是一种信号增强设备,运行在 OSI 参考模型的第一层。它的功能仅仅是将信号重新输出,延迟网络的传输距离,不进行其它的数据控制...
  • 文章目录一、数据链路层1、数据链路层的功能2、以太网的发展3、以太网MAC地址4、以太网帧格式二、以太网交换机1、交换机设备简介2、交换机的...交换机配置前的软件连接3、交换机常用的命令3.1 常用命令3.2 远程登录设置...
  • 用户可以在软件的图形用户界面上直接使用拖曳方法建立网络拓扑,并可提供数据包在网络中行进的详细处理过程,观察网络实时运行情况。可以学习IOS的配置、锻炼故障排查能力。Cisco Packet Tracer补充物理设备在课堂上...
  • -理解交换机转发原理 -能完成交换机的基本配置 提示:以下是本篇文章正文内容,下面案例可供参考 参考 : https://blog.csdn.net/weixin_51486343/article/details/109219242 一、数据链路层  数据链路层...
  • 交换机系统配置实验心得5

    千次阅读 2021-07-09 09:03:53
    你还在为交换机基本配置实验报告而烦恼么?不用担心,下面就是小编带来的交换机系统配置实验心得,希望能帮助大家!交换机系统配置实验心得1单交换机的VLAN配置【基本原理】 VLAN(Virtual Local AreaNetwork,虚拟...
  • OpenFlow交换机的数据路径由流表和与每个流条目相关联的操作组成。OpenFlow交换机支持的操作集是可扩展的,但下面我们将描述对所有交换机的最低要求。为了高性能和低成本,数据路径必须具有仔细规定的灵活性程度,...
  • 交换机

    千次阅读 2019-09-21 13:58:45
    交换机的分类 1、按照管理划分 网管交换机 非网管交换机 2、按照工作层次分 2层交换机 数据链路层 3层交换机 网络层 4层交换机 可以依靠传输层的端口进行转发 3、按照网络拓扑结构分 1、接入层交换机 : 将计算机和...
  • 交换机的简单介绍

    2021-07-26 08:39:52
    交换机简单介绍与基本配置1.2.1交换机组成交换机是一台特殊的计算机,也由硬件和软件两部分组成, 其软件部分主要包括操作系统(如IOS)和配置文件,硬件部分主要包含CPU、端口和存储介质。局域网交换机的端口主要有...
  • 交换机基础知识

    千次阅读 2021-01-12 13:50:01
    交换机基础知识以太网交换机演进史 以太网交换机演进史 随着以太网的飞速发展,以太网交换机凭着高性能,低成本的优势在不断演进。目前已经成为应用最广泛的网络设备。早期的以太网设备如集线器是物理层设备,不能...
  • 硬件仍然是数据中心网络设备的重要组成部分,但交换机软件的影响力不容小觑。 如果不是在有关软件定义网络(SDN)的对话中,我们很难将软件和网络相提并论。但是,数据中心网络中交换机软件的作用与SDN没有太多关系。...
  • 提起核心交换机与普通交换机有什么区别?相信很多朋友都有点迷惑,今天我们一起来了解下。核心交换机并不是交换机的一种类型,而是放在核心层(网络主干部分)的交换机叫核心交换机。一般大型企业网络和网吧需要购买...
  • 公众号回复:干货,领取价值58元/套IT管理体系文档公众号回复:ITIL教材,领取最新ITIL4中文教材更多专业文档请访问 www.itilzj.com提起核心交换机与普通交换机有什么区别...
  • 华为交换机配置SNMP

    千次阅读 2022-06-27 10:50:11
    网管系统可以通过SNMP协议对网络设备(包括交换机、路由器、防火墙等)进行监测和管理。SNMP是被广泛接受并投入使用的工业标准,用于保证管理信息在任意两点间传送,便于网络管理员在网络上的任何节点检索信息、修改...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 37,939
精华内容 15,175
热门标签
关键字:

交换机软件组成