精华内容
下载资源
问答
  • cisco交换机配置ssh远程登陆

    千次阅读 多人点赞 2019-09-11 21:25:53
    前言: 最近整理一些以前的学习笔记(有部分缺失,会有些乱,日后再补)。 过去都是存储在本地,此次传到网络留待...cisco SSH远程登陆配置 0.配置ip,启动端口 Switch>enable //进入特权模式 Switch#config...

    前言:

    最近整理一些以前的学习笔记(有部分缺失,会有些乱,日后再补)。
    过去都是存储在本地,此次传到网络留待备用。


     

    cisco SSH远程登陆配置

    0.配置ip,启动端口

    Switch>enable						            //进入特权模式
    Switch#configure terminal				        //进入全局模式
    Switch(config)#interface vlan 1                 //进入端口vlan1
    Switch(config-if)#ip address 设置ip 子网掩码	//设置ip
    Switch(config-if)#no shutdown			        //启动端口
    

    1.配置hostname和domain-name

    · rsa的秘钥是用hostname和domain-name产生的
      Switch> enable
      Switch# configure terminal
      Switch(config)# hostname Switch-ssh             //修改设备名,配置ssh的时候不能为router
      Switch-ssh(config)# ip domain-name test.com     //修改域名,配置ssh必须
      Switch-ssh(config)# aaa new-model               //开启3a认证(部分已开启)
    

    2.生成RSA秘钥

    · 生成RSA秘钥后ssh服务会自动开启,反之会自动关闭
    Switch-ssh(config)# crypto key generate rsa         //生成RSA秘钥
        How many bits in the modulus [512]: 768         //设置秘钥长度,指定ssh2版本要求至少768
        %SSH-5-ENABLED: SSH 1.5 has been enabled        //ssh自动开启
    Switch-ssh(config)# crypto key zeroize rsa          //删除RSA秘钥
    

    3.创建新用户和密码

    Switch-ssh(config)# username 用户名 privilege 0 secret 密码    //0,ssh时不会自动进入特权模式
    

    4.配置enable特权密码

    Switch-ssh(config)# enable secret 密码
    

    5.配置vty(虚拟终端)

    Switch-ssh(config)# line vty 0 4                    //4,最大并行连接数
    Switch-ssh(config-line)# transport input ssh        //只允许用ssh登陆
    Switch-ssh(config-line)# exec-timeout 10 0          //超时时间
    Switch-ssh(config-line)# logging synchronous        //光标跟随,同步信息输出
    Switch-ssh(config-line)# login local                //本地密码检测
    

    6.ssh的其他设置

    Switch-ssh(config)# ip ssh authentication-retries 2    //ssh认证失败的次数
    Switch-ssh(config)# ip ssh time-out 120                //ssh超时时间,单位秒
    Switch-ssh(config)# ip ssh version 2                   //指定ssh的协议版本
    Switch-ssh(config)# ip ssh source-interface f0/0       //指定ssh的接口(vlan也可以)
    

    7.保存配置

    # write
    

    8.测试登陆

    • 在cisco设备上使用ssh命令需要指定用户(若本地未配置username)
      # ssh -l 交换机用户名 交换机ip地址
          Password:用户密码
      # sw_ssh>enable
          Password: 特权密码
      

    转载于:https://my.oschina.net/xinsui1314x/blog/3078047

    展开全文
  • 网络设备如何配置SSH远程登陆

    从事网络运维工作的小伙伴们都知道,在交换机正式上线时,必须完成配置SSH远程登录,这样做目的是为了日后,维护方便,不需要每次登录设备都要跑到机房,这样既不现实,又费事。

    远程登录方式

    目前网络设备中主流的两种远程登录方式是,一种是SSH,另外一种是Telent。两种远程登录方式差不较大,其中Telnet在传输中采用的明文,相对于不安全。而SSH采用的是加密方式传输。

    Telent方式登录,通过抓包中可以看到明文传输的密码。相对于SSH方式,Telnet方式相对于不安全。
    在这里插入图片描述

    案例分享

    2.1、拓扑图

    在这里插入图片描述

    2.2、配置交换机vlanif 1接口IP地址

    [SW1]interface Vlanif 1 #进入vlan1的配置模式
    [SW1-Vlanif1]ip address 192.168.56.10 24 #配置vlan1接口ip地址
    

    2.3、创建用户以及密码

    [SW1]aaa  #进入AAA
    [SW1-aaa]local-user sshuser password cipher admin privilege level 3 #设置用户名密码、用户等级
    

    2.4、在本地设备服务端生成秘钥对

    [SW1]rsa local-key-pair create #创建密钥对
    

    在这里插入图片描述

    2.5、打开服务以及认证方式

    [SW1]stelnet server enable  #使能SSH服务
    [SW1]ssh user sshuser authentication-type password  #认证模式为密码模式
    [SW1]ssh user sshuser service-type stelnet  #服务方式
    

    验证

    在这里插入图片描述
    通过以上几个简单的步骤配置,就完成了一台交换机的ssh远程登录。

    展开全文
  • [Huawei] rsa local-key-pair create //创建rsa本地密钥对 [Huawei]aaa //进入aaa模式 ...[Huawei-aaa]local-user admin service-type ssh //配置登录类型为SSH [Huawei-aaa]quit //退出 [Huawei]user-int

    [Huawei] rsa local-key-pair create //创建rsa本地密钥对

    [Huawei]aaa //进入aaa模式

    [Huawei-aaa]local-user admin password ciper mima //配置登录用户密码(admin是登录用户名,mima是登录密码)

    [Huawei-aaa]local-user admin service-type ssh //配置登录类型为SSH

    [Huawei-aaa]quit //退出

    [Huawei]user-interface vty 0 4 //配置用户虚拟端口

    [Huawei-ui-vty0-4]authentication-mode aaa //认证类型为3a

    [Huawei-ui-vty0-4]user privilege level 15 //配置用户级别

    [Huawei-ui-vty0-4]protocol inbound ssh //配置允许ssh登入

    [Huawei-ui-vty0-4]quit //退出

    [Huawei]stelnet server enable //开启SSH服务

    [Huawei]ssh user admin authentication-type password //配置admin用户设置ssh认证为password

    [Huawei]ssh user admin service-type stelnet //配置admin用户设置ssh服务类型为stelnet

    [Huawei]ssh server port 22622 //配置ssh登录端口为22622,默认是22

    --------------------------------------------------------------------------------------------------
    上云就用博瑞云
    www.boruiwl.cn

    展开全文
  • 华为交换机S5700设置远程ssh telnet登录 AAA是指:authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和...

    华为交换机S5700设置远程ssh telnet登录

    AAA是指:authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处radius(远程拨号认证系统)服务或hwtacacs(华为终端访问控制系统)服务器完成认证/授权;AAA是基于用户进行认证、授权、计费的,而NAC方案是基于接入设备接口进行认证的,在实际应用中,可以使用AAA的一种或两种服务

    如果是一台刚初始化过的华为交换机,需要输入两次相同的密码作为登录交换机的登录密码

    交换机上有console 端口 MEth管理端口 usb端口

    通过串口线配置S5700 的管理IP地址,串口线接在交换机的console口,ip设置完成后网线接在ETH口:

    system-view
    [Quidway] interface MEth 0/0/1
    [Quidway] interface MEth 0/0/1
    [Quidway-MEth0/0/1]ip address x.x.x.x 255.255.255.0 ///设置MEth管理端口的ip地址
    [Quidway-MEth0/0/1]quit
    [Quidway]ip route-static 0.0.0.0 0.0.0.0 x.x.x.x(gateway)
    [Quidway-MEth0/0/1]display ip interface MEth 0/0/1 ///查看MEth管理端口的配置信息
    [Quidway]

    添加用户,设置ssh telent远程登录
    system-view ///进入系统配置模式
    [Quidway]aaa ///进入AAA模式
    [Quidway-aaa]local-user chy password cipher qaz123456 ///设置本地用户名和密码 cipher加密
    [Quidway-aaa]local-user chy service-type ssh telnet ///设置用户设置登录ssh telnet服务
    [Quidway-aaa]display ssh server status             ///查看ssh服务是否生效
    [Quidway-aaa]display telnet server status           ///查看telnet服务是否生效
    [Quidway-aaa]local-user chy privilege level 15 ///设置用户级别
    [Quidway-aaa]q ///退出AAA模式

    设置vty 0 4远程登陆的虚拟端口

    VTY是路由器的远程登陆的虚拟端口,0 4表示可以同时打开5个会话,line vty 0 4是进入VTY端口,对VTY端口进行配置,比如说配置密码,或者ACL.

    [Quidway]user-interface vty 0 4 ///进入vty 0 4远程虚拟端口
    [Quidway-ui-vty0-4]authentication-mode aaa ///为虚拟用户终端配置AAA身份验证模式
    [Quidway-ui-vty0-4]user privilege level 15 ///为虚拟用户终端配置用户级别
    [Quidway-ui-vty0-4]protocol inbound all ///为虚拟用户终端配置使用的协议,all即都支持
    [Quidway-ui-vty0-4]protocol inbound telnet ///为虚拟用户终端配置telnet协议,即可以使用telnet远程登录
    [Quidway-ui-vty0-4]protocol inbound ssh ///为虚拟用户终端配置ssh协议,即用户可以使用ssh远程登录
    [Quidway]ssh user chy authentication-type password ///为chy用户设置ssh认证为password,此命令对设置单一用户设置来说比较实用
    [Quidway]ssh authentication-type default password ///设置ssh默认的认证方式为密码认证,对设置多个用户来说很实用
    [Quidway]ssh user chy service-type stelnet ///为chy用户设置ssh认证服务类型为stelnet
    [Quidway]display ssh user-information chy ///查看ssh服务chy用户的配置信息
    [Quidway]q                        ///退出系统设置视图
    save                      ///保存设置

    配置登陆IP地址
    system-view //进入系统配置模式
    [Quidway]interface Vlanif 1 //进入三层 vlanif 接口
    [Quidway-Vlanif1]ip address 192.168.0.1 255.255.255.0 //配置管理 IP 地址

    创建web登录管理账号

    [Quidway]http server enable ///系统视图下开启http服务
    [Quidway]http secure-server enable ///系统视图下开启http安全服务 即https
    [Quidway]aaa //系统视图下进入aaa模式
    [Quidway-aaa]local-user admin privilege level 15 ///配置 http 登录名权限
    [Quidway-aaa]local-user admin service-type http /// 开启 http 登录服务
    [Quidway-aaa]quit /// 退出aaa模式

    创建vlan

    system-view           ///进入系统配置模式
    [Quidway]vlan 10             ///创建vlan 10
    [Quidway-vlan10]quit           ///退出系统配置模式
    [Quidway]interface Vlanif 10        ///进入配置vlan 10的模式
    [Quidway-Vlanif10]ip address 192.168.0.1 255.255.255.0 ///为vlan 10配置IP地址和掩码
    [Quidway-vlan10]quit           ///退出系统配置模式
    [Quidway-GigabitEthernet0/0/2]       ///进入端口2
    [Quidway-GigabitEthernet0/0/2]port link-type access  ///端口类型设置为access
    [Quidway-GigabitEthernet0/0/2]port default vlan 10   ///将port加入到我们创建好的vlan 10
    [Quidway-GigabitEthernet0/0/2]display vlan     ///查看配置的vlan信息
    [Quidway]q                         ///退出系统设置视图

    批量创建vlan

    system-view           ///进入系统配置模式
    [Quidway]vlan batch 2 to 19            ///批量创建vlan 2-19 ,系统都会有一个默认的vlan 1
    [Quidway]display vlan               ///查看vlan信息
    [Quidway]q                      ///退出系统设置视图

    批量删除vlan

    system-view           ///进入系统配置模式
    [Quidway]undo vlan batch 2 to 19      ///批量删除vlan 2-19 ,系统都会有一个默认的vlan 1
    [Quidway]display vlan            ///查看vlan信息
    [Quidway]q                  ///退出系统设置视图

    批量把端口加入到vlan 10

    system-view           ///进入系统配置模式
    [Quidway]interface range GigabitEthernet 0/0/1 to GigabitEthernet 0/0/6
    ///将1口到6口添加到port-group,此处系统默认的给1口到6口添加到1个组里了。
    [Quidway-port-group]port link-type access   ///将port-group组内的端口全部改为access口
    [Quidway-port-group]port default vlan 10    ///将port-group组内的端口全部加入到vlan 10
    [Quidway]q                    ///退出系统设置视图

    或者先创建一个端口组,再添加到vlan中

    system-view           ///进入系统配置模式
    [Quidway]port-group 1           ///创建端口组,组名为1
    [Quidway-port-group-1]group-member GigabitEthernet 0/0/7 to GigabitEthernet 0/0/17  ///把端口7到17添加到端口组1中
    [Quidway-port-group-1]port link-type access ///将port-group-1组内的端口全部改为access口
    [Quidway-port-group-1]port default vlan 20  ///将port-group-1组内的端口全部加入到vlan 20
    [Quidway-port-group-1]display vlan     ///查看配置的vlan信息
    [Quidway-port-group-1]q            ///退出端口组1的配置模式
    [Quidway]q                ///退出系统设置视图

    删除vlan----需要先删除vlanif信息—再删vlan

    system-view           ///进入系统配置模式
    [Quidway]undo interface Vlanif 10     ///删除vlanif 10
    [Quidway]display vlan            ///查看vlan配置
    [Quidway]display current-configuration ///发现vlan配置还在,vlanif配置已经不在
    [Quidway]undo vlan 10            ///删除vlan 10
    [Quidway]display vlan            ///查看vlan配置,发现vlan 10已经不在
    [Quidway]display current-configuration ///发现vlan配置不在,vlanif配置也不在,但是port信息还有,单独删port信息太慢

    批量删除port信息

    对于上面我们已经把vlanif信息删除,vlan删除,但是display current-configuration发现

    之前创建的port信息还是在的,一个一个删太慢,这里我们还创建组去删

    system-view           ///进入系统配置模式
    [Quidway]port-group 2            ///创建port组2
    [Quidway-port-group-2]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/6 ///将1口到6口加入到port组2中
    [Quidway-port-group-2]undo port default vlan ///将port组2内的端口vlan配置全部删除
    [Quidway-port-group-2]undo port link-type ///将port组2内的端口类型全部恢复到默认
    [Quidway-port-group-2]display current-configuration ///查看端口信息
    [Quidway-port-group-2]q            ///退出端口组1的配置模式
    [Quidway]q                ///退出系统设置视图

    展开全文
  • 通过交换的console口连接PC,进行如下配置,具体连接方式可参考我另外一篇博客 <HUAWEI(guangkou-48)>sys # 进入系统视图 [HUAWEI(guangkou-48)]aaa [HUAWEI(guangkou-48)-aaa]local-user kobe password ...
  • 一、配置S5700交换机。 1.交换机开启stelnet服务 <Huawei>system-view Enter system view, return user view with Ctrl+Z. [Huawei]sysname LSW4 [LSW4]stelnet server enable //使能stelnet服务。 2.配置...
  • 华为交换机 ssh和Telnet远程登录配置命令 ##定位合肥 ,有没有大的公司招人 ,正在考IE中 联系方式 QQ481715271 ** 简单拓扑 ** LSW4 vlan 20配置地址的原因是SSH Telnet 都可以登录 LSW3 配置 vlan batch 10 20 ...
  • Cisco交换机配置SSH登录

    千次阅读 2014-04-04 23:46:48
    前言Ssh是加密通讯而telnet是明文通讯,所以在保密要求较高的网络需要使用ssh来管理...一般支持SSH的IOS版本文件名中都带有K3或者K4字样,K3代表56bitSSH加密,K4代表168bitSSH加密(在交换机上通过执行showver来...
  • 华为交换机配置SSH

    2014-04-05 15:43:24
    华为交换机配置SSH SSH是在传统的Telnet协议之基础上发展起来的一种安全的远程登录协议,相比于Telnet,SSH无论是在认证方式或者数据传输的安全性上,都有很大的提高,而且部分企业出于安全的需求交换机管理必须通过...
  • 如何利用华为交换机配置SSH登录

    千次阅读 2017-11-17 12:04:00
    SSH是在传统的Telnet协议之基础上发展起来的一种安全的远程登录协议。相比于Telnet,SSH无论是在认证方式或者数据传输的安全性上,都有很大的提高。 步骤一、生成本地密钥对 [Huawei]rsa local-key-pair create The ...
  • H3C交换机配置SSH登录

    2019-09-14 04:42:59
    使用串口和网口转接线连接电脑和交换机,使用PuTTY通过串口连接交换机 # 生成 RSA 密钥对 <H3C>system-view [H3C] public-key local create rsa # 生成 DSA 密钥对 [H3C] public-key local creat...
  • h3c交换机配置ssh密码验证登录方式

    万次阅读 2018-11-07 17:45:57
    一、背景: 1、由于PC机串口不支持热插拔,请不要在交换机带电的情况下,将串口插入...2、恢复出厂设置交换机 &lt;H3C&gt;reset saved-configuration 3、重启设备 必须重启才能生效 二、VLAN配置 1...
  • 交换机的telnet远程登录配置。1) 掌握交换机命令行各种操作模式的区别,以及模式之间的切换 2) 掌握交换机的全局基本配置 3) 掌握交换机端口的常用基本配置参数 4) 查看交换机系统和配置信息和当前交换机的工作状态
  • CiSCO 交换机配置 SSH 登陆

    千次阅读 2017-03-10 23:37:00
    CiSCO 交换机配置 SSH 登陆 题目:在三层交换机上仅运行 SSH 服务,且用户名和密码的方式登录交换机。 (一)了解主机名与域名 ​ 1、"主机名" 为该设备的名称 ​ 2、"域名" 为该设备所属的所属者 (二)配置主机名...
  • 华为交换机配置ssh rsa认证登录方式

    千次阅读 2016-11-16 10:27:00
    systemrsa local-key-pair createstelnet server enable输入公钥* * *New Key from Linux ssh-keygen```systemrsa peer-public-key newpublic-key-code beginpublic-key-code endpeer-public-key end```配置ssh...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,702
精华内容 3,080
关键字:

交换机配置ssh远程登录