精华内容
下载资源
问答
  • 前天我们发布了关于华为交换机配置,很多朋友多次提到锐捷交换机配置,本期我们来了解锐捷交换机配置。一、基础配置命令1、准备命令>Enable 进入特权模式#Exit 返回上一级操作模式#End 返回到特权模式#...

    前天我们发布了关于华为交换机的配置,很多朋友多次提到锐捷交换机的配置,本期我们来了解锐捷交换机的配置。

    一、基础配置命令

    1、准备命令 

    >Enable 进入特权模式
    #Exit   返回上一级操作模式
    #End   返回到特权模式
    #write memory 或copy running-config startup-config   保存配置文件
    #del flash:config.text   删除配置文件(交换机及1700系列路由器)
    #erase startup-config   删除配置文件(2500系列路由器)
    #del flash:vlan.dat 删除Vlan配置信息(交换机)
    #Configure terminal 进入全局配置模式
    (config)# hostname switchA   配置设备名称为switchA
    (config)#banner motd &      配置每日提示信息 &为终止符
    (config)#enable secret level 1 0 star   配置远程登陆密码为star
    (config)#enable secret level 15 0 star 配置特权密码为star
    Level 1为普通用户级别,可选为1~15,15为最高权限级别;0表示密码不加密
    (config)#enable services web-server 开启交换机WEB管理功能
    Services 可选以下:web-server(WEB管理)、telnet-server(远程登陆)等
    2、查看信息#show running-config       //查看当前生效的配置信息
    #show interface fastethernet 0/3   //查看F0/3端口信息
    #show interface serial 1/2      //查看S1/2端口信息
    #show interface                //查看所有端口信息
    #show ip interface brief          //以简洁方式汇总查看所有端口信息
    #show ip interface         //查看所有端口信息
    #show version               //查看版本信息
    #show mac-address-table       //查看交换机当前MAC地址表信息
    #show running-config       //查看当前生效的配置信息
    #show vlan                 //查看所有VLAN信息
    #show vlan id 10          //查看某一VLAN (如VLAN10)的信息
    #show interface fastethernet 0/1   //查看某一端口模式(如F 0/1)
    #show aggregateport 1 summary    //查看聚合端口AG1的信息
    #show spanning-tree      //查看生成树配置信息
    #show spanning-tree interface fastethernet 0/1   //查看该端口的生成树状态
    #show port-security     //查看交换机的端口安全配置信息
    #show port-security address    //查看地址安全绑定配置信息
    #show ip access-lists listname   //查看名为listname的列表的配置信息
    3、端口的基本配置
    (config)#Interface fastethernet 0/3     //进入F0/3的端口配置模式
    (config)#interface range fa 0/1-2,0/5,0/7-9   //进入F0/1、F0/2、F0/5、F0/7、F0/8、F0/9的端口配置模式
    (config-if)#speed 10   //配置端口速率为10M,可选10,100,auto
    (config-if)#duplex full    //配置端口为全双工模式,可选full(全双工),half(半双式),auto(自适应)
    (config-if)#no shutdown     //开启该端口
    (config-if)#switchport access vlan 10  //将该端口划入VLAN10中,用于VLAN
    (config-if)#switchport mode trunk   //将该端口设为trunk模式,可选模式为access , trunk
    (config-if)#port-group 1     //将该端口划入聚合端口AG1中,用于聚合端口
    4、聚合端口的创建(config)# interface aggregateport 1    //创建聚合接口AG1
    (config-if)# switchport mode trunk    //配置并保证AG1为 trunk 模式
    (config)#int f0/23-24
    (config-if-range)#port-group 1        //将端口(端口组)划入聚合端口AG1中

    5、生成树配置多生成树协议:switch(config)#spanning-tree             //开启生成树协议switch(config)#spanning-tree mst configuration     //建立多生成树协议switch(config-mst)#name ruijie                //命名为ruijieswitch(config-mst)#revision 1   //设定校订本为1switch(config-mst)#instance 0 vlan 10,20      //建立实例0switch(config-mst)#instance 1 vlan 30,40      //建立实例1switch(config)#spanning-tree mst 0 priority 4096   //设置优先级为4096switch(config)#spanning-tree mst 1 priority 8192   //设置优先级为8192switch(config)#interface vlan 10switch(config-if)#vrrp 1 ip 192.168.10.1 //此为vlan 10的IP地址switch(config)#interface vlan 20switch(config-if)#vrrp 1 ip 192.168.20.1 //此为vlan 20的IP地址switch(config)#interface vlan 30switch(config-if)#vrrp 2 ip 192.168.30.1 //此为vlan 30的IP地址(另一三层交换机)switch(config)#interface vlan 40switch(config-if)#vrrp 2 ip 192.168.40.1 //此为vlan 40的IP地址(另一三层交换机)

    6、VLAN的基本配置(config)#vlan 10    //创建VLAN10
    (config-vlan)#name vlanname // 命名VLAN为vlanname
    (config-if)#switchport access vlan 10  //将该端口划入VLAN10中
    某端口的接口配置模式下进行
    (config)#interface vlan 10    //进入VLAN 10的虚拟端口配置模式
    (config-if)# ip address 192.168.1.1 255.255.255.0  //为VLAN10的虚拟端口配置IP及掩码,二层交换机只能配置一个IP,此IP是作为管理IP使用,例如,使用Telnet的方式登录的IP地址
    (config-if)# no shutdown     //启用该端口
    7、端口安全(config)# interface fastethernet 0/1      //进入一个端口
    (config-if)# switchport port-security     //开启该端口的安全功能

    a、配置最大连接数限制(config-if)# switchport port-secruity maxmum 1 //配置端口的最大连接数为1,最大连接数为128(config-if)# switchport port-secruity violation shutdown  //配置安全违例的处理方式为shutdown,可选为protect (当安全地址数满后,将未知名地址丢弃)、restrict(当违例时,发送一个Trap通知)、shutdown(当违例时将端口关闭,并发送Trap通知,可在全局模式下用errdisable recovery来恢复)

    b、IP和MAC地址绑定(config-if)#switchport port-security mac-address xxxx.xxxx.xxxx ip-address 172.16.1.1  //接口配置模式下配置MAC地址xxxx.xxxx.xxxx和IP172.16.1.1进行绑定(MAC地址注意用小写)8、三层路由功能(针对三层交换机)(config)# ip routing       //开启三层交换机的路由功能(config)# interface fastethernet 0/1    (config-if)# no switchport    //开启端口的三层路由功能(这样就可以为某一端口配置IP)(config-if)# ip address 192.168.1.1 255.255.255.0 (config-if)# no shutdown   

    9、三层交换机路由协议(config)# ip route 172.16.1.0 255.255.255.0 172.16.2.1   //配置静态路由

    注:172.16.1.0 255.255.255.0  为目标网络的网络号及子网掩码172.16.2.1 为下一跳的地址,也可用接口表示,如ip route 172.16.1.0 255.255.255.0 serial 1/2(172.16.2.0所接的端口)

    (config)# router rip     //开启RIP协议进程(config-router)# network 172.16.1.0     //申明本设备的直连网段信息(config-router)# version 2        //开启RIP V2,可选为version 1(RIPV1)、version 2(RIPV2) (config-router)# no auto-summary   //关闭路由信息的自动汇总功能(只有在RIPV2支持)(config)# router ospf   //开启OSPF路由协议进程(针对1762,无需使用进程ID)(config)# router ospf 1    //开启OSPF路由协议进程(针对2501,需要加OSPF进程ID)(config-router)# network 192.168.1.0 0.0.0.255 area 0    //申明直连网段信息,并分配区域号(area0为骨干区域)10、IP ACL:交换机采用命名的访问控制列表;分标准(stand)和扩展(extended)两种a、标准ACL(config)#ip access-list stand listname //定义命名标准列表,命名为listname,stand为标准列表(config-std-nacl)#deny 192.168.30.0 0.0.0.255 //拒绝来自192.168.30.0网段的IP流量通过

    注:deny:拒绝通过;可选:deny(拒绝通过)、permit(允许通过)192.168.30.0 0.0.0.255:源地址及源地址通配符;可使用any表示任何IP(config-std-nacl)#permit any(config-std-nacl)#end   //返回

    b、扩展ACL(config)#ip access-list extended listname //定义命名扩展列表,命名为listname,extended为扩展(config-ext-nacl)#deny tcp 192.168.30.0 0.0.0.255 192.168.10.0 0.0.0.255 eq www  //拒绝源地址为192.168.30.0网段的IP访问目的地址为192.168.10.0网段的WWW服务  

    注:deny:拒绝通过,可选:deny(拒绝通过)、permit(允许通过)  tcp: 协议名称,协议可以是udp, ip,eigrp, gre, icmp, igmp, igrp等等。  192.168.10.0 0.0.0.255:源地址及源地址通配符  192.168.30.0 0.0.0.255:目的地址及目的地址通配符  eq:操作符(lt-小于,eq-等于,gt-大于,neg-不等于,range-包含)   www:端口号,可使用名称或具体编号  可以使用的协议名称(或编号)和端口名称(或编号)请打?查询。


    (config-ext-nacl)#permit ip any any   //允许其它通过
    (config-ext-nacl)#end      //返回(config)#interface vlan 10     //进入端口配置模式(config-if)# ip access-group listname in   //访问控制列表在端口下in方向应用;可选:in(入栈)、out(出栈)(config-if)#end     //返回

    注:配置ACL时,若只想对其中部分IP进行限制访问时,必须配置允许其流量通过,否则设备只会对限制IP进行处理,不会对非限制IP进行允许通过处理。

    二、功能配置命令示例

    换机密码(config)#enable secret level 1 0 100
    (config)#enable secret level 15 0 100
    远程登入密码(config)#line vty 0 4(config-line)#password 100(config-line)#end交换机管理IP(config)#interface vlan 1(config-if)#ip address 192.168.1.10 255.255.255.0(config-if)#no shutdown修改交换机老化时间(config)#mac-address-table aging-time 20(config)#end添删vlan(config)#vlan 888(config-vlan)#name a888(config)#no vlan 888添加access口(config)#interface gigabitEthernet 0/10(config-if)#switchport mode access(config-if)#switchport access vlan 10切换assess trunk(config-if)#switchport mode access(config-if)#switchport mode trunk指定特定一个native vlan(config-if)#switchport trunk native vlan 10配置网关:switch(config)#ip default-gateway 192.168.1.254 显示接口详细信息的命令show interfaces gigabitEthernet 4/1 counters接口配置Switch(config)#interface gigabitethernet 0/1 把接口工作模式改为光口。Switch(config-if)#medium-type fiber把接口工作模式改为电口。Switch(config-if)#medium-type copperVLAN配置建立VLAN 100Switch (config)#vlan 100该VLAN名称为ruijieSwitch (config)#name ruijie将交换机接口划入VLAN 中:range表示选取了系列端口1-48,这个对多个端口进行相同配置时非常有用。Switch (config)#interface range f 0/1-48 将接口划到VLAN 100中。Switch (config-if-range)#switchport access vlan 100   
    将接口划回到默认VLAN 1中,即端口初始配置。
    Switch (config-if-range)#no switchport access vlan Switch(config)#interface fastEthernet 0/1

    该端口工作在access模式下
    Switch(config-if)#switchport mode access   

    该端口工作在trunk模式下
    Switch(config-if)#switchport mode trunk    Switch(config)#interface fastEthernet 0/2
    路由配置:添加一条路由。switch (config)#ip route 目的地址 掩码 下一跳    switch (config)#ip route 210.10.10.0 255.255.255.0 218.8.8.8

    AI人工智能-安防课程,安防行业目前难得诚意的在线课程,点击左下角“阅读原文”进行报名,系统化丰富您的“安防+AI”技术储备

    aab9be5fed2f2c1819f8e1cc1af6af8a.gif

    这是关于安防最详细的课程了

    展开全文
  • H3C交换机常用命令1.查看Linux下查看端口状态root@root:~# netstat -an|grep -E "6002|6003"2.H3C交换机显示当前配置[H3C]display current-configuration3.H3C交换机显示arp信息[H3C]dis arp4.H3C交换机显示mac列表...

    H3C交换机常用命令

    e769bc33819b544834f0398094c0118a.png

    1.查看Linux下查看端口状态

    root@root:~# netstat -an|grep -E "6002|6003"

    2.H3C交换机显示当前配置

    [H3C]display current-configuration

    3.H3C交换机显示arp信息

    [H3C]dis arp

    4.H3C交换机显示mac列表信息

    [H3C]dis mac-address

    5.H3C交换机显示端口信息

    [H3C]display interface

    6.进入系统视图

    system-view

    7.打开路由器的telnet功能

    [H3C]telnet server enable

    8.设置允许同时配置路由器的用户数

    [H3C]configure-user count 5

    9.添加本地用户(此处为telnet用户登录时使用的用户名)

    [H3C]local-user telnet

    10.设置telnet用户登录时所使用的密码

    [H3C-luser-telnet]password simple h3c

    11.设置本地用户的服务类型(此处为telnet)

    [H3C-luser-telnet]service-type telnet

    12.设置本地用户的服务级别

    [H3C-luser-telnet]level 3

    13.退出本地用户视图

    [H3C-luser-telnet]quit

    14.进入用户视图

    [H3C]user-interface vty 0 4

    15.选择“scheme”认证方式

    [H3C-ui-vty0-4]authentication-mode scheme

    16.进入某个端口

    [H3C] interface serial 3/0

    17.为该端口设置ip

    [H3C-Serial3/0]ip address 200.1.1.1 255.255.255.0

    18.对该端口进行复位

    [H3C-Serial3/0]undo shutdown

    19.添加一条静态路由

    [H3C]ip route-static 192.168.1.0 255.255.255.0 192.168.0.1

    20.添加一条默认路由

    [H3C]ip route-static 0.0.0.0 0.0.0.0 192.168.0.1

    21.保存配置文件

    [H3C]save

    22.查看某端口的状态

    [H3C]display interface GigabitEthernet 0/0

    23.创建vlan

    [H3C]vlan 10

    24.将某个端口加入到vlan中

    [H3C-vlan100]port ethernet 0/1

    25.创建vlan虚拟口

    [H3C]interface vlan-interface 1

    26.配置ip地址

    [H3C-Vlan-interface100]ip address 192.168.1.4 255.255.255.0

    27.将端口类型设置为trunk

    [H3C]port link-type trunk

    28.设置trunk口允许所有vlan通过(需要执行save保存)

    [H3C]port trunk permit vlan all

    注意:Trunk 可以收发多个vlan的报文,用于交换机与交换机之间的互连

    29.关闭端口

    [H3C-GigabitEthernet1/1/1]shutdown

    30.设置端口备注

    [H3C-Ethernet1/0/15]description 测试数据

    6.切换端口vlan

    81bc893809a2186ced9bae6d3f2f4595.png
    展开全文
  • 1、开始 建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。 在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和...

    1、开始 建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。 在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100。 以太网交换机上电,终端上显示以太网交换机自检信息,自检结束后提示用户键入回车,之后将出现命令行提示符(如)。 键入命令,配置以太网交换机或查看以太网交换机运行状态。需要帮助可以随时键入'?'

    2、命令视图

    (1)用户视图(查看交换机的简单运行状态和统计信息):与交换机建立连接即进入(2)系统视图(配置系统参数)[Quidway]:在用户视图下键入system-view (3)以太网端口视图(配置以太网端口参数)[Quidway-Ethernet0/1]:在系统视图下键入interface ethernet 0/1 (4)VLAN视图(配置VLAN参数)[Quidway-Vlan1]:在系统视图下键入vlan 1 (5)VLAN接口视图(配置VLAN和VLAN汇聚对应的IP接口参数)[Quidway-Vlan-interface1]:在系统视图下键入interface vlan-interface 1 (6)本地用户视图(配置本地用户参数)[Quidway-luser-user1]:在系统视图下键入local-user user1 (7)用户界面视图(配置用户界面参数)[Quidway-ui0]:在系统视图下键入user-interface

    3、其他命令

    设置系统时间和时区clock time Beijing  add 8                   clock datetime 12:00:00 2005/01/23 设置交换机的名称[Quidway]sysname TRAIN-3026-1[TRAIN-3026-1] 配置用户登录[Quidway]user-interface vty 0 4             [Quidway-ui-vty0]authentication-mode scheme 创建本地用户[Quidway]local-user huawei             [Quidway-luser-huawei]password simple huawei             [Quidway-luser-huawei] service-type telnet level 3

    4、VLAN配置方法

    『配置环境参数』 SwitchA端口E0/1属于VLAN2,E0/2属于VLAN3 『组网需求』 把交换机端口E0/1加入到VLAN2 ,E0/2加入到VLAN3 数据配置步骤 『VLAN配置流程』 (1)缺省情况下所有端口都属于VLAN 1,并且端口是access端口,一个access端口只能属于一个vlan; (2)如果端口是access端口,则把端口加入到另外一个vlan的同时,系统自动把该端口从原来的vlan中删除掉; (3)除了VLAN1,如果VLAN XX不存在,在系统视图下键入VLAN XX,则创建VLAN XX并进入VLAN视图;如果VLAN XX已经存在,则进入VLAN视图。

    【SwitchA相关配置】 方法一: (1)创建(进入)vlan2    [SwitchA]vlan 2 (2)将端口E0/1加入到vlan2    [SwitchA-vlan2]port ethernet 0/1 (3)创建(进入)vlan3    [SwitchA-vlan2]vlan 3 (4)将端口E0/2加入到vlan3    [SwitchA-vlan3]port ethernet 0/2 方法二: (1)创建(进入)vlan2    [SwitchA]vlan 2 (2)进入端口E0/1视图    [SwitchA]interface ethernet 0/1 (3)指定端口E0/1属于vlan2    [SwitchA-Ethernet1]port access vlan 2 (4)创建(进入)vlan3    [SwitchA]vlan 3 (5)进入端口E0/2视图    [SwitchA]interface ethernet 0/2 (6)指定端口E0/2属于vlan3    [SwitchA-Ethernet2]port access vlan 3 测试验证 (1)使用命令disp cur可以看到端口E0/1属于vlan2,E0/2属于vlan3; (2)使用display interface Ethernet 0/1可以看到端口为access端口,PVID为2; (3)使用display interface Ethernet 0/2可以看到端口为access端口,PVID为3

    5、交换机IP地址配置

    功能需求及组网说明 『配置环境参数』 三层交换机SwitchA有两个端口ethetnet 0/1、ethernet 0/2,分别属于vlan 2、vlan 3; 以vlan 2的三层接口地址分别是1.0.0.1/24作为PC1的网关; 以vlan 3的三层接口地址分别是2.0.0.1/24作为PC2的网关; 『组网需求』 PC1和PC2通过三层接口互通 【SwitchA相关配置】 (1)创建(进入)vlan2    [Quidway]vlan 2 (2)将端口E0/1加入到vlan2    [Quidway-vlan2]port ethernet 0/1 (3)进入vlan2的虚接口    [Quidway-vlan2]interface vlan 2 (4)在vlan2的虚接口上配置IP地址    [Quidway-Vlan-interface2]ip address 1.0.0.1 255.255.255.0 (5)创建(进入)vlan3    [Quidway]vlan 3 (6)将E0/2加入到vlan3    [Quidway-vlan3]port ethernet 0/2 (7)进入vlan3的虚接口    [Quidway-vlan3]interface vlan 3 (8)在vlan3的虚接口上配置IP地址    [Quidway-Vlan-interface3]ip address 2.0.0.1 255.255.255.0 测试验证 (1)PC1和PC2都可以PING通自己的网关 (2)PC1和PC2可以相互PING通

    6、端口的trunk配置

    『配置环境参数』 (1)SwitchA 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchB端口E0/3互连 (2)SwitchB 端口E0/1属于vlan10,E0/2属于vlan20,E0/3与SwitchA端口E0/3互连 『组网需求』 (1)要求SwitchA的vlan10的PC与SwitchB的vlan10的PC互通 (2)要求SwitchA的vlan20的PC与SwitchB的vlan20的PC互通 数据配置步骤 【SwitchA相关配置】 (1)创建(进入)vlan10   [SwitchA] vlan 10 (2)将E0/1加入到vlan10   [SwitchA-vlan10]port Ethernet 0/1 (3)创建(进入)vlan20   [SwitchA]vlan 20 (4)将E0/2加入到vlan20   [SwitchA-vlan20]port Ethernet 0/2 (5)实际当中一般将上行端口设置成trunk属性,允许vlan透传   [SwitchA-Ethernet0/3]port link-type trunk (6)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值   [SwitchA-Ethernet0/3]port trunk permit vlan all 【SwitchB相关配置】 (1)创建(进入)vlan10   [SwitchB] vlan 10 (2)将E0/1加入到vlan10   [SwitchB-vlan10]port Ethernet 0/1 (3)创建(进入)vlan20   [SwitchB]vlan 20 (4)将E0/2加入到vlan20   [SwitchB-vlan20]port Ethernet 0/2 (5)实际当中一般将上行端口设置成trunk属性,允许vlan透传   [SwitchB-Ethernet0/3]port link-type trunk (7)允许所有的vlan从E0/3端口透传通过,也可以指定具体的vlan值   [SwitchB-Ethernet0/3]port trunk permit vlan all 【补充说明】 (1)如果一个端口是trunk端口,则该端口可以属于多个vlan; (2)缺省情况下trunk端口的PVID为1,可以在端口模式下通过命令port trunk pvid vlan vlanid 来修改端口的PVID; (3)如果从trunk转发出去的数据报文的vlan id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点在配置trunk端口时需要注意。 (4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。 (5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。 测试验证 (1)SwitchA vlan10内的PC可以与SwitchB vlan10内的PC互通 (2)SwitchA vlan20内的PC可以与SwitchB vlan20内的PC互通 (3)SwitchA vlan10内的PC不能与SwitchB vlan20内的PC互通 (4)SwitchA vlan20内的PC不能与SwitchB vlan10内的PC互通

    7、端口汇聚配置

    『配置环境参数』 (1)交换机SwitchA和SwitchB通过以太网口实现互连。 (2)SwitchA用于互连的端口为e0/1和e0/2,SwitchB用于互连的端口为e0/1和e0/2。 『组网需求』 增加SwitchA的SwitchB的互连链路的带宽,并且能够实现链路备份,使用端口汇聚 数据配置步骤 【SwitchA交换机配置】 (1)进入端口E0/1   [SwitchA]interface Ethernet 0/1 (2)汇聚端口必须工作在全双工模式   [SwitchA-Ethernet0/1]duplex full (3)汇聚的端口速率要求相同,但不能是自适应   [SwitchA-Ethernet0/1]speed 100 (4)进入端口E0/2   [SwitchA]interface Ethernet 0/2 (5)汇聚端口必须工作在全双工模式   [SwitchA-Ethernet0/2]duplex full (6)汇聚的端口速率要求相同,但不能是自适应   [SwitchA-Ethernet0/2]speed 100 (7)根据源和目的MAC进行端口选择汇聚   [SwitchA]link-aggregation Ethernet 0/1 to Ethernet 0/2 both  【SwitchB交换机配置】 [SwitchB]interface Ethernet 0/1 [SwitchB-Ethernet0/1]duplex full [SwitchB-Ethernet0/1]speed 100 [SwitchB]interface Ethernet 0/2 [SwitchB-Ethernet0/2]duplex full [SwitchB-Ethernet0/2]speed 100 [SwitchB]link-aggregation Ethernet 0/1 to Ethernet 0/2 both 【补充说明】 (1)同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。 (2)不同的产品对端口汇聚时的起始端口号要求各有不同,请对照《操作手册》进行配置。

    8、端口镜像配置

    『环境配置参数』 (1)PC1接在交换机E0/1端口,IP地址1.1.1.1/24 (2)PC2接在交换机E0/2端口,IP地址2.2.2.2/24 (3)E0/24为交换机上行端口 (4)Server接在交换机E0/8端口,该端口作为镜像端口 『组网需求』 (1)通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。 根据Quidway交换机不同型号,镜像有不同方式进行配置: 基于端口的镜像 ——基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。 基于流的镜像 ——基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。 S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像  8016交换机支持基于端口的镜像 3500/3026E/3026F/3050支持基于流的镜像  5516/6506/6503/6506R支持对入端口流量进行镜像 数据配置步骤 以Quidway S3026C为例,通过基于二层流的镜像进行配置: (1)定义一个ACL    [SwitchA]acl num 200  (2)定义一个规则从E0/1发送至其它所有端口的数据包    [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2 (3)定义一个规则从其它所有端口到E0/1端口的数据包    [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1 (4)将符合上述ACL的数据包镜像到E0/8    [SwitchA]mirrored-to link-group 200 interface e0/8

    9、生成树STP配置

    『配置环境参数』 (1)交换机SwitchA、SwitchB和SwitchC都通过GE接口互连 (2)SwitchB和SwitchC交换机是核心交换机,要求主备。 『组网需求』  要求整个网络运行STP协议 数据配置步骤 (1)【SwitchA交换机配置】   启动生成树协议: [SwitchA]stp enable (1)【SwitchB交换机配置】    启动生成树协议:[SwitchB]stp enable (3)配置本桥为根桥    [SwitchB]stp root primary  (4)【SwitchC交换机配置】    a 启动生成树协议[SwitchC]stp enable    b 配置本桥为备份根桥[SwitchC]stp root secondary (5)【SwitchD交换机配置】    a 启动生成树协议[SwitchD]stp enable 【补充说明】 (1)缺省情况下交换机的优先级都是32768,如果想人为指定某一台交换机为根交换机,也可以通过修改优先级来实现; (2)缺省情况下打开生成树后,所有端口都会开启生成树协议,请把接PC的端口改为边缘端口模式; (3)如果要控制某条链路的状态可以通过设置端口的cost值来实现。 测试验证 (1)使用display stp查看交换机STP运行状态 (2)查看端口STP状态display stp interface Ethernet XX是否正确

    10、Quidway交换机维护

    显示系统版本信息:display version 显示诊断信息:display diagnostic-information  显示系统当前配置:display current-configuration  显示系统保存配置: display saved-configuration 显示接口信息:display interface 显示路由信息:display ip routing-table 显示VLAN信息:display vlan 显示生成树信息:display stp 显示MAC地址表:display mac-address 显示ARP表信息:display arp 显示系统CPU使用率:display cpu 显示系统内存使用率:display memory 显示系统日志:display log  显示系统时钟:display clock 验证配置正确后,使用保存配置命令:save 删除某条命令,一般使用命令: undo

    c05340328bd67733090e3a5c7c3a6ef1.png

       大家好,我是老季,一个做弱电的民工,我将尽我最大的努力做好这个公众号,和大家一起分享,一起学习。这是我的个人微信号,想加入弱电圈子可以添加我的个人号,圈子里都是做弱电的,资源互相补充,实时资源多多。

    89b9a950470c3d36ed37e3d2fb5a3f56.png

    扫一扫,关注本公众号,成为弱电行业高手

    60dc4230841a4ed04638cf01c7190209.png

    喜欢这篇文章,在右下角点个在看,点个赞,谢谢

    展开全文
  • 最近有网友讨论华为三层交换机配置问题,今天小编也整理了下华为交换机的文章,大家来一起学习交流下!1、给交换机划分VLANVlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的...

    最近有网友讨论华为三层交换机的配置问题,今天小编也整理了下华为交换机的文章,大家来一起学习交流下!

    f72564aeb6468e102e78be3e357a21fe.png

    1、给交换机划分VLAN

    Vlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的vlan,比如vlan 2就是编号为2的vlan,只是一个编号而已,并不是说vlan 2的网段一定要是2网段,vlan2的IP地址是可以随便设置的。

    下面我将三层交换机的第20个端口添加到vlan 10里,步骤如下:

    A.在交换机里添加VLAN 10

    system-view (一般用缩写:sys)
    [Quidway] vlan 10 (添加编号为10的vlan)
    [Quidway-vlan10] quit (一般缩写:q)

    B.设置vlan 10的IP地址为192.168.66.66 网关为255.255.255.0

    [Quidway]interface vlanif 10 (interface一般可以缩写为:int ;vlanif也可以只写vlan)

    [Quidway-vlanif10] ip address 192.168.66.66 255.255.255.0 (address缩写add)

    [Quidway-vlanif10]quit

    C.设定交换机上第20个端口模式为access (默认为trunk,需在将端口划入VLAN前转为ACCESS)
    [Quidway] int gigabitethernet 0/0/20 (gigabitethernet:千兆以太网口)
    [Quidway-GigabitEthernet0/0/20] port link-type access (port:端口)
    [Quidway-GigabitEthernet0/0/20]quit

    D.将第20个端口加入到vlan 10里

    [Quidway] vlan 10
    [Quidway-vlan10] port gigabitethernet 0/0/20 (如果是多个连续端口,用XX to XX)
    [Quidway-Vlan10]quit

    这样就是成功的将交换机上的第20个端口添加到了编号为10的Vlan 里,划分VLAN就是这4个步骤,2个步骤设置vlan,2个步骤设置端口。现在可以用网线把交换机的第20个端口和电脑网卡连接起来,设置网卡地址为192.168.66.XX,网关为192.168.66.66,在CMD里ping192.168.66.66可以ping通。

    2、删除VLAN

    A.

    在系统视图下,用“undo int vlan 2”命令删除vlan 2的3层口,这样vlan 2就没有了,但是划分给vlan 2的那些端口依然还处于vlan 2里,这时可以将那些端口释放出来,让他们不再属于任何vlan

    B.

    在系统视图下,用“undo vlan 2”命令删除2层口,这个命令可以释放那些原先划分给了vlan 2的端口,现在它们不属于任何vlan了。

    当然,将交换机上的某个端口更换到某个vlan里,是可以直接在vlan视图里添加端口的。

    注意:交换机上的某个端口被设置成了access模式,且加入了一个vlan,要想将这个端口的模式更改为trunk,直接在端口视图里打上“port link-type trunk”是不行的,会出现Error: Please renew the defaultconfigurations.这时需要先从VLAN里删除这个端口,也就是前面说的让这个端口不属于任何vlan,才能将这个端口设置为trunk。

    3、通过端口进行限速

    现在要对交换机上的第2个端口进行限速操作,让通过这个端口的下载速度不超过128KB/S

    配置命令说明:

    Inbound:对入端口报文进行限速

    Outbound:对出端口报文进行限速

    sys
    [Quidway] intgigabitethernet 0/0/2

    [Quidway-GigabitEthernet0/0/2] qos lr outbound cir 1024 cbs204800 (1024代表1M的带宽,理论下载速度就是128KB/S,204800=1024*200,cbs代表突发信息速率 cir代表承诺信息速率 )

    这个命令执行后,端口2的下载速度就被限制在128KB/S以内,实际测速表明,这个限速数值是该端口数据流量稳定后的速度,它的短暂峰值高出128KB/S很多,这个应该是交换机从侦测端口流量到启动限速需要一个过程,下载速度稳定后是在128KB/S上下徘徊,效果还是不错的,比路由器限速和限速软件的效果都要好很多,最关键的交换机稳定。

    注:取消限速方法

    [Quidway-GigabitEthernet0/0/2] undo qos lr outbound

    4、配置基于地址池的DHCP服务器

    A.全局启动DHCP服务。

    sys

    [Quidway] dhcp enable

    B.配置IP地址池10的属性(地址池范围,dns地址,出口网关,地址池租期)

    [Quidway] ip pool 10

    Info:It's successful to create an IP address pool.

    [Quidway-ip-pool-10] network 192.168.10.0 mask 255.255.255.0

    [Quidway-ip-pool-10] dns-list 202.103.24.68

    [Quidway-ip-pool-10] gateway-list 192.168.10.1

    [Quidway-ip-pool-10] lease day 10

    [Quidway-ip-pool-10] q

    C.将接口GE0/0/1加入到VLAN 10

    [Quidway] vlan 10
    [Quidway-vlan10] port gigabitethernet 0/0/1 (如果是多个连续端口,用XX to XX)
    [Quidway-Vlan10]quit

    D. 配置VLANIF10接口下的客户端从全局地址池中获取IP地址

    [Quidway]int vlan 10

    [Quidway-vlanif10] ip add 192.168.10.1 24

    [Quidway-vlanif10] dhcp select global

    [Quidway-vlanif10] q

    这时,可以用“dis ip pool”命令查看IP地址池配置情况

    最后可以在电脑上验证是否成功

    d5cad6c3ee8a7aa0809928772f4b4247.png

    5、telnet远程登录设置

    system-view

    [Quidway]aaa (进入aaa视图)

    [Quidway-aaa] local-user tcwq passwordcipher tcwq (cipher是暗号的意思,password cipher就是指密码显示出来的是乱码,在用dis cur命令时,看到的密码是乱码)

    [Quidway-aaa] local-user tcwq passwordsimple tcwq (simple是简单的意思,passwor simple:弱口令,可以理解为明文,和cipher是相对的,在用dis cur命令时,看到的密码是明文)

    [Quidway-aaa] local-user tcwq service-type telnet (设置用户tcwq的登录方式为telnet)

    [Quidway-aaa] local-user tcwqprivilege level 3 (privilege level:权限级别,3为最高级别,拥有最高权限)

    [Quidway-aaa] q
    [Quidway]user-interface vty 04 (vty:虚拟终端,0 4代表有0到4一共最多5个终端可以同时登录到交换机)

    [Quidway-vty0-4]authentication-modeaaa (authentication:认证,验证。验证模式设置为aaa模式)

    [Quidway -ui-vty0-4]q

    设置完毕,这时可以在cmd里telnet 网关,即可登录到交换机。

    下面是S5324和S5700成功配置telnet后的截图

    31e29cd0a7904651e63554fb5d7cf5e8.png

    d7b87eaecab27b02bca4e484226c073e.png

    注意:当提示验证失败时,将网卡禁用再启用可以解决问题。

    6、配置FTP服务器

    建立一个FTP服务器,用户名为tcwq,密码为tcwq

    sys

    [Quidway] ftp server enable (开启FTP服务)

    [Quidway] aaa

    [Quidway-aaa] local-user tcwq passwordsimple tcwq

    [Quidway-aaa] local-usertcwq service-type ftp

    [Quidway-aaa] local-usertcwq ftp-directory flash:/ (配置FTP用户的访问路径,如果不配置这一项,登录时会提示“530 logged incorrect”)

    [Quidway-aaa] q

    这时用网线把电脑网卡和交换机的某个端口相连,电脑IP设置为和该端口所在Vlan的网关同一网段的地址(如IP:192.168.1.128,网关:192.168.1.1),在CMD命令行里输入FTP 192.168.1.1即可进入FTP的验证界面,输入账号tcwq,密码tcwq,即可登录

    fc1504109202e0bc45f6fc66e7129ca7.png

    登录到ftp后,可以从交换机的Flash里下载文件到电脑里(下载的文件所在位置是登录到ftp服务器前的盘符,如上图中是从F盘根目录登录到FTP的,那么文件都会被下载到F盘的根目录里),也可以从电脑里选择文件上传到交换机的Flash里(速度很快,比串口烧录快多了),还可以删除flash里文件

    ftp>dir (查看文件)

    ftp>getvrpcfg.zip (下载文件名为“vrpcfg.zip”的文件)

    ftp>put f:\S5700\web.zip (将电脑F盘里名字为S5700的文件夹里的web.zip文件上传的交换机的Flash里)

    ftp>deleteweb.zip (删除文件名为“web.zip”的文件)

    7、WEB网页管理

    三层交换机可以进行网页管理,前提是HTTP服务要开启,且交换机Flash里有web管理文件并被成功加载。

    上一步进行了FTP服务器配置,如果交换机里没有ZIP后缀名的WEB管理文件,就需要先用FTP把WEB管理文件上传到Flash里

    ftp> put f:\S5700\web.zip

    200 Port command okay.

    150 Opening ASCII mode data connection for web.zip.

    226 Transfer complete.

    显示到这里就说明web.zip文件被成功上传到Flash里了。

    下面就需要在终端或者telnet里将刚刚上传的web.zip进行加载

    sys

    [Quidway] http server loadweb.zip (加载web.zip)

    接下来就可以开启HTTP服务了,在没有加载web.zip之前,HTTP服务是开启不了的

    [Quidway] http server enable

    现在建立一个网管账号,账户名xiaodong,密码xiaodong

    [Quidway] aaa

    [Quidway-aaa] local-user xiaodong passwordsimple xiaodong

    [Quidway-aaa] local-user xiaodong service-typehttp

    [Quidway-aaa] q

    这时可以在电脑上打开浏览器,输入192.168.1.1,进入登录验证界面,输入账号xiaodong,密码xiaodong,验证码,即可登录。

    df0d98549b555e7a8c0f6d2c0b8203b8.png

    精品学习资料,有弱电、室分工程学习资料。入行必备,培训必备!

    好消息,资料更新了,39元,买到资料,学习到知识,交到专业朋友,想想都开心

    弱电、室分技术交流群,这里高手如云,学习交流好去处!

    加入弱电技术交流群,学习交流两不误!

    88d438ae52528d4ccfeb515b73e1d0e9.png

    展开全文
  • 最近交流群有讨论华为三层交换机配置问题,今天小编也整理了下华为交换机的文章,大家来一起学习交流下!1、给交换机划分VLANVlan是虚拟局域网的意思,它相当于一个局域网工作组。“vlan几”可以理解成编号为几的...
  • 展开全部TRUNK(端口636f707962616964757a686964616f31333431356633汇聚)是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于...
  • 华三交换机配置vlan命令教程[H3C]vlan 2[H3C]undo vlan all 删除除缺省VLAN外的所有VLAN,缺省VLAN不能被删除[H3C-vlan2]port Ethernet 0/4 to Ethernet 0/7 将4到7号端口加入到VLAN2中,此命令只能用来加access端口,...
  • 有的交换机,例如 2950只能封装 dot1q,因此无需执行该命令。 Switch(config)#interface f0/2 Switch(config-if)#switchport trunk encapsulation dot1q Switch(config-if)#switchport mode trunk Switch...
  • -`H3C交换机配置命令大全1、system-view进入系统视图模式2、sysname为设备命名3、displaycurrent-configuration当前配置情况4、language-modeChinese|English中英文切换5、interfaceEthernet1/0/1进入以太网端口视图...
  • 前面我们给大家汇总了华为、华三交换机配置命令,都是非常适合小项目的,当然碰到大型的网络工程,还是需要厂家的专业人才来做。今天再给大家分享一下锐捷交换机配置命令,这样国内三大家就全部都有了,学习一些...
  • 华为路由器交换机配置命令:计算机命令 PCAlogin:root;使用root用户 password:linux;口令是linux #shutdown-hnow;关机 #init0;关机 #logout;用户注销 #login;用户登录 #ifconfig;显示IP地址 #ifconfigeth0...
  • view进入系统视图模式2、sysname为设备命名3、displaycurrent-configuration当前配置情况4、language-modeChinese|English中英文切换5、interfaceEthernet1/0/1进入以太网端口视图6、portlink-typeAccess|Trunk|...
  • 2.Trunk类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;3.Hybrid类型的端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于...
  • 21. 为了从一条中继链路上删除 VLAN,可使用下列命令:switch(enable) clear trunk module/port vlan-range22. 用 show vtp domain 显示管理域的 VTP 参数.23. 用 show vtp statistics 显示管理域的 VTP 参数.24. 在 ...
  • H3C交换机配置基本命令1、system-view进入系统视图模式2、sysname为设备命名3、displaycurrent-configuration当前配置情况4、language-modeChinese|English中英文切换5、interfaceEthernet1/0/1进入以太网端口视图6...
  • [Huawei]intg0/0/1[Huawei]portlink-typeaccess(注:接口类型access,hybrid、trunk)[Huawei]portdefaultvlan10批量端口放入VLAN[Huawei]port-group1[Huawei-port-group-1]group-memberethernetG0/0/1...
  • 前面我们给大家汇总了华为、华三交换机配置命令,都是非常适合小项目的,当然碰到大型的网络工程,还是需要厂家的专业人才来做。今天再给大家分享一下锐捷交换机配置命令,这样国内三大家就全部都有了,学习一些...
  • 请教下如何删除undo port trunk allow-pass vlan 1这句命令配置管理WLAN和端口如何开WLAN数据,下面是我配置的请指教,因为我以前配置H3C的,现在弄华为的,人人都说配置命令一样,可是我觉得都不一样。下面是我...
  • 记一次h3c交换机端口trunk配置过程

    万次阅读 2016-03-14 14:14:02
    配置h3c交换机时,由于缺少执行了vlan all命令,导致trunk模式下同一vlan下不能正常ping通。 经过试验的配置脚本如下: systemview vlan all #批量配置端口 port-group manual 1 group-member GigabitEthernet 1/0...
  • 华为交换机配置命令

    千次阅读 2013-07-16 21:50:18
    华为交换机配置命令 sys 进入系统视图 interface Gigabitethernet 0/0/1 进入接口视图 ip address 10.10.10.10 255.255.255.0 配置端口的ip地址 description aaa 给接口配置描述信息 port link-trunk {...
  • 给你个绝对可行得办法:[switch]interface g0/0/1 //如果是33系列以下,则是interface ethernet0/0/1[switch-interface g0/0/1]display this //查看当前端口类型,是access,hybrid还是trunk,如果查不到,就说明它...
  • H3C交换机配置命令大全1、system-view进入系统视图模式2、sysname为设备命名3、displaycurrent-configuration当前配置情况4、language-modeChinese|English中英文切换5、interfaceEthernet1/0/1进入以太网端口视图6...
  • 锐捷交换机基本配置命令

    万次阅读 2018-04-19 14:38:55
    show ip interface brief 查看当前配置的ip地址 enable password admin 给enable...switchport trunk allowed vlan all 允许全部vlan通过? show version 查看设备的软件版本信息 show logging 查看设备的日志 ...
  • sysname:设备命名vlan batch vlanid vlanid:定义vlanvlan vlanid/description:注释vlanport-group groupname:定义端口组group-member:端口加人端口组port link-type access trunk hybrid:设置端口模式port ...
  • 一 组网需求:1.SwitchA与SwitchB用trunk互连,相同VLAN的PC之间可以互访,不同VLAN的PC之间禁止互访;2.PC1与PC2之间在不同VLAN,通过设置上层三层交换机SwitchB的VLAN接口10的IP地址为10.1.1.254/24,VLAN接口20...
  • 1、配置端口聚合(H3C) 要求聚合的端口工作在全双工,速度一致,在同一槽口且连续。 参数:ingress:源MAC, both:源和目的MAC 主要命令: [SwitchA]link-aggregation ethernet0/1 to ethernet0/2 both [SwitchB...
  • H3C交换机配置命令大全1、system-view进入系统视图模式2、sysname为设备命名3、displaycurrent-configuration当前配置情况4、language-modeChinese|English中英文切换5、interfaceEthernet1/0/1进入以太网端口视图6...

空空如也

空空如也

1 2 3 4 5 ... 14
收藏数 273
精华内容 109
关键字:

交换机配置trunk命令