精华内容
下载资源
问答
  • 2017-11-17 21:19:00

    一、局域网概念

      LAN是指一个较小的范围内的多台计算机或者其他通信设备,通过双绞线、同轴电缆、等连接介质互相连接起来,以达到资源和信息共享的互联网络。

    二、无线局域网

      协议标准是IEEE802.11,分为有固定基础设施和无固定基础设施。

    (1)有固定基础设施无线局域网组成

      

    一个基本服务集包含一个基站和若干个移动站,所有的站在本基本服务集以内可以直接通信,但是和其他基本服务集的站通信时要通过本基本服务集中的基站。移动站A从一个基本服务集漫游到另外一个基本服务集,仍然可以保持与另外一个移动站B进行通信。门桥相当于一个网桥。

    转载于:https://www.cnblogs.com/isabelle/p/7853534.html

    更多相关内容
  • 计算机网络:局域网协议

    千次阅读 2020-05-24 14:43:12
    根据计算机网络的拓扑结构,可将网络分为总线型、树型、...局域网中传输数据的基本单元“帧”,当采用不同的局域网通信协议时,其中具体的数据帧格式也会不同,目前常见的数据帧格式包括PPP帧和MAC帧。所有的局域网

    根据计算机网络的拓扑结构,可将网络分为总线型、树型、星型、环型和网状型五种类型。常见的局域网组网方式包括令牌环、光纤分布数字接口和以太网等。

    一、概述

    在不同类型的网络拓扑结构中,网络设备的连接方式、传输介质的选择、网络的可靠性及可扩展性均存在差异。在组建网络时,通常需要综合网络功能和性能需求、环境状况和投入成本等因素,以确定所采用的网络拓扑方案。

    局域网中传输数据的基本单元为“帧”,当采用不同的局域网通信协议时,其中具体的数据帧格式也会不同,目前常见的数据帧格式包括PPP帧和MAC帧。所有的局域网通信协议都需要解决帧定界、透明传输和差错检测这三个基本问题。

    常见的局域网组网方式包括令牌环、光纤分布数字接口(FDDI,Fiber Distributing Data Interface)和以太网等。

    1.令牌环

    令牌环网络的拓扑结构为环型拓扑,它使用同轴电缆作为传输介质,抗干扰性强。在令牌环网络中,使用一种被称为令牌的特殊数据帧进行访问控制,令牌循环遍历环路中的每台主机,主机在接收到令牌后才能发送数据。这种网络的结构固定,不便于网络拓展和增加主机,且维护令牌需要付出额外代价,在令牌损坏后,整个网络将不能正常工作。

    2.光纤分布数字接口

    光纤分布数字接口FDDI的网络拓扑结构同样为环型拓扑,采用光纤作为传输介质,有着较高的网络带宽。FDDI组网方式只支持采用光缆或5类电缆作为传输介质,这种组网方式成本较高,多用于连接多个局域网的骨干网。

    3.以太网

    以太网相对于前两种方式具有结构简单、成本低的特点,在实际应用中也更为常见。以太网使用双绞线作为传输介质,最大覆盖半径可达数百米之内。随着以太网技术的发展,其数据传输速率可达到从10Mbps到100Gbps不等。

    二、PPP帧与MAC帧

    数据链路层的常用信道有两种,即点对点信道和广播信道。

    在点对点信道中,发送端仅发送数据给接收端,是一种一对一的通信方式。

    在广播信道中,发送端将数据发送给连接至信道的多个设备,由于信道被多个设备共享,数据碰撞概率高,故需要通过网络协议来进行协调。

    1.点对点信道

    PPP(Point-to-Point Protocol)协议只提供无比特差错的数据传输服务,是目前使用点对点信道的网络中应用最广泛的数据链路层协议。

    终端用户通过因特网服务提供商(ISP,Internet Service Provider)所提供的数据链路层协议,获得相应的网络访问服务,中国电信和网通等ISP均采用PPP协议为终端用户提供通信服务。PPPoE(Point-to-Point Protocol over Ethernet)协议及PPPoA(Point-to-Point Protocol over ATM)协议是由PPP协议衍生而来的两个协议, 目前家庭常用的ADSL宽带上网方式就是采用了PPPoE协议技术。

    PPP协议规定的数据帧格式如图2-11所示,数据帧首部包含4个字段,尾部包含2个字段。首部的第一个字段和尾部的第二个字段均为标志字段,起到帧定界符的作用。标志字段Flag被规定为十六进制数0x7E,转化成二进制数即为01111110。在PPP帧的首部,标志字段之后依次为地址字段和控制字段,地址字段规定为0xFF,控制字段规定为0x03。首部最后一个字段长度为2字节,为协议字段,表示数据部分所对应的网络层协议。若协议字段值为0x0021,则表示数据部分为IP数据报;若协议字段值为0xC021,则表示数据部分为链路控制协议LCP的数据。尾部第一个字段即帧校验序列,用于检测数据比特差错。

    图2-11 PPP数据帧格式

    为保证数据的透明传输,PPP协议对异步和同步这两种传输方式分别采用了字符填充法和比特填充法。使用异步传输时,PPP协议定义转义字符为0x7D,在RFC1662文档中定义了相应的字符填充方法;在同步传输中,则采用“零”比特填充法实现透明传输。

    2.广播信道

    数据链路层被拆分为两个子层:逻辑链路控制LLC子层和介质访问控制MAC子层。MAC子层负责与接入到传输介质相关的所有工作,LLC子层的作用被逐渐淡化。

    以太网MAC帧的格式具有两种标准,一种是以太网V2标准(DIX Ethernet V2),另一种是IEEE 802.3标准,其中以太网V2标准的MAC帧应用最为广泛。

    如图2-12所示为MAC帧的格式示意图,前两个长度为6字节的字段分别代表目的地址和源地址,第三个字段长度为2字节,用于表示上一层协议的类型。若第三个字段值为0x0800,则表示上一层使用IP协议,数据部分为IP数据报。数据部分的长度在46~1500字节。从图2-12中可以看出,物理层所传输的数据比MAC帧多8个字节,前7个字节用于实现接收端与发送端时钟频率的同步,第8个字节为帧开始定界符,标识MAC帧的开始。

    图2-12 MAC帧格式

    这里的MAC地址由IEEE802.3规定的扩展唯一标识EUI-48(EUI,Extended Unique Identifier)表示,它是一个由48位二进制表示的字符串,又称为物理地址、硬件地址。此地址由24位公司ID(也称为制造商ID)和24位扩展ID(也称为网卡ID)组成。公司ID被唯一指派给每个网络适配器的制造商;扩展ID在装配时被唯一指派给每个网络适配器。两者组合,即可生成全球唯一的48位的MAC地址。

    三、CSMA/CD协议

    CSMA/CD协议是以太网所采用的一种监听避免“碰撞”的协议,该协议工作在OSI模型数据链路层的MAC子层,是一种“争用”型的半双工介质访问控制协议,包含以下几个要素。

    1.多点接入

    CSMA/CD协议的应用环境为总线型网络,网络中的主机以多点接入的方式连接在总线上。

    2.载波监听

    CSMA/CD协议要求发送端在发送数据前对总线进行监听,若监听到其他计算机在发送数据,则等待一段时间后,确认总线空闲时才开始发送数据。

    3.“碰撞”监听

    在数据发送过程中需保持对总线上信号的监听,根据信号电平的变化幅度即可判断是否发生了“碰撞”。一旦监听到“碰撞”,就立即停止数据发送,等待一段时间后再次尝试重发,直至发送成功。

    四、虚拟局域网

    虚拟局域网(VLAN,Virtual Local network)是一种将局域网设备从逻辑上划分为多个网段,从而实现虚拟工作组的交换技术。

    在典型的局域网中,通常一个工作组属于同一个网段,多个逻辑工作组之间通过网桥或者路由器交换数据,逻辑工作组受到节点所在物理位置的限制。

    虚拟局域网使用交换机,以软件的方式实现逻辑工作组的划分与管理,不受物理位置的限制而组建的局域网。

    如图2-13所示为一个虚拟局域网,一个VLAN可以包含一台或多台交换机,如图中椭圆形区域所示,有3个VLAN。PC-1、PC-2、PC-3、PC-4在同一个VLAN中,但连接到不同的交换机。同时,一个VLAN中的所有主机也可以连接到同一台交换机上,如PC-5与PC-6连接到Switch A。

    图2-13 虚拟局域网

    不同虚拟局域网的组网方法,主要表现在对虚拟局域网成员的定义上,通常有四种:交换机端口号、MAC地址、网络层地址和IP广播组等方式。虚拟局域网不同划分方法的优缺点如表2-8所示。

    表2- 8虚拟局域网不同划分方法的优缺点

    划分方法

    优点

    缺点

    交换机端口

    可简单定义VLAN成员,将交换机端口定义为相应的VLAN组当用户改变端口时,需要重新进行配置

    MAC地址

    当用户物理位置改变时,VLAN不用重新配置当交换机初始化时,所有的用户都必须进行配置

    网络层地址

    根据协议类型划分,方便网络管理效率低,检查每个数据包的网络层地址需要消耗处理时间

    IP广播组

    灵活性好,且较易通过路由器进行扩展不适合局域网,因其效率不高

    五、高速以太网

    高速以太网是指传输速率达到或超过100Mb/s的以太网,适用于较远距离的传输。

    1.快速以太网

    快速以太网(Fast Ethernet)的传输速率比传统10BASE-T以太网快10倍,数据传输速率达到100Mb/s。100BASE-T标准的快速以太网仍使用IEEE802.3的CSMA/CD(Carrier Sensing Multiple Access with Collision Detection)协议,并采用星型拓扑结构。用户只需更换一个适配器,再配上一个100Mb/s的集线器就可方便地由10BASE-T以太网直接升级到100Mb/s。目前的10Mb/s和100Mb/s以太网是使用无屏蔽双绞线布线的。

    100BASE-T以太网有3种与传输介质相关的标准,如表2-9所示。

    1)100BASE-TX:支持2对5类非屏蔽双绞线(UTP)或2对1类屏蔽双绞线(STP)。其中,一对双绞线用于发送,而另一对双绞线用于接收。因此,100BASE-TX工作在全双工模式,每个节点均可以同时以100Mb/s的速率发送与接收数据。

    2)100BASE-T4:支持4对3类或5类非屏蔽双绞线。其中,3对双绞线用于数据传输,每一对均以33.3 Mb/s的速率传送数据;而另一对用作冲突检测的接收信道。

    3)100BASE-FX:支持两芯的多模或单模光纤。其中,一根光纤用于数据发送,另一根光纤用于数据接收。100BASE-FX工作在全双工模式,主要用作高速主干网,从节点到集线器的距离可以达到2 km。

    表2- 9不同传输介质的100BASE-T以太网技术指标

    以太网标准

    100BASE-TX

    100BASE-T4

    100BASE-FX

    传输介质

    2对UTP-5

    2对STP-1

    4对UTP-3/5

    2芯光纤

    信号技术

    MLT-3

    MLT-3

    8B6T,NTZ

    4B5B,NRZI

    数据速率

    100Mb/s

    100Mb/s

    100Mb/s

    100Mb/s

    最大段长

    100m

    100m

    100m

    200m

    网络跨度

    200m

    200m

    200m

    400m

    2.吉比特以太网

    吉比特以太网的数据传输速率是快速以太网的10倍,可达到1Gb/s。吉比特以太网保留了传统10BASE-T以太网的基本特征,具有相同的帧格式和类似的组网方法。

    吉比特以太网定义了基于双绞线的物理层标准1000BASE-T和基于光纤通道的物理层标准1000BASE-X:

    1)1000BASE-T,即IEEE 802.3ab,使用4对5类非屏蔽双绞线,双绞线长度可达100 m。

    2)1000BASE-X,即IEEE 802.3z,有以下3种有关传输介质的标准:

    (1)1000BASE-CX;

    (2)1000BASE-LX;

    (3)1000BASE-SX。

    IEEE 802.3z标准的吉比特以太网具有以下特点:

    1)支持全双工和半双工两种工作方式;

    2)在半双工方式下采用CSMA/CD协议,而在全双工方式下不采用该协议;

    3)向后兼容10BASE-T和100BASE-T技术。

    3.10吉比特以太网

    10吉比特以太网又称万兆以太网,使用IEEE 802.3以太网介质访问控制MAC协议。与传统的以太网标准相比,10吉比特以太网具有以下特征:

    1)只支持双工模式,不支持单工模式,而传统的以太网标准均支持单工/双工模式。

    2)由于传输速率高,10吉比特以太网只能使用光纤作为传输介质,而传统的以太网标准均支持同轴电缆。

    3)不支持CSMA/CD协议,因为该协议只适用于速率较慢的单工以太网。

    4)使用64B/66B和8B/10B两种编码方式,而传统以太网只使用8B/10B的编码方式。

    5)具有支持局域网和广域网的接口,且有效距离可达40 km,而传统的以太网只支持局域网应用,有效传输距离不超过5 km。

    100 Mb/s以太网、1 Gb/s以太网和10 Gb/s以太网均属于共享介质方式的高速以太网。这里,介绍一些其他类型的高速以太网。

    1)光纤分布式数据接口。光纤分布式数据接口(FDDI,Fiber Distributed Data Interface)是一个使用光纤作为传输介质的令牌环网,使用共享介质方式。其主要具有以下几个特点:

    (1)使用IEEE 802.5的单令牌环网MAC协议。

    (2)兼容IEEE 802标准的局域网。

    (3)数据传输速率为100 Mb/s,联网的节点数不超过1000,环路长度为100 km。

    (4)使用双环结构,提高容错能力。

    (5)可以使用多模或单模光纤。

    2)高性能并行接口。高性能并行接口(HIPPI,High-Performance Parallel Interface)是一个美国国家标准协会标准,主要用于连接外围设备、处理器和巨型机等。

    HIPPI标准具有以下特点:

    (1)HIPPI提供点对点的接口,可以在两个设备间建立连接。

    (2)HIPPI工作在单工模式下,只能沿着一个方向传输数据,但是,两条单工通道可以组成一条双工通道。

    由于光纤价格昂贵,HIPPI在设计之初,只能采用双绞线作为数据传输的媒介。

    3)光纤通道。光纤通道(FC,Fibre Channel)是一种高速网络互联技术,主要用于连接计算机存储设备。

    光纤通道标准定义了三种不同的拓扑结构:点到点、仲裁环和交换网。

    六、宽带接入技术

    1.xDSL 技术

    xDSL技术是使用数字技术改造现有的模拟电话用户线,可以承载宽带业务。

    前缀x表示在数字用户线(DSL,Digital Subscriber Line)上实现的不同带宽方案。

    表2-10列出了xDSL的几种类型。其中ADSL(Asymmetric DSL)表示非对称数字用户线,HDSL(High speed DSL)表示高速数字用户线,SDSL(Single-line DSL)表示1对线的数字用户线,VDSL(Very high speed DSL)表示甚高速数字用户线。

    表2- 10 xDSL类型

    xDSL

    对称性

    下行带宽

    上行带宽

    极限传输距离

    ADSL

    不对称

    1.5 Mb/s

    64 kb/s

    4.6~5.5 km

    HDSL(1对线)

    对称

    768 Kb/s

    768 kb/s

    2.7~3.6 km

    SDSL

    对称

    1.5 Mb/s

    1.5 Mb/s

    3 km

    VDSL

    不对称

    52 Mb/s

    1.6~2.3 Mb/s

    0.3 km

    DSL(ISDN)

    对称

    160 Kb/s

    160 Kb/s

    4.6~5.5 km

    ADSL有上行和下行之分,其不对称的原因在于用户下载的数据量要大于上传的数据量。

    如图2-14所示,ADSL接入网包含数字用户线接入复用器(DSLAM,DSL Access Multiplexer)、用户线和用户设施如ADSL调制解调器(ATU-R,ADSLTransceiver Unit Remote Terminal End)、电话机和PC等。

    图2-14 ADSL接入网的组成

    ADSL的优势在于可以利用现有电话网中的用户线,而不需要重新布线。

    2.光纤同轴混合网

    光纤同轴混合网(HFC,Hybrid Fiber Coax)是一种居民宽带接入网,在原有有线电视网(CATV,Community Antenna TeleVision)的基础上发展而来。HFC网不仅能够传输电视信号,还能提供电话、数据等业务。

    HFC网采用光纤作为主干线路,并使用模拟光纤技术,如图2-15所示。头端发射出的光信号经过模拟光纤到达光纤节点,光纤节点将接收到的光信号转换为电信号,电信号经由光纤节点下游的同轴电缆传送到居民区。

    图2-15 HFC网的体系结构

    HFC网具有以下特点:

    1)HFC网以光纤作为主干线路。

    2)HFC网采用节点体系结构。

    3)HFC网具有更宽的频谱,且具有双向传输能力。

    4)用户接口盒。每个家庭都需要安装一个用户接口盒(UIB,User Interface Box)。

    3.FTTx 技术

    光纤通信是利用光波作为载波,以光纤作为传输媒体,将信息从源节点传送至目的节点的一种通信方式。

    光纤通信具有容量大、传输距离远、抗干扰能力强、性能稳定和保密性能好等优点,已在各种不同的骨干网中得到了广泛应用。

    FTTx中x代表不同的技术。

    1)光纤到户(FTTH,Fiber To The Home)是家庭接入的解决方案,即将光纤一直铺设到用户家庭内。

    2)光纤到大楼(FTTB,Fiber To The Building)方案能解决一幢大楼有多个用户连接宽带的情况。

    3)光纤到路边(FTTC,Fiber To The Curb)是指将光纤铺设到离家庭或办公室1km以内的路边,从路边到单个用户,可以采用双绞线或同轴电缆,以星型结构连接。FTTC代替了普通旧式电话服务,只需通过一条线就可以完成电话、有线电视、多媒体和其他通信业务。

    FTTx还提供其他宽带接入方案,如光纤到节点或邻区(FTTN,Fiber To The Node/Neighborhood)、光纤到交换机(FTTE,Fiber To The Exchange)、光纤到小区(FTTZ,Fiber To The Zone)和光纤到办公室(FTTO,Fiber To The Office)等。

     

     

     

     

     

    IEEE 802

     

    IEEE 802也指IEEE标准中关于局域网和城域网的一系列标准。更确切的说,IEEE 802标准仅限定在传输可变大小的网络。

    系列标准

    IEEE 802系列标准是IEEE 802 LAN/MAN 标准委员会制定的局域网、城域网技术标准。其中最广泛使用的有以太网令牌环无线局域网等。这一系列标准中的每一个子标准都由委员会中的一个专门工作组负责。

    IEEE 802委员会成立于1980年2月,它的任务是制定局域网和城域网标准。IEEE 802中定义的服务和协议限定在OSI模型[OSI网络参考模型]的最低两层(即物理层数据链路层)。事实上,IEEE 802将OSI的数据链路层分为两个子层,分别是逻辑链路控制(Logical Link Control, LLC)和介质访问控制(Media Access Control, MAC),如下所示:

    · 数据链路层

    · 逻辑链路控制子层

    · 介质访问控制子层

    · 物理层

    IEEE 802系列标准是IEEE 802 LAN/MAN 标准委员会制定的局域网、城域网技术标准。其中最广泛使用的有以太网令牌环无线局域网等。这一系列标准中的每一个子标准都由委员会中的一个专门工作组负责。

    802委员会前有20多个分委员会。

    IEEE 802现有标准

    IEEE 802.1 :局域网体系结构、寻址、网络互联和网络

    IEEE 802.1A:概述和系统结构

    IEEE 802.1B:网络管理和网络互连

    IEEE 802.2 :逻辑链路控制子层(LLC)的定义。

    IEEE 802.3 :以太网介质访问控制协议 (CSMA/CD)及物理层技术规范 [1]  

    IEEE 802.4 :令牌总线网(Token-Bus)的介质访问控制协议及物理层技术规范。

    IEEE 802.5 :令牌环网(Token-Ring)的介质访问控制协议及物理层技术规范。

    IEEE 802.6 :城域网介质访问控制协议DQDB (Distributed Queue Dual Bus 分布式队列双总线)及物理层技术规范。

    IEEE 802.7 :宽带技术咨询组,提供有关宽带联网的技术咨询。

    IEEE 802.8 :光纤技术咨询组,提供有关光纤联网的技术咨询。

    IEEE 802.9 :综合声音数据的局域网(IVD LAN)介质访问控制协议及物理层技术规范。

    IEEE 802.10:网络安全技术咨询组,定义了网络互操作的认证和加密方法。

    IEEE 802.11无线局域网(WLAN)的介质访问控制协议及物理层技术规范。

    IEEE 802.11,1997年,原始标准(2Mbit/s,播在2.4GHz)。

    IEEE 802.11a,1999年,物理层补充(54Mbit/s,播在5GHz)。

    IEEE 802.11b,1999年,物理层补充(11Mbit/s播在2.4GHz)。

    IEEE 802.11c,符合802.1D的媒体接入控制层桥接(MAC Layer Bridging)。

    IEEE 802.11d,根据各国无线电规定做的调整。

    IEEE 802.11e,对服务等级(Quality of Service, QoS)的支持。

    IEEE 802.11f,基站的互连性(IAPP,Inter-Access Point Protocol),2006年2月被IEEE批准撤销。

    IEEE 802.11g,2003年,物理层补充(54Mbit/s,播在2.4GHz)。

    IEEE 802.11h,2004年,无线覆盖半径的调整,室内(indoor)和室外(outdoor)信道(5GHz频段)。

    IEEE 802.11i,2004年,无线网络的安全方面的补充。.

    IEEE 802.11j,2004年,根据日本规定做的升级。

    IEEE 802.11l,预留及准备不使用。

    IEEE 802.11m,维护标准;互斥及极限。

    IEEE 802.11n,更高传输速率的改善,基础速率提升到72.2Mbit/s,可以使用双倍带宽40MHz,此时速率提升到150Mbit/s。支持多输入多输出技术(Multi-Input Multi-Output,MIMO)。

    IEEE 802.11k,该协议规范规定了无线局域网频谱测量规范。该规范的制订体现了无线局域网络对频谱资源智能化使用的需求。

    IEEE 802.11p,这个通信协定主要用在车用电子的无线通信上。它设置上是从IEEE 802.11来扩充延伸,来符合智能型运输系统(Intelligent Transportation Systems,ITS)的相关应用。

    IEEE 802.11ac,802.11n的潜在继承者,更高传输速率的改善,当使用多基站时将无线速率提高到至少1Gbps,将单信道速率提高到至少500Mbps。使用更高的无线带宽(80MHz-160MHz)(802.11n只有40MHz),更多的MIMO流(最多8条流),更好的调制方式(QAM256)。目前是草案标准(draft),预计正式标准于2012年晚些时间推出。Quantenna公司在2011年11月15日推出了世界上第一只采用802.11ac的无线路由器Broadcom公司于2012年1月5日也发布了它的第一支支持802.11ac的芯片。

    IEEE 802.11ae-2012

    IEEE 802.12 : [1]  [2-3]  需求优先的介质访问控制协议(100VG AnyLAN)。

    IEEE 802.13 :(未使用 )【不吉利的数字,没有人愿意使用它---查自《计算机网络-Andrew S. Tanebaum》 Page 63 - 1.6.2 国际标准领域中最有影响的组织】

    IEEE 802.14:采用线缆调制解调器(Cable Modem)的交互式电视介质访问控制协议及网络层技术规范。

    IEEE 802.15:采用蓝牙技术的无线个人网(Wireless Personal Area Networks,WPAN)技术规范。

    IEEE 802.15.1:无线个人网络。

    IEEE 802.15.4:低速无线个人网络

    IEEE 802.16:宽带无线连接工作组,开发2~66GHz的无线接入系统空中接口

    IEEE 802.17:弹性分组环 (Resilient Packet Ring,RPR)工作组,制定了单性分组环网访问控制协议及有关标准。

    IEEE 802.18:宽带无线局域网技术咨询组(Radio Regulatory)。

    IEEE 802.19:多重虚拟局域网共存(Coexistence)技术咨询组。

    IEEE 802.20:移动宽带无线接入( Mobile Broadband Wireless Access ,MBWA)工作组,制定宽带无线接入网的解决 。

    IEEE 802.21:媒介独立换手(Media Independent Handover)。

    IEEE 802.22: [4]  无线区域网(Wireless Regional Area Network)

    IEEE 802.23:紧急服务工作组 (Emergency Service Work Group)

    展开全文
  • 本期介绍的内容局域网接口配置、路由器的静态路由配置、OSPF动态路由协议配置、DHCP服务器配置。掌握了这些,基本的网络协议配置,小型办公网络的组建就不成问题了,后面会讲Vlan的划分以及其他技术! 注:这次...

    在一篇文章《IP地址、子网掩码、网络地址详解》(也已同步至CSDN有兴趣的可以去关注一下!)一文中,重点向大家介绍了IP地址及其分类,子网掩码的概念,网络号、主机号、网络地址、直接广播地址等的概念及其计算方法。本期介绍的内容为:局域网接口配置、路由器的静态路由配置、OSPF动态路由协议配置、DHCP服务器配置。掌握了这些,基本的网络协议配置,小型办公网络的组建就不成问题了,后面会讲Vlan的划分以及其他技术!

    注:这次实验以Cisco设备为主,仿真环境为:Cisco Packet Tracer 7.2.1

    一、题目描述

    如下图所示,某校园网用10Gbps的POS技术与Internet相连,POS接口的帧格式是SDH。路由协议的选择方案是校园网内部采用OSPF协议,校园网与Internet的连接使用静态路由协议。校园网内的路由器R1设为DHCP服务器,可分配的IP地址是221.89.23.192/26,其中221.89.23.200-221.89.23.254地址除外,地址租用时间为5小时30分。

    1.1、问题

    请阅读以下R3和R1的部分配置信息,并补充下列空白处的配置命令或参数,按题目要求完成路由器的配置。

    R3的POS接口、OSPF和缺省路由的配置信息如下:

    Router-R3#configure terminal
    Router-R3(config)#interface pos4/0
    Router-R3(config-if)#description To Internet
    Router-R3(config-if)#bandwidth 10000000
    Router-R3(config-if)#ip address 211.68.69.170 255.255.255.252
    Router-R3(config-if)#【1】 32
    Router-R3(config-if)#pos framing sdh
    Router-R3(config-if)#no ip directed-broadcast
    Router-R3(config-if)#pos flag s1 s0 2
    Router-R3(config-if)#no shutdown
    Router-R3(config-if)#exit
    Router-R3(config)#router ospf 63
    Router-R3(config-router)#network 【2】 area 0
    Router-R3(config-router)#redistribute connected metric-type 1 subnets
    Router-R3(config-router)#area 0 range 【3】
    Router-R3(config-router)#exit
    Router-R3(config)#ip route 0.0.0.0 0.0.0.0 211.68.69.169
    Router-R3(config)#exit
    Router-R3#
    

    R1的DHCP的部分配置信息如下:

    Router-R1#configure terminal
    Router-R1(config)#ip dhcp 【4】 221.89.23.200 221.89.23.254
    Router-R1(eonfig)#ip dhcp pool bupt
    Router-R1(dhep-config)#network 221.89.23.192 255.255.255.192
    Router-R1(dhcp-config)#default-router 221.89.23.193
    Router-R1(dhcp-config)#domain-name bupt.edu.cn
    Router-R1(dhcp-config)#dns-server address 221.89.24.27 221.89.24.26
    Router-R1(dhcp-config)#lease 【5】
    Router-R1(dhcp-config)#exit
    Router-R1(config)#exit
    Router-R1#
    

    二、概念理解

    跟往常一样,在解决问题之前,先来搞明白下面这些概念:

    2.1、局域网

    局域网(Local Area Network,LAN)的覆盖范围一般是方圆几千米之内,其具备的安装便捷、成本节约、扩展方便等特点使其在各类办公室内运用广泛。局域网可以实现文件管理、应用软件共享、打印机共享等功能,在使用过程当中,通过维护局域网网络安全,能够有效地保护资料安全,保证局域网网络能够正常稳定的运行。局域网技术的特点表现在以下几个方面:

    • 局域网覆盖的地理范围有限,一般属于一个单位所有,易于建立、维护与扩展。
    • 局域网具有较高的数据传输速率(10Mbit/s~100Gbit/s)与较低的误码率。

    2.2、路由器

    路由器是连接两个或多个网络的硬件设备,在网络间起网关的作用,是读取每一个数据包中的地址然后决定如何传送的专用智能性的网络设备。它能够理解不同的协议,例如某个局域网使用的以太网协议,因特网使用的TCP/IP协议。这样,路由器可以分析各种不同类型网络传来的数据包的目的地址,把非TCP/IP网络的地址转换成TCP/IP地址,或者反之;再根据选定的路由算法把各数据包按最佳路线传送到指定位置。所以路由器可以把非TCP/IP网络连接到因特网上。它分为普通家用路由器与企业核心路由器。

    普通家用路由器

    企业核心路由器

    2.3、IGP协议

    IGP(内部网关协议)是在一个自治网络内网关(主机和路由器)间交换路由信息的协议。路由信息能用于网间协议(IP)或者其它网络协议来说明路由传送是如何进行的。IGP协议包括RIP、OSPF、IS-IS、IGRP、EIGRP。

    2.4、EGP协议

    外部网关协议(Exterior Gateway Protocol,EGP)是一个在自治系统网络中两个邻近的网关主机(每个都有它们自己的路由)间交换路由信息的协议。EGP常常被用来在英特网的两个主机间交换路由表信息。路由表包括已知的路由器清单、它们能到达的地址以及与每个路由的路径相关的成本度量,以便选出最好的可用路径。每个路由器按照一定的时间间隔,通常在120秒到480秒之间,就给它的邻近路由发送信息,然后邻近路由就会将自己的完整路由表发回给它。EGP-2是EGP的最新版本。

    2.5、RIP协议

    RIP(Routing Information Protocol,路由信息协议)是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳数”(即metric)来衡量到达目标地址的路由距离。RIP规定,路由器每30秒向外广播一个(V,D)报文,报文信息来自本地路由表。一条有限的路径长度不得超过15,超过15则意味路径为无限长,即路径不存在。

    2.6、OSPF协议

    开放式最短路径优先(Open Shortest Path First,OSPF)协议,也是内部网关协议的一种。它是在1989年为适应Internet的不断发展,克服RIP的缺点开发出来的。开放式最短路径优先协议主要用于在自治系统内部路由器之间传输路由信息。与RIP相比,OSPF协议的主要特点有如下几点:

    • OSPF协议最主要的特征就是使用分布式链路状态协议(Link State Protocol),而不是像RIP协议那样使用距离向量协议。
    • OSPF协议要求当链路发送变化时用洪泛发向本自治系统中所有路由器发送信息。
    • OSPF发送的信息是与本路由器相邻的所有路由器的链路状态。

    2.7、DHCP协议

    DHCP(Dynamic Host Configuration Protocol,动态主机配置协议)通常被应用在大型的局域网络环境中,主要作用是集中的管理、分配IP地址,使网络环境中的主机动态的获得IP地址、Gateway地址、DNS服务器地址等信息,并能够提升地址的使用率。

    三、实训环节

    3.1、路由器接口配置

    路由器接口基本配置

    配置接口描述信息:

    进入配置模式,使用命令description设置描述信息。

    router-test>en
    router-test#configure terminal
    router-test(config)#interface f0/1
    router-test(config-if)#description test
    

    配置接口带宽:

    进入接口配置模式,使用bandwidth命令设置接口带宽,单位为:kbit/s。

    router-test(config-if)#bandwidth 12345(注意单位换算)
    

    配置接口地址:

    进入接口配置模式,使用ip address命令配置接口的ip地址。

    命令格式:ip address <ip地址> <子网掩码>

    router-test(config-if)#ip address 192.168.1.254 255.255.255.0
    

    配置接口的开启与关闭:

    进入接口配置模式,使用shutdown或者no shutdown命令关闭或开启接口。

    router-test(config-if)#shutdown (关闭接口)
    router-test(config-if)#no shutdown (开启接口)
    

    环回接口配置

    配置loopback接口号:

    在全局配置模式下,使用loopback命令进行环回接口配置,loopback接口的范围为:0~2147483647。

    router-test(config-if)#ip address 192.168.100.1 255.255.255.255
    

    局域网接口配置

    路由器上可提供包括FDDI、ATM和Token Ring以及以太网在内的各种局域网接口,其中以太网接口应用最为广泛,因此在这里介绍几种以太网标准的接口配置方法。以太网接口配置的主要任务包括:配置接口的ip地址、接口传输速率、通信(双工)方式、MTU值,以及禁用ARP代理等安全选项配置。

    标准以太网接口配置实例:

    标准以太网接口的接口类型为Ethernet,简写为e。

    router-test(config)#interface e1 (配置接口类型)
    router-test(config-if)#description Etest (配置描述信息)
    router-test(config-if)#ip address 192.168.1.1 255.255.255.0 (配置接口地址)
    router-test(config-if)#bandwidth 10000 (配置带宽)
    router-test(config-if)#no shutdown (配置接口为开启状态)
    router-test(config-if)#exit (退出)
    router-test(config)#exit
    router-test#
    

    快速以太网接口配置实例:

    快速以太网接口的接口类型为FastEthernet,简写为f。

    router-test(config)#interface f0/1
    router-test(config-if)#description Ftest
    router-test(config-if)#ip address 192.168.2.1 255.255.255.0
    router-test(config-if)#bandwidth 100000
    router-test(config-if)#duplex half (配置工作模式为半双工)
    router-test(config-if)#no ip directed-broadcast (禁止转发主机位全为1的广播包)
    router-test(config-if)#no ip proxy-arp (关闭ARP代理)
    router-test(config-if)#no shutdown
    router-test(config-if)#exit
    router-test(config)#exit
    router-test#
    

    吉比特以太网接口配置实例:

    吉比特以太网接口的接口类型为GigabitEthernet,简写为g。

    router-test(config)#interface g0/0
    router-test(config-if)#description Gtest
    router-test(config-if)#ip address 192.168.3.1 255.255.255.0
    router-test(config-if)#bandwidth 1000000
    router-test(config-if)#duplex full(配置工作模式为全双工)
    router-test(config-if)#ip directed-broadcast (允许转发主机位全为1的广播包)
    router-test(config-if)#no ip proxy-arp (关闭ARP代理)
    router-test(config-if)#no shutdown
    router-test(config-if)#exit
    router-test(config)#exit
    router-test#
    

    广域网接口配置

    异步串行接口的配置:

    异步串行接口的接口类型为Async,简写为a

    router-test(config)#interface a0/0
    router-test(config-if)#ip unnumbered ethernet0
    router-test(config-if)#encapsulation ppp (封装PPP协议)
    router-test(config-if)#async default ip address 192.168.1.1
    router-test(config-if)#async dynamic routing
    router-test(config-if)#async mode interactive (配置异步接口的ppp工作方式)
    router-test(config-if)#no shutdown
    router-test(config-if)#exit
    router-test(config)#exit
    router-test#
    

    高速同步串行接口的配置:

    高速同步串行接口的接口类型为Serial,简写为s。Serial接口主要的配置参数包括接口带宽、接口协议、接口ip等。

    router-test(config)#interface s0/0
    router-test(config-if)#description Stest
    router-test(config-if)#ip address 192.168.4.1 255.255.255.0
    router-test(config-if)#bandwidth 2048
    router-test(config-if)#encapsulation ppp (封装HDLC或PPP协议,HDLC为默认值)
    router-test(config-if)#ip directed-broadcast 
    router-test(config-if)#no ip proxy-arp
    router-test(config-if)#no shutdown
    router-test(config-if)#exit
    router-test(config)#exit
    router-test#
    

    POS接口的配置:

    POS使用的链路协议主要有PPP和HDLC。

    目前POS可以提供155Mbit/s、622Mbit/s、2.5Gbit/s和10Gbit/s等多种传输速率的接口。

    POS接口的配置任务包括:在POS接口模式下设置POS物理端口帧类型(sdh或sonet)、在POS接口模式下设置POS物理端口的协议封装模式(ppp或chdlc)、在POS接口模式下设置POS物理端口的数据帧格式中的flag值(0表示sonet帧,2表示sdh帧)、强制POS物理端口数据帧是否加扰、设置POS物理端口数据帧的CRC校验位数(16或32)等。

    router-test(config)#interface POS0/1
    router-test(config-if)#description Ptest
    router-test(config-if)#ip address 192.168.5.1 255.255.255.0
    router-test(config-if)#crc 16 (配置POS物理端口数据帧的CRC校验位数,可选值:16或32)
    router-test(config-if)#pos framing sonet (可选的帧格式是sdh或sonet)
    router-test(config-if)#bandwidth 10000000
    router-test(config-if)#pos flag s1 s0 0 (s1s0=00表示是sonet帧的数据,s1s0=10(十进制2)表示是sdh帧的数据)
    router-test(config-if)#no ip directed-broadcast
    router-test(config-if)#no shutdown
    router-test(config-if)#exit
    router-test(config)#exit
    router-test#
    

    3.2、路由器静态路由配置

    静态路由由“ip route”命令在全局配置模式下配置,使用“no ip route”命令可以删除静态路由配置。

    命令格式:

    ip route <目的网络地址> <子网掩码> <下一跳路由器的ip地址>

    router-test(config)#ip route 10.0.0.0 255.0.0.0 192.168.1.1
    

    其中,默认路由配置的方式为:

    ip route 0.0.0.0 0.0.0.0 下一跳路由器的ip地址
    

    3.3、动态路由协议配置

    RIP协议配置(主要命令)

    router rip 命令(基本配置)

    该命令用于启动RIP协议,开始RIP进程

    例如:

    router-test(config)#router rip
    

    network 命令(基本配置)

    该命令用于设置参与RIP协议的网络地址

    命令格式:network <网络ip地址>

    例如:

    router-test(config)#router rip
    router-test(config-router)#network 192.168.0.1
    

    passive-interface 命令(高级配置 可选)

    该命令用于指定被动接口,该接口将被抑制路由更新,即路由更新报文不再通过该路由器的接口

    命令格式:passive-interface <接口>

    例如:

    router-test(config)#router rip
    router-test(config-router)#passive-interface FastEthernet0/1
    router-test(config-router)#exit
    router-test(config)#exit
    router-test#
    

    distribute-list 命令(高级配置 可选)

    该命令用于指定有路由过滤功能的接口

    命令格式:distribute-list <接口>

    例如:

    router-test(config)#router rip
    router-test(config-router)#distribute-list 10 in FastEthernet0/1
    

    distance 命令(高级配置 可选)

    该命令用于配置或改变RIP的管理距离,管理距离用来测量路由的可信度,该值越小可信度越高,RIP的默认距离值是120,有效的管理距离取值范围是1~255

    命令格式:distance <管理距离>

    例如:

    router-test(config)#router rip
    router-test(config-router)#distance 100 (配置管理距离为100)
    router-test(config-router)#exit
    router-test(config)#exit
    router-test#
    

    neighbor 命令(高级配置 可选)

    该命令用于指定邻居路由器,在RIP路由器不允许发送广播包或是在网络技术不支持网络广播的特殊情况下,路由器仍然可以用单播的方式向邻居路由器发送路由信息

    命令格式:neighbor <邻居路由器的ip地址>

    例如:

    router-test(config)#router rip
    router-test(config-router)#neighbor 128.55.101.1
    router-test(config-router)#exit
    router-test(config)#exit
    router-test#
    

    OSPF协议配置(主要命令)

    router ospf 命令

    该命令用来启用OSPF进程

    命令格式:router ospf

    其中,Process ID是OSPF的进程号,它的范围是1~65535。Process ID可以在指定范围内随意设置,它只对本地路由器内部有意义,不同的路由器Process ID可以相同,也可以不同

    例如:

    router-test(config)# router ospf 10 
    

    network ip 命令

    该命令用于定义参与OSPF的子网地址

    命令格式:network ip <子网号> <子网掩码的反码> area <区域号>

    例如:

    router-test(config-router)#network 192.168.1.0 0.0.0.255 area 0
    

    range 命令

    该命令用于定义某一特定范围子网的聚合

    命令格式:area <区域号> range <子网地址> <子网掩码>

    例如:

    router-test(config-router)#area 0 range 212.37.123.0 255.255.255.0
    

    passive-interface 命令

    该命令用来配置OSPF的被动接口

    命令格式:passive-interface <接口>

    例如:

    router-test(config-router)#passive-interface FastEthernet0/1
    

    distribute-list 命令

    该命令用来配置路由器的过滤功能

    使用方法与RIP中的distribute-list 命令一致

    distance

    该命令用来配置或改变OSPF的管理距离

    使用方法与RIP中的distance命令一致

    3.4、路由器上DHCP服务器的配置

    IP地址池的建立

    在全局模式下,使用“ip dhcp pool”命令建立IP地址池,其中name是所建地址池的名称,可以是一组字符串或数字。

    例如:

    router-test>en
    router-test#conf t (进入全局模式)
    router-test(config)#ip dhcp pool 123 (建立名为123的地址池)
    router-test(dhcp-config)#
    

    IP地址池的子网地址与子网掩码的配置

    IP地址池建立后,便进入地址池配置模式,在该模式下可以进行IP地址池子网地址和子网掩码的配置,即使用“network <网络地址> <子网掩码>”命令。

    例如:

    router-test(dhcp-config)#network 192.168.1.0 255.255.255.0
    router-test(dhcp-config)#
    

    排除不用于动态分配的IP地址

    使用“ip dhcp excluded-address low-address [high-address]”命令排除不用于动态分配的IP地址,其中“low-address [high-address]”表示要排除的ip地址的范围,若只排除一个地址,则可直接在命令后输入地址即可。

    例如:

    排除从192.168.1.1~192.168.1.10的一段ip地址

    router-test(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10
    

    排除单个ip地址192.168.1.11

    router-test(config)#ip dhcp excluded-address 192.168.1.11
    

    配置默认网关

    执行“default-router address [address1…address8]”命令,其中默认网关的地址最多可以设置8个

    例如:

    router-test(dhcp-config)#default-router 192.168.1.1
    router-test(dhcp-config)#
    

    配置IP地址池的域名系统

    配置IP地址池的域名系统使用“domain-name”命令,其中为指定的域名名称。

    例如:

    router-test(dhcp-config)#domain-name test.cya.com
    router-test(dhcp-config)#
    

    IP地址租用时间

    ip地址租用时间是指客户端在获得一个ip地址后,可以占用这个地址的最长时间,配置方法为在DHCP地址池配置模式下,使用“leaseday [hours] [minutes]”命令,其中参数可以包含天数、小时数以及分秒数,还可以设置永不过期(infinite)。

    例如:

    router-test(dhcp-config)#lease 0 3 (设置租用时间为3小时)
    router-test(dhcp-config)#lease infinite (设置租用时间为永不过期)
    router-test(dhcp-config)#
    

    四、参考答案及解析

    1. “Router-R3(config-if) #crc 32”指的是配置CRC校验功能,因此【1】处应填入:crc

    2. 语句“Router-R3(config-router) #network 【2】 area 0”是在配置OSPF的子网地址,命令格式为:network ip <子网号> <子网掩码的反码> area <区域号>。由题意知,校园网内部采用OSPF协议,网络地址为221.89.23.0/24,子网地址为221.89.23.0,子网掩码为255.255.255.0,得到子网掩码的反码为0.0.0.255。因此【2】处应填入:211.89.23.0 0.0.0.255。

    3. 语句“Router-R3(config-router) #area 0 range 【3】”是在配置某一特定范围子网的聚合。校园网内部采用OSPF协议,网络地址为211.89.23.0/24,子网地址为211.89.23.0,子网掩码为255.255.255.0。因此【3】处应填入:211.89.23.0 255.255.255.0。

    4. 语句“Router-R1(config) #ip dhcp 【4】 221.89.23.200 221.89.23.254”是在配置DHCP服务器排除不用于动态分配的IP地址,命令格式为:ip dhcp excluded-address low-address [high-address]。因此【4】处填入:excluded-address

    5. 语句“Router-R1(dhcp-config) #lease 【5】”在设置ip租用时间,命令格式:leaseday [hours] [minutes]。由题意得,地址租用时间为5小时30分,所有【5】处应填入:0 5 30。

    五、后记

    马上也要找工作了就很烦!手上一个Offer都没有,唉大家可移步私人博客给我留个言,点点关注!主要是现在搞互联网都太卷了,我就想不明白,为啥要卷。卷来卷去像不像恶意竞争。最后身体垮了,钱也没赚到!太难了~~。CoderX_Blog传送门

    展开全文
  • WLAN无线局域网IEEE802.11协议

    千次阅读 2021-12-23 14:12:17
    1、 无线网络简介 1.1、无线网络的历史 在1971年时,夏威夷大学的研究员创造了第一个基于...根据网络覆盖范围的不同,可以将无线网络划分无线广域网(WWAN:Wireless Wide Area Network)、无线局域网(WLAN:Wireless

    1、 无线网络简介

    1.1、无线网络的历史

    在1971年时,夏威夷大学的研究员创造了第一个基于封包式技术的无线电通讯网络。这被称作ALOHNET的网络,这是最早期的无线局域网络 (WLAN)。1990年,IEEE正式启用了802.11项目。2003年开始,无线网络市场开始迅速增长,wifi、蓝牙技术在市场上的应用越来越广。

    1.2、无线网络的分类

    根据网络覆盖范围的不同,可以将无线网络划分为无线广域网(WWAN:Wireless Wide Area Network)、无线局域网(WLAN:Wireless Local Area Network)、无线城域网(WMAN:Wireless Metropolitan Area Network)和无线个人局域网(WPAN:Wireless Personal Area Network)。
    在这里插入图片描述

    无线个人局域网(WPAN:Wireless Personal Area Network) 是一种采用无线连接的个人局域网。它被用在诸如电话、计算机、附属设备以及小范围(个人局域网的工作范围一般是在10米以内)内的数字助理设备之间的通讯。除了基于蓝牙技术的802.15之外,IEEE还推荐了其他两个类型:低频率的802.15.4(TG4,也被称为ZigBee)和高频率的802.15.3(TG3,也被称为超波段或UWB)

    特点:用于实现同一地点终端与终端间的连接,价格便宜、体积小、易操作和功耗低。
    工作在2.4GHZ频段。

    无线局域网(WLAN:Wireless Local Area Network) 指应用无线通信技术将计算机设备互联起来,构成可以互相通信和实现资源共享的网络体系。基于IEEE802.11标准的无线局域网允许在局域网络环境中使用可以不必授权的ISM频段中的2.4GHz或5GHz射频波段进行无线连接。
    特点:支持多用户,灵活性和移动性。
    应用范围:企业、医院、商店、工厂和学校。

    无线城域网(WMAN:Wireless Metropolitan Area Network) 主要用于骨干连接和用户覆盖。以IEEE 802. 16 系列标准为代表的宽带WMAN 主要用于本地多点连接。市场上也把无线城域网技术称为“wimax技术”。信息产业部将3. 5 GHz (3400~3430MHz、3500 ~ 3530 MHz) 、5. 8 GHz ( 5725 ~ 5850MHz) 两个频带规划为城域网无线接入专用频带。

    无线广域网(WWAN:Wireless Wide Area Network) WWAN是采用无线网络把物理距离极为分散的局域网(LAN)连接起来的通信方式,主要是运营商用于无线覆盖。所采用标准IEEE802.20。

    1.3、无线网络采用的传输技术

    1.3.1、IrDA红外连接技术

    是一种利用红外线进行通信的点对点通信的技术。传输速率可达16M,作用距离几十米。中间不能有阻挡物。最常见设备红外遥控器、遥控钥匙。

    1.3.2、Blue Tooth蓝牙技术

    短距离的无线电连接技术。工作于2.45GHz频段上,使用IEEE 802.15.1协议,作用距离范围是10cm-10m,最高速度可达723.1kb/s。蓝牙设备连接必须在一定范围内进行配对。这种配对搜索被称之为短程临时网络模式,也被称之为微微。
    在这里插入图片描述

    1.3.3、Home RF家庭射频

    是无绳电话技术(数字式增强型无绳电话或者简称DECT:DigitalEnhanced Cordless Telephone)和无线局域网(WLAN)技术相互融合发展的产物。支持语音和数据的接入点。是IEEE802.11与DECT(数字无绳电话标准)的结合,工作在2.4GHz频段,100m内提供的最大接入速率为2M。

    传输高速数据分组则采用CSMA/CA技术;无线电干扰影响小;支持流媒体。有线电视系统就是采用射频传输方式的。

    1.3.4、WiFi

    “Wi-Fi”作为801.11无线网络的代名词,使用无线电波来连网。实际上通过有线数据信号转换为无线数据信号,提供支持无线上线设备进行数据传输。

    1.3.5、LTE、TD-LTE、LTE FDD、5G

    LTE(Long Term Evolution,长期演进)标准于2008年12月确立。在高速数据通信提供下行100Mbps、上行50Mbps的峰值速率,频率范围:
    700MHz-2.7GHz,即对应特高频(UHF),对应电磁波的波长为分米波:1m~10cm。对应2G/3G频段。

    4G指第四代移动通信技术,主要应用于移动网络数据传输。LTE根据双工方式不同,分为LTE-TDD和LTE-FDD两种制式。

    LTE-TDD:TDD是时分双工的缩写。,代表分双工,上下行在同一频段上按照分配交叉进行。TDD是时分双工的缩写。下行采用OFDMA,而上行根据链路特点采用单载波DFT - SOFDM作为多址方式。

    国内使用频段4个:2010~2025MHz,1880~1920MHz2300~2400MHz,2496~2690MHz。

    峰值速率-20 MHz带宽内下行峰值速率为100Mbps,上行峰值速率为50Mbps;

    目前是中国移动使用。

    LTE-FDD:FDD是频分双工的缩写。上下行分处不同频段同时进行。 FDD是在分离的两个对称频率信道上进行接收和发送,用保护频段来分离接收和发送信道。依靠频率来区分上下行链路,其单方向的资源在时间上是连续的。缺点:频谱利用率将大大降低。比TD-LTE研发更早,技术更成熟,终端更丰富。FDD 4G市场占有率95%, TD 4G市场占有率5%。

    峰值速率-20 MHz带宽内下行峰值速率为150Mbps,上行峰值速率为50Mbps;
    国内使用频段4个:800MHz,900MHz,2100MHz。
    目前是中国电信、中国联通使用。

    5G指第五代移动通信技术,5G国际技术标准重点满足灵活多样的物联网需要。高频传输技术是5G网络通信技术的核心技术。
    2013年2月,欧盟宣布将拨款5000万欧元,加快5G移动技术的发展,计划到2020年推出成熟的标准。深圳从2017年10月开通首个5G试验站点。

    峰值速率需要达到10-20Gbit/s,以满足高清视频、虚拟现实等大数据量传输。

    5G的频率范围,分为两种:一种是6GHz以下,6GHz以下的频段统称为Sub6GHz,450MHz-6000MHz频率。6GHz以上24250MHz-52600MHz频率范围是FR2,也就是常说的毫米波,国内5G网络的频段主要是,中国电信获得了3400MHz-3500MHz的频段,频段号为n78,中国联通获得了3500MHz-3600MHz的频段,频段号也是n78。中国移动获得了2515MHz-2675MHz和4800MHz-4900MHz两个5G频段,频段号分别为n41和n79。

    1.3.5、ZIGBEE

    ZigBee技术是一种新兴的短距离、低功耗的无线通信技术,用于传感控制应用(Sensor and Control)。由IEEE 802.15工作组中提出,并由其TG4工作组制定规范。。这一名称(又称紫蜂协议)来源于蜜蜂的八字舞,由于蜜蜂(bee)是靠飞翔和“嗡嗡”(zig)地抖动翅膀的“舞蹈”来与同伴传递花粉所在方位信息,也就是说蜜蜂依靠这样的方式构成了群体中的通信网络。其特点是近距离、低复杂度、自组织、低功耗、低数据速率。主要适合用于自动控制和远程控制领域,可以嵌入各种设备。2001年8月,ZigBee Alliance成立。相近的技术是Z-WAVE。

    2、WLAN无线局域网技术

    WLAN起步于1997年。当年的6月,第一个无线局域网标准IEEE802. 11正式颁布实施,为无线局域网技术提供了统一标准,但当时的传输速率只有1~2 Mbit/s。“Wi-Fi”作为801.11无线网络的代名词。
    无线局域网

    2.1、wifi的发展

    WiFi 版本WiFi 标准发布时间最高速率工作频段
    WiFi 0IEEE 802.111997 年2Mbps2.4GHz
    WiFi 1IEEE 802.11a1999 年54Mbps5GHz
    WiFi 2IEEE 802.11b1999 年11Mbps2.4GHz
    WiFi 3IEEE 802.11g2003 年54Mbps2.4GHz
    WiFi 4IEEE 802.11n2009 年600Mbps2.4GhHz 或 5GHz
    WiFi 5IEEE 802.11ac2014 年1Gbps5GHz
    WiFi 6IEEE 802.11ax2019 年11Gbps2.4GHz 或 5GHz

    注:bps比特率,指单位时间内传送的比特(bit)数。单位是比特/秒(b/s)。

    技术的发展,带宽越来越高,从2Mbps到11Gbps;覆盖范围越来越广,从802.11a/g的100m到802.11n的500-1000m。从单纯的Fat AP模式转为集中控制的AC-Fit AP模式。

    wifi的好处是不用再到处拉线、接线,体现出移动性、灵活性、扩展性、经济性的特点。应用场景:家庭、商店、工厂、企业、大型设施如体育馆、展馆等。

    2.1、IEEE 802.11协议族

    802为首的协议,其中80是指1980年,2指的是二月份,表示1980年2月份制定的关于网络通信的协议规范。802.11系列协议,规范传输信号时,进行双向通信、使用相同频率收发数据,但不能同时传输和接收,这是半双工方式。

    制定802.11系列协议作用是让各国提供公用免费的频道使大众都可以无线网络,生产商不需要申请许可,消费方不需要支付许可和运行费用。

    2.1.1、无线管理机构:

    中国国家无线电监测中心 (State Radio Monitoring Center, SRMC)
    为目前中国大陆唯一获得授权可测试及认证无线电型号核准规定的机构。目前,中国已针对不同类别的无线电发射设备订定特殊的频率范围,且并非所有频率皆得以在中国合法使用。

    FCC联邦通信委员会
    1934年建立的美国政府的一个独立机构。FCC通过控制无线电广播、电视、电信、卫星和电缆来协调国内和国际的通信。许多无线电应用产品、通讯产品和数字产品要进入美国市场,都要求FCC的认可—FCC认证。

    一般来说,FCC与其他国家的监管机构负责管理两类无线通信:需要牌照与无需牌照。二者的区别在于,用户可以免费使用无需牌照的频段进行通信,即安装无线系统之前不需要进行申请牌照的程序。监管机构通常从以下5个方面管理需要牌照和不需要牌照的通信:

    • 频率
    • 带宽
    • 主动辐射器(Intentional Radiator,IR)的最大输出功率
    • 最大EIRP(EquivalentIsotropically Radiated Power,等效全向辐射功率)
    • 用途(室内和/或室外)

    ETSI 欧洲电信标准化协会
    是由欧共体委员会1988年批准建立的一个非赢利性的电信标准化组织,总部设在法国南部的尼斯。ETSI的标准化领域主要是电信业,并涉及与其他组织合作的信息及广播技术领域。ETSI作为一个被CEN(欧洲标准化协会)和CEPT(欧洲邮电主管部门会议)认可的电信标准协会,其制定的推荐性标准常被欧共体作为欧洲法规的技术基础而采用并被要求执行。

    IEEE电子电气工程师协会
    被国际标准化组织授权为可以制定标准的组织,设有专门的标准工作委员会,有30000义务工作者参与标准的研究和制定工作,每年制定和修订800多个技术标准。IEEE的标准制定内容有:电气与电子设备、试验方法、原器件、符号、定义以及测试方法等。

    其中比较出名的是IEEE 802委员会,它成立于1980年2月,它的任务是制定局域网的国际标准。
    IEEE负责制定网络设备兼容于共存的标准,IEEE标准必须遵循FCC等通信监管机构的规定。

    Wi-Fi联盟
    1999年,几位Wi-Fi行业领袖携手创建了一个全球性非营利性组织,旨在推动为高速无线局域网采纳一个全世界通用的标准。组织名称是 Wi-Fi 联盟。

    • 一个由300多家会员公司组成的不断壮大的非营利国际组织,目前在6个国家拥有10个独立权威测试实验室。

    • 与整个产业链保持良好的合作关系,会员覆盖了生产商、标准化机构、监管单位、服务提供商及运营商等。

    • Wi-Fi CERTIFIED 认证实现WLAN技术互操作性,提供最佳用户体验;

    • 由于 Wi-Fi网络的持续扩张是基于众多的企业、家庭以及现在为人们提供随时随地无线上网地点的公共 hotspot,因此,兼容性至关重要。Wi-Fi 联盟制定全球通用的规范,并通过对无线设备的严格测试和 Wi-Fi 认证加以遵循。

    IETF国际互联网工程任务组
    是一个公开性质的大型民间国际团体,汇集了与互联网架构和互联网顺利运作相关的网络设计者、运营者、投资人和研究人员。

    成立于1985年底,是全球互联网最具权威的技术标准化组织,主要任务是负责互联网相关技术规范的研发和制定,当前绝大多数国际互联网技术标准出自IETF。

    作为标准的RFC又分为几种:

    • 第一种是提议性的,就是说建议采用这个作为一个方案而列出。
    • 另外一种就是完全被认可的标准,这种是大家都在用,而且是不应该改变的。
    • 还有一种就是现在的最佳实践法,它相当于一种介绍。

    2.1.2、无线射频基础

    射频电波是频率介于3赫兹和约300G赫兹之间的电磁波。
    射频电波频率

    • 极低频 ELF (3Hz–30Hz) 极长波 100,000千米– 10,000千米 潜艇通讯或直接转换成声音。
    • 超低频 SLF (30Hz–300Hz) 超长波 10,000千米– 1,000千米 直接转换成声音或交流输电系统(50-60赫兹)。
    • 特低频 ULF (300Hz–3KHz) 特长波 1,000千米– 100千米 矿场通讯或直接转换成声音。
    • 甚低频 VLF (3KHz–30KHz) 甚长波 100千米– 10千米 直接转换成声音、超声、地球物理学研究。
    • 低频 LF (30KHz–300KHz) 长波 10千米– 1千米 国际广播。
    • 中频 MF (300KHz–3MHz) 中波 1千米– 100米 调幅(AM)广播、海事及航空通讯。
    • 高频 HF (3MHz–30MHz) 短波 100米– 10米 短波、民用电台。
    • 甚高频 VHF (30MHz–300MHz) 米波 10米– 1米 调频(FM)广播、电视广播、航空通讯。
    • 特高频 UHF (300MHz–3GHz) 分米波 1米– 100毫米 电视广播、无线电话通讯、无线网络、微波炉。
    • 超高频 SHF (3GHz–30GHz) 厘米波 100毫米– 10毫米 无线网络、雷达、人造卫星接收。
    • 极高频 EHF (30GHz–300GHz) 毫米波 10毫米– 1毫米 射电天文学、遥感、人体扫描安检仪。
      300GHz以上 - 红外线、可见光、紫外线、射线等。

    2.1.3、无线信号基本概念

    1、信号基本概念:

    • 单向通信(又称单工通信):只能有一个方向通信,没有反方向(广播电视)
    • 双向交替通信(又称半双工通信):通信双方可以发送信息,但是不能同时收发(对讲机)
    • 双向同时通信(又称全双工通信):可以同时收发(电话机)
    • 基带信号:来自信源的信号,像计算机输出的各种文字图像文件
    • 调制:基带信号中包含许多低频成分,甚至直流成分,许多信道不支持低频或直流分量,因此必须对基带信号进行调制
    • 带通信号:基带信号经过载波调制后,把频率范围搬移到较高以便在信道中传输(频率高能使信号传输距离更远)

    2、最基本的调制方法:
    调幅(AM):载波的振幅随基带数字信号而变化
    调频(FM):载波的频率随基带数字信号而变化
    调相(PM):在波的初始相位随基带数字信号而变化
    在这里插入图片描述

    3、常用编码方式:
    不归零制:正电平代表1,负电平代表0
    归零制:正脉冲代表1,负脉冲代表0
    曼彻斯特编码:位周期中心向上跳代表0,向下跳代表1
    查分曼彻斯特编码:位中心始终有跳变,边界有跳变代表0,无跳变代表1

    编码总结:
    曼彻斯特编码与前两种相比能够表示没有数据传输,具有同步能力。查分曼彻斯特编码抗干扰性强于曼彻斯特编码。

    展开全文
  • 无线个人区域网WPAN 802.11局域网的MAC层协议 CSMA/CA协议
  • 文章目录一、WEP(有线等效保密)二、WPA(Wi-Fi网络安全接入)三、WAPI(无线局域网鉴别和保密基础结构) WLAN是Wireless Local Area Network的简称,指应用无线通信技术将计算机设备互联起来,构成可以互相通信和...
  • 网络(局域网和广域网、网址、协议、网络硬件) 局域网和广域网 1、局域网(Local Area Network),简称LAN,是指在某一区域内由多台计算机互联成的计算机组。“某一区域”指的是同一办公室、同一建筑物、同一公司和同一...
  • 局域网的参考模型与协议标准

    千次阅读 2018-10-19 11:13:38
    局域网的参考模型与协议标准 随着个人计算机的普及,用户共享数据,硬件与软件的愿望越发的强烈,局域网的发展示意图如图所示:   局域网的参考模型 IEEE802局域网与城域网标标准化委员会主要研究的是解决一...
  • 局域网设备发现之Bonjour协议

    万次阅读 多人点赞 2016-09-28 23:37:43
    通常我们需要对设备进行绑定,需要通过某种方法先对设备进行发现,比如微信硬件采用广播的方式,定时向外发送上线消息或者采用一问一答的方式进行发现,Bonjour是由苹果公司实现的一种零配置网络(Zeroconf)协议,...
  • 无线局域网(Wireless LAN,以下简称WLAN)是近年来发展迅速的无线数据通讯网。MAC作为无线局域网的关键技术之一,决定WLAN的网络性能。本文探讨了WLAN中MAC协议的网络工作方式,介绍了MAC典型技术CSMA/CS,最后提出WLAN...
  • 在广播信道中,当两个或两个以上结点同时传输数据时,就会产生冲突从而接收失败,于是就出现了多路访问控制(Multiple Access Control , MAC)协议,MAC协议的根本任务是为了解决信道的共享问题。 1.信道划分MAC...
  • 虚拟局域网什么意思VLAN(VirtualLocalAreaNetwork)的中文名“虚拟局域网”。虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,...
  • 本次实验通过配置RIPv2协议、OSPF协议、静态路由、动态NAT实现了各局域网内的PC可经边界路由器进行私有IP到公有IP的转换,并成功访问公网服务器。
  • 随着云计算技术的兴起以及虚拟化技术的普及,VLAN 技术的弊端逐渐显现出来,表现为以下 3 个方面: 在大规模云计算的多租户模式下,802.1Q 标准定义的最多支持 4094 个 VLAN 的能力已经无法满足需求。 在大规模...
  • 无线局域网 CSMA/CA 协议工作原理

    千次阅读 2020-08-31 15:45:44
    它规定无线局域网为星型拓扑结构,其中心点称作接入点 AP(Access Point),并把基本服务集 BSS(Basic Service Set)作为其最小构件。一个 BSS 又由一个固定基站和若干移动终端组成,其中固定基站就是上文所提到的接入...
  • 局域网文件分享协议和方案的探究

    千次阅读 2016-12-22 15:07:43
    不管是学习还是工作中经常遇见这样一种情况,需要传输一些文件给同学,同事...当然作为一个IT人士,程序猿,或者Geek这样传输实在太没品太不装X了,而且主要有以下弊端: 1、受u盘大小的限制,如果你一个4G优盘,并且
  • 局域网互连

    2021-07-01 03:48:34
    近年来,许多单位和部门根据实际需要都组建了局域网,这日常事务处理带来了极大的便利。然而,有些单位不同部门之间的局域网相互独立,未实现真正意义上的信息共享。因此,网络互联在这种环境中显得尤重要。通过...
  • 局域网IP段哪些 - 卡饭网

    千次阅读 2020-12-19 16:41:57
    查询局域网IP所在的网段查询局域网IP所在的网段 在Win7系统中,如何查询局域网IP所在的网段呢? 第1步:找到"开始"菜单,在"搜索"中输入cmd,按[Enter]键可以打开"命令提示符"对话框. 第2步:在"命令提示符"中输入ipconfig...
  • 局域网故障排查

    千次阅读 2021-11-15 10:43:53
    毕业后加入了一家做智能电视的公司做Android系统开发,同时做了兼职网管,后来换工作后,老东家新网管经常联系我问一些故障,于是就顺手了这篇文章。 问题及解决办法 1. 局域网内部分主机分配到其它网段的IP,且不...
  • 虚拟局域网11.1 虚拟局域网VLAN概述11.1.1 课后练习11.2 虚拟局域网VLAN的实现机制11.2.1 IEEE 802.1Q帧11.2.2 交换机的端口类型11.2.3 课后练习 10. 以太网交换机的生成树协议STP   问题: 如何提高以太网的可靠...
  • 网络协议局域网

    2018-08-02 23:02:57
    很早以前,两台电脑如果想要组成一个局域网...不过集线器需要解决的问题主要有以下: 一、包发给谁,谁来接收 二、网络包的是如何发送的,谁先发,谁后发等先后顺序 三、万一发送过程中出现错误 解决第二个问题...
  • 编译 cd srt sudo ./configure 单纯的srt caller 只支持单对单,如果需要单对多,就需要安装srt-live-server服务 下载安装srt-live-server(此协议为国内大神武爱敏开发) 回到根目录, cd .. sudo git clone ...
  • 一、安装Nginxnginx: download(安装Nginx直接解压便可以用)二、安装...命令提示行如果以上提示,改环境变量或者到安装目录下执行,本人用安装目下执行3.生成证书1)执行以下语句,创建服务器私钥key文件genrs...
  • 局域网中的基本概念2.Vlan 概述3.VLAN工作原理三、实验部分问题1:一个HUB的所有端口是属于同一个广播域吗?是属于同一个冲突域吗?交换机呢?问题2:能够在一条链路上承载多vlan的链路,叫什么链路?该链路上的数据...
  • 1、局域网定义和特性 2、各种流行的局域网技术 3、高速局域网技术 4、基于交换的局域网技术 5、无线局域网技术及城域网技术 一、局域网定义和特性 局域网(Local Area Network)即LAN:将小区域内的各种通信...
  • 局域网

    2018-12-28 18:20:25
    先介绍局域网的主要技术特点,拓扑结构,传输介质,机制访问控制技术。接着便是ALOHA协议、CSMA协议、CSMA/CD协议、基本位图协议(无冲突)、最后便是有限竞争协议和适应树协议
  • 如何快速枚举局域网内所有存活主机IP (转) 我想快速搜索所有主机,我已经试过以下方法,注意,我强调的是快速
  • 局域网中CSMA/CD协议的应用

    千次阅读 2018-10-12 13:50:12
    特点:网络一个单位所拥有,且地理范围和站点数目均有限。 优点: 具有广播功能(使用广播信道),从一个站点可很方便地访问全网 便于系统的扩展和逐渐演变,各设备的位置可灵活调整和改变 提高系统的可靠性、可用...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 75,133
精华内容 30,053
关键字:

以下为局域网协议的有