精华内容
下载资源
问答
  • 以太网根据传输方式可分为 共享式以太网交换以太网   共享式以太网 共享式以太网顾名思义就是所有设备共享同一带宽。 共享带来的问题就是冲突严重,所以以太网中采用CSMA/CD来解决这个问题 CS(Carrier ...

    原版本涉及培训后发现可能涉及到 信息安全违规,检查完毕后重新发布

     

    以太网根据传输方式可分为 共享式以太网和交换式以太网

     

    共享式以太网

    共享式以太网顾名思义就是所有设备共享同一带宽。

    共享带来的问题就是冲突严重,所以以太网中采用CSMA/CD来解决这个问题

    CS(Carrier Sense)载波监听

    在发送数据前进行监听,以确保线路空闲,减少冲突的机会

    MA(Multiple Access)多址访问

    每个站点发送给您额数据,可以同时被多个站点接收

    CD(Collision Detection)冲突检测

    边发送边检测,发送冲突就停止发送,然后延迟一个随机时间之后继续发送

     

    共享式以太网常使用Hub集线器来进行构建,但Hub的作用就是将分散的网线集起来,用来放大信号,它仅仅是工作在物理层的设备,上述的CSMA/CD过程集线器是不知道的。

    Hub是个半双工设备,这也和其应用在共享式网络中是对应的。

    任何一个时刻只有一个用户进行传递,Hub收到数据后以广播的方式对其他所有的接口进行广播。

    共享式以太网的缺陷如下:

    1、冲突严重,共享的固有缺点

    2、广播泛滥,没有进行隔离。如上图,1是以广播的方式发送的数据

    3、安全性差。和2同样,1想发给2的数据可以被2、3、4、5收到。此外,还会遭受到广播攻击等。

    交换式以太网

    交换式以太网使用交换机进行构建,每个端口之间有独立专用的通道,除非2个端口同时对1个端口进行通信,不然不会发生冲突问题。

     

    L2交换机的工作原理(本节所指导都是L2交换机)

    L2交换机通过Mac地址表确定每个端口连接设备对应的Mac地址。

    交换机获取地址采用源Mac地址学习法,转发采用目的Mac地址传递。

    源Mac地址学习法

     

    最初接入网时,交换机内部是没有Mac地址信息的。

    当A想发送消息给C时,A会封装数据报文+IP + 源MAC地址 + 目的MAC地址。

    此时C的目的MAC地址是不知道的,通过ARP地址解析协议发送ARP消息(进行广播),交换机收到该消息后对所有进行广播。

    此时交换机收到的A的ARP消息里就有A自身的源Mac地址与其发送出的端口了,就将端口与对应的Mac地址i信息写入到Mac地址表中。

     

    当在Mac地址表中存有相应的信息后,查询对应的表的映射就完成转发,此就称为基于目的地址转发。

     

    当发送来的目的Mac地址在Mac地址表中匹配不到时,就进行广播

     

    交换机的交换方式

    有3种交换转发方式

    1、直通转发(Cut-Through)

    当交换机接收到第一个字节时(接收到目的地址)就开始转发

    此方法延迟小,但交换机不检测错误

     

    2、存储转发(Store-and-Forward)

    交换机接收到完整的数据帧并校验正确后才开始转发

    此方法延迟取决于数据帧长度,当交换机检测错误,就将错误的包丢弃

    3、片段转发(Fragment-Free)

    对1、2的折中。

    交换机接收到数据包的前64字节(一个最短帧的长度),然后根据头信息表进行转发

    此方法检查前64字节的错误,一旦发现错误就丢弃。

     

    L2交换机的缺陷如下

    1、广播泛滥

    当找不到目的Mac地址时就会进行广播,L2交换机主要缺点。

    2、安全性仍旧无法保障

    如1所述,若有恶意人反复故意发送不存在的Mac地址就会造成不停进行广播,瞬间爆炸。此问题可有L3交换机解决。

     

    L3交换机的工作原理(本节所指导都是L3交换机)

    在逻辑上,三层交换和路由是等同的,三层交换的过程就是IP报文选路的过程

    具有二层功能的同时提供三层功能

    许多三层交换机用三层精确查找实现三层转发

    针对局域网,对以太网进行了优化,大部分三层交换机只提供以太网接口和ATM局域网仿真接口。

    展开全文
  • 以太网的其他名称就是内网和局域网。 在局域网中有两种通信方式,一种是基于ppp协议的点对点通信。另一种是基于CSMA/CD的广播通信。 集线器(Hub):集线器(hub)属于纯硬件网络底层设备,基本上不具有类似于交换机的...

    以太网的其他名称就是内网和局域网。
    在局域网中有两种通信方式,一种是基于ppp协议的点对点通信。另一种是基于CSMA/CD的广播通信。

    1. 集线器(Hub):集线器(hub)属于纯硬件网络底层设备,基本上不具有类似于交换机的"智能记忆"能力和"学习"能力。它也不具备交换机所具有的MAC地址表,所以它发送数据时都是没有针对性的,而是采用广播方式发送。也就是说当它要向某节点发送数据时,不是直接把数据发送到目的节点,而是把数据包发送到与集线器相连的所有节点,如图所示,简单明了。
    2. **交换机(Switch)😗*交换器的每个端口都用来连接一个独立的网段。交换机和集线器的不同在于以下三种功能。1.学习功能:以太网交换机了解每一端口相连设备的MAC地址,并将地址同相应的端口映射起来存放在交换器缓存中的MAC地址表中。
      2.转发过滤:当一个数据帧的目的地址在MAC地址表中有映射时,它被转发到连接目的节点的端口而不是所有端口(如该数据帧为广播/组播帧则转发至所有端口)。
      3.消除回路:当交换器包括一个冗余回路时,以太网交换器通过生成树协议避免回路的产生,同时允许存在后备路径。
      共享式以太网用的是Hub集线器,它是使用CSMA/CD协议进行广播通信的如果该集线器接入设备过多可能会引起广播风暴,且传输效率低。
      交换式以太网用的是Switch交换机,它是使用PPP协议进行点对点通信的。如果在交换机中存在该MAC地址的端口,交换机会直接将数据转发给该端口。如果不存在正在该MAC端口,交换机可以通过动态学习的方式,或者说提前写入去记录MAC地址位置。为以后转发备用。
      1.参考文章csdn
    展开全文
  • 原因:方式数据最后一帧发过来第一帧还未到,引发冲突 Ethernet_II的帧结构 以太网的双工模式 半双工(HUB) 全双工(二层设备、三层设备) 冲突域和广播域 冲突域:连接在同一导线上的所有节点的集合就是一...

    1.1 以太交换


    以太网的网络层次

    • 物理层
    • 数据链路层
      1. 媒体接入控制层(MAC)
      2. 逻辑链路控制层(LLC)
    img

    CSMA/CD

    • 名字:载波侦听多址访问冲突检测
    • 口诀:先听后发,边听边发,冲突停发,随机延迟后重发

    最小帧长

    • 64
    • 原因:方式数据最后一帧发过来第一帧还未到,引发冲突
    • Ethernet_II的帧结构
    • img

    以太网的双工模式

    1. 半双工(HUB)
    2. 全双工(二层设备、三层设备)

    冲突域和广播域

    • 冲突域:连接在同一导线上的所有节点的集合就是一个冲突域
    • 广播域:一个节点发送一个广播报文其余节点都能够收到的节点的集合

    MAC子层

    • 当上层要发送数据的时候,把数据提交给MAC子层。
    • 然后加上目的MAC地址和自己的MAC地址(源MAC地址),计算出数据帧的长度,形成以太网帧。
    • 对端设备用帧的目的MAC地址,跟MAC地址表中的条目进行比较。
    • 以太网帧根据目的MAC地址被发送到对端设备。

    以太网交换(二、三层)

    1. 二层交换原理
      • 二层交换通过维护MAC表以及根据目的MAC查表转发,有效的利用了网络带宽,改善了网络性能
      • img
      • 二层交换设备虽然能够隔离冲突域,但是它并不能有效的划分广播域。so 出现了valn技术
    2. 三层交换原理
      • 三层交换机一般是通过VLAN来划分二层网络并实现二层交换
      • img
    展开全文
  • BCM5690是BroadCOM公司推出的集成有12个千兆...文章比较全面地介绍了该芯片的结构和功能特性,给出了它的访问控制方式数据流程,同时给出了用BCM5690设计交换整机的硬件结构和软件实现方法。
  • 文章目录CCNP3交换:管理VLAN、三层交换机、Ether Channel、数据交换方式、网关冗余(HSRP、VRRP、GLBP)一、管理VLAN:1、SVI2、配置SVI:二、三层交换机的灵活使用:1、路由功能:2、SVI充当网关:3、实现不同VLAN...

    CCNP3交换:管理VLAN、三层交换机、Ether Channel、数据交换方式、网关冗余(HSRP、VRRP、GLBP)

    一、管理VLAN:

    1、SVI

    在讲管理VLAN之前,我们先讲一下 VLAN1 这个特殊的VLAN:
    VLAN1默认创建,并且默认所有接口处于该VLAN,Native VLAN也是VLAN1,管理VLAN也是VLAN1

    交换机需要被远程登录管理,真实的二层接口不能配置IP地址,故只能使用SVI虚接口。虚接口的MAC地址从背板地址池中获取(二层交换机仅存在一个SVI虚接口,多层交换机有多少个VLAN就存在多少个SVI虚接口
    在这里插入图片描述

    2、配置SVI:

    (1)配置SVI(管理VLAN):

    SW1(config)#int vlan 1
    SW1(config-if)#ip add 192.168.1.1 255.255.255.0
    SW1(config-if)#no shutdown
    

    有了上面的配置,SW1再设置一个用户名和密码,就可以让PC进行Telnet远程登录了。

    (2)转移SVI:

    SW1(config)#int VLAN 2
    SW1(config-if)#ip add 192.168.2.1 255.255.255.0
    SW1(config-if)#no shutdown 
    

    注意:在真机上配置的时候,由于二层交换机仅存在一个SVI,故开启某个VLAN的SVI口后,其它的SVI口自动被关闭。多层交换机可以存在多个SVI。

    SVI双UP的条件:
    ①该交换机上存在该VLAN
    ②该VLAN中存在活动用户(双UP),或存在活动trunk干道。

    (3)配置网关:
    若该交换机需要被其它广播域访问,需要定义网关地址。

    Switch(config)#ip default-gateway 192.168.1.1
    

    二、三层交换机的灵活使用:

    三层交换机简述:
    对于普通二层交换机对于发来的包,认识的单播,不认识的洪泛。
    对于路由器来说,认识的转发,不认识的丢弃

    将两者结合起来的三层交换机即会解包,又会洪泛。这就是三层交换机所特有的魅力,但是如果只是把它当作普通交换机来说比较浪费,而作为一个路由器来讲,它又承载不了向路由器那样的路由能力。

    正式因为三层交换机有这样的特点,它可以完成以下的功能。

    1、路由功能:

    在这里插入图片描述

    开启路由功能:
    SW1(config)#ip routing
    
    关闭交换机端口:
    SW1(config)#int range f0/1-2
    SW1(config-if-range)#no switchport 
    
    SW1(config)#int f0/1
    SW1(config-if)#ip add 192.168.1.254 255.255.255.0
    SW1(config-if)#no shutdown 
    
    SW1(config-if)#int f0/2
    SW1(config-if)#ip add 192.168.2.254 255.255.255.0
    SW1(config-if)#no shutdown 
    

    此时PC0可以Ping通PC1

    2、SVI充当网关:

    我们将上面那个图做大,给它再增加一个交换机,配置我这里不再演示了。大致思路就是:让新增加的设备在同一VLAN(默认VLAN1),然后给三层交换机配置一个SVI(192.168.3.254/24),接着让底下的交换机连着PC,把PC的网关
    在这里插入图片描述

    SW2(config)#int vlan 1
    SW2(config-if)#ip add 192.168.3.2 255.255.255.0
    SW2(config-if)#no shutdown
    
    SW1(config)#int vlan 1
    SW1(config-if)#ip add 192.168.3.254 255.255.255.0
    SW1(config-if)#no shutdown 
    

    将PC的网关设置为192.168.3.254,就会发现PC2可以ping 通PC0、PC1的电脑。

    以前一个物理接口,当N个子接口,每个子接口管理一个VLAN,当VLAN一多,链路利用就会很高,就会导致卡。

    如果不使用子接口,我们一般情况下一个接口一个VLAN,但是我们到这里就发现可以多个接口配置同一个VLAN(这里默认都是VLAN1),让SVI充当所有VLAN1的网关。

    3、实现不同VLAN的访问:

    在这里插入图片描述
    上面的配置省略,需要注意访问其它网段下的IP,需要有路由。

    Switch(config)#ip default-gateway 192.168.4.254
    

    4、二层交换机的透明化:

    图中将F0/5口划分到VLAN2中,然后将PC4的 IP 也配置到VLAN2中。
    在这里插入图片描述
    PC4可以正常访问其它PC。

    5、实现一台二层交换机下不同VLAN的PC的访问:

    在这里插入图片描述
    这样实现一台二层交换机之间不同VLAN的PC的访问。

    三、Ether Channel(以太网通道):

    我们再回到三层架构,根网桥是一棵树的中心,网关是一个广播域的中心。当一个VLAN2中的电脑访问VLAN3的电脑时,数据包就会经过两台汇聚层的交换机。

    我们知道接入层的设备一旦多起来,那么两台汇聚层交换机之间的通信负担就会越来越越来越大,单纯的千兆网线根本就不够用,就算上了万兆网线,在一个大型的网络中,两台汇聚层设备之间的通信依然是问题。

    因此有人提出将多根网线逻辑的捆在一起的思路:

    1、原理:

    Ether Channel :以太网通道,主要用于 SW-SW 之间,将多个交换机间直连的物理接口逻辑的整合为一个接口,起到带宽叠加的作用。

    SW1(config)#int range f0/1-4
    SW1(config-if-range)#channel-group 1 mode on
    
    SW2(config)#int range f0/1-4
    SW2(config-if-range)#channel-group 1 mode on
    

    配置好之后,就可以看作多个接口成为一个Port口了。
    在这里插入图片描述
    原理:当流量到汇聚层交换机上的Port口时,它们将流量分担到各个链路上,比如说在这张图中各走25%,流量到达对端之后,交换机将多个接口来的流量组合成一个流量,视作是一个接口过来的,自然将流量洪泛到除F0/1-4的其它接口上。

    一般设备支持8根绑在一起,好一些的设备支持16根绑在一起。
    Channel的建立可以通过手动,也可以自动:
    由用户选择模式来决定:

    模式 特点
    PAGP
    Cisco私有
    desirable(主动)、auto(被动)
    LACP
    公有
    active(主动)、passive(被动)
    on 若配置为手动,两端必须均为手动。

    2、配置指南:

    序号 配置指南
    所有端口必须支持etherchannel,同时注意必须连接相同设备(同一设备,同本地类型相同)
    这些物理接口必须具有相同的速率和双工模式,LACP必须为全双工
    通道内不得使用span,若为3层通道,ip地址必须配置到逻辑接口上
    三层通道内所有的物理接口必须为3层接口,然后在channel口上配置ip地址
    若二层通道,这些物理接口应该属于同一VLAN或者均为trunk干道,且封装的类型一致,VLAN的允许列表必须一致
    通道的属性改变将同步到物理接口,反之也可;若物理没有全部down,通信依然正常
    同时配置所有物理接口,或直接配置channel口,均可修改接口的属性。

    3、三层Channel配置:

    先将所有物理接口修改为三层,然后在port接口上配置IP地址。

    sw1(config)#interface range e0/0 -1
    sw1(config-if-range)#no switchport   
    
    sw1(config-if-range)#channel-group 1 mode on
    
    sw1(config)#interface port-channel 1 
    sw1(config-if)#ip address 192.168.1.1 255.255.255.0
    
    Switch(config)#ip routing
    

    (1)负载分担:
    二层通道基于不同的源MAC地址或不同的目标MAC地址对流量进行负载分担。默认基于源MAC地址,不管源是谁,访问一些流量一条线,另一些流量走另外一条线。

    基于源区分比较合理,建议不要修改。
    在这里插入图片描述
    (2)负载均衡:
    三层通道基于负载均衡来转发流量。
    在这里插入图片描述

    四、数据交换方式:

    数据交换方式,实际上就是数据路由方式。

    1、原始式:

    这种原始式数据交换方式会让设备查两张表,每一个流量都会查两张表:路由表+ARP表,延时会很高。
    在这里插入图片描述

    2、网流式(传统式):

    之后经过几年的发展,原始式开始淘汰,出现了传统的数据交换方式:网流式。用八个字进行概括:一次路由、多次交换,使用的是Cache表,该技术广泛用于三层交换机中。

    这种网流式是现在很多的公有厂商的默认转发方法。
    在这里插入图片描述
    三层交换在完成对收到的第一个新数据流进行路由后,产生一个MAC地址与IP地址的映射表,当具有相同地址信息的数据流再次通过时,即根据此表直接在二层完成转发,即“一次路由,多次交换”,有效提高了数据包转发的效率。

    3、CEF(快速交换):

    CEF的查表方式是目前最好的路由器的数据交换方式,它是Cisco私有的。无需路由、直接交换,一直只有一张表。

    正常路由器是有路由表和ARP表的,而使用了这种技术,会将路由表转成FIB表,将 ARP表转成ADJ 邻居表

    FIB表:转发信息数据库,二进制表格,解决了递归看IP,直接寻找出接口。

    ADJ表:该表记录了访问某个网段时特定地 源、目MAC

    当上面两张表合在一起之后:就会变成:
    目标IP、出接口、源MAC、目MAC

    Cisco 的设备默认CEF功能都在打开着。

    SW1(config)#ip cef
    

    注意:CEF适合用于局域网,但不适合用于广域网。CEF技术不支持负载均衡,因为它的出接口是一个,即便路由表显示为负载均衡,但实际的CEF下的流量仅延一条路径传输。

    五、网关冗余:

    网关冗余就是备份网关,为什么需要备份网关呢?它的意义在于当一边的设备瘫痪后,另一边的网关可以接替原来的网关继续流量的转发

    所有的冗余协议,若在多层交换机上配置,且使用SVI虚接口作为网关接口,那么命令必须全部到SVI接口上配置。

    1、早期的网关冗余:

    早期使用代理ARP和ICMP重定向来实现网关冗余。这里使用下面这个图作为讲解:
    在这里插入图片描述
    将上面的协议运行EIGRP,模拟Win98PC的路由器R1,只配置一个接口IP,然后关闭路由功能。

    接着让它去pingR3的环回,我们发现很奇怪,R1没有网关竟然可以ping通R3的环回。
    在这里插入图片描述
    为什么可以ping 通R3的环回呢?这就是最原始的网关冗余思路:由于R1既没有去往R3环回的路由,也找不到网关。因此R1会发送ARP请求:询问3.3.3.3的MAC。该请求一出来就会遇到R2、R4这两个路由器。

    由于路由器具有代理ARP的功能,这两台路由器收到请求之后查看自己的路由表,发现存在去往3.3.3.3的路由,它们都会积极的将自己的MAC代理为2.2.2.2的MAC去回复R1,R1最终会从中选择一个,这样就可以ping通R3的环回了。

    当这张图中的R2、R3之间的链路(上行链路)断了的时候,比如下面这样:
    在这里插入图片描述
    此时EIGRP会重新收敛,R1会把流量给R2,R2又把流量甩给R4,R4在把访问R3。由于路由器具有ICMP重定向的功能:

    当流量从R2 e0/0 口进去,然后又从R2 的e0/0口出去。证明R2不是最佳下一跳,R2会让R1去找R4,这样网关冗余就成功了。

    如果断开的下行链路,R1一直访问不到R2,2个小时arp表刷新,R1重新发送ARP,R4进行代理。

    总结一下就是:早期使用ARP、ICMP重定向来实现网关冗余,若上行链路不可达,随着路由协议重新收敛,ICMP重定向生效,在一定时间内可以完成网关的切换,若下行链路不可达,那必须等到ARP表刷新的时间(2h)之后重新新发送ARP请求。

    可以修改ARP请求的时间,但是比较鸡肋不推荐:

    R1(config)#int e0/0
    R1(config-if)#arp timeout ?
      <0-2147483>  Seconds
    

    Win 98系统以下在不知道网关IP的情况下会自动发出ARP请求,但以上系统将不发包。以上系统填写网关地址为直接广播地址(主机位全1),可以使系统发出ARP请求。

    2、HSRP:

    由于上述技术并不是真正用到了冗余,而是利用了一下代理ARP、ICMP重定向。在这种背景下,Cisco提出了HSRP网关冗余技术。

    HSRP:热备份冗余协议特点:切换速度快,可以使网关的IP和MAC地址不用变化,网关的切换对主机是透明的,可以实施上行链路追踪。
    (1)原理:
    ①首先两台路由器用HSRP发hello包建邻,它们共同管理着它们虚拟出来的IP 10.254(为了讲解引用,该IP也可以是三层交换机上虚拟出来的网关IP)。

    ②这两台路由器之间会分主次,将最好的根网桥、网关放在好的一端,我们暂且可以理解为主的第二地址。

    ③当PC上网的时候,它会向网关要MAC,发送ARP请求后,住的会把虚拟的MAC给该PC,然后交换机之后便找它上网。

    ④若主设备瘫痪,两路由器之间HSRP的Hello包将会断开,次设备会知道主设备已凉,然后它会用该虚拟的MAC为源MAC发一个包给交换机,然后下次传输数据时就会走次设备。(虽然交换机发现接收MAC地址的接口发生了转变,但是电脑不知道)

    这样就实现了网关冗余。

    (2)原理细化:
    hello time 3s、hold time 10s,组播地址:224.0.0.2,TTL=1

    关系 名称 优先级
    Forwarding 路由器就是Active 路由器 优先级高(默认100)、真实物理接口IP地址最大
    standy 路由器

    上面虚拟出来的MAC地址是下面这部分值,0000.0c段它是被Cisco买断的,07.ac用于HSRP协议,后面的256位作为组。
    在这里插入图片描述
    (3)配置:
    这里还是使用之前的路由器说事,为PC指定网关 124.1.1.254,两台路由器均配置。

    1、R2#show standby
    
    2、R2、R4都要敲
    R2(config)#int e0/0
    R2(config-if)#standby 1 ip 124.1.1.254
    
    R4(config)#int e0/0
    R4(config-if)#standby 1 ip 124.1.1.254
    
    3、
    优先级修改: 修改优先级,默认100(改的比100大就可以当老大)
    R2(config-if)#standby 1 priority ?  
      <0-255>  Priority value
    
    4R2(config-if)#standby 1 preempt  开启抢占
    

    (4)上行链路追踪 :
    如果我们下行链路断开之后:没关系,我们有网关冗余,可以走另一条路。但是上行链路断开之后,假设R1继续访问R2,就会和之前的原理类似,使用ICMP重定向。

    但是问题来了,ICMP重定向会重定向到一个真实的IP,而我们却使用的是虚拟的IP。它的网关将不会切换,流量会一直沿图中的方向走
    在这里插入图片描述
    因此当上行链路Down时,网关将不会切换。

    解决方法:定义上行链路追踪:
    该配置必须在抢占开启的情况下生效,且两台设备间的优先级差值小于下调值

    定义追踪表1,追踪接口为S1/0口(引用上面网关冗余的图)
    R2(config)#int e0/0
    R2(config-if)#standby 1 track serial 1/0 ?
      <1-255>  Decrement value
    

    意思就是说,如果被追踪的接口(S1/0口)Down了本地(R2)默认将自动将本地优先级减10,减10后的优先级就没有对端好了,对端开启抢占后,就可以成为网关了。

    (5)总结:

    缺点
    HSRP 1、收敛速度慢(hello time 3s、hold time 10s)
    2、只能两台设备
    3、抢占默认关闭
    4、Cisco私有

    3、VRRP:

    VRRP:虚拟路由冗余协议
    (1)特点:
    VRRP:公有协议,3hold time、N台设备,抢占开启。

    VRRP在一个组内可以存在多台3层设备,存在一个master、多个backup,正常产生一个虚拟IP(可以为真实接口IP)和一个虚拟MAC。

    默认每1S来检测一次master是否活动

    只有master发出hello包,其它人(backup)只检测master是否存活,master组播地址:224.0.0.18、TTL=1,hold time 3s

    选举规则:先优先级(默认100,越大越好),再比接口IP地址(越大越好)。

    (2)注意事项:

    这是正常情况下的网关和虚拟MAC同属于一个路由器:
    在这里插入图片描述
    如果网关和虚拟MAC不在同一个路由器上:
    在这里插入图片描述
    所以如果你决定,用真实的IP地址作为虚拟的IP地址的时候,就必须保证,最开始的主(提供虚拟MAC)和要访问的真实IP在同一设备上。就向第一张图一样。

    官方一点:若使用某个接口的真实ip地址作为虚拟网关ip地址,那么依然使用虚拟的MAC地址。
    当真实IP地址所在接口未down之前,其他设备不能作为master,否则将可能出现错误的ARP应答,导致选路不佳。故该地址所在的接口优先级为255。

    开启VRRP网关冗余:R2、R4都需要配置:
    R2(config)#int e0/0
    R2(config-if)#vrrp 1 ip 134.1.1.254
    
    修改优先级
    R2(config-if)#vrrp 1 priority 110
    
    R2#show vrrp brief
    

    (3)上行链路追踪:

    R1(config)#track 1 int s1/0 line-protocol
    
    接口调用:
    R1(config)#int e0/0
    R1(config-if)#vrrp 1 track 1 decrement 156
    				组号		  表号		下调的优先级
    

    之所以下降156是因为担心该设备属于master,它的优先级为255,下降到比默认100小的时候,才可以被别人抢占。
    (4)与HSRP的区别:

    HSRP VRRP
    Cisco私有 公有
    224.0.0.2 224.0.0.18
    两台设备 多台设备
    hello time 3s
    hold time 10s
    hello time 1s
    hold time 3s
    两台设备均发送 hello包 仅Master发送 hello包
    抢占默认关闭 抢占默认开启
    不可使用物理接口的IP地址来作为网关地址 可以使用物理接口的IP地址来作为网关

    4、GLBP:

    GLBP(网关负载均衡协议)其实比较鸡肋,GLBP支持最多四台设备。

    AVG:优先级最大,再ip地址最大。响应所有对网关地址ARP请求后,根据网关设备的数量(最大4个)回应不同MAC给PC;同时将这些MAC分配给对应的AVF。

    3s hello time、10s hold time、224.0.0.102、UDP 3222端口
    AVF:根据AVG分配的MAC地址来转发流量

    AVG抢占关闭
    AVF抢占开启

    (1)原理如下:
    在这里插入图片描述
    (2)鸡肋之处:
    当我们有三层架构时,路由器那么当接入层的设备访问另一台汇聚层的交换机时,流量就会绕着走。
    在这里插入图片描述
    注意:该协议在应用时,考虑到生成树在3层架构中的存在,需要相应的改变拓扑结构。

    (3)配置:

    启动GLBP网关冗余协议:
    R1(config)#int e0/0
    R1(config-if)#glbp 1 ip 134.1.1.254
    

    (4)上行链路追踪:

     R1(config)#track 1 int e1/0 line-protocol
               
    R1(config)#interface e0/0
    R1(config-if)#glbp 1 weighting track 1 decrement 10 
    
    展开全文
  • 文章比较全面地介绍了该芯片的结构和功能特性,给出了它的访问控制方式数据流程,同时给出了用BCM5690设计交换整机的硬件结构和软件实现方法。 关键词:千兆以太网;BCM5690;堆叠;数据流程目前,万兆芯片...
  • 导读:有线和无线通信半导体创新解决方案博通(Broadcom)公司近日宣布推出新款10G多端口以太网交换芯片产品系列,以扩展其行业的StrataConnect交换芯片产品组合。  博通公司的新款单芯片解决方案(SoC)产品系列...
  • 为了满足未来大容量、高速率、...实验结果表明,采用优先级调度算法能在牺牲非实时数据时延的条件下降低实时数据的时延,验证了采用交换以太网的TCN吞吐量远超过现有的TCN,并且能够为今后的设计和优化提供理论依据。
  • 点到点信道:这种信道使用一对一的点对点通信方式。->广播信道:广播信道上的主机很多,需要专用的共享信道协议来协调主机的数据发送。3.1.2 链路与数字链路->链路(link)——是一条点到点的物理线路段,中间...
  • 总结(真理解为主): 数据链路层的功能; 以太网是; 以太网采用什么避免信号的冲突; ...以太网工作原理是;...以太网MAC地址格式;...以太网帧格式;...交换机内部交换方式是3; 交换机2960,3560,4500,65
  • 交换机是一种用于电(光)信号转发的网络设备,它...接下来就由飞畅科技的小编来为大家详细介绍下交换机的交换方式有哪些吧!交换机通过以下三种方式进行交换:1) 直通式:直通方式的以太网交换机可以理解为在各端口...
  • 以太网交换机

    2013-07-08 10:58:00
    以太网交换机是基于以太网传输数据的交换机,以太网采用共享总线型传输媒体方式的局域网。以太网交换机的结构是每个端口都直接与主机相连,并且一般都工作在全双工方式交换机能同时连通许多对端口,使每一对相互...
  • 以太网概述

    2018-05-21 16:06:28
    以太网所处的位置物理层和数据链路层2种以太网经典以太网:3M~10Mbps(不再使用)交换以太网:10M,100M,1GIEEE以太网命名规则10Base2(IEEE 802.3a)"10":传输带宽(单位Mbps)"Base":...
  • 我们知道:以太网访问控制用的是CSMA/CD,即载波侦听多点接入/ 冲突检测,是以广播的方式数据发送到所有端口; 我们还知道:交换机能主动学习端口所接设备的MAC地址,在获知该端口的MAC 地址后,就会把传送给目标...
  • 车载以太网入门

    2020-10-24 17:48:44
    面向车载的以太网 和其他一般的网络一样,只是交换数据的计算机的集合。 车载网络概观 通讯方式
  • 以太网技术

    2018-05-23 18:01:47
    6.3 VLAN在交换机上的配置 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26 6.2 数据帧在不同类型端口之间的转发 . . . . . . . . . . . . . . . . . . . ....
  • 我们知道:以太网访问控制用的是CSMA/CD,即载波侦听多点接入/ 冲突检测,是以广播的方式数据发送到所有端口;  我们还知道:交换机能主动学习端口所接设备的MAC地址,在获知该端口的MAC 地址后,就会把传送给...
  • 计算机网络-扩展以太网

    千次阅读 2020-03-04 16:19:59
    目录1 在物理层扩展以太网1.1 使用光纤扩展1.2 使用集线器扩展2 在数据链路层扩展以太网-网桥2.1 网桥2.1.1 透明网桥3 在数据链路层扩展以太网-交换机3.1 以太网交换机的交换方式3.2 以太网交换机的自学习功能 ...
  • 以太网交换机工作原理

    千次阅读 2017-08-08 20:44:32
    以太网交换机是基于以太网传输数据的交换机,以太网采用共享总线型传输媒体方式的局域网。以太网交换机的结构是每个端口都直接与主机相连,并且一般都工作在全双工方式交换机能同时连通许多对端口,使每一对相互...
  • 项目概述  城市污水处理厂在生态文明建设、节能减排等综合治理中发挥重要作用...工业以太网交换机采用存储转换交换方式,同时提高以太网通信速度,并且内置智能报警设计监控网络运行状况,使得在恶劣危险的工业环境中
  • 以太网交换机是基于以太网传输数据的交换机,以太网采用共享总线型传输媒体方式的局域网。以太网交换机的结构是每个端口都直接与主机相连,并且一般都工作在全双工方式交换机能同时连通许多对端口,使每一对相互...
  • 多接口网桥——以太网交换机

    千次阅读 2016-02-12 11:45:32
    以太网交换机:是基于以太网传输数据的交换机,以太网采用共享总线型传输媒体方式的局域网。 以太网交换机的结构:是每个端口都直接与主机相连,并且一般都工作在全双工方式。 网桥的接口数很少,一般只有2~4个,而...
  • 项目概述  城市污水处理厂在生态文明建设、节能减排等综合治理中发挥重要作用...工业以太网交换机采用存储转换交换方式,同时提高以太网通信速度,并且内置智能报警设计监控网络运行状况,使得在恶劣危险的工业环境中
  • 以太网交换机这个名词相信很多人都听过吧,那么大家知道什么是以太网交换机吗?关于以太网交换机大家又知道多少呢,接下来就由飞畅...交换式集线器常称为以太网交换机(switch)或第二层交换机(表明此交换机工作在数据...
  • 以太网的互联技术也从早期采用专用同轴电缆的总线式网络发展到现在的多层交换机方式。传输和交换的效率和可靠性大为提高。在普通的商用网络中由于交换机性能高,扩展性强等优势,逐渐成为了以太网互联的主流技术,而...
  • 从变电站自动化系统的分层分布式结构及其通信任务和要求出发,分析了目前现场总线技术标准过多,信息交互困难及...最后,指出采用交换式高速以太网,并使节点工作在全双工方式,能满足变电站数据传输的实时性和可靠性要求。
  • 以太网的互联技术也从早期采用专用同轴电缆的总线式网络发展到现在的多层交换机方式。传输和交换的效率和可靠性大为提高。在普通的商用网络中由于交换机性能高,扩展性强等优势,逐渐成为了以太网互联的主流技术,而...
  • 随着互联网技术的发展、普及与推广,以太网技术得到了迅速的发展,其传输速率的提高和交换技术的应用,解决了以太网通信的非确定性问题,使得工业以太网能够广泛应用于工业信息控制领域,也是工业信息控制未来的发展...

空空如也

空空如也

1 2 3 4 5 ... 11
收藏数 209
精华内容 83
关键字:

以太网数据交换方式